HistorianAdapters Namespace

openPDC Synchrophasor Help
HistorianAdapters Namespace
Namespaces ► HistorianAdapters

[Missing <summary> documentation for "N:HistorianAdapters"]

Declaration Syntax
C# Visual Basic Visual C++
namespace HistorianAdapters
Namespace HistorianAdapters
namespace HistorianAdapters
Types
All Types Classes
Icon | Type | Description
 | LocalInputAdapter | Represents an output adapter that publishes measurements to TVA Historian for archival.
 | LocalOutputAdapter | Represents an output adapter that archives measurements to a local archive.
 | RemoteInputAdapter | Represents an input adapters that listens for time-series data from a remote Historian.
 | RemoteOutputAdapter | Represents an output adapter that publishes measurements to TVA Historian for archival.

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.


LocalInputAdapter Class

LocalInputAdapter Class
Namespaces ► HistorianAdapters ► LocalInputAdapter
Represents an output adapter that publishes measurements to TVA Historian for archival.
Declaration Syntax
C# Visual Basic Visual C++
public class LocalInputAdapter : InputAdapterBase
Public Class LocalInputAdapter _
    Inherits InputAdapterBase
public ref class LocalInputAdapter : public InputAdapterBase
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalInputAdapter()()()() | Creates a new instance of the LocalInputAdapter.
 | ArchiveLocation | Gets or sets archive path for this LocalInputAdapter.
 | AssignParentCollection(IAdapterCollection) | (Inherited from AdapterBase.)
 | AttemptConnection()()()() | Attempts to connect to this LocalInputAdapter. (Overrides InputAdapterBase.AttemptConnection()()()().)
 | AttemptDisconnection()()()() | Attempts to disconnect from this LocalInputAdapter. (Overrides InputAdapterBase.AttemptDisconnection()()()().)
 | AutoStart()()()() | (Inherited from AdapterBase.)
 | ConnectionAttemptInterval()()()() | (Inherited from InputAdapterBase.)
 | ConnectionString()()()() | (Inherited from AdapterBase.)
 | DataSource()()()() | (Inherited from AdapterBase.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the LocalInputAdapter object and optionally releases the managed resources. (Overrides InputAdapterBase.Dispose(Boolean).)
 | Dispose()()()() | (Inherited from AdapterBase.)
 | Disposed()()()() | (Inherited from AdapterBase.)
 | Enabled()()()() | (Inherited from AdapterBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | (Inherited from AdapterBase.)
 | GetHashCode()()()() | (Inherited from AdapterBase.)
 | GetShortStatus(Int32) | Gets a short one-line status of this RemoteInputAdapter. (Overrides AdapterBase.GetShortStatus(Int32).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID()()()() | (Inherited from AdapterBase.)
 | IncrementProcessedMeasurements(Int64) | (Inherited from AdapterBase.)
 | InitializationTimeout()()()() | (Inherited from AdapterBase.)
 | Initialize()()()() | Initializes this RemoteInputAdapter. (Overrides InputAdapterBase.Initialize()()()().)
 | Initialized()()()() | (Inherited from AdapterBase.)
 | InputMeasurementKeys()()()() | (Inherited from AdapterBase.)
 | InputMeasurementKeysUpdated()()()() | (Inherited from AdapterBase.)
 | InstanceName | Gets or sets instance name defined for this LocalInputAdapter.
 | IsConnected()()()() | (Inherited from InputAdapterBase.)
 | IsInputMeasurement(MeasurementKey) | (Inherited from AdapterBase.)
 | MeasurementReportingInterval()()()() | (Inherited from AdapterBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()()()() | (Inherited from AdapterBase.)
 | NewMeasurements()()()() | (Inherited from InputAdapterBase.)
 | OnConnected()()()() | (Inherited from InputAdapterBase.)
 | OnDisconnected()()()() | (Inherited from InputAdapterBase.)
 | OnInputMeasurementKeysUpdated()()()() | (Inherited from AdapterBase.)
 | OnNewMeasurements(ICollection<(Of <<'(IMeasurement>)>>)) | (Inherited from InputAdapterBase.)
 | OnOutputMeasurementsUpdated()()()() | (Inherited from AdapterBase.)
 | OnProcessException(Exception) | (Inherited from InputAdapterBase.)
 | OnStatusMessage(String) | (Inherited from AdapterBase.)
 | OnStatusMessage(String, array<Object>[]()[][]) | (Inherited from AdapterBase.)
 | OutputMeasurements()()()() | (Inherited from AdapterBase.)
 | OutputMeasurementsUpdated()()()() | (Inherited from AdapterBase.)
 | OutputSourceIDs()()()() | (Inherited from InputAdapterBase.)
 | Parent()()()() | (Inherited from AdapterBase.)
 | ProcessedMeasurements()()()() | (Inherited from AdapterBase.)
 | ProcessException()()()() | (Inherited from AdapterBase.)
 | ProcessingInterval()()()() | (Inherited from AdapterBase.)
 | ProcessMeasurementFilter()()()() | (Inherited from AdapterBase.)
 | PublicationInterval | Gets or sets the publication interval for this LocalInputAdapter.
 | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Overrides InputAdapterBase.RequestedOutputMeasurementKeys()()()().)
 | RunTime()()()() | (Inherited from AdapterBase.)
 | SetInitializedState(Boolean) | (Inherited from AdapterBase.)
 | SetTemporalConstraint(String, String, String) | (Inherited from AdapterBase.)
 | Settings()()()() | (Inherited from AdapterBase.)
 | Start()()()() | (Inherited from InputAdapterBase.)
 | StartTime()()()() | (Inherited from AdapterBase.)
 | StartTimeConstraint()()()() | (Inherited from AdapterBase.)
 | Status | Returns the detailed status of the data input source. (Overrides InputAdapterBase.Status()()()().)
 | StatusMessage()()()() | (Inherited from AdapterBase.)
 | Stop()()()() | (Inherited from InputAdapterBase.)
 | StopTime()()()() | (Inherited from AdapterBase.)
 | StopTimeConstraint()()()() | (Inherited from AdapterBase.)
 | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Overrides AdapterBase.SupportsTemporalProcessing()()()().)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseAsyncConnect | Gets flag that determines if this LocalInputAdapter uses an asynchronous connection. (Overrides InputAdapterBase.UseAsyncConnect()()()().)
 | WaitForInitialize(Int32) | (Inherited from AdapterBase.)
Inheritance Hierarchy
Object
 | AdapterBase
 |  | InputAdapterBase
 |  |  | LocalInputAdapter

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


LocalInputAdapter Constructor

LocalInputAdapter Constructor
Namespaces ► HistorianAdapters ► LocalInputAdapter ► LocalInputAdapter()()()()
Creates a new instance of the LocalInputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
public LocalInputAdapter()
Public Sub New
public:
LocalInputAdapter()

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


ArchiveLocation Property

ArchiveLocation Property
Namespaces ► HistorianAdapters ► LocalInputAdapter ► ArchiveLocation
Gets or sets archive path for this LocalInputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
[ConnectionStringParameterAttribute]
public string ArchiveLocation { get; set; }
<ConnectionStringParameterAttribute> _
Public Property ArchiveLocation As String
    Get
    Set
[ConnectionStringParameterAttribute]
public:
property String^ ArchiveLocation {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


AttemptConnection Method

AttemptConnection Method
Namespaces ► HistorianAdapters ► LocalInputAdapter ► AttemptConnection()()()()
Attempts to connect to this LocalInputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AttemptConnection()
Protected Overrides Sub AttemptConnection
protected:
virtual void AttemptConnection() override

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


AttemptDisconnection Method

AttemptDisconnection Method
Namespaces ► HistorianAdapters ► LocalInputAdapter ► AttemptDisconnection()()()()
Attempts to disconnect from this LocalInputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AttemptDisconnection()
Protected Overrides Sub AttemptDisconnection
protected:
virtual void AttemptDisconnection() override

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► HistorianAdapters ► LocalInputAdapter ► Dispose(Boolean)
Releases the unmanaged resources used by the LocalInputAdapter object and optionally releases the managed resources.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true to release both managed and unmanaged resources; false to release only unmanaged resources.

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


GetShortStatus Method (maxLength)

GetShortStatus Method (maxLength)
Namespaces ► HistorianAdapters ► LocalInputAdapter ► GetShortStatus(Int32)
Gets a short one-line status of this RemoteInputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
public override string GetShortStatus(
    int maxLength
)
Public Overrides Function GetShortStatus ( _
    maxLength As Integer _
) As String
public:
virtual String^ GetShortStatus(
    int maxLength
) override
Parameters
maxLength (Int32)
Maximum length of the status message.
Return Value
Text of the status message.

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Initialize Method

Initialize Method
Namespaces ► HistorianAdapters ► LocalInputAdapter ► Initialize()()()()
Initializes this RemoteInputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
public override void Initialize()
Public Overrides Sub Initialize
public:
virtual void Initialize() override
Exceptions
Exception | Condition
ArgumentException | HistorianID, Server, Port, Protocol, or InitiateConnection is missing from the Settings()()()().

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


InstanceName Property

InstanceName Property
Namespaces ► HistorianAdapters ► LocalInputAdapter ► InstanceName
Gets or sets instance name defined for this LocalInputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
[ConnectionStringParameterAttribute]
[DefaultValueAttribute("")]
public string InstanceName { get; set; }
<ConnectionStringParameterAttribute> _
<DefaultValueAttribute("")> _
Public Property InstanceName As String
    Get
    Set
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(L"")]
public:
property String^ InstanceName {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


PublicationInterval Property

PublicationInterval Property
Namespaces ► HistorianAdapters ► LocalInputAdapter ► PublicationInterval
Gets or sets the publication interval for this LocalInputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute()]
[ConnectionStringParameterAttribute]
public long PublicationInterval { get; set; }
<DefaultValueAttribute()> _
<ConnectionStringParameterAttribute> _
Public Property PublicationInterval As Long
    Get
    Set
[DefaultValueAttribute()]
[ConnectionStringParameterAttribute]
public:
property long long PublicationInterval {
    long long get ();
    void set (long long value);
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


RequestedOutputMeasurementKeys Property

RequestedOutputMeasurementKeys Property
Namespaces ► HistorianAdapters ► LocalInputAdapter ► RequestedOutputMeasurementKeys
Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.
Declaration Syntax
C# Visual Basic Visual C++
public override MeasurementKey[] RequestedOutputMeasurementKeys { get; set; }
Public Overrides Property RequestedOutputMeasurementKeys As MeasurementKey()
    Get
    Set
public:
virtual property array<MeasurementKey>^ RequestedOutputMeasurementKeys {
    array<MeasurementKey>^ get () override;
    void set (array<MeasurementKey>^ value) override;
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Status Property

Status Property
Namespaces ► HistorianAdapters ► LocalInputAdapter ► Status
Returns the detailed status of the data input source.
Declaration Syntax
C# Visual Basic Visual C++
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
public:
virtual property String^ Status {
    String^ get () override;
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


SupportsTemporalProcessing Property

SupportsTemporalProcessing Property
Namespaces ► HistorianAdapters ► LocalInputAdapter ► SupportsTemporalProcessing
Gets the flag indicating if this adapter supports temporal processing.
Declaration Syntax
C# Visual Basic Visual C++
public override bool SupportsTemporalProcessing { get; }
Public Overrides ReadOnly Property SupportsTemporalProcessing As Boolean
    Get
public:
virtual property bool SupportsTemporalProcessing {
    bool get () override;
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


UseAsyncConnect Property

UseAsyncConnect Property
Namespaces ► HistorianAdapters ► LocalInputAdapter ► UseAsyncConnect
Gets flag that determines if this LocalInputAdapter uses an asynchronous connection.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool UseAsyncConnect { get; }
Protected Overrides ReadOnly Property UseAsyncConnect As Boolean
    Get
protected:
virtual property bool UseAsyncConnect {
    bool get () override;
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


LocalOutputAdapter Class

LocalOutputAdapter Class
Namespaces ► HistorianAdapters ► LocalOutputAdapter
Represents an output adapter that archives measurements to a local archive.
Declaration Syntax
C# Visual Basic Visual C++
public class LocalOutputAdapter : OutputAdapterBase
Public Class LocalOutputAdapter _
    Inherits OutputAdapterBase
public ref class LocalOutputAdapter : public OutputAdapterBase
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalOutputAdapter()()()() | Initializes a new instance of the LocalOutputAdapter class.
 | ArchivePath | Gets or sets the path to the archive.
 | AssignParentCollection(IAdapterCollection) | (Inherited from AdapterBase.)
 | AttemptConnection()()()() | Attempts to connect to this LocalOutputAdapter. (Overrides OutputAdapterBase.AttemptConnection()()()().)
 | AttemptDisconnection()()()() | Attempts to disconnect from this LocalOutputAdapter. (Overrides OutputAdapterBase.AttemptDisconnection()()()().)
 | AutoRefreshMetadata | Gets or sets a boolean indicating whether or not metadata is refreshed when the adapter attempts to connect to the archive.
 | AutoStart()()()() | (Inherited from AdapterBase.)
 | ConnectionAttemptInterval()()()() | (Inherited from OutputAdapterBase.)
 | ConnectionString()()()() | (Inherited from AdapterBase.)
 | DataSource()()()() | (Inherited from AdapterBase.)
 | Dispose(Boolean) | Releases the unmanaged resources used by this LocalOutputAdapter and optionally releases the managed resources. (Overrides OutputAdapterBase.Dispose(Boolean).)
 | Dispose()()()() | (Inherited from AdapterBase.)
 | Disposed()()()() | (Inherited from AdapterBase.)
 | Enabled()()()() | (Inherited from AdapterBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | (Inherited from AdapterBase.)
 | Flush()()()() | (Inherited from OutputAdapterBase.)
 | GetHashCode()()()() | (Inherited from AdapterBase.)
 | GetShortStatus(Int32) | Gets a short one-line status of this LocalOutputAdapter. (Overrides AdapterBase.GetShortStatus(Int32).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID()()()() | (Inherited from AdapterBase.)
 | IncrementProcessedMeasurements(Int64) | (Inherited from AdapterBase.)
 | InitializationTimeout()()()() | (Inherited from AdapterBase.)
 | Initialize()()()() | Initializes this LocalOutputAdapter. (Overrides OutputAdapterBase.Initialize()()()().)
 | Initialized()()()() | (Inherited from AdapterBase.)
 | InputMeasurementKeys()()()() | (Inherited from AdapterBase.)
 | InputMeasurementKeysUpdated()()()() | (Inherited from AdapterBase.)
 | InputSourceIDs()()()() | (Inherited from OutputAdapterBase.)
 | InstanceName | Gets or sets instance name defined for this LocalOutputAdapter.
 | InternalProcessQueue()()()() | (Inherited from OutputAdapterBase.)
 | IsInputMeasurement(MeasurementKey) | (Inherited from AdapterBase.)
 | MeasurementReportingInterval()()()() | (Inherited from AdapterBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()()()() | (Inherited from AdapterBase.)
 | OnConnected()()()() | (Inherited from OutputAdapterBase.)
 | OnDisconnected()()()() | (Inherited from OutputAdapterBase.)
 | OnInputMeasurementKeysUpdated()()()() | (Inherited from AdapterBase.)
 | OnOutputMeasurementsUpdated()()()() | (Inherited from AdapterBase.)
 | OnProcessException(Exception) | (Inherited from OutputAdapterBase.)
 | OnStatusMessage(String) | (Inherited from AdapterBase.)
 | OnStatusMessage(String, array<Object>[]()[][]) | (Inherited from AdapterBase.)
 | OnUnprocessedMeasurements(Int32) | (Inherited from OutputAdapterBase.)
 | OutputIsForArchive | Returns a flag that determines if measurements sent to this LocalOutputAdapter are destined for archival. (Overrides OutputAdapterBase.OutputIsForArchive()()()().)
 | OutputMeasurements()()()() | (Inherited from AdapterBase.)
 | OutputMeasurementsUpdated()()()() | (Inherited from AdapterBase.)
 | Parent()()()() | (Inherited from AdapterBase.)
 | ProcessedMeasurements()()()() | (Inherited from AdapterBase.)
 | ProcessException()()()() | (Inherited from AdapterBase.)
 | ProcessingInterval()()()() | (Inherited from OutputAdapterBase.)
 | ProcessMeasurementFilter()()()() | (Inherited from AdapterBase.)
 | ProcessMeasurements(array<IMeasurement>[]()[][]) | Archives measurements locally. (Overrides OutputAdapterBase.ProcessMeasurements(array<IMeasurement>[]()[][]).)
 | QueueMeasurementForProcessing(IMeasurement) | (Inherited from OutputAdapterBase.)
 | QueueMeasurementsForProcessing(IEnumerable<(Of <<'(IMeasurement>)>>)) | (Inherited from OutputAdapterBase.)
 | RefreshMetadata()()()() | Refreshes metadata using all available and enabled providers. (Overrides OutputAdapterBase.RefreshMetadata()()()().)
 | RemoveMeasurements(Int32) | (Inherited from OutputAdapterBase.)
 | RequestedInputMeasurementKeys()()()() | (Inherited from OutputAdapterBase.)
 | RequeueOnException()()()() | (Inherited from OutputAdapterBase.)
 | RunTime()()()() | (Inherited from AdapterBase.)
 | SetInitializedState(Boolean) | (Inherited from AdapterBase.)
 | SetTemporalConstraint(String, String, String) | (Inherited from AdapterBase.)
 | Settings()()()() | (Inherited from AdapterBase.)
 | Start()()()() | (Inherited from OutputAdapterBase.)
 | StartTime()()()() | (Inherited from AdapterBase.)
 | StartTimeConstraint()()()() | (Inherited from AdapterBase.)
 | Status | Returns the detailed status of the data output source. (Overrides OutputAdapterBase.Status()()()().)
 | StatusMessage()()()() | (Inherited from AdapterBase.)
 | Stop()()()() | (Inherited from OutputAdapterBase.)
 | StopTime()()()() | (Inherited from AdapterBase.)
 | StopTimeConstraint()()()() | (Inherited from AdapterBase.)
 | SupportsTemporalProcessing()()()() | (Inherited from OutputAdapterBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnprocessedMeasurements()()()() | (Inherited from OutputAdapterBase.)
 | UseAsyncConnect | Gets flag that determines if this LocalOutputAdapter uses an asynchronous connection. (Overrides OutputAdapterBase.UseAsyncConnect()()()().)
 | WaitForInitialize(Int32) | (Inherited from AdapterBase.)
Inheritance Hierarchy
Object
 | AdapterBase
 |  | OutputAdapterBase
 |  |  | LocalOutputAdapter

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


LocalOutputAdapter Constructor

LocalOutputAdapter Constructor
Namespaces ► HistorianAdapters ► LocalOutputAdapter ► LocalOutputAdapter()()()()
Initializes a new instance of the LocalOutputAdapter class.
Declaration Syntax
C# Visual Basic Visual C++
public LocalOutputAdapter()
Public Sub New
public:
LocalOutputAdapter()

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


ArchivePath Property

ArchivePath Property
Namespaces ► HistorianAdapters ► LocalOutputAdapter ► ArchivePath
Gets or sets the path to the archive.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute("")]
[ConnectionStringParameterAttribute]
public string ArchivePath { get; set; }
<DefaultValueAttribute("")> _
<ConnectionStringParameterAttribute> _
Public Property ArchivePath As String
    Get
    Set
[DefaultValueAttribute(L"")]
[ConnectionStringParameterAttribute]
public:
property String^ ArchivePath {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


AttemptConnection Method

AttemptConnection Method
Namespaces ► HistorianAdapters ► LocalOutputAdapter ► AttemptConnection()()()()
Attempts to connect to this LocalOutputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AttemptConnection()
Protected Overrides Sub AttemptConnection
protected:
virtual void AttemptConnection() override

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


AttemptDisconnection Method

AttemptDisconnection Method
Namespaces ► HistorianAdapters ► LocalOutputAdapter ► AttemptDisconnection()()()()
Attempts to disconnect from this LocalOutputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AttemptDisconnection()
Protected Overrides Sub AttemptDisconnection
protected:
virtual void AttemptDisconnection() override

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


AutoRefreshMetadata Property

AutoRefreshMetadata Property
Namespaces ► HistorianAdapters ► LocalOutputAdapter ► AutoRefreshMetadata
Gets or sets a boolean indicating whether or not metadata is refreshed when the adapter attempts to connect to the archive.
Declaration Syntax
C# Visual Basic Visual C++
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(true)]
public bool AutoRefreshMetadata { get; set; }
<ConnectionStringParameterAttribute> _
<DefaultValueAttribute(True)> _
Public Property AutoRefreshMetadata As Boolean
    Get
    Set
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(true)]
public:
property bool AutoRefreshMetadata {
    bool get ();
    void set (bool value);
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► HistorianAdapters ► LocalOutputAdapter ► Dispose(Boolean)
Releases the unmanaged resources used by this LocalOutputAdapter and optionally releases the managed resources.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true to release both managed and unmanaged resources; false to release only unmanaged resources.

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


GetShortStatus Method (maxLength)

GetShortStatus Method (maxLength)
Namespaces ► HistorianAdapters ► LocalOutputAdapter ► GetShortStatus(Int32)
Gets a short one-line status of this LocalOutputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
public override string GetShortStatus(
    int maxLength
)
Public Overrides Function GetShortStatus ( _
    maxLength As Integer _
) As String
public:
virtual String^ GetShortStatus(
    int maxLength
) override
Parameters
maxLength (Int32)
Maximum length of the status message.
Return Value
Text of the status message.

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Initialize Method

Initialize Method
Namespaces ► HistorianAdapters ► LocalOutputAdapter ► Initialize()()()()
Initializes this LocalOutputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
public override void Initialize()
Public Overrides Sub Initialize
public:
virtual void Initialize() override
Exceptions
Exception | Condition
ArgumentException | InstanceName is missing from the Settings()()()().

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


InstanceName Property

InstanceName Property
Namespaces ► HistorianAdapters ► LocalOutputAdapter ► InstanceName
Gets or sets instance name defined for this LocalOutputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute("")]
[ConnectionStringParameterAttribute]
public string InstanceName { get; set; }
<DefaultValueAttribute("")> _
<ConnectionStringParameterAttribute> _
Public Property InstanceName As String
    Get
    Set
[DefaultValueAttribute(L"")]
[ConnectionStringParameterAttribute]
public:
property String^ InstanceName {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


OutputIsForArchive Property

OutputIsForArchive Property
Namespaces ► HistorianAdapters ► LocalOutputAdapter ► OutputIsForArchive
Returns a flag that determines if measurements sent to this LocalOutputAdapter are destined for archival.
Declaration Syntax
C# Visual Basic Visual C++
public override bool OutputIsForArchive { get; }
Public Overrides ReadOnly Property OutputIsForArchive As Boolean
    Get
public:
virtual property bool OutputIsForArchive {
    bool get () override;
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


ProcessMeasurements Method (measurements)

ProcessMeasurements Method (measurements)
Namespaces ► HistorianAdapters ► LocalOutputAdapter ► ProcessMeasurements(array<IMeasurement>[]()[][])
Archives measurements locally.
Declaration Syntax
C# Visual Basic Visual C++
protected override void ProcessMeasurements(
    IMeasurement[] measurements
)
Protected Overrides Sub ProcessMeasurements ( _
    measurements As IMeasurement() _
)
protected:
virtual void ProcessMeasurements(
    array<IMeasurement^>^ measurements
) override
Parameters
measurements (array<IMeasurement>[]()[][])
Measurements to be archived.
Exceptions
Exception | Condition
InvalidOperationException | Local archive is closed.

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


RefreshMetadata Method

RefreshMetadata Method
Namespaces ► HistorianAdapters ► LocalOutputAdapter ► RefreshMetadata()()()()
Refreshes metadata using all available and enabled providers.
Declaration Syntax
C# Visual Basic Visual C++
[AdapterCommandAttribute("Refreshes metadata using all available and enabled providers.")]
public override void RefreshMetadata()
<AdapterCommandAttribute("Refreshes metadata using all available and enabled providers.")> _
Public Overrides Sub RefreshMetadata
[AdapterCommandAttribute(L"Refreshes metadata using all available and enabled providers.")]
public:
virtual void RefreshMetadata() override

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Status Property

Status Property
Namespaces ► HistorianAdapters ► LocalOutputAdapter ► Status
Returns the detailed status of the data output source.
Declaration Syntax
C# Visual Basic Visual C++
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
public:
virtual property String^ Status {
    String^ get () override;
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


UseAsyncConnect Property

UseAsyncConnect Property
Namespaces ► HistorianAdapters ► LocalOutputAdapter ► UseAsyncConnect
Gets flag that determines if this LocalOutputAdapter uses an asynchronous connection.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool UseAsyncConnect { get; }
Protected Overrides ReadOnly Property UseAsyncConnect As Boolean
    Get
protected:
virtual property bool UseAsyncConnect {
    bool get () override;
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


RemoteInputAdapter Class

RemoteInputAdapter Class
Namespaces ► HistorianAdapters ► RemoteInputAdapter
Represents an input adapters that listens for time-series data from a remote Historian.
Declaration Syntax
C# Visual Basic Visual C++
public class RemoteInputAdapter : InputAdapterBase
Public Class RemoteInputAdapter _
    Inherits InputAdapterBase
public ref class RemoteInputAdapter : public InputAdapterBase
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RemoteInputAdapter()()()() | Initializes a new instance of the RemoteInputAdapter class.
 | AssignParentCollection(IAdapterCollection) | (Inherited from AdapterBase.)
 | AttemptConnection()()()() | Attempts to connect to this RemoteInputAdapter. (Overrides InputAdapterBase.AttemptConnection()()()().)
 | AttemptDisconnection()()()() | Attempts to disconnect from this RemoteInputAdapter. (Overrides InputAdapterBase.AttemptDisconnection()()()().)
 | AutoStart()()()() | (Inherited from AdapterBase.)
 | ConnectionAttemptInterval()()()() | (Inherited from InputAdapterBase.)
 | ConnectionString()()()() | (Inherited from AdapterBase.)
 | DataSource()()()() | (Inherited from AdapterBase.)
 | Dispose(Boolean) | Releases the unmanaged resources used by this RemoteInputAdapter and optionally releases the managed resources. (Overrides InputAdapterBase.Dispose(Boolean).)
 | Dispose()()()() | (Inherited from AdapterBase.)
 | Disposed()()()() | (Inherited from AdapterBase.)
 | Enabled()()()() | (Inherited from AdapterBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | (Inherited from AdapterBase.)
 | GetHashCode()()()() | (Inherited from AdapterBase.)
 | GetShortStatus(Int32) | Gets a short one-line status of this RemoteInputAdapter. (Overrides AdapterBase.GetShortStatus(Int32).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID()()()() | (Inherited from AdapterBase.)
 | IncrementProcessedMeasurements(Int64) | (Inherited from AdapterBase.)
 | InitializationTimeout()()()() | (Inherited from AdapterBase.)
 | Initialize()()()() | Initializes this RemoteInputAdapter. (Overrides InputAdapterBase.Initialize()()()().)
 | Initialized()()()() | (Inherited from AdapterBase.)
 | InitiateConnection | Gets or sets a value that indicates whether the listener will initiate the connection to the TVA Historian.
 | InputMeasurementKeys()()()() | (Inherited from AdapterBase.)
 | InputMeasurementKeysUpdated()()()() | (Inherited from AdapterBase.)
 | IsConnected()()()() | (Inherited from InputAdapterBase.)
 | IsInputMeasurement(MeasurementKey) | (Inherited from AdapterBase.)
 | MeasurementReportingInterval()()()() | (Inherited from AdapterBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()()()() | (Inherited from AdapterBase.)
 | NewMeasurements()()()() | (Inherited from InputAdapterBase.)
 | OnConnected()()()() | (Inherited from InputAdapterBase.)
 | OnDisconnected()()()() | (Inherited from InputAdapterBase.)
 | OnInputMeasurementKeysUpdated()()()() | (Inherited from AdapterBase.)
 | OnNewMeasurements(ICollection<(Of <<'(IMeasurement>)>>)) | (Inherited from InputAdapterBase.)
 | OnOutputMeasurementsUpdated()()()() | (Inherited from AdapterBase.)
 | OnProcessException(Exception) | (Inherited from InputAdapterBase.)
 | OnStatusMessage(String) | (Inherited from AdapterBase.)
 | OnStatusMessage(String, array<Object>[]()[][]) | (Inherited from AdapterBase.)
 | OutputMeasurements()()()() | (Inherited from AdapterBase.)
 | OutputMeasurementsUpdated()()()() | (Inherited from AdapterBase.)
 | OutputSourceIDs()()()() | (Inherited from InputAdapterBase.)
 | Parent()()()() | (Inherited from AdapterBase.)
 | Port | Gets or sets the port on which the TVA Historian is broadcasting data.
 | ProcessedMeasurements()()()() | (Inherited from AdapterBase.)
 | ProcessException()()()() | (Inherited from AdapterBase.)
 | ProcessingInterval()()()() | (Inherited from AdapterBase.)
 | ProcessMeasurementFilter()()()() | (Inherited from AdapterBase.)
 | Protocol | Gets or sets the type of connection used to connect to the TVA Historian.
 | RequestedOutputMeasurementKeys()()()() | (Inherited from InputAdapterBase.)
 | RunTime()()()() | (Inherited from AdapterBase.)
 | Server | Gets or sets the host name or IP address of the TVA Historian.
 | SetInitializedState(Boolean) | (Inherited from AdapterBase.)
 | SetTemporalConstraint(String, String, String) | (Inherited from AdapterBase.)
 | Settings()()()() | (Inherited from AdapterBase.)
 | Start()()()() | (Inherited from InputAdapterBase.)
 | StartTime()()()() | (Inherited from AdapterBase.)
 | StartTimeConstraint()()()() | (Inherited from AdapterBase.)
 | Status | Returns the detailed status of the data input source. (Overrides InputAdapterBase.Status()()()().)
 | StatusMessage()()()() | (Inherited from AdapterBase.)
 | Stop()()()() | (Inherited from InputAdapterBase.)
 | StopTime()()()() | (Inherited from AdapterBase.)
 | StopTimeConstraint()()()() | (Inherited from AdapterBase.)
 | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Overrides AdapterBase.SupportsTemporalProcessing()()()().)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseAsyncConnect | Gets flag that determines if this RemoteInputAdapter uses an asynchronous connection. (Overrides InputAdapterBase.UseAsyncConnect()()()().)
 | WaitForInitialize(Int32) | (Inherited from AdapterBase.)
Inheritance Hierarchy
Object
 | AdapterBase
 |  | InputAdapterBase
 |  |  | RemoteInputAdapter

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


RemoteInputAdapter Constructor

RemoteInputAdapter Constructor
Namespaces ► HistorianAdapters ► RemoteInputAdapter ► RemoteInputAdapter()()()()
Initializes a new instance of the RemoteInputAdapter class.
Declaration Syntax
C# Visual Basic Visual C++
public RemoteInputAdapter()
Public Sub New
public:
RemoteInputAdapter()

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


AttemptConnection Method

AttemptConnection Method
Namespaces ► HistorianAdapters ► RemoteInputAdapter ► AttemptConnection()()()()
Attempts to connect to this RemoteInputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AttemptConnection()
Protected Overrides Sub AttemptConnection
protected:
virtual void AttemptConnection() override

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


AttemptDisconnection Method

AttemptDisconnection Method
Namespaces ► HistorianAdapters ► RemoteInputAdapter ► AttemptDisconnection()()()()
Attempts to disconnect from this RemoteInputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AttemptDisconnection()
Protected Overrides Sub AttemptDisconnection
protected:
virtual void AttemptDisconnection() override

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► HistorianAdapters ► RemoteInputAdapter ► Dispose(Boolean)
Releases the unmanaged resources used by this RemoteInputAdapter and optionally releases the managed resources.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true to release both managed and unmanaged resources; false to release only unmanaged resources.

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


GetShortStatus Method (maxLength)

GetShortStatus Method (maxLength)
Namespaces ► HistorianAdapters ► RemoteInputAdapter ► GetShortStatus(Int32)
Gets a short one-line status of this RemoteInputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
public override string GetShortStatus(
    int maxLength
)
Public Overrides Function GetShortStatus ( _
    maxLength As Integer _
) As String
public:
virtual String^ GetShortStatus(
    int maxLength
) override
Parameters
maxLength (Int32)
Maximum length of the status message.
Return Value
Text of the status message.

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Initialize Method

Initialize Method
Namespaces ► HistorianAdapters ► RemoteInputAdapter ► Initialize()()()()
Initializes this RemoteInputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
public override void Initialize()
Public Overrides Sub Initialize
public:
virtual void Initialize() override
Exceptions
Exception | Condition
ArgumentException | HistorianID, Server, Port, Protocol, or InitiateConnection is missing from the Settings()()()().

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


InitiateConnection Property

InitiateConnection Property
Namespaces ► HistorianAdapters ► RemoteInputAdapter ► InitiateConnection
Gets or sets a value that indicates whether the listener will initiate the connection to the TVA Historian.
Declaration Syntax
C# Visual Basic Visual C++
[ConnectionStringParameterAttribute]
public bool InitiateConnection { get; set; }
<ConnectionStringParameterAttribute> _
Public Property InitiateConnection As Boolean
    Get
    Set
[ConnectionStringParameterAttribute]
public:
property bool InitiateConnection {
    bool get ();
    void set (bool value);
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Port Property

Port Property
Namespaces ► HistorianAdapters ► RemoteInputAdapter ► Port
Gets or sets the port on which the TVA Historian is broadcasting data.
Declaration Syntax
C# Visual Basic Visual C++
[ConnectionStringParameterAttribute]
public int Port { get; set; }
<ConnectionStringParameterAttribute> _
Public Property Port As Integer
    Get
    Set
[ConnectionStringParameterAttribute]
public:
property int Port {
    int get ();
    void set (int value);
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Protocol Property

Protocol Property
Namespaces ► HistorianAdapters ► RemoteInputAdapter ► Protocol
Gets or sets the type of connection used to connect to the TVA Historian.
Declaration Syntax
C# Visual Basic Visual C++
[ConnectionStringParameterAttribute]
public TransportProtocol Protocol { get; set; }
<ConnectionStringParameterAttribute> _
Public Property Protocol As TransportProtocol
    Get
    Set
[ConnectionStringParameterAttribute]
public:
property TransportProtocol Protocol {
    TransportProtocol get ();
    void set (TransportProtocol value);
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Server Property

Server Property
Namespaces ► HistorianAdapters ► RemoteInputAdapter ► Server
Gets or sets the host name or IP address of the TVA Historian.
Declaration Syntax
C# Visual Basic Visual C++
[ConnectionStringParameterAttribute]
public string Server { get; set; }
<ConnectionStringParameterAttribute> _
Public Property Server As String
    Get
    Set
[ConnectionStringParameterAttribute]
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Status Property

Status Property
Namespaces ► HistorianAdapters ► RemoteInputAdapter ► Status
Returns the detailed status of the data input source.
Declaration Syntax
C# Visual Basic Visual C++
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
public:
virtual property String^ Status {
    String^ get () override;
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


SupportsTemporalProcessing Property

SupportsTemporalProcessing Property
Namespaces ► HistorianAdapters ► RemoteInputAdapter ► SupportsTemporalProcessing
Gets the flag indicating if this adapter supports temporal processing.
Declaration Syntax
C# Visual Basic Visual C++
public override bool SupportsTemporalProcessing { get; }
Public Overrides ReadOnly Property SupportsTemporalProcessing As Boolean
    Get
public:
virtual property bool SupportsTemporalProcessing {
    bool get () override;
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


UseAsyncConnect Property

UseAsyncConnect Property
Namespaces ► HistorianAdapters ► RemoteInputAdapter ► UseAsyncConnect
Gets flag that determines if this RemoteInputAdapter uses an asynchronous connection.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool UseAsyncConnect { get; }
Protected Overrides ReadOnly Property UseAsyncConnect As Boolean
    Get
protected:
virtual property bool UseAsyncConnect {
    bool get () override;
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


RemoteOutputAdapter Class

RemoteOutputAdapter Class
Namespaces ► HistorianAdapters ► RemoteOutputAdapter
Represents an output adapter that publishes measurements to TVA Historian for archival.
Declaration Syntax
C# Visual Basic Visual C++
public class RemoteOutputAdapter : OutputAdapterBase
Public Class RemoteOutputAdapter _
    Inherits OutputAdapterBase
public ref class RemoteOutputAdapter : public OutputAdapterBase
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RemoteOutputAdapter()()()() | Initializes a new instance of the RemoteOutputAdapter class.
 | AssignParentCollection(IAdapterCollection) | (Inherited from AdapterBase.)
 | AttemptConnection()()()() | Attempts to connect to this RemoteOutputAdapter. (Overrides OutputAdapterBase.AttemptConnection()()()().)
 | AttemptDisconnection()()()() | Attempts to disconnect from this RemoteOutputAdapter. (Overrides OutputAdapterBase.AttemptDisconnection()()()().)
 | AutoStart()()()() | (Inherited from AdapterBase.)
 | ConnectionAttemptInterval()()()() | (Inherited from OutputAdapterBase.)
 | ConnectionString()()()() | (Inherited from AdapterBase.)
 | ConserveBandwidth | Gets or sets a boolean value that determines the packet type to be used when sending data to the server.
 | DataSource()()()() | (Inherited from AdapterBase.)
 | Dispose(Boolean) | Releases the unmanaged resources used by this RemoteOutputAdapter and optionally releases the managed resources. (Overrides OutputAdapterBase.Dispose(Boolean).)
 | Dispose()()()() | (Inherited from AdapterBase.)
 | Disposed()()()() | (Inherited from AdapterBase.)
 | Enabled()()()() | (Inherited from AdapterBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | (Inherited from AdapterBase.)
 | Flush()()()() | (Inherited from OutputAdapterBase.)
 | GetHashCode()()()() | (Inherited from AdapterBase.)
 | GetShortStatus(Int32) | Gets a short one-line status of this RemoteOutputAdapter. (Overrides AdapterBase.GetShortStatus(Int32).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID()()()() | (Inherited from AdapterBase.)
 | IncrementProcessedMeasurements(Int64) | (Inherited from AdapterBase.)
 | InitializationTimeout()()()() | (Inherited from AdapterBase.)
 | Initialize()()()() | Initializes this RemoteOutputAdapter. (Overrides OutputAdapterBase.Initialize()()()().)
 | Initialized()()()() | (Inherited from AdapterBase.)
 | InputMeasurementKeys()()()() | (Inherited from AdapterBase.)
 | InputMeasurementKeysUpdated()()()() | (Inherited from AdapterBase.)
 | InputSourceIDs()()()() | (Inherited from OutputAdapterBase.)
 | InternalProcessQueue()()()() | (Inherited from OutputAdapterBase.)
 | IsInputMeasurement(MeasurementKey) | (Inherited from AdapterBase.)
 | MeasurementReportingInterval()()()() | (Inherited from AdapterBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()()()() | (Inherited from AdapterBase.)
 | OnConnected()()()() | (Inherited from OutputAdapterBase.)
 | OnDisconnected()()()() | (Inherited from OutputAdapterBase.)
 | OnInputMeasurementKeysUpdated()()()() | (Inherited from AdapterBase.)
 | OnOutputMeasurementsUpdated()()()() | (Inherited from AdapterBase.)
 | OnProcessException(Exception) | (Inherited from OutputAdapterBase.)
 | OnStatusMessage(String) | (Inherited from AdapterBase.)
 | OnStatusMessage(String, array<Object>[]()[][]) | (Inherited from AdapterBase.)
 | OnUnprocessedMeasurements(Int32) | (Inherited from OutputAdapterBase.)
 | OutputIsForArchive | Returns a flag that determines if measurements sent to this RemoteOutputAdapter are destined for archival. (Overrides OutputAdapterBase.OutputIsForArchive()()()().)
 | OutputMeasurements()()()() | (Inherited from AdapterBase.)
 | OutputMeasurementsUpdated()()()() | (Inherited from AdapterBase.)
 | Parent()()()() | (Inherited from AdapterBase.)
 | PayloadAware | Gets or sets a boolean value indicating whether the payload boundaries are to be preserved during transmission.
 | Port | Gets or sets the port on which the remote historian is listening.
 | ProcessedMeasurements()()()() | (Inherited from AdapterBase.)
 | ProcessException()()()() | (Inherited from AdapterBase.)
 | ProcessingInterval()()()() | (Inherited from OutputAdapterBase.)
 | ProcessMeasurementFilter()()()() | (Inherited from AdapterBase.)
 | ProcessMeasurements(array<IMeasurement>[]()[][]) | Publishes measurements for archival. (Overrides OutputAdapterBase.ProcessMeasurements(array<IMeasurement>[]()[][]).)
 | QueueMeasurementForProcessing(IMeasurement) | (Inherited from OutputAdapterBase.)
 | QueueMeasurementsForProcessing(IEnumerable<(Of <<'(IMeasurement>)>>)) | (Inherited from OutputAdapterBase.)
 | RefreshMetadata()()()() | (Inherited from OutputAdapterBase.)
 | RemoveMeasurements(Int32) | (Inherited from OutputAdapterBase.)
 | RequestedInputMeasurementKeys()()()() | (Inherited from OutputAdapterBase.)
 | RequeueOnException()()()() | (Inherited from OutputAdapterBase.)
 | RunTime()()()() | (Inherited from AdapterBase.)
 | SamplesPerTransmission | Gets or sets an integer that indicates the maximum number of points to be published to the historian at once.
 | Server | Gets or sets the host name for the server hosting the remote historian.
 | SetInitializedState(Boolean) | (Inherited from AdapterBase.)
 | SetTemporalConstraint(String, String, String) | (Inherited from AdapterBase.)
 | Settings()()()() | (Inherited from AdapterBase.)
 | Start()()()() | (Inherited from OutputAdapterBase.)
 | StartTime()()()() | (Inherited from AdapterBase.)
 | StartTimeConstraint()()()() | (Inherited from AdapterBase.)
 | Status | Returns the detailed status of the data output source. (Overrides OutputAdapterBase.Status()()()().)
 | StatusMessage()()()() | (Inherited from AdapterBase.)
 | Stop()()()() | (Inherited from OutputAdapterBase.)
 | StopTime()()()() | (Inherited from AdapterBase.)
 | StopTimeConstraint()()()() | (Inherited from AdapterBase.)
 | SupportsTemporalProcessing()()()() | (Inherited from OutputAdapterBase.)
 | ThrottleTransmission | Gets or sets a boolean value that determines whether to wait for acknowledgement from the historian that the last set of points have been received before attempting to send the next set of points.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnprocessedMeasurements()()()() | (Inherited from OutputAdapterBase.)
 | UseAsyncConnect | Gets flag that determines if this RemoteOutputAdapter uses an asynchronous connection. (Overrides OutputAdapterBase.UseAsyncConnect()()()().)
 | WaitForInitialize(Int32) | (Inherited from AdapterBase.)
Inheritance Hierarchy
Object
 | AdapterBase
 |  | OutputAdapterBase
 |  |  | RemoteOutputAdapter

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


RemoteOutputAdapter Constructor

RemoteOutputAdapter Constructor
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► RemoteOutputAdapter()()()()
Initializes a new instance of the RemoteOutputAdapter class.
Declaration Syntax
C# Visual Basic Visual C++
public RemoteOutputAdapter()
Public Sub New
public:
RemoteOutputAdapter()

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


AttemptConnection Method

AttemptConnection Method
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► AttemptConnection()()()()
Attempts to connect to this RemoteOutputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AttemptConnection()
Protected Overrides Sub AttemptConnection
protected:
virtual void AttemptConnection() override

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


AttemptDisconnection Method

AttemptDisconnection Method
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► AttemptDisconnection()()()()
Attempts to disconnect from this RemoteOutputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AttemptDisconnection()
Protected Overrides Sub AttemptDisconnection
protected:
virtual void AttemptDisconnection() override

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


ConserveBandwidth Property

ConserveBandwidth Property
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► ConserveBandwidth
Gets or sets a boolean value that determines the packet type to be used when sending data to the server.
Declaration Syntax
C# Visual Basic Visual C++
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(true)]
public bool ConserveBandwidth { get; set; }
<ConnectionStringParameterAttribute> _
<DefaultValueAttribute(True)> _
Public Property ConserveBandwidth As Boolean
    Get
    Set
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(true)]
public:
property bool ConserveBandwidth {
    bool get ();
    void set (bool value);
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► Dispose(Boolean)
Releases the unmanaged resources used by this RemoteOutputAdapter and optionally releases the managed resources.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true to release both managed and unmanaged resources; false to release only unmanaged resources.

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


GetShortStatus Method (maxLength)

GetShortStatus Method (maxLength)
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► GetShortStatus(Int32)
Gets a short one-line status of this RemoteOutputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
public override string GetShortStatus(
    int maxLength
)
Public Overrides Function GetShortStatus ( _
    maxLength As Integer _
) As String
public:
virtual String^ GetShortStatus(
    int maxLength
) override
Parameters
maxLength (Int32)
Maximum length of the status message.
Return Value
Text of the status message.

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Initialize Method

Initialize Method
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► Initialize()()()()
Initializes this RemoteOutputAdapter.
Declaration Syntax
C# Visual Basic Visual C++
public override void Initialize()
Public Overrides Sub Initialize
public:
virtual void Initialize() override
Exceptions
Exception | Condition
ArgumentException | Server is missing from the Settings()()()().

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


OutputIsForArchive Property

OutputIsForArchive Property
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► OutputIsForArchive
Returns a flag that determines if measurements sent to this RemoteOutputAdapter are destined for archival.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(true)]
[ConnectionStringParameterAttribute]
public override bool OutputIsForArchive { get; }
<DefaultValueAttribute(True)> _
<ConnectionStringParameterAttribute> _
Public Overrides ReadOnly Property OutputIsForArchive As Boolean
    Get
[DefaultValueAttribute(true)]
[ConnectionStringParameterAttribute]
public:
virtual property bool OutputIsForArchive {
    bool get () override;
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


PayloadAware Property

PayloadAware Property
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► PayloadAware
Gets or sets a boolean value indicating whether the payload boundaries are to be preserved during transmission.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(true)]
[ConnectionStringParameterAttribute]
public bool PayloadAware { get; set; }
<DefaultValueAttribute(True)> _
<ConnectionStringParameterAttribute> _
Public Property PayloadAware As Boolean
    Get
    Set
[DefaultValueAttribute(true)]
[ConnectionStringParameterAttribute]
public:
property bool PayloadAware {
    bool get ();
    void set (bool value);
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Port Property

Port Property
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► Port
Gets or sets the port on which the remote historian is listening.
Declaration Syntax
C# Visual Basic Visual C++
[ConnectionStringParameterAttribute]
[DefaultValueAttribute()]
public int Port { get; set; }
<ConnectionStringParameterAttribute> _
<DefaultValueAttribute()> _
Public Property Port As Integer
    Get
    Set
[ConnectionStringParameterAttribute]
[DefaultValueAttribute()]
public:
property int Port {
    int get ();
    void set (int value);
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


ProcessMeasurements Method (measurements)

ProcessMeasurements Method (measurements)
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► ProcessMeasurements(array<IMeasurement>[]()[][])
Publishes measurements for archival.
Declaration Syntax
C# Visual Basic Visual C++
protected override void ProcessMeasurements(
    IMeasurement[] measurements
)
Protected Overrides Sub ProcessMeasurements ( _
    measurements As IMeasurement() _
)
protected:
virtual void ProcessMeasurements(
    array<IMeasurement^>^ measurements
) override
Parameters
measurements (array<IMeasurement>[]()[][])
Measurements to be archived.
Exceptions
Exception | Condition
OperationCanceledException | Acknowledgement is not received from historian for published data.

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


SamplesPerTransmission Property

SamplesPerTransmission Property
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► SamplesPerTransmission
Gets or sets an integer that indicates the maximum number of points to be published to the historian at once.
Declaration Syntax
C# Visual Basic Visual C++
[ConnectionStringParameterAttribute]
[DefaultValueAttribute()]
public int SamplesPerTransmission { get; set; }
<ConnectionStringParameterAttribute> _
<DefaultValueAttribute()> _
Public Property SamplesPerTransmission As Integer
    Get
    Set
[ConnectionStringParameterAttribute]
[DefaultValueAttribute()]
public:
property int SamplesPerTransmission {
    int get ();
    void set (int value);
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Server Property

Server Property
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► Server
Gets or sets the host name for the server hosting the remote historian.
Declaration Syntax
C# Visual Basic Visual C++
[ConnectionStringParameterAttribute]
public string Server { get; set; }
<ConnectionStringParameterAttribute> _
Public Property Server As String
    Get
    Set
[ConnectionStringParameterAttribute]
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Status Property

Status Property
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► Status
Returns the detailed status of the data output source.
Declaration Syntax
C# Visual Basic Visual C++
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
public:
virtual property String^ Status {
    String^ get () override;
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


ThrottleTransmission Property

ThrottleTransmission Property
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► ThrottleTransmission
Gets or sets a boolean value that determines whether to wait for acknowledgement from the historian that the last set of points have been received before attempting to send the next set of points.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(true)]
[ConnectionStringParameterAttribute]
public bool ThrottleTransmission { get; set; }
<DefaultValueAttribute(True)> _
<ConnectionStringParameterAttribute> _
Public Property ThrottleTransmission As Boolean
    Get
    Set
[DefaultValueAttribute(true)]
[ConnectionStringParameterAttribute]
public:
property bool ThrottleTransmission {
    bool get ();
    void set (bool value);
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


UseAsyncConnect Property

UseAsyncConnect Property
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► UseAsyncConnect
Gets flag that determines if this RemoteOutputAdapter uses an asynchronous connection.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool UseAsyncConnect { get; }
Protected Overrides ReadOnly Property UseAsyncConnect As Boolean
    Get
protected:
virtual property bool UseAsyncConnect {
    bool get () override;
}

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


TVA.PhasorProtocols Namespace

TVA.PhasorProtocols Namespace
Namespaces ► TVA.PhasorProtocols
Contains fundamental classes and interfaces used by all phasor protocol parsing and generating code.
Declaration Syntax
C# Visual Basic Visual C++
namespace TVA.PhasorProtocols
Namespace TVA.PhasorProtocols
namespace TVA.PhasorProtocols
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
 | AnalogDefinitionBase | Represents the common implementation of the protocol independent definition of an IAnalogValue.
 | AnalogDefinitionCollection | Represents a protocol independent collection of IAnalogDefinition objects.
 | AnalogType | Analog types enumeration.
 | AnalogValueBase | Represents the common implementation of the protocol independent representation of an analog value.
 | AnalogValueCollection | Represents a protocol independent collection of IAnalogValue objects.
 | CalculatedMeasurementBase | Represents the base class for calculated measurements that use phasor data.
 | ChannelBase | Represents the common implementation of the protocol independent definition of any kind of data that can be parsed or generated. This is the base class of all parsing/generating classes in the phasor protocols library; it is the root of the parsing/generating class hierarchy.
 | ChannelCellBase | Represents the common implementation of the protocol independent representation of any kind of data cell.
 | ChannelCellCollectionBase<(Of <(<'T>)>)> | Represents a protocol independent collection of IChannelCell objects.
 | ChannelCellParsingStateBase | Represents the protocol independent common implementation of the parsing state used by any IChannelCell.
 | ChannelCollectionBase<(Of <(<'T>)>)> | Represents a protocol independent collection of IChannel objects. This is the base class of all collection classes in the phasor protocols library; it is the root of the collection class hierarchy.
 | ChannelDefinitionBase | Represents the common implementation of the protocol independent definition of any kind of IChannel data.
 | ChannelDefinitionCollectionBase<(Of <(<'T>)>)> | Represents a protocol independent collection of IChannelDefinition objects.
 | ChannelFrameBase<(Of <(<'T>)>)> | Represents the protocol independent common implementation of any frame of data that can be sent or received.
 | ChannelFrameCollectionBase<(Of <(<'T>)>)> | Represents a protocol independent collection of IChannelFrame objects.
 | ChannelFrameParsingStateBase<(Of <(<'T>)>)> | Represents the protocol independent common implementation of the parsing state used by any IChannelFrame.
 | ChannelParsingStateBase | Represents the common implementation of the protocol independent parsing state class used by any kind of data. This is the base class of all parsing state classes in the phasor protocols library; it is the root of the parsing state class hierarchy.
 | ChannelValueBase<(Of <(<'T>)>)> | Represents the common implementation of the protocol independent representation of any kind of data value.
 | ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> | Represents a protocol independent collection of IChannelValue<(Of <(<'T>)>)> objects.
 | ChannelValueMeasurement<(Of <(<'T>)>)> | Represents a IMeasurement implementation for composite values of a given IChannelValue<(Of <(<'T>)>)>.
 | CommandCell | Represents the protocol independent common implementation of an element of extended data for cells in a ICommandFrame.
 | CommandCellCollection | Represents a protocol independent collection of ICommandCell objects.
 | CommandFrameBase | Represents the protocol independent common implementation of any ICommandFrame that can be sent or received.
 | CommandFrameParsingState | Represents the protocol independent common implementation of the parsing state used by any ICommandFrame.
 | Common | Common constants, functions and extensions for phasor classes.
 | CommonPhasorServices | Provides common phasor services.
 | CommonStatusFlags | Protocol independent common status flags enumeration.
 | CompositeFrequencyValue | Composite frequency value indicies enumeration.
 | CompositePhasorValue | Composite polar value indicies enumeration.
 | ConfigurationCellBase | Represents the protocol independent common implementation of all configuration elements for cells in a IConfigurationFrame.
 | ConfigurationCellCollection | Represents a protocol independent collection of IConfigurationCell objects.
 | ConfigurationCellParsingState | Represents the protocol independent common implementation of the parsing state used by any IConfigurationCell.
 | ConfigurationErrorFrame | Represents an implementation of IConfigurationFrame that by existance only denotes an error state.
 | ConfigurationFrameBase | Represents the protocol independent common implementation of any IConfigurationFrame that can be sent or received.
 | ConfigurationFrameCollection | Represents a protocol independent collection of IConfigurationFrame.
 | ConfigurationFrameParsingState | Represents the protocol independent common implementation of the parsing state used by any IConfigurationFrame.
 | ConnectionParametersBase | Represents the common implementation of the protocol independent set of extra connection parameters.
 | CoordinateFormat | Phasor coordinate formats enumeration.
 | CrcException | The exception that is thrown when an object's CRC check fails.
 | CreateNewCellFunction<(Of <(<'T>)>)> | Defines function signature for creating new IChannelCell objects.
 | CreateNewDefinitionFunction<(Of <(<'T>)>)> | Defines function signature for creating new IChannelDefinition objects.
 | CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> | Defines function signature for creating new IChannelValue<(Of <(<'T>)>)> objects.
 | DataCellBase | Represents the protocol independent common implementation of all elements for cells in a IDataFrame.
 | DataCellCollection | Represents a protocol independent collection of IDataCell objects.
 | DataCellParsingState | Represents the protocol independent common implementation of the parsing state used by any IDataCell.
 | DataFormat | Data transmission formats enumeration.
 | DataFrameBase | Represents the protocol independent common implementation of any IDataFrame that can be sent or received.
 | DataFrameCollection | Represents a protocol independent collection of IDataFrame objects.
 | DataFrameParsingState | Represents the protocol independent common implementation of the parsing state used by any IDataFrame.
 | DataSortingType | Data sorting types enumeration.
 | DeviceCommand | Phasor enabled device commands enumeration.
 | DigitalDefinitionBase | Represents the common implementation of the protocol independent definition of a IDigitalValue.
 | DigitalDefinitionCollection | Represents a protocol independent collection of IDigitalDefinition objects.
 | DigitalValueBase | Represents the common implementation of the protocol independent representation of a digital value.
 | DigitalValueCollection | Represents a protocol independent collection of IDigitalValue objects.
 | FrameParserBase<(Of <(<'TFrameIdentifier>)>)> | Represents a frame parser that defines the basic functionality for a protocol to parse a binary data stream and return the parsed data via events.
 | FrequencyDefinitionBase | Represents the common implementation of the protocol independent definition of a IFrequencyValue.
 | FrequencyDefinitionCollection | Represents a protocol independent collection of IFrequencyDefinition objects.
 | FrequencyValueBase | Represents the common implementation of the protocol independent representation of a frequency and df/dt value.
 | FrequencyValueCollection | Represents a protocol independent collection of IFrequencyValue objects.
 | FundamentalFrameType | Fundamental frame types enumeration.
 | HeaderCell | Represents the protocol independent common implementation of an element of header data for cells in a IHeaderFrame.
 | HeaderCellCollection | Represents a protocol independent collection of IHeaderCell objects.
 | HeaderFrameBase | Represents the protocol independent common implementation of any IHeaderFrame that can be sent or received.
 | HeaderFrameParsingState | Represents the protocol independent common implementation of the parsing state used by any IHeaderFrame.
 | IAnalogDefinition | Represents a protocol independent interface representation of a definition of an IAnalogValue.
 | IAnalogValue | Represents a protocol independent interface representation of an analog value.
 | IChannel | Represents a protocol independent interface representation of any data type that can be parsed or generated. This is the base interface implemented by all parsing/generating classes in the phasor protocols library; it is the root of the parsing/generating interface hierarchy.
 | IChannelCell | Represents a protocol independent interface representation of any kind of IChannelFrame cell.
 | IChannelCellCollection<(Of <(<'T>)>)> | Represents a protocol independent interface representation of a collection of IChannelCell objects.
 | IChannelCellParsingState | Represents a protocol independent interface representation of the parsing state of any kind of IChannelCell.
 | IChannelCollection<(Of <(<'T>)>)> | Represents a protocol independent interface representation of a collection of any IChannel objects. This is the base interface implemented by all collections classes in the phasor protocols library; it is the root of the collection interface hierarchy.
 | IChannelDefinition | Represents a protocol independent interface representation of a definition of any kind of IChannel data.
 | IChannelFrame | Represents a protocol independent interface representation of any kind of frame of data that contains a collection of IChannelCell objects.
 | IChannelFrame<(Of <(<'T>)>)> | Represents a strongly-typed protocol independent interface representation of any kind of frame of data that contains a collection of IChannelCell objects.
 | IChannelFrameParsingState<(Of <(<'T>)>)> | Represents a protocol independent interface representation of the parsing state of any kind of IChannelFrame.
 | IChannelParsingState | Represents a protocol independent interface representation of the parsing state used by any kind of IChannel data. This is the base interface implemented by all parsing state classes in the phasor protocols library; it is the root of the parsing state interface hierarchy.
 | IChannelValue<(Of <(<'T>)>)> | Represents a protocol independent interface representation any kind of IChannel data value.
 | ICommandCell | Represents a protocol independent interface representation of any kind of ICommandFrame cell.
 | ICommandFrame | Represents a protocol independent interface representation of any kind of command frame that contains a collection of ICommandCell objects.
 | ICommandFrameParsingState | Represents a protocol independent interface representation of the parsing state of a ICommandFrame.
 | IConfigurationCell | Represents a protocol independent interface representation of any kind of IConfigurationFrame cell.
 | IConfigurationCellParsingState | Represents a protocol independent interface representation of the parsing state of any kind of IConfigurationCell.
 | IConfigurationFrame | Represents a protocol independent interface representation of any kind of configuration frame that contains a collection of IConfigurationCell objects.
 | IConfigurationFrameParsingState | Represents a protocol independent interface representation of the parsing state of a IConfigurationFrame.
 | IConnectionParameters | Represents a protocol independent interface representation of custom connection parameters.
 | IDataCell | Represents a protocol independent interface representation of any kind of IDataFrame cell.
 | IDataCellParsingState | Represents a protocol independent interface representation of the parsing state of any kind of IDataCell.
 | IDataFrame | Represents a protocol independent interface representation of any kind of data frame that contains a collection of IDataCell objects.
 | IDataFrameParsingState | Represents a protocol independent interface representation of the parsing state of a IDataFrame.
 | IDigitalDefinition | Represents a protocol independent interface representation of a definition of a IDigitalValue.
 | IDigitalValue | Represents a protocol independent interface representation of a digital value.
 | IFrameParser | Represents a protocol independent representation of a frame parser.
 | IFrequencyDefinition | Represents a protocol independent interface representation of a definition of a IFrequencyValue.
 | IFrequencyValue | Represents a protocol independent interface of a frequency value.
 | IHeaderCell | Represents a protocol independent interface representation of any kind of IHeaderFrame cell.
 | IHeaderFrame | Represents a protocol independent interface representation of any kind of header frame that contains a collection of IHeaderCell objects.
 | IHeaderFrameParsingState | Represents a protocol independent interface representation of the parsing state of a IHeaderFrame.
 | IPhasorDefinition | Represents a protocol independent interface representation of a definition of a IPhasorValue.
 | IPhasorValue | Represents a protocol independent interface representation of a phasor value.
 | LineFrequency | Nominal line frequencies enumeration.
 | MultiProtocolFrameParser | Protocol independent frame parser.
 | PhasorDataConcentratorBase | Represents an IActionAdapter used to generate and transmit concentrated stream of phasor measurements in a specific phasor protocol.
 | PhasorDefinitionBase | Represents the common implementation of the protocol independent definition of a IPhasorValue.
 | PhasorDefinitionCollection | Represents a protocol independent collection of IPhasorDefinition objects.
 | PhasorMeasurementMapper | Represents an IInputAdapter used to map measured values from a connection to a phasor measurement device to new IMeasurement values.
 | PhasorProtocol | Phasor data protocols enumeration.
 | PhasorType | Phasor types enumeration.
 | PhasorValueBase | Represents the common implementation of the protocol independent representation of a phasor value.
 | PhasorValueCollection | Represents a protocol independent collection of IPhasorValue objects.
 | SignalKind | Fundamental signal types enumeration.
 | SignalReference | Represents a signal that can be referenced by its constituent components.
 | SignalReferenceMeasurement | Represents an IMeasurement wrapper that is associated with a SignalReference.
 | SignalType | Signal type enumeration.
 | StatisticCalculationFunction | Method signature for function used to calculate a statistic for a given object.
 | StatisticsReader | Reads certain device and input stream statistics from the statistics archive. The statistics that are read are the total frame count, the missing frame count, connectivity, average latency, the actual data rate, data quality errors, and time quality errors.


AnalogDefinitionBase Class

AnalogDefinitionBase Class
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionBase
Represents the common implementation of the protocol independent definition of an IAnalogValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class AnalogDefinitionBase : ChannelDefinitionBase,
    IAnalogDefinition, IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IChannelDefinition>, IComparable<IChannelDefinition>, IComparable
<SerializableAttribute> _
Public MustInherit Class AnalogDefinitionBase _
    Inherits ChannelDefinitionBase _
    Implements IAnalogDefinition, IChannelDefinition, IChannel, ISupportBinaryImage,  _
    ISerializable, IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition),  _
    IComparable
[SerializableAttribute]
public ref class AnalogDefinitionBase abstract : public ChannelDefinitionBase,
    IAnalogDefinition, IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IChannelDefinition^>, IComparable<IChannelDefinition^>, IComparable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalogDefinitionBase(IConfigurationCell) | Creates a new AnalogDefinitionBase.
 | AnalogDefinitionBase(IConfigurationCell, String, UInt32, Double, AnalogType) | Creates a new AnalogDefinitionBase from specified parameters.
 | AnalogDefinitionBase(SerializationInfo, StreamingContext) | Creates a new AnalogDefinitionBase from serialization parameters.
 | AnalogType | Gets or sets AnalogType of this AnalogDefinitionBase.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this AnalogDefinitionBase object. (Overrides ChannelDefinitionBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat for the AnalogDefinitionBase. (Overrides ChannelDefinitionBase.DataFormat.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Parent | Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | AnalogDefinitionBase
 |  |  |  |  | AnalogDefinition
 |  |  |  |  | AnalogDefinition
 |  |  |  |  | AnalogDefinition

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: TVA.PhasorProtocols (Module: TVA.PhasorProtocols) Version: 1.4.192.0


AnalogDefinitionBase Constructor

AnalogDefinitionBase Constructor
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionBase ► AnalogDefinitionBase()()()()
Members
Icon | Member | Description
 | AnalogDefinitionBase(IConfigurationCell) | Creates a new AnalogDefinitionBase.
 | AnalogDefinitionBase(IConfigurationCell, String, UInt32, Double, AnalogType) | Creates a new AnalogDefinitionBase from specified parameters.
 | AnalogDefinitionBase(SerializationInfo, StreamingContext) | Creates a new AnalogDefinitionBase from serialization parameters.


AnalogDefinitionBase Constructor (info, context)

AnalogDefinitionBase Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionBase ► AnalogDefinitionBase(SerializationInfo, StreamingContext)
Creates a new AnalogDefinitionBase from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected AnalogDefinitionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
AnalogDefinitionBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


AnalogDefinitionBase Constructor (parent)

AnalogDefinitionBase Constructor (parent)
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionBase ► AnalogDefinitionBase(IConfigurationCell)
Creates a new AnalogDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
protected AnalogDefinitionBase(
    IConfigurationCell parent
)
Protected Sub New ( _
    parent As IConfigurationCell _
)
protected:
AnalogDefinitionBase(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this AnalogDefinitionBase.


AnalogDefinitionBase Constructor (parent, label, scale, offset, type)

AnalogDefinitionBase Constructor (parent, label, scale, offset, type)
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionBase ► AnalogDefinitionBase(IConfigurationCell, String, UInt32, Double, AnalogType)
Creates a new AnalogDefinitionBase from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected AnalogDefinitionBase(
    IConfigurationCell parent,
    string label,
    uint scale,
    double offset,
    AnalogType type
)
Protected Sub New ( _
    parent As IConfigurationCell, _
    label As String, _
    scale As UInteger, _
    offset As Double, _
    type As AnalogType _
)
protected:
AnalogDefinitionBase(
    IConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset,
    AnalogType type
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this AnalogDefinitionBase.
label (String)
The label of this AnalogDefinitionBase.
scale (UInt32)
The integer scaling value of this AnalogDefinitionBase.
offset (Double)
The offset of this AnalogDefinitionBase.
type (AnalogType)
The AnalogType of this AnalogDefinitionBase.


AnalogType Property

AnalogType Property
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionBase ► AnalogType
Gets or sets AnalogType of this AnalogDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual AnalogType AnalogType { get; set; }
Public Overridable Property AnalogType As AnalogType
    Get
    Set
public:
virtual property AnalogType AnalogType {
    AnalogType get ();
    void set (AnalogType value);
}


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionBase ► Attributes
Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this AnalogDefinitionBase object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


DataFormat Property

DataFormat Property
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionBase ► DataFormat
Gets the DataFormat for the AnalogDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat DataFormat { get; }
Public Overrides ReadOnly Property DataFormat As DataFormat
    Get
public:
virtual property DataFormat DataFormat {
    DataFormat get () override;
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


AnalogDefinitionCollection Class

AnalogDefinitionCollection Class
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionCollection
Represents a protocol independent collection of IAnalogDefinition objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class AnalogDefinitionCollection : ChannelDefinitionCollectionBase<IAnalogDefinition>
<SerializableAttribute> _
Public Class AnalogDefinitionCollection _
    Inherits ChannelDefinitionCollectionBase(Of IAnalogDefinition)
[SerializableAttribute]
public ref class AnalogDefinitionCollection : public ChannelDefinitionCollectionBase<IAnalogDefinition^>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalogDefinitionCollection(Int32) | Creates a new AnalogDefinitionCollection using specified lastValidIndex.
 | AnalogDefinitionCollection(SerializationInfo, StreamingContext) | Creates a new AnalogDefinitionCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelDefinitionCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelDefinitionCollectionBase<(Of <(<'T>)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelDefinitionCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelDefinitionCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelDefinitionCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' T >)>)>
 |  | ChannelCollectionBase <(Of <(<' T >)>)>
 |  |  | ChannelDefinitionCollectionBase <(Of <(<' IAnalogDefinition >)>)>
 |  |  |  | AnalogDefinitionCollection


AnalogDefinitionCollection Constructor

AnalogDefinitionCollection Constructor
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionCollection ► AnalogDefinitionCollection()()()()
Members
Icon | Member | Description
 | AnalogDefinitionCollection(Int32) | Creates a new AnalogDefinitionCollection using specified lastValidIndex.
 | AnalogDefinitionCollection(SerializationInfo, StreamingContext) | Creates a new AnalogDefinitionCollection from serialization parameters.


AnalogDefinitionCollection Constructor (lastValidIndex)

AnalogDefinitionCollection Constructor (lastValidIndex)
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionCollection ► AnalogDefinitionCollection(Int32)
Creates a new AnalogDefinitionCollection using specified lastValidIndex.
Declaration Syntax
C# Visual Basic Visual C++
public AnalogDefinitionCollection(
    int lastValidIndex
)
Public Sub New ( _
    lastValidIndex As Integer _
)
public:
AnalogDefinitionCollection(
    int lastValidIndex
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


AnalogDefinitionCollection Constructor (info, context)

AnalogDefinitionCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionCollection ► AnalogDefinitionCollection(SerializationInfo, StreamingContext)
Creates a new AnalogDefinitionCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected AnalogDefinitionCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
AnalogDefinitionCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


AnalogType Enumeration

AnalogType Enumeration
Namespaces ► TVA.PhasorProtocols ► AnalogType
Analog types enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum AnalogType
<SerializableAttribute> _
Public Enumeration AnalogType
[SerializableAttribute]
public enum class AnalogType
Members
Member | Description
SinglePointOnWave | Single point-on-wave.
RmsOfAnalogInput | RMS of analog input.
PeakOfAnalogInput | Peak of analog input.


AnalogValueBase Class

AnalogValueBase Class
Namespaces ► TVA.PhasorProtocols ► AnalogValueBase
Represents the common implementation of the protocol independent representation of an analog value.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class AnalogValueBase : ChannelValueBase<IAnalogDefinition>,
    IAnalogValue, IChannelValue<IAnalogDefinition>, IChannel, ISupportBinaryImage,
    ISerializable
<SerializableAttribute> _
Public MustInherit Class AnalogValueBase _
    Inherits ChannelValueBase(Of IAnalogDefinition) _
    Implements IAnalogValue, IChannelValue(Of IAnalogDefinition),  _
    IChannel, ISupportBinaryImage, ISerializable
[SerializableAttribute]
public ref class AnalogValueBase abstract : public ChannelValueBase<IAnalogDefinition^>,
    IAnalogValue, IChannelValue<IAnalogDefinition^>, IChannel, ISupportBinaryImage,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalogValueBase(IDataCell, IAnalogDefinition) | Creates a new AnalogValueBase.
 | AnalogValueBase(IDataCell, IAnalogDefinition, Double) | Creates a new AnalogValueBase from specified parameters.
 | AnalogValueBase(SerializationInfo, StreamingContext) | Creates a new AnalogValueBase from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the AnalogValueBase object. (Overrides ChannelValueBase <(Of <(<' IAnalogDefinition >)>)>.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the AnalogValueBase object. (Overrides BinaryImageBase.BodyImage()()()().)
 | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBase.BodyLength()()()().)
 | CompositeValueCount | Gets total number of composite values that this AnalogValueBase provides. (Overrides ChannelValueBase <(Of <(<' IAnalogDefinition >)>)>.CompositeValueCount.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the IChannelDefinition associated with this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this AnalogValueBase. (Overrides ChannelValueBase <(Of <(<' IAnalogDefinition >)>)>.GetCompositeValue(Int32).)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelValueBase <(Of <(<' IAnalogDefinition >)>)>.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IntegerValue | Gets or sets the integer representation of this AnalogValueBase value.
 | IsEmpty | Gets boolean value that determines if none of the composite values of AnalogValueBase have been assigned a value. (Overrides ChannelValueBase <(Of <(<' IAnalogDefinition >)>)>.IsEmpty.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the IDataCell parent of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides BinaryImageBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets the floating point value that represents this AnalogValueBase.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IAnalogDefinition >)>)>
 |  |  |  | AnalogValueBase
 |  |  |  |  | AnalogValue
 |  |  |  |  | AnalogValue


AnalogValueBase Constructor

AnalogValueBase Constructor
Namespaces ► TVA.PhasorProtocols ► AnalogValueBase ► AnalogValueBase()()()()
Members
Icon | Member | Description
 | AnalogValueBase(IDataCell, IAnalogDefinition) | Creates a new AnalogValueBase.
 | AnalogValueBase(IDataCell, IAnalogDefinition, Double) | Creates a new AnalogValueBase from specified parameters.
 | AnalogValueBase(SerializationInfo, StreamingContext) | Creates a new AnalogValueBase from serialization parameters.


AnalogValueBase Constructor (info, context)

AnalogValueBase Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► AnalogValueBase ► AnalogValueBase(SerializationInfo, StreamingContext)
Creates a new AnalogValueBase from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected AnalogValueBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
AnalogValueBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


AnalogValueBase Constructor (parent, analogDefinition)

AnalogValueBase Constructor (parent, analogDefinition)
Namespaces ► TVA.PhasorProtocols ► AnalogValueBase ► AnalogValueBase(IDataCell, IAnalogDefinition)
Creates a new AnalogValueBase.
Declaration Syntax
C# Visual Basic Visual C++
protected AnalogValueBase(
    IDataCell parent,
    IAnalogDefinition analogDefinition
)
Protected Sub New ( _
    parent As IDataCell, _
    analogDefinition As IAnalogDefinition _
)
protected:
AnalogValueBase(
    IDataCell^ parent,
    IAnalogDefinition^ analogDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this AnalogValueBase.
analogDefinition (IAnalogDefinition)
The IAnalogDefinition associated with this AnalogValueBase.


AnalogValueBase Constructor (parent, analogDefinition, value)

AnalogValueBase Constructor (parent, analogDefinition, value)
Namespaces ► TVA.PhasorProtocols ► AnalogValueBase ► AnalogValueBase(IDataCell, IAnalogDefinition, Double)
Creates a new AnalogValueBase from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected AnalogValueBase(
    IDataCell parent,
    IAnalogDefinition analogDefinition,
    double value
)
Protected Sub New ( _
    parent As IDataCell, _
    analogDefinition As IAnalogDefinition, _
    value As Double _
)
protected:
AnalogValueBase(
    IDataCell^ parent,
    IAnalogDefinition^ analogDefinition,
    double value
)
Parameters
parent (IDataCell)
The IDataCell parent of this AnalogValueBase.
analogDefinition (IAnalogDefinition)
The IAnalogDefinition associated with this AnalogValueBase.
value (Double)
The floating point value that represents this AnalogValueBase.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► AnalogValueBase ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the AnalogValueBase object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols ► AnalogValueBase ► BodyImage
Gets the binary body image of the AnalogValueBase object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols ► AnalogValueBase ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).


CompositeValueCount Property

CompositeValueCount Property
Namespaces ► TVA.PhasorProtocols ► AnalogValueBase ► CompositeValueCount
Gets total number of composite values that this AnalogValueBase provides.
Declaration Syntax
C# Visual Basic Visual C++
public override int CompositeValueCount { get; }
Public Overrides ReadOnly Property CompositeValueCount As Integer
    Get
public:
virtual property int CompositeValueCount {
    int get () override;
}


GetCompositeValue Method (index)

GetCompositeValue Method (index)
Namespaces ► TVA.PhasorProtocols ► AnalogValueBase ► GetCompositeValue(Int32)
Gets the specified composite value of this AnalogValueBase.
Declaration Syntax
C# Visual Basic Visual C++
public override double GetCompositeValue(
    int index
)
Public Overrides Function GetCompositeValue ( _
    index As Integer _
) As Double
public:
virtual double GetCompositeValue(
    int index
) override
Parameters
index (Int32)
Index of composite value to retrieve.
Return Value
A composite value as Double.
Remarks
Some ChannelValueBase<(Of <(<'T>)>)> implementations can contain more than one value, this method is used to abstractly expose each value.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► AnalogValueBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


IntegerValue Property

IntegerValue Property
Namespaces ► TVA.PhasorProtocols ► AnalogValueBase ► IntegerValue
Gets or sets the integer representation of this AnalogValueBase value.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int IntegerValue { get; set; }
Public Overridable Property IntegerValue As Integer
    Get
    Set
public:
virtual property int IntegerValue {
    int get ();
    void set (int value);
}


IsEmpty Property

IsEmpty Property
Namespaces ► TVA.PhasorProtocols ► AnalogValueBase ► IsEmpty
Gets boolean value that determines if none of the composite values of AnalogValueBase have been assigned a value.
Declaration Syntax
C# Visual Basic Visual C++
public override bool IsEmpty { get; }
Public Overrides ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get () override;
}
Return Value
True, if no composite values have been assigned a value; otherwise, false.


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols ► AnalogValueBase ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).


Value Property

Value Property
Namespaces ► TVA.PhasorProtocols ► AnalogValueBase ► Value
Gets or sets the floating point value that represents this AnalogValueBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Value { get; set; }
Public Overridable Property Value As Double
    Get
    Set
public:
virtual property double Value {
    double get ();
    void set (double value);
}


AnalogValueCollection Class

AnalogValueCollection Class
Namespaces ► TVA.PhasorProtocols ► AnalogValueCollection
Represents a protocol independent collection of IAnalogValue objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class AnalogValueCollection : ChannelValueCollectionBase<IAnalogDefinition, IAnalogValue>
<SerializableAttribute> _
Public Class AnalogValueCollection _
    Inherits ChannelValueCollectionBase(Of IAnalogDefinition, IAnalogValue)
[SerializableAttribute]
public ref class AnalogValueCollection : public ChannelValueCollectionBase<IAnalogDefinition^, IAnalogValue^>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalogValueCollection(Int32) | Creates a new AnalogValueCollection using specified lastValidIndex.
 | AnalogValueCollection(SerializationInfo, StreamingContext) | Creates a new AnalogValueCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IAnalogValue >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | AllValuesAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> object. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IAnalogValue >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IAnalogValue >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IAnalogValue >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IAnalogValue >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IAnalogValue >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IAnalogValue >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IAnalogValue >)>)>.)
 | InsertItem(Int32, TValue) | Inserts an element into the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> at the specified index. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' IAnalogValue >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IAnalogValue >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IAnalogValue >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IAnalogValue >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | SetItem(Int32, TValue) | Replaces the element at the specified index. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IAnalogValue >)>)>
 |  | ChannelCollectionBase <(Of <(<' IAnalogValue >)>)>
 |  |  | ChannelValueCollectionBase <(Of <(<' IAnalogDefinition, IAnalogValue >)>)>
 |  |  |  | AnalogValueCollection


AnalogValueCollection Constructor

AnalogValueCollection Constructor
Namespaces ► TVA.PhasorProtocols ► AnalogValueCollection ► AnalogValueCollection()()()()
Members
Icon | Member | Description
 | AnalogValueCollection(Int32) | Creates a new AnalogValueCollection using specified lastValidIndex.
 | AnalogValueCollection(SerializationInfo, StreamingContext) | Creates a new AnalogValueCollection from serialization parameters.


AnalogValueCollection Constructor (lastValidIndex)

AnalogValueCollection Constructor (lastValidIndex)
Namespaces ► TVA.PhasorProtocols ► AnalogValueCollection ► AnalogValueCollection(Int32)
Creates a new AnalogValueCollection using specified lastValidIndex.
Declaration Syntax
C# Visual Basic Visual C++
public AnalogValueCollection(
    int lastValidIndex
)
Public Sub New ( _
    lastValidIndex As Integer _
)
public:
AnalogValueCollection(
    int lastValidIndex
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


AnalogValueCollection Constructor (info, context)

AnalogValueCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► AnalogValueCollection ► AnalogValueCollection(SerializationInfo, StreamingContext)
Creates a new AnalogValueCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected AnalogValueCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
AnalogValueCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


CalculatedMeasurementBase Class

CalculatedMeasurementBase Class
Namespaces ► TVA.PhasorProtocols ► CalculatedMeasurementBase
Represents the base class for calculated measurements that use phasor data.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class CalculatedMeasurementBase : ActionAdapterBase
Public MustInherit Class CalculatedMeasurementBase _
    Inherits ActionAdapterBase
public ref class CalculatedMeasurementBase abstract : public ActionAdapterBase
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CalculatedMeasurementBase()()()() | Initializes a new instance of the CalculatedMeasurementBase class
 | AllowPreemptivePublishing()()()() | (Inherited from ConcentratorBase.)
 | AllowSortsByArrival()()()() | (Inherited from ConcentratorBase.)
 | AssignMeasurementToFrame(IFrame, IMeasurement) | (Inherited from ConcentratorBase.)
 | AssignParentCollection(IAdapterCollection) | (Inherited from ActionAdapterBase.)
 | AutoStart()()()() | (Inherited from ActionAdapterBase.)
 | AveragePublicationTimePerFrame()()()() | (Inherited from ConcentratorBase.)
 | ConfigurationSection | Gets or sets the configuration section to use for this CalculatedMeasurementBase.
 | ConnectionString()()()() | (Inherited from ActionAdapterBase.)
 | CreateNewFrame(Ticks) | (Inherited from ConcentratorBase.)
 | DataSource()()()() | (Inherited from ActionAdapterBase.)
 | DiscardedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | DiscardingMeasurements()()()() | (Inherited from ConcentratorBase.)
 | Dispose(Boolean) | (Inherited from ActionAdapterBase.)
 | Dispose()()()() | (Inherited from ConcentratorBase.)
 | Disposed()()()() | (Inherited from ConcentratorBase.)
 | DownsampledMeasurements()()()() | (Inherited from ConcentratorBase.)
 | DownsamplingMethod()()()() | (Inherited from ConcentratorBase.)
 | Enabled()()()() | (Inherited from ConcentratorBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExamineQueueState()()()() | (Inherited from ActionAdapterBase.)
 | ExpectedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | Finalize()()()() | (Inherited from ConcentratorBase.)
 | FramesAheadOfSchedule()()()() | (Inherited from ConcentratorBase.)
 | FramesPerSecond()()()() | (Inherited from ConcentratorBase.)
 | GetHashCode()()()() | (Inherited from ActionAdapterBase.)
 | GetShortStatus(Int32) | (Inherited from ActionAdapterBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID()()()() | (Inherited from ActionAdapterBase.)
 | IgnoreBadTimestamps()()()() | (Inherited from ConcentratorBase.)
 | InitializationTimeout()()()() | (Inherited from ActionAdapterBase.)
 | Initialize()()()() | Intializes CalculatedMeasurementBase. (Overrides ActionAdapterBase.Initialize()()()().)
 | Initialized()()()() | (Inherited from ActionAdapterBase.)
 | InputMeasurementKeys | Gets or sets primary keys of input measurements the calculated measurement expects. (Overrides ActionAdapterBase.InputMeasurementKeys()()()().)
 | InputMeasurementKeysUpdated()()()() | (Inherited from ActionAdapterBase.)
 | InputMeasurementKeyTypes | Gets or sets input measurement SignalType's for each of the InputMeasurementKeys()()()(), if any.
 | InputSourceIDs()()()() | (Inherited from ActionAdapterBase.)
 | IsInputMeasurement(MeasurementKey) | (Inherited from ActionAdapterBase.)
 | LagTicks()()()() | (Inherited from ConcentratorBase.)
 | LagTime()()()() | (Inherited from ConcentratorBase.)
 | LastDiscardedMeasurement()()()() | (Inherited from ConcentratorBase.)
 | LastDiscardedMeasurementLatency()()()() | (Inherited from ConcentratorBase.)
 | LastFrame()()()() | (Inherited from ConcentratorBase.)
 | LatestMeasurements()()()() | (Inherited from ConcentratorBase.)
 | LeadTime()()()() | (Inherited from ConcentratorBase.)
 | MaximumPublicationTimeout()()()() | (Inherited from ConcentratorBase.)
 | MeasurementsSortedByArrival()()()() | (Inherited from ConcentratorBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MillisecondsFromRealTime(Ticks) | (Inherited from ConcentratorBase.)
 | MinimumMeasurementsToUse()()()() | (Inherited from ActionAdapterBase.)
 | MissedSortsByTimeout()()()() | (Inherited from ConcentratorBase.)
 | Name()()()() | (Inherited from ActionAdapterBase.)
 | NewMeasurements()()()() | (Inherited from ActionAdapterBase.)
 | OnDiscardingMeasurements(IEnumerable<(Of <<'(IMeasurement>)>>)) | (Inherited from ConcentratorBase.)
 | OnInputMeasurementKeysUpdated()()()() | (Inherited from ActionAdapterBase.)
 | OnNewMeasurements(ICollection<(Of <<'(IMeasurement>)>>)) | (Inherited from ActionAdapterBase.)
 | OnOutputMeasurementsUpdated()()()() | (Inherited from ActionAdapterBase.)
 | OnProcessException(Exception) | (Inherited from ConcentratorBase.)
 | OnStatusMessage(String) | (Inherited from ActionAdapterBase.)
 | OnStatusMessage(String, array<Object>[]()[][]) | (Inherited from ActionAdapterBase.)
 | OnUnpublishedSamples(Int32) | (Inherited from ConcentratorBase.)
 | OutputMeasurements | Gets or sets output measurements that the calculated measurement will produce, if any. (Overrides ActionAdapterBase.OutputMeasurements()()()().)
 | OutputMeasurementsUpdated()()()() | (Inherited from ActionAdapterBase.)
 | OutputMeasurementTypes | Gets or sets output measurement SignalType's for each of the OutputMeasurements()()()(), if any.
 | OutputSourceIDs()()()() | (Inherited from ActionAdapterBase.)
 | Parent()()()() | (Inherited from ActionAdapterBase.)
 | PerformTimestampReasonabilityCheck()()()() | (Inherited from ConcentratorBase.)
 | ProcessByReceivedTimestamp()()()() | (Inherited from ConcentratorBase.)
 | ProcessedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | ProcessException()()()() | (Inherited from ConcentratorBase.)
 | ProcessingInterval()()()() | (Inherited from ConcentratorBase.)
 | ProcessMeasurementFilter()()()() | (Inherited from ActionAdapterBase.)
 | PublishedFrames()()()() | (Inherited from ConcentratorBase.)
 | PublishedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | PublishFrame(IFrame, Int32) | (Inherited from ConcentratorBase.)
 | QueueMeasurementForProcessing(IMeasurement) | (Inherited from ActionAdapterBase.)
 | QueueMeasurementsForProcessing(IEnumerable<(Of <<'(IMeasurement>)>>)) | (Inherited from ActionAdapterBase.)
 | QueueState()()()() | (Inherited from ConcentratorBase.)
 | RealTime()()()() | (Inherited from ConcentratorBase.)
 | ReceivedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | RequestedInputMeasurementKeys()()()() | (Inherited from ActionAdapterBase.)
 | RequestedOutputMeasurementKeys()()()() | (Inherited from ActionAdapterBase.)
 | ResetStatistics()()()() | (Inherited from ActionAdapterBase.)
 | RunTime()()()() | (Inherited from ConcentratorBase.)
 | SecondsFromRealTime(Ticks) | (Inherited from ConcentratorBase.)
 | SetInitializedState(Boolean) | (Inherited from ActionAdapterBase.)
 | SetTemporalConstraint(String, String, String) | (Inherited from ActionAdapterBase.)
 | Settings()()()() | (Inherited from ActionAdapterBase.)
 | SortMeasurement(IMeasurement) | (Inherited from ConcentratorBase.)
 | SortMeasurements(IEnumerable<(Of <<'(IMeasurement>)>>)) | (Inherited from ConcentratorBase.)
 | Start()()()() | (Inherited from ActionAdapterBase.)
 | StartTime()()()() | (Inherited from ConcentratorBase.)
 | StartTimeConstraint()()()() | (Inherited from ActionAdapterBase.)
 | Status | Returns the detailed status of the calculated measurement. (Overrides ActionAdapterBase.Status()()()().)
 | StatusMessage()()()() | (Inherited from ActionAdapterBase.)
 | Stop()()()() | (Inherited from ActionAdapterBase.)
 | StopTime()()()() | (Inherited from ConcentratorBase.)
 | StopTimeConstraint()()()() | (Inherited from ActionAdapterBase.)
 | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Overrides ActionAdapterBase.SupportsTemporalProcessing()()()().)
 | TicksPerFrame()()()() | (Inherited from ConcentratorBase.)
 | TimeResolution()()()() | (Inherited from ConcentratorBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalPublicationTime()()()() | (Inherited from ConcentratorBase.)
 | TrackLatestMeasurements()()()() | (Inherited from ConcentratorBase.)
 | TrackPublishedTimestamp()()()() | (Inherited from ConcentratorBase.)
 | TryGetMinimumNeededMeasurements(IFrame, array<IMeasurement>[]()[][]%) | (Inherited from ActionAdapterBase.)
 | UnpublishedSamples()()()() | (Inherited from ConcentratorBase.)
 | UseLocalClockAsRealTime()()()() | (Inherited from ConcentratorBase.)
 | UsePrecisionTimer()()()() | (Inherited from ConcentratorBase.)
 | WaitForInitialize(Int32) | (Inherited from ActionAdapterBase.)
 | WaitHandleExpirations()()()() | (Inherited from ConcentratorBase.)
Remarks
This base class extends ActionAdapterBase by automatically looking up the SignalType for each of the input and output measurements.
Inheritance Hierarchy
Object
 | ConcentratorBase
 |  | ActionAdapterBase
 |  |  | CalculatedMeasurementBase


CalculatedMeasurementBase Constructor

CalculatedMeasurementBase Constructor
Namespaces ► TVA.PhasorProtocols ► CalculatedMeasurementBase ► CalculatedMeasurementBase()()()()
Initializes a new instance of the CalculatedMeasurementBase class
Declaration Syntax
C# Visual Basic Visual C++
protected CalculatedMeasurementBase()
Protected Sub New
protected:
CalculatedMeasurementBase()


ConfigurationSection Property

ConfigurationSection Property
Namespaces ► TVA.PhasorProtocols ► CalculatedMeasurementBase ► ConfigurationSection
Gets or sets the configuration section to use for this CalculatedMeasurementBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string ConfigurationSection { get; set; }
Public Overridable Property ConfigurationSection As String
    Get
    Set
public:
virtual property String^ ConfigurationSection {
    String^ get ();
    void set (String^ value);
}


Initialize Method

Initialize Method
Namespaces ► TVA.PhasorProtocols ► CalculatedMeasurementBase ► Initialize()()()()
Intializes CalculatedMeasurementBase.
Declaration Syntax
C# Visual Basic Visual C++
public override void Initialize()
Public Overrides Sub Initialize
public:
virtual void Initialize() override


InputMeasurementKeys Property

InputMeasurementKeys Property
Namespaces ► TVA.PhasorProtocols ► CalculatedMeasurementBase ► InputMeasurementKeys
Gets or sets primary keys of input measurements the calculated measurement expects.
Declaration Syntax
C# Visual Basic Visual C++
public override MeasurementKey[] InputMeasurementKeys { get; set; }
Public Overrides Property InputMeasurementKeys As MeasurementKey()
    Get
    Set
public:
virtual property array<MeasurementKey>^ InputMeasurementKeys {
    array<MeasurementKey>^ get () override;
    void set (array<MeasurementKey>^ value) override;
}


InputMeasurementKeyTypes Property

InputMeasurementKeyTypes Property
Namespaces ► TVA.PhasorProtocols ► CalculatedMeasurementBase ► InputMeasurementKeyTypes
Gets or sets input measurement SignalType's for each of the InputMeasurementKeys()()()(), if any.
Declaration Syntax
C# Visual Basic Visual C++
public virtual SignalType[] InputMeasurementKeyTypes { get; }
Public Overridable ReadOnly Property InputMeasurementKeyTypes As SignalType()
    Get
public:
virtual property array<SignalType>^ InputMeasurementKeyTypes {
    array<SignalType>^ get ();
}


OutputMeasurements Property

OutputMeasurements Property
Namespaces ► TVA.PhasorProtocols ► CalculatedMeasurementBase ► OutputMeasurements
Gets or sets output measurements that the calculated measurement will produce, if any.
Declaration Syntax
C# Visual Basic Visual C++
public override IMeasurement[] OutputMeasurements { get; set; }
Public Overrides Property OutputMeasurements As IMeasurement()
    Get
    Set
public:
virtual property array<IMeasurement^>^ OutputMeasurements {
    array<IMeasurement^>^ get () override;
    void set (array<IMeasurement^>^ value) override;
}


OutputMeasurementTypes Property

OutputMeasurementTypes Property
Namespaces ► TVA.PhasorProtocols ► CalculatedMeasurementBase ► OutputMeasurementTypes
Gets or sets output measurement SignalType's for each of the OutputMeasurements()()()(), if any.
Declaration Syntax
C# Visual Basic Visual C++
public virtual SignalType[] OutputMeasurementTypes { get; }
Public Overridable ReadOnly Property OutputMeasurementTypes As SignalType()
    Get
public:
virtual property array<SignalType>^ OutputMeasurementTypes {
    array<SignalType>^ get ();
}


Status Property

Status Property
Namespaces ► TVA.PhasorProtocols ► CalculatedMeasurementBase ► Status
Returns the detailed status of the calculated measurement.
Declaration Syntax
C# Visual Basic Visual C++
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
public:
virtual property String^ Status {
    String^ get () override;
}
Remarks
Derived classes should extend status with implementation specific information.


SupportsTemporalProcessing Property

SupportsTemporalProcessing Property
Namespaces ► TVA.PhasorProtocols ► CalculatedMeasurementBase ► SupportsTemporalProcessing
Gets the flag indicating if this adapter supports temporal processing.
Declaration Syntax
C# Visual Basic Visual C++
public override bool SupportsTemporalProcessing { get; }
Public Overrides ReadOnly Property SupportsTemporalProcessing As Boolean
    Get
public:
virtual property bool SupportsTemporalProcessing {
    bool get () override;
}


ChannelBase Class

ChannelBase Class
Namespaces ► TVA.PhasorProtocols ► ChannelBase
Represents the common implementation of the protocol independent definition of any kind of data that can be parsed or generated.
This is the base class of all parsing/generating classes in the phasor protocols library; it is the root of the parsing/generating class hierarchy.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class ChannelBase : BinaryImageBase,
    IChannel, ISupportBinaryImage
Public MustInherit Class ChannelBase _
    Inherits BinaryImageBase _
    Implements IChannel, ISupportBinaryImage
public ref class ChannelBase abstract : public BinaryImageBase,
    IChannel, ISupportBinaryImage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChannelBase()()()() | Initializes a new instance of the ChannelBase class
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelBase object.
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage()()()() | (Inherited from BinaryImageBase.)
 | BodyLength()()()() | (Inherited from BinaryImageBase.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object.
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This base class represents IChannel data images for parsing or generation in terms of a header, body and footer (see BinaryImageBase for details).
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  | ChannelDefinitionBase
 |  |  | ChannelFrameBase<(Of <(<'T>)>)>
 |  |  | ChannelValueBase<(Of <(<'T>)>)>


ChannelBase Constructor

ChannelBase Constructor
Namespaces ► TVA.PhasorProtocols ► ChannelBase ► ChannelBase()()()()
Initializes a new instance of the ChannelBase class
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelBase()
Protected Sub New
protected:
ChannelBase()


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► ChannelBase ► Attributes
Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelBase object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Dictionary<string, string> Attributes { get; }
Public Overridable ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get ();
}
Remarks
The attributes dictionary is relevant to all channel properties. This dictionary will only be instantiated with a call to the Attributes property which will begin the enumeration of relevant system properties. This is typically used for display purposes. For example, this information is displayed in a tree view on the the PMU Connection Tester to display attributes of data elements that may be protocol specific.


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► ChannelBase ► State
Gets or sets the parsing state for this ChannelBase object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IChannelParsingState State { get; set; }
Public Overridable Property State As IChannelParsingState
    Get
    Set
public:
virtual property IChannelParsingState^ State {
    IChannelParsingState^ get ();
    void set (IChannelParsingState^ value);
}


Tag Property

Tag Property
Namespaces ► TVA.PhasorProtocols ► ChannelBase ► Tag
Gets or sets a user definable reference to an object associated with this ChannelBase object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Tag { get; set; }
Public Overridable Property Tag As Object
    Get
    Set
public:
virtual property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}


ChannelCellBase Class

ChannelCellBase Class
Namespaces ► TVA.PhasorProtocols ► ChannelCellBase
Represents the common implementation of the protocol independent representation of any kind of data cell.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class ChannelCellBase : ChannelBase,
    IChannelCell, IChannel, ISupportBinaryImage, ISerializable
<SerializableAttribute> _
Public MustInherit Class ChannelCellBase _
    Inherits ChannelBase _
    Implements IChannelCell, IChannel, ISupportBinaryImage, ISerializable
[SerializableAttribute]
public ref class ChannelCellBase abstract : public ChannelBase,
    IChannelCell, IChannel, ISupportBinaryImage, ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChannelCellBase(IChannelFrame, UInt16) | Creates a new ChannelCellBase from specified parameters.
 | ChannelCellBase(SerializationInfo, StreamingContext) | Creates a new ChannelCellBase from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ChannelCellBase object. (Overrides ChannelBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage()()()() | (Inherited from BinaryImageBase.)
 | BodyLength()()()() | (Inherited from BinaryImageBase.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets or sets the numeric ID code for this ChannelCellBase.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets a reference to the parent IChannelFrame for this ChannelCellBase.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for the this ChannelCellBase.
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelCellBase. (Overrides Object.ToString()()()().)
Remarks
This phasor protocol implementation defines a "cell" as a portion of a frame, i.e., a logical unit of data. For example, a DataCellBase (dervied from ChannelCellBase) could be defined as a PMU within a frame of data, a DataFrameBase, that contains multiple PMU's coming from a PDC.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | CommandCell
 |  |  |  | ConfigurationCellBase
 |  |  |  | DataCellBase
 |  |  |  | HeaderCell


ChannelCellBase Constructor

ChannelCellBase Constructor
Namespaces ► TVA.PhasorProtocols ► ChannelCellBase ► ChannelCellBase()()()()
Members
Icon | Member | Description
 | ChannelCellBase(IChannelFrame, UInt16) | Creates a new ChannelCellBase from specified parameters.
 | ChannelCellBase(SerializationInfo, StreamingContext) | Creates a new ChannelCellBase from serialization parameters.


ChannelCellBase Constructor (info, context)

ChannelCellBase Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► ChannelCellBase ► ChannelCellBase(SerializationInfo, StreamingContext)
Creates a new ChannelCellBase from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelCellBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ChannelCellBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ChannelCellBase Constructor (parent, idCode)

ChannelCellBase Constructor (parent, idCode)
Namespaces ► TVA.PhasorProtocols ► ChannelCellBase ► ChannelCellBase(IChannelFrame, UInt16)
Creates a new ChannelCellBase from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelCellBase(
    IChannelFrame parent,
    ushort idCode
)
Protected Sub New ( _
    parent As IChannelFrame, _
    idCode As UShort _
)
protected:
ChannelCellBase(
    IChannelFrame^ parent,
    unsigned short idCode
)
Parameters
parent (IChannelFrame)
A reference to the parent IChannelFrame for this ChannelCellBase.
idCode (UInt16)
The numeric ID code for this ChannelCellBase.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► ChannelCellBase ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ChannelCellBase object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► ChannelCellBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols ► ChannelCellBase ► IDCode
Gets or sets the numeric ID code for this ChannelCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ushort IDCode { get; set; }
Public Overridable Property IDCode As UShort
    Get
    Set
public:
virtual property unsigned short IDCode {
    unsigned short get ();
    void set (unsigned short value);
}
Remarks
Most phasor measurement devices define some kind of numeric identifier (e.g., a hardware identifier coded into the device ROM); this is the abstract representation of this identifier.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► ChannelCellBase ► Parent
Gets or sets a reference to the parent IChannelFrame for this ChannelCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IChannelFrame Parent { get; set; }
Public Overridable Property Parent As IChannelFrame
    Get
    Set
public:
virtual property IChannelFrame^ Parent {
    IChannelFrame^ get ();
    void set (IChannelFrame^ value);
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► ChannelCellBase ► State
Gets or sets the parsing state for the this ChannelCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IChannelCellParsingState State { get; set; }
Public Overridable Property State As IChannelCellParsingState
    Get
    Set
public:
virtual property IChannelCellParsingState^ State {
    IChannelCellParsingState^ get ();
    void set (IChannelCellParsingState^ value);
}


ToString Method

ToString Method
Namespaces ► TVA.PhasorProtocols ► ChannelCellBase ► ToString()()()()
Gets the string respresentation of this ChannelCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
String respresentation of this ChannelCellBase.


ChannelCellCollectionBase(T) Class

ChannelCellCollectionBase<(Of <(<'T>)>)> Class
Namespaces ► TVA.PhasorProtocols ► ChannelCellCollectionBase<(Of <(<'T>)>)>
Represents a protocol independent collection of IChannelCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class ChannelCellCollectionBase<T> : ChannelCollectionBase<T>,
    IChannelCellCollection<T>, IChannelCollection<T>, IChannel, ISupportBinaryImage, IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable, INotifyCollectionChanged, ISerializable
where T : IChannelCell

<SerializableAttribute> _
Public MustInherit Class ChannelCellCollectionBase(Of T As IChannelCell) _
    Inherits ChannelCollectionBase(Of T) _
    Implements IChannelCellCollection(Of T), IChannelCollection(Of T),  _
    IChannel, ISupportBinaryImage, IList(Of T), ICollection(Of T),  _
    IEnumerable(Of T), IEnumerable, INotifyCollectionChanged, ISerializable
[SerializableAttribute]
generic<typename T>
where T : IChannelCell
public ref class ChannelCellCollectionBase abstract : public ChannelCollectionBase<T>,
    IChannelCellCollection<T>, IChannelCollection<T>, IChannel, ISupportBinaryImage, IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable, INotifyCollectionChanged, ISerializable
Generic Template Parameters
T
Specific IChannelCell type that the ChannelCellCollectionBase<(Of <(<'T>)>)> contains.
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChannelCellCollectionBase<(Of <(<'T>)>)>(Int32, Boolean) | Creates a new ChannelCellCollectionBase<(Of <(<'T>)>)> from specified parameters.
 | ChannelCellCollectionBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext) | Creates a new ChannelCellCollectionBase<(Of <(<'T>)>)> from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Overrides ChannelCollectionBase <(Of <(<'T>)>)>.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Overrides ChannelCollectionBase <(Of <(<'T>)>)>.BinaryLength.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant.
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<'T>)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCollectionBase <(Of <(<'T>)>)>.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<'T>)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<'T>)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<'T>)>)>
 |  | ChannelCollectionBase <(Of <(<'T>)>)>
 |  |  | ChannelCellCollectionBase<(Of <(<'T>)>)>
 |  |  |  | CommandCellCollection
 |  |  |  | ConfigurationCellCollection
 |  |  |  | DataCellCollection
 |  |  |  | HeaderCellCollection


ChannelCellCollectionBase(T) Constructor

ChannelCellCollectionBase<(Of <(<'T>)>)> Constructor
Namespaces ► TVA.PhasorProtocols ► ChannelCellCollectionBase<(Of <(<'T>)>)> ► ChannelCellCollectionBase<(Of <(<'T>)>)>()()()()
Members
Icon | Member | Description
 | ChannelCellCollectionBase<(Of <(<'T>)>)>(Int32, Boolean) | Creates a new ChannelCellCollectionBase<(Of <(<'T>)>)> from specified parameters.
 | ChannelCellCollectionBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext) | Creates a new ChannelCellCollectionBase<(Of <(<'T>)>)> from serialization parameters.


ChannelCellCollectionBase(T) Constructor (lastValidIndex, constantCellLength)

ChannelCellCollectionBase<(Of <(<'T>)>)> Constructor (lastValidIndex, constantCellLength)
Namespaces ► TVA.PhasorProtocols ► ChannelCellCollectionBase<(Of <(<'T>)>)> ► ChannelCellCollectionBase<(Of <(<'T>)>)>(Int32, Boolean)
Creates a new ChannelCellCollectionBase<(Of <(<'T>)>)> from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelCellCollectionBase(
    int lastValidIndex,
    bool constantCellLength
)
Protected Sub New ( _
    lastValidIndex As Integer, _
    constantCellLength As Boolean _
)
protected:
ChannelCellCollectionBase(
    int lastValidIndex,
    bool constantCellLength
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
constantCellLength (Boolean)
Sets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant.
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


ChannelCellCollectionBase(T) Constructor (info, context)

ChannelCellCollectionBase<(Of <(<'T>)>)> Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► ChannelCellCollectionBase<(Of <(<'T>)>)> ► ChannelCellCollectionBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext)
Creates a new ChannelCellCollectionBase<(Of <(<'T>)>)> from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelCellCollectionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ChannelCellCollectionBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► ChannelCellCollectionBase<(Of <(<'T>)>)> ► Attributes
Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BinaryLength Property

BinaryLength Property
Namespaces ► TVA.PhasorProtocols ► ChannelCellCollectionBase<(Of <(<'T>)>)> ► BinaryLength
Gets the length of the BinaryImage.
Declaration Syntax
C# Visual Basic Visual C++
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
public:
virtual property int BinaryLength {
    int get () override;
}
Remarks
The length of the ChannelCellCollectionBase<(Of <(<'T>)>)> binary image is the combined length of all the items in the collection.


ConstantCellLength Property

ConstantCellLength Property
Namespaces ► TVA.PhasorProtocols ► ChannelCellCollectionBase<(Of <(<'T>)>)> ► ConstantCellLength
Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant.
Declaration Syntax
C# Visual Basic Visual C++
public bool ConstantCellLength { get; }
Public ReadOnly Property ConstantCellLength As Boolean
    Get
public:
virtual property bool ConstantCellLength {
    bool get () sealed;
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► ChannelCellCollectionBase<(Of <(<'T>)>)> ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


ChannelCellParsingStateBase Class

ChannelCellParsingStateBase Class
Namespaces ► TVA.PhasorProtocols ► ChannelCellParsingStateBase
Represents the protocol independent common implementation of the parsing state used by any IChannelCell.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class ChannelCellParsingStateBase : ChannelParsingStateBase,
    IChannelCellParsingState, IChannelParsingState
Public MustInherit Class ChannelCellParsingStateBase _
    Inherits ChannelParsingStateBase _
    Implements IChannelCellParsingState, IChannelParsingState
public ref class ChannelCellParsingStateBase abstract : public ChannelParsingStateBase,
    IChannelCellParsingState, IChannelParsingState
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChannelCellParsingStateBase()()()() | Initializes a new instance of the ChannelCellParsingStateBase class
 | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed.
 | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
 | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ChannelParsingStateBase
 |  | ChannelCellParsingStateBase
 |  |  | ConfigurationCellParsingState
 |  |  | DataCellParsingState


ChannelCellParsingStateBase Constructor

ChannelCellParsingStateBase Constructor
Namespaces ► TVA.PhasorProtocols ► ChannelCellParsingStateBase ► ChannelCellParsingStateBase()()()()
Initializes a new instance of the ChannelCellParsingStateBase class
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelCellParsingStateBase()
Protected Sub New
protected:
ChannelCellParsingStateBase()


AnalogCount Property

AnalogCount Property
Namespaces ► TVA.PhasorProtocols ► ChannelCellParsingStateBase ► AnalogCount
Gets or sets the number of analog elements associated with the IChannelCell being parsed.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int AnalogCount { get; set; }
Public Overridable Property AnalogCount As Integer
    Get
    Set
public:
virtual property int AnalogCount {
    int get ();
    void set (int value);
}


DigitalCount Property

DigitalCount Property
Namespaces ► TVA.PhasorProtocols ► ChannelCellParsingStateBase ► DigitalCount
Gets or sets the number of digital elements associated with the IChannelCell being parsed.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int DigitalCount { get; set; }
Public Overridable Property DigitalCount As Integer
    Get
    Set
public:
virtual property int DigitalCount {
    int get ();
    void set (int value);
}


PhasorCount Property

PhasorCount Property
Namespaces ► TVA.PhasorProtocols ► ChannelCellParsingStateBase ► PhasorCount
Gets or sets the number of phasor elements associated with the IChannelCell being parsed.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int PhasorCount { get; set; }
Public Overridable Property PhasorCount As Integer
    Get
    Set
public:
virtual property int PhasorCount {
    int get ();
    void set (int value);
}


ChannelCollectionBase(T) Class

ChannelCollectionBase<(Of <(<'T>)>)> Class
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)>
Represents a protocol independent collection of IChannel objects.
This is the base class of all collection classes in the phasor protocols library; it is the root of the collection class hierarchy.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class ChannelCollectionBase<T> : Collection<T>,
    IChannelCollection<T>, IChannel, ISupportBinaryImage, IList<T>, ICollection<T>,
    IEnumerable<T>, IEnumerable, ISerializable, INotifyCollectionChanged
where T : IChannel

<SerializableAttribute> _
Public MustInherit Class ChannelCollectionBase(Of T As IChannel) _
    Inherits Collection(Of T) _
    Implements IChannelCollection(Of T), IChannel, ISupportBinaryImage,  _
    IList(Of T), ICollection(Of T), IEnumerable(Of T),  _
    IEnumerable, ISerializable, INotifyCollectionChanged
[SerializableAttribute]
generic<typename T>
where T : IChannel
public ref class ChannelCollectionBase abstract : public Collection<T>,
    IChannelCollection<T>, IChannel, ISupportBinaryImage, IList<T>, ICollection<T>,
    IEnumerable<T>, IEnumerable, ISerializable, INotifyCollectionChanged
Generic Template Parameters
T
Specific IChannel type that the ChannelCollectionBase<(Of <(<'T>)>)> contains.
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChannelCollectionBase<(Of <(<'T>)>)>()()()() | Creates a new ChannelCollectionBase<(Of <(<'T>)>)>.
 | ChannelCollectionBase<(Of <(<'T>)>)>(Int32) | Creates a new ChannelCollectionBase<(Of <(<'T>)>)> using specified lastValidIndex.
 | ChannelCollectionBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext) | Creates a new ChannelCollectionBase<(Of <(<'T>)>)> from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object.
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>.
 | BinaryLength | Gets the length of the BinaryImage.
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Overrides Collection <(Of <(<'T>)>)>.ClearItems()()()().)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed.
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<'T>)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<'T>)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Overrides Collection <(Of <(<'T>)>)>.InsertItem(Int32, T).)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<'T>)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event.
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event.
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'T>)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Overrides Collection <(Of <(<'T>)>)>.RemoveItem(Int32).)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Overrides Collection <(Of <(<'T>)>)>.SetItem(Int32, T).)
 | State | Gets or sets the parsing state for this IChannel object.
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This channel collection implements IChannel (inherited via IChannelCollection<(Of <(<'T>)>)>) for the benefit of providing a cumulative binary image of the entire collection.
Inheritance Hierarchy
Object
 | Collection <(Of <(<'T>)>)>
 |  | ChannelCollectionBase<(Of <(<'T>)>)>
 |  |  | ChannelCellCollectionBase<(Of <(<'T>)>)>
 |  |  | ChannelDefinitionCollectionBase<(Of <(<'T>)>)>
 |  |  | ChannelFrameCollectionBase<(Of <(<'T>)>)>
 |  |  | ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>


ChannelCollectionBase(T) Constructor

ChannelCollectionBase<(Of <(<'T>)>)> Constructor
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► ChannelCollectionBase<(Of <(<'T>)>)>()()()()
Members
Icon | Member | Description
 | ChannelCollectionBase<(Of <(<'T>)>)>()()()() | Creates a new ChannelCollectionBase<(Of <(<'T>)>)>.
 | ChannelCollectionBase<(Of <(<'T>)>)>(Int32) | Creates a new ChannelCollectionBase<(Of <(<'T>)>)> using specified lastValidIndex.
 | ChannelCollectionBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext) | Creates a new ChannelCollectionBase<(Of <(<'T>)>)> from serialization parameters.


ChannelCollectionBase(T) Constructor

ChannelCollectionBase<(Of <(<'T>)>)> Constructor
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► ChannelCollectionBase<(Of <(<'T>)>)>()()()()
Creates a new ChannelCollectionBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelCollectionBase()
Protected Sub New
protected:
ChannelCollectionBase()


ChannelCollectionBase(T) Constructor (lastValidIndex)

ChannelCollectionBase<(Of <(<'T>)>)> Constructor (lastValidIndex)
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► ChannelCollectionBase<(Of <(<'T>)>)>(Int32)
Creates a new ChannelCollectionBase<(Of <(<'T>)>)> using specified lastValidIndex.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelCollectionBase(
    int lastValidIndex
)
Protected Sub New ( _
    lastValidIndex As Integer _
)
protected:
ChannelCollectionBase(
    int lastValidIndex
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


ChannelCollectionBase(T) Constructor (info, context)

ChannelCollectionBase<(Of <(<'T>)>)> Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► ChannelCollectionBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext)
Creates a new ChannelCollectionBase<(Of <(<'T>)>)> from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelCollectionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ChannelCollectionBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


AddRange Method (collection)

AddRange Method (collection)
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► AddRange(IEnumerable<(Of <<'(T>)>>))
Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AddRange(
    IEnumerable<T> collection
)
Public Overridable Sub AddRange ( _
    collection As IEnumerable(Of T) _
)
public:
virtual void AddRange(
    IEnumerable<T>^ collection
)
Parameters
collection (IEnumerable <(Of <(<' T >)>)>)
The collection whose elements should be added to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. The collection itself cannot be null, but it can contain elements that are null, if type T is a reference type.
Exceptions
Exception | Condition
ArgumentNullException | collection is null.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► Attributes
Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Dictionary<string, string> Attributes { get; }
Public Overridable ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get ();
}


BinaryImage Property

BinaryImage Property
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► BinaryImage
Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual byte[] BinaryImage { get; }
Public Overridable ReadOnly Property BinaryImage As Byte()
    Get
public:
virtual property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get ();
}
Remarks
The binary image of the ChannelCollectionBase<(Of <(<'T>)>)> is the combined images of all the items in the collection.


BinaryLength Property

BinaryLength Property
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► BinaryLength
Gets the length of the BinaryImage.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int BinaryLength { get; }
Public Overridable ReadOnly Property BinaryLength As Integer
    Get
public:
virtual property int BinaryLength {
    int get ();
}
Remarks
The length of the ChannelCollectionBase<(Of <(<'T>)>)> binary image is the combined length of all the items in the collection.
The default implementation assumes all IChannel items in the collection have the same length, hence the value returned is the BinaryLength()()()() of the first item in the collection times the Count.


ClearItems Method

ClearItems Method
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► ClearItems()()()()
Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
protected override void ClearItems()
Protected Overrides Sub ClearItems
protected:
virtual void ClearItems() override


CollectionChanged Event

CollectionChanged Event
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► CollectionChanged
Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed.
Declaration Syntax
C# Visual Basic Visual C++
public event NotifyCollectionChangedEventHandler CollectionChanged
Public Event CollectionChanged As NotifyCollectionChangedEventHandler
public:
virtual  event NotifyCollectionChangedEventHandler^ CollectionChanged {
    void add (NotifyCollectionChangedEventHandler^ value);
    void remove (NotifyCollectionChangedEventHandler^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


InsertItem Method (index, item)

InsertItem Method (index, item)
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► InsertItem(Int32, T)
Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index.
Declaration Syntax
C# Visual Basic Visual C++
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As T _
)
protected:
virtual void InsertItem(
    int index,
    T item
) override
Parameters
index (Int32)
The zero-based index at which item should be inserted.
item (T)
The object to insert.
Exceptions
Exception | Condition
OverflowException | Maximum collection item limit reached.


MaximumCount Property

MaximumCount Property
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► MaximumCount
Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int MaximumCount { get; set; }
Public Overridable Property MaximumCount As Integer
    Get
    Set
public:
virtual property int MaximumCount {
    int get ();
    void set (int value);
}


OnCollectionChanged Method (e)

OnCollectionChanged Method (e)
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► OnCollectionChanged(NotifyCollectionChangedEventArgs)
Raises the NotifyCollectionChangedEventHandler event.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
Protected Overridable Sub OnCollectionChanged ( _
    e As NotifyCollectionChangedEventArgs _
)
protected:
virtual void OnCollectionChanged(
    NotifyCollectionChangedEventArgs^ e
)
Parameters
e (NotifyCollectionChangedEventArgs)
Changed event arguments.


RefreshBinding Method

RefreshBinding Method
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► RefreshBinding()()()()
Manually sends a Reset to the collection changed event.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RefreshBinding()
Public Overridable Sub RefreshBinding
public:
virtual void RefreshBinding()


RemoveItem Method (index)

RemoveItem Method (index)
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► RemoveItem(Int32)
Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)
protected:
virtual void RemoveItem(
    int index
) override
Parameters
index (Int32)
The zero-based index of the element to remove.


SetItem Method (index, item)

SetItem Method (index, item)
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► SetItem(Int32, T)
Replaces the element at the specified index.
Declaration Syntax
C# Visual Basic Visual C++
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As T _
)
protected:
virtual void SetItem(
    int index,
    T item
) override
Parameters
index (Int32)
The zero-based index of the element to replace.
item (T)
The new value for the element at the specified index. The value can be null for reference types.


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► State
Gets or sets the parsing state for this IChannel object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IChannelParsingState State { get; set; }
Public Overridable Property State As IChannelParsingState
    Get
    Set
public:
virtual property IChannelParsingState^ State {
    IChannelParsingState^ get ();
    void set (IChannelParsingState^ value);
}


Tag Property

Tag Property
Namespaces ► TVA.PhasorProtocols ► ChannelCollectionBase<(Of <(<'T>)>)> ► Tag
Gets or sets a user definable reference to an object associated with this IChannel object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Tag { get; set; }
Public Overridable Property Tag As Object
    Get
    Set
public:
virtual property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}


ChannelDefinitionBase Class

ChannelDefinitionBase Class
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase
Represents the common implementation of the protocol independent definition of any kind of IChannel data.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class ChannelDefinitionBase : ChannelBase,
    IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition>,
    IComparable<IChannelDefinition>, IComparable
<SerializableAttribute> _
Public MustInherit Class ChannelDefinitionBase _
    Inherits ChannelBase _
    Implements IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,  _
    IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition), IComparable
[SerializableAttribute]
public ref class ChannelDefinitionBase abstract : public ChannelBase,
    IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition^>,
    IComparable<IChannelDefinition^>, IComparable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChannelDefinitionBase(IConfigurationCell) | Creates a new ChannelDefinitionBase.
 | ChannelDefinitionBase(IConfigurationCell, String, UInt32, Double) | Creates a new ChannelDefinitionBase from specified parameters.
 | ChannelDefinitionBase(SerializationInfo, StreamingContext) | Creates a new ChannelDefinitionBase from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelDefinitionBase object. (Overrides ChannelBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Overrides BinaryImageBase.BodyImage()()()().)
 | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBase.BodyLength()()()().)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this ChannelDefinitionBase.
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Overrides Object.GetHashCode()()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase.
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase.
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase.
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this ChannelDefinitionBase.
 | Parent | Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides BinaryImageBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase.
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase.
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | AnalogDefinitionBase
 |  |  |  | DigitalDefinitionBase
 |  |  |  | FrequencyDefinitionBase
 |  |  |  | PhasorDefinitionBase


ChannelDefinitionBase Constructor

ChannelDefinitionBase Constructor
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► ChannelDefinitionBase()()()()
Members
Icon | Member | Description
 | ChannelDefinitionBase(IConfigurationCell) | Creates a new ChannelDefinitionBase.
 | ChannelDefinitionBase(IConfigurationCell, String, UInt32, Double) | Creates a new ChannelDefinitionBase from specified parameters.
 | ChannelDefinitionBase(SerializationInfo, StreamingContext) | Creates a new ChannelDefinitionBase from serialization parameters.


ChannelDefinitionBase Constructor (info, context)

ChannelDefinitionBase Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► ChannelDefinitionBase(SerializationInfo, StreamingContext)
Creates a new ChannelDefinitionBase from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelDefinitionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ChannelDefinitionBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ChannelDefinitionBase Constructor (parent)

ChannelDefinitionBase Constructor (parent)
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► ChannelDefinitionBase(IConfigurationCell)
Creates a new ChannelDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelDefinitionBase(
    IConfigurationCell parent
)
Protected Sub New ( _
    parent As IConfigurationCell _
)
protected:
ChannelDefinitionBase(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this ChannelDefinitionBase.


ChannelDefinitionBase Constructor (parent, label, scale, offset)

ChannelDefinitionBase Constructor (parent, label, scale, offset)
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► ChannelDefinitionBase(IConfigurationCell, String, UInt32, Double)
Creates a new ChannelDefinitionBase from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelDefinitionBase(
    IConfigurationCell parent,
    string label,
    uint scale,
    double offset
)
Protected Sub New ( _
    parent As IConfigurationCell, _
    label As String, _
    scale As UInteger, _
    offset As Double _
)
protected:
ChannelDefinitionBase(
    IConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this ChannelDefinitionBase.
label (String)
The label of this ChannelDefinitionBase.
scale (UInt32)
The integer scaling value of this ChannelDefinitionBase.
offset (Double)
The offset of this ChannelDefinitionBase.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► Attributes
Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelDefinitionBase object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► BodyImage
Gets the binary body image of the ChannelDefinitionBase object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► CompareTo(Object)
Compares this instance to a specified object and returns an indication of their relative values.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int CompareTo(
    Object obj
)
Public Overridable Function CompareTo ( _
    obj As Object _
) As Integer
public:
virtual int CompareTo(
    Object^ obj
)
Parameters
obj (Object)
An object to compare, or null.
Return Value
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.
Exceptions
Exception | Condition
ArgumentException | value is not an IChannelDefinition.


CompareTo Method (other)

CompareTo Method (other)
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► CompareTo(IChannelDefinition)
Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.
Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    IChannelDefinition other
)
Public Function CompareTo ( _
    other As IChannelDefinition _
) As Integer
public:
virtual int CompareTo(
    IChannelDefinition^ other
) sealed
Parameters
other (IChannelDefinition)
A IChannelDefinition object to compare.
Return Value
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.


ConversionFactor Property

ConversionFactor Property
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► ConversionFactor
Gets or sets the conversion factor of this ChannelDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double ConversionFactor { get; set; }
Public Overridable Property ConversionFactor As Double
    Get
    Set
public:
virtual property double ConversionFactor {
    double get ();
    void set (double value);
}


DataFormat Property

DataFormat Property
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► DataFormat
Gets the DataFormat of this ChannelDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public abstract DataFormat DataFormat { get; }
Public MustOverride ReadOnly Property DataFormat As DataFormat
    Get
public:
virtual property DataFormat DataFormat {
    DataFormat get () abstract;
}


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


Equals Method (obj)

Equals Method (obj)
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► Equals(Object)
Returns a value indicating whether this instance is equal to a specified object.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)
An object to compare, or null.
Return Value
True if obj is an instance of IChannelDefinition and equals the value of this instance; otherwise, False.
Exceptions
Exception | Condition
ArgumentException | value is not an IChannelDefinition.


Equals Method (other)

Equals Method (other)
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► Equals(IChannelDefinition)
Returns a value indicating whether this instance is equal to specified IChannelDefinition value.
Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    IChannelDefinition other
)
Public Function Equals ( _
    other As IChannelDefinition _
) As Boolean
public:
virtual bool Equals(
    IChannelDefinition^ other
) sealed
Parameters
other (IChannelDefinition)
A IChannelDefinition object to compare to this instance.
Return Value
True if other has the same value as this instance; otherwise, False.


GetHashCode Method

GetHashCode Method
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► GetHashCode()()()()
Returns the hash code for this instance.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
A 32-bit signed integer hash code.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


Index Property

Index Property
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► Index
Gets or sets the index of this ChannelDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Index { get; set; }
Public Overridable Property Index As Integer
    Get
    Set
public:
virtual property int Index {
    int get ();
    void set (int value);
}
Remarks
Index is automatically maintained by ChannelDefinitionCollectionBase<(Of <(<'T>)>)>.


Label Property

Label Property
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► Label
Gets or sets the label of this ChannelDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Label { get; set; }
Public Overridable Property Label As String
    Get
    Set
public:
virtual property String^ Label {
    String^ get ();
    void set (String^ value);
}


LabelImage Property

LabelImage Property
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► LabelImage
Gets the binary image of the Label of this ChannelDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual byte[] LabelImage { get; }
Public Overridable ReadOnly Property LabelImage As Byte()
    Get
public:
virtual property array<unsigned char>^ LabelImage {
    array<unsigned char>^ get ();
}


MaximumLabelLength Property

MaximumLabelLength Property
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► MaximumLabelLength
Gets the maximum length of the Label of this ChannelDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int MaximumLabelLength { get; }
Public Overridable ReadOnly Property MaximumLabelLength As Integer
    Get
public:
virtual property int MaximumLabelLength {
    int get ();
}


MaximumScalingValue Property

MaximumScalingValue Property
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► MaximumScalingValue
Gets the maximum value for the ScalingValue of this ChannelDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual uint MaximumScalingValue { get; }
Public Overridable ReadOnly Property MaximumScalingValue As UInteger
    Get
public:
virtual property unsigned int MaximumScalingValue {
    unsigned int get ();
}
Remarks
The base implementation accomodates maximum scaling factor of 24-bits of space.


Offset Property

Offset Property
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► Offset
Gets or sets the offset of this ChannelDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Offset { get; set; }
Public Overridable Property Offset As Double
    Get
    Set
public:
virtual property double Offset {
    double get ();
    void set (double value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► Parent
Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IConfigurationCell Parent { get; set; }
Public Overridable Property Parent As IConfigurationCell
    Get
    Set
public:
virtual property IConfigurationCell^ Parent {
    IConfigurationCell^ get ();
    void set (IConfigurationCell^ value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
The base implementation assumes that all channel defintions begin with a label as this is the general case, override functionality if this is not the case.


ScalePerBit Property

ScalePerBit Property
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► ScalePerBit
Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double ScalePerBit { get; }
Public Overridable ReadOnly Property ScalePerBit As Double
    Get
public:
virtual property double ScalePerBit {
    double get ();
}
Remarks
The base implementation assumes scale/bit of 10^-5.


ScalingValue Property

ScalingValue Property
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► ScalingValue
Gets or sets the integer scaling value of this ChannelDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual uint ScalingValue { get; set; }
Public Overridable Property ScalingValue As UInteger
    Get
    Set
public:
virtual property unsigned int ScalingValue {
    unsigned int get ();
    void set (unsigned int value);
}


ToString Method

ToString Method
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionBase ► ToString()()()()
Gets the string respresentation of this ChannelDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
String respresentation of this ChannelDefinitionBase.


ChannelDefinitionCollectionBase(T) Class

ChannelDefinitionCollectionBase<(Of <(<'T>)>)> Class
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionCollectionBase<(Of <(<'T>)>)>
Represents a protocol independent collection of IChannelDefinition objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class ChannelDefinitionCollectionBase<T> : ChannelCollectionBase<T>
where T : IChannelDefinition

<SerializableAttribute> _
Public MustInherit Class ChannelDefinitionCollectionBase(Of T As IChannelDefinition) _
    Inherits ChannelCollectionBase(Of T)
[SerializableAttribute]
generic<typename T>
where T : IChannelDefinition
public ref class ChannelDefinitionCollectionBase abstract : public ChannelCollectionBase<T>
Generic Template Parameters
T
Specific IChannelDefinition type that the ChannelDefinitionCollectionBase<(Of <(<'T>)>)> contains.
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChannelDefinitionCollectionBase<(Of <(<'T>)>)>(Int32) | Creates a new ChannelDefinitionCollectionBase<(Of <(<'T>)>)> using specified lastValidIndex.
 | ChannelDefinitionCollectionBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext) | Creates a new ChannelDefinitionCollectionBase<(Of <(<'T>)>)> from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelDefinitionCollectionBase<(Of <(<'T>)>)> at the specified index.
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelDefinitionCollectionBase<(Of <(<'T>)>)>. (Overrides ChannelCollectionBase <(Of <(<' T >)>)>.RemoveItem(Int32).)
 | SetItem(Int32, T) | Replaces the element at the specified index.
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' T >)>)>
 |  | ChannelCollectionBase <(Of <(<' T >)>)>
 |  |  | ChannelDefinitionCollectionBase<(Of <(<'T>)>)>
 |  |  |  | AnalogDefinitionCollection
 |  |  |  | DigitalDefinitionCollection
 |  |  |  | FrequencyDefinitionCollection
 |  |  |  | PhasorDefinitionCollection


ChannelDefinitionCollectionBase(T) Constructor

ChannelDefinitionCollectionBase<(Of <(<'T>)>)> Constructor
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionCollectionBase<(Of <(<'T>)>)> ► ChannelDefinitionCollectionBase<(Of <(<'T>)>)>()()()()
Members
Icon | Member | Description
 | ChannelDefinitionCollectionBase<(Of <(<'T>)>)>(Int32) | Creates a new ChannelDefinitionCollectionBase<(Of <(<'T>)>)> using specified lastValidIndex.
 | ChannelDefinitionCollectionBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext) | Creates a new ChannelDefinitionCollectionBase<(Of <(<'T>)>)> from serialization parameters.


ChannelDefinitionCollectionBase(T) Constructor (lastValidIndex)

ChannelDefinitionCollectionBase<(Of <(<'T>)>)> Constructor (lastValidIndex)
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionCollectionBase<(Of <(<'T>)>)> ► ChannelDefinitionCollectionBase<(Of <(<'T>)>)>(Int32)
Creates a new ChannelDefinitionCollectionBase<(Of <(<'T>)>)> using specified lastValidIndex.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelDefinitionCollectionBase(
    int lastValidIndex
)
Protected Sub New ( _
    lastValidIndex As Integer _
)
protected:
ChannelDefinitionCollectionBase(
    int lastValidIndex
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


ChannelDefinitionCollectionBase(T) Constructor (info, context)

ChannelDefinitionCollectionBase<(Of <(<'T>)>)> Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionCollectionBase<(Of <(<'T>)>)> ► ChannelDefinitionCollectionBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext)
Creates a new ChannelDefinitionCollectionBase<(Of <(<'T>)>)> from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelDefinitionCollectionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ChannelDefinitionCollectionBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


InsertItem Method (index, item)

InsertItem Method (index, item)
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionCollectionBase<(Of <(<'T>)>)> ► InsertItem(Int32, T)
Inserts an element into the ChannelDefinitionCollectionBase<(Of <(<'T>)>)> at the specified index.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void InsertItem(
    int index,
    T item
)
Protected Overridable Sub InsertItem ( _
    index As Integer, _
    item As T _
)
protected:
virtual void InsertItem(
    int index,
    T item
)
Parameters
index (Int32)
The zero-based index at which item should be inserted.
item (T)
The object to insert.


RemoveItem Method (index)

RemoveItem Method (index)
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionCollectionBase<(Of <(<'T>)>)> ► RemoveItem(Int32)
Removes the element at the specified index of the ChannelDefinitionCollectionBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)
protected:
virtual void RemoveItem(
    int index
) override
Parameters
index (Int32)
The zero-based index of the element to remove.


SetItem Method (index, item)

SetItem Method (index, item)
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionCollectionBase<(Of <(<'T>)>)> ► SetItem(Int32, T)
Replaces the element at the specified index.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void SetItem(
    int index,
    T item
)
Protected Overridable Sub SetItem ( _
    index As Integer, _
    item As T _
)
protected:
virtual void SetItem(
    int index,
    T item
)
Parameters
index (Int32)
The zero-based index of the element to replace.
item (T)
The new value for the element at the specified index. The value can be null for reference types.


ChannelFrameBase(T) Class

ChannelFrameBase<(Of <(<'T>)>)> Class
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)>
Represents the protocol independent common implementation of any frame of data that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class ChannelFrameBase<T> : ChannelBase,
    IChannelFrame<T>, IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable<IFrame>, IComparable<IFrame>, IComparable,
    ISerializable
where T : IChannelCell

<SerializableAttribute> _
Public MustInherit Class ChannelFrameBase(Of T As IChannelCell) _
    Inherits ChannelBase _
    Implements IChannelFrame(Of T), IChannelFrame, IChannel,  _
    ISupportBinaryImage, IFrame, IEquatable(Of IFrame), IComparable(Of IFrame),  _
    IComparable, ISerializable
[SerializableAttribute]
generic<typename T>
where T : IChannelCell
public ref class ChannelFrameBase abstract : public ChannelBase,
    IChannelFrame<T>, IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable<IFrame^>, IComparable<IFrame^>, IComparable,
    ISerializable
Generic Template Parameters
T
Specific IChannelCell type that the ChannelFrameBase<(Of <(<'T>)>)> contains.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChannelFrameBase<(Of <(<'T>)>)>(UInt16, IChannelCellCollection<(Of <<'(T>)>>), Ticks) | Creates a new ChannelFrameBase<(Of <(<'T>)>)> from specified parameters.
 | ChannelFrameBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext) | Creates a new ChannelFrameBase<(Of <(<'T>)>)> from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ChannelFrameBase<(Of <(<'T>)>)> object. (Overrides ChannelBase.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Overrides BinaryImageBase.BinaryImage()()()().)
 | BinaryLength | Gets the length of the BinaryImage. (Overrides BinaryImageBase.BinaryLength()()()().)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Overrides BinaryImageBase.BodyImage()()()().)
 | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBase.BodyLength()()()().)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer.
 | Cells | Gets the strongly-typed reference to the collection of cells for this ChannelFrameBase<(Of <(<'T>)>)>.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameType | Gets the FundamentalFrameType for this ChannelFrameBase<(Of <(<'T>)>)>.
 | GetHashCode()()()() | Returns the hash code for this instance. (Overrides Object.GetHashCode()()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Overrides BinaryImageBase.Initialize(array<Byte>[]()[][], Int32, Int32).)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>.
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides BinaryImageBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any.
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>.
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing).
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created).
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>.
 | State | Gets or sets the parsing state for the this ChannelFrameBase<(Of <(<'T>)>)>.
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>.
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

This phasor protocol implementation defines a "frame" as a collection of cells (logical units of data). For example, a DataCellBase could be defined as a PMU within a frame of data, a DataFrameBase (derived from ChannelFrameBase<(Of <(<'T>)>)>), that contains multiple PMU's coming from a PDC.

This class implements the IFrame interface so it can be cooperatively integrated into measurement concentration. For more information see the ConcentratorBase class.

Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase<(Of <(<'T>)>)>
 |  |  |  | CommandFrameBase
 |  |  |  | ConfigurationFrameBase
 |  |  |  | DataFrameBase
 |  |  |  | HeaderFrameBase


ChannelFrameBase(T) Constructor

ChannelFrameBase<(Of <(<'T>)>)> Constructor
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► ChannelFrameBase<(Of <(<'T>)>)>()()()()
Members
Icon | Member | Description
 | ChannelFrameBase<(Of <(<'T>)>)>(UInt16, IChannelCellCollection<(Of <<'(T>)>>), Ticks) | Creates a new ChannelFrameBase<(Of <(<'T>)>)> from specified parameters.
 | ChannelFrameBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext) | Creates a new ChannelFrameBase<(Of <(<'T>)>)> from serialization parameters.


ChannelFrameBase(T) Constructor (info, context)

ChannelFrameBase<(Of <(<'T>)>)> Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► ChannelFrameBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext)
Creates a new ChannelFrameBase<(Of <(<'T>)>)> from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelFrameBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ChannelFrameBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ChannelFrameBase(T) Constructor (idCode, cells, timestamp)

ChannelFrameBase<(Of <(<'T>)>)> Constructor (idCode, cells, timestamp)
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► ChannelFrameBase<(Of <(<'T>)>)>(UInt16, IChannelCellCollection<(Of <<'(T>)>>), Ticks)
Creates a new ChannelFrameBase<(Of <(<'T>)>)> from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelFrameBase(
    ushort idCode,
    IChannelCellCollection<T> cells,
    Ticks timestamp
)
Protected Sub New ( _
    idCode As UShort, _
    cells As IChannelCellCollection(Of T), _
    timestamp As Ticks _
)
protected:
ChannelFrameBase(
    unsigned short idCode,
    IChannelCellCollection<T>^ cells,
    Ticks timestamp
)
Parameters
idCode (UInt16)
The ID code of this ChannelFrameBase<(Of <(<'T>)>)>.
cells (IChannelCellCollection <(Of <(<' T >)>)>)
The reference to the collection of cells for this ChannelFrameBase<(Of <(<'T>)>)>.
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>.


AppendChecksum Method (buffer, startIndex)

AppendChecksum Method (buffer, startIndex)
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► AppendChecksum(array<Byte>[]()[][], Int32)
Appends checksum onto buffer starting at startIndex.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void AppendChecksum(
    byte[] buffer,
    int startIndex
)
Protected Overridable Sub AppendChecksum ( _
    buffer As Byte(), _
    startIndex As Integer _
)
protected:
virtual void AppendChecksum(
    array<unsigned char>^ buffer,
    int startIndex
)
Parameters
buffer (array< Byte >[]()[][])
Buffer image on which to append checksum.
startIndex (Int32)
Index into buffer where checksum should be appended.
Remarks
Default implementation encodes checksum in big-endian order and expects buffer size large enough to accomodate 2-byte checksum representation. Override method if protocol expectations are different.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ChannelFrameBase<(Of <(<'T>)>)> object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BinaryImage Property

BinaryImage Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► BinaryImage
Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public override byte[] BinaryImage { get; }
Public Overrides ReadOnly Property BinaryImage As Byte()
    Get
public:
virtual property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get () override;
}
Remarks
This property is overriden to include a checksum in the image.


BinaryLength Property

BinaryLength Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► BinaryLength
Gets the length of the BinaryImage.
Declaration Syntax
C# Visual Basic Visual C++
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
public:
virtual property int BinaryLength {
    int get () override;
}
Remarks
This property is overriden so the length can be extended to include a checksum.


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► BodyImage
Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}
Remarks
The body image of the ChannelFrameBase<(Of <(<'T>)>)> is the combined images of all the Cells.


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}
Remarks
The length of the ChannelFrameBase<(Of <(<'T>)>)> body image is the combined length of all the Cells.


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected MustOverride Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) abstract
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.
Remarks
Override with needed checksum calculation for particular protocol.
Examples
This example provides a CRC-CCITT checksum:
CopyC#
using TVA.IO.Checksums;

protected override ushort CalculateChecksum(byte[] buffer, int offset, int length)
{
    // Return calculated CRC-CCITT over given buffer...
    return buffer.CrcCCITTChecksum(offset, length);
}


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► Cells
Gets the strongly-typed reference to the collection of cells for this ChannelFrameBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IChannelCellCollection<T> Cells { get; }
Public Overridable ReadOnly Property Cells As IChannelCellCollection(Of T)
    Get
public:
virtual property IChannelCellCollection<T>^ Cells {
    IChannelCellCollection<T>^ get ();
}


ChecksumIsValid Method (buffer, startIndex)

ChecksumIsValid Method (buffer, startIndex)
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► ChecksumIsValid(array<Byte>[]()[][], Int32)
Determines if checksum in the buffer is valid.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overridable Function ChecksumIsValid ( _
    buffer As Byte(), _
    startIndex As Integer _
) As Boolean
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
)
Parameters
buffer (array< Byte >[]()[][])
Buffer image to validate.
startIndex (Int32)
Start index into buffer to perform checksum.
Return Value
Flag that determines if checksum over buffer is valid.
Remarks
Default implementation expects 2-byte big-endian ordered checksum. Override method if protocol checksum implementation is different.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► CompareTo(Object)
Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int CompareTo(
    Object obj
)
Public Overridable Function CompareTo ( _
    obj As Object _
) As Integer
public:
virtual int CompareTo(
    Object^ obj
)
Parameters
obj (Object)
The Object to compare with the current ChannelFrameBase<(Of <(<'T>)>)>.
Return Value
A 32-bit signed integer that indicates the relative order of the objects being compared.
Remarks
This frame implementation compares itself by timestamp.
Exceptions
Exception | Condition
ArgumentException | Object is not an IFrame.


CompareTo Method (other)

CompareTo Method (other)
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► CompareTo(IFrame)
Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int CompareTo(
    IFrame other
)
Public Overridable Function CompareTo ( _
    other As IFrame _
) As Integer
public:
virtual int CompareTo(
    IFrame^ other
)
Parameters
other (IFrame)
The IFrame to compare with the current ChannelFrameBase<(Of <(<'T>)>)>.
Return Value
A 32-bit signed integer that indicates the relative order of the objects being compared.
Remarks
This frame implementation compares itself by timestamp.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


Equals Method (obj)

Equals Method (obj)
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► Equals(Object)
Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)
The Object to compare with the current ChannelFrameBase<(Of <(<'T>)>)>.
Return Value
true if the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | Object is not an IFrame.


Equals Method (other)

Equals Method (other)
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► Equals(IFrame)
Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Equals(
    IFrame other
)
Public Overridable Function Equals ( _
    other As IFrame _
) As Boolean
public:
virtual bool Equals(
    IFrame^ other
)
Parameters
other (IFrame)
The IFrame to compare with the current ChannelFrameBase<(Of <(<'T>)>)>.
Return Value
true if the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>; otherwise, false.
Remarks
This frame implementation compares itself by timestamp.


FrameType Property

FrameType Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► FrameType
Gets the FundamentalFrameType for this ChannelFrameBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public abstract FundamentalFrameType FrameType { get; }
Public MustOverride ReadOnly Property FrameType As FundamentalFrameType
    Get
public:
virtual property FundamentalFrameType FrameType {
    FundamentalFrameType get () abstract;
}


GetHashCode Method

GetHashCode Method
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► GetHashCode()()()()
Returns the hash code for this instance.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
A 32-bit signed integer hash code.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► IDCode
Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ushort IDCode { get; set; }
Public Overridable Property IDCode As UShort
    Get
    Set
public:
virtual property unsigned short IDCode {
    unsigned short get ();
    void set (unsigned short value);
}


Initialize Method (binaryImage, startIndex, length)

Initialize Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► Initialize(array<Byte>[]()[][], Int32, Int32)
Parses the binary image.
Declaration Syntax
C# Visual Basic Visual C++
public override int Initialize(
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Overrides Function Initialize ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
public:
virtual int Initialize(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
This method is overriden to validate the checksum in the ChannelFrameBase<(Of <(<'T>)>)>.
Exceptions
Exception | Condition
InvalidOperationException | Invalid binary image detected - check sum did not match.


LastSortedMeasurement Property

LastSortedMeasurement Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► LastSortedMeasurement
Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public IMeasurement LastSortedMeasurement { get; set; }
Public Property LastSortedMeasurement As IMeasurement
    Get
    Set
public:
virtual property IMeasurement^ LastSortedMeasurement {
    IMeasurement^ get () sealed;
    void set (IMeasurement^ value) sealed;
}
Remarks
This value is used to help monitor slow moving measurements that are being sorted into the ChannelFrameBase<(Of <(<'T>)>)>.


Measurements Property

Measurements Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► Measurements
Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public ConcurrentDictionary Measurements { get; }
Public ReadOnly Property Measurements As ConcurrentDictionary
    Get
public:
virtual property ConcurrentDictionary^ Measurements {
    ConcurrentDictionary^ get () sealed;
}
Remarks
Represents a dictionary of measurements, keyed by MeasurementKey.


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
The body image of the ChannelFrameBase<(Of <(<'T>)>)> is parsed to create a collection of Cells.


ParsedBinaryLength Property

ParsedBinaryLength Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► ParsedBinaryLength
Gets the parsed binary length derived from the parsing state, if any.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual int ParsedBinaryLength { get; }
Protected Overridable ReadOnly Property ParsedBinaryLength As Integer
    Get
protected:
virtual property int ParsedBinaryLength {
    int get ();
}


Published Property

Published Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► Published
Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public bool Published { get; set; }
Public Property Published As Boolean
    Get
    Set
public:
virtual property bool Published {
    bool get () sealed;
    void set (bool value) sealed;
}


PublishedTimestamp Property

PublishedTimestamp Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► PublishedTimestamp
Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing).
Declaration Syntax
C# Visual Basic Visual C++
public virtual Ticks PublishedTimestamp { get; set; }
Public Overridable Property PublishedTimestamp As Ticks
    Get
    Set
public:
virtual property Ticks PublishedTimestamp {
    Ticks get ();
    void set (Ticks value);
}
Remarks

In the default implementation, setting this property will update all associated PublishedTimestamp()()()().

The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


ReceivedTimestamp Property

ReceivedTimestamp Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► ReceivedTimestamp
Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created).
Declaration Syntax
C# Visual Basic Visual C++
public virtual Ticks ReceivedTimestamp { get; set; }
Public Overridable Property ReceivedTimestamp As Ticks
    Get
    Set
public:
virtual property Ticks ReceivedTimestamp {
    Ticks get ();
    void set (Ticks value);
}
Remarks

In the default implementation, this timestamp will simply be the ticks of UtcNow()()()() of when this class was created.

The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


SortedMeasurements Property

SortedMeasurements Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► SortedMeasurements
Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public int SortedMeasurements { get; set; }
Public Property SortedMeasurements As Integer
    Get
    Set
public:
virtual property int SortedMeasurements {
    int get () sealed;
    void set (int value) sealed;
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► State
Gets or sets the parsing state for the this ChannelFrameBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IChannelFrameParsingState<T> State { get; set; }
Public Overridable Property State As IChannelFrameParsingState(Of T)
    Get
    Set
public:
virtual property IChannelFrameParsingState<T>^ State {
    IChannelFrameParsingState<T>^ get ();
    void set (IChannelFrameParsingState<T>^ value);
}


Timestamp Property

Timestamp Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► Timestamp
Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Ticks Timestamp { get; set; }
Public Overridable Property Timestamp As Ticks
    Get
    Set
public:
virtual property Ticks Timestamp {
    Ticks get ();
    void set (Ticks value);
}
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


TimeTag Property

TimeTag Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameBase<(Of <(<'T>)>)> ► TimeTag
Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual UnixTimeTag TimeTag { get; }
Public Overridable ReadOnly Property TimeTag As UnixTimeTag
    Get
public:
virtual property UnixTimeTag^ TimeTag {
    UnixTimeTag^ get ();
}


ChannelFrameCollectionBase(T) Class

ChannelFrameCollectionBase<(Of <(<'T>)>)> Class
Namespaces ► TVA.PhasorProtocols ► ChannelFrameCollectionBase<(Of <(<'T>)>)>
Represents a protocol independent collection of IChannelFrame objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class ChannelFrameCollectionBase<T> : ChannelCollectionBase<T>
where T : IChannelFrame

<SerializableAttribute> _
Public MustInherit Class ChannelFrameCollectionBase(Of T As IChannelFrame) _
    Inherits ChannelCollectionBase(Of T)
[SerializableAttribute]
generic<typename T>
where T : IChannelFrame
public ref class ChannelFrameCollectionBase abstract : public ChannelCollectionBase<T>
Generic Template Parameters
T
Specific IChannelFrame type that the ChannelFrameCollectionBase<(Of <(<'T>)>)> contains.
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChannelFrameCollectionBase<(Of <(<'T>)>)>(Int32) | Creates a new ChannelFrameCollectionBase<(Of <(<'T>)>)> using specified lastValidIndex.
 | ChannelFrameCollectionBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext) | Creates a new ChannelFrameCollectionBase<(Of <(<'T>)>)> from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Overrides ChannelCollectionBase <(Of <(<' T >)>)>.BinaryLength.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' T >)>)>
 |  | ChannelCollectionBase <(Of <(<' T >)>)>
 |  |  | ChannelFrameCollectionBase<(Of <(<'T>)>)>
 |  |  |  | ConfigurationFrameCollection
 |  |  |  | DataFrameCollection


ChannelFrameCollectionBase(T) Constructor

ChannelFrameCollectionBase<(Of <(<'T>)>)> Constructor
Namespaces ► TVA.PhasorProtocols ► ChannelFrameCollectionBase<(Of <(<'T>)>)> ► ChannelFrameCollectionBase<(Of <(<'T>)>)>()()()()
Members
Icon | Member | Description
 | ChannelFrameCollectionBase<(Of <(<'T>)>)>(Int32) | Creates a new ChannelFrameCollectionBase<(Of <(<'T>)>)> using specified lastValidIndex.
 | ChannelFrameCollectionBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext) | Creates a new ChannelFrameCollectionBase<(Of <(<'T>)>)> from serialization parameters.


ChannelFrameCollectionBase(T) Constructor (lastValidIndex)

ChannelFrameCollectionBase<(Of <(<'T>)>)> Constructor (lastValidIndex)
Namespaces ► TVA.PhasorProtocols ► ChannelFrameCollectionBase<(Of <(<'T>)>)> ► ChannelFrameCollectionBase<(Of <(<'T>)>)>(Int32)
Creates a new ChannelFrameCollectionBase<(Of <(<'T>)>)> using specified lastValidIndex.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelFrameCollectionBase(
    int lastValidIndex
)
Protected Sub New ( _
    lastValidIndex As Integer _
)
protected:
ChannelFrameCollectionBase(
    int lastValidIndex
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


ChannelFrameCollectionBase(T) Constructor (info, context)

ChannelFrameCollectionBase<(Of <(<'T>)>)> Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► ChannelFrameCollectionBase<(Of <(<'T>)>)> ► ChannelFrameCollectionBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext)
Creates a new ChannelFrameCollectionBase<(Of <(<'T>)>)> from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelFrameCollectionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ChannelFrameCollectionBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


BinaryLength Property

BinaryLength Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameCollectionBase<(Of <(<'T>)>)> ► BinaryLength
Gets the length of the BinaryImage.
Declaration Syntax
C# Visual Basic Visual C++
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
public:
virtual property int BinaryLength {
    int get () override;
}
Remarks
The length of the ChannelFrameCollectionBase<(Of <(<'T>)>)> binary image is the combined length of all the items in the collection.


ChannelFrameParsingStateBase(T) Class

ChannelFrameParsingStateBase<(Of <(<'T>)>)> Class
Namespaces ► TVA.PhasorProtocols ► ChannelFrameParsingStateBase<(Of <(<'T>)>)>
Represents the protocol independent common implementation of the parsing state used by any IChannelFrame.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class ChannelFrameParsingStateBase<T> : ChannelParsingStateBase,
    IChannelFrameParsingState<T>, IChannelParsingState
where T : IChannelCell

Public MustInherit Class ChannelFrameParsingStateBase(Of T As IChannelCell) _
    Inherits ChannelParsingStateBase _
    Implements IChannelFrameParsingState(Of T), IChannelParsingState
generic<typename T>
where T : IChannelCell
public ref class ChannelFrameParsingStateBase abstract : public ChannelParsingStateBase,
    IChannelFrameParsingState<T>, IChannelParsingState
Generic Template Parameters
T
Type of IChannelCell referenced by IChannelFrame being parsed.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChannelFrameParsingStateBase<(Of <(<'T>)>)>(Int32, CreateNewCellFunction<(Of <<'(T>)>>)) | Creates a new ChannelFrameParsingStateBase<(Of <(<'T>)>)> from specified parameters.
 | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed.
 | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ChannelParsingStateBase
 |  | ChannelFrameParsingStateBase<(Of <(<'T>)>)>
 |  |  | CommandFrameParsingState
 |  |  | ConfigurationFrameParsingState
 |  |  | DataFrameParsingState
 |  |  | HeaderFrameParsingState


ChannelFrameParsingStateBase(T) Constructor (parsedBinaryLength, createNewCellFunction)

ChannelFrameParsingStateBase<(Of <(<'T>)>)> Constructor (parsedBinaryLength, createNewCellFunction)
Namespaces ► TVA.PhasorProtocols ► ChannelFrameParsingStateBase<(Of <(<'T>)>)> ► ChannelFrameParsingStateBase<(Of <(<'T>)>)>(Int32, CreateNewCellFunction<(Of <<'(T>)>>))
Creates a new ChannelFrameParsingStateBase<(Of <(<'T>)>)> from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelFrameParsingStateBase(
    int parsedBinaryLength,
    CreateNewCellFunction<T> createNewCellFunction
)
Protected Sub New ( _
    parsedBinaryLength As Integer, _
    createNewCellFunction As CreateNewCellFunction(Of T) _
)
protected:
ChannelFrameParsingStateBase(
    int parsedBinaryLength,
    CreateNewCellFunction<T>^ createNewCellFunction
)
Parameters
parsedBinaryLength (Int32)
Binary length of the IChannelFrame being parsed.
createNewCellFunction (CreateNewCellFunction <(Of <(<' T >)>)>)
Reference to delegate to create new IChannelCell instances.


CellCount Property

CellCount Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameParsingStateBase<(Of <(<'T>)>)> ► CellCount
Gets or sets number of cells that are expected in associated IChannelFrame being parsed.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int CellCount { get; set; }
Public Overridable Property CellCount As Integer
    Get
    Set
public:
virtual property int CellCount {
    int get ();
    void set (int value);
}


CreateNewCell Property

CreateNewCell Property
Namespaces ► TVA.PhasorProtocols ► ChannelFrameParsingStateBase<(Of <(<'T>)>)> ► CreateNewCell
Gets reference to delegate used to create a new IChannelCell object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual CreateNewCellFunction<T> CreateNewCell { get; }
Public Overridable ReadOnly Property CreateNewCell As CreateNewCellFunction(Of T)
    Get
public:
virtual property CreateNewCellFunction<T>^ CreateNewCell {
    CreateNewCellFunction<T>^ get ();
}


ChannelParsingStateBase Class

ChannelParsingStateBase Class
Namespaces ► TVA.PhasorProtocols ► ChannelParsingStateBase
Represents the common implementation of the protocol independent parsing state class used by any kind of data.
This is the base class of all parsing state classes in the phasor protocols library; it is the root of the parsing state class hierarchy.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class ChannelParsingStateBase : IChannelParsingState
Public MustInherit Class ChannelParsingStateBase _
    Implements IChannelParsingState
public ref class ChannelParsingStateBase abstract : IChannelParsingState
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChannelParsingStateBase()()()() | Initializes a new instance of the ChannelParsingStateBase class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This class is inherited by subsequent classes to provide parsing state information particular to data type needs.
Inheritance Hierarchy
Object
 | ChannelParsingStateBase
 |  | ChannelCellParsingStateBase
 |  | ChannelFrameParsingStateBase<(Of <(<'T>)>)>


ChannelParsingStateBase Constructor

ChannelParsingStateBase Constructor
Namespaces ► TVA.PhasorProtocols ► ChannelParsingStateBase ► ChannelParsingStateBase()()()()
Initializes a new instance of the ChannelParsingStateBase class
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelParsingStateBase()
Protected Sub New
protected:
ChannelParsingStateBase()


ParsedBinaryLength Property

ParsedBinaryLength Property
Namespaces ► TVA.PhasorProtocols ► ChannelParsingStateBase ► ParsedBinaryLength
Gets or sets the length of the associated IChannel object being parsed from the binary image.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int ParsedBinaryLength { get; set; }
Public Overridable Property ParsedBinaryLength As Integer
    Get
    Set
public:
virtual property int ParsedBinaryLength {
    int get ();
    void set (int value);
}


ChannelValueBase(T) Class

ChannelValueBase<(Of <(<'T>)>)> Class
Namespaces ► TVA.PhasorProtocols ► ChannelValueBase<(Of <(<'T>)>)>
Represents the common implementation of the protocol independent representation of any kind of data value.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class ChannelValueBase<T> : ChannelBase,
    IChannelValue<T>, IChannel, ISupportBinaryImage, ISerializable
where T : IChannelDefinition

<SerializableAttribute> _
Public MustInherit Class ChannelValueBase(Of T As IChannelDefinition) _
    Inherits ChannelBase _
    Implements IChannelValue(Of T), IChannel, ISupportBinaryImage,  _
    ISerializable
[SerializableAttribute]
generic<typename T>
where T : IChannelDefinition
public ref class ChannelValueBase abstract : public ChannelBase,
    IChannelValue<T>, IChannel, ISupportBinaryImage, ISerializable
Generic Template Parameters
T
Generic type.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChannelValueBase<(Of <(<'T>)>)>(IDataCell, T) | Creates a new ChannelValueBase<(Of <(<'T>)>)> from specified parameters.
 | ChannelValueBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext) | Creates a new ChannelValueBase<(Of <(<'T>)>)> from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ChannelValueBase<(Of <(<'T>)>)> object. (Overrides ChannelBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage()()()() | (Inherited from BinaryImageBase.)
 | BodyLength()()()() | (Inherited from BinaryImageBase.)
 | CompositeValueCount | Gets total number of composite values that this ChannelValueBase<(Of <(<'T>)>)> provides.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>.
 | Definition | Gets or sets the IChannelDefinition associated with this ChannelValueBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this ChannelValueBase<(Of <(<'T>)>)>.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values.
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of ChannelValueBase<(Of <(<'T>)>)> have been assigned a value.
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>.
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the IDataCell parent of this ChannelValueBase<(Of <(<'T>)>)>.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase<(Of <(<'T>)>)>
 |  |  |  | AnalogValueBase
 |  |  |  | DigitalValueBase
 |  |  |  | FrequencyValueBase
 |  |  |  | PhasorValueBase


ChannelValueBase(T) Constructor

ChannelValueBase<(Of <(<'T>)>)> Constructor
Namespaces ► TVA.PhasorProtocols ► ChannelValueBase<(Of <(<'T>)>)> ► ChannelValueBase<(Of <(<'T>)>)>()()()()
Members
Icon | Member | Description
 | ChannelValueBase<(Of <(<'T>)>)>(IDataCell, T) | Creates a new ChannelValueBase<(Of <(<'T>)>)> from specified parameters.
 | ChannelValueBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext) | Creates a new ChannelValueBase<(Of <(<'T>)>)> from serialization parameters.


ChannelValueBase(T) Constructor (info, context)

ChannelValueBase<(Of <(<'T>)>)> Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► ChannelValueBase<(Of <(<'T>)>)> ► ChannelValueBase<(Of <(<'T>)>)>(SerializationInfo, StreamingContext)
Creates a new ChannelValueBase<(Of <(<'T>)>)> from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelValueBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ChannelValueBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ChannelValueBase(T) Constructor (parent, channelDefinition)

ChannelValueBase<(Of <(<'T>)>)> Constructor (parent, channelDefinition)
Namespaces ► TVA.PhasorProtocols ► ChannelValueBase<(Of <(<'T>)>)> ► ChannelValueBase<(Of <(<'T>)>)>(IDataCell, T)
Creates a new ChannelValueBase<(Of <(<'T>)>)> from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelValueBase(
    IDataCell parent,
    T channelDefinition
)
Protected Sub New ( _
    parent As IDataCell, _
    channelDefinition As T _
)
protected:
ChannelValueBase(
    IDataCell^ parent,
    T channelDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this ChannelValueBase<(Of <(<'T>)>)>.
channelDefinition (T)
The IChannelDefinition associated with this ChannelValueBase<(Of <(<'T>)>)>.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueBase<(Of <(<'T>)>)> ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ChannelValueBase<(Of <(<'T>)>)> object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


CompositeValueCount Property

CompositeValueCount Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueBase<(Of <(<'T>)>)> ► CompositeValueCount
Gets total number of composite values that this ChannelValueBase<(Of <(<'T>)>)> provides.
Declaration Syntax
C# Visual Basic Visual C++
public abstract int CompositeValueCount { get; }
Public MustOverride ReadOnly Property CompositeValueCount As Integer
    Get
public:
virtual property int CompositeValueCount {
    int get () abstract;
}


DataFormat Property

DataFormat Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueBase<(Of <(<'T>)>)> ► DataFormat
Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataFormat DataFormat { get; }
Public Overridable ReadOnly Property DataFormat As DataFormat
    Get
public:
virtual property DataFormat DataFormat {
    DataFormat get ();
}


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueBase<(Of <(<'T>)>)> ► Definition
Gets or sets the IChannelDefinition associated with this ChannelValueBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual T Definition { get; set; }
Public Overridable Property Definition As T
    Get
    Set
public:
virtual property T Definition {
    T get ();
    void set (T value);
}


GetCompositeValue Method (index)

GetCompositeValue Method (index)
Namespaces ► TVA.PhasorProtocols ► ChannelValueBase<(Of <(<'T>)>)> ► GetCompositeValue(Int32)
Gets the specified composite value of this ChannelValueBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public abstract double GetCompositeValue(
    int index
)
Public MustOverride Function GetCompositeValue ( _
    index As Integer _
) As Double
public:
virtual double GetCompositeValue(
    int index
) abstract
Parameters
index (Int32)
Index of composite value to retrieve.
Return Value
A Double representing the composite value.
Remarks
Some ChannelValueBase<(Of <(<'T>)>)> implementations can contain more than one value, this method is used to abstractly expose each value.


GetMeasurementValueFilterFunction Method (index)

GetMeasurementValueFilterFunction Method (index)
Namespaces ► TVA.PhasorProtocols ► ChannelValueBase<(Of <(<'T>)>)> ► GetMeasurementValueFilterFunction(Int32)
Gets function used to apply a downsampling filter over a sequence of IMeasurement values.
Declaration Syntax
C# Visual Basic Visual C++
public virtual MeasurementValueFilterFunction GetMeasurementValueFilterFunction(
    int index
)
Public Overridable Function GetMeasurementValueFilterFunction ( _
    index As Integer _
) As MeasurementValueFilterFunction
public:
virtual MeasurementValueFilterFunction^ GetMeasurementValueFilterFunction(
    int index
)
Parameters
index (Int32)
Index of composite value for which to retrieve its filter function.
Return Value
Function used to apply a downsampling filter over a sequence of IMeasurement values, if defined; otherwise, null.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► ChannelValueBase<(Of <(<'T>)>)> ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


IsEmpty Property

IsEmpty Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueBase<(Of <(<'T>)>)> ► IsEmpty
Gets boolean value that determines if none of the composite values of ChannelValueBase<(Of <(<'T>)>)> have been assigned a value.
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool IsEmpty { get; }
Public MustOverride ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get () abstract;
}
Return Value
true, if no composite values have been assigned a value; otherwise, false.


Label Property

Label Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueBase<(Of <(<'T>)>)> ► Label
Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Label { get; }
Public Overridable ReadOnly Property Label As String
    Get
public:
virtual property String^ Label {
    String^ get ();
}


Measurements Property

Measurements Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueBase<(Of <(<'T>)>)> ► Measurements
Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IMeasurement[] Measurements { get; }
Public Overridable ReadOnly Property Measurements As IMeasurement()
    Get
public:
virtual property array<IMeasurement^>^ Measurements {
    array<IMeasurement^>^ get ();
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueBase<(Of <(<'T>)>)> ► Parent
Gets or sets the IDataCell parent of this ChannelValueBase<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IDataCell Parent { get; set; }
Public Overridable Property Parent As IDataCell
    Get
    Set
public:
virtual property IDataCell^ Parent {
    IDataCell^ get ();
    void set (IDataCell^ value);
}


ChannelValueCollectionBase(TDefinition, TValue) Class

ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> Class
Namespaces ► TVA.PhasorProtocols ► ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>
Represents a protocol independent collection of IChannelValue<(Of <(<'T>)>)> objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class ChannelValueCollectionBase<TDefinition, TValue> : ChannelCollectionBase<TValue>
where TDefinition : IChannelDefinition
where TValue : IChannelValue<T>

<SerializableAttribute> _
Public MustInherit Class ChannelValueCollectionBase(Of TDefinition As IChannelDefinition, TValue As IChannelValue(Of T)) _
    Inherits ChannelCollectionBase(Of TValue)
[SerializableAttribute]
generic<typename TDefinition, typename TValue>
where TDefinition : IChannelDefinition
where TValue : IChannelValue<T>
public ref class ChannelValueCollectionBase abstract : public ChannelCollectionBase<TValue>
Generic Template Parameters
TDefinition
Specific IChannelDefinition type that the IChannelValue<(Of <(<'T>)>)> references.
TValue
Specific IChannelValue<(Of <(<'T>)>)> type that the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> contains.
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>(Int32) | Creates a new ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> using specified lastValidIndex.
 | ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>(SerializationInfo, StreamingContext) | Creates a new ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'TValue>)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | AllValuesAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> object. (Overrides ChannelCollectionBase <(Of <(<'TValue>)>)>.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Overrides ChannelCollectionBase <(Of <(<'TValue>)>)>.BinaryLength.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'TValue>)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>. (Overrides ChannelCollectionBase <(Of <(<'TValue>)>)>.ClearItems()()()().)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'TValue>)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<'TValue>)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'TValue>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'TValue>)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCollectionBase <(Of <(<'TValue>)>)>.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'TValue>)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<'TValue>)>)>.)
 | InsertItem(Int32, TValue) | Inserts an element into the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> at the specified index. (Overrides ChannelCollectionBase <(Of <(<'TValue>)>)>.InsertItem(Int32, T).)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<'TValue>)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'TValue>)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'TValue>)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<'TValue>)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>. (Overrides ChannelCollectionBase <(Of <(<'TValue>)>)>.RemoveItem(Int32).)
 | SetItem(Int32, TValue) | Replaces the element at the specified index. (Overrides ChannelCollectionBase <(Of <(<'TValue>)>)>.SetItem(Int32, T).)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<'TValue>)>)>
 |  | ChannelCollectionBase <(Of <(<'TValue>)>)>
 |  |  | ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>
 |  |  |  | AnalogValueCollection
 |  |  |  | DigitalValueCollection
 |  |  |  | FrequencyValueCollection
 |  |  |  | PhasorValueCollection


ChannelValueCollectionBase(TDefinition, TValue) Constructor

ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> Constructor
Namespaces ► TVA.PhasorProtocols ► ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> ► ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>()()()()
Members
Icon | Member | Description
 | ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>(Int32) | Creates a new ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> using specified lastValidIndex.
 | ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>(SerializationInfo, StreamingContext) | Creates a new ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> from serialization parameters.


ChannelValueCollectionBase(TDefinition, TValue) Constructor (lastValidIndex)

ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> Constructor (lastValidIndex)
Namespaces ► TVA.PhasorProtocols ► ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> ► ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>(Int32)
Creates a new ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> using specified lastValidIndex.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelValueCollectionBase(
    int lastValidIndex
)
Protected Sub New ( _
    lastValidIndex As Integer _
)
protected:
ChannelValueCollectionBase(
    int lastValidIndex
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


ChannelValueCollectionBase(TDefinition, TValue) Constructor (info, context)

ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> ► ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>(SerializationInfo, StreamingContext)
Creates a new ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ChannelValueCollectionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ChannelValueCollectionBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


AllValuesAssigned Property

AllValuesAssigned Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> ► AllValuesAssigned
Gets a boolean value indicating if all of the composite values have been assigned a value.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool AllValuesAssigned { get; }
Public Overridable ReadOnly Property AllValuesAssigned As Boolean
    Get
public:
virtual property bool AllValuesAssigned {
    bool get ();
}
Return Value
true, if all composite values have been assigned a value; otherwise, false.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> ► Attributes
Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BinaryLength Property

BinaryLength Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> ► BinaryLength
Gets the length of the BinaryImage.
Declaration Syntax
C# Visual Basic Visual C++
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
public:
virtual property int BinaryLength {
    int get () override;
}


ClearItems Method

ClearItems Method
Namespaces ► TVA.PhasorProtocols ► ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> ► ClearItems()()()()
Removes all elements from the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
protected override void ClearItems()
Protected Overrides Sub ClearItems
protected:
virtual void ClearItems() override


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


InsertItem Method (index, item)

InsertItem Method (index, item)
Namespaces ► TVA.PhasorProtocols ► ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> ► InsertItem(Int32, TValue)
Inserts an element into the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> at the specified index.
Declaration Syntax
C# Visual Basic Visual C++
protected override void InsertItem(
    int index,
    TValue item
)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As TValue _
)
protected:
virtual void InsertItem(
    int index,
    TValue item
) override
Parameters
index (Int32)
The zero-based index at which item should be inserted.
item (TValue)
The object to insert.


RemoveItem Method (index)

RemoveItem Method (index)
Namespaces ► TVA.PhasorProtocols ► ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> ► RemoveItem(Int32)
Removes the element at the specified index of the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)
protected:
virtual void RemoveItem(
    int index
) override
Parameters
index (Int32)
The zero-based index of the element to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.


SetItem Method (index, item)

SetItem Method (index, item)
Namespaces ► TVA.PhasorProtocols ► ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> ► SetItem(Int32, TValue)
Replaces the element at the specified index.
Declaration Syntax
C# Visual Basic Visual C++
protected override void SetItem(
    int index,
    TValue item
)
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As TValue _
)
protected:
virtual void SetItem(
    int index,
    TValue item
) override
Parameters
index (Int32)
The zero-based index of the element to replace.
item (TValue)
The new value for the element at the specified index. The value can be null for reference types.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.


ChannelValueMeasurement(T) Class

ChannelValueMeasurement<(Of <(<'T>)>)> Class
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)>
Represents a IMeasurement implementation for composite values of a given IChannelValue<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public class ChannelValueMeasurement<T> : IMeasurement,
    ITimeSeriesValue<double>, ITimeSeriesValue, IEquatable<ITimeSeriesValue>, IComparable<ITimeSeriesValue>,
    IComparable
where T : IChannelDefinition

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Class ChannelValueMeasurement(Of T As IChannelDefinition) _
    Implements IMeasurement, ITimeSeriesValue(Of Double),  _
    ITimeSeriesValue, IEquatable(Of ITimeSeriesValue), IComparable(Of ITimeSeriesValue),  _
    IComparable
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
generic<typename T>
where T : IChannelDefinition
public ref class ChannelValueMeasurement : IMeasurement,
    ITimeSeriesValue<double>, ITimeSeriesValue, IEquatable<ITimeSeriesValue^>, IComparable<ITimeSeriesValue^>,
    IComparable
Generic Template Parameters
T
Generic type T.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChannelValueMeasurement<(Of <(<'T>)>)>(IChannelValue<(Of <<'(T>)>>), Int32) | Constructs a new ChannelValueMeasurement<(Of <(<'T>)>)> given the specified parameters.
 | Adder | Gets or sets an offset to add to the measurement value. This defaults to 0.0.
 | AdjustedValue | Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets.
 | CompareTo(ITimeSeriesValue) | Compares the ChannelValueMeasurement<(Of <(<'T>)>)> with an ITimeSeriesValue.
 | CompareTo(Object) | Compares the ChannelValueMeasurement<(Of <(<'T>)>)> with the specified Object.
 | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current ChannelValueMeasurement<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelValueMeasurement<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Get the hash code for the ChannelValueMeasurement<(Of <(<'T>)>)>.MeasurementKey. (Overrides Object.GetHashCode()()()().)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the Guid based signal ID of this ChannelValueMeasurement<(Of <(<'T>)>)>, if available.
 | Key | Gets the primary key (a MeasurementKey, of this ChannelValueMeasurement<(Of <(<'T>)>)>.
 | MeasurementValueFilter | Gets or sets function used to apply a downsampling filter over a sequence of IMeasurement values.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Multiplier | Defines a mulplicative offset to apply to the measurement value. This defaults to 1.0.
 | Parent | Gets or sets reference to the IChannelValue<(Of <(<'T>)>)> that this measurement derives its values from.
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelValueMeasurement<(Of <(<'T>)>)> was published (post-processing).
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelValueMeasurement<(Of <(<'T>)>)> was received (i.e., created).
 | StateFlags | Gets or sets MeasurementStateFlags associated with this ChannelValueMeasurement<(Of <(<'T>)>)>.
 | TagName | Gets or sets the text based tag name of this ChannelValueMeasurement<(Of <(<'T>)>)>.
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelValueMeasurement<(Of <(<'T>)>)>.
 | ToString()()()() | Returns a String that represents the current ChannelValueMeasurement<(Of <(<'T>)>)>. (Overrides Object.ToString()()()().)
 | Value | Gets or sets the raw measurement value that is not offset by Adder and Multiplier.
 | ValueIndex | Gets or sets index into the GetCompositeValue(Int32) that this measurement derives its value from.
Inheritance Hierarchy
Object
ChannelValueMeasurement<(Of <(<'T>)>)>


ChannelValueMeasurement(T) Constructor (parent, valueIndex)

ChannelValueMeasurement<(Of <(<'T>)>)> Constructor (parent, valueIndex)
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► ChannelValueMeasurement<(Of <(<'T>)>)>(IChannelValue<(Of <<'(T>)>>), Int32)
Constructs a new ChannelValueMeasurement<(Of <(<'T>)>)> given the specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ChannelValueMeasurement(
    IChannelValue<T> parent,
    int valueIndex
)
Public Sub New ( _
    parent As IChannelValue(Of T), _
    valueIndex As Integer _
)
public:
ChannelValueMeasurement(
    IChannelValue<T>^ parent,
    int valueIndex
)
Parameters
parent (IChannelValue <(Of <(<' T >)>)>)
The reference to the IChannelValue<(Of <(<'T>)>)> that this measurement derives its values from.
valueIndex (Int32)
The index into the GetCompositeValue(Int32) that this measurement derives its value from.


Adder Property

Adder Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► Adder
Gets or sets an offset to add to the measurement value. This defaults to 0.0.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Adder { get; set; }
Public Overridable Property Adder As Double
    Get
    Set
public:
virtual property double Adder {
    double get ();
    void set (double value);
}


AdjustedValue Property

AdjustedValue Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► AdjustedValue
Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double AdjustedValue { get; }
Public Overridable ReadOnly Property AdjustedValue As Double
    Get
public:
virtual property double AdjustedValue {
    double get ();
}
Return Value
Value offset by Adder and Multiplier (i.e., Value * Multiplier + Adder).
Remarks
Note that returned value will be offset by Adder and Multiplier.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(ITimeSeriesValue) | Compares the ChannelValueMeasurement<(Of <(<'T>)>)> with an ITimeSeriesValue.
 | CompareTo(Object) | Compares the ChannelValueMeasurement<(Of <(<'T>)>)> with the specified Object.


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► CompareTo(Object)
Compares the ChannelValueMeasurement<(Of <(<'T>)>)> with the specified Object.
Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    Object obj
)
Public Function CompareTo ( _
    obj As Object _
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
Parameters
obj (Object)
The Object to compare with the current ChannelValueMeasurement<(Of <(<'T>)>)>.
Return Value
A 32-bit signed integer that indicates the relative order of the objects being compared.
Remarks
Measurement implementations should compare by hash code.
Exceptions
Exception | Condition
ArgumentException | obj is not an IMeasurement.


CompareTo Method (other)

CompareTo Method (other)
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► CompareTo(ITimeSeriesValue)
Compares the ChannelValueMeasurement<(Of <(<'T>)>)> with an ITimeSeriesValue.
Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    ITimeSeriesValue other
)
Public Function CompareTo ( _
    other As ITimeSeriesValue _
) As Integer
public:
virtual int CompareTo(
    ITimeSeriesValue^ other
) sealed
Parameters
other (ITimeSeriesValue)
The ITimeSeriesValue to compare with the current ChannelValueMeasurement<(Of <(<'T>)>)>.
Return Value
A 32-bit signed integer that indicates the relative order of the objects being compared.
Remarks
Measurement implementations should compare by hash code.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► Equals()()()()
Members
Icon | Member | Description
 | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current ChannelValueMeasurement<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelValueMeasurement<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


Equals Method (obj)

Equals Method (obj)
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► Equals(Object)
Determines whether the specified Object is equal to the current ChannelValueMeasurement<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)
The Object to compare with the current ChannelValueMeasurement<(Of <(<'T>)>)>.
Return Value
true if the specified Object is equal to the current ChannelValueMeasurement<(Of <(<'T>)>)>; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | obj is not an IMeasurement.


Equals Method (other)

Equals Method (other)
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► Equals(ITimeSeriesValue)
Determines whether the specified ITimeSeriesValue is equal to the current ChannelValueMeasurement<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    ITimeSeriesValue other
)
Public Function Equals ( _
    other As ITimeSeriesValue _
) As Boolean
public:
virtual bool Equals(
    ITimeSeriesValue^ other
) sealed
Parameters
other (ITimeSeriesValue)
The ITimeSeriesValue to compare with the current ChannelValueMeasurement<(Of <(<'T>)>)>.
Return Value
true if the specified ITimeSeriesValue is equal to the current ChannelValueMeasurement<(Of <(<'T>)>)>; otherwise, false.


GetHashCode Method

GetHashCode Method
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► GetHashCode()()()()
Get the hash code for the ChannelValueMeasurement<(Of <(<'T>)>)>.MeasurementKey.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
Hash code for the ChannelValueMeasurement<(Of <(<'T>)>)>.MeasurementKey.


ID Property

ID Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► ID
Gets or sets the Guid based signal ID of this ChannelValueMeasurement<(Of <(<'T>)>)>, if available.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Guid ID { get; set; }
Public Overridable Property ID As Guid
    Get
    Set
public:
virtual property Guid ID {
    Guid get ();
    void set (Guid value);
}


Key Property

Key Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► Key
Gets the primary key (a MeasurementKey, of this ChannelValueMeasurement<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual MeasurementKey Key { get; set; }
Public Overridable Property Key As MeasurementKey
    Get
    Set
public:
virtual property MeasurementKey Key {
    MeasurementKey get ();
    void set (MeasurementKey value);
}


MeasurementValueFilter Property

MeasurementValueFilter Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► MeasurementValueFilter
Gets or sets function used to apply a downsampling filter over a sequence of IMeasurement values.
Declaration Syntax
C# Visual Basic Visual C++
public virtual MeasurementValueFilterFunction MeasurementValueFilter { get; set; }
Public Overridable Property MeasurementValueFilter As MeasurementValueFilterFunction
    Get
    Set
public:
virtual property MeasurementValueFilterFunction^ MeasurementValueFilter {
    MeasurementValueFilterFunction^ get ();
    void set (MeasurementValueFilterFunction^ value);
}


Multiplier Property

Multiplier Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► Multiplier
Defines a mulplicative offset to apply to the measurement value. This defaults to 1.0.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Multiplier { get; set; }
Public Overridable Property Multiplier As Double
    Get
    Set
public:
virtual property double Multiplier {
    double get ();
    void set (double value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► Parent
Gets or sets reference to the IChannelValue<(Of <(<'T>)>)> that this measurement derives its values from.
Declaration Syntax
C# Visual Basic Visual C++
public IChannelValue<T> Parent { get; set; }
Public Property Parent As IChannelValue(Of T)
    Get
    Set
public:
property IChannelValue<T>^ Parent {
    IChannelValue<T>^ get ();
    void set (IChannelValue<T>^ value);
}


PublishedTimestamp Property

PublishedTimestamp Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► PublishedTimestamp
Gets or sets exact timestamp, in ticks, of when this ChannelValueMeasurement<(Of <(<'T>)>)> was published (post-processing).
Declaration Syntax
C# Visual Basic Visual C++
public virtual Ticks PublishedTimestamp { get; set; }
Public Overridable Property PublishedTimestamp As Ticks
    Get
    Set
public:
virtual property Ticks PublishedTimestamp {
    Ticks get ();
    void set (Ticks value);
}
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


ReceivedTimestamp Property

ReceivedTimestamp Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► ReceivedTimestamp
Gets or sets exact timestamp, in ticks, of when this ChannelValueMeasurement<(Of <(<'T>)>)> was received (i.e., created).
Declaration Syntax
C# Visual Basic Visual C++
public virtual Ticks ReceivedTimestamp { get; set; }
Public Overridable Property ReceivedTimestamp As Ticks
    Get
    Set
public:
virtual property Ticks ReceivedTimestamp {
    Ticks get ();
    void set (Ticks value);
}
Remarks

In the default implementation, this timestamp will simply be the ticks of UtcNow()()()() of when this class was created.

The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


StateFlags Property

StateFlags Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► StateFlags
Gets or sets MeasurementStateFlags associated with this ChannelValueMeasurement<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual MeasurementStateFlags StateFlags { get; set; }
Public Overridable Property StateFlags As MeasurementStateFlags
    Get
    Set
public:
virtual property MeasurementStateFlags StateFlags {
    MeasurementStateFlags get ();
    void set (MeasurementStateFlags value);
}


TagName Property

TagName Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► TagName
Gets or sets the text based tag name of this ChannelValueMeasurement<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string TagName { get; set; }
Public Overridable Property TagName As String
    Get
    Set
public:
virtual property String^ TagName {
    String^ get ();
    void set (String^ value);
}


Timestamp Property

Timestamp Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► Timestamp
Gets or sets exact timestamp, in ticks, of the data represented by this ChannelValueMeasurement<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Ticks Timestamp { get; set; }
Public Overridable Property Timestamp As Ticks
    Get
    Set
public:
virtual property Ticks Timestamp {
    Ticks get ();
    void set (Ticks value);
}
Remarks
This value returns timestamp of parent data frame unless assigned an alternate value.
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


ToString Method

ToString Method
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► ToString()()()()
Returns a String that represents the current ChannelValueMeasurement<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents the current ChannelValueMeasurement<(Of <(<'T>)>)>.


Value Property

Value Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► Value
Gets or sets the raw measurement value that is not offset by Adder and Multiplier.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Value { get; set; }
Public Overridable Property Value As Double
    Get
    Set
public:
virtual property double Value {
    double get ();
    void set (double value);
}
Return Value
Raw value of this ChannelValueMeasurement<(Of <(<'T>)>)> (i.e., value that is not offset by Adder and Multiplier).


ValueIndex Property

ValueIndex Property
Namespaces ► TVA.PhasorProtocols ► ChannelValueMeasurement<(Of <(<'T>)>)> ► ValueIndex
Gets or sets index into the GetCompositeValue(Int32) that this measurement derives its value from.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int ValueIndex { get; set; }
Public Overridable Property ValueIndex As Integer
    Get
    Set
public:
virtual property int ValueIndex {
    int get ();
    void set (int value);
}


CommandCell Class

CommandCell Class
Namespaces ► TVA.PhasorProtocols ► CommandCell
Represents the protocol independent common implementation of an element of extended data for cells in a ICommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CommandCell : ChannelCellBase,
    ICommandCell, IChannelCell, IChannel, ISupportBinaryImage, ISerializable
<SerializableAttribute> _
Public Class CommandCell _
    Inherits ChannelCellBase _
    Implements ICommandCell, IChannelCell, IChannel, ISupportBinaryImage,  _
    ISerializable
[SerializableAttribute]
public ref class CommandCell : public ChannelCellBase,
    ICommandCell, IChannelCell, IChannel, ISupportBinaryImage, ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandCell(ICommandFrame, Byte) | Creates a new CommandCell from specified parameters.
 | CommandCell(SerializationInfo, StreamingContext) | Creates a new CommandCell from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the CommandCell object. (Overrides ChannelCellBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the CommandCell object. (Overrides BinaryImageBase.BodyImage()()()().)
 | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBase.BodyLength()()()().)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtendedDataByte | Gets or sets extended data Byte that represents this CommandCell.
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCellBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets a reference to the parent ICommandFrame for this CommandCell.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides BinaryImageBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from ChannelCellBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | CommandCell


CommandCell Constructor

CommandCell Constructor
Namespaces ► TVA.PhasorProtocols ► CommandCell ► CommandCell()()()()
Members
Icon | Member | Description
 | CommandCell(ICommandFrame, Byte) | Creates a new CommandCell from specified parameters.
 | CommandCell(SerializationInfo, StreamingContext) | Creates a new CommandCell from serialization parameters.


CommandCell Constructor (info, context)

CommandCell Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► CommandCell ► CommandCell(SerializationInfo, StreamingContext)
Creates a new CommandCell from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected CommandCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CommandCell(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


CommandCell Constructor (parent, extendedDataByte)

CommandCell Constructor (parent, extendedDataByte)
Namespaces ► TVA.PhasorProtocols ► CommandCell ► CommandCell(ICommandFrame, Byte)
Creates a new CommandCell from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public CommandCell(
    ICommandFrame parent,
    byte extendedDataByte
)
Public Sub New ( _
    parent As ICommandFrame, _
    extendedDataByte As Byte _
)
public:
CommandCell(
    ICommandFrame^ parent,
    unsigned char extendedDataByte
)
Parameters
parent (ICommandFrame)
A reference to the parent ICommandFrame for this CommandCell.
extendedDataByte (Byte)
Extended data Byte that represents this CommandCell.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► CommandCell ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the CommandCell object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols ► CommandCell ► BodyImage
Gets the binary body image of the CommandCell object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols ► CommandCell ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}


ExtendedDataByte Property

ExtendedDataByte Property
Namespaces ► TVA.PhasorProtocols ► CommandCell ► ExtendedDataByte
Gets or sets extended data Byte that represents this CommandCell.
Declaration Syntax
C# Visual Basic Visual C++
public virtual byte ExtendedDataByte { get; set; }
Public Overridable Property ExtendedDataByte As Byte
    Get
    Set
public:
virtual property unsigned char ExtendedDataByte {
    unsigned char get ();
    void set (unsigned char value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► CommandCell ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► CommandCell ► Parent
Gets or sets a reference to the parent ICommandFrame for this CommandCell.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ICommandFrame Parent { get; set; }
Public Overridable Property Parent As ICommandFrame
    Get
    Set
public:
virtual property ICommandFrame^ Parent {
    ICommandFrame^ get ();
    void set (ICommandFrame^ value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols ► CommandCell ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


CommandCellCollection Class

CommandCellCollection Class
Namespaces ► TVA.PhasorProtocols ► CommandCellCollection
Represents a protocol independent collection of ICommandCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CommandCellCollection : ChannelCellCollectionBase<ICommandCell>
<SerializableAttribute> _
Public Class CommandCellCollection _
    Inherits ChannelCellCollectionBase(Of ICommandCell)
[SerializableAttribute]
public ref class CommandCellCollection : public ChannelCellCollectionBase<ICommandCell^>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandCellCollection(Int32) | Creates a new CommandCellCollection using specified lastValidIndex.
 | CommandCellCollection(SerializationInfo, StreamingContext) | Creates a new CommandCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ICommandCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ICommandCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ICommandCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' ICommandCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ICommandCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ICommandCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ICommandCell >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' ICommandCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' ICommandCell >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ICommandCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ICommandCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ICommandCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' ICommandCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' ICommandCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' ICommandCell >)>)>
 |  |  |  | CommandCellCollection


CommandCellCollection Constructor

CommandCellCollection Constructor
Namespaces ► TVA.PhasorProtocols ► CommandCellCollection ► CommandCellCollection()()()()
Members
Icon | Member | Description
 | CommandCellCollection(Int32) | Creates a new CommandCellCollection using specified lastValidIndex.
 | CommandCellCollection(SerializationInfo, StreamingContext) | Creates a new CommandCellCollection from serialization parameters.


CommandCellCollection Constructor (lastValidIndex)

CommandCellCollection Constructor (lastValidIndex)
Namespaces ► TVA.PhasorProtocols ► CommandCellCollection ► CommandCellCollection(Int32)
Creates a new CommandCellCollection using specified lastValidIndex.
Declaration Syntax
C# Visual Basic Visual C++
public CommandCellCollection(
    int lastValidIndex
)
Public Sub New ( _
    lastValidIndex As Integer _
)
public:
CommandCellCollection(
    int lastValidIndex
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


CommandCellCollection Constructor (info, context)

CommandCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► CommandCellCollection ► CommandCellCollection(SerializationInfo, StreamingContext)
Creates a new CommandCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected CommandCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CommandCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


CommandFrameBase Class

CommandFrameBase Class
Namespaces ► TVA.PhasorProtocols ► CommandFrameBase
Represents the protocol independent common implementation of any ICommandFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class CommandFrameBase : ChannelFrameBase<ICommandCell>,
    ICommandFrame, IChannelFrame<ICommandCell>, IChannelFrame, IChannel,
    ISupportBinaryImage, IFrame, IEquatable<IFrame>, IComparable<IFrame>,
    IComparable, ISerializable
<SerializableAttribute> _
Public MustInherit Class CommandFrameBase _
    Inherits ChannelFrameBase(Of ICommandCell) _
    Implements ICommandFrame, IChannelFrame(Of ICommandCell),  _
    IChannelFrame, IChannel, ISupportBinaryImage, IFrame, IEquatable(Of IFrame),  _
    IComparable(Of IFrame), IComparable, ISerializable
[SerializableAttribute]
public ref class CommandFrameBase abstract : public ChannelFrameBase<ICommandCell^>,
    ICommandFrame, IChannelFrame<ICommandCell^>, IChannelFrame, IChannel,
    ISupportBinaryImage, IFrame, IEquatable<IFrame^>, IComparable<IFrame^>,
    IComparable, ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandFrameBase(CommandCellCollection, DeviceCommand) | Creates a new CommandFrameBase from specified parameters.
 | CommandFrameBase(SerializationInfo, StreamingContext) | Creates a new CommandFrameBase from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the CommandFrameBase object. (Overrides ChannelFrameBase <(Of <(<' ICommandCell >)>)>.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this CommandFrameBase. (Overrides ChannelFrameBase <(Of <(<' ICommandCell >)>)>.BodyImage.)
 | BodyLength | Gets the length of the BodyImage. (Overrides ChannelFrameBase <(Of <(<' ICommandCell >)>)>.BodyLength.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Cells | Gets reference to the CommandCellCollection for this CommandFrameBase.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Command | Gets or sets the DeviceCommand for this CommandFrameBase.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ExtendedData | Gets or sets extended binary image data for this CommandFrameBase.
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Overrides ChannelFrameBase <(Of <(<' ICommandCell >)>)>.FrameType.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelFrameBase <(Of <(<' ICommandCell >)>)>.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides ChannelFrameBase <(Of <(<' ICommandCell >)>)>.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this CommandFrameBase.
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' ICommandCell >)>)>
 |  |  |  | CommandFrameBase
 |  |  |  |  | CommandFrame
 |  |  |  |  | CommandFrame
 |  |  |  |  | CommandFrame
 |  |  |  |  | CommandFrame


CommandFrameBase Constructor

CommandFrameBase Constructor
Namespaces ► TVA.PhasorProtocols ► CommandFrameBase ► CommandFrameBase()()()()
Members
Icon | Member | Description
 | CommandFrameBase(CommandCellCollection, DeviceCommand) | Creates a new CommandFrameBase from specified parameters.
 | CommandFrameBase(SerializationInfo, StreamingContext) | Creates a new CommandFrameBase from serialization parameters.


CommandFrameBase Constructor (info, context)

CommandFrameBase Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► CommandFrameBase ► CommandFrameBase(SerializationInfo, StreamingContext)
Creates a new CommandFrameBase from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected CommandFrameBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CommandFrameBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


CommandFrameBase Constructor (cells, command)

CommandFrameBase Constructor (cells, command)
Namespaces ► TVA.PhasorProtocols ► CommandFrameBase ► CommandFrameBase(CommandCellCollection, DeviceCommand)
Creates a new CommandFrameBase from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected CommandFrameBase(
    CommandCellCollection cells,
    DeviceCommand command
)
Protected Sub New ( _
    cells As CommandCellCollection, _
    command As DeviceCommand _
)
protected:
CommandFrameBase(
    CommandCellCollection^ cells,
    DeviceCommand command
)
Parameters
cells (CommandCellCollection)
The reference to the CommandCellCollection for this CommandFrameBase.
command (DeviceCommand)
The DeviceCommand for this CommandFrameBase.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► CommandFrameBase ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the CommandFrameBase object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols ► CommandFrameBase ► BodyImage
Gets the binary body image of this CommandFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols ► CommandFrameBase ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols ► CommandFrameBase ► Cells
Gets reference to the CommandCellCollection for this CommandFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual CommandCellCollection Cells { get; }
Public Overridable ReadOnly Property Cells As CommandCellCollection
    Get
public:
virtual property CommandCellCollection^ Cells {
    CommandCellCollection^ get ();
}


Command Property

Command Property
Namespaces ► TVA.PhasorProtocols ► CommandFrameBase ► Command
Gets or sets the DeviceCommand for this CommandFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DeviceCommand Command { get; set; }
Public Overridable Property Command As DeviceCommand
    Get
    Set
public:
virtual property DeviceCommand Command {
    DeviceCommand get ();
    void set (DeviceCommand value);
}


ExtendedData Property

ExtendedData Property
Namespaces ► TVA.PhasorProtocols ► CommandFrameBase ► ExtendedData
Gets or sets extended binary image data for this CommandFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual byte[] ExtendedData { get; set; }
Public Overridable Property ExtendedData As Byte()
    Get
    Set
public:
virtual property array<unsigned char>^ ExtendedData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


FrameType Property

FrameType Property
Namespaces ► TVA.PhasorProtocols ► CommandFrameBase ► FrameType
Gets the FundamentalFrameType for this CommandFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public override FundamentalFrameType FrameType { get; }
Public Overrides ReadOnly Property FrameType As FundamentalFrameType
    Get
public:
virtual property FundamentalFrameType FrameType {
    FundamentalFrameType get () override;
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► CommandFrameBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols ► CommandFrameBase ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► CommandFrameBase ► State
Gets or sets the parsing state for the this CommandFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ICommandFrameParsingState State { get; set; }
Public Overridable Property State As ICommandFrameParsingState
    Get
    Set
public:
virtual property ICommandFrameParsingState^ State {
    ICommandFrameParsingState^ get ();
    void set (ICommandFrameParsingState^ value);
}


CommandFrameParsingState Class

CommandFrameParsingState Class
Namespaces ► TVA.PhasorProtocols ► CommandFrameParsingState
Represents the protocol independent common implementation of the parsing state used by any ICommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
public class CommandFrameParsingState : ChannelFrameParsingStateBase<ICommandCell>,
    ICommandFrameParsingState, IChannelFrameParsingState<ICommandCell>, IChannelParsingState
Public Class CommandFrameParsingState _
    Inherits ChannelFrameParsingStateBase(Of ICommandCell) _
    Implements ICommandFrameParsingState, IChannelFrameParsingState(Of ICommandCell),  _
    IChannelParsingState
public ref class CommandFrameParsingState : public ChannelFrameParsingStateBase<ICommandCell^>,
    ICommandFrameParsingState, IChannelFrameParsingState<ICommandCell^>, IChannelParsingState
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandFrameParsingState(Int32, Int32) | Creates a new CommandFrameParsingState from specified parameters.
 | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBase<(Of <(<'T>)>)>.)
 | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ChannelParsingStateBase
 |  | ChannelFrameParsingStateBase <(Of <(<' ICommandCell >)>)>
 |  |  | CommandFrameParsingState


CommandFrameParsingState Constructor (parsedBinaryLength, dataLength)

CommandFrameParsingState Constructor (parsedBinaryLength, dataLength)
Namespaces ► TVA.PhasorProtocols ► CommandFrameParsingState ► CommandFrameParsingState(Int32, Int32)
Creates a new CommandFrameParsingState from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public CommandFrameParsingState(
    int parsedBinaryLength,
    int dataLength
)
Public Sub New ( _
    parsedBinaryLength As Integer, _
    dataLength As Integer _
)
public:
CommandFrameParsingState(
    int parsedBinaryLength,
    int dataLength
)
Parameters
parsedBinaryLength (Int32)
Binary length of the ICommandFrame being parsed.
dataLength (Int32)
Length of data in ICommandFrame being parsed (i.e., number of cells).


Common Class

Common Class
Namespaces ► TVA.PhasorProtocols ► Common
Common constants, functions and extensions for phasor classes.
Declaration Syntax
C# Visual Basic Visual C++
public static class Common
<ExtensionAttribute> _
Public NotInheritable Class Common
[ExtensionAttribute]
public ref class Common abstract sealed
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CopyImage(array<Byte>[]()[][], array<Byte>[]()[][], Int32%, Int32) | This is a common optimized block copy function for binary data.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data.
 | DeserializeConfigurationFrame(String) | Deserializes a configuration frame from an XML file.
 | DeserializeConfigurationFrame(Stream) | Deserializes a configuration frame from an XML stream.
 | GetFormattedProtocolName | Returns display friendly protocol name.
 | GetFormattedSignalTypeName | Returns display friendly signal type name.
 | GetValidLabel(String) | Removes duplicate white space, control characters and null from a string.
 | SyncByte | Typical data stream synchrnonization byte.
Inheritance Hierarchy
Object
Common


CopyImage Method

CopyImage Method
Namespaces ► TVA.PhasorProtocols ► Common ► CopyImage()()()()
Members
Icon | Member | Description
 | CopyImage(array<Byte>[]()[][], array<Byte>[]()[][], Int32%, Int32) | This is a common optimized block copy function for binary data.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data.


CopyImage Method (source, destination, index, length)

CopyImage Method (source, destination, index, length)
Namespaces ► TVA.PhasorProtocols ► Common ► CopyImage(array<Byte>[]()[][], array<Byte>[]()[][], Int32%, Int32)
This is a common optimized block copy function for binary data.
Declaration Syntax
C# Visual Basic Visual C++
public static void CopyImage(
    this byte[] source,
    byte[] destination,
    ref int index,
    int length
)
<ExtensionAttribute> _
Public Shared Sub CopyImage ( _
    source As Byte(), _
    destination As Byte(), _
    ByRef index As Integer, _
    length As Integer _
)
[ExtensionAttribute]
public:
static void CopyImage(
    array<unsigned char>^ source,
    array<unsigned char>^ destination,
    int% index,
    int length
)
Parameters
source (array< Byte >[]()[][])
Source buffer to copy data from.
destination (array< Byte >[]()[][])
Destination buffer to hold copied buffer data.
index (Int32 %)
Index into destination buffer to begin copy. Index is automatically incremented by length.
length (Int32)
Number of bytes to copy from source.
Remarks
Source index is always zero so hence not requested. This function automatically advances index for convenience.


CopyImage Method (channel, destination, index)

CopyImage Method (channel, destination, index)
Namespaces ► TVA.PhasorProtocols ► Common ► CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%)
This is a common optimized block copy function for any kind of data.
Declaration Syntax
C# Visual Basic Visual C++
public static void CopyImage(
    this ISupportBinaryImage channel,
    byte[] destination,
    ref int index
)
<ExtensionAttribute> _
Public Shared Sub CopyImage ( _
    channel As ISupportBinaryImage, _
    destination As Byte(), _
    ByRef index As Integer _
)
[ExtensionAttribute]
public:
static void CopyImage(
    ISupportBinaryImage^ channel,
    array<unsigned char>^ destination,
    int% index
)
Parameters
channel (ISupportBinaryImage)
Source channel with BinaryImage data to copy.
destination (array< Byte >[]()[][])
Destination buffer to hold copied buffer data.
index (Int32 %)
Index into destination buffer to begin copy. Index is automatically incremented by BinaryLength()()()().
Remarks
This function automatically advances index for convenience.


DeserializeConfigurationFrame Method

DeserializeConfigurationFrame Method
Namespaces ► TVA.PhasorProtocols ► Common ► DeserializeConfigurationFrame()()()()
Members
Icon | Member | Description
 | DeserializeConfigurationFrame(String) | Deserializes a configuration frame from an XML file.
 | DeserializeConfigurationFrame(Stream) | Deserializes a configuration frame from an XML stream.


DeserializeConfigurationFrame Method (configStream)

DeserializeConfigurationFrame Method (configStream)
Namespaces ► TVA.PhasorProtocols ► Common ► DeserializeConfigurationFrame(Stream)
Deserializes a configuration frame from an XML stream.
Declaration Syntax
C# Visual Basic Visual C++
public static IConfigurationFrame DeserializeConfigurationFrame(
    Stream configStream
)
Public Shared Function DeserializeConfigurationFrame ( _
    configStream As Stream _
) As IConfigurationFrame
public:
static IConfigurationFrame^ DeserializeConfigurationFrame(
    Stream^ configStream
)
Parameters
configStream (Stream)
Stream that contains an XML serialized configuration frame.
Return Value
Deserialized IConfigurationFrame.


DeserializeConfigurationFrame Method (configFileName)

DeserializeConfigurationFrame Method (configFileName)
Namespaces ► TVA.PhasorProtocols ► Common ► DeserializeConfigurationFrame(String)
Deserializes a configuration frame from an XML file.
Declaration Syntax
C# Visual Basic Visual C++
public static IConfigurationFrame DeserializeConfigurationFrame(
    string configFileName
)
Public Shared Function DeserializeConfigurationFrame ( _
    configFileName As String _
) As IConfigurationFrame
public:
static IConfigurationFrame^ DeserializeConfigurationFrame(
    String^ configFileName
)
Parameters
configFileName (String)
Path and file name of XML configuration file.
Return Value
Deserialized IConfigurationFrame.


GetFormattedProtocolName Method (protocol)

GetFormattedProtocolName Method (protocol)
Namespaces ► TVA.PhasorProtocols ► Common ► GetFormattedProtocolName
Returns display friendly protocol name.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetFormattedProtocolName(
    this PhasorProtocol protocol
)
<ExtensionAttribute> _
Public Shared Function GetFormattedProtocolName ( _
    protocol As PhasorProtocol _
) As String
[ExtensionAttribute]
public:
static String^ GetFormattedProtocolName(
    PhasorProtocol protocol
)
Parameters
protocol (PhasorProtocol)
PhasorProtocol to return display name for.
Return Value
Friendly protocol display name for specified phasor protocol.


GetFormattedSignalTypeName Method (signalType)

GetFormattedSignalTypeName Method (signalType)
Namespaces ► TVA.PhasorProtocols ► Common ► GetFormattedSignalTypeName
Returns display friendly signal type name.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetFormattedSignalTypeName(
    this SignalType signalType
)
<ExtensionAttribute> _
Public Shared Function GetFormattedSignalTypeName ( _
    signalType As SignalType _
) As String
[ExtensionAttribute]
public:
static String^ GetFormattedSignalTypeName(
    SignalType signalType
)
Parameters
signalType (SignalType)
SignalType to return display name for.
Return Value
Friendly protocol display name for specified signalType.


GetValidLabel Method (value)

GetValidLabel Method (value)
Namespaces ► TVA.PhasorProtocols ► Common ► GetValidLabel(String)
Removes duplicate white space, control characters and null from a string.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetValidLabel(
    this string value
)
<ExtensionAttribute> _
Public Shared Function GetValidLabel ( _
    value As String _
) As String
[ExtensionAttribute]
public:
static String^ GetValidLabel(
    String^ value
)
Parameters
value (String)
Source String to validate.
Return Value
value with duplicate white space, control characters and nulls removed.
Remarks
Strings reported from field devices can be full of inconsistencies, this function "cleans-up" the strings for visualization.


SyncByte Field

SyncByte Field
Namespaces ► TVA.PhasorProtocols ► Common ► SyncByte
Typical data stream synchrnonization byte.
Declaration Syntax
C# Visual Basic Visual C++
public const byte SyncByte
Public Const SyncByte As Byte
public:
literal unsigned char SyncByte


CommonPhasorServices Class

CommonPhasorServices Class
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices
Provides common phasor services.
Declaration Syntax
C# Visual Basic Visual C++
public class CommonPhasorServices : FacileActionAdapterBase
Public Class CommonPhasorServices _
    Inherits FacileActionAdapterBase
public ref class CommonPhasorServices : public FacileActionAdapterBase
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommonPhasorServices()()()() | Creates a new CommonPhasorServices.
 | AssignParentCollection(IAdapterCollection) | Assigns the reference to the parent IAdapterCollection that will contain this AdapterBase. (Overrides AdapterBase.AssignParentCollection(IAdapterCollection).)
 | AutoStart()()()() | (Inherited from AdapterBase.)
 | ConnectionString()()()() | (Inherited from AdapterBase.)
 | DataSource | Gets or sets DataSet based data source available to the CommonPhasorServices instance. (Overrides AdapterBase.DataSource()()()().)
 | DiscardingMeasurements()()()() | (Inherited from FacileActionAdapterBase.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the CommonPhasorServices object and optionally releases the managed resources. (Overrides AdapterBase.Dispose(Boolean).)
 | Dispose()()()() | (Inherited from AdapterBase.)
 | Disposed()()()() | (Inherited from AdapterBase.)
 | Enabled()()()() | (Inherited from AdapterBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | (Inherited from AdapterBase.)
 | FramesPerSecond()()()() | (Inherited from FacileActionAdapterBase.)
 | GetHashCode()()()() | (Inherited from AdapterBase.)
 | GetShortStatus(Int32) | Gets a short one-line status of this CommonPhasorServices. (Overrides AdapterBase.GetShortStatus(Int32).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID()()()() | (Inherited from AdapterBase.)
 | IncrementProcessedMeasurements(Int64) | (Inherited from AdapterBase.)
 | InitializationTimeout()()()() | (Inherited from AdapterBase.)
 | Initialize()()()() | Intializes CommonPhasorServices. (Overrides FacileActionAdapterBase.Initialize()()()().)
 | Initialized()()()() | (Inherited from AdapterBase.)
 | InputMeasurementKeys | Gets or sets primary keys of input measurements the CommonPhasorServices expects, if any. (Overrides FacileActionAdapterBase.InputMeasurementKeys()()()().)
 | InputMeasurementKeysUpdated()()()() | (Inherited from AdapterBase.)
 | InputSourceIDs()()()() | (Inherited from FacileActionAdapterBase.)
 | IsInputMeasurement(MeasurementKey) | (Inherited from AdapterBase.)
 | LatestMeasurements()()()() | (Inherited from FacileActionAdapterBase.)
 | MapMeasurementAttributes(ICollection<(Of <<'(IMeasurement>)>>), String, IMeasurement) | Map parsed measurement value to defined measurement attributes (i.e., assign meta-data to parsed measured value).
 | MeasurementReportingInterval()()()() | (Inherited from AdapterBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()()()() | (Inherited from AdapterBase.)
 | NewMeasurements()()()() | (Inherited from FacileActionAdapterBase.)
 | OnDiscardingMeasurements(IEnumerable<(Of <<'(IMeasurement>)>>)) | (Inherited from FacileActionAdapterBase.)
 | OnInputMeasurementKeysUpdated()()()() | (Inherited from AdapterBase.)
 | OnNewMeasurements(ICollection<(Of <<'(IMeasurement>)>>)) | (Inherited from FacileActionAdapterBase.)
 | OnOutputMeasurementsUpdated()()()() | (Inherited from AdapterBase.)
 | OnProcessException(Exception) | (Inherited from FacileActionAdapterBase.)
 | OnStatusMessage(String) | (Inherited from AdapterBase.)
 | OnStatusMessage(String, array<Object>[]()[][]) | (Inherited from AdapterBase.)
 | OnUnpublishedSamples(Int32) | (Inherited from FacileActionAdapterBase.)
 | OutputMeasurements | Gets or sets output measurements that the CommonPhasorServices will produce, if any. (Overrides AdapterBase.OutputMeasurements()()()().)
 | OutputMeasurementsUpdated()()()() | (Inherited from AdapterBase.)
 | OutputSourceIDs()()()() | (Inherited from FacileActionAdapterBase.)
 | Parent()()()() | (Inherited from AdapterBase.)
 | ProcessedMeasurements()()()() | (Inherited from AdapterBase.)
 | ProcessException()()()() | (Inherited from AdapterBase.)
 | ProcessingInterval()()()() | (Inherited from AdapterBase.)
 | ProcessMeasurementFilter()()()() | (Inherited from AdapterBase.)
 | QueueMeasurementForProcessing(IMeasurement) | (Inherited from FacileActionAdapterBase.)
 | QueueMeasurementsForProcessing(IEnumerable<(Of <<'(IMeasurement>)>>)) | Queues a collection of measurements for processing. (Overrides FacileActionAdapterBase.QueueMeasurementsForProcessing(IEnumerable<(Of <<'(IMeasurement>)>>)).)
 | RealTime()()()() | (Inherited from FacileActionAdapterBase.)
 | ReloadStatistics()()()() | Loads or reloads system statistics.
 | RequestDeviceConfiguration(String) | Requests a configuration frame from a phasor device.
 | RequestedInputMeasurementKeys()()()() | (Inherited from FacileActionAdapterBase.)
 | RequestedOutputMeasurementKeys()()()() | (Inherited from FacileActionAdapterBase.)
 | RunTime()()()() | (Inherited from AdapterBase.)
 | SendCommand(DeviceCommand) | Sends the specified DeviceCommand to the current device connection.
 | SetInitializedState(Boolean) | (Inherited from AdapterBase.)
 | SetTemporalConstraint(String, String, String) | (Inherited from AdapterBase.)
 | Settings()()()() | (Inherited from AdapterBase.)
 | Start()()()() | Starts the CommonPhasorServices or restarts it if it is already running. (Overrides AdapterBase.Start()()()().)
 | StartTime()()()() | (Inherited from AdapterBase.)
 | StartTimeConstraint()()()() | (Inherited from AdapterBase.)
 | Status | Gets the status of this CommonPhasorServices instance. (Overrides FacileActionAdapterBase.Status()()()().)
 | StatusMessage()()()() | (Inherited from AdapterBase.)
 | Stop()()()() | Stops the CommonPhasorServices. (Overrides AdapterBase.Stop()()()().)
 | StopTime()()()() | (Inherited from AdapterBase.)
 | StopTimeConstraint()()()() | (Inherited from AdapterBase.)
 | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Overrides AdapterBase.SupportsTemporalProcessing()()()().)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackLatestMeasurements()()()() | (Inherited from FacileActionAdapterBase.)
 | UnpublishedSamples()()()() | (Inherited from FacileActionAdapterBase.)
 | UseLocalClockAsRealTime()()()() | (Inherited from FacileActionAdapterBase.)
 | WaitForInitialize(Int32) | (Inherited from AdapterBase.)
Remarks
Typically class should be implemented as a singleton since one instance will suffice.
Inheritance Hierarchy
Object
 | AdapterBase
 |  | FacileActionAdapterBase
 |  |  | CommonPhasorServices


CommonPhasorServices Constructor

CommonPhasorServices Constructor
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► CommonPhasorServices()()()()
Creates a new CommonPhasorServices.
Declaration Syntax
C# Visual Basic Visual C++
public CommonPhasorServices()
Public Sub New
public:
CommonPhasorServices()


AssignParentCollection Method (parent)

AssignParentCollection Method (parent)
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► AssignParentCollection(IAdapterCollection)
Assigns the reference to the parent IAdapterCollection that will contain this AdapterBase.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AssignParentCollection(
    IAdapterCollection parent
)
Protected Overrides Sub AssignParentCollection ( _
    parent As IAdapterCollection _
)
protected:
virtual void AssignParentCollection(
    IAdapterCollection^ parent
) override
Parameters
parent (IAdapterCollection)
Parent adapter collection.


DataSource Property

DataSource Property
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► DataSource
Gets or sets DataSet based data source available to the CommonPhasorServices instance.
Declaration Syntax
C# Visual Basic Visual C++
public override DataSet DataSource { get; set; }
Public Overrides Property DataSource As DataSet
    Get
    Set
public:
virtual property DataSet^ DataSource {
    DataSet^ get () override;
    void set (DataSet^ value) override;
}


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► Dispose(Boolean)
Releases the unmanaged resources used by the CommonPhasorServices object and optionally releases the managed resources.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true to release both managed and unmanaged resources; false to release only unmanaged resources.


GetShortStatus Method (maxLength)

GetShortStatus Method (maxLength)
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► GetShortStatus(Int32)
Gets a short one-line status of this CommonPhasorServices.
Declaration Syntax
C# Visual Basic Visual C++
public override string GetShortStatus(
    int maxLength
)
Public Overrides Function GetShortStatus ( _
    maxLength As Integer _
) As String
public:
virtual String^ GetShortStatus(
    int maxLength
) override
Parameters
maxLength (Int32)
Maximum number of available characters for display.
Return Value
A short one-line summary of the current status of the CommonPhasorServices.


Initialize Method

Initialize Method
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► Initialize()()()()
Intializes CommonPhasorServices.
Declaration Syntax
C# Visual Basic Visual C++
public override void Initialize()
Public Overrides Sub Initialize
public:
virtual void Initialize() override


InputMeasurementKeys Property

InputMeasurementKeys Property
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► InputMeasurementKeys
Gets or sets primary keys of input measurements the CommonPhasorServices expects, if any.
Declaration Syntax
C# Visual Basic Visual C++
public override MeasurementKey[] InputMeasurementKeys { get; set; }
Public Overrides Property InputMeasurementKeys As MeasurementKey()
    Get
    Set
public:
virtual property array<MeasurementKey>^ InputMeasurementKeys {
    array<MeasurementKey>^ get () override;
    void set (array<MeasurementKey>^ value) override;
}


MapMeasurementAttributes Method (mappedMeasurements, signalReference, parsedMeasurement)

MapMeasurementAttributes Method (mappedMeasurements, signalReference, parsedMeasurement)
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► MapMeasurementAttributes(ICollection<(Of <<'(IMeasurement>)>>), String, IMeasurement)
Map parsed measurement value to defined measurement attributes (i.e., assign meta-data to parsed measured value).
Declaration Syntax
C# Visual Basic Visual C++
protected void MapMeasurementAttributes(
    ICollection<IMeasurement> mappedMeasurements,
    string signalReference,
    IMeasurement parsedMeasurement
)
Protected Sub MapMeasurementAttributes ( _
    mappedMeasurements As ICollection(Of IMeasurement), _
    signalReference As String, _
    parsedMeasurement As IMeasurement _
)
protected:
void MapMeasurementAttributes(
    ICollection<IMeasurement^>^ mappedMeasurements,
    String^ signalReference,
    IMeasurement^ parsedMeasurement
)
Parameters
mappedMeasurements (ICollection <(Of <(<'IMeasurement>)>)>)
Destination collection for the mapped measurement values.
signalReference (String)
Derived SignalReference string for the parsed measurement value.
parsedMeasurement (IMeasurement)
The parsed IMeasurement value.
Remarks
This procedure is used to identify a parsed measurement value by its derived signal reference and apply the additional needed measurement meta-data attributes (i.e., ID, Source, Adder and Multiplier).


OutputMeasurements Property

OutputMeasurements Property
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► OutputMeasurements
Gets or sets output measurements that the CommonPhasorServices will produce, if any.
Declaration Syntax
C# Visual Basic Visual C++
public override IMeasurement[] OutputMeasurements { get; set; }
Public Overrides Property OutputMeasurements As IMeasurement()
    Get
    Set
public:
virtual property array<IMeasurement^>^ OutputMeasurements {
    array<IMeasurement^>^ get () override;
    void set (array<IMeasurement^>^ value) override;
}


QueueMeasurementsForProcessing Method (measurements)

QueueMeasurementsForProcessing Method (measurements)
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► QueueMeasurementsForProcessing(IEnumerable<(Of <<'(IMeasurement>)>>))
Queues a collection of measurements for processing.
Declaration Syntax
C# Visual Basic Visual C++
public override void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement> measurements
)
Public Overrides Sub QueueMeasurementsForProcessing ( _
    measurements As IEnumerable(Of IMeasurement) _
)
public:
virtual void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement^>^ measurements
) override
Parameters
measurements (IEnumerable <(Of <(<'IMeasurement>)>)>)
Collection of measurements to queue for processing.


ReloadStatistics Method

ReloadStatistics Method
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► ReloadStatistics()()()()
Loads or reloads system statistics.
Declaration Syntax
C# Visual Basic Visual C++
[AdapterCommandAttribute("Reloads system statistics.")]
public void ReloadStatistics()
<AdapterCommandAttribute("Reloads system statistics.")> _
Public Sub ReloadStatistics
[AdapterCommandAttribute(L"Reloads system statistics.")]
public:
void ReloadStatistics()


RequestDeviceConfiguration Method (connectionString)

RequestDeviceConfiguration Method (connectionString)
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► RequestDeviceConfiguration(String)
Requests a configuration frame from a phasor device.
Declaration Syntax
C# Visual Basic Visual C++
[AdapterCommandAttribute("Connects to a phasor device and requests its configuration frame.")]
public IConfigurationFrame RequestDeviceConfiguration(
    string connectionString
)
<AdapterCommandAttribute("Connects to a phasor device and requests its configuration frame.")> _
Public Function RequestDeviceConfiguration ( _
    connectionString As String _
) As IConfigurationFrame
[AdapterCommandAttribute(L"Connects to a phasor device and requests its configuration frame.")]
public:
IConfigurationFrame^ RequestDeviceConfiguration(
    String^ connectionString
)
Parameters
connectionString (String)
Connection string used to connect to phasor device.
Return Value
A IConfigurationFrame if successful, -or- null if request failed.


SendCommand Method (command)

SendCommand Method (command)
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► SendCommand(DeviceCommand)
Sends the specified DeviceCommand to the current device connection.
Declaration Syntax
C# Visual Basic Visual C++
public void SendCommand(
    DeviceCommand command
)
Public Sub SendCommand ( _
    command As DeviceCommand _
)
public:
void SendCommand(
    DeviceCommand command
)
Parameters
command (DeviceCommand)
DeviceCommand to send to connected device.


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► Start()()()()
Starts the CommonPhasorServices or restarts it if it is already running.
Declaration Syntax
C# Visual Basic Visual C++
[AdapterCommandAttribute("Starts the common phasor services adapter or restarts it if it is already running.")]
public override void Start()
<AdapterCommandAttribute("Starts the common phasor services adapter or restarts it if it is already running.")> _
Public Overrides Sub Start
[AdapterCommandAttribute(L"Starts the common phasor services adapter or restarts it if it is already running.")]
public:
virtual void Start() override


Status Property

Status Property
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► Status
Gets the status of this CommonPhasorServices instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
public:
virtual property String^ Status {
    String^ get () override;
}
Remarks
Derived classes should provide current status information about the adapter for display purposes.


Stop Method

Stop Method
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► Stop()()()()
Stops the CommonPhasorServices.
Declaration Syntax
C# Visual Basic Visual C++
[AdapterCommandAttribute("Stops the common phasor services adapter.")]
public override void Stop()
<AdapterCommandAttribute("Stops the common phasor services adapter.")> _
Public Overrides Sub Stop
[AdapterCommandAttribute(L"Stops the common phasor services adapter.")]
public:
virtual void Stop() override


SupportsTemporalProcessing Property

SupportsTemporalProcessing Property
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► SupportsTemporalProcessing
Gets the flag indicating if this adapter supports temporal processing.
Declaration Syntax
C# Visual Basic Visual C++
public override bool SupportsTemporalProcessing { get; }
Public Overrides ReadOnly Property SupportsTemporalProcessing As Boolean
    Get
public:
virtual property bool SupportsTemporalProcessing {
    bool get () override;
}
Remarks
Since the common phasor services is designed to assist in various real-time operations, it is expected that this would not be desired in a temporal data streaming session.


CommonStatusFlags Enumeration

CommonStatusFlags Enumeration
Namespaces ► TVA.PhasorProtocols ► CommonStatusFlags
Protocol independent common status flags enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[FlagsAttribute]
public enum CommonStatusFlags
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration CommonStatusFlags
[SerializableAttribute]
[FlagsAttribute]
public enum class CommonStatusFlags
Members
Member | Description
DataDiscarded | Data was discarded from real-time stream due to late arrival (0 when not discarded, 1 when discarded).
DataIsValid | Data is valid (0 when device data is valid, 1 when invalid or device is in test mode).
SynchronizationIsValid | Synchronization is valid (0 when in device is in sync, 1 when it is not).
DataSortingType | Data sorting type, 0 by timestamp, 1 by arrival.
DeviceError | Device error (including configuration error), 0 when no error.
ReservedFlags | Reserved bits for future common flags, presently set to 0.
NoFlags | No flags.
Remarks

These flags are expected to exist in the high-word of a double-word flag set such that original word flags remain in-tact in low-word of double-word flag set.

Note that value being stored in a historian using a 32-bit single precision floating number value will only have castable conversion accuracy back to an unsigned 32-bit integer up to the 24th bit, so any bits used beyond Bit23 will be lossy.


CompositeFrequencyValue Enumeration

CompositeFrequencyValue Enumeration
Namespaces ► TVA.PhasorProtocols ► CompositeFrequencyValue
Composite frequency value indicies enumeration.
Declaration Syntax
C# Visual Basic Visual C++
public enum CompositeFrequencyValue
Public Enumeration CompositeFrequencyValue
public enum class CompositeFrequencyValue
Members
Member | Description
Frequency | Composite frequency value index.
DfDt | Composite df/ft value index.


CompositePhasorValue Enumeration

CompositePhasorValue Enumeration
Namespaces ► TVA.PhasorProtocols ► CompositePhasorValue
Composite polar value indicies enumeration.
Declaration Syntax
C# Visual Basic Visual C++
public enum CompositePhasorValue
Public Enumeration CompositePhasorValue
public enum class CompositePhasorValue
Members
Member | Description
Angle | Composite angle value index.
Magnitude | Composite magnitude value index.


ConfigurationCellBase Class

ConfigurationCellBase Class
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase
Represents the protocol independent common implementation of all configuration elements for cells in a IConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class ConfigurationCellBase : ChannelCellBase,
    IConfigurationCell, IChannelCell, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IConfigurationCell>, IComparable<IConfigurationCell>, IComparable
<SerializableAttribute> _
Public MustInherit Class ConfigurationCellBase _
    Inherits ChannelCellBase _
    Implements IConfigurationCell, IChannelCell, IChannel, ISupportBinaryImage,  _
    ISerializable, IEquatable(Of IConfigurationCell), IComparable(Of IConfigurationCell),  _
    IComparable
[SerializableAttribute]
public ref class ConfigurationCellBase abstract : public ChannelCellBase,
    IConfigurationCell, IChannelCell, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IConfigurationCell^>, IComparable<IConfigurationCell^>, IComparable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCellBase(IConfigurationFrame, UInt16, Int32, Int32, Int32) | Creates a new ConfigurationCellBase from specified parameters.
 | ConfigurationCellBase(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellBase from serialization parameters.
 | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCellBase.
 | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationCellBase object. (Overrides ChannelCellBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Overrides BinaryImageBase.BodyImage()()()().)
 | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBase.BodyLength()()()().)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase.
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value.
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage | Gets the binary footer image of the ConfigurationCellBase object. (Overrides BinaryImageBase.FooterImage()()()().)
 | FooterLength | Gets the length of the FooterImage. (Overrides BinaryImageBase.FooterLength()()()().)
 | FrameRate | Gets the specified frame rate of this ConfigurationCellBase.
 | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCellBase.
 | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase.
 | GetHashCode()()()() | Returns the hash code for this instance. (Overrides Object.GetHashCode()()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCellBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the ConfigurationCellBase object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
 | IDLabel | Gets or sets the ID label of this ConfigurationCellBase.
 | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase.
 | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCellBase.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase.
 | Parent | Gets or sets a reference to the parent IConfigurationFrame for this ConfigurationCellBase.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides BinaryImageBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary footer image. (Overrides BinaryImageBase.ParseFooterImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides BinaryImageBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase.
 | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase.
 | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase.
 | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase.
 | State | Gets or sets the parsing state for the this ConfigurationCellBase.
 | StationName | Gets or sets the station name of this ConfigurationCellBase.
 | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase.
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ConfigurationCellBase. (Overrides ChannelCellBase.ToString()()()().)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | ConfigurationCellBase
 |  |  |  |  | ConfigurationCell
 |  |  |  |  | ConfigurationCell
 |  |  |  |  | ConfigurationCell
 |  |  |  |  | ConfigurationCell
 |  |  |  |  | ConfigurationCell
 |  |  |  |  | ConfigurationCell
 |  |  |  |  | ConfigurationCell


ConfigurationCellBase Constructor

ConfigurationCellBase Constructor
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► ConfigurationCellBase()()()()
Members
Icon | Member | Description
 | ConfigurationCellBase(IConfigurationFrame, UInt16, Int32, Int32, Int32) | Creates a new ConfigurationCellBase from specified parameters.
 | ConfigurationCellBase(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellBase from serialization parameters.


ConfigurationCellBase Constructor (info, context)

ConfigurationCellBase Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► ConfigurationCellBase(SerializationInfo, StreamingContext)
Creates a new ConfigurationCellBase from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCellBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationCellBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationCellBase Constructor (parent, idCode, maximumPhasors, maximumAnalogs, maximumDigitals)

ConfigurationCellBase Constructor (parent, idCode, maximumPhasors, maximumAnalogs, maximumDigitals)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► ConfigurationCellBase(IConfigurationFrame, UInt16, Int32, Int32, Int32)
Creates a new ConfigurationCellBase from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCellBase(
    IConfigurationFrame parent,
    ushort idCode,
    int maximumPhasors,
    int maximumAnalogs,
    int maximumDigitals
)
Protected Sub New ( _
    parent As IConfigurationFrame, _
    idCode As UShort, _
    maximumPhasors As Integer, _
    maximumAnalogs As Integer, _
    maximumDigitals As Integer _
)
protected:
ConfigurationCellBase(
    IConfigurationFrame^ parent,
    unsigned short idCode,
    int maximumPhasors,
    int maximumAnalogs,
    int maximumDigitals
)
Parameters
parent (IConfigurationFrame)
The reference to parent IConfigurationFrame of this ConfigurationCellBase.
idCode (UInt16)
The numeric ID code for this ConfigurationCellBase.
maximumPhasors (Int32)
Sets the maximum number of phasors for the PhasorDefinitions collection.
maximumAnalogs (Int32)
Sets the maximum number of phasors for the AnalogDefinitions collection.
maximumDigitals (Int32)
Sets the maximum number of phasors for the DigitalDefinitions collection.


AnalogDataFormat Property

AnalogDataFormat Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► AnalogDataFormat
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public abstract DataFormat AnalogDataFormat { get; set; }
Public MustOverride Property AnalogDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat AnalogDataFormat {
    DataFormat get () abstract;
    void set (DataFormat value) abstract;
}


AnalogDefinitions Property

AnalogDefinitions Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► AnalogDefinitions
Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual AnalogDefinitionCollection AnalogDefinitions { get; }
Public Overridable ReadOnly Property AnalogDefinitions As AnalogDefinitionCollection
    Get
public:
virtual property AnalogDefinitionCollection^ AnalogDefinitions {
    AnalogDefinitionCollection^ get ();
}


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationCellBase object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► BodyImage
Gets the binary body image of the ConfigurationCellBase object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}
Remarks
Channel names of IEEE protocol configuration frames are common in order and type so these are defined in the base class.


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}
Remarks
Channel names of IEEE protocol configuration frames are common in order and type so these are defined in the base class.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values.


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► CompareTo(Object)
Compares this instance to a specified object and returns an indication of their relative values.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int CompareTo(
    Object obj
)
Public Overridable Function CompareTo ( _
    obj As Object _
) As Integer
public:
virtual int CompareTo(
    Object^ obj
)
Parameters
obj (Object)
An object to compare, or null.
Return Value
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.
Exceptions
Exception | Condition
ArgumentException | value is not an IConfigurationCell.


CompareTo Method (other)

CompareTo Method (other)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► CompareTo(IConfigurationCell)
Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int CompareTo(
    IConfigurationCell other
)
Public Overridable Function CompareTo ( _
    other As IConfigurationCell _
) As Integer
public:
virtual int CompareTo(
    IConfigurationCell^ other
)
Parameters
other (IConfigurationCell)
A IConfigurationCell object to compare.
Return Value
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.


DigitalDefinitions Property

DigitalDefinitions Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► DigitalDefinitions
Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DigitalDefinitionCollection DigitalDefinitions { get; }
Public Overridable ReadOnly Property DigitalDefinitions As DigitalDefinitionCollection
    Get
public:
virtual property DigitalDefinitionCollection^ DigitalDefinitions {
    DigitalDefinitionCollection^ get ();
}


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value.


Equals Method (obj)

Equals Method (obj)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► Equals(Object)
Returns a value indicating whether this instance is equal to a specified object.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)
An object to compare, or null.
Return Value
True if obj is an instance of IConfigurationCell and equals the value of this instance; otherwise, False.
Exceptions
Exception | Condition
ArgumentException | value is not an IConfigurationCell.


Equals Method (other)

Equals Method (other)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► Equals(IConfigurationCell)
Returns a value indicating whether this instance is equal to specified IConfigurationCell value.
Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    IConfigurationCell other
)
Public Function Equals ( _
    other As IConfigurationCell _
) As Boolean
public:
virtual bool Equals(
    IConfigurationCell^ other
) sealed
Parameters
other (IConfigurationCell)
A IConfigurationCell object to compare to this instance.
Return Value
True if other has the same value as this instance; otherwise, False.


FooterImage Property

FooterImage Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► FooterImage
Gets the binary footer image of the ConfigurationCellBase object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] FooterImage { get; }
Protected Overrides ReadOnly Property FooterImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ FooterImage {
    array<unsigned char>^ get () override;
}
Remarks
Bottom of the IEEE protocol configuration frames contain a nominal frequency definition, so base implementation exposes frequency definition as the footer.


FooterLength Property

FooterLength Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► FooterLength
Gets the length of the FooterImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int FooterLength { get; }
Protected Overrides ReadOnly Property FooterLength As Integer
    Get
protected:
virtual property int FooterLength {
    int get () override;
}
Remarks
Bottom of the IEEE protocol configuration frames contain a nominal frequency definition, so base implementation exposes frequency definition as the footer.


FrameRate Property

FrameRate Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► FrameRate
Gets the specified frame rate of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ushort FrameRate { get; }
Public Overridable ReadOnly Property FrameRate As UShort
    Get
public:
virtual property unsigned short FrameRate {
    unsigned short get ();
}


FrequencyDataFormat Property

FrequencyDataFormat Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► FrequencyDataFormat
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public abstract DataFormat FrequencyDataFormat { get; set; }
Public MustOverride Property FrequencyDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () abstract;
    void set (DataFormat value) abstract;
}


FrequencyDefinition Property

FrequencyDefinition Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► FrequencyDefinition
Gets or sets the IFrequencyDefinition of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IFrequencyDefinition FrequencyDefinition { get; set; }
Public Overridable Property FrequencyDefinition As IFrequencyDefinition
    Get
    Set
public:
virtual property IFrequencyDefinition^ FrequencyDefinition {
    IFrequencyDefinition^ get ();
    void set (IFrequencyDefinition^ value);
}


GetHashCode Method

GetHashCode Method
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► GetHashCode()()()()
Returns the hash code for this instance.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
A 32-bit signed integer hash code.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► HeaderImage
Gets the binary header image of the ConfigurationCellBase object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}
Remarks
Base implementation provides station name image from the header which is common to configuration frame headers in IEEE protocols.


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}
Remarks
Base implementation provides station name length from the header which is common to configuration frame headers in IEEE protocols.


IDLabel Property

IDLabel Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► IDLabel
Gets or sets the ID label of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string IDLabel { get; set; }
Public Overridable Property IDLabel As String
    Get
    Set
public:
virtual property String^ IDLabel {
    String^ get ();
    void set (String^ value);
}


IDLabelImage Property

IDLabelImage Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► IDLabelImage
Gets the binary image of the IDLabel of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual byte[] IDLabelImage { get; }
Public Overridable ReadOnly Property IDLabelImage As Byte()
    Get
public:
virtual property array<unsigned char>^ IDLabelImage {
    array<unsigned char>^ get ();
}


IDLabelLength Property

IDLabelLength Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► IDLabelLength
Gets the length of the IDLabel of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int IDLabelLength { get; }
Public Overridable ReadOnly Property IDLabelLength As Integer
    Get
public:
virtual property int IDLabelLength {
    int get ();
}


MaximumStationNameLength Property

MaximumStationNameLength Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► MaximumStationNameLength
Gets the maximum length of the StationName of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int MaximumStationNameLength { get; }
Public Overridable ReadOnly Property MaximumStationNameLength As Integer
    Get
public:
virtual property int MaximumStationNameLength {
    int get ();
}


NominalFrequency Property

NominalFrequency Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► NominalFrequency
Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual LineFrequency NominalFrequency { get; set; }
Public Overridable Property NominalFrequency As LineFrequency
    Get
    Set
public:
virtual property LineFrequency NominalFrequency {
    LineFrequency get ();
    void set (LineFrequency value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► Parent
Gets or sets a reference to the parent IConfigurationFrame for this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IConfigurationFrame Parent { get; set; }
Public Overridable Property Parent As IConfigurationFrame
    Get
    Set
public:
virtual property IConfigurationFrame^ Parent {
    IConfigurationFrame^ get ();
    void set (IConfigurationFrame^ value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


ParseFooterImage Method (binaryImage, startIndex, length)

ParseFooterImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► ParseFooterImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary footer image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseFooterImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseFooterImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseFooterImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


PhasorCoordinateFormat Property

PhasorCoordinateFormat Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► PhasorCoordinateFormat
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public abstract CoordinateFormat PhasorCoordinateFormat { get; set; }
Public MustOverride Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () abstract;
    void set (CoordinateFormat value) abstract;
}


PhasorDataFormat Property

PhasorDataFormat Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► PhasorDataFormat
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public abstract DataFormat PhasorDataFormat { get; set; }
Public MustOverride Property PhasorDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () abstract;
    void set (DataFormat value) abstract;
}


PhasorDefinitions Property

PhasorDefinitions Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► PhasorDefinitions
Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual PhasorDefinitionCollection PhasorDefinitions { get; }
Public Overridable ReadOnly Property PhasorDefinitions As PhasorDefinitionCollection
    Get
public:
virtual property PhasorDefinitionCollection^ PhasorDefinitions {
    PhasorDefinitionCollection^ get ();
}


RevisionCount Property

RevisionCount Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► RevisionCount
Gets or sets the revision count of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ushort RevisionCount { get; set; }
Public Overridable Property RevisionCount As UShort
    Get
    Set
public:
virtual property unsigned short RevisionCount {
    unsigned short get ();
    void set (unsigned short value);
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► State
Gets or sets the parsing state for the this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IConfigurationCellParsingState State { get; set; }
Public Overridable Property State As IConfigurationCellParsingState
    Get
    Set
public:
virtual property IConfigurationCellParsingState^ State {
    IConfigurationCellParsingState^ get ();
    void set (IConfigurationCellParsingState^ value);
}


StationName Property

StationName Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► StationName
Gets or sets the station name of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string StationName { get; set; }
Public Overridable Property StationName As String
    Get
    Set
public:
virtual property String^ StationName {
    String^ get ();
    void set (String^ value);
}


StationNameImage Property

StationNameImage Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► StationNameImage
Gets the binary image of the StationName of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual byte[] StationNameImage { get; }
Public Overridable ReadOnly Property StationNameImage As Byte()
    Get
public:
virtual property array<unsigned char>^ StationNameImage {
    array<unsigned char>^ get ();
}


ToString Method

ToString Method
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellBase ► ToString()()()()
Gets the string respresentation of this ConfigurationCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
String respresentation of this ConfigurationCellBase.


ConfigurationCellCollection Class

ConfigurationCellCollection Class
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellCollection
Represents a protocol independent collection of IConfigurationCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationCellCollection : ChannelCellCollectionBase<IConfigurationCell>
<SerializableAttribute> _
Public Class ConfigurationCellCollection _
    Inherits ChannelCellCollectionBase(Of IConfigurationCell)
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ChannelCellCollectionBase<IConfigurationCell^>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCellCollection(Int32, Boolean) | Creates a new ConfigurationCellCollection from specified parameters.
 | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | IndexOfIDCode(UInt16) | Attempts to find the index of the IConfigurationCell with the specified ID code.
 | IndexOfIDLabel(String) | Attempts to find the index of the IConfigurationCell with the specified ID label.
 | IndexOfStationName(String) | Attempts to find the index of the IConfigurationCell with the specified station name.
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetByIDCode(UInt16, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified ID code.
 | TryGetByIDLabel(String, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified label.
 | TryGetByStationName(String, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified station name.
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IConfigurationCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' IConfigurationCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationCellCollection
 |  |  |  |  | ConfigurationCellCollection
 |  |  |  |  | ConfigurationCellCollection
 |  |  |  |  | ConfigurationCellCollection
 |  |  |  |  | ConfigurationCellCollection
 |  |  |  |  | ConfigurationCellCollection
 |  |  |  |  | ConfigurationCellCollection
 |  |  |  |  | ConfigurationCellCollection


ConfigurationCellCollection Constructor

ConfigurationCellCollection Constructor
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellCollection ► ConfigurationCellCollection()()()()
Members
Icon | Member | Description
 | ConfigurationCellCollection(Int32, Boolean) | Creates a new ConfigurationCellCollection from specified parameters.
 | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.


ConfigurationCellCollection Constructor (lastValidIndex, constantCellLength)

ConfigurationCellCollection Constructor (lastValidIndex, constantCellLength)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellCollection ► ConfigurationCellCollection(Int32, Boolean)
Creates a new ConfigurationCellCollection from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellCollection(
    int lastValidIndex,
    bool constantCellLength
)
Public Sub New ( _
    lastValidIndex As Integer, _
    constantCellLength As Boolean _
)
public:
ConfigurationCellCollection(
    int lastValidIndex,
    bool constantCellLength
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
constantCellLength (Boolean)
Sets flag that determines if the lengths of IConfigurationCell elements in this ConfigurationCellCollection are constant.
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


ConfigurationCellCollection Constructor (info, context)

ConfigurationCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellCollection ► ConfigurationCellCollection(SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


IndexOfIDCode Method (idCode)

IndexOfIDCode Method (idCode)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellCollection ► IndexOfIDCode(UInt16)
Attempts to find the index of the IConfigurationCell with the specified ID code.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int IndexOfIDCode(
    ushort idCode
)
Public Overridable Function IndexOfIDCode ( _
    idCode As UShort _
) As Integer
public:
virtual int IndexOfIDCode(
    unsigned short idCode
)
Parameters
idCode (UInt16)
The IDCode to find.
Return Value
Index of the ConfigurationCellCollection that contains the specified idCode; otherwise, -1.


IndexOfIDLabel Method (label)

IndexOfIDLabel Method (label)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellCollection ► IndexOfIDLabel(String)
Attempts to find the index of the IConfigurationCell with the specified ID label.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int IndexOfIDLabel(
    string label
)
Public Overridable Function IndexOfIDLabel ( _
    label As String _
) As Integer
public:
virtual int IndexOfIDLabel(
    String^ label
)
Parameters
label (String)
The IDLabel to find.
Return Value
Index of the ConfigurationCellCollection that contains the specified label; otherwise, -1.


IndexOfStationName Method (stationName)

IndexOfStationName Method (stationName)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellCollection ► IndexOfStationName(String)
Attempts to find the index of the IConfigurationCell with the specified station name.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int IndexOfStationName(
    string stationName
)
Public Overridable Function IndexOfStationName ( _
    stationName As String _
) As Integer
public:
virtual int IndexOfStationName(
    String^ stationName
)
Parameters
stationName (String)
The StationName to find.
Return Value
Index of the ConfigurationCellCollection that contains the specified stationName; otherwise, -1.


TryGetByIDCode Method (idCode, configurationCell)

TryGetByIDCode Method (idCode, configurationCell)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellCollection ► TryGetByIDCode(UInt16, IConfigurationCell%)
Attempts to get IConfigurationCell with the specified ID code.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool TryGetByIDCode(
    ushort idCode,
    out IConfigurationCell configurationCell
)
Public Overridable Function TryGetByIDCode ( _
    idCode As UShort, _
    <OutAttribute> ByRef configurationCell As IConfigurationCell _
) As Boolean
public:
virtual bool TryGetByIDCode(
    unsigned short idCode,
    [OutAttribute] IConfigurationCell^% configurationCell
)
Parameters
idCode (UInt16)
The IDCode to find.
configurationCell (IConfigurationCell %)
When this method returns, contains the IConfigurationCell with the specified idCode, if found; otherwise, null is returned.
Return Value
true if the ConfigurationCellCollection contains an element with the specified idCode; otherwise, false.


TryGetByIDLabel Method (label, configurationCell)

TryGetByIDLabel Method (label, configurationCell)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellCollection ► TryGetByIDLabel(String, IConfigurationCell%)
Attempts to get IConfigurationCell with the specified label.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool TryGetByIDLabel(
    string label,
    out IConfigurationCell configurationCell
)
Public Overridable Function TryGetByIDLabel ( _
    label As String, _
    <OutAttribute> ByRef configurationCell As IConfigurationCell _
) As Boolean
public:
virtual bool TryGetByIDLabel(
    String^ label,
    [OutAttribute] IConfigurationCell^% configurationCell
)
Parameters
label (String)
The IDLabel to find.
configurationCell (IConfigurationCell %)
When this method returns, contains the IConfigurationCell with the specified label, if found; otherwise, null is returned.
Return Value
true if the ConfigurationCellCollection contains an element with the specified label; otherwise, false.


TryGetByStationName Method (stationName, configurationCell)

TryGetByStationName Method (stationName, configurationCell)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellCollection ► TryGetByStationName(String, IConfigurationCell%)
Attempts to get IConfigurationCell with the specified station name.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool TryGetByStationName(
    string stationName,
    out IConfigurationCell configurationCell
)
Public Overridable Function TryGetByStationName ( _
    stationName As String, _
    <OutAttribute> ByRef configurationCell As IConfigurationCell _
) As Boolean
public:
virtual bool TryGetByStationName(
    String^ stationName,
    [OutAttribute] IConfigurationCell^% configurationCell
)
Parameters
stationName (String)
The StationName to find.
configurationCell (IConfigurationCell %)
When this method returns, contains the IConfigurationCell with the specified stationName, if found; otherwise, null is returned.
Return Value
true if the ConfigurationCellCollection contains an element with the specified stationName; otherwise, false.


ConfigurationCellParsingState Class

ConfigurationCellParsingState Class
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellParsingState
Represents the protocol independent common implementation of the parsing state used by any IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public class ConfigurationCellParsingState : ChannelCellParsingStateBase,
    IConfigurationCellParsingState, IChannelCellParsingState, IChannelParsingState
Public Class ConfigurationCellParsingState _
    Inherits ChannelCellParsingStateBase _
    Implements IConfigurationCellParsingState, IChannelCellParsingState, IChannelParsingState
public ref class ConfigurationCellParsingState : public ChannelCellParsingStateBase,
    IConfigurationCellParsingState, IChannelCellParsingState, IChannelParsingState
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCellParsingState(CreateNewDefinitionFunction<(Of <<'(IPhasorDefinition>)>>), CreateNewDefinitionFunction<(Of <<'(IFrequencyDefinition>)>>), CreateNewDefinitionFunction<(Of <<'(IAnalogDefinition>)>>), CreateNewDefinitionFunction<(Of <<'(IDigitalDefinition>)>>)) | Creates a new ConfigurationCellParsingState from specified parameters.
 | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
 | CreateNewAnalogDefinition | Gets reference to CreateNewDefinitionFunction<(Of <(<'T>)>)> delegate used to create new IAnalogDefinition objects.
 | CreateNewDigitalDefinition | Gets reference to CreateNewDefinitionFunction<(Of <(<'T>)>)> delegate used to create new IDigitalDefinition objects.
 | CreateNewFrequencyDefinition | Gets reference to CreateNewDefinitionFunction<(Of <(<'T>)>)> delegate used to create new IFrequencyDefinition objects.
 | CreateNewPhasorDefinition | Gets reference to CreateNewDefinitionFunction<(Of <(<'T>)>)> delegate used to create new IPhasorDefinition objects.
 | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
 | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ChannelParsingStateBase
 |  | ChannelCellParsingStateBase
 |  |  | ConfigurationCellParsingState


ConfigurationCellParsingState Constructor (createNewPhasorDefinition, createNewFrequencyDefinition, createNewAnalogDefinition, createNewDigitalDefinition)

ConfigurationCellParsingState Constructor (createNewPhasorDefinition, createNewFrequencyDefinition, createNewAnalogDefinition, createNewDigitalDefinition)
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellParsingState ► ConfigurationCellParsingState(CreateNewDefinitionFunction<(Of <<'(IPhasorDefinition>)>>), CreateNewDefinitionFunction<(Of <<'(IFrequencyDefinition>)>>), CreateNewDefinitionFunction<(Of <<'(IAnalogDefinition>)>>), CreateNewDefinitionFunction<(Of <<'(IDigitalDefinition>)>>))
Creates a new ConfigurationCellParsingState from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellParsingState(
    CreateNewDefinitionFunction<IPhasorDefinition> createNewPhasorDefinition,
    CreateNewDefinitionFunction<IFrequencyDefinition> createNewFrequencyDefinition,
    CreateNewDefinitionFunction<IAnalogDefinition> createNewAnalogDefinition,
    CreateNewDefinitionFunction<IDigitalDefinition> createNewDigitalDefinition
)
Public Sub New ( _
    createNewPhasorDefinition As CreateNewDefinitionFunction(Of IPhasorDefinition), _
    createNewFrequencyDefinition As CreateNewDefinitionFunction(Of IFrequencyDefinition), _
    createNewAnalogDefinition As CreateNewDefinitionFunction(Of IAnalogDefinition), _
    createNewDigitalDefinition As CreateNewDefinitionFunction(Of IDigitalDefinition) _
)
public:
ConfigurationCellParsingState(
    CreateNewDefinitionFunction<IPhasorDefinition^>^ createNewPhasorDefinition,
    CreateNewDefinitionFunction<IFrequencyDefinition^>^ createNewFrequencyDefinition,
    CreateNewDefinitionFunction<IAnalogDefinition^>^ createNewAnalogDefinition,
    CreateNewDefinitionFunction<IDigitalDefinition^>^ createNewDigitalDefinition
)
Parameters
createNewPhasorDefinition (CreateNewDefinitionFunction <(Of <(<' IPhasorDefinition >)>)>)
Reference to delegate to create new IPhasorDefinition instances.
createNewFrequencyDefinition (CreateNewDefinitionFunction <(Of <(<' IFrequencyDefinition >)>)>)
Reference to delegate to create new IFrequencyDefinition instances.
createNewAnalogDefinition (CreateNewDefinitionFunction <(Of <(<' IAnalogDefinition >)>)>)
Reference to delegate to create new IAnalogDefinition instances.
createNewDigitalDefinition (CreateNewDefinitionFunction <(Of <(<' IDigitalDefinition >)>)>)
Reference to delegate to create new IDigitalDefinition instances.


CreateNewAnalogDefinition Property

CreateNewAnalogDefinition Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellParsingState ► CreateNewAnalogDefinition
Gets reference to CreateNewDefinitionFunction<(Of <(<'T>)>)> delegate used to create new IAnalogDefinition objects.
Declaration Syntax
C# Visual Basic Visual C++
public virtual CreateNewDefinitionFunction<IAnalogDefinition> CreateNewAnalogDefinition { get; }
Public Overridable ReadOnly Property CreateNewAnalogDefinition As CreateNewDefinitionFunction(Of IAnalogDefinition)
    Get
public:
virtual property CreateNewDefinitionFunction<IAnalogDefinition^>^ CreateNewAnalogDefinition {
    CreateNewDefinitionFunction<IAnalogDefinition^>^ get ();
}


CreateNewDigitalDefinition Property

CreateNewDigitalDefinition Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellParsingState ► CreateNewDigitalDefinition
Gets reference to CreateNewDefinitionFunction<(Of <(<'T>)>)> delegate used to create new IDigitalDefinition objects.
Declaration Syntax
C# Visual Basic Visual C++
public virtual CreateNewDefinitionFunction<IDigitalDefinition> CreateNewDigitalDefinition { get; }
Public Overridable ReadOnly Property CreateNewDigitalDefinition As CreateNewDefinitionFunction(Of IDigitalDefinition)
    Get
public:
virtual property CreateNewDefinitionFunction<IDigitalDefinition^>^ CreateNewDigitalDefinition {
    CreateNewDefinitionFunction<IDigitalDefinition^>^ get ();
}


CreateNewFrequencyDefinition Property

CreateNewFrequencyDefinition Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellParsingState ► CreateNewFrequencyDefinition
Gets reference to CreateNewDefinitionFunction<(Of <(<'T>)>)> delegate used to create new IFrequencyDefinition objects.
Declaration Syntax
C# Visual Basic Visual C++
public virtual CreateNewDefinitionFunction<IFrequencyDefinition> CreateNewFrequencyDefinition { get; }
Public Overridable ReadOnly Property CreateNewFrequencyDefinition As CreateNewDefinitionFunction(Of IFrequencyDefinition)
    Get
public:
virtual property CreateNewDefinitionFunction<IFrequencyDefinition^>^ CreateNewFrequencyDefinition {
    CreateNewDefinitionFunction<IFrequencyDefinition^>^ get ();
}


CreateNewPhasorDefinition Property

CreateNewPhasorDefinition Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationCellParsingState ► CreateNewPhasorDefinition
Gets reference to CreateNewDefinitionFunction<(Of <(<'T>)>)> delegate used to create new IPhasorDefinition objects.
Declaration Syntax
C# Visual Basic Visual C++
public virtual CreateNewDefinitionFunction<IPhasorDefinition> CreateNewPhasorDefinition { get; }
Public Overridable ReadOnly Property CreateNewPhasorDefinition As CreateNewDefinitionFunction(Of IPhasorDefinition)
    Get
public:
virtual property CreateNewDefinitionFunction<IPhasorDefinition^>^ CreateNewPhasorDefinition {
    CreateNewDefinitionFunction<IPhasorDefinition^>^ get ();
}


ConfigurationErrorFrame Class

ConfigurationErrorFrame Class
Namespaces ► TVA.PhasorProtocols ► ConfigurationErrorFrame
Represents an implementation of IConfigurationFrame that by existance only denotes an error state.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationErrorFrame : IConfigurationFrame,
    IChannelFrame, IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame>,
    IComparable<IFrame>, IComparable, ISerializable
<SerializableAttribute> _
Public Class ConfigurationErrorFrame _
    Implements IConfigurationFrame, IChannelFrame, IChannel, ISupportBinaryImage,  _
    IFrame, IEquatable(Of IFrame), IComparable(Of IFrame),  _
    IComparable, ISerializable
[SerializableAttribute]
public ref class ConfigurationErrorFrame : IConfigurationFrame,
    IChannelFrame, IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame^>,
    IComparable<IFrame^>, IComparable, ISerializable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConfigurationErrorFrame()()()() | Creates a new instance of the ConfigurationErrorFrame class.
 | ConfigurationErrorFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationErrorFrame from serialization parameters.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This class is used by CommonPhasorServices to return an error state when configuration could not be retrieved.
Inheritance Hierarchy
Object
ConfigurationErrorFrame


ConfigurationErrorFrame Constructor

ConfigurationErrorFrame Constructor
Namespaces ► TVA.PhasorProtocols ► ConfigurationErrorFrame ► ConfigurationErrorFrame()()()()
Members
Icon | Member | Description
 | ConfigurationErrorFrame()()()() | Creates a new instance of the ConfigurationErrorFrame class.
 | ConfigurationErrorFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationErrorFrame from serialization parameters.


ConfigurationErrorFrame Constructor

ConfigurationErrorFrame Constructor
Namespaces ► TVA.PhasorProtocols ► ConfigurationErrorFrame ► ConfigurationErrorFrame()()()()
Creates a new instance of the ConfigurationErrorFrame class.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationErrorFrame()
Public Sub New
public:
ConfigurationErrorFrame()


ConfigurationErrorFrame Constructor (info, context)

ConfigurationErrorFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► ConfigurationErrorFrame ► ConfigurationErrorFrame(SerializationInfo, StreamingContext)
Creates a new ConfigurationErrorFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationErrorFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationErrorFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► ConfigurationErrorFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


ConfigurationFrameBase Class

ConfigurationFrameBase Class
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameBase
Represents the protocol independent common implementation of any IConfigurationFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class ConfigurationFrameBase : ChannelFrameBase<IConfigurationCell>,
    IConfigurationFrame, IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable<IFrame>, IComparable<IFrame>, IComparable,
    ISerializable
<SerializableAttribute> _
Public MustInherit Class ConfigurationFrameBase _
    Inherits ChannelFrameBase(Of IConfigurationCell) _
    Implements IConfigurationFrame, IChannelFrame, IChannel, ISupportBinaryImage,  _
    IFrame, IEquatable(Of IFrame), IComparable(Of IFrame),  _
    IComparable, ISerializable
[SerializableAttribute]
public ref class ConfigurationFrameBase abstract : public ChannelFrameBase<IConfigurationCell^>,
    IConfigurationFrame, IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable<IFrame^>, IComparable<IFrame^>, IComparable,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationFrameBase(UInt16, ConfigurationCellCollection, Ticks, UInt16) | Creates a new ConfigurationFrameBase from specified parameters.
 | ConfigurationFrameBase(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrameBase from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrameBase object. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrameBase.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase.
 | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.FrameType.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SetNominalFrequency(LineFrequency) | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection.
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this ConfigurationFrameBase.
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase.
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationFrameBase
 |  |  |  |  | ConfigurationFrame
 |  |  |  |  | ConfigurationFrame
 |  |  |  |  | ConfigurationFrame
 |  |  |  |  | ConfigurationFrame
 |  |  |  |  | ConfigurationFrame1
 |  |  |  |  | ConfigurationFrame
 |  |  |  |  | ConfigurationFrame


ConfigurationFrameBase Constructor

ConfigurationFrameBase Constructor
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameBase ► ConfigurationFrameBase()()()()
Members
Icon | Member | Description
 | ConfigurationFrameBase(UInt16, ConfigurationCellCollection, Ticks, UInt16) | Creates a new ConfigurationFrameBase from specified parameters.
 | ConfigurationFrameBase(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrameBase from serialization parameters.


ConfigurationFrameBase Constructor (info, context)

ConfigurationFrameBase Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameBase ► ConfigurationFrameBase(SerializationInfo, StreamingContext)
Creates a new ConfigurationFrameBase from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationFrameBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationFrameBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationFrameBase Constructor (idCode, cells, timestamp, frameRate)

ConfigurationFrameBase Constructor (idCode, cells, timestamp, frameRate)
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameBase ► ConfigurationFrameBase(UInt16, ConfigurationCellCollection, Ticks, UInt16)
Creates a new ConfigurationFrameBase from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationFrameBase(
    ushort idCode,
    ConfigurationCellCollection cells,
    Ticks timestamp,
    ushort frameRate
)
Protected Sub New ( _
    idCode As UShort, _
    cells As ConfigurationCellCollection, _
    timestamp As Ticks, _
    frameRate As UShort _
)
protected:
ConfigurationFrameBase(
    unsigned short idCode,
    ConfigurationCellCollection^ cells,
    Ticks timestamp,
    unsigned short frameRate
)
Parameters
idCode (UInt16)
The ID code of this ConfigurationFrameBase.
cells (ConfigurationCellCollection)
The reference to the collection of cells for this ConfigurationFrameBase.
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrameBase.
frameRate (UInt16)
The defined frame rate of this ConfigurationFrameBase.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameBase ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrameBase object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameBase ► Cells
Gets reference to the ConfigurationCellCollection for this ConfigurationFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCellCollection Cells { get; }
Public Overridable ReadOnly Property Cells As ConfigurationCellCollection
    Get
public:
virtual property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}


FrameRate Property

FrameRate Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameBase ► FrameRate
Gets or sets defined frame rate of this ConfigurationFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ushort FrameRate { get; set; }
Public Overridable Property FrameRate As UShort
    Get
    Set
public:
virtual property unsigned short FrameRate {
    unsigned short get ();
    void set (unsigned short value);
}


FrameType Property

FrameType Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameBase ► FrameType
Gets the FundamentalFrameType for this ConfigurationFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public override FundamentalFrameType FrameType { get; }
Public Overrides ReadOnly Property FrameType As FundamentalFrameType
    Get
public:
virtual property FundamentalFrameType FrameType {
    FundamentalFrameType get () override;
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


SetNominalFrequency Method (value)

SetNominalFrequency Method (value)
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameBase ► SetNominalFrequency(LineFrequency)
Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetNominalFrequency(
    LineFrequency value
)
Public Overridable Sub SetNominalFrequency ( _
    value As LineFrequency _
)
public:
virtual void SetNominalFrequency(
    LineFrequency value
)
Parameters
value (LineFrequency)
New nominal LineFrequency for IFrequencyDefinition elements.


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameBase ► State
Gets or sets the parsing state for the this ConfigurationFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IConfigurationFrameParsingState State { get; set; }
Public Overridable Property State As IConfigurationFrameParsingState
    Get
    Set
public:
virtual property IConfigurationFrameParsingState^ State {
    IConfigurationFrameParsingState^ get ();
    void set (IConfigurationFrameParsingState^ value);
}


TicksPerFrame Property

TicksPerFrame Property
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameBase ► TicksPerFrame
Gets the defined Ticks per frame of this ConfigurationFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual decimal TicksPerFrame { get; }
Public Overridable ReadOnly Property TicksPerFrame As Decimal
    Get
public:
virtual property Decimal TicksPerFrame {
    Decimal get ();
}


ConfigurationFrameCollection Class

ConfigurationFrameCollection Class
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameCollection
Represents a protocol independent collection of IConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationFrameCollection : ChannelFrameCollectionBase<IConfigurationFrame>
<SerializableAttribute> _
Public Class ConfigurationFrameCollection _
    Inherits ChannelFrameCollectionBase(Of IConfigurationFrame)
[SerializableAttribute]
public ref class ConfigurationFrameCollection : public ChannelFrameCollectionBase<IConfigurationFrame^>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationFrameCollection(Int32) | Creates a new ConfigurationFrameCollection using specified lastValidIndex.
 | ConfigurationFrameCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrameCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' T >)>)>
 |  | ChannelCollectionBase <(Of <(<' T >)>)>
 |  |  | ChannelFrameCollectionBase <(Of <(<' IConfigurationFrame >)>)>
 |  |  |  | ConfigurationFrameCollection


ConfigurationFrameCollection Constructor

ConfigurationFrameCollection Constructor
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameCollection ► ConfigurationFrameCollection()()()()
Members
Icon | Member | Description
 | ConfigurationFrameCollection(Int32) | Creates a new ConfigurationFrameCollection using specified lastValidIndex.
 | ConfigurationFrameCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrameCollection from serialization parameters.


ConfigurationFrameCollection Constructor (lastValidIndex)

ConfigurationFrameCollection Constructor (lastValidIndex)
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameCollection ► ConfigurationFrameCollection(Int32)
Creates a new ConfigurationFrameCollection using specified lastValidIndex.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrameCollection(
    int lastValidIndex
)
Public Sub New ( _
    lastValidIndex As Integer _
)
public:
ConfigurationFrameCollection(
    int lastValidIndex
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


ConfigurationFrameCollection Constructor (info, context)

ConfigurationFrameCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameCollection ► ConfigurationFrameCollection(SerializationInfo, StreamingContext)
Creates a new ConfigurationFrameCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationFrameCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationFrameCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationFrameParsingState Class

ConfigurationFrameParsingState Class
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameParsingState
Represents the protocol independent common implementation of the parsing state used by any IConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public class ConfigurationFrameParsingState : ChannelFrameParsingStateBase<IConfigurationCell>,
    IConfigurationFrameParsingState, IChannelFrameParsingState<IConfigurationCell>, IChannelParsingState
Public Class ConfigurationFrameParsingState _
    Inherits ChannelFrameParsingStateBase(Of IConfigurationCell) _
    Implements IConfigurationFrameParsingState, IChannelFrameParsingState(Of IConfigurationCell),  _
    IChannelParsingState
public ref class ConfigurationFrameParsingState : public ChannelFrameParsingStateBase<IConfigurationCell^>,
    IConfigurationFrameParsingState, IChannelFrameParsingState<IConfigurationCell^>, IChannelParsingState
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationFrameParsingState(Int32, CreateNewCellFunction<(Of <<'(IConfigurationCell>)>>)) | Creates a new ConfigurationFrameParsingState from specified parameters.
 | ConfigurationFrameParsingState(Int32, CreateNewCellFunction<(Of <<'(IConfigurationCell>)>>), Int32) | Creates a new ConfigurationFrameParsingState from specified parameters.
 | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBase<(Of <(<'T>)>)>.)
 | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ChannelParsingStateBase
 |  | ChannelFrameParsingStateBase <(Of <(<' IConfigurationCell >)>)>
 |  |  | ConfigurationFrameParsingState
 |  |  |  | ConfigurationFrameParsingState
 |  |  |  | ConfigurationFrameParsingState


ConfigurationFrameParsingState Constructor

ConfigurationFrameParsingState Constructor
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameParsingState ► ConfigurationFrameParsingState()()()()
Members
Icon | Member | Description
 | ConfigurationFrameParsingState(Int32, CreateNewCellFunction<(Of <<'(IConfigurationCell>)>>)) | Creates a new ConfigurationFrameParsingState from specified parameters.
 | ConfigurationFrameParsingState(Int32, CreateNewCellFunction<(Of <<'(IConfigurationCell>)>>), Int32) | Creates a new ConfigurationFrameParsingState from specified parameters.


ConfigurationFrameParsingState Constructor (parsedBinaryLength, createNewCellFunction)

ConfigurationFrameParsingState Constructor (parsedBinaryLength, createNewCellFunction)
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameParsingState ► ConfigurationFrameParsingState(Int32, CreateNewCellFunction<(Of <<'(IConfigurationCell>)>>))
Creates a new ConfigurationFrameParsingState from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrameParsingState(
    int parsedBinaryLength,
    CreateNewCellFunction<IConfigurationCell> createNewCellFunction
)
Public Sub New ( _
    parsedBinaryLength As Integer, _
    createNewCellFunction As CreateNewCellFunction(Of IConfigurationCell) _
)
public:
ConfigurationFrameParsingState(
    int parsedBinaryLength,
    CreateNewCellFunction<IConfigurationCell^>^ createNewCellFunction
)
Parameters
parsedBinaryLength (Int32)
Binary length of the IConfigurationFrame being parsed.
createNewCellFunction (CreateNewCellFunction <(Of <(<' IConfigurationCell >)>)>)
Reference to delegate to create new IConfigurationCell instances.


ConfigurationFrameParsingState Constructor (parsedBinaryLength, createNewCellFunction, cellCount)

ConfigurationFrameParsingState Constructor (parsedBinaryLength, createNewCellFunction, cellCount)
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameParsingState ► ConfigurationFrameParsingState(Int32, CreateNewCellFunction<(Of <<'(IConfigurationCell>)>>), Int32)
Creates a new ConfigurationFrameParsingState from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrameParsingState(
    int parsedBinaryLength,
    CreateNewCellFunction<IConfigurationCell> createNewCellFunction,
    int cellCount
)
Public Sub New ( _
    parsedBinaryLength As Integer, _
    createNewCellFunction As CreateNewCellFunction(Of IConfigurationCell), _
    cellCount As Integer _
)
public:
ConfigurationFrameParsingState(
    int parsedBinaryLength,
    CreateNewCellFunction<IConfigurationCell^>^ createNewCellFunction,
    int cellCount
)
Parameters
parsedBinaryLength (Int32)
Binary length of the IConfigurationFrame being parsed.
createNewCellFunction (CreateNewCellFunction <(Of <(<' IConfigurationCell >)>)>)
Reference to delegate to create new IConfigurationCell instances.
cellCount (Int32)
Number of cells that exist in the frame to be parsed.


ConnectionParametersBase Class

ConnectionParametersBase Class
Namespaces ► TVA.PhasorProtocols ► ConnectionParametersBase
Represents the common implementation of the protocol independent set of extra connection parameters.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class ConnectionParametersBase : IConnectionParameters,
    ISerializable
<SerializableAttribute> _
Public MustInherit Class ConnectionParametersBase _
    Implements IConnectionParameters, ISerializable
[SerializableAttribute]
public ref class ConnectionParametersBase abstract : IConnectionParameters,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConnectionParametersBase()()()() | Initializes a new instance of the ConnectionParametersBase class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValuesAreValid | Determines if custom connection parameters are valid.
Remarks

This class is inherited by subsequent classes to provide protocol specific connection parameters that may be needed to make a connection.

Derived implementations of this class are designed to be exposed by a "PropertyGrid" so a UI can request protocol specific connection parameters.

Inheritance Hierarchy
Object
 | ConnectionParametersBase
 |  | ConnectionParameters
 |  | ConnectionParameters
 |  | ConnectionParameters


ConnectionParametersBase Constructor

ConnectionParametersBase Constructor
Namespaces ► TVA.PhasorProtocols ► ConnectionParametersBase ► ConnectionParametersBase()()()()
Initializes a new instance of the ConnectionParametersBase class
Declaration Syntax
C# Visual Basic Visual C++
protected ConnectionParametersBase()
Protected Sub New
protected:
ConnectionParametersBase()


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► ConnectionParametersBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public abstract void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public MustOverride Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) abstract
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


ValuesAreValid Property

ValuesAreValid Property
Namespaces ► TVA.PhasorProtocols ► ConnectionParametersBase ► ValuesAreValid
Determines if custom connection parameters are valid.
Declaration Syntax
C# Visual Basic Visual C++
[BrowsableAttribute(false)]
public virtual bool ValuesAreValid { get; }
<BrowsableAttribute(False)> _
Public Overridable ReadOnly Property ValuesAreValid As Boolean
    Get
[BrowsableAttribute(false)]
public:
virtual property bool ValuesAreValid {
    bool get ();
}


CoordinateFormat Enumeration

CoordinateFormat Enumeration
Namespaces ► TVA.PhasorProtocols ► CoordinateFormat
Phasor coordinate formats enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum CoordinateFormat
<SerializableAttribute> _
Public Enumeration CoordinateFormat
[SerializableAttribute]
public enum class CoordinateFormat
Members
Member | Description
Rectangular | Rectangular coordinate format.
Polar | Polar coordinate format.


CrcException Class

CrcException Class
Namespaces ► TVA.PhasorProtocols ► CrcException
The exception that is thrown when an object's CRC check fails.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CrcException : Exception
<SerializableAttribute> _
Public Class CrcException _
    Inherits Exception
[SerializableAttribute]
public ref class CrcException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CrcException()()()() | Initializes a new instance of the CrcException class.
 | CrcException(String) | Initializes a new instance of the CrcException class.
 | CrcException(String, Exception) | Initializes a new instance of the CrcException class.
 | CrcException(SerializationInfo, StreamingContext) | Creates a new CrcException from serialization parameters.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | CrcException


CrcException Constructor

CrcException Constructor
Namespaces ► TVA.PhasorProtocols ► CrcException ► CrcException()()()()
Members
Icon | Member | Description
 | CrcException()()()() | Initializes a new instance of the CrcException class.
 | CrcException(String) | Initializes a new instance of the CrcException class.
 | CrcException(String, Exception) | Initializes a new instance of the CrcException class.
 | CrcException(SerializationInfo, StreamingContext) | Creates a new CrcException from serialization parameters.


CrcException Constructor

CrcException Constructor
Namespaces ► TVA.PhasorProtocols ► CrcException ► CrcException()()()()
Initializes a new instance of the CrcException class.
Declaration Syntax
C# Visual Basic Visual C++
public CrcException()
Public Sub New
public:
CrcException()


CrcException Constructor (info, context)

CrcException Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► CrcException ► CrcException(SerializationInfo, StreamingContext)
Creates a new CrcException from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected CrcException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CrcException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


CrcException Constructor (message)

CrcException Constructor (message)
Namespaces ► TVA.PhasorProtocols ► CrcException ► CrcException(String)
Initializes a new instance of the CrcException class.
Declaration Syntax
C# Visual Basic Visual C++
public CrcException(
    string message
)
Public Sub New ( _
    message As String _
)
public:
CrcException(
    String^ message
)
Parameters
message (String)
The message that describes the error.


CrcException Constructor (message, innerException)

CrcException Constructor (message, innerException)
Namespaces ► TVA.PhasorProtocols ► CrcException ► CrcException(String, Exception)
Initializes a new instance of the CrcException class.
Declaration Syntax
C# Visual Basic Visual C++
public CrcException(
    string message,
    Exception innerException
)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
public:
CrcException(
    String^ message,
    Exception^ innerException
)
Parameters
message (String)
The message that describes the error.
innerException (Exception)
The exception that is the cause of the current exception.


CreateNewCellFunction(T) Delegate

CreateNewCellFunction<(Of <(<'T>)>)> Delegate
Namespaces ► TVA.PhasorProtocols ► CreateNewCellFunction<(Of <(<'T>)>)>
Defines function signature for creating new IChannelCell objects.
Declaration Syntax
C# Visual Basic Visual C++
public delegate T CreateNewCellFunction<T>(
    IChannelFrame parent,
    IChannelFrameParsingState<T> state,
    int index,
    byte[] binaryImage,
    int startIndex,
    out int parsedLength
)
where T : IChannelCell

Public Delegate Function CreateNewCellFunction(Of T As IChannelCell) ( _
    parent As IChannelFrame, _
    state As IChannelFrameParsingState(Of T), _
    index As Integer, _
    binaryImage As Byte(), _
    startIndex As Integer, _
    <OutAttribute> ByRef parsedLength As Integer _
) As T
generic<typename T>
where T : IChannelCell
public delegate T CreateNewCellFunction(
    IChannelFrame^ parent,
    IChannelFrameParsingState<T>^ state,
    int index,
    array<unsigned char>^ binaryImage,
    int startIndex,
    [OutAttribute] int% parsedLength
)
Generic Template Parameters
T
Specific IChannelCell type of object that gets created by referenced function.
Parameters
parent (IChannelFrame)
Reference to parent IChannelFrame.
state (IChannelFrameParsingState <(Of <(<'T>)>)>)
Current parsing state of associated IChannelFrame.
index (Int32)
Index of cell within its collection.
binaryImage (array< Byte >[]()[][])
Binary image to parse IChannelCell from.
startIndex (Int32)
Start index into binaryImage to begin parsing.
parsedLength (Int32 %)
Returns the total number of bytes parsed from binaryImage.
Return Value
New IChannelCell object.


CreateNewDefinitionFunction(T) Delegate

CreateNewDefinitionFunction<(Of <(<'T>)>)> Delegate
Namespaces ► TVA.PhasorProtocols ► CreateNewDefinitionFunction<(Of <(<'T>)>)>
Defines function signature for creating new IChannelDefinition objects.
Declaration Syntax
C# Visual Basic Visual C++
public delegate T CreateNewDefinitionFunction<T>(
    IConfigurationCell parent,
    byte[] binaryImage,
    int startIndex,
    out int parsedLength
)
where T : IChannelDefinition

Public Delegate Function CreateNewDefinitionFunction(Of T As IChannelDefinition) ( _
    parent As IConfigurationCell, _
    binaryImage As Byte(), _
    startIndex As Integer, _
    <OutAttribute> ByRef parsedLength As Integer _
) As T
generic<typename T>
where T : IChannelDefinition
public delegate T CreateNewDefinitionFunction(
    IConfigurationCell^ parent,
    array<unsigned char>^ binaryImage,
    int startIndex,
    [OutAttribute] int% parsedLength
)
Generic Template Parameters
T
Specific IChannelDefinition type of object that the CreateNewDefinitionFunction<(Of <(<'T>)>)> creates.
Parameters
parent (IConfigurationCell)
Reference to parent IConfigurationCell.
binaryImage (array< Byte >[]()[][])
Binary image to parse IChannelDefinition from.
startIndex (Int32)
Start index into binaryImage to begin parsing.
parsedLength (Int32 %)
Returns the total number of bytes parsed from binaryImage.
Return Value
New IChannelDefinition object.


CreateNewValueFunction(TDefinition, TValue) Delegate

CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> Delegate
Namespaces ► TVA.PhasorProtocols ► CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)>
Defines function signature for creating new IChannelValue<(Of <(<'T>)>)> objects.
Declaration Syntax
C# Visual Basic Visual C++
public delegate TValue CreateNewValueFunction<TDefinition, TValue>(
    IDataCell parent,
    TDefinition definition,
    byte[] binaryImage,
    int startIndex,
    out int parsedLength
)
where TDefinition : IChannelDefinition
where TValue : IChannelValue<T>

Public Delegate Function CreateNewValueFunction(Of TDefinition As IChannelDefinition, TValue As IChannelValue(Of T)) ( _
    parent As IDataCell, _
    definition As TDefinition, _
    binaryImage As Byte(), _
    startIndex As Integer, _
    <OutAttribute> ByRef parsedLength As Integer _
) As TValue
generic<typename TDefinition, typename TValue>
where TDefinition : IChannelDefinition
where TValue : IChannelValue<T>
public delegate TValue CreateNewValueFunction(
    IDataCell^ parent,
    TDefinition definition,
    array<unsigned char>^ binaryImage,
    int startIndex,
    [OutAttribute] int% parsedLength
)
Generic Template Parameters
TDefinition
Specific IChannelDefinition type that the IChannelValue<(Of <(<'T>)>)> references.
TValue
Specific IChannelValue<(Of <(<'T>)>)> type that the CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> creates.
Parameters
parent (IDataCell)
Reference to parent IDataCell.
definition (TDefinition)
Refrence to associated IChannelDefinition object.
binaryImage (array< Byte >[]()[][])
Binary image to parse IChannelValue<(Of <(<'T>)>)> from.
startIndex (Int32)
Start index into binaryImage to begin parsing.
parsedLength (Int32 %)
Returns the total number of bytes parsed from binaryImage.
Return Value
New IChannelValue<(Of <(<'T>)>)> object.


DataCellBase Class

DataCellBase Class
Namespaces ► TVA.PhasorProtocols ► DataCellBase
Represents the protocol independent common implementation of all elements for cells in a IDataFrame.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class DataCellBase : ChannelCellBase,
    IDataCell, IChannelCell, IChannel, ISupportBinaryImage, ISerializable,
    IMeasurement, ITimeSeriesValue<double>, ITimeSeriesValue, IEquatable<ITimeSeriesValue>,
    IComparable<ITimeSeriesValue>, IComparable
<SerializableAttribute> _
Public MustInherit Class DataCellBase _
    Inherits ChannelCellBase _
    Implements IDataCell, IChannelCell, IChannel, ISupportBinaryImage,  _
    ISerializable, IMeasurement, ITimeSeriesValue(Of Double), ITimeSeriesValue,  _
    IEquatable(Of ITimeSeriesValue), IComparable(Of ITimeSeriesValue), IComparable
[SerializableAttribute]
public ref class DataCellBase abstract : public ChannelCellBase,
    IDataCell, IChannelCell, IChannel, ISupportBinaryImage, ISerializable,
    IMeasurement, ITimeSeriesValue<double>, ITimeSeriesValue, IEquatable<ITimeSeriesValue^>,
    IComparable<ITimeSeriesValue^>, IComparable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCellBase(IDataFrame, IConfigurationCell, UInt16, Int32, Int32, Int32) | Creates a new DataCellBase from specified parameters.
 | DataCellBase(SerializationInfo, StreamingContext) | Creates a new DataCellBase from serialization parameters.
 | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned.
 | AnalogValues | Gets AnalogValueCollectionof this DataCellBase.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataCellBase object. (Overrides ChannelCellBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the DataCellBase object. (Overrides BinaryImageBase.BodyImage()()()().)
 | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBase.BodyLength()()()().)
 | CommonStatusFlags | Gets or sets common status flags of this DataCellBase.
 | ConfigurationCell | Gets or sets the IConfigurationCell associated with this DataCellBase.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataIsValid | Gets or sets flag that determines if data of this DataCellBase is valid.
 | DataSortingType | Gets or sets DataSortingType of this DataCellBase.
 | DeviceError | Gets or sets flag that determines if source device of this DataCellBase is reporting an error.
 | DigitalValues | Gets DigitalValueCollectionof this DataCellBase.
 | Equals(Object) | Determines whether the specified object is equal to the DataCellBase. (Overrides Object.Equals(Object).)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrequencyValue | Gets IFrequencyValue of this DataCellBase.
 | GetHashCode()()()() | Serves as a hash function for the DataCellBase. (Overrides Object.GetHashCode()()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCellBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets the numeric ID code for this DataCellBase. (Overrides ChannelCellBase.IDCode.)
 | IDLabel | Gets ID label of this DataCellBase.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the reference to parent IDataFrame of this DataCellBase.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides BinaryImageBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | PhasorValues | Gets PhasorValueCollection of this DataCellBase.
 | State | Gets or sets the parsing state for the this DataCellBase.
 | StationName | Gets station name of this DataCellBase.
 | StatusFlags | Gets or sets 16-bit status flags of this DataCellBase.
 | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCellBase is valid based on GPS lock.
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this DataCellBase. (Overrides ChannelCellBase.ToString()()()().)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | DataCellBase
 |  |  |  |  | DataCell
 |  |  |  |  | DataCell
 |  |  |  |  | DataCell
 |  |  |  |  | DataCell
 |  |  |  |  | DataCell
 |  |  |  |  | DataCell


DataCellBase Constructor

DataCellBase Constructor
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► DataCellBase()()()()
Members
Icon | Member | Description
 | DataCellBase(IDataFrame, IConfigurationCell, UInt16, Int32, Int32, Int32) | Creates a new DataCellBase from specified parameters.
 | DataCellBase(SerializationInfo, StreamingContext) | Creates a new DataCellBase from serialization parameters.


DataCellBase Constructor (info, context)

DataCellBase Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► DataCellBase(SerializationInfo, StreamingContext)
Creates a new DataCellBase from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataCellBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataCellBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DataCellBase Constructor (parent, configurationCell, statusFlags, maximumPhasors, maximumAnalogs, maximumDigitals)

DataCellBase Constructor (parent, configurationCell, statusFlags, maximumPhasors, maximumAnalogs, maximumDigitals)
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► DataCellBase(IDataFrame, IConfigurationCell, UInt16, Int32, Int32, Int32)
Creates a new DataCellBase from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataCellBase(
    IDataFrame parent,
    IConfigurationCell configurationCell,
    ushort statusFlags,
    int maximumPhasors,
    int maximumAnalogs,
    int maximumDigitals
)
Protected Sub New ( _
    parent As IDataFrame, _
    configurationCell As IConfigurationCell, _
    statusFlags As UShort, _
    maximumPhasors As Integer, _
    maximumAnalogs As Integer, _
    maximumDigitals As Integer _
)
protected:
DataCellBase(
    IDataFrame^ parent,
    IConfigurationCell^ configurationCell,
    unsigned short statusFlags,
    int maximumPhasors,
    int maximumAnalogs,
    int maximumDigitals
)
Parameters
parent (IDataFrame)
The reference to parent IDataFrame of this DataCellBase.
configurationCell (IConfigurationCell)
The IConfigurationCell associated with this DataCellBase.
statusFlags (UInt16)
The default status flags to apply to this DataCellBase.
maximumPhasors (Int32)
Sets the maximum number of phasors for the PhasorValues collection.
maximumAnalogs (Int32)
Sets the maximum number of phasors for the AnalogValues collection.
maximumDigitals (Int32)
Sets the maximum number of phasors for the DigitalValues collection.


AllValuesAssigned Property

AllValuesAssigned Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► AllValuesAssigned
Gets flag that determines if all values of this DataCellBase have been assigned.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool AllValuesAssigned { get; }
Public Overridable ReadOnly Property AllValuesAssigned As Boolean
    Get
public:
virtual property bool AllValuesAssigned {
    bool get ();
}


AnalogValues Property

AnalogValues Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► AnalogValues
Gets AnalogValueCollectionof this DataCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual AnalogValueCollection AnalogValues { get; }
Public Overridable ReadOnly Property AnalogValues As AnalogValueCollection
    Get
public:
virtual property AnalogValueCollection^ AnalogValues {
    AnalogValueCollection^ get ();
}


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataCellBase object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► BodyImage
Gets the binary body image of the DataCellBase object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}


CommonStatusFlags Property

CommonStatusFlags Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► CommonStatusFlags
Gets or sets common status flags of this DataCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public uint CommonStatusFlags { get; set; }
Public Property CommonStatusFlags As UInteger
    Get
    Set
public:
virtual property unsigned int CommonStatusFlags {
    unsigned int get () sealed;
    void set (unsigned int value) sealed;
}


ConfigurationCell Property

ConfigurationCell Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► ConfigurationCell
Gets or sets the IConfigurationCell associated with this DataCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IConfigurationCell ConfigurationCell { get; set; }
Public Overridable Property ConfigurationCell As IConfigurationCell
    Get
    Set
public:
virtual property IConfigurationCell^ ConfigurationCell {
    IConfigurationCell^ get ();
    void set (IConfigurationCell^ value);
}


DataIsValid Property

DataIsValid Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► DataIsValid
Gets or sets flag that determines if data of this DataCellBase is valid.
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool DataIsValid { get; set; }
Public MustOverride Property DataIsValid As Boolean
    Get
    Set
public:
virtual property bool DataIsValid {
    bool get () abstract;
    void set (bool value) abstract;
}
Remarks
This value is used to abstractly assign the protocol independent set of CommonStatusFlags.


DataSortingType Property

DataSortingType Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► DataSortingType
Gets or sets DataSortingType of this DataCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public abstract DataSortingType DataSortingType { get; set; }
Public MustOverride Property DataSortingType As DataSortingType
    Get
    Set
public:
virtual property DataSortingType DataSortingType {
    DataSortingType get () abstract;
    void set (DataSortingType value) abstract;
}
Remarks
This value is used to abstractly assign the protocol independent set of CommonStatusFlags.


DeviceError Property

DeviceError Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► DeviceError
Gets or sets flag that determines if source device of this DataCellBase is reporting an error.
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool DeviceError { get; set; }
Public MustOverride Property DeviceError As Boolean
    Get
    Set
public:
virtual property bool DeviceError {
    bool get () abstract;
    void set (bool value) abstract;
}
Remarks
This value is used to abstractly assign the protocol independent set of CommonStatusFlags.


DigitalValues Property

DigitalValues Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► DigitalValues
Gets DigitalValueCollectionof this DataCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DigitalValueCollection DigitalValues { get; }
Public Overridable ReadOnly Property DigitalValues As DigitalValueCollection
    Get
public:
virtual property DigitalValueCollection^ DigitalValues {
    DigitalValueCollection^ get ();
}


Equals Method (obj)

Equals Method (obj)
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► Equals(Object)
Determines whether the specified object is equal to the DataCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)
The Object to compare with the DataCellBase.
Return Value
true if the specified object is equal to the DataCellBase; otherwise, false.


FrequencyValue Property

FrequencyValue Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► FrequencyValue
Gets IFrequencyValue of this DataCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IFrequencyValue FrequencyValue { get; set; }
Public Overridable Property FrequencyValue As IFrequencyValue
    Get
    Set
public:
virtual property IFrequencyValue^ FrequencyValue {
    IFrequencyValue^ get ();
    void set (IFrequencyValue^ value);
}


GetHashCode Method

GetHashCode Method
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► GetHashCode()()()()
Serves as a hash function for the DataCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
A hash code for the DataCellBase.
Remarks
Hash code based on value of measurement key associated with the DataCellBase.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► IDCode
Gets the numeric ID code for this DataCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public override ushort IDCode { get; set; }
Public Overrides Property IDCode As UShort
    Get
    Set
public:
virtual property unsigned short IDCode {
    unsigned short get () override;
    void set (unsigned short value) override;
}
Remarks
This value is read-only for DataCellBase; assigning a value will throw an exception. Value returned is the IDCode of the associated ConfigurationCell.
Exceptions
Exception | Condition
NotSupportedException | IDCode of a data cell is read-only, change IDCode is associated configuration cell instead.


IDLabel Property

IDLabel Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► IDLabel
Gets ID label of this DataCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string IDLabel { get; }
Public Overridable ReadOnly Property IDLabel As String
    Get
public:
virtual property String^ IDLabel {
    String^ get ();
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► Parent
Gets or sets the reference to parent IDataFrame of this DataCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IDataFrame Parent { get; set; }
Public Overridable Property Parent As IDataFrame
    Get
    Set
public:
virtual property IDataFrame^ Parent {
    IDataFrame^ get ();
    void set (IDataFrame^ value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


PhasorValues Property

PhasorValues Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► PhasorValues
Gets PhasorValueCollection of this DataCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual PhasorValueCollection PhasorValues { get; }
Public Overridable ReadOnly Property PhasorValues As PhasorValueCollection
    Get
public:
virtual property PhasorValueCollection^ PhasorValues {
    PhasorValueCollection^ get ();
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► State
Gets or sets the parsing state for the this DataCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IDataCellParsingState State { get; set; }
Public Overridable Property State As IDataCellParsingState
    Get
    Set
public:
virtual property IDataCellParsingState^ State {
    IDataCellParsingState^ get ();
    void set (IDataCellParsingState^ value);
}


StationName Property

StationName Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► StationName
Gets station name of this DataCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string StationName { get; }
Public Overridable ReadOnly Property StationName As String
    Get
public:
virtual property String^ StationName {
    String^ get ();
}


StatusFlags Property

StatusFlags Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► StatusFlags
Gets or sets 16-bit status flags of this DataCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ushort StatusFlags { get; set; }
Public Overridable Property StatusFlags As UShort
    Get
    Set
public:
virtual property unsigned short StatusFlags {
    unsigned short get ();
    void set (unsigned short value);
}


SynchronizationIsValid Property

SynchronizationIsValid Property
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► SynchronizationIsValid
Gets or sets flag that determines if timestamp of this DataCellBase is valid based on GPS lock.
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool SynchronizationIsValid { get; set; }
Public MustOverride Property SynchronizationIsValid As Boolean
    Get
    Set
public:
virtual property bool SynchronizationIsValid {
    bool get () abstract;
    void set (bool value) abstract;
}
Remarks
This value is used to abstractly assign the protocol independent set of CommonStatusFlags.


ToString Method

ToString Method
Namespaces ► TVA.PhasorProtocols ► DataCellBase ► ToString()()()()
Gets the string respresentation of this DataCellBase.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
String respresentation of this DataCellBase.


DataCellCollection Class

DataCellCollection Class
Namespaces ► TVA.PhasorProtocols ► DataCellCollection
Represents a protocol independent collection of IDataCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataCellCollection : ChannelCellCollectionBase<IDataCell>
<SerializableAttribute> _
Public Class DataCellCollection _
    Inherits ChannelCellCollectionBase(Of IDataCell)
[SerializableAttribute]
public ref class DataCellCollection : public ChannelCellCollectionBase<IDataCell^>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCellCollection(Int32, Boolean) | Creates a new DataCellCollection from specified parameters.
 | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IDataCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' IDataCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' IDataCell >)>)>
 |  |  |  | DataCellCollection
 |  |  |  |  | DataCellCollection
 |  |  |  |  | DataCellCollection
 |  |  |  |  | DataCellCollection
 |  |  |  |  | DataCellCollection
 |  |  |  |  | DataCellCollection
 |  |  |  |  | DataCellCollection


DataCellCollection Constructor

DataCellCollection Constructor
Namespaces ► TVA.PhasorProtocols ► DataCellCollection ► DataCellCollection()()()()
Members
Icon | Member | Description
 | DataCellCollection(Int32, Boolean) | Creates a new DataCellCollection from specified parameters.
 | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.


DataCellCollection Constructor (lastValidIndex, constantCellLength)

DataCellCollection Constructor (lastValidIndex, constantCellLength)
Namespaces ► TVA.PhasorProtocols ► DataCellCollection ► DataCellCollection(Int32, Boolean)
Creates a new DataCellCollection from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DataCellCollection(
    int lastValidIndex,
    bool constantCellLength
)
Public Sub New ( _
    lastValidIndex As Integer, _
    constantCellLength As Boolean _
)
public:
DataCellCollection(
    int lastValidIndex,
    bool constantCellLength
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
constantCellLength (Boolean)
Sets flag that determines if the lengths of IDataCell elements in this DataCellCollection are constant.
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


DataCellCollection Constructor (info, context)

DataCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► DataCellCollection ► DataCellCollection(SerializationInfo, StreamingContext)
Creates a new DataCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DataCellParsingState Class

DataCellParsingState Class
Namespaces ► TVA.PhasorProtocols ► DataCellParsingState
Represents the protocol independent common implementation of the parsing state used by any IDataCell.
Declaration Syntax
C# Visual Basic Visual C++
public class DataCellParsingState : ChannelCellParsingStateBase,
    IDataCellParsingState, IChannelCellParsingState, IChannelParsingState
Public Class DataCellParsingState _
    Inherits ChannelCellParsingStateBase _
    Implements IDataCellParsingState, IChannelCellParsingState, IChannelParsingState
public ref class DataCellParsingState : public ChannelCellParsingStateBase,
    IDataCellParsingState, IChannelCellParsingState, IChannelParsingState
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCellParsingState(IConfigurationCell, CreateNewValueFunction<(Of <<'(IPhasorDefinition, IPhasorValue>)>>), CreateNewValueFunction<(Of <<'(IFrequencyDefinition, IFrequencyValue>)>>), CreateNewValueFunction<(Of <<'(IAnalogDefinition, IAnalogValue>)>>), CreateNewValueFunction<(Of <<'(IDigitalDefinition, IDigitalValue>)>>)) | Creates a new DataCellParsingState from specified parameters.
 | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
 | ConfigurationCell | Gets reference to the IConfigurationCell associated with the IDataCell being parsed.
 | CreateNewAnalogValue | Gets reference to CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> delegate used to create new IAnalogValue objects.
 | CreateNewDigitalValue | Gets reference to CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> delegate used to create new IDigitalValue objects.
 | CreateNewFrequencyValue | Gets reference to CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> delegate used to create new IFrequencyValue objects.
 | CreateNewPhasorValue | Gets reference to CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> delegate used to create new IPhasorValue objects.
 | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
 | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ChannelParsingStateBase
 |  | ChannelCellParsingStateBase
 |  |  | DataCellParsingState


DataCellParsingState Constructor (configurationCell, createNewPhasorValue, createNewFrequencyValue, createNewAnalogValue, createNewDigitalValue)

DataCellParsingState Constructor (configurationCell, createNewPhasorValue, createNewFrequencyValue, createNewAnalogValue, createNewDigitalValue)
Namespaces ► TVA.PhasorProtocols ► DataCellParsingState ► DataCellParsingState(IConfigurationCell, CreateNewValueFunction<(Of <<'(IPhasorDefinition, IPhasorValue>)>>), CreateNewValueFunction<(Of <<'(IFrequencyDefinition, IFrequencyValue>)>>), CreateNewValueFunction<(Of <<'(IAnalogDefinition, IAnalogValue>)>>), CreateNewValueFunction<(Of <<'(IDigitalDefinition, IDigitalValue>)>>))
Creates a new DataCellParsingState from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DataCellParsingState(
    IConfigurationCell configurationCell,
    CreateNewValueFunction<IPhasorDefinition, IPhasorValue> createNewPhasorValue,
    CreateNewValueFunction<IFrequencyDefinition, IFrequencyValue> createNewFrequencyValue,
    CreateNewValueFunction<IAnalogDefinition, IAnalogValue> createNewAnalogValue,
    CreateNewValueFunction<IDigitalDefinition, IDigitalValue> createNewDigitalValue
)
Public Sub New ( _
    configurationCell As IConfigurationCell, _
    createNewPhasorValue As CreateNewValueFunction(Of IPhasorDefinition, IPhasorValue), _
    createNewFrequencyValue As CreateNewValueFunction(Of IFrequencyDefinition, IFrequencyValue), _
    createNewAnalogValue As CreateNewValueFunction(Of IAnalogDefinition, IAnalogValue), _
    createNewDigitalValue As CreateNewValueFunction(Of IDigitalDefinition, IDigitalValue) _
)
public:
DataCellParsingState(
    IConfigurationCell^ configurationCell,
    CreateNewValueFunction<IPhasorDefinition^, IPhasorValue^>^ createNewPhasorValue,
    CreateNewValueFunction<IFrequencyDefinition^, IFrequencyValue^>^ createNewFrequencyValue,
    CreateNewValueFunction<IAnalogDefinition^, IAnalogValue^>^ createNewAnalogValue,
    CreateNewValueFunction<IDigitalDefinition^, IDigitalValue^>^ createNewDigitalValue
)
Parameters
configurationCell (IConfigurationCell)
Reference to the IConfigurationCell associated with the IDataCell being parsed.
createNewPhasorValue (CreateNewValueFunction <(Of <(<' IPhasorDefinition, IPhasorValue >)>)>)
Reference to delegate to create new IPhasorValue instances.
createNewFrequencyValue (CreateNewValueFunction <(Of <(<' IFrequencyDefinition, IFrequencyValue >)>)>)
Reference to delegate to create new IFrequencyValue instances.
createNewAnalogValue (CreateNewValueFunction <(Of <(<' IAnalogDefinition, IAnalogValue >)>)>)
Reference to delegate to create new IAnalogValue instances.
createNewDigitalValue (CreateNewValueFunction <(Of <(<' IDigitalDefinition, IDigitalValue >)>)>)
Reference to delegate to create new IDigitalValue instances.


ConfigurationCell Property

ConfigurationCell Property
Namespaces ► TVA.PhasorProtocols ► DataCellParsingState ► ConfigurationCell
Gets reference to the IConfigurationCell associated with the IDataCell being parsed.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IConfigurationCell ConfigurationCell { get; }
Public Overridable ReadOnly Property ConfigurationCell As IConfigurationCell
    Get
public:
virtual property IConfigurationCell^ ConfigurationCell {
    IConfigurationCell^ get ();
}


CreateNewAnalogValue Property

CreateNewAnalogValue Property
Namespaces ► TVA.PhasorProtocols ► DataCellParsingState ► CreateNewAnalogValue
Gets reference to CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> delegate used to create new IAnalogValue objects.
Declaration Syntax
C# Visual Basic Visual C++
public virtual CreateNewValueFunction<IAnalogDefinition, IAnalogValue> CreateNewAnalogValue { get; }
Public Overridable ReadOnly Property CreateNewAnalogValue As CreateNewValueFunction(Of IAnalogDefinition, IAnalogValue)
    Get
public:
virtual property CreateNewValueFunction<IAnalogDefinition^, IAnalogValue^>^ CreateNewAnalogValue {
    CreateNewValueFunction<IAnalogDefinition^, IAnalogValue^>^ get ();
}


CreateNewDigitalValue Property

CreateNewDigitalValue Property
Namespaces ► TVA.PhasorProtocols ► DataCellParsingState ► CreateNewDigitalValue
Gets reference to CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> delegate used to create new IDigitalValue objects.
Declaration Syntax
C# Visual Basic Visual C++
public virtual CreateNewValueFunction<IDigitalDefinition, IDigitalValue> CreateNewDigitalValue { get; }
Public Overridable ReadOnly Property CreateNewDigitalValue As CreateNewValueFunction(Of IDigitalDefinition, IDigitalValue)
    Get
public:
virtual property CreateNewValueFunction<IDigitalDefinition^, IDigitalValue^>^ CreateNewDigitalValue {
    CreateNewValueFunction<IDigitalDefinition^, IDigitalValue^>^ get ();
}


CreateNewFrequencyValue Property

CreateNewFrequencyValue Property
Namespaces ► TVA.PhasorProtocols ► DataCellParsingState ► CreateNewFrequencyValue
Gets reference to CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> delegate used to create new IFrequencyValue objects.
Declaration Syntax
C# Visual Basic Visual C++
public virtual CreateNewValueFunction<IFrequencyDefinition, IFrequencyValue> CreateNewFrequencyValue { get; }
Public Overridable ReadOnly Property CreateNewFrequencyValue As CreateNewValueFunction(Of IFrequencyDefinition, IFrequencyValue)
    Get
public:
virtual property CreateNewValueFunction<IFrequencyDefinition^, IFrequencyValue^>^ CreateNewFrequencyValue {
    CreateNewValueFunction<IFrequencyDefinition^, IFrequencyValue^>^ get ();
}


CreateNewPhasorValue Property

CreateNewPhasorValue Property
Namespaces ► TVA.PhasorProtocols ► DataCellParsingState ► CreateNewPhasorValue
Gets reference to CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> delegate used to create new IPhasorValue objects.
Declaration Syntax
C# Visual Basic Visual C++
public virtual CreateNewValueFunction<IPhasorDefinition, IPhasorValue> CreateNewPhasorValue { get; }
Public Overridable ReadOnly Property CreateNewPhasorValue As CreateNewValueFunction(Of IPhasorDefinition, IPhasorValue)
    Get
public:
virtual property CreateNewValueFunction<IPhasorDefinition^, IPhasorValue^>^ CreateNewPhasorValue {
    CreateNewValueFunction<IPhasorDefinition^, IPhasorValue^>^ get ();
}


DataFormat Enumeration

DataFormat Enumeration
Namespaces ► TVA.PhasorProtocols ► DataFormat
Data transmission formats enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum DataFormat
<SerializableAttribute> _
Public Enumeration DataFormat
[SerializableAttribute]
public enum class DataFormat
Members
Member | Description
FixedInteger | Fixed integer data transmission format.
FloatingPoint | Floating point data transmission format.


DataFrameBase Class

DataFrameBase Class
Namespaces ► TVA.PhasorProtocols ► DataFrameBase
Represents the protocol independent common implementation of any IDataFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class DataFrameBase : ChannelFrameBase<IDataCell>,
    IDataFrame, IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable<IFrame>, IComparable<IFrame>, IComparable,
    ISerializable
<SerializableAttribute> _
Public MustInherit Class DataFrameBase _
    Inherits ChannelFrameBase(Of IDataCell) _
    Implements IDataFrame, IChannelFrame, IChannel, ISupportBinaryImage,  _
    IFrame, IEquatable(Of IFrame), IComparable(Of IFrame),  _
    IComparable, ISerializable
[SerializableAttribute]
public ref class DataFrameBase abstract : public ChannelFrameBase<IDataCell^>,
    IDataFrame, IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable<IFrame^>, IComparable<IFrame^>, IComparable,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataFrameBase(DataCellCollection, Ticks, IConfigurationFrame) | Creates a new DataFrameBase from specified parameters.
 | DataFrameBase(SerializationInfo, StreamingContext) | Creates a new DataFrameBase from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ChannelFrameBase<(Of <(<'T>)>)> object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Cells | Gets reference to the DataCellCollection for this DataFrameBase.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ConfigurationFrame | Gets or sets IConfigurationFrame associated with this DataFrameBase.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.FrameType.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets the numeric ID code for this DataFrameBase. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.IDCode.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.Initialize(array<Byte>[]()[][], Int32, Int32).)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this DataFrameBase.
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IDataCell >)>)>
 |  |  |  | DataFrameBase
 |  |  |  |  | DataFrame
 |  |  |  |  | DataFrame
 |  |  |  |  | DataFrame
 |  |  |  |  | DataFrame
 |  |  |  |  | DataFrame
 |  |  |  |  | DataFrame


DataFrameBase Constructor

DataFrameBase Constructor
Namespaces ► TVA.PhasorProtocols ► DataFrameBase ► DataFrameBase()()()()
Members
Icon | Member | Description
 | DataFrameBase(DataCellCollection, Ticks, IConfigurationFrame) | Creates a new DataFrameBase from specified parameters.
 | DataFrameBase(SerializationInfo, StreamingContext) | Creates a new DataFrameBase from serialization parameters.


DataFrameBase Constructor (info, context)

DataFrameBase Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► DataFrameBase ► DataFrameBase(SerializationInfo, StreamingContext)
Creates a new DataFrameBase from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataFrameBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataFrameBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DataFrameBase Constructor (cells, timestamp, configurationFrame)

DataFrameBase Constructor (cells, timestamp, configurationFrame)
Namespaces ► TVA.PhasorProtocols ► DataFrameBase ► DataFrameBase(DataCellCollection, Ticks, IConfigurationFrame)
Creates a new DataFrameBase from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataFrameBase(
    DataCellCollection cells,
    Ticks timestamp,
    IConfigurationFrame configurationFrame
)
Protected Sub New ( _
    cells As DataCellCollection, _
    timestamp As Ticks, _
    configurationFrame As IConfigurationFrame _
)
protected:
DataFrameBase(
    DataCellCollection^ cells,
    Ticks timestamp,
    IConfigurationFrame^ configurationFrame
)
Parameters
cells (DataCellCollection)
The reference to the collection of cells for this DataFrameBase.
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this DataFrameBase.
configurationFrame (IConfigurationFrame)
The IConfigurationFrame associated with this DataFrameBase.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols ► DataFrameBase ► Cells
Gets reference to the DataCellCollection for this DataFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCellCollection Cells { get; }
Public Overridable ReadOnly Property Cells As DataCellCollection
    Get
public:
virtual property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols ► DataFrameBase ► ConfigurationFrame
Gets or sets IConfigurationFrame associated with this DataFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IConfigurationFrame ConfigurationFrame { get; set; }
Public Overridable Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get ();
    void set (IConfigurationFrame^ value);
}


FrameType Property

FrameType Property
Namespaces ► TVA.PhasorProtocols ► DataFrameBase ► FrameType
Gets the FundamentalFrameType for this DataFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public override FundamentalFrameType FrameType { get; }
Public Overrides ReadOnly Property FrameType As FundamentalFrameType
    Get
public:
virtual property FundamentalFrameType FrameType {
    FundamentalFrameType get () override;
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► DataFrameBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols ► DataFrameBase ► IDCode
Gets the numeric ID code for this DataFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public override ushort IDCode { get; set; }
Public Overrides Property IDCode As UShort
    Get
    Set
public:
virtual property unsigned short IDCode {
    unsigned short get () override;
    void set (unsigned short value) override;
}
Remarks
This value is read-only for DataFrameBase; assigning a value will throw an exception. Value returned is the IDCode of the associated ConfigurationFrame.
Exceptions
Exception | Condition
NotSupportedException | IDCode of a data frame is read-only, change IDCode is associated configuration frame instead.


Initialize Method (binaryImage, startIndex, length)

Initialize Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols ► DataFrameBase ► Initialize(array<Byte>[]()[][], Int32, Int32)
Parses the binary image.
Declaration Syntax
C# Visual Basic Visual C++
public override int Initialize(
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Overrides Function Initialize ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
public:
virtual int Initialize(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
This method is overriden to ensure assignment of configuration frame.


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► DataFrameBase ► State
Gets or sets the parsing state for the this DataFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IDataFrameParsingState State { get; set; }
Public Overridable Property State As IDataFrameParsingState
    Get
    Set
public:
virtual property IDataFrameParsingState^ State {
    IDataFrameParsingState^ get ();
    void set (IDataFrameParsingState^ value);
}


DataFrameCollection Class

DataFrameCollection Class
Namespaces ► TVA.PhasorProtocols ► DataFrameCollection
Represents a protocol independent collection of IDataFrame objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataFrameCollection : ChannelFrameCollectionBase<IDataFrame>
<SerializableAttribute> _
Public Class DataFrameCollection _
    Inherits ChannelFrameCollectionBase(Of IDataFrame)
[SerializableAttribute]
public ref class DataFrameCollection : public ChannelFrameCollectionBase<IDataFrame^>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataFrameCollection(Int32) | Creates a new DataFrameCollection using specified lastValidIndex.
 | DataFrameCollection(SerializationInfo, StreamingContext) | Creates a new DataFrameCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' T >)>)>
 |  | ChannelCollectionBase <(Of <(<' T >)>)>
 |  |  | ChannelFrameCollectionBase <(Of <(<' IDataFrame >)>)>
 |  |  |  | DataFrameCollection


DataFrameCollection Constructor

DataFrameCollection Constructor
Namespaces ► TVA.PhasorProtocols ► DataFrameCollection ► DataFrameCollection()()()()
Members
Icon | Member | Description
 | DataFrameCollection(Int32) | Creates a new DataFrameCollection using specified lastValidIndex.
 | DataFrameCollection(SerializationInfo, StreamingContext) | Creates a new DataFrameCollection from serialization parameters.


DataFrameCollection Constructor (lastValidIndex)

DataFrameCollection Constructor (lastValidIndex)
Namespaces ► TVA.PhasorProtocols ► DataFrameCollection ► DataFrameCollection(Int32)
Creates a new DataFrameCollection using specified lastValidIndex.
Declaration Syntax
C# Visual Basic Visual C++
public DataFrameCollection(
    int lastValidIndex
)
Public Sub New ( _
    lastValidIndex As Integer _
)
public:
DataFrameCollection(
    int lastValidIndex
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


DataFrameCollection Constructor (info, context)

DataFrameCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► DataFrameCollection ► DataFrameCollection(SerializationInfo, StreamingContext)
Creates a new DataFrameCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataFrameCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataFrameCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DataFrameParsingState Class

DataFrameParsingState Class
Namespaces ► TVA.PhasorProtocols ► DataFrameParsingState
Represents the protocol independent common implementation of the parsing state used by any IDataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public class DataFrameParsingState : ChannelFrameParsingStateBase<IDataCell>,
    IDataFrameParsingState, IChannelFrameParsingState<IDataCell>, IChannelParsingState
Public Class DataFrameParsingState _
    Inherits ChannelFrameParsingStateBase(Of IDataCell) _
    Implements IDataFrameParsingState, IChannelFrameParsingState(Of IDataCell),  _
    IChannelParsingState
public ref class DataFrameParsingState : public ChannelFrameParsingStateBase<IDataCell^>,
    IDataFrameParsingState, IChannelFrameParsingState<IDataCell^>, IChannelParsingState
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataFrameParsingState(Int32, IConfigurationFrame, CreateNewCellFunction<(Of <<'(IDataCell>)>>)) | Creates a new DataFrameParsingState from specified parameters.
 | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBase<(Of <(<'T>)>)>.)
 | ConfigurationFrame | Gets reference to the IConfigurationFrame associated with the IDataFrame being parsed.
 | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ChannelParsingStateBase
 |  | ChannelFrameParsingStateBase <(Of <(<' IDataCell >)>)>
 |  |  | DataFrameParsingState
 |  |  |  | DataFrameParsingState


DataFrameParsingState Constructor (parsedBinaryLength, configurationFrame, createNewCellFunction)

DataFrameParsingState Constructor (parsedBinaryLength, configurationFrame, createNewCellFunction)
Namespaces ► TVA.PhasorProtocols ► DataFrameParsingState ► DataFrameParsingState(Int32, IConfigurationFrame, CreateNewCellFunction<(Of <<'(IDataCell>)>>))
Creates a new DataFrameParsingState from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DataFrameParsingState(
    int parsedBinaryLength,
    IConfigurationFrame configurationFrame,
    CreateNewCellFunction<IDataCell> createNewCellFunction
)
Public Sub New ( _
    parsedBinaryLength As Integer, _
    configurationFrame As IConfigurationFrame, _
    createNewCellFunction As CreateNewCellFunction(Of IDataCell) _
)
public:
DataFrameParsingState(
    int parsedBinaryLength,
    IConfigurationFrame^ configurationFrame,
    CreateNewCellFunction<IDataCell^>^ createNewCellFunction
)
Parameters
parsedBinaryLength (Int32)
Binary length of the IDataFrame being parsed.
configurationFrame (IConfigurationFrame)
Reference to the IConfigurationFrame associated with the IDataFrame being parsed.
createNewCellFunction (CreateNewCellFunction <(Of <(<' IDataCell >)>)>)
Reference to delegate to create new IDataCell instances.


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols ► DataFrameParsingState ► ConfigurationFrame
Gets reference to the IConfigurationFrame associated with the IDataFrame being parsed.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IConfigurationFrame ConfigurationFrame { get; }
Public Overridable ReadOnly Property ConfigurationFrame As IConfigurationFrame
    Get
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get ();
}


DataSortingType Enumeration

DataSortingType Enumeration
Namespaces ► TVA.PhasorProtocols ► DataSortingType
Data sorting types enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum DataSortingType
<SerializableAttribute> _
Public Enumeration DataSortingType
[SerializableAttribute]
public enum class DataSortingType
Members
Member | Description
ByTimestamp | Data sorted by timestamp (typical situation).
ByArrival | Data sorted by arrival (bad timestamp).


DeviceCommand Enumeration

DeviceCommand Enumeration
Namespaces ► TVA.PhasorProtocols ► DeviceCommand
Phasor enabled device commands enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum DeviceCommand
<SerializableAttribute> _
Public Enumeration DeviceCommand
[SerializableAttribute]
public enum class DeviceCommand
Members
Member | Description
DisableRealTimeData | 0001 Turn off transmission of data frames.
EnableRealTimeData | 0010 Turn on transmission of data frames.
SendHeaderFrame | 0011 Send header file.
SendConfigurationFrame1 | 0100 Send configuration file 1.
SendConfigurationFrame2 | 0101 Send configuration file 2.
ReceiveExtendedFrame | 1000 Receive extended frame for IEEE C37.118 / receive reference phasor for IEEE 1344.
ReservedBits | Reserved bits.


DigitalDefinitionBase Class

DigitalDefinitionBase Class
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionBase
Represents the common implementation of the protocol independent definition of a IDigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class DigitalDefinitionBase : ChannelDefinitionBase,
    IDigitalDefinition, IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IChannelDefinition>, IComparable<IChannelDefinition>, IComparable
<SerializableAttribute> _
Public MustInherit Class DigitalDefinitionBase _
    Inherits ChannelDefinitionBase _
    Implements IDigitalDefinition, IChannelDefinition, IChannel, ISupportBinaryImage,  _
    ISerializable, IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition),  _
    IComparable
[SerializableAttribute]
public ref class DigitalDefinitionBase abstract : public ChannelDefinitionBase,
    IDigitalDefinition, IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IChannelDefinition^>, IComparable<IChannelDefinition^>, IComparable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalDefinitionBase(IConfigurationCell) | Creates a new DigitalDefinitionBase.
 | DigitalDefinitionBase(IConfigurationCell, String) | Creates a new DigitalDefinitionBase from specified parameters.
 | DigitalDefinitionBase(SerializationInfo, StreamingContext) | Creates a new DigitalDefinitionBase from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Overrides ChannelDefinitionBase.DataFormat.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Overrides ChannelDefinitionBase.Offset.)
 | Parent | Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Overrides ChannelDefinitionBase.ScalePerBit.)
 | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Overrides ChannelDefinitionBase.ScalingValue.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | DigitalDefinitionBase
 |  |  |  |  | DigitalDefinition
 |  |  |  |  | DigitalDefinition
 |  |  |  |  | DigitalDefinition
 |  |  |  |  | DigitalDefinition
 |  |  |  |  | DigitalDefinition


DigitalDefinitionBase Constructor

DigitalDefinitionBase Constructor
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionBase ► DigitalDefinitionBase()()()()
Members
Icon | Member | Description
 | DigitalDefinitionBase(IConfigurationCell) | Creates a new DigitalDefinitionBase.
 | DigitalDefinitionBase(IConfigurationCell, String) | Creates a new DigitalDefinitionBase from specified parameters.
 | DigitalDefinitionBase(SerializationInfo, StreamingContext) | Creates a new DigitalDefinitionBase from serialization parameters.


DigitalDefinitionBase Constructor (info, context)

DigitalDefinitionBase Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionBase ► DigitalDefinitionBase(SerializationInfo, StreamingContext)
Creates a new DigitalDefinitionBase from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalDefinitionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DigitalDefinitionBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DigitalDefinitionBase Constructor (parent)

DigitalDefinitionBase Constructor (parent)
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionBase ► DigitalDefinitionBase(IConfigurationCell)
Creates a new DigitalDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalDefinitionBase(
    IConfigurationCell parent
)
Protected Sub New ( _
    parent As IConfigurationCell _
)
protected:
DigitalDefinitionBase(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this DigitalDefinitionBase.


DigitalDefinitionBase Constructor (parent, label)

DigitalDefinitionBase Constructor (parent, label)
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionBase ► DigitalDefinitionBase(IConfigurationCell, String)
Creates a new DigitalDefinitionBase from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalDefinitionBase(
    IConfigurationCell parent,
    string label
)
Protected Sub New ( _
    parent As IConfigurationCell, _
    label As String _
)
protected:
DigitalDefinitionBase(
    IConfigurationCell^ parent,
    String^ label
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this DigitalDefinitionBase.
label (String)
The label of this DigitalDefinitionBase.


DataFormat Property

DataFormat Property
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionBase ► DataFormat
Gets the DataFormat of this DigitalDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override sealed DataFormat DataFormat { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides NotOverridable ReadOnly Property DataFormat As DataFormat
    Get
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property DataFormat DataFormat {
    DataFormat get () override sealed;
}
Remarks
Data format for digital values will always be FixedInteger.


Offset Property

Offset Property
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionBase ► Offset
Gets or sets the offset of this DigitalDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override sealed double Offset { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides NotOverridable Property Offset As Double
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property double Offset {
    double get () override sealed;
    void set (double value) override sealed;
}
Remarks
Offset for digital values will always be 0; assigning a value other than 0 will thrown an exception.
Exceptions
Exception | Condition
NotImplementedException | Digital values represent bit flags and thus do not support an offset.


ScalePerBit Property

ScalePerBit Property
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionBase ► ScalePerBit
Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override sealed double ScalePerBit { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides NotOverridable ReadOnly Property ScalePerBit As Double
    Get
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property double ScalePerBit {
    double get () override sealed;
}
Remarks
Scale/bit for digital values will always be 1.0.


ScalingValue Property

ScalingValue Property
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionBase ► ScalingValue
Gets or sets the integer scaling value of this DigitalDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override sealed uint ScalingValue { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides NotOverridable Property ScalingValue As UInteger
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property unsigned int ScalingValue {
    unsigned int get () override sealed;
    void set (unsigned int value) override sealed;
}
Remarks
Scaling value for digital values will always be 1; assigning a value other than 1 will thrown an exception.
Exceptions
Exception | Condition
NotImplementedException | Digital values represent bit flags and thus are not scaled.


DigitalDefinitionCollection Class

DigitalDefinitionCollection Class
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionCollection
Represents a protocol independent collection of IDigitalDefinition objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DigitalDefinitionCollection : ChannelDefinitionCollectionBase<IDigitalDefinition>
<SerializableAttribute> _
Public Class DigitalDefinitionCollection _
    Inherits ChannelDefinitionCollectionBase(Of IDigitalDefinition)
[SerializableAttribute]
public ref class DigitalDefinitionCollection : public ChannelDefinitionCollectionBase<IDigitalDefinition^>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalDefinitionCollection(Int32) | Creates a new DigitalDefinitionCollection using specified lastValidIndex.
 | DigitalDefinitionCollection(SerializationInfo, StreamingContext) | Creates a new DigitalDefinitionCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelDefinitionCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelDefinitionCollectionBase<(Of <(<'T>)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelDefinitionCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelDefinitionCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelDefinitionCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' T >)>)>
 |  | ChannelCollectionBase <(Of <(<' T >)>)>
 |  |  | ChannelDefinitionCollectionBase <(Of <(<' IDigitalDefinition >)>)>
 |  |  |  | DigitalDefinitionCollection


DigitalDefinitionCollection Constructor

DigitalDefinitionCollection Constructor
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionCollection ► DigitalDefinitionCollection()()()()
Members
Icon | Member | Description
 | DigitalDefinitionCollection(Int32) | Creates a new DigitalDefinitionCollection using specified lastValidIndex.
 | DigitalDefinitionCollection(SerializationInfo, StreamingContext) | Creates a new DigitalDefinitionCollection from serialization parameters.


DigitalDefinitionCollection Constructor (lastValidIndex)

DigitalDefinitionCollection Constructor (lastValidIndex)
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionCollection ► DigitalDefinitionCollection(Int32)
Creates a new DigitalDefinitionCollection using specified lastValidIndex.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalDefinitionCollection(
    int lastValidIndex
)
Public Sub New ( _
    lastValidIndex As Integer _
)
public:
DigitalDefinitionCollection(
    int lastValidIndex
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


DigitalDefinitionCollection Constructor (info, context)

DigitalDefinitionCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionCollection ► DigitalDefinitionCollection(SerializationInfo, StreamingContext)
Creates a new DigitalDefinitionCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalDefinitionCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DigitalDefinitionCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DigitalValueBase Class

DigitalValueBase Class
Namespaces ► TVA.PhasorProtocols ► DigitalValueBase
Represents the common implementation of the protocol independent representation of a digital value.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class DigitalValueBase : ChannelValueBase<IDigitalDefinition>,
    IDigitalValue, IChannelValue<IDigitalDefinition>, IChannel, ISupportBinaryImage,
    ISerializable
<SerializableAttribute> _
Public MustInherit Class DigitalValueBase _
    Inherits ChannelValueBase(Of IDigitalDefinition) _
    Implements IDigitalValue, IChannelValue(Of IDigitalDefinition),  _
    IChannel, ISupportBinaryImage, ISerializable
[SerializableAttribute]
public ref class DigitalValueBase abstract : public ChannelValueBase<IDigitalDefinition^>,
    IDigitalValue, IChannelValue<IDigitalDefinition^>, IChannel, ISupportBinaryImage,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalValueBase(IDataCell, IDigitalDefinition) | Creates a new DigitalValueBase.
 | DigitalValueBase(IDataCell, IDigitalDefinition, UInt16) | Creates a new DigitalValueBase from specified parameters.
 | DigitalValueBase(SerializationInfo, StreamingContext) | Creates a new DigitalValueBase from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DigitalValueBase object. (Overrides ChannelValueBase <(Of <(<' IDigitalDefinition >)>)>.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the DigitalValueBase object. (Overrides BinaryImageBase.BodyImage()()()().)
 | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBase.BodyLength()()()().)
 | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Overrides ChannelValueBase <(Of <(<' IDigitalDefinition >)>)>.CompositeValueCount.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the IChannelDefinition associated with this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this DigitalValueBase. (Overrides ChannelValueBase <(Of <(<' IDigitalDefinition >)>)>.GetCompositeValue(Int32).)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Overrides ChannelValueBase <(Of <(<' IDigitalDefinition >)>)>.GetMeasurementValueFilterFunction(Int32).)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelValueBase <(Of <(<' IDigitalDefinition >)>)>.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Overrides ChannelValueBase <(Of <(<' IDigitalDefinition >)>)>.IsEmpty.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the IDataCell parent of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides BinaryImageBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IDigitalDefinition >)>)>
 |  |  |  | DigitalValueBase
 |  |  |  |  | DigitalValue
 |  |  |  |  | DigitalValue
 |  |  |  |  | DigitalValue
 |  |  |  |  | DigitalValue


DigitalValueBase Constructor

DigitalValueBase Constructor
Namespaces ► TVA.PhasorProtocols ► DigitalValueBase ► DigitalValueBase()()()()
Members
Icon | Member | Description
 | DigitalValueBase(IDataCell, IDigitalDefinition) | Creates a new DigitalValueBase.
 | DigitalValueBase(IDataCell, IDigitalDefinition, UInt16) | Creates a new DigitalValueBase from specified parameters.
 | DigitalValueBase(SerializationInfo, StreamingContext) | Creates a new DigitalValueBase from serialization parameters.


DigitalValueBase Constructor (info, context)

DigitalValueBase Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► DigitalValueBase ► DigitalValueBase(SerializationInfo, StreamingContext)
Creates a new DigitalValueBase from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalValueBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DigitalValueBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DigitalValueBase Constructor (parent, digitalDefinition)

DigitalValueBase Constructor (parent, digitalDefinition)
Namespaces ► TVA.PhasorProtocols ► DigitalValueBase ► DigitalValueBase(IDataCell, IDigitalDefinition)
Creates a new DigitalValueBase.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalValueBase(
    IDataCell parent,
    IDigitalDefinition digitalDefinition
)
Protected Sub New ( _
    parent As IDataCell, _
    digitalDefinition As IDigitalDefinition _
)
protected:
DigitalValueBase(
    IDataCell^ parent,
    IDigitalDefinition^ digitalDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this DigitalValueBase.
digitalDefinition (IDigitalDefinition)
The IDigitalDefinition associated with this DigitalValueBase.


DigitalValueBase Constructor (parent, digitalDefinition, value)

DigitalValueBase Constructor (parent, digitalDefinition, value)
Namespaces ► TVA.PhasorProtocols ► DigitalValueBase ► DigitalValueBase(IDataCell, IDigitalDefinition, UInt16)
Creates a new DigitalValueBase from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalValueBase(
    IDataCell parent,
    IDigitalDefinition digitalDefinition,
    ushort value
)
Protected Sub New ( _
    parent As IDataCell, _
    digitalDefinition As IDigitalDefinition, _
    value As UShort _
)
protected:
DigitalValueBase(
    IDataCell^ parent,
    IDigitalDefinition^ digitalDefinition,
    unsigned short value
)
Parameters
parent (IDataCell)
The IDataCell parent of this DigitalValueBase.
digitalDefinition (IDigitalDefinition)
The IDigitalDefinition associated with this DigitalValueBase.
value (UInt16)
The unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► DigitalValueBase ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DigitalValueBase object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols ► DigitalValueBase ► BodyImage
Gets the binary body image of the DigitalValueBase object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols ► DigitalValueBase ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}


CompositeValueCount Property

CompositeValueCount Property
Namespaces ► TVA.PhasorProtocols ► DigitalValueBase ► CompositeValueCount
Gets total number of composite values that this DigitalValueBase provides.
Declaration Syntax
C# Visual Basic Visual C++
public override int CompositeValueCount { get; }
Public Overrides ReadOnly Property CompositeValueCount As Integer
    Get
public:
virtual property int CompositeValueCount {
    int get () override;
}


GetCompositeValue Method (index)

GetCompositeValue Method (index)
Namespaces ► TVA.PhasorProtocols ► DigitalValueBase ► GetCompositeValue(Int32)
Gets the specified composite value of this DigitalValueBase.
Declaration Syntax
C# Visual Basic Visual C++
public override double GetCompositeValue(
    int index
)
Public Overrides Function GetCompositeValue ( _
    index As Integer _
) As Double
public:
virtual double GetCompositeValue(
    int index
) override
Parameters
index (Int32)
Index of composite value to retrieve.
Return Value
A Double representing the composite value.
Remarks
Some ChannelValueBase<(Of <(<'T>)>)> implementations can contain more than one value, this method is used to abstractly expose each value.


GetMeasurementValueFilterFunction Method (index)

GetMeasurementValueFilterFunction Method (index)
Namespaces ► TVA.PhasorProtocols ► DigitalValueBase ► GetMeasurementValueFilterFunction(Int32)
Gets function used to apply a downsampling filter over a sequence of IMeasurement values.
Declaration Syntax
C# Visual Basic Visual C++
public override MeasurementValueFilterFunction GetMeasurementValueFilterFunction(
    int index
)
Public Overrides Function GetMeasurementValueFilterFunction ( _
    index As Integer _
) As MeasurementValueFilterFunction
public:
virtual MeasurementValueFilterFunction^ GetMeasurementValueFilterFunction(
    int index
) override
Parameters
index (Int32)
Index of composite value for which to retrieve its filter function.
Return Value
Majority value filter function since all values are digital in nature.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► DigitalValueBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


IsEmpty Property

IsEmpty Property
Namespaces ► TVA.PhasorProtocols ► DigitalValueBase ► IsEmpty
Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value.
Declaration Syntax
C# Visual Basic Visual C++
public override bool IsEmpty { get; }
Public Overrides ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get () override;
}
Return Value
True, if no composite values have been assigned a value; otherwise, false.


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols ► DigitalValueBase ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


Value Property

Value Property
Namespaces ► TVA.PhasorProtocols ► DigitalValueBase ► Value
Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ushort Value { get; set; }
Public Overridable Property Value As UShort
    Get
    Set
public:
virtual property unsigned short Value {
    unsigned short get ();
    void set (unsigned short value);
}


DigitalValueCollection Class

DigitalValueCollection Class
Namespaces ► TVA.PhasorProtocols ► DigitalValueCollection
Represents a protocol independent collection of IDigitalValue objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DigitalValueCollection : ChannelValueCollectionBase<IDigitalDefinition, IDigitalValue>
<SerializableAttribute> _
Public Class DigitalValueCollection _
    Inherits ChannelValueCollectionBase(Of IDigitalDefinition, IDigitalValue)
[SerializableAttribute]
public ref class DigitalValueCollection : public ChannelValueCollectionBase<IDigitalDefinition^, IDigitalValue^>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalValueCollection(Int32) | Creates a new DigitalValueCollection using specified lastValidIndex.
 | DigitalValueCollection(SerializationInfo, StreamingContext) | Creates a new DigitalValueCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDigitalValue >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | AllValuesAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> object. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDigitalValue >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDigitalValue >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IDigitalValue >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDigitalValue >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDigitalValue >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDigitalValue >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IDigitalValue >)>)>.)
 | InsertItem(Int32, TValue) | Inserts an element into the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> at the specified index. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' IDigitalValue >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDigitalValue >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDigitalValue >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDigitalValue >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | SetItem(Int32, TValue) | Replaces the element at the specified index. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IDigitalValue >)>)>
 |  | ChannelCollectionBase <(Of <(<' IDigitalValue >)>)>
 |  |  | ChannelValueCollectionBase <(Of <(<' IDigitalDefinition, IDigitalValue >)>)>
 |  |  |  | DigitalValueCollection


DigitalValueCollection Constructor

DigitalValueCollection Constructor
Namespaces ► TVA.PhasorProtocols ► DigitalValueCollection ► DigitalValueCollection()()()()
Members
Icon | Member | Description
 | DigitalValueCollection(Int32) | Creates a new DigitalValueCollection using specified lastValidIndex.
 | DigitalValueCollection(SerializationInfo, StreamingContext) | Creates a new DigitalValueCollection from serialization parameters.


DigitalValueCollection Constructor (lastValidIndex)

DigitalValueCollection Constructor (lastValidIndex)
Namespaces ► TVA.PhasorProtocols ► DigitalValueCollection ► DigitalValueCollection(Int32)
Creates a new DigitalValueCollection using specified lastValidIndex.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalValueCollection(
    int lastValidIndex
)
Public Sub New ( _
    lastValidIndex As Integer _
)
public:
DigitalValueCollection(
    int lastValidIndex
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


DigitalValueCollection Constructor (info, context)

DigitalValueCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► DigitalValueCollection ► DigitalValueCollection(SerializationInfo, StreamingContext)
Creates a new DigitalValueCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalValueCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DigitalValueCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrameParserBase(TFrameIdentifier) Class

FrameParserBase<(Of <(<'TFrameIdentifier>)>)> Class
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)>
Represents a frame parser that defines the basic functionality for a protocol to parse a binary data stream and return the parsed data via events.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class FrameParserBase<TFrameIdentifier> : FrameImageParserBase<TFrameIdentifier, ISupportFrameImage<TFrameIdentifier>>,
    IFrameParser, IProvideStatus, IDisposable

Public MustInherit Class FrameParserBase(Of TFrameIdentifier) _
    Inherits FrameImageParserBase(Of TFrameIdentifier, ISupportFrameImage(Of TFrameIdentifier)) _
    Implements IFrameParser, IProvideStatus, IDisposable
generic<typename TFrameIdentifier>
public ref class FrameParserBase abstract : public FrameImageParserBase<TFrameIdentifier, ISupportFrameImage<TFrameIdentifier>^>,
    IFrameParser, IProvideStatus, IDisposable
Generic Template Parameters
TFrameIdentifier
Frame type identifier used to distinguish frames.
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrameParserBase<(Of <(<'TFrameIdentifier>)>)>()()()() | Creates a new FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.
 | BeginRead(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead()()()() | (Inherited from BinaryImageParserBase.)
 | CanSeek()()()() | (Inherited from BinaryImageParserBase.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite()()()() | (Inherited from BinaryImageParserBase.)
 | Close()()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed.
 | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
 | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing.
 | CreateBufferQueue()()()() | Creates the internal buffer queue.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | DataDiscarded()()()() | (Inherited from BinaryImageParserBase.)
 | DataParsed()()()() | (Inherited from FrameImageParserBase<(Of <(<'TFrameIdentifier, ISupportFrameImage<(Of <(<'TFrameIdentifier>)>)>>)>)>.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBase<(Of <(<'TFrameIdentifier>)>)> object and optionally releases the managed resources. (Overrides FrameImageParserBase<(Of <(<'TFrameIdentifier, ISupportFrameImage<(Of <(<'TFrameIdentifier>)>)>>)>)>.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | DuplicateTypeHandlerEncountered()()()() | (Inherited from FrameImageParserBase<(Of <(<'TFrameIdentifier, ISupportFrameImage<(Of <(<'TFrameIdentifier>)>)>>)>)>.)
 | Enabled()()()() | (Inherited from BinaryImageParserBase.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteParseOnSeparateThread | Gets or sets a flag that allows frame parsing to be executed on a separate thread (i.e., other than communications thread).
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()()() | Clears all buffers for this stream and causes any buffered data to be parsed immediately. (Overrides BinaryImageParserBase.Flush()()()().)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length()()()() | (Inherited from BinaryImageParserBase.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()()()() | (Inherited from BinaryImageParserBase.)
 | OnConfigurationChanged()()()() | Raises the ConfigurationChanged event.
 | OnDataDiscarded(array<Byte>[]()[][]) | (Inherited from BinaryImageParserBase.)
 | OnDataParsed(UTP) | (Inherited from FrameImageParserBase<(Of <(<'TFrameIdentifier, ISupportFrameImage<(Of <(<'TFrameIdentifier>)>)>>)>)>.)
 | OnDuplicateTypeHandlerEncountered(Type, UTP) | (Inherited from FrameImageParserBase<(Of <(<'TFrameIdentifier, ISupportFrameImage<(Of <(<'TFrameIdentifier>)>)>>)>)>.)
 | OnOutputTypeNotFound(UTP) | (Inherited from FrameImageParserBase<(Of <(<'TFrameIdentifier, ISupportFrameImage<(Of <(<'TFrameIdentifier>)>)>>)>)>.)
 | OnParsingException(Exception) | (Inherited from BinaryImageParserBase.)
 | OnReceivedChannelFrame(IChannelFrame) | Casts the parsed IChannelFrame to its specific implementation (i.e., IDataFrame, IConfigurationFrame, ICommandFrame or IHeaderFrame).
 | OnReceivedCommandFrame(ICommandFrame) | Raises the ReceivedCommandFrame event.
 | OnReceivedConfigurationFrame(IConfigurationFrame) | Raises the ReceivedConfigurationFrame event.
 | OnReceivedDataFrame(IDataFrame) | Raises the ReceivedDataFrame event.
 | OnReceivedFrameBufferImage(FundamentalFrameType, array<Byte>[]()[][], Int32, Int32) | Raises the ReceivedFrameBufferImage event.
 | OnReceivedHeaderFrame(IHeaderFrame) | Raises the ReceivedHeaderFrame event.
 | OnReceivedUndeterminedFrame(IChannelFrame) | Raises the ReceivedUndeterminedFrame event.
 | OnUnknownFrameTypeEncountered(TFrameIdentifier) | Handles unknown frame types.
 | OutputTypeNotFound()()()() | (Inherited from FrameImageParserBase<(Of <(<'TFrameIdentifier, ISupportFrameImage<(Of <(<'TFrameIdentifier>)>)>>)>)>.)
 | Parse(ISupportBinaryImage) | (Inherited from BinaryImageParserBase.)
 | ParseCommonHeader(array<Byte>[]()[][], Int32, Int32) | (Inherited from FrameImageParserBase<(Of <(<'TFrameIdentifier, ISupportFrameImage<(Of <(<'TFrameIdentifier>)>)>>)>)>.)
 | ParseFrame(array<Byte>[]()[][], Int32, Int32) | (Inherited from FrameImageParserBase<(Of <(<'TFrameIdentifier, ISupportFrameImage<(Of <(<'TFrameIdentifier>)>)>>)>)>.)
 | ParseQueuedBuffers(array<array<Byte>[]()[][]>[]()[][]) | This method is used by the internal ProcessQueue to process all queued data buffers.
 | ParsingException()()()() | (Inherited from BinaryImageParserBase.)
 | Position()()()() | (Inherited from BinaryImageParserBase.)
 | ProtocolSyncBytes()()()() | (Inherited from BinaryImageParserBase.)
 | ProtocolUsesSyncBytes()()()() | (Inherited from BinaryImageParserBase.)
 | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any.
 | Read(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageParserBase.)
 | ReadByte()()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | ReceivedCommandFrame | Occurs when a ICommandFrame has been received.
 | ReceivedConfigurationFrame | Occurs when a IConfigurationFrame has been received.
 | ReceivedDataFrame | Occurs when a IDataFrame has been received.
 | ReceivedFrameBufferImage | Occurs when a frame buffer image has been received.
 | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received.
 | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received.
 | RunTime()()()() | (Inherited from BinaryImageParserBase.)
 | Seek(Int64, SeekOrigin) | (Inherited from BinaryImageParserBase.)
 | SetLength(Int64) | (Inherited from BinaryImageParserBase.)
 | Start(IEnumerable<(Of <<'(Type>)>>)) | Starts the frame parser given the specified type implementations. (Overrides FrameImageParserBase<(Of <(<'TFrameIdentifier, ISupportFrameImage<(Of <(<'TFrameIdentifier>)>)>>)>)>.Start(IEnumerable<(Of <<'(Type>)>>)).)
 | Start()()()() | (Inherited from FrameImageParserBase<(Of <(<'TFrameIdentifier, ISupportFrameImage<(Of <(<'TFrameIdentifier>)>)>>)>)>.)
 | Status | Gets current descriptive status of the FrameParserBase<(Of <(<'TFrameIdentifier>)>)>. (Overrides FrameImageParserBase<(Of <(<'TFrameIdentifier, ISupportFrameImage<(Of <(<'TFrameIdentifier>)>)>>)>)>.Status()()()().)
 | Stop()()()() | Stops the frame parser. (Overrides BinaryImageParserBase.Stop()()()().)
 | StreamInitialized()()()() | (Inherited from BinaryImageParserBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalProcessedBuffers()()()() | (Inherited from BinaryImageParserBase.)
 | UnparsedBuffer()()()() | (Inherited from BinaryImageParserBase.)
 | Write(array<Byte>[]()[][], Int32, Int32) | Writes a sequence of bytes onto the stream for parsing. (Overrides BinaryImageParserBase.Write(array<Byte>[]()[][], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks
Frame parsers are implemented as a write-only streams so that data can come from any source.
See FrameImageParserBase for more detail.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | BinaryImageParserBase
 |  |  |  | FrameImageParserBase<(Of <(<'TFrameIdentifier, ISupportFrameImage<(Of <(<'TFrameIdentifier>)>)>>)>)>
 |  |  |  |  | FrameParserBase<(Of <(<'TFrameIdentifier>)>)>
 |  |  |  |  |  | FrameParser
 |  |  |  |  |  | FrameParser
 |  |  |  |  |  | FrameParser
 |  |  |  |  |  | FrameParser
 |  |  |  |  |  | FrameParser
 |  |  |  |  |  | FrameParser


FrameParserBase(TFrameIdentifier) Constructor

FrameParserBase<(Of <(<'TFrameIdentifier>)>)> Constructor
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)>()()()()
Creates a new FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
protected FrameParserBase()
Protected Sub New
protected:
FrameParserBase()


ConfigurationChanged Event

ConfigurationChanged Event
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► ConfigurationChanged
Occurs when a device sends a notification that its configuration has changed.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler ConfigurationChanged
Public Event ConfigurationChanged As EventHandler
public:
virtual  event EventHandler^ ConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► ConfigurationFrame
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
Declaration Syntax
C# Visual Basic Visual C++
public abstract IConfigurationFrame ConfigurationFrame { get; set; }
Public MustOverride Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () abstract;
    void set (IConfigurationFrame^ value) abstract;
}
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.


ConnectionParameters Property

ConnectionParameters Property
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► ConnectionParameters
Gets or sets any connection specific IConnectionParameters that may be needed for parsing.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IConnectionParameters ConnectionParameters { get; set; }
Public Overridable Property ConnectionParameters As IConnectionParameters
    Get
    Set
public:
virtual property IConnectionParameters^ ConnectionParameters {
    IConnectionParameters^ get ();
    void set (IConnectionParameters^ value);
}


CreateBufferQueue Method

CreateBufferQueue Method
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► CreateBufferQueue()()()()
Creates the internal buffer queue.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual ProcessQueue<byte[]> CreateBufferQueue()
Protected Overridable Function CreateBufferQueue As ProcessQueue(Of Byte())
protected:
virtual ProcessQueue<array<unsigned char>^>^ CreateBufferQueue()
Return Value
New internal buffer processing queue (i.e., a new ProcessQueue).
Remarks

This method is virtual to allow derived classes to customize the style of processing queue used when consumers choose to implement an internal buffer queue (i.e., set ExecuteParseOnSeparateThread to true). Default type is a real-time queue with the default settings. When overriding this method, be sure to use the ParseQueuedBuffers(array<array<Byte>[]()[][]>[]()[][]) method for the ProcessQueue) item processing delegate.

Note that current design only supports synchronous parsing - consumer overriding this method to return an asynchronous (i.e., multi-threaded) process queue will need to redesign the processing delegate.


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► Dispose(Boolean)
Releases the unmanaged resources used by the FrameParserBase<(Of <(<'TFrameIdentifier>)>)> object and optionally releases the managed resources.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true to release both managed and unmanaged resources; false to release only unmanaged resources.


ExecuteParseOnSeparateThread Property

ExecuteParseOnSeparateThread Property
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► ExecuteParseOnSeparateThread
Gets or sets a flag that allows frame parsing to be executed on a separate thread (i.e., other than communications thread).
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool ExecuteParseOnSeparateThread { get; set; }
Public Overridable Property ExecuteParseOnSeparateThread As Boolean
    Get
    Set
public:
virtual property bool ExecuteParseOnSeparateThread {
    bool get ();
    void set (bool value);
}
Remarks
This is typically only needed when data frames are very large. This change will happen dynamically, even if a connection is active.


Flush Method

Flush Method
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► Flush()()()()
Clears all buffers for this stream and causes any buffered data to be parsed immediately.
Declaration Syntax
C# Visual Basic Visual C++
public override void Flush()
Public Overrides Sub Flush
public:
virtual void Flush() override
Remarks

This method is only relevant when ExecuteParseOnSeparateThread is true; otherwise this method has no effect.

If the user has called Start(IEnumerable<(Of <<'(Type>)>>)) method, this method will process all remaining buffers on the calling thread until all queued buffers have been parsed - the FrameParserBase<(Of <(<'TFrameIdentifier>)>)> will then be automatically stopped. This method is typically called on shutdown to make sure any remaining queued buffers get parsed before the class instance is destructed.

It is possible for items to be queued while the flush is executing. The flush will continue to parse buffers as quickly as possible until the internal buffer queue is empty. Unless the user stops queueing data to be parsed (i.e. calling the Write(array<Byte>[]()[][], Int32, Int32) method), the flush call may never return (not a happy situtation on shutdown).

The FrameParserBase<(Of <(<'TFrameIdentifier>)>)> does not clear queue prior to destruction. If the user fails to call this method before the class is destructed, there may be data that remains unparsed in the internal buffer.


OnConfigurationChanged Method

OnConfigurationChanged Method
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► OnConfigurationChanged()()()()
Raises the ConfigurationChanged event.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnConfigurationChanged()
Protected Overridable Sub OnConfigurationChanged
protected:
virtual void OnConfigurationChanged()


OnReceivedChannelFrame Method (frame)

OnReceivedChannelFrame Method (frame)
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► OnReceivedChannelFrame(IChannelFrame)
Casts the parsed IChannelFrame to its specific implementation (i.e., IDataFrame, IConfigurationFrame, ICommandFrame or IHeaderFrame).
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnReceivedChannelFrame(
    IChannelFrame frame
)
Protected Overridable Sub OnReceivedChannelFrame ( _
    frame As IChannelFrame _
)
protected:
virtual void OnReceivedChannelFrame(
    IChannelFrame^ frame
)
Parameters
frame (IChannelFrame)
IChannelFrame that was parsed by FrameImageParserBase that implements protocol specific common frame header interface.


OnReceivedCommandFrame Method (frame)

OnReceivedCommandFrame Method (frame)
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► OnReceivedCommandFrame(ICommandFrame)
Raises the ReceivedCommandFrame event.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnReceivedCommandFrame(
    ICommandFrame frame
)
Protected Overridable Sub OnReceivedCommandFrame ( _
    frame As ICommandFrame _
)
protected:
virtual void OnReceivedCommandFrame(
    ICommandFrame^ frame
)
Parameters
frame (ICommandFrame)
ICommandFrame to send to ReceivedCommandFrame event.


OnReceivedConfigurationFrame Method (frame)

OnReceivedConfigurationFrame Method (frame)
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► OnReceivedConfigurationFrame(IConfigurationFrame)
Raises the ReceivedConfigurationFrame event.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnReceivedConfigurationFrame(
    IConfigurationFrame frame
)
Protected Overridable Sub OnReceivedConfigurationFrame ( _
    frame As IConfigurationFrame _
)
protected:
virtual void OnReceivedConfigurationFrame(
    IConfigurationFrame^ frame
)
Parameters
frame (IConfigurationFrame)
IConfigurationFrame to send to ReceivedConfigurationFrame event.


OnReceivedDataFrame Method (frame)

OnReceivedDataFrame Method (frame)
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► OnReceivedDataFrame(IDataFrame)
Raises the ReceivedDataFrame event.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnReceivedDataFrame(
    IDataFrame frame
)
Protected Overridable Sub OnReceivedDataFrame ( _
    frame As IDataFrame _
)
protected:
virtual void OnReceivedDataFrame(
    IDataFrame^ frame
)
Parameters
frame (IDataFrame)
IDataFrame to send to ReceivedDataFrame event.


OnReceivedFrameBufferImage Method (frameType, binaryImage, offset, length)

OnReceivedFrameBufferImage Method (frameType, binaryImage, offset, length)
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► OnReceivedFrameBufferImage(FundamentalFrameType, array<Byte>[]()[][], Int32, Int32)
Raises the ReceivedFrameBufferImage event.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnReceivedFrameBufferImage(
    FundamentalFrameType frameType,
    byte[] binaryImage,
    int offset,
    int length
)
Protected Overridable Sub OnReceivedFrameBufferImage ( _
    frameType As FundamentalFrameType, _
    binaryImage As Byte(), _
    offset As Integer, _
    length As Integer _
)
protected:
virtual void OnReceivedFrameBufferImage(
    FundamentalFrameType frameType,
    array<unsigned char>^ binaryImage,
    int offset,
    int length
)
Parameters
frameType (FundamentalFrameType)
FundamentalFrameType to send to ReceivedFrameBufferImage event.
binaryImage (array< Byte >[]()[][])
Frame buffer image to send to ReceivedFrameBufferImage event.
offset (Int32)
Offset into frame buffer image to send to ReceivedFrameBufferImage event.
length (Int32)
Length of data in frame buffer image to send to ReceivedFrameBufferImage event.


OnReceivedHeaderFrame Method (frame)

OnReceivedHeaderFrame Method (frame)
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► OnReceivedHeaderFrame(IHeaderFrame)
Raises the ReceivedHeaderFrame event.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnReceivedHeaderFrame(
    IHeaderFrame frame
)
Protected Overridable Sub OnReceivedHeaderFrame ( _
    frame As IHeaderFrame _
)
protected:
virtual void OnReceivedHeaderFrame(
    IHeaderFrame^ frame
)
Parameters
frame (IHeaderFrame)
IHeaderFrame to send to ReceivedHeaderFrame event.


OnReceivedUndeterminedFrame Method (frame)

OnReceivedUndeterminedFrame Method (frame)
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► OnReceivedUndeterminedFrame(IChannelFrame)
Raises the ReceivedUndeterminedFrame event.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnReceivedUndeterminedFrame(
    IChannelFrame frame
)
Protected Overridable Sub OnReceivedUndeterminedFrame ( _
    frame As IChannelFrame _
)
protected:
virtual void OnReceivedUndeterminedFrame(
    IChannelFrame^ frame
)
Parameters
frame (IChannelFrame)
IChannelFrame to send to ReceivedUndeterminedFrame event.


OnUnknownFrameTypeEncountered Method (frameType)

OnUnknownFrameTypeEncountered Method (frameType)
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► OnUnknownFrameTypeEncountered(TFrameIdentifier)
Handles unknown frame types.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnUnknownFrameTypeEncountered(
    TFrameIdentifier frameType
)
Protected Overridable Sub OnUnknownFrameTypeEncountered ( _
    frameType As TFrameIdentifier _
)
protected:
virtual void OnUnknownFrameTypeEncountered(
    TFrameIdentifier frameType
)
Parameters
frameType (TFrameIdentifier)
Unknown frame ID.


ParseQueuedBuffers Method (buffers)

ParseQueuedBuffers Method (buffers)
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► ParseQueuedBuffers(array<array<Byte>[]()[][]>[]()[][])
This method is used by the internal ProcessQueue to process all queued data buffers.
Declaration Syntax
C# Visual Basic Visual C++
protected void ParseQueuedBuffers(
    byte[][] buffers
)
Protected Sub ParseQueuedBuffers ( _
    buffers As Byte()() _
)
protected:
void ParseQueuedBuffers(
    array<array<unsigned char>^>^ buffers
)
Parameters
buffers (array<array< Byte >[]()[][]>[]()[][])
Queued buffers to process.
Remarks
This is the item processing delegate to use when overriding the CreateBufferQueue()()()() method.


QueuedBuffers Property

QueuedBuffers Property
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► QueuedBuffers
Gets the total number of buffers that are currently queued for processing, if any.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int QueuedBuffers { get; }
Public Overridable ReadOnly Property QueuedBuffers As Integer
    Get
public:
virtual property int QueuedBuffers {
    int get ();
}


ReceivedCommandFrame Event

ReceivedCommandFrame Event
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► ReceivedCommandFrame
Occurs when a ICommandFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<ICommandFrame>> ReceivedCommandFrame
Public Event ReceivedCommandFrame As EventHandler(Of EventArgs(Of ICommandFrame))
public:
virtual  event EventHandler<EventArgs<ICommandFrame^>^>^ ReceivedCommandFrame {
    void add (EventHandler<EventArgs<ICommandFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ICommandFrame^>^>^ value);
}
Remarks
Argument()()()() is the ICommandFrame that was received.

Command frames are normally sent, not received, but there is nothing that prevents this.


ReceivedConfigurationFrame Event

ReceivedConfigurationFrame Event
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► ReceivedConfigurationFrame
Occurs when a IConfigurationFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<IConfigurationFrame>> ReceivedConfigurationFrame
Public Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of IConfigurationFrame))
public:
virtual  event EventHandler<EventArgs<IConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<IConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IConfigurationFrame^>^>^ value);
}
Remarks
Argument()()()() is the IConfigurationFrame that was received.


ReceivedDataFrame Event

ReceivedDataFrame Event
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► ReceivedDataFrame
Occurs when a IDataFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<IDataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of IDataFrame))
public:
virtual  event EventHandler<EventArgs<IDataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<IDataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IDataFrame^>^>^ value);
}
Remarks
Argument()()()() is the IDataFrame that was received.


ReceivedFrameBufferImage Event

ReceivedFrameBufferImage Event
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► ReceivedFrameBufferImage
Occurs when a frame buffer image has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<FundamentalFrameType, byte[], int, int>> ReceivedFrameBufferImage
Public Event ReceivedFrameBufferImage As EventHandler(Of EventArgs(Of FundamentalFrameType, Byte(), Integer, Integer))
public:
virtual  event EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ ReceivedFrameBufferImage {
    void add (EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ value);
    void remove (EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ value);
}
Remarks
Argument1()()()() is the FundamentalFrameType of the frame buffer image that was received.
Argument2()()()() is the buffer that contains the frame image that was received.
Argument3()()()() is the offset into the buffer that contains the frame image that was received.
Argument4()()()() is the length of data in the buffer that contains the frame image that was received..


ReceivedHeaderFrame Event

ReceivedHeaderFrame Event
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► ReceivedHeaderFrame
Occurs when a IHeaderFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<IHeaderFrame>> ReceivedHeaderFrame
Public Event ReceivedHeaderFrame As EventHandler(Of EventArgs(Of IHeaderFrame))
public:
virtual  event EventHandler<EventArgs<IHeaderFrame^>^>^ ReceivedHeaderFrame {
    void add (EventHandler<EventArgs<IHeaderFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IHeaderFrame^>^>^ value);
}
Remarks
Argument()()()() is the IHeaderFrame that was received.


ReceivedUndeterminedFrame Event

ReceivedUndeterminedFrame Event
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► ReceivedUndeterminedFrame
Occurs when an undetermined IChannelFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<IChannelFrame>> ReceivedUndeterminedFrame
Public Event ReceivedUndeterminedFrame As EventHandler(Of EventArgs(Of IChannelFrame))
public:
virtual  event EventHandler<EventArgs<IChannelFrame^>^>^ ReceivedUndeterminedFrame {
    void add (EventHandler<EventArgs<IChannelFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IChannelFrame^>^>^ value);
}
Remarks
Argument()()()() is the undetermined IChannelFrame that was received.


Start Method (implementations)

Start Method (implementations)
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► Start(IEnumerable<(Of <<'(Type>)>>))
Starts the frame parser given the specified type implementations.
Declaration Syntax
C# Visual Basic Visual C++
public override void Start(
    IEnumerable<Type> implementations
)
Public Overrides Sub Start ( _
    implementations As IEnumerable(Of Type) _
)
public:
virtual void Start(
    IEnumerable<Type^>^ implementations
) override
Parameters
implementations (IEnumerable <(Of <(<' Type >)>)>)
An implementation type paramater.


Status Property

Status Property
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► Status
Gets current descriptive status of the FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
public:
virtual property String^ Status {
    String^ get () override;
}


Stop Method

Stop Method
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► Stop()()()()
Stops the frame parser.
Declaration Syntax
C# Visual Basic Visual C++
public override void Stop()
Public Overrides Sub Stop
public:
virtual void Stop() override


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► Write(array<Byte>[]()[][], Int32, Int32)
Writes a sequence of bytes onto the stream for parsing.
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[][])
An array of bytes. This method copies count bytes from buffer to the current stream.
offset (Int32)
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count (Int32)
The number of bytes to be written to the current stream.


FrequencyDefinitionBase Class

FrequencyDefinitionBase Class
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionBase
Represents the common implementation of the protocol independent definition of a IFrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class FrequencyDefinitionBase : ChannelDefinitionBase,
    IFrequencyDefinition, IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IChannelDefinition>, IComparable<IChannelDefinition>, IComparable
<SerializableAttribute> _
Public MustInherit Class FrequencyDefinitionBase _
    Inherits ChannelDefinitionBase _
    Implements IFrequencyDefinition, IChannelDefinition, IChannel, ISupportBinaryImage,  _
    ISerializable, IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition),  _
    IComparable
[SerializableAttribute]
public ref class FrequencyDefinitionBase abstract : public ChannelDefinitionBase,
    IFrequencyDefinition, IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IChannelDefinition^>, IComparable<IChannelDefinition^>, IComparable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyDefinitionBase(IConfigurationCell) | Creates a new FrequencyDefinitionBase.
 | FrequencyDefinitionBase(IConfigurationCell, String, UInt32, UInt32, Double) | Creates a new FrequencyDefinitionBase from specified parameters.
 | FrequencyDefinitionBase(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinitionBase from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this FrequencyDefinitionBase object. (Overrides ChannelDefinitionBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Overrides ChannelDefinitionBase.DataFormat.)
 | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase.
 | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase.
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this FrequencyDefinitionBase. (Overrides ChannelDefinitionBase.Index.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase.
 | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Overrides ChannelDefinitionBase.Offset.)
 | Parent | Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | FrequencyDefinitionBase
 |  |  |  |  | FrequencyDefinition
 |  |  |  |  | FrequencyDefinition
 |  |  |  |  | FrequencyDefinition
 |  |  |  |  | FrequencyDefinition
 |  |  |  |  | FrequencyDefinition
 |  |  |  |  | FrequencyDefinition
 |  |  |  |  | FrequencyDefinition


FrequencyDefinitionBase Constructor

FrequencyDefinitionBase Constructor
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionBase ► FrequencyDefinitionBase()()()()
Members
Icon | Member | Description
 | FrequencyDefinitionBase(IConfigurationCell) | Creates a new FrequencyDefinitionBase.
 | FrequencyDefinitionBase(IConfigurationCell, String, UInt32, UInt32, Double) | Creates a new FrequencyDefinitionBase from specified parameters.
 | FrequencyDefinitionBase(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinitionBase from serialization parameters.


FrequencyDefinitionBase Constructor (info, context)

FrequencyDefinitionBase Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionBase ► FrequencyDefinitionBase(SerializationInfo, StreamingContext)
Creates a new FrequencyDefinitionBase from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyDefinitionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyDefinitionBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrequencyDefinitionBase Constructor (parent)

FrequencyDefinitionBase Constructor (parent)
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionBase ► FrequencyDefinitionBase(IConfigurationCell)
Creates a new FrequencyDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyDefinitionBase(
    IConfigurationCell parent
)
Protected Sub New ( _
    parent As IConfigurationCell _
)
protected:
FrequencyDefinitionBase(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this FrequencyDefinitionBase.


FrequencyDefinitionBase Constructor (parent, label, scale, dfdtScale, dfdtOffset)

FrequencyDefinitionBase Constructor (parent, label, scale, dfdtScale, dfdtOffset)
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionBase ► FrequencyDefinitionBase(IConfigurationCell, String, UInt32, UInt32, Double)
Creates a new FrequencyDefinitionBase from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyDefinitionBase(
    IConfigurationCell parent,
    string label,
    uint scale,
    uint dfdtScale,
    double dfdtOffset
)
Protected Sub New ( _
    parent As IConfigurationCell, _
    label As String, _
    scale As UInteger, _
    dfdtScale As UInteger, _
    dfdtOffset As Double _
)
protected:
FrequencyDefinitionBase(
    IConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    unsigned int dfdtScale,
    double dfdtOffset
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this FrequencyDefinitionBase.
label (String)
The label of this FrequencyDefinitionBase.
scale (UInt32)
The integer scaling value of this FrequencyDefinitionBase.
dfdtScale (UInt32)
The df/dt scaling value of this FrequencyDefinitionBase.
dfdtOffset (Double)
The df/dt offset of this FrequencyDefinitionBase.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionBase ► Attributes
Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this FrequencyDefinitionBase object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


DataFormat Property

DataFormat Property
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionBase ► DataFormat
Gets the DataFormat of this FrequencyDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat DataFormat { get; }
Public Overrides ReadOnly Property DataFormat As DataFormat
    Get
public:
virtual property DataFormat DataFormat {
    DataFormat get () override;
}


DfDtOffset Property

DfDtOffset Property
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionBase ► DfDtOffset
Gets or sets the df/dt offset of this FrequencyDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double DfDtOffset { get; set; }
Public Overridable Property DfDtOffset As Double
    Get
    Set
public:
virtual property double DfDtOffset {
    double get ();
    void set (double value);
}


DfDtScalingValue Property

DfDtScalingValue Property
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionBase ► DfDtScalingValue
Gets or sets the df/dt scaling value of this FrequencyDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual uint DfDtScalingValue { get; set; }
Public Overridable Property DfDtScalingValue As UInteger
    Get
    Set
public:
virtual property unsigned int DfDtScalingValue {
    unsigned int get ();
    void set (unsigned int value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


Index Property

Index Property
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionBase ► Index
Gets or sets the index of this FrequencyDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override int Index { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides Property Index As Integer
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property int Index {
    int get () override;
    void set (int value) override;
}
Remarks
Phasor protocols only define one frequency measurement per device.


NominalFrequency Property

NominalFrequency Property
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionBase ► NominalFrequency
Gets the nominal LineFrequency of this FrequencyDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual LineFrequency NominalFrequency { get; }
Public Overridable ReadOnly Property NominalFrequency As LineFrequency
    Get
public:
virtual property LineFrequency NominalFrequency {
    LineFrequency get ();
}
Remarks
Value returned is the NominalFrequency and is exposed here just for convenience.


Offset Property

Offset Property
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionBase ► Offset
Gets or sets the offset of this FrequencyDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public override double Offset { get; set; }
Public Overrides Property Offset As Double
    Get
    Set
public:
virtual property double Offset {
    double get () override;
    void set (double value) override;
}
Remarks
Offset for frequency values will always be the nominal frequency as defined in parent configuration cell; assigning a value is not supported.
Exceptions
Exception | Condition
NotSupportedException | Frequency offset is read-only; value is determined by nominal frequency specified in containing configuration cell.


FrequencyDefinitionCollection Class

FrequencyDefinitionCollection Class
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionCollection
Represents a protocol independent collection of IFrequencyDefinition objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FrequencyDefinitionCollection : ChannelDefinitionCollectionBase<IFrequencyDefinition>
<SerializableAttribute> _
Public Class FrequencyDefinitionCollection _
    Inherits ChannelDefinitionCollectionBase(Of IFrequencyDefinition)
[SerializableAttribute]
public ref class FrequencyDefinitionCollection : public ChannelDefinitionCollectionBase<IFrequencyDefinition^>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyDefinitionCollection(Int32) | Creates a new FrequencyDefinitionCollection using specified lastValidIndex.
 | FrequencyDefinitionCollection(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinitionCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelDefinitionCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelDefinitionCollectionBase<(Of <(<'T>)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelDefinitionCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelDefinitionCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelDefinitionCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
None of the phasor protocols currently define multiple frequency elements per transmission, but if a future protocol does this collection can be used.
Inheritance Hierarchy
Object
 | Collection <(Of <(<' T >)>)>
 |  | ChannelCollectionBase <(Of <(<' T >)>)>
 |  |  | ChannelDefinitionCollectionBase <(Of <(<' IFrequencyDefinition >)>)>
 |  |  |  | FrequencyDefinitionCollection


FrequencyDefinitionCollection Constructor

FrequencyDefinitionCollection Constructor
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionCollection ► FrequencyDefinitionCollection()()()()
Members
Icon | Member | Description
 | FrequencyDefinitionCollection(Int32) | Creates a new FrequencyDefinitionCollection using specified lastValidIndex.
 | FrequencyDefinitionCollection(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinitionCollection from serialization parameters.


FrequencyDefinitionCollection Constructor (lastValidIndex)

FrequencyDefinitionCollection Constructor (lastValidIndex)
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionCollection ► FrequencyDefinitionCollection(Int32)
Creates a new FrequencyDefinitionCollection using specified lastValidIndex.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyDefinitionCollection(
    int lastValidIndex
)
Public Sub New ( _
    lastValidIndex As Integer _
)
public:
FrequencyDefinitionCollection(
    int lastValidIndex
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


FrequencyDefinitionCollection Constructor (info, context)

FrequencyDefinitionCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionCollection ► FrequencyDefinitionCollection(SerializationInfo, StreamingContext)
Creates a new FrequencyDefinitionCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyDefinitionCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyDefinitionCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrequencyValueBase Class

FrequencyValueBase Class
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase
Represents the common implementation of the protocol independent representation of a frequency and df/dt value.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class FrequencyValueBase : ChannelValueBase<IFrequencyDefinition>,
    IFrequencyValue, IChannelValue<IFrequencyDefinition>, IChannel, ISupportBinaryImage,
    ISerializable
<SerializableAttribute> _
Public MustInherit Class FrequencyValueBase _
    Inherits ChannelValueBase(Of IFrequencyDefinition) _
    Implements IFrequencyValue, IChannelValue(Of IFrequencyDefinition),  _
    IChannel, ISupportBinaryImage, ISerializable
[SerializableAttribute]
public ref class FrequencyValueBase abstract : public ChannelValueBase<IFrequencyDefinition^>,
    IFrequencyValue, IChannelValue<IFrequencyDefinition^>, IChannel, ISupportBinaryImage,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyValueBase(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValueBase.
 | FrequencyValueBase(IDataCell, IFrequencyDefinition, Double, Double) | Creates a new FrequencyValueBase from specified parameters.
 | FrequencyValueBase(SerializationInfo, StreamingContext) | Creates a new FrequencyValueBase from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the FrequencyValueBase object. (Overrides ChannelValueBase <(Of <(<' IFrequencyDefinition >)>)>.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the FrequencyValueBase object. (Overrides BinaryImageBase.BodyImage()()()().)
 | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBase.BodyLength()()()().)
 | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Overrides ChannelValueBase <(Of <(<' IFrequencyDefinition >)>)>.CompositeValueCount.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the IChannelDefinition associated with this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase.
 | GetCompositeValue(Int32) | Gets the specified composite value of this FrequencyValueBase. (Overrides ChannelValueBase <(Of <(<' IFrequencyDefinition >)>)>.GetCompositeValue(Int32).)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelValueBase <(Of <(<' IFrequencyDefinition >)>)>.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Overrides ChannelValueBase <(Of <(<' IFrequencyDefinition >)>)>.IsEmpty.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the IDataCell parent of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides BinaryImageBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time.
 | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IFrequencyDefinition >)>)>
 |  |  |  | FrequencyValueBase
 |  |  |  |  | FrequencyValue
 |  |  |  |  | FrequencyValue
 |  |  |  |  | FrequencyValue
 |  |  |  |  | FrequencyValue
 |  |  |  |  | FrequencyValue
 |  |  |  |  | FrequencyValue


FrequencyValueBase Constructor

FrequencyValueBase Constructor
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase ► FrequencyValueBase()()()()
Members
Icon | Member | Description
 | FrequencyValueBase(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValueBase.
 | FrequencyValueBase(IDataCell, IFrequencyDefinition, Double, Double) | Creates a new FrequencyValueBase from specified parameters.
 | FrequencyValueBase(SerializationInfo, StreamingContext) | Creates a new FrequencyValueBase from serialization parameters.


FrequencyValueBase Constructor (info, context)

FrequencyValueBase Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase ► FrequencyValueBase(SerializationInfo, StreamingContext)
Creates a new FrequencyValueBase from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyValueBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyValueBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrequencyValueBase Constructor (parent, frequencyDefinition)

FrequencyValueBase Constructor (parent, frequencyDefinition)
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase ► FrequencyValueBase(IDataCell, IFrequencyDefinition)
Creates a new FrequencyValueBase.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyValueBase(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition
)
Protected Sub New ( _
    parent As IDataCell, _
    frequencyDefinition As IFrequencyDefinition _
)
protected:
FrequencyValueBase(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this FrequencyValueBase.
frequencyDefinition (IFrequencyDefinition)
The IFrequencyDefinition associated with this FrequencyValueBase.


FrequencyValueBase Constructor (parent, frequencyDefinition, frequency, dfdt)

FrequencyValueBase Constructor (parent, frequencyDefinition, frequency, dfdt)
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase ► FrequencyValueBase(IDataCell, IFrequencyDefinition, Double, Double)
Creates a new FrequencyValueBase from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyValueBase(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition,
    double frequency,
    double dfdt
)
Protected Sub New ( _
    parent As IDataCell, _
    frequencyDefinition As IFrequencyDefinition, _
    frequency As Double, _
    dfdt As Double _
)
protected:
FrequencyValueBase(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition,
    double frequency,
    double dfdt
)
Parameters
parent (IDataCell)
The IDataCell parent of this FrequencyValueBase.
frequencyDefinition (IFrequencyDefinition)
The IFrequencyDefinition associated with this FrequencyValueBase.
frequency (Double)
The floating point value that represents this FrequencyValueBase.
dfdt (Double)
The floating point value that represents the change in this FrequencyValueBase over time.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the FrequencyValueBase object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase ► BodyImage
Gets the binary body image of the FrequencyValueBase object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).


CompositeValueCount Property

CompositeValueCount Property
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase ► CompositeValueCount
Gets total number of composite values that this FrequencyValueBase provides.
Declaration Syntax
C# Visual Basic Visual C++
public override int CompositeValueCount { get; }
Public Overrides ReadOnly Property CompositeValueCount As Integer
    Get
public:
virtual property int CompositeValueCount {
    int get () override;
}


DfDt Property

DfDt Property
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase ► DfDt
Gets or sets the floating point value that represents the change in this FrequencyValueBase over time.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double DfDt { get; set; }
Public Overridable Property DfDt As Double
    Get
    Set
public:
virtual property double DfDt {
    double get ();
    void set (double value);
}


Frequency Property

Frequency Property
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase ► Frequency
Gets or sets the floating point value that represents this FrequencyValueBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Frequency { get; set; }
Public Overridable Property Frequency As Double
    Get
    Set
public:
virtual property double Frequency {
    double get ();
    void set (double value);
}


GetCompositeValue Method (index)

GetCompositeValue Method (index)
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase ► GetCompositeValue(Int32)
Gets the specified composite value of this FrequencyValueBase.
Declaration Syntax
C# Visual Basic Visual C++
public override double GetCompositeValue(
    int index
)
Public Overrides Function GetCompositeValue ( _
    index As Integer _
) As Double
public:
virtual double GetCompositeValue(
    int index
) override
Parameters
index (Int32)
Index of composite value to retrieve.
Return Value
A Double representing the composite value.
Remarks
Some ChannelValueBase<(Of <(<'T>)>)> implementations can contain more than one value, this method is used to abstractly expose each value.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


IsEmpty Property

IsEmpty Property
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase ► IsEmpty
Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value.
Declaration Syntax
C# Visual Basic Visual C++
public override bool IsEmpty { get; }
Public Overrides ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get () override;
}
Return Value
True, if no composite values have been assigned a value; otherwise, false.


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).


UnscaledDfDt Property

UnscaledDfDt Property
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase ► UnscaledDfDt
Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int UnscaledDfDt { get; set; }
Public Overridable Property UnscaledDfDt As Integer
    Get
    Set
public:
virtual property int UnscaledDfDt {
    int get ();
    void set (int value);
}


UnscaledFrequency Property

UnscaledFrequency Property
Namespaces ► TVA.PhasorProtocols ► FrequencyValueBase ► UnscaledFrequency
Gets or sets the unscaled integer representation of this FrequencyValueBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int UnscaledFrequency { get; set; }
Public Overridable Property UnscaledFrequency As Integer
    Get
    Set
public:
virtual property int UnscaledFrequency {
    int get ();
    void set (int value);
}


FrequencyValueCollection Class

FrequencyValueCollection Class
Namespaces ► TVA.PhasorProtocols ► FrequencyValueCollection
Represents a protocol independent collection of IFrequencyValue objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FrequencyValueCollection : ChannelValueCollectionBase<IFrequencyDefinition, IFrequencyValue>
<SerializableAttribute> _
Public Class FrequencyValueCollection _
    Inherits ChannelValueCollectionBase(Of IFrequencyDefinition, IFrequencyValue)
[SerializableAttribute]
public ref class FrequencyValueCollection : public ChannelValueCollectionBase<IFrequencyDefinition^, IFrequencyValue^>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyValueCollection(Int32) | Creates a new FrequencyValueCollection using specified lastValidIndex.
 | FrequencyValueCollection(SerializationInfo, StreamingContext) | Creates a new FrequencyValueCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IFrequencyValue >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | AllValuesAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> object. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IFrequencyValue >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IFrequencyValue >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IFrequencyValue >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IFrequencyValue >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IFrequencyValue >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IFrequencyValue >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IFrequencyValue >)>)>.)
 | InsertItem(Int32, TValue) | Inserts an element into the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> at the specified index. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' IFrequencyValue >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IFrequencyValue >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IFrequencyValue >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IFrequencyValue >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | SetItem(Int32, TValue) | Replaces the element at the specified index. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
None of the phasor protocols currently define multiple frequency elements per transmission, but if a future protocol does this collection can be used.
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IFrequencyValue >)>)>
 |  | ChannelCollectionBase <(Of <(<' IFrequencyValue >)>)>
 |  |  | ChannelValueCollectionBase <(Of <(<' IFrequencyDefinition, IFrequencyValue >)>)>
 |  |  |  | FrequencyValueCollection


FrequencyValueCollection Constructor

FrequencyValueCollection Constructor
Namespaces ► TVA.PhasorProtocols ► FrequencyValueCollection ► FrequencyValueCollection()()()()
Members
Icon | Member | Description
 | FrequencyValueCollection(Int32) | Creates a new FrequencyValueCollection using specified lastValidIndex.
 | FrequencyValueCollection(SerializationInfo, StreamingContext) | Creates a new FrequencyValueCollection from serialization parameters.


FrequencyValueCollection Constructor (lastValidIndex)

FrequencyValueCollection Constructor (lastValidIndex)
Namespaces ► TVA.PhasorProtocols ► FrequencyValueCollection ► FrequencyValueCollection(Int32)
Creates a new FrequencyValueCollection using specified lastValidIndex.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyValueCollection(
    int lastValidIndex
)
Public Sub New ( _
    lastValidIndex As Integer _
)
public:
FrequencyValueCollection(
    int lastValidIndex
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


FrequencyValueCollection Constructor (info, context)

FrequencyValueCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► FrequencyValueCollection ► FrequencyValueCollection(SerializationInfo, StreamingContext)
Creates a new FrequencyValueCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyValueCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyValueCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FundamentalFrameType Enumeration

FundamentalFrameType Enumeration
Namespaces ► TVA.PhasorProtocols ► FundamentalFrameType
Fundamental frame types enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum FundamentalFrameType
<SerializableAttribute> _
Public Enumeration FundamentalFrameType
[SerializableAttribute]
public enum class FundamentalFrameType
Members
Member | Description
ConfigurationFrame | Configuration frame.
DataFrame | Data frame.
HeaderFrame | Header frame.
CommandFrame | Command frame.
Undetermined | Undetermined frame type.


HeaderCell Class

HeaderCell Class
Namespaces ► TVA.PhasorProtocols ► HeaderCell
Represents the protocol independent common implementation of an element of header data for cells in a IHeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class HeaderCell : ChannelCellBase, IHeaderCell,
    IChannelCell, IChannel, ISupportBinaryImage, ISerializable
<SerializableAttribute> _
Public Class HeaderCell _
    Inherits ChannelCellBase _
    Implements IHeaderCell, IChannelCell, IChannel, ISupportBinaryImage,  _
    ISerializable
[SerializableAttribute]
public ref class HeaderCell : public ChannelCellBase,
    IHeaderCell, IChannelCell, IChannel, ISupportBinaryImage, ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HeaderCell(IHeaderFrame, Byte) | Creates a new HeaderCell from specified parameters.
 | HeaderCell(SerializationInfo, StreamingContext) | Creates a new HeaderCell from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the HeaderCell object. (Overrides ChannelCellBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the HeaderCell object. (Overrides BinaryImageBase.BodyImage()()()().)
 | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBase.BodyLength()()()().)
 | Character | Gets or sets ASCII character as a Byte that represents this HeaderCell.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCellBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets a reference to the parent ICommandFrame for this HeaderCell.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides BinaryImageBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from ChannelCellBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | HeaderCell


HeaderCell Constructor

HeaderCell Constructor
Namespaces ► TVA.PhasorProtocols ► HeaderCell ► HeaderCell()()()()
Members
Icon | Member | Description
 | HeaderCell(IHeaderFrame, Byte) | Creates a new HeaderCell from specified parameters.
 | HeaderCell(SerializationInfo, StreamingContext) | Creates a new HeaderCell from serialization parameters.


HeaderCell Constructor (info, context)

HeaderCell Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► HeaderCell ► HeaderCell(SerializationInfo, StreamingContext)
Creates a new HeaderCell from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected HeaderCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
HeaderCell(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


HeaderCell Constructor (parent, character)

HeaderCell Constructor (parent, character)
Namespaces ► TVA.PhasorProtocols ► HeaderCell ► HeaderCell(IHeaderFrame, Byte)
Creates a new HeaderCell from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public HeaderCell(
    IHeaderFrame parent,
    byte character
)
Public Sub New ( _
    parent As IHeaderFrame, _
    character As Byte _
)
public:
HeaderCell(
    IHeaderFrame^ parent,
    unsigned char character
)
Parameters
parent (IHeaderFrame)
A reference to the parent ICommandFrame for this HeaderCell.
character (Byte)
ASCII character as a Byte that represents this HeaderCell.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► HeaderCell ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the HeaderCell object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols ► HeaderCell ► BodyImage
Gets the binary body image of the HeaderCell object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols ► HeaderCell ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}


Character Property

Character Property
Namespaces ► TVA.PhasorProtocols ► HeaderCell ► Character
Gets or sets ASCII character as a Byte that represents this HeaderCell.
Declaration Syntax
C# Visual Basic Visual C++
public virtual byte Character { get; set; }
Public Overridable Property Character As Byte
    Get
    Set
public:
virtual property unsigned char Character {
    unsigned char get ();
    void set (unsigned char value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► HeaderCell ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► HeaderCell ► Parent
Gets or sets a reference to the parent ICommandFrame for this HeaderCell.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IHeaderFrame Parent { get; set; }
Public Overridable Property Parent As IHeaderFrame
    Get
    Set
public:
virtual property IHeaderFrame^ Parent {
    IHeaderFrame^ get ();
    void set (IHeaderFrame^ value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols ► HeaderCell ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


HeaderCellCollection Class

HeaderCellCollection Class
Namespaces ► TVA.PhasorProtocols ► HeaderCellCollection
Represents a protocol independent collection of IHeaderCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class HeaderCellCollection : ChannelCellCollectionBase<IHeaderCell>
<SerializableAttribute> _
Public Class HeaderCellCollection _
    Inherits ChannelCellCollectionBase(Of IHeaderCell)
[SerializableAttribute]
public ref class HeaderCellCollection : public ChannelCellCollectionBase<IHeaderCell^>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HeaderCellCollection(Int32) | Creates a new HeaderCellCollection using specified lastValidIndex.
 | HeaderCellCollection(SerializationInfo, StreamingContext) | Creates a new HeaderCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IHeaderCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IHeaderCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IHeaderCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IHeaderCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IHeaderCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IHeaderCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IHeaderCell >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IHeaderCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' IHeaderCell >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IHeaderCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IHeaderCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IHeaderCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IHeaderCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' IHeaderCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' IHeaderCell >)>)>
 |  |  |  | HeaderCellCollection


HeaderCellCollection Constructor

HeaderCellCollection Constructor
Namespaces ► TVA.PhasorProtocols ► HeaderCellCollection ► HeaderCellCollection()()()()
Members
Icon | Member | Description
 | HeaderCellCollection(Int32) | Creates a new HeaderCellCollection using specified lastValidIndex.
 | HeaderCellCollection(SerializationInfo, StreamingContext) | Creates a new HeaderCellCollection from serialization parameters.


HeaderCellCollection Constructor (lastValidIndex)

HeaderCellCollection Constructor (lastValidIndex)
Namespaces ► TVA.PhasorProtocols ► HeaderCellCollection ► HeaderCellCollection(Int32)
Creates a new HeaderCellCollection using specified lastValidIndex.
Declaration Syntax
C# Visual Basic Visual C++
public HeaderCellCollection(
    int lastValidIndex
)
Public Sub New ( _
    lastValidIndex As Integer _
)
public:
HeaderCellCollection(
    int lastValidIndex
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


HeaderCellCollection Constructor (info, context)

HeaderCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► HeaderCellCollection ► HeaderCellCollection(SerializationInfo, StreamingContext)
Creates a new HeaderCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected HeaderCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
HeaderCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


HeaderFrameBase Class

HeaderFrameBase Class
Namespaces ► TVA.PhasorProtocols ► HeaderFrameBase
Represents the protocol independent common implementation of any IHeaderFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class HeaderFrameBase : ChannelFrameBase<IHeaderCell>,
    IHeaderFrame, IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable<IFrame>, IComparable<IFrame>, IComparable,
    ISerializable
<SerializableAttribute> _
Public MustInherit Class HeaderFrameBase _
    Inherits ChannelFrameBase(Of IHeaderCell) _
    Implements IHeaderFrame, IChannelFrame, IChannel, ISupportBinaryImage,  _
    IFrame, IEquatable(Of IFrame), IComparable(Of IFrame),  _
    IComparable, ISerializable
[SerializableAttribute]
public ref class HeaderFrameBase abstract : public ChannelFrameBase<IHeaderCell^>,
    IHeaderFrame, IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable<IFrame^>, IComparable<IFrame^>, IComparable,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HeaderFrameBase(HeaderCellCollection) | Creates a new HeaderFrameBase.
 | HeaderFrameBase(SerializationInfo, StreamingContext) | Creates a new HeaderFrameBase from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the HeaderFrameBase object. (Overrides ChannelFrameBase <(Of <(<' IHeaderCell >)>)>.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Cells | Gets reference to the HeaderCellCollection for this HeaderFrameBase.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameType | Gets the FundamentalFrameType for this HeaderFrameBase. (Overrides ChannelFrameBase <(Of <(<' IHeaderCell >)>)>.FrameType.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderData | Gets or sets header data for this HeaderFrameBase.
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this HeaderFrameBase.
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IHeaderCell >)>)>
 |  |  |  | HeaderFrameBase
 |  |  |  |  | HeaderFrame
 |  |  |  |  | HeaderFrame
 |  |  |  |  | HeaderFrame


HeaderFrameBase Constructor

HeaderFrameBase Constructor
Namespaces ► TVA.PhasorProtocols ► HeaderFrameBase ► HeaderFrameBase()()()()
Members
Icon | Member | Description
 | HeaderFrameBase(HeaderCellCollection) | Creates a new HeaderFrameBase.
 | HeaderFrameBase(SerializationInfo, StreamingContext) | Creates a new HeaderFrameBase from serialization parameters.


HeaderFrameBase Constructor (info, context)

HeaderFrameBase Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► HeaderFrameBase ► HeaderFrameBase(SerializationInfo, StreamingContext)
Creates a new HeaderFrameBase from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected HeaderFrameBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
HeaderFrameBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


HeaderFrameBase Constructor (cells)

HeaderFrameBase Constructor (cells)
Namespaces ► TVA.PhasorProtocols ► HeaderFrameBase ► HeaderFrameBase(HeaderCellCollection)
Creates a new HeaderFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
protected HeaderFrameBase(
    HeaderCellCollection cells
)
Protected Sub New ( _
    cells As HeaderCellCollection _
)
protected:
HeaderFrameBase(
    HeaderCellCollection^ cells
)
Parameters
cells (HeaderCellCollection)
The reference to the HeaderCellCollection for this HeaderFrameBase.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► HeaderFrameBase ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the HeaderFrameBase object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols ► HeaderFrameBase ► Cells
Gets reference to the HeaderCellCollection for this HeaderFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual HeaderCellCollection Cells { get; }
Public Overridable ReadOnly Property Cells As HeaderCellCollection
    Get
public:
virtual property HeaderCellCollection^ Cells {
    HeaderCellCollection^ get ();
}


FrameType Property

FrameType Property
Namespaces ► TVA.PhasorProtocols ► HeaderFrameBase ► FrameType
Gets the FundamentalFrameType for this HeaderFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public override FundamentalFrameType FrameType { get; }
Public Overrides ReadOnly Property FrameType As FundamentalFrameType
    Get
public:
virtual property FundamentalFrameType FrameType {
    FundamentalFrameType get () override;
}


HeaderData Property

HeaderData Property
Namespaces ► TVA.PhasorProtocols ► HeaderFrameBase ► HeaderData
Gets or sets header data for this HeaderFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string HeaderData { get; set; }
Public Overridable Property HeaderData As String
    Get
    Set
public:
virtual property String^ HeaderData {
    String^ get ();
    void set (String^ value);
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► HeaderFrameBase ► State
Gets or sets the parsing state for the this HeaderFrameBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IHeaderFrameParsingState State { get; set; }
Public Overridable Property State As IHeaderFrameParsingState
    Get
    Set
public:
virtual property IHeaderFrameParsingState^ State {
    IHeaderFrameParsingState^ get ();
    void set (IHeaderFrameParsingState^ value);
}


HeaderFrameParsingState Class

HeaderFrameParsingState Class
Namespaces ► TVA.PhasorProtocols ► HeaderFrameParsingState
Represents the protocol independent common implementation of the parsing state used by any IHeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
public class HeaderFrameParsingState : ChannelFrameParsingStateBase<IHeaderCell>,
    IHeaderFrameParsingState, IChannelFrameParsingState<IHeaderCell>, IChannelParsingState
Public Class HeaderFrameParsingState _
    Inherits ChannelFrameParsingStateBase(Of IHeaderCell) _
    Implements IHeaderFrameParsingState, IChannelFrameParsingState(Of IHeaderCell),  _
    IChannelParsingState
public ref class HeaderFrameParsingState : public ChannelFrameParsingStateBase<IHeaderCell^>,
    IHeaderFrameParsingState, IChannelFrameParsingState<IHeaderCell^>, IChannelParsingState
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HeaderFrameParsingState(Int32, Int32) | Creates a new HeaderFrameParsingState from specified parameters.
 | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBase<(Of <(<'T>)>)>.)
 | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ChannelParsingStateBase
 |  | ChannelFrameParsingStateBase <(Of <(<' IHeaderCell >)>)>
 |  |  | HeaderFrameParsingState


HeaderFrameParsingState Constructor (parsedBinaryLength, dataLength)

HeaderFrameParsingState Constructor (parsedBinaryLength, dataLength)
Namespaces ► TVA.PhasorProtocols ► HeaderFrameParsingState ► HeaderFrameParsingState(Int32, Int32)
Creates a new HeaderFrameParsingState from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public HeaderFrameParsingState(
    int parsedBinaryLength,
    int dataLength
)
Public Sub New ( _
    parsedBinaryLength As Integer, _
    dataLength As Integer _
)
public:
HeaderFrameParsingState(
    int parsedBinaryLength,
    int dataLength
)
Parameters
parsedBinaryLength (Int32)
Binary length of the IHeaderFrame being parsed.
dataLength (Int32)
Length of data in IHeaderFrame being parsed (i.e., number of cells).


IAnalogDefinition Interface

IAnalogDefinition Interface
Namespaces ► TVA.PhasorProtocols ► IAnalogDefinition
Represents a protocol independent interface representation of a definition of an IAnalogValue.
Declaration Syntax
C# Visual Basic Visual C++
public interface IAnalogDefinition : IChannelDefinition,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition>,
    IComparable<IChannelDefinition>, IComparable
Public Interface IAnalogDefinition _
    Inherits IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,  _
    IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition), IComparable
public interface class IAnalogDefinition : IChannelDefinition,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition^>,
    IComparable<IChannelDefinition^>, IComparable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AnalogType | Gets or sets AnalogType of this IAnalogDefinition.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable <(Of <(<' IChannelDefinition >)>)>.)
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
 | ConversionFactor | Gets or sets the conversion factor of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | Equals(T) | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable <(Of <(<' IChannelDefinition >)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | Index | Gets or sets the index of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | Label | Gets or sets the label of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | LabelImage | Gets the binary image of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | MaximumLabelLength | Gets the maximum length of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | Offset | Gets or sets the offset of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | Parent | Gets the IConfigurationCell parent of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | ScalePerBit | Gets the scale/bit value of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | ScalingValue | Gets or sets the integer scaling value of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)


AnalogType Property

AnalogType Property
Namespaces ► TVA.PhasorProtocols ► IAnalogDefinition ► AnalogType
Gets or sets AnalogType of this IAnalogDefinition.
Declaration Syntax
C# Visual Basic Visual C++
AnalogType AnalogType { get; set; }
Property AnalogType As AnalogType
    Get
    Set
property AnalogType AnalogType {
    AnalogType get ();
    void set (AnalogType value);
}


IAnalogValue Interface

IAnalogValue Interface
Namespaces ► TVA.PhasorProtocols ► IAnalogValue
Represents a protocol independent interface representation of an analog value.
Declaration Syntax
C# Visual Basic Visual C++
public interface IAnalogValue : IChannelValue<IAnalogDefinition>,
    IChannel, ISupportBinaryImage, ISerializable
Public Interface IAnalogValue _
    Inherits IChannelValue(Of IAnalogDefinition), IChannel, ISupportBinaryImage,  _
    ISerializable
public interface class IAnalogValue : IChannelValue<IAnalogDefinition^>,
    IChannel, ISupportBinaryImage, ISerializable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | CompositeValueCount | Gets total number of composite values that this IChannelValue<(Of <(<'T>)>)> provides. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this IChannelValue<(Of <(<'T>)>)> typically derived from DataFormat. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Definition | Gets the IChannelDefinition associated with this IChannelValue<(Of <(<'T>)>)>. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this IChannelValue<(Of <(<'T>)>)>. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | IntegerValue | Gets or sets the integer representation of this IAnalogValue value.
 | IsEmpty | Gets boolean value that determines if none of the composite values of IChannelValue<(Of <(<'T>)>)> have been assigned a value. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Label | Gets text based label of this IChannelValue<(Of <(<'T>)>)> typically derived from Label. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this IChannelValue<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Parent | Gets the IDataCell parent of this IChannelValue<(Of <(<'T>)>)>. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
 | Value | Gets or sets the floating point value that represents this IAnalogValue.


IntegerValue Property

IntegerValue Property
Namespaces ► TVA.PhasorProtocols ► IAnalogValue ► IntegerValue
Gets or sets the integer representation of this IAnalogValue value.
Declaration Syntax
C# Visual Basic Visual C++
int IntegerValue { get; set; }
Property IntegerValue As Integer
    Get
    Set
property int IntegerValue {
    int get ();
    void set (int value);
}


Value Property

Value Property
Namespaces ► TVA.PhasorProtocols ► IAnalogValue ► Value
Gets or sets the floating point value that represents this IAnalogValue.
Declaration Syntax
C# Visual Basic Visual C++
double Value { get; set; }
Property Value As Double
    Get
    Set
property double Value {
    double get ();
    void set (double value);
}


IChannel Interface

IChannel Interface
Namespaces ► TVA.PhasorProtocols ► IChannel
Represents a protocol independent interface representation of any data type that can be parsed or generated.
This is the base interface implemented by all parsing/generating classes in the phasor protocols library; it is the root of the parsing/generating interface hierarchy.
Declaration Syntax
C# Visual Basic Visual C++
public interface IChannel : ISupportBinaryImage
Public Interface IChannel _
    Inherits ISupportBinaryImage
public interface class IChannel : ISupportBinaryImage
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object.
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | State | Gets or sets the parsing state for this IChannel object.
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► IChannel ► Attributes
Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object.
Declaration Syntax
C# Visual Basic Visual C++
Dictionary<string, string> Attributes { get; }
ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get ();
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► IChannel ► State
Gets or sets the parsing state for this IChannel object.
Declaration Syntax
C# Visual Basic Visual C++
IChannelParsingState State { get; set; }
Property State As IChannelParsingState
    Get
    Set
property IChannelParsingState^ State {
    IChannelParsingState^ get ();
    void set (IChannelParsingState^ value);
}


Tag Property

Tag Property
Namespaces ► TVA.PhasorProtocols ► IChannel ► Tag
Gets or sets a user definable reference to an object associated with this IChannel object.
Declaration Syntax
C# Visual Basic Visual C++
Object Tag { get; set; }
Property Tag As Object
    Get
    Set
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
Remarks
Classes implementing IChannel should only track this value.


IChannelCell Interface

IChannelCell Interface
Namespaces ► TVA.PhasorProtocols ► IChannelCell
Represents a protocol independent interface representation of any kind of IChannelFrame cell.
Declaration Syntax
C# Visual Basic Visual C++
public interface IChannelCell : IChannel,
    ISupportBinaryImage, ISerializable
Public Interface IChannelCell _
    Inherits IChannel, ISupportBinaryImage, ISerializable
public interface class IChannelCell : IChannel,
    ISupportBinaryImage, ISerializable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | IDCode | Gets the numeric ID code for this IChannelCell.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell.
 | State | Gets or sets the parsing state for the this ChannelCellBase.
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Remarks
This phasor protocol implementation defines a "cell" as a portion of a "frame", i.e., a logical unit of data. For example, a IDataCell (dervied from IChannelCell) could be defined as a PMU within a frame of data, a IDataFrame, that contains multiple PMU's coming from a PDC.


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols ► IChannelCell ► IDCode
Gets the numeric ID code for this IChannelCell.
Declaration Syntax
C# Visual Basic Visual C++
ushort IDCode { get; set; }
Property IDCode As UShort
    Get
    Set
property unsigned short IDCode {
    unsigned short get ();
    void set (unsigned short value);
}
Remarks
Most phasor measurement devices define some kind of numeric identifier (e.g., a hardware identifier coded into the device ROM); this is the abstract representation of this identifier.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► IChannelCell ► Parent
Gets a reference to the parent IChannelFrame for this IChannelCell.
Declaration Syntax
C# Visual Basic Visual C++
IChannelFrame Parent { get; set; }
Property Parent As IChannelFrame
    Get
    Set
property IChannelFrame^ Parent {
    IChannelFrame^ get ();
    void set (IChannelFrame^ value);
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► IChannelCell ► State
Gets or sets the parsing state for the this ChannelCellBase.
Declaration Syntax
C# Visual Basic Visual C++
IChannelCellParsingState State { get; set; }
Property State As IChannelCellParsingState
    Get
    Set
property IChannelCellParsingState^ State {
    IChannelCellParsingState^ get ();
    void set (IChannelCellParsingState^ value);
}


IChannelCellCollection(T) Interface

IChannelCellCollection<(Of <(<'T>)>)> Interface
Namespaces ► TVA.PhasorProtocols ► IChannelCellCollection<(Of <(<'T>)>)>
Represents a protocol independent interface representation of a collection of IChannelCell objects.
Declaration Syntax
C# Visual Basic Visual C++
public interface IChannelCellCollection<T> : IChannelCollection<T>,
    IChannel, ISupportBinaryImage, IList<T>, ICollection<T>, IEnumerable<T>,
    IEnumerable, INotifyCollectionChanged, ISerializable
where T : IChannelCell

Public Interface IChannelCellCollection(Of T As IChannelCell) _
    Inherits IChannelCollection(Of T), IChannel, ISupportBinaryImage,  _
    IList(Of T), ICollection(Of T), IEnumerable(Of T),  _
    IEnumerable, INotifyCollectionChanged, ISerializable
generic<typename T>
where T : IChannelCell
public interface class IChannelCellCollection : IChannelCollection<T>,
    IChannel, ISupportBinaryImage, IList<T>, ICollection<T>, IEnumerable<T>,
    IEnumerable, INotifyCollectionChanged, ISerializable
Generic Template Parameters
T
Generic type used.
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Add(T) | Adds an item to the ICollection<(Of <(<'T>)>)>. (Inherited from ICollection <(Of <(<' T >)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | Clear()()()() | Removes all items from the ICollection<(Of <(<'T>)>)>. (Inherited from ICollection <(Of <(<' T >)>)>.)
 | CollectionChanged | (Inherited from INotifyCollectionChanged.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this IChannelCellCollection<(Of <(<'T>)>)> are constant.
 | Contains(T) | Determines whether the ICollection<(Of <(<'T>)>)> contains a specific value. (Inherited from ICollection <(Of <(<' T >)>)>.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the elements of the ICollection<(Of <(<'T>)>)> to an Array, starting at a particular Array index. (Inherited from ICollection <(Of <(<' T >)>)>.)
 | Count | Gets the number of elements contained in the ICollection<(Of <(<'T>)>)>. (Inherited from ICollection <(Of <(<' T >)>)>.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <(<' T >)>)>.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | IndexOf(T) | Determines the index of a specific item in the IList<(Of <(<'T>)>)>. (Inherited from IList <(Of <(<' T >)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | Insert(Int32, T) | Inserts an item to the IList<(Of <(<'T>)>)> at the specified index. (Inherited from IList <(Of <(<' T >)>)>.)
 | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(<'T>)>)> is read-only. (Inherited from ICollection <(Of <(<' T >)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from IList <(Of <(<' T >)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the ICollection<(Of <(<'T>)>)>. (Inherited from ICollection <(Of <(<' T >)>)>.)
 | RemoveAt(Int32) | Removes the IList<(Of <(<'T>)>)> item at the specified index. (Inherited from IList <(Of <(<' T >)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)


ConstantCellLength Property

ConstantCellLength Property
Namespaces ► TVA.PhasorProtocols ► IChannelCellCollection<(Of <(<'T>)>)> ► ConstantCellLength
Gets flag that determines if the lengths of IChannelCell elements in this IChannelCellCollection<(Of <(<'T>)>)> are constant.
Declaration Syntax
C# Visual Basic Visual C++
bool ConstantCellLength { get; }
ReadOnly Property ConstantCellLength As Boolean
    Get
property bool ConstantCellLength {
    bool get ();
}


IChannelCellParsingState Interface

IChannelCellParsingState Interface
Namespaces ► TVA.PhasorProtocols ► IChannelCellParsingState
Represents a protocol independent interface representation of the parsing state of any kind of IChannelCell.
Declaration Syntax
C# Visual Basic Visual C++
public interface IChannelCellParsingState : IChannelParsingState
Public Interface IChannelCellParsingState _
    Inherits IChannelParsingState
public interface class IChannelCellParsingState : IChannelParsingState
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed.
 | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed.
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
 | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed.


AnalogCount Property

AnalogCount Property
Namespaces ► TVA.PhasorProtocols ► IChannelCellParsingState ► AnalogCount
Gets or sets the number of analog elements associated with the IChannelCell being parsed.
Declaration Syntax
C# Visual Basic Visual C++
int AnalogCount { get; set; }
Property AnalogCount As Integer
    Get
    Set
property int AnalogCount {
    int get ();
    void set (int value);
}


DigitalCount Property

DigitalCount Property
Namespaces ► TVA.PhasorProtocols ► IChannelCellParsingState ► DigitalCount
Gets or sets the number of digital elements associated with the IChannelCell being parsed.
Declaration Syntax
C# Visual Basic Visual C++
int DigitalCount { get; set; }
Property DigitalCount As Integer
    Get
    Set
property int DigitalCount {
    int get ();
    void set (int value);
}


PhasorCount Property

PhasorCount Property
Namespaces ► TVA.PhasorProtocols ► IChannelCellParsingState ► PhasorCount
Gets or sets the number of phasor elements associated with the IChannelCell being parsed.
Declaration Syntax
C# Visual Basic Visual C++
int PhasorCount { get; set; }
Property PhasorCount As Integer
    Get
    Set
property int PhasorCount {
    int get ();
    void set (int value);
}


IChannelCollection(T) Interface

IChannelCollection<(Of <(<'T>)>)> Interface
Namespaces ► TVA.PhasorProtocols ► IChannelCollection<(Of <(<'T>)>)>
Represents a protocol independent interface representation of a collection of any IChannel objects.
This is the base interface implemented by all collections classes in the phasor protocols library; it is the root of the collection interface hierarchy.
Declaration Syntax
C# Visual Basic Visual C++
public interface IChannelCollection<T> : IChannel,
    ISupportBinaryImage, IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable,
    INotifyCollectionChanged, ISerializable
where T : IChannel

Public Interface IChannelCollection(Of T As IChannel) _
    Inherits IChannel, ISupportBinaryImage, IList(Of T),  _
    ICollection(Of T), IEnumerable(Of T), IEnumerable, INotifyCollectionChanged,  _
    ISerializable
generic<typename T>
where T : IChannel
public interface class IChannelCollection : IChannel,
    ISupportBinaryImage, IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable,
    INotifyCollectionChanged, ISerializable
Generic Template Parameters
T
Specific IChannel type that the IChannelCollection<(Of <(<'T>)>)> contains.
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Add(T) | Adds an item to the ICollection<(Of <(<'T>)>)>. (Inherited from ICollection <(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | Clear()()()() | Removes all items from the ICollection<(Of <(<'T>)>)>. (Inherited from ICollection <(Of <(<'T>)>)>.)
 | CollectionChanged | (Inherited from INotifyCollectionChanged.)
 | Contains(T) | Determines whether the ICollection<(Of <(<'T>)>)> contains a specific value. (Inherited from ICollection <(Of <(<'T>)>)>.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the elements of the ICollection<(Of <(<'T>)>)> to an Array, starting at a particular Array index. (Inherited from ICollection <(Of <(<'T>)>)>.)
 | Count | Gets the number of elements contained in the ICollection<(Of <(<'T>)>)>. (Inherited from ICollection <(Of <(<'T>)>)>.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <(<'T>)>)>.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | IndexOf(T) | Determines the index of a specific item in the IList<(Of <(<'T>)>)>. (Inherited from IList <(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | Insert(Int32, T) | Inserts an item to the IList<(Of <(<'T>)>)> at the specified index. (Inherited from IList <(Of <(<'T>)>)>.)
 | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(<'T>)>)> is read-only. (Inherited from ICollection <(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from IList <(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the ICollection<(Of <(<'T>)>)>. (Inherited from ICollection <(Of <(<'T>)>)>.)
 | RemoveAt(Int32) | Removes the IList<(Of <(<'T>)>)> item at the specified index. (Inherited from IList <(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)


IChannelDefinition Interface

IChannelDefinition Interface
Namespaces ► TVA.PhasorProtocols ► IChannelDefinition
Represents a protocol independent interface representation of a definition of any kind of IChannel data.
Declaration Syntax
C# Visual Basic Visual C++
public interface IChannelDefinition : IChannel,
    ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition>, IComparable<IChannelDefinition>,
    IComparable
Public Interface IChannelDefinition _
    Inherits IChannel, ISupportBinaryImage, ISerializable, IEquatable(Of IChannelDefinition),  _
    IComparable(Of IChannelDefinition), IComparable
public interface class IChannelDefinition : IChannel,
    ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition^>, IComparable<IChannelDefinition^>,
    IComparable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable <(Of <(<'IChannelDefinition>)>)>.)
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
 | ConversionFactor | Gets or sets the conversion factor of this IChannelDefinition.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this IChannelDefinition.
 | Equals(T) | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable <(Of <(<'IChannelDefinition>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | Index | Gets or sets the index of this IChannelDefinition.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | Label | Gets or sets the label of this IChannelDefinition.
 | LabelImage | Gets the binary image of the Label of this IChannelDefinition.
 | MaximumLabelLength | Gets the maximum length of the Label of this IChannelDefinition.
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this IChannelDefinition.
 | Offset | Gets or sets the offset of this IChannelDefinition.
 | Parent | Gets the IConfigurationCell parent of this IChannelDefinition.
 | ScalePerBit | Gets the scale/bit value of this IChannelDefinition.
 | ScalingValue | Gets or sets the integer scaling value of this IChannelDefinition.
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Remarks
Each instance of IChannelDefinition will have a more specific derived implementation (e.g., IAnalogDefinition and IFrequencyDefinition), these specific implementations of IChannelDefinition will be referenced children of a IConfigurationCell.
The IChannelDefinition defines the properties of an associated IChannelValue<(Of <(<'T>)>)>.


ConversionFactor Property

ConversionFactor Property
Namespaces ► TVA.PhasorProtocols ► IChannelDefinition ► ConversionFactor
Gets or sets the conversion factor of this IChannelDefinition.
Declaration Syntax
C# Visual Basic Visual C++
double ConversionFactor { get; set; }
Property ConversionFactor As Double
    Get
    Set
property double ConversionFactor {
    double get ();
    void set (double value);
}


DataFormat Property

DataFormat Property
Namespaces ► TVA.PhasorProtocols ► IChannelDefinition ► DataFormat
Gets the DataFormat of this IChannelDefinition.
Declaration Syntax
C# Visual Basic Visual C++
DataFormat DataFormat { get; }
ReadOnly Property DataFormat As DataFormat
    Get
property DataFormat DataFormat {
    DataFormat get ();
}


Index Property

Index Property
Namespaces ► TVA.PhasorProtocols ► IChannelDefinition ► Index
Gets or sets the index of this IChannelDefinition.
Declaration Syntax
C# Visual Basic Visual C++
int Index { get; set; }
Property Index As Integer
    Get
    Set
property int Index {
    int get ();
    void set (int value);
}


Label Property

Label Property
Namespaces ► TVA.PhasorProtocols ► IChannelDefinition ► Label
Gets or sets the label of this IChannelDefinition.
Declaration Syntax
C# Visual Basic Visual C++
string Label { get; set; }
Property Label As String
    Get
    Set
property String^ Label {
    String^ get ();
    void set (String^ value);
}


LabelImage Property

LabelImage Property
Namespaces ► TVA.PhasorProtocols ► IChannelDefinition ► LabelImage
Gets the binary image of the Label of this IChannelDefinition.
Declaration Syntax
C# Visual Basic Visual C++
byte[] LabelImage { get; }
ReadOnly Property LabelImage As Byte()
    Get
property array<unsigned char>^ LabelImage {
    array<unsigned char>^ get ();
}


MaximumLabelLength Property

MaximumLabelLength Property
Namespaces ► TVA.PhasorProtocols ► IChannelDefinition ► MaximumLabelLength
Gets the maximum length of the Label of this IChannelDefinition.
Declaration Syntax
C# Visual Basic Visual C++
int MaximumLabelLength { get; }
ReadOnly Property MaximumLabelLength As Integer
    Get
property int MaximumLabelLength {
    int get ();
}


MaximumScalingValue Property

MaximumScalingValue Property
Namespaces ► TVA.PhasorProtocols ► IChannelDefinition ► MaximumScalingValue
Gets the maximum value for the ScalingValue of this IChannelDefinition.
Declaration Syntax
C# Visual Basic Visual C++
uint MaximumScalingValue { get; }
ReadOnly Property MaximumScalingValue As UInteger
    Get
property unsigned int MaximumScalingValue {
    unsigned int get ();
}


Offset Property

Offset Property
Namespaces ► TVA.PhasorProtocols ► IChannelDefinition ► Offset
Gets or sets the offset of this IChannelDefinition.
Declaration Syntax
C# Visual Basic Visual C++
double Offset { get; set; }
Property Offset As Double
    Get
    Set
property double Offset {
    double get ();
    void set (double value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► IChannelDefinition ► Parent
Gets the IConfigurationCell parent of this IChannelDefinition.
Declaration Syntax
C# Visual Basic Visual C++
IConfigurationCell Parent { get; set; }
Property Parent As IConfigurationCell
    Get
    Set
property IConfigurationCell^ Parent {
    IConfigurationCell^ get ();
    void set (IConfigurationCell^ value);
}


ScalePerBit Property

ScalePerBit Property
Namespaces ► TVA.PhasorProtocols ► IChannelDefinition ► ScalePerBit
Gets the scale/bit value of this IChannelDefinition.
Declaration Syntax
C# Visual Basic Visual C++
double ScalePerBit { get; }
ReadOnly Property ScalePerBit As Double
    Get
property double ScalePerBit {
    double get ();
}


ScalingValue Property

ScalingValue Property
Namespaces ► TVA.PhasorProtocols ► IChannelDefinition ► ScalingValue
Gets or sets the integer scaling value of this IChannelDefinition.
Declaration Syntax
C# Visual Basic Visual C++
uint ScalingValue { get; set; }
Property ScalingValue As UInteger
    Get
    Set
property unsigned int ScalingValue {
    unsigned int get ();
    void set (unsigned int value);
}


IChannelFrame Interface

IChannelFrame Interface
Namespaces ► TVA.PhasorProtocols ► IChannelFrame
Represents a protocol independent interface representation of any kind of frame of data that contains a collection of IChannelCell objects.
Declaration Syntax
C# Visual Basic Visual C++
public interface IChannelFrame : IChannel,
    ISupportBinaryImage, IFrame, IEquatable<IFrame>, IComparable<IFrame>,
    IComparable, ISerializable
Public Interface IChannelFrame _
    Inherits IChannel, ISupportBinaryImage, IFrame, IEquatable(Of IFrame),  _
    IComparable(Of IFrame), IComparable, ISerializable
public interface class IChannelFrame : IChannel,
    ISupportBinaryImage, IFrame, IEquatable<IFrame^>, IComparable<IFrame^>,
    IComparable, ISerializable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | Cells | Gets the simple reference to the collection of cells for this IChannelFrame.
 | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable <(Of <(<'IFrame>)>)>.)
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(T) | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable <(Of <(<'IFrame>)>)>.)
 | FrameType | Gets the FundamentalFrameType for this IChannelFrame.
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | IDCode | Gets or sets the ID code of this IChannelFrame.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | LastSortedMeasurement()()()() | (Inherited from IFrame.)
 | Measurements()()()() | (Inherited from IFrame.)
 | Published()()()() | (Inherited from IFrame.)
 | PublishedTimestamp()()()() | (Inherited from IFrame.)
 | ReceivedTimestamp()()()() | (Inherited from IFrame.)
 | SortedMeasurements()()()() | (Inherited from IFrame.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
 | Timestamp()()()() | (Inherited from IFrame.)
 | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame.
Remarks

The phasor protocols library defines a "frame" as a collection of cells (logical units of data). For example, a IDataCell would be defined as a PMU within a frame of data, a IDataFrame (derived from IChannelFrame), that contains multiple PMU's coming from a PDC.

This interface inherits IFrame so that classes implementing this interface can be cooperatively integrated into measurement concentration (see ConcentratorBase).


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols ► IChannelFrame ► Cells
Gets the simple reference to the collection of cells for this IChannelFrame.
Declaration Syntax
C# Visual Basic Visual C++
Object Cells { get; }
ReadOnly Property Cells As Object
    Get
property Object^ Cells {
    Object^ get ();
}


FrameType Property

FrameType Property
Namespaces ► TVA.PhasorProtocols ► IChannelFrame ► FrameType
Gets the FundamentalFrameType for this IChannelFrame.
Declaration Syntax
C# Visual Basic Visual C++
FundamentalFrameType FrameType { get; }
ReadOnly Property FrameType As FundamentalFrameType
    Get
property FundamentalFrameType FrameType {
    FundamentalFrameType get ();
}


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols ► IChannelFrame ► IDCode
Gets or sets the ID code of this IChannelFrame.
Declaration Syntax
C# Visual Basic Visual C++
ushort IDCode { get; set; }
Property IDCode As UShort
    Get
    Set
property unsigned short IDCode {
    unsigned short get ();
    void set (unsigned short value);
}


TimeTag Property

TimeTag Property
Namespaces ► TVA.PhasorProtocols ► IChannelFrame ► TimeTag
Gets UNIX based time representation of the ticks of this IChannelFrame.
Declaration Syntax
C# Visual Basic Visual C++
UnixTimeTag TimeTag { get; }
ReadOnly Property TimeTag As UnixTimeTag
    Get
property UnixTimeTag^ TimeTag {
    UnixTimeTag^ get ();
}


IChannelFrame(T) Interface

IChannelFrame<(Of <(<'T>)>)> Interface
Namespaces ► TVA.PhasorProtocols ► IChannelFrame<(Of <(<'T>)>)>
Represents a strongly-typed protocol independent interface representation of any kind of frame of data that contains a collection of IChannelCell objects.
Declaration Syntax
C# Visual Basic Visual C++
public interface IChannelFrame<T> : IChannelFrame,
    IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame>,
    IComparable<IFrame>, IComparable, ISerializable
where T : IChannelCell

Public Interface IChannelFrame(Of T As IChannelCell) _
    Inherits IChannelFrame, IChannel, ISupportBinaryImage, IFrame,  _
    IEquatable(Of IFrame), IComparable(Of IFrame), IComparable,  _
    ISerializable
generic<typename T>
where T : IChannelCell
public interface class IChannelFrame : IChannelFrame,
    IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame^>,
    IComparable<IFrame^>, IComparable, ISerializable
Generic Template Parameters
T
Specific IChannelCell type that the IChannelFrame<(Of <(<'T>)>)> contains.
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | Cells | Gets the strongly-typed reference to the collection of cells for this IChannelFrame<(Of <(<'T>)>)>.
 | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
 | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable <(Of <(<'IFrame>)>)>.)
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(T) | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable <(Of <(<'IFrame>)>)>.)
 | FrameType | Gets the FundamentalFrameType for this IChannelFrame. (Inherited from IChannelFrame.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | IDCode | Gets or sets the ID code of this IChannelFrame. (Inherited from IChannelFrame.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | LastSortedMeasurement()()()() | (Inherited from IFrame.)
 | Measurements()()()() | (Inherited from IFrame.)
 | Published()()()() | (Inherited from IFrame.)
 | PublishedTimestamp()()()() | (Inherited from IFrame.)
 | ReceivedTimestamp()()()() | (Inherited from IFrame.)
 | SortedMeasurements()()()() | (Inherited from IFrame.)
 | State | Gets or sets the parsing state for this IChannelFrame<(Of <(<'T>)>)>.
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
 | Timestamp()()()() | (Inherited from IFrame.)
 | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame. (Inherited from IChannelFrame.)
Remarks
This interface inherits IFrame so that classes implementing this interface can be cooperatively integrated into measurement concentration (see ConcentratorBase).


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols ► IChannelFrame<(Of <(<'T>)>)> ► Cells
Gets the strongly-typed reference to the collection of cells for this IChannelFrame<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
IChannelCellCollection<T> Cells { get; }
ReadOnly Property Cells As IChannelCellCollection(Of T)
    Get
property IChannelCellCollection<T>^ Cells {
    IChannelCellCollection<T>^ get ();
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► IChannelFrame<(Of <(<'T>)>)> ► State
Gets or sets the parsing state for this IChannelFrame<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
IChannelFrameParsingState<T> State { get; set; }
Property State As IChannelFrameParsingState(Of T)
    Get
    Set
property IChannelFrameParsingState<T>^ State {
    IChannelFrameParsingState<T>^ get ();
    void set (IChannelFrameParsingState<T>^ value);
}


IChannelFrameParsingState(T) Interface

IChannelFrameParsingState<(Of <(<'T>)>)> Interface
Namespaces ► TVA.PhasorProtocols ► IChannelFrameParsingState<(Of <(<'T>)>)>
Represents a protocol independent interface representation of the parsing state of any kind of IChannelFrame.
Declaration Syntax
C# Visual Basic Visual C++
public interface IChannelFrameParsingState<T> : IChannelParsingState
where T : IChannelCell

Public Interface IChannelFrameParsingState(Of T As IChannelCell) _
    Inherits IChannelParsingState
generic<typename T>
where T : IChannelCell
public interface class IChannelFrameParsingState : IChannelParsingState
Generic Template Parameters
T
Specific IChannelCell type that the IChannelFrameParsingState<(Of <(<'T>)>)> references.
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed.
 | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object.
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)


CellCount Property

CellCount Property
Namespaces ► TVA.PhasorProtocols ► IChannelFrameParsingState<(Of <(<'T>)>)> ► CellCount
Gets or sets number of cells that are expected in associated IChannelFrame being parsed.
Declaration Syntax
C# Visual Basic Visual C++
int CellCount { get; set; }
Property CellCount As Integer
    Get
    Set
property int CellCount {
    int get ();
    void set (int value);
}


CreateNewCell Property

CreateNewCell Property
Namespaces ► TVA.PhasorProtocols ► IChannelFrameParsingState<(Of <(<'T>)>)> ► CreateNewCell
Gets reference to delegate used to create a new IChannelCell object.
Declaration Syntax
C# Visual Basic Visual C++
CreateNewCellFunction<T> CreateNewCell { get; }
ReadOnly Property CreateNewCell As CreateNewCellFunction(Of T)
    Get
property CreateNewCellFunction<T>^ CreateNewCell {
    CreateNewCellFunction<T>^ get ();
}


IChannelParsingState Interface

IChannelParsingState Interface
Namespaces ► TVA.PhasorProtocols ► IChannelParsingState
Represents a protocol independent interface representation of the parsing state used by any kind of IChannel data.
This is the base interface implemented by all parsing state classes in the phasor protocols library; it is the root of the parsing state interface hierarchy.
Declaration Syntax
C# Visual Basic Visual C++
public interface IChannelParsingState
Public Interface IChannelParsingState
public interface class IChannelParsingState
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image.
Remarks
Data parsing is very format specific, classes implementing this interface create a common form for parsing state information particular to a data type.


ParsedBinaryLength Property

ParsedBinaryLength Property
Namespaces ► TVA.PhasorProtocols ► IChannelParsingState ► ParsedBinaryLength
Gets or sets the length of the associated IChannel object being parsed from the binary image.
Declaration Syntax
C# Visual Basic Visual C++
int ParsedBinaryLength { get; set; }
Property ParsedBinaryLength As Integer
    Get
    Set
property int ParsedBinaryLength {
    int get ();
    void set (int value);
}


IChannelValue(T) Interface

IChannelValue<(Of <(<'T>)>)> Interface
Namespaces ► TVA.PhasorProtocols ► IChannelValue<(Of <(<'T>)>)>
Represents a protocol independent interface representation any kind of IChannel data value.
Declaration Syntax
C# Visual Basic Visual C++
public interface IChannelValue<T> : IChannel,
    ISupportBinaryImage, ISerializable
where T : IChannelDefinition

Public Interface IChannelValue(Of T As IChannelDefinition) _
    Inherits IChannel, ISupportBinaryImage, ISerializable
generic<typename T>
where T : IChannelDefinition
public interface class IChannelValue : IChannel,
    ISupportBinaryImage, ISerializable
Generic Template Parameters
T
Specific IChannelDefinition type that represents the IChannelValue<(Of <(<'T>)>)> definition.
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | CompositeValueCount | Gets total number of composite values that this IChannelValue<(Of <(<'T>)>)> provides.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this IChannelValue<(Of <(<'T>)>)> typically derived from DataFormat.
 | Definition | Gets the IChannelDefinition associated with this IChannelValue<(Of <(<'T>)>)>.
 | GetCompositeValue(Int32) | Gets the specified composite value of this IChannelValue<(Of <(<'T>)>)>.
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values.
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of IChannelValue<(Of <(<'T>)>)> have been assigned a value.
 | Label | Gets text based label of this IChannelValue<(Of <(<'T>)>)> typically derived from Label.
 | Measurements | Gets the composite values of this IChannelValue<(Of <(<'T>)>)> as an array of IMeasurement values.
 | Parent | Gets the IDataCell parent of this IChannelValue<(Of <(<'T>)>)>.
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Remarks
Each instance of IChannelValue<(Of <(<'T>)>)> will have a more specific derived implementation (e.g., IDigitalValue and IPhasorValue), these specific implementations of IChannelValue<(Of <(<'T>)>)> will be referenced children of a IDataCell.
The IChannelValue<(Of <(<'T>)>)> uses the specified IChannelDefinition type to define its properties.


CompositeValueCount Property

CompositeValueCount Property
Namespaces ► TVA.PhasorProtocols ► IChannelValue<(Of <(<'T>)>)> ► CompositeValueCount
Gets total number of composite values that this IChannelValue<(Of <(<'T>)>)> provides.
Declaration Syntax
C# Visual Basic Visual C++
int CompositeValueCount { get; }
ReadOnly Property CompositeValueCount As Integer
    Get
property int CompositeValueCount {
    int get ();
}


DataFormat Property

DataFormat Property
Namespaces ► TVA.PhasorProtocols ► IChannelValue<(Of <(<'T>)>)> ► DataFormat
Gets the DataFormat of this IChannelValue<(Of <(<'T>)>)> typically derived from DataFormat.
Declaration Syntax
C# Visual Basic Visual C++
DataFormat DataFormat { get; }
ReadOnly Property DataFormat As DataFormat
    Get
property DataFormat DataFormat {
    DataFormat get ();
}


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols ► IChannelValue<(Of <(<'T>)>)> ► Definition
Gets the IChannelDefinition associated with this IChannelValue<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
T Definition { get; set; }
Property Definition As T
    Get
    Set
property T Definition {
    T get ();
    void set (T value);
}


GetCompositeValue Method (index)

GetCompositeValue Method (index)
Namespaces ► TVA.PhasorProtocols ► IChannelValue<(Of <(<'T>)>)> ► GetCompositeValue(Int32)
Gets the specified composite value of this IChannelValue<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
double GetCompositeValue(
    int index
)
Function GetCompositeValue ( _
    index As Integer _
) As Double
double GetCompositeValue(
    int index
)
Parameters
index (Int32)
Index of composite value to retrieve.
Return Value
A Double representing the composite value.


GetMeasurementValueFilterFunction Method (index)

GetMeasurementValueFilterFunction Method (index)
Namespaces ► TVA.PhasorProtocols ► IChannelValue<(Of <(<'T>)>)> ► GetMeasurementValueFilterFunction(Int32)
Gets function used to apply a downsampling filter over a sequence of IMeasurement values.
Declaration Syntax
C# Visual Basic Visual C++
MeasurementValueFilterFunction GetMeasurementValueFilterFunction(
    int index
)
Function GetMeasurementValueFilterFunction ( _
    index As Integer _
) As MeasurementValueFilterFunction
MeasurementValueFilterFunction^ GetMeasurementValueFilterFunction(
    int index
)
Parameters
index (Int32)
Index of composite value for which to retrieve its filter function.
Return Value
Function used to apply a downsampling filter over a sequence of IMeasurement values, if defined; otherwise, null.


IsEmpty Property

IsEmpty Property
Namespaces ► TVA.PhasorProtocols ► IChannelValue<(Of <(<'T>)>)> ► IsEmpty
Gets boolean value that determines if none of the composite values of IChannelValue<(Of <(<'T>)>)> have been assigned a value.
Declaration Syntax
C# Visual Basic Visual C++
bool IsEmpty { get; }
ReadOnly Property IsEmpty As Boolean
    Get
property bool IsEmpty {
    bool get ();
}
Return Value
True, if no composite values have been assigned a value; otherwise, false.


Label Property

Label Property
Namespaces ► TVA.PhasorProtocols ► IChannelValue<(Of <(<'T>)>)> ► Label
Gets text based label of this IChannelValue<(Of <(<'T>)>)> typically derived from Label.
Declaration Syntax
C# Visual Basic Visual C++
string Label { get; }
ReadOnly Property Label As String
    Get
property String^ Label {
    String^ get ();
}


Measurements Property

Measurements Property
Namespaces ► TVA.PhasorProtocols ► IChannelValue<(Of <(<'T>)>)> ► Measurements
Gets the composite values of this IChannelValue<(Of <(<'T>)>)> as an array of IMeasurement values.
Declaration Syntax
C# Visual Basic Visual C++
IMeasurement[] Measurements { get; }
ReadOnly Property Measurements As IMeasurement()
    Get
property array<IMeasurement^>^ Measurements {
    array<IMeasurement^>^ get ();
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► IChannelValue<(Of <(<'T>)>)> ► Parent
Gets the IDataCell parent of this IChannelValue<(Of <(<'T>)>)>.
Declaration Syntax
C# Visual Basic Visual C++
IDataCell Parent { get; set; }
Property Parent As IDataCell
    Get
    Set
property IDataCell^ Parent {
    IDataCell^ get ();
    void set (IDataCell^ value);
}


ICommandCell Interface

ICommandCell Interface
Namespaces ► TVA.PhasorProtocols ► ICommandCell
Represents a protocol independent interface representation of any kind of ICommandFrame cell.
Declaration Syntax
C# Visual Basic Visual C++
public interface ICommandCell : IChannelCell,
    IChannel, ISupportBinaryImage, ISerializable
Public Interface ICommandCell _
    Inherits IChannelCell, IChannel, ISupportBinaryImage, ISerializable
public interface class ICommandCell : IChannelCell,
    IChannel, ISupportBinaryImage, ISerializable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | ExtendedDataByte | Gets or sets extended data Byte that represents this ICommandCell.
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | IDCode | Gets the numeric ID code for this IChannelCell. (Inherited from IChannelCell.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | Parent | Gets a reference to the parent ICommandFrame for this ICommandCell.
 | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell. (Inherited from IChannelCell.)
 | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from IChannelCell.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)


ExtendedDataByte Property

ExtendedDataByte Property
Namespaces ► TVA.PhasorProtocols ► ICommandCell ► ExtendedDataByte
Gets or sets extended data Byte that represents this ICommandCell.
Declaration Syntax
C# Visual Basic Visual C++
byte ExtendedDataByte { get; set; }
Property ExtendedDataByte As Byte
    Get
    Set
property unsigned char ExtendedDataByte {
    unsigned char get ();
    void set (unsigned char value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► ICommandCell ► Parent
Gets a reference to the parent ICommandFrame for this ICommandCell.
Declaration Syntax
C# Visual Basic Visual C++
ICommandFrame Parent { get; set; }
Property Parent As ICommandFrame
    Get
    Set
property ICommandFrame^ Parent {
    ICommandFrame^ get ();
    void set (ICommandFrame^ value);
}


ICommandFrame Interface

ICommandFrame Interface
Namespaces ► TVA.PhasorProtocols ► ICommandFrame
Represents a protocol independent interface representation of any kind of command frame that contains a collection of ICommandCell objects.
Declaration Syntax
C# Visual Basic Visual C++
public interface ICommandFrame : IChannelFrame<ICommandCell>,
    IChannelFrame, IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame>,
    IComparable<IFrame>, IComparable, ISerializable
Public Interface ICommandFrame _
    Inherits IChannelFrame(Of ICommandCell), IChannelFrame, IChannel,  _
    ISupportBinaryImage, IFrame, IEquatable(Of IFrame), IComparable(Of IFrame),  _
    IComparable, ISerializable
public interface class ICommandFrame : IChannelFrame<ICommandCell^>,
    IChannelFrame, IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame^>,
    IComparable<IFrame^>, IComparable, ISerializable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | Cells | Gets reference to the CommandCellCollection for this ICommandFrame.
 | Cells | Gets the strongly-typed reference to the collection of cells for this IChannelFrame<(Of <(<'T>)>)>. (Inherited from IChannelFrame<(Of <(<'T>)>)>.)
 | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
 | Command | Gets or sets DeviceCommand for this ICommandFrame.
 | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable <(Of <(<'IFrame>)>)>.)
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(T) | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable <(Of <(<'IFrame>)>)>.)
 | ExtendedData | Gets or sets extended binary image data for this ICommandFrame.
 | FrameType | Gets the FundamentalFrameType for this IChannelFrame. (Inherited from IChannelFrame.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | IDCode | Gets or sets the ID code of this IChannelFrame. (Inherited from IChannelFrame.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | LastSortedMeasurement()()()() | (Inherited from IFrame.)
 | Measurements()()()() | (Inherited from IFrame.)
 | Published()()()() | (Inherited from IFrame.)
 | PublishedTimestamp()()()() | (Inherited from IFrame.)
 | ReceivedTimestamp()()()() | (Inherited from IFrame.)
 | SortedMeasurements()()()() | (Inherited from IFrame.)
 | State | Gets or sets the parsing state for the this ICommandFrame.
 | State | Gets or sets the parsing state for this IChannelFrame<(Of <(<'T>)>)>. (Inherited from IChannelFrame<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
 | Timestamp()()()() | (Inherited from IFrame.)
 | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame. (Inherited from IChannelFrame.)


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols ► ICommandFrame ► Cells
Gets reference to the CommandCellCollection for this ICommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
CommandCellCollection Cells { get; }
ReadOnly Property Cells As CommandCellCollection
    Get
property CommandCellCollection^ Cells {
    CommandCellCollection^ get ();
}


Command Property

Command Property
Namespaces ► TVA.PhasorProtocols ► ICommandFrame ► Command
Gets or sets DeviceCommand for this ICommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
DeviceCommand Command { get; set; }
Property Command As DeviceCommand
    Get
    Set
property DeviceCommand Command {
    DeviceCommand get ();
    void set (DeviceCommand value);
}


ExtendedData Property

ExtendedData Property
Namespaces ► TVA.PhasorProtocols ► ICommandFrame ► ExtendedData
Gets or sets extended binary image data for this ICommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
byte[] ExtendedData { get; set; }
Property ExtendedData As Byte()
    Get
    Set
property array<unsigned char>^ ExtendedData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► ICommandFrame ► State
Gets or sets the parsing state for the this ICommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
ICommandFrameParsingState State { get; set; }
Property State As ICommandFrameParsingState
    Get
    Set
property ICommandFrameParsingState^ State {
    ICommandFrameParsingState^ get ();
    void set (ICommandFrameParsingState^ value);
}


ICommandFrameParsingState Interface

ICommandFrameParsingState Interface
Namespaces ► TVA.PhasorProtocols ► ICommandFrameParsingState
Represents a protocol independent interface representation of the parsing state of a ICommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
public interface ICommandFrameParsingState : IChannelFrameParsingState<ICommandCell>,
    IChannelParsingState
Public Interface ICommandFrameParsingState _
    Inherits IChannelFrameParsingState(Of ICommandCell), IChannelParsingState
public interface class ICommandFrameParsingState : IChannelFrameParsingState<ICommandCell^>,
    IChannelParsingState
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from IChannelFrameParsingState<(Of <(<'T>)>)>.)
 | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from IChannelFrameParsingState<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)


IConfigurationCell Interface

IConfigurationCell Interface
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell
Represents a protocol independent interface representation of any kind of IConfigurationFrame cell.
Declaration Syntax
C# Visual Basic Visual C++
public interface IConfigurationCell : IChannelCell,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IConfigurationCell>,
    IComparable<IConfigurationCell>, IComparable
Public Interface IConfigurationCell _
    Inherits IChannelCell, IChannel, ISupportBinaryImage, ISerializable,  _
    IEquatable(Of IConfigurationCell), IComparable(Of IConfigurationCell), IComparable
public interface class IConfigurationCell : IChannelCell,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IConfigurationCell^>,
    IComparable<IConfigurationCell^>, IComparable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this IConfigurationCell.
 | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this IConfigurationCell.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable <(Of <(<'IConfigurationCell>)>)>.)
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this IConfigurationCell.
 | Equals(T) | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable <(Of <(<'IConfigurationCell>)>)>.)
 | FrameRate | Gets the specified frame rate of this IConfigurationCell.
 | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this IConfigurationCell.
 | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this IConfigurationCell.
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | IDCode | Gets the numeric ID code for this IChannelCell. (Inherited from IChannelCell.)
 | IDLabel | Gets or sets the ID label of this IConfigurationCell.
 | IDLabelImage | Gets the binary image of the IDLabel of this IConfigurationCell.
 | IDLabelLength | Gets the length of the IDLabel of this IConfigurationCell.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | MaximumStationNameLength | Gets the maximum length of the StationName of this IConfigurationCell.
 | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this IConfigurationCell.
 | Parent | Gets a reference to the parent IConfigurationFrame for this IConfigurationCell.
 | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell. (Inherited from IChannelCell.)
 | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this IConfigurationCell.
 | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this IConfigurationCell.
 | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this IConfigurationCell.
 | RevisionCount | Gets or sets the revision count of this IConfigurationCell.
 | State | Gets or sets the parsing state for the this IConfigurationCell.
 | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from IChannelCell.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | StationName | Gets or sets the station name of this IConfigurationCell.
 | StationNameImage | Gets the binary image of the StationName of this IConfigurationCell.
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)


AnalogDataFormat Property

AnalogDataFormat Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► AnalogDataFormat
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
DataFormat AnalogDataFormat { get; set; }
Property AnalogDataFormat As DataFormat
    Get
    Set
property DataFormat AnalogDataFormat {
    DataFormat get ();
    void set (DataFormat value);
}


AnalogDefinitions Property

AnalogDefinitions Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► AnalogDefinitions
Gets a reference to the AnalogDefinitionCollection of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
AnalogDefinitionCollection AnalogDefinitions { get; }
ReadOnly Property AnalogDefinitions As AnalogDefinitionCollection
    Get
property AnalogDefinitionCollection^ AnalogDefinitions {
    AnalogDefinitionCollection^ get ();
}


DigitalDefinitions Property

DigitalDefinitions Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► DigitalDefinitions
Gets a reference to the DigitalDefinitionCollection of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
DigitalDefinitionCollection DigitalDefinitions { get; }
ReadOnly Property DigitalDefinitions As DigitalDefinitionCollection
    Get
property DigitalDefinitionCollection^ DigitalDefinitions {
    DigitalDefinitionCollection^ get ();
}


FrameRate Property

FrameRate Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► FrameRate
Gets the specified frame rate of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
ushort FrameRate { get; }
ReadOnly Property FrameRate As UShort
    Get
property unsigned short FrameRate {
    unsigned short get ();
}


FrequencyDataFormat Property

FrequencyDataFormat Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► FrequencyDataFormat
Gets or sets the DataFormat of the FrequencyDefinition of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
DataFormat FrequencyDataFormat { get; set; }
Property FrequencyDataFormat As DataFormat
    Get
    Set
property DataFormat FrequencyDataFormat {
    DataFormat get ();
    void set (DataFormat value);
}


FrequencyDefinition Property

FrequencyDefinition Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► FrequencyDefinition
Gets or sets the IFrequencyDefinition of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
IFrequencyDefinition FrequencyDefinition { get; set; }
Property FrequencyDefinition As IFrequencyDefinition
    Get
    Set
property IFrequencyDefinition^ FrequencyDefinition {
    IFrequencyDefinition^ get ();
    void set (IFrequencyDefinition^ value);
}


IDLabel Property

IDLabel Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► IDLabel
Gets or sets the ID label of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
string IDLabel { get; set; }
Property IDLabel As String
    Get
    Set
property String^ IDLabel {
    String^ get ();
    void set (String^ value);
}


IDLabelImage Property

IDLabelImage Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► IDLabelImage
Gets the binary image of the IDLabel of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
byte[] IDLabelImage { get; }
ReadOnly Property IDLabelImage As Byte()
    Get
property array<unsigned char>^ IDLabelImage {
    array<unsigned char>^ get ();
}


IDLabelLength Property

IDLabelLength Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► IDLabelLength
Gets the length of the IDLabel of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
int IDLabelLength { get; }
ReadOnly Property IDLabelLength As Integer
    Get
property int IDLabelLength {
    int get ();
}


MaximumStationNameLength Property

MaximumStationNameLength Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► MaximumStationNameLength
Gets the maximum length of the StationName of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
int MaximumStationNameLength { get; }
ReadOnly Property MaximumStationNameLength As Integer
    Get
property int MaximumStationNameLength {
    int get ();
}


NominalFrequency Property

NominalFrequency Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► NominalFrequency
Gets or sets the nominal LineFrequency of the FrequencyDefinition of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
LineFrequency NominalFrequency { get; set; }
Property NominalFrequency As LineFrequency
    Get
    Set
property LineFrequency NominalFrequency {
    LineFrequency get ();
    void set (LineFrequency value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► Parent
Gets a reference to the parent IConfigurationFrame for this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
IConfigurationFrame Parent { get; set; }
Property Parent As IConfigurationFrame
    Get
    Set
property IConfigurationFrame^ Parent {
    IConfigurationFrame^ get ();
    void set (IConfigurationFrame^ value);
}


PhasorCoordinateFormat Property

PhasorCoordinateFormat Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► PhasorCoordinateFormat
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
CoordinateFormat PhasorCoordinateFormat { get; set; }
Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get ();
    void set (CoordinateFormat value);
}


PhasorDataFormat Property

PhasorDataFormat Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► PhasorDataFormat
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
DataFormat PhasorDataFormat { get; set; }
Property PhasorDataFormat As DataFormat
    Get
    Set
property DataFormat PhasorDataFormat {
    DataFormat get ();
    void set (DataFormat value);
}


PhasorDefinitions Property

PhasorDefinitions Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► PhasorDefinitions
Gets a reference to the PhasorDefinitionCollection of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
PhasorDefinitionCollection PhasorDefinitions { get; }
ReadOnly Property PhasorDefinitions As PhasorDefinitionCollection
    Get
property PhasorDefinitionCollection^ PhasorDefinitions {
    PhasorDefinitionCollection^ get ();
}


RevisionCount Property

RevisionCount Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► RevisionCount
Gets or sets the revision count of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
ushort RevisionCount { get; set; }
Property RevisionCount As UShort
    Get
    Set
property unsigned short RevisionCount {
    unsigned short get ();
    void set (unsigned short value);
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► State
Gets or sets the parsing state for the this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
IConfigurationCellParsingState State { get; set; }
Property State As IConfigurationCellParsingState
    Get
    Set
property IConfigurationCellParsingState^ State {
    IConfigurationCellParsingState^ get ();
    void set (IConfigurationCellParsingState^ value);
}


StationName Property

StationName Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► StationName
Gets or sets the station name of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
string StationName { get; set; }
Property StationName As String
    Get
    Set
property String^ StationName {
    String^ get ();
    void set (String^ value);
}


StationNameImage Property

StationNameImage Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► StationNameImage
Gets the binary image of the StationName of this IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
byte[] StationNameImage { get; }
ReadOnly Property StationNameImage As Byte()
    Get
property array<unsigned char>^ StationNameImage {
    array<unsigned char>^ get ();
}


IConfigurationCellParsingState Interface

IConfigurationCellParsingState Interface
Namespaces ► TVA.PhasorProtocols ► IConfigurationCellParsingState
Represents a protocol independent interface representation of the parsing state of any kind of IConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public interface IConfigurationCellParsingState : IChannelCellParsingState,
    IChannelParsingState
Public Interface IConfigurationCellParsingState _
    Inherits IChannelCellParsingState, IChannelParsingState
public interface class IConfigurationCellParsingState : IChannelCellParsingState,
    IChannelParsingState
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)
 | CreateNewAnalogDefinition | Gets reference to CreateNewDefinitionFunction<(Of <(<'T>)>)> delegate used to create new IAnalogDefinition objects.
 | CreateNewDigitalDefinition | Gets reference to CreateNewDefinitionFunction<(Of <(<'T>)>)> delegate used to create new IDigitalDefinition objects.
 | CreateNewFrequencyDefinition | Gets reference to CreateNewDefinitionFunction<(Of <(<'T>)>)> delegate used to create new IFrequencyDefinition objects.
 | CreateNewPhasorDefinition | Gets reference to CreateNewDefinitionFunction<(Of <(<'T>)>)> delegate used to create new IPhasorDefinition objects.
 | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
 | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)


CreateNewAnalogDefinition Property

CreateNewAnalogDefinition Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCellParsingState ► CreateNewAnalogDefinition
Gets reference to CreateNewDefinitionFunction<(Of <(<'T>)>)> delegate used to create new IAnalogDefinition objects.
Declaration Syntax
C# Visual Basic Visual C++
CreateNewDefinitionFunction<IAnalogDefinition> CreateNewAnalogDefinition { get; }
ReadOnly Property CreateNewAnalogDefinition As CreateNewDefinitionFunction(Of IAnalogDefinition)
    Get
property CreateNewDefinitionFunction<IAnalogDefinition^>^ CreateNewAnalogDefinition {
    CreateNewDefinitionFunction<IAnalogDefinition^>^ get ();
}


CreateNewDigitalDefinition Property

CreateNewDigitalDefinition Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCellParsingState ► CreateNewDigitalDefinition
Gets reference to CreateNewDefinitionFunction<(Of <(<'T>)>)> delegate used to create new IDigitalDefinition objects.
Declaration Syntax
C# Visual Basic Visual C++
CreateNewDefinitionFunction<IDigitalDefinition> CreateNewDigitalDefinition { get; }
ReadOnly Property CreateNewDigitalDefinition As CreateNewDefinitionFunction(Of IDigitalDefinition)
    Get
property CreateNewDefinitionFunction<IDigitalDefinition^>^ CreateNewDigitalDefinition {
    CreateNewDefinitionFunction<IDigitalDefinition^>^ get ();
}


CreateNewFrequencyDefinition Property

CreateNewFrequencyDefinition Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCellParsingState ► CreateNewFrequencyDefinition
Gets reference to CreateNewDefinitionFunction<(Of <(<'T>)>)> delegate used to create new IFrequencyDefinition objects.
Declaration Syntax
C# Visual Basic Visual C++
CreateNewDefinitionFunction<IFrequencyDefinition> CreateNewFrequencyDefinition { get; }
ReadOnly Property CreateNewFrequencyDefinition As CreateNewDefinitionFunction(Of IFrequencyDefinition)
    Get
property CreateNewDefinitionFunction<IFrequencyDefinition^>^ CreateNewFrequencyDefinition {
    CreateNewDefinitionFunction<IFrequencyDefinition^>^ get ();
}


CreateNewPhasorDefinition Property

CreateNewPhasorDefinition Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCellParsingState ► CreateNewPhasorDefinition
Gets reference to CreateNewDefinitionFunction<(Of <(<'T>)>)> delegate used to create new IPhasorDefinition objects.
Declaration Syntax
C# Visual Basic Visual C++
CreateNewDefinitionFunction<IPhasorDefinition> CreateNewPhasorDefinition { get; }
ReadOnly Property CreateNewPhasorDefinition As CreateNewDefinitionFunction(Of IPhasorDefinition)
    Get
property CreateNewDefinitionFunction<IPhasorDefinition^>^ CreateNewPhasorDefinition {
    CreateNewDefinitionFunction<IPhasorDefinition^>^ get ();
}


IConfigurationFrame Interface

IConfigurationFrame Interface
Namespaces ► TVA.PhasorProtocols ► IConfigurationFrame
Represents a protocol independent interface representation of any kind of configuration frame that contains a collection of IConfigurationCell objects.
Declaration Syntax
C# Visual Basic Visual C++
public interface IConfigurationFrame : IChannelFrame,
    IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame>,
    IComparable<IFrame>, IComparable, ISerializable
Public Interface IConfigurationFrame _
    Inherits IChannelFrame, IChannel, ISupportBinaryImage, IFrame,  _
    IEquatable(Of IFrame), IComparable(Of IFrame), IComparable,  _
    ISerializable
public interface class IConfigurationFrame : IChannelFrame,
    IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame^>,
    IComparable<IFrame^>, IComparable, ISerializable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | Cells | Gets reference to the ConfigurationCellCollection for this IConfigurationFrame.
 | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
 | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable <(Of <(<'IFrame>)>)>.)
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(T) | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable <(Of <(<'IFrame>)>)>.)
 | FrameRate | Gets or sets defined frame rate of this IConfigurationFrame.
 | FrameType | Gets the FundamentalFrameType for this IChannelFrame. (Inherited from IChannelFrame.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | IDCode | Gets or sets the ID code of this IChannelFrame. (Inherited from IChannelFrame.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | LastSortedMeasurement()()()() | (Inherited from IFrame.)
 | Measurements()()()() | (Inherited from IFrame.)
 | Published()()()() | (Inherited from IFrame.)
 | PublishedTimestamp()()()() | (Inherited from IFrame.)
 | ReceivedTimestamp()()()() | (Inherited from IFrame.)
 | SetNominalFrequency(LineFrequency) | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection.
 | SortedMeasurements()()()() | (Inherited from IFrame.)
 | State | Gets or sets the parsing state for the this IConfigurationFrame.
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
 | TicksPerFrame | Gets the defined Ticks per frame of this IConfigurationFrame.
 | Timestamp()()()() | (Inherited from IFrame.)
 | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame. (Inherited from IChannelFrame.)


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationFrame ► Cells
Gets reference to the ConfigurationCellCollection for this IConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
ConfigurationCellCollection Cells { get; }
ReadOnly Property Cells As ConfigurationCellCollection
    Get
property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}


FrameRate Property

FrameRate Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationFrame ► FrameRate
Gets or sets defined frame rate of this IConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
ushort FrameRate { get; set; }
Property FrameRate As UShort
    Get
    Set
property unsigned short FrameRate {
    unsigned short get ();
    void set (unsigned short value);
}


SetNominalFrequency Method (value)

SetNominalFrequency Method (value)
Namespaces ► TVA.PhasorProtocols ► IConfigurationFrame ► SetNominalFrequency(LineFrequency)
Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection.
Declaration Syntax
C# Visual Basic Visual C++
void SetNominalFrequency(
    LineFrequency value
)
Sub SetNominalFrequency ( _
    value As LineFrequency _
)
void SetNominalFrequency(
    LineFrequency value
)
Parameters
value (LineFrequency)
New nominal LineFrequency for IFrequencyDefinition elements.


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationFrame ► State
Gets or sets the parsing state for the this IConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
IConfigurationFrameParsingState State { get; set; }
Property State As IConfigurationFrameParsingState
    Get
    Set
property IConfigurationFrameParsingState^ State {
    IConfigurationFrameParsingState^ get ();
    void set (IConfigurationFrameParsingState^ value);
}


TicksPerFrame Property

TicksPerFrame Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationFrame ► TicksPerFrame
Gets the defined Ticks per frame of this IConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
decimal TicksPerFrame { get; }
ReadOnly Property TicksPerFrame As Decimal
    Get
property Decimal TicksPerFrame {
    Decimal get ();
}


IConfigurationFrameParsingState Interface

IConfigurationFrameParsingState Interface
Namespaces ► TVA.PhasorProtocols ► IConfigurationFrameParsingState
Represents a protocol independent interface representation of the parsing state of a IConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public interface IConfigurationFrameParsingState : IChannelFrameParsingState<IConfigurationCell>,
    IChannelParsingState
Public Interface IConfigurationFrameParsingState _
    Inherits IChannelFrameParsingState(Of IConfigurationCell), IChannelParsingState
public interface class IConfigurationFrameParsingState : IChannelFrameParsingState<IConfigurationCell^>,
    IChannelParsingState
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from IChannelFrameParsingState<(Of <(<'T>)>)>.)
 | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from IChannelFrameParsingState<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)


IConnectionParameters Interface

IConnectionParameters Interface
Namespaces ► TVA.PhasorProtocols ► IConnectionParameters
Represents a protocol independent interface representation of custom connection parameters.
Declaration Syntax
C# Visual Basic Visual C++
public interface IConnectionParameters : ISerializable
Public Interface IConnectionParameters _
    Inherits ISerializable
public interface class IConnectionParameters : ISerializable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | ValuesAreValid | Determines if custom connection parameters are valid.


ValuesAreValid Property

ValuesAreValid Property
Namespaces ► TVA.PhasorProtocols ► IConnectionParameters ► ValuesAreValid
Determines if custom connection parameters are valid.
Declaration Syntax
C# Visual Basic Visual C++
bool ValuesAreValid { get; }
ReadOnly Property ValuesAreValid As Boolean
    Get
property bool ValuesAreValid {
    bool get ();
}


IDataCell Interface

IDataCell Interface
Namespaces ► TVA.PhasorProtocols ► IDataCell
Represents a protocol independent interface representation of any kind of IDataFrame cell.
Declaration Syntax
C# Visual Basic Visual C++
public interface IDataCell : IChannelCell,
    IChannel, ISupportBinaryImage, ISerializable, IMeasurement, ITimeSeriesValue<double>,
    ITimeSeriesValue, IEquatable<ITimeSeriesValue>, IComparable<ITimeSeriesValue>,
    IComparable
Public Interface IDataCell _
    Inherits IChannelCell, IChannel, ISupportBinaryImage, ISerializable,  _
    IMeasurement, ITimeSeriesValue(Of Double), ITimeSeriesValue, IEquatable(Of ITimeSeriesValue),  _
    IComparable(Of ITimeSeriesValue), IComparable
public interface class IDataCell : IChannelCell,
    IChannel, ISupportBinaryImage, ISerializable, IMeasurement, ITimeSeriesValue<double>,
    ITimeSeriesValue, IEquatable<ITimeSeriesValue^>, IComparable<ITimeSeriesValue^>,
    IComparable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Adder()()()() | (Inherited from IMeasurement.)
 | AdjustedValue()()()() | (Inherited from IMeasurement.)
 | AllValuesAssigned | Gets flag that determines if all values of this IDataCell have been assigned.
 | AnalogValues | Gets AnalogValueCollectionof this IDataCell.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | CommonStatusFlags | Gets or sets command status flags of this IDataCell.
 | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable <(Of <(<'ITimeSeriesValue>)>)>.)
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
 | ConfigurationCell | Gets or sets IConfigurationCell associated with this IDataCell.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataIsValid | Gets or sets flag that determines if data of this IDataCell is valid.
 | DataSortingType | Gets or sets DataSortingType of this IDataCell.
 | DeviceError | Gets or sets flag that determines if source device of this IDataCell is reporting an error.
 | DigitalValues | Gets DigitalValueCollectionof this IDataCell.
 | Equals(T) | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable <(Of <(<'ITimeSeriesValue>)>)>.)
 | FrequencyValue | Gets IFrequencyValue of this IDataCell.
 | GetHashCode()()()() | (Inherited from ITimeSeriesValue.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | ID()()()() | (Inherited from ITimeSeriesValue.)
 | IDCode | Gets the numeric ID code for this IChannelCell. (Inherited from IChannelCell.)
 | IDLabel | Gets ID label of this IDataCell.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | Key()()()() | (Inherited from IMeasurement.)
 | MeasurementValueFilter()()()() | (Inherited from IMeasurement.)
 | Multiplier()()()() | (Inherited from IMeasurement.)
 | Parent | Gets reference to parent IDataFrame of this IDataCell.
 | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell. (Inherited from IChannelCell.)
 | PhasorValues | Gets PhasorValueCollection of this IDataCell.
 | PublishedTimestamp()()()() | (Inherited from IMeasurement.)
 | ReceivedTimestamp()()()() | (Inherited from IMeasurement.)
 | State | Gets or sets the parsing state for the this IDataCell.
 | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from IChannelCell.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | StateFlags()()()() | (Inherited from IMeasurement.)
 | StationName | Gets station name of this IDataCell.
 | StatusFlags | Gets or sets 16-bit status flags of this IDataCell.
 | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this IDataCell is valid based on GPS lock.
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
 | TagName()()()() | (Inherited from IMeasurement.)
 | Timestamp()()()() | (Inherited from ITimeSeriesValue.)
 | Value()()()() | (Inherited from ITimeSeriesValue<(Of <(<' Double >)>)>.)
 | Value()()()() | (Inherited from ITimeSeriesValue.)
Remarks
This phasor protocol implementation defines a "cell" as a portion of a "frame", i.e., a logical unit of data. For example, a IDataCell could be defined as a PMU within a IDataFrame that contains multiple PMU's coming from a PDC.


AllValuesAssigned Property

AllValuesAssigned Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► AllValuesAssigned
Gets flag that determines if all values of this IDataCell have been assigned.
Declaration Syntax
C# Visual Basic Visual C++
bool AllValuesAssigned { get; }
ReadOnly Property AllValuesAssigned As Boolean
    Get
property bool AllValuesAssigned {
    bool get ();
}


AnalogValues Property

AnalogValues Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► AnalogValues
Gets AnalogValueCollectionof this IDataCell.
Declaration Syntax
C# Visual Basic Visual C++
AnalogValueCollection AnalogValues { get; }
ReadOnly Property AnalogValues As AnalogValueCollection
    Get
property AnalogValueCollection^ AnalogValues {
    AnalogValueCollection^ get ();
}


CommonStatusFlags Property

CommonStatusFlags Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► CommonStatusFlags
Gets or sets command status flags of this IDataCell.
Declaration Syntax
C# Visual Basic Visual C++
uint CommonStatusFlags { get; set; }
Property CommonStatusFlags As UInteger
    Get
    Set
property unsigned int CommonStatusFlags {
    unsigned int get ();
    void set (unsigned int value);
}


ConfigurationCell Property

ConfigurationCell Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► ConfigurationCell
Gets or sets IConfigurationCell associated with this IDataCell.
Declaration Syntax
C# Visual Basic Visual C++
IConfigurationCell ConfigurationCell { get; set; }
Property ConfigurationCell As IConfigurationCell
    Get
    Set
property IConfigurationCell^ ConfigurationCell {
    IConfigurationCell^ get ();
    void set (IConfigurationCell^ value);
}


DataIsValid Property

DataIsValid Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► DataIsValid
Gets or sets flag that determines if data of this IDataCell is valid.
Declaration Syntax
C# Visual Basic Visual C++
bool DataIsValid { get; set; }
Property DataIsValid As Boolean
    Get
    Set
property bool DataIsValid {
    bool get ();
    void set (bool value);
}


DataSortingType Property

DataSortingType Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► DataSortingType
Gets or sets DataSortingType of this IDataCell.
Declaration Syntax
C# Visual Basic Visual C++
DataSortingType DataSortingType { get; set; }
Property DataSortingType As DataSortingType
    Get
    Set
property DataSortingType DataSortingType {
    DataSortingType get ();
    void set (DataSortingType value);
}


DeviceError Property

DeviceError Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► DeviceError
Gets or sets flag that determines if source device of this IDataCell is reporting an error.
Declaration Syntax
C# Visual Basic Visual C++
bool DeviceError { get; set; }
Property DeviceError As Boolean
    Get
    Set
property bool DeviceError {
    bool get ();
    void set (bool value);
}


DigitalValues Property

DigitalValues Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► DigitalValues
Gets DigitalValueCollectionof this IDataCell.
Declaration Syntax
C# Visual Basic Visual C++
DigitalValueCollection DigitalValues { get; }
ReadOnly Property DigitalValues As DigitalValueCollection
    Get
property DigitalValueCollection^ DigitalValues {
    DigitalValueCollection^ get ();
}


FrequencyValue Property

FrequencyValue Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► FrequencyValue
Gets IFrequencyValue of this IDataCell.
Declaration Syntax
C# Visual Basic Visual C++
IFrequencyValue FrequencyValue { get; set; }
Property FrequencyValue As IFrequencyValue
    Get
    Set
property IFrequencyValue^ FrequencyValue {
    IFrequencyValue^ get ();
    void set (IFrequencyValue^ value);
}


IDLabel Property

IDLabel Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► IDLabel
Gets ID label of this IDataCell.
Declaration Syntax
C# Visual Basic Visual C++
string IDLabel { get; }
ReadOnly Property IDLabel As String
    Get
property String^ IDLabel {
    String^ get ();
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► Parent
Gets reference to parent IDataFrame of this IDataCell.
Declaration Syntax
C# Visual Basic Visual C++
IDataFrame Parent { get; set; }
Property Parent As IDataFrame
    Get
    Set
property IDataFrame^ Parent {
    IDataFrame^ get ();
    void set (IDataFrame^ value);
}


PhasorValues Property

PhasorValues Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► PhasorValues
Gets PhasorValueCollection of this IDataCell.
Declaration Syntax
C# Visual Basic Visual C++
PhasorValueCollection PhasorValues { get; }
ReadOnly Property PhasorValues As PhasorValueCollection
    Get
property PhasorValueCollection^ PhasorValues {
    PhasorValueCollection^ get ();
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► State
Gets or sets the parsing state for the this IDataCell.
Declaration Syntax
C# Visual Basic Visual C++
IDataCellParsingState State { get; set; }
Property State As IDataCellParsingState
    Get
    Set
property IDataCellParsingState^ State {
    IDataCellParsingState^ get ();
    void set (IDataCellParsingState^ value);
}


StationName Property

StationName Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► StationName
Gets station name of this IDataCell.
Declaration Syntax
C# Visual Basic Visual C++
string StationName { get; }
ReadOnly Property StationName As String
    Get
property String^ StationName {
    String^ get ();
}


StatusFlags Property

StatusFlags Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► StatusFlags
Gets or sets 16-bit status flags of this IDataCell.
Declaration Syntax
C# Visual Basic Visual C++
ushort StatusFlags { get; set; }
Property StatusFlags As UShort
    Get
    Set
property unsigned short StatusFlags {
    unsigned short get ();
    void set (unsigned short value);
}


SynchronizationIsValid Property

SynchronizationIsValid Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► SynchronizationIsValid
Gets or sets flag that determines if timestamp of this IDataCell is valid based on GPS lock.
Declaration Syntax
C# Visual Basic Visual C++
bool SynchronizationIsValid { get; set; }
Property SynchronizationIsValid As Boolean
    Get
    Set
property bool SynchronizationIsValid {
    bool get ();
    void set (bool value);
}


IDataCellParsingState Interface

IDataCellParsingState Interface
Namespaces ► TVA.PhasorProtocols ► IDataCellParsingState
Represents a protocol independent interface representation of the parsing state of any kind of IDataCell.
Declaration Syntax
C# Visual Basic Visual C++
public interface IDataCellParsingState : IChannelCellParsingState,
    IChannelParsingState
Public Interface IDataCellParsingState _
    Inherits IChannelCellParsingState, IChannelParsingState
public interface class IDataCellParsingState : IChannelCellParsingState,
    IChannelParsingState
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)
 | ConfigurationCell | Gets reference to the IConfigurationCell associated with the IDataCell being parsed.
 | CreateNewAnalogValue | Gets reference to CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> delegate used to create new IAnalogValue objects.
 | CreateNewDigitalValue | Gets reference to CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> delegate used to create new IDigitalValue objects.
 | CreateNewFrequencyValue | Gets reference to CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> delegate used to create new IFrequencyValue objects.
 | CreateNewPhasorValue | Gets reference to CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> delegate used to create new IPhasorValue objects.
 | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
 | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)


ConfigurationCell Property

ConfigurationCell Property
Namespaces ► TVA.PhasorProtocols ► IDataCellParsingState ► ConfigurationCell
Gets reference to the IConfigurationCell associated with the IDataCell being parsed.
Declaration Syntax
C# Visual Basic Visual C++
IConfigurationCell ConfigurationCell { get; }
ReadOnly Property ConfigurationCell As IConfigurationCell
    Get
property IConfigurationCell^ ConfigurationCell {
    IConfigurationCell^ get ();
}


CreateNewAnalogValue Property

CreateNewAnalogValue Property
Namespaces ► TVA.PhasorProtocols ► IDataCellParsingState ► CreateNewAnalogValue
Gets reference to CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> delegate used to create new IAnalogValue objects.
Declaration Syntax
C# Visual Basic Visual C++
CreateNewValueFunction<IAnalogDefinition, IAnalogValue> CreateNewAnalogValue { get; }
ReadOnly Property CreateNewAnalogValue As CreateNewValueFunction(Of IAnalogDefinition, IAnalogValue)
    Get
property CreateNewValueFunction<IAnalogDefinition^, IAnalogValue^>^ CreateNewAnalogValue {
    CreateNewValueFunction<IAnalogDefinition^, IAnalogValue^>^ get ();
}


CreateNewDigitalValue Property

CreateNewDigitalValue Property
Namespaces ► TVA.PhasorProtocols ► IDataCellParsingState ► CreateNewDigitalValue
Gets reference to CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> delegate used to create new IDigitalValue objects.
Declaration Syntax
C# Visual Basic Visual C++
CreateNewValueFunction<IDigitalDefinition, IDigitalValue> CreateNewDigitalValue { get; }
ReadOnly Property CreateNewDigitalValue As CreateNewValueFunction(Of IDigitalDefinition, IDigitalValue)
    Get
property CreateNewValueFunction<IDigitalDefinition^, IDigitalValue^>^ CreateNewDigitalValue {
    CreateNewValueFunction<IDigitalDefinition^, IDigitalValue^>^ get ();
}


CreateNewFrequencyValue Property

CreateNewFrequencyValue Property
Namespaces ► TVA.PhasorProtocols ► IDataCellParsingState ► CreateNewFrequencyValue
Gets reference to CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> delegate used to create new IFrequencyValue objects.
Declaration Syntax
C# Visual Basic Visual C++
CreateNewValueFunction<IFrequencyDefinition, IFrequencyValue> CreateNewFrequencyValue { get; }
ReadOnly Property CreateNewFrequencyValue As CreateNewValueFunction(Of IFrequencyDefinition, IFrequencyValue)
    Get
property CreateNewValueFunction<IFrequencyDefinition^, IFrequencyValue^>^ CreateNewFrequencyValue {
    CreateNewValueFunction<IFrequencyDefinition^, IFrequencyValue^>^ get ();
}


CreateNewPhasorValue Property

CreateNewPhasorValue Property
Namespaces ► TVA.PhasorProtocols ► IDataCellParsingState ► CreateNewPhasorValue
Gets reference to CreateNewValueFunction<(Of <(<'TDefinition, TValue>)>)> delegate used to create new IPhasorValue objects.
Declaration Syntax
C# Visual Basic Visual C++
CreateNewValueFunction<IPhasorDefinition, IPhasorValue> CreateNewPhasorValue { get; }
ReadOnly Property CreateNewPhasorValue As CreateNewValueFunction(Of IPhasorDefinition, IPhasorValue)
    Get
property CreateNewValueFunction<IPhasorDefinition^, IPhasorValue^>^ CreateNewPhasorValue {
    CreateNewValueFunction<IPhasorDefinition^, IPhasorValue^>^ get ();
}


IDataFrame Interface

IDataFrame Interface
Namespaces ► TVA.PhasorProtocols ► IDataFrame
Represents a protocol independent interface representation of any kind of data frame that contains a collection of IDataCell objects.
Declaration Syntax
C# Visual Basic Visual C++
public interface IDataFrame : IChannelFrame,
    IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame>,
    IComparable<IFrame>, IComparable, ISerializable
Public Interface IDataFrame _
    Inherits IChannelFrame, IChannel, ISupportBinaryImage, IFrame,  _
    IEquatable(Of IFrame), IComparable(Of IFrame), IComparable,  _
    ISerializable
public interface class IDataFrame : IChannelFrame,
    IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame^>,
    IComparable<IFrame^>, IComparable, ISerializable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | Cells | Gets reference to the DataCellCollection for this IDataFrame.
 | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
 | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable <(Of <(<'IFrame>)>)>.)
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
 | ConfigurationFrame | Gets or sets IConfigurationFrame associated with this IDataFrame.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(T) | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable <(Of <(<'IFrame>)>)>.)
 | FrameType | Gets the FundamentalFrameType for this IChannelFrame. (Inherited from IChannelFrame.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | IDCode | Gets or sets the ID code of this IChannelFrame. (Inherited from IChannelFrame.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | LastSortedMeasurement()()()() | (Inherited from IFrame.)
 | Measurements()()()() | (Inherited from IFrame.)
 | Published()()()() | (Inherited from IFrame.)
 | PublishedTimestamp()()()() | (Inherited from IFrame.)
 | ReceivedTimestamp()()()() | (Inherited from IFrame.)
 | SortedMeasurements()()()() | (Inherited from IFrame.)
 | State | Gets or sets the parsing state for the this IDataFrame.
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
 | Timestamp()()()() | (Inherited from IFrame.)
 | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame. (Inherited from IChannelFrame.)


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols ► IDataFrame ► Cells
Gets reference to the DataCellCollection for this IDataFrame.
Declaration Syntax
C# Visual Basic Visual C++
DataCellCollection Cells { get; }
ReadOnly Property Cells As DataCellCollection
    Get
property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols ► IDataFrame ► ConfigurationFrame
Gets or sets IConfigurationFrame associated with this IDataFrame.
Declaration Syntax
C# Visual Basic Visual C++
IConfigurationFrame ConfigurationFrame { get; set; }
Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get ();
    void set (IConfigurationFrame^ value);
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► IDataFrame ► State
Gets or sets the parsing state for the this IDataFrame.
Declaration Syntax
C# Visual Basic Visual C++
IDataFrameParsingState State { get; set; }
Property State As IDataFrameParsingState
    Get
    Set
property IDataFrameParsingState^ State {
    IDataFrameParsingState^ get ();
    void set (IDataFrameParsingState^ value);
}


IDataFrameParsingState Interface

IDataFrameParsingState Interface
Namespaces ► TVA.PhasorProtocols ► IDataFrameParsingState
Represents a protocol independent interface representation of the parsing state of a IDataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public interface IDataFrameParsingState : IChannelFrameParsingState<IDataCell>,
    IChannelParsingState
Public Interface IDataFrameParsingState _
    Inherits IChannelFrameParsingState(Of IDataCell), IChannelParsingState
public interface class IDataFrameParsingState : IChannelFrameParsingState<IDataCell^>,
    IChannelParsingState
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from IChannelFrameParsingState<(Of <(<'T>)>)>.)
 | ConfigurationFrame | Gets reference to the IConfigurationFrame associated with the IDataFrame being parsed.
 | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from IChannelFrameParsingState<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols ► IDataFrameParsingState ► ConfigurationFrame
Gets reference to the IConfigurationFrame associated with the IDataFrame being parsed.
Declaration Syntax
C# Visual Basic Visual C++
IConfigurationFrame ConfigurationFrame { get; }
ReadOnly Property ConfigurationFrame As IConfigurationFrame
    Get
property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get ();
}


IDigitalDefinition Interface

IDigitalDefinition Interface
Namespaces ► TVA.PhasorProtocols ► IDigitalDefinition
Represents a protocol independent interface representation of a definition of a IDigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
public interface IDigitalDefinition : IChannelDefinition,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition>,
    IComparable<IChannelDefinition>, IComparable
Public Interface IDigitalDefinition _
    Inherits IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,  _
    IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition), IComparable
public interface class IDigitalDefinition : IChannelDefinition,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition^>,
    IComparable<IChannelDefinition^>, IComparable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable <(Of <(<' IChannelDefinition >)>)>.)
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
 | ConversionFactor | Gets or sets the conversion factor of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | Equals(T) | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable <(Of <(<' IChannelDefinition >)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | Index | Gets or sets the index of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | Label | Gets or sets the label of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | LabelImage | Gets the binary image of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | MaximumLabelLength | Gets the maximum length of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | Offset | Gets or sets the offset of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | Parent | Gets the IConfigurationCell parent of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | ScalePerBit | Gets the scale/bit value of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | ScalingValue | Gets or sets the integer scaling value of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)


IDigitalValue Interface

IDigitalValue Interface
Namespaces ► TVA.PhasorProtocols ► IDigitalValue
Represents a protocol independent interface representation of a digital value.
Declaration Syntax
C# Visual Basic Visual C++
public interface IDigitalValue : IChannelValue<IDigitalDefinition>,
    IChannel, ISupportBinaryImage, ISerializable
Public Interface IDigitalValue _
    Inherits IChannelValue(Of IDigitalDefinition), IChannel, ISupportBinaryImage,  _
    ISerializable
public interface class IDigitalValue : IChannelValue<IDigitalDefinition^>,
    IChannel, ISupportBinaryImage, ISerializable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | CompositeValueCount | Gets total number of composite values that this IChannelValue<(Of <(<'T>)>)> provides. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this IChannelValue<(Of <(<'T>)>)> typically derived from DataFormat. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Definition | Gets the IChannelDefinition associated with this IChannelValue<(Of <(<'T>)>)>. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this IChannelValue<(Of <(<'T>)>)>. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of IChannelValue<(Of <(<'T>)>)> have been assigned a value. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Label | Gets text based label of this IChannelValue<(Of <(<'T>)>)> typically derived from Label. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this IChannelValue<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Parent | Gets the IDataCell parent of this IChannelValue<(Of <(<'T>)>)>. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
 | Value | Gets or sets the 16-bit integer value (composed of digital bits) that represents this IDigitalValue.


Value Property

Value Property
Namespaces ► TVA.PhasorProtocols ► IDigitalValue ► Value
Gets or sets the 16-bit integer value (composed of digital bits) that represents this IDigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
ushort Value { get; set; }
Property Value As UShort
    Get
    Set
property unsigned short Value {
    unsigned short get ();
    void set (unsigned short value);
}


IFrameParser Interface

IFrameParser Interface
Namespaces ► TVA.PhasorProtocols ► IFrameParser
Represents a protocol independent representation of a frame parser.
Declaration Syntax
C# Visual Basic Visual C++
public interface IFrameParser : IProvideStatus,
    IDisposable
Public Interface IFrameParser _
    Inherits IProvideStatus, IDisposable
public interface class IFrameParser : IProvideStatus,
    IDisposable
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed.
 | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
 | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing.
 | Dispose()()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
 | Enabled | Gets or sets a boolean value that indicates whether the data parser is currently enabled.
 | ExecuteParseOnSeparateThread | Gets or sets a flag that allows frame parsing to be executed on a separate thread (i.e., other than communications thread).
 | Name()()()() | (Inherited from IProvideStatus.)
 | ParsingException | Occurs when an Exception is encountered while attempting to parse data.
 | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any.
 | ReceivedCommandFrame | Occurs when a ICommandFrame has been received.
 | ReceivedConfigurationFrame | Occurs when a IConfigurationFrame has been received.
 | ReceivedDataFrame | Occurs when a IDataFrame has been received.
 | ReceivedFrameBufferImage | Occurs when a frame buffer image has been received.
 | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received.
 | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received.
 | Start()()()() | Start the streaming data parser.
 | Status()()()() | (Inherited from IProvideStatus.)
 | Stop()()()() | Stops the streaming data parser.
 | Write(array<Byte>[]()[][], Int32, Int32) | Writes a sequence of bytes onto the IBinaryImageParser stream for parsing.
Remarks
This interface allows protocol specific frame parsers to be handled abstractly by the MultiProtocolFrameParser.


ConfigurationChanged Event

ConfigurationChanged Event
Namespaces ► TVA.PhasorProtocols ► IFrameParser ► ConfigurationChanged
Occurs when a device sends a notification that its configuration has changed.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler ConfigurationChanged
Event ConfigurationChanged As EventHandler
 event EventHandler^ ConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols ► IFrameParser ► ConfigurationFrame
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
Declaration Syntax
C# Visual Basic Visual C++
IConfigurationFrame ConfigurationFrame { get; set; }
Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get ();
    void set (IConfigurationFrame^ value);
}
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.


ConnectionParameters Property

ConnectionParameters Property
Namespaces ► TVA.PhasorProtocols ► IFrameParser ► ConnectionParameters
Gets or sets any connection specific IConnectionParameters that may be needed for parsing.
Declaration Syntax
C# Visual Basic Visual C++
IConnectionParameters ConnectionParameters { get; set; }
Property ConnectionParameters As IConnectionParameters
    Get
    Set
property IConnectionParameters^ ConnectionParameters {
    IConnectionParameters^ get ();
    void set (IConnectionParameters^ value);
}


Enabled Property

Enabled Property
Namespaces ► TVA.PhasorProtocols ► IFrameParser ► Enabled
Gets or sets a boolean value that indicates whether the data parser is currently enabled.
Declaration Syntax
C# Visual Basic Visual C++
bool Enabled { get; set; }
Property Enabled As Boolean
    Get
    Set
property bool Enabled {
    bool get ();
    void set (bool value);
}


ExecuteParseOnSeparateThread Property

ExecuteParseOnSeparateThread Property
Namespaces ► TVA.PhasorProtocols ► IFrameParser ► ExecuteParseOnSeparateThread
Gets or sets a flag that allows frame parsing to be executed on a separate thread (i.e., other than communications thread).
Declaration Syntax
C# Visual Basic Visual C++
bool ExecuteParseOnSeparateThread { get; set; }
Property ExecuteParseOnSeparateThread As Boolean
    Get
    Set
property bool ExecuteParseOnSeparateThread {
    bool get ();
    void set (bool value);
}
Remarks
This is typically only needed when data frames are very large. This change will happen dynamically, even if a connection is active.


ParsingException Event

ParsingException Event
Namespaces ► TVA.PhasorProtocols ► IFrameParser ► ParsingException
Occurs when an Exception is encountered while attempting to parse data.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<EventArgs<Exception>> ParsingException
Event ParsingException As EventHandler(Of EventArgs(Of Exception))
 event EventHandler<EventArgs<Exception^>^>^ ParsingException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}
Remarks
Argument()()()() is the Exception encountered while parsing data.


QueuedBuffers Property

QueuedBuffers Property
Namespaces ► TVA.PhasorProtocols ► IFrameParser ► QueuedBuffers
Gets the total number of buffers that are currently queued for processing, if any.
Declaration Syntax
C# Visual Basic Visual C++
int QueuedBuffers { get; }
ReadOnly Property QueuedBuffers As Integer
    Get
property int QueuedBuffers {
    int get ();
}


ReceivedCommandFrame Event

ReceivedCommandFrame Event
Namespaces ► TVA.PhasorProtocols ► IFrameParser ► ReceivedCommandFrame
Occurs when a ICommandFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<EventArgs<ICommandFrame>> ReceivedCommandFrame
Event ReceivedCommandFrame As EventHandler(Of EventArgs(Of ICommandFrame))
 event EventHandler<EventArgs<ICommandFrame^>^>^ ReceivedCommandFrame {
    void add (EventHandler<EventArgs<ICommandFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ICommandFrame^>^>^ value);
}
Remarks
Argument()()()() is the ICommandFrame that was received.


ReceivedConfigurationFrame Event

ReceivedConfigurationFrame Event
Namespaces ► TVA.PhasorProtocols ► IFrameParser ► ReceivedConfigurationFrame
Occurs when a IConfigurationFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<EventArgs<IConfigurationFrame>> ReceivedConfigurationFrame
Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of IConfigurationFrame))
 event EventHandler<EventArgs<IConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<IConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IConfigurationFrame^>^>^ value);
}
Remarks
Argument()()()() is the IConfigurationFrame that was received.


ReceivedDataFrame Event

ReceivedDataFrame Event
Namespaces ► TVA.PhasorProtocols ► IFrameParser ► ReceivedDataFrame
Occurs when a IDataFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<EventArgs<IDataFrame>> ReceivedDataFrame
Event ReceivedDataFrame As EventHandler(Of EventArgs(Of IDataFrame))
 event EventHandler<EventArgs<IDataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<IDataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IDataFrame^>^>^ value);
}
Remarks
Argument()()()() is the IDataFrame that was received.


ReceivedFrameBufferImage Event

ReceivedFrameBufferImage Event
Namespaces ► TVA.PhasorProtocols ► IFrameParser ► ReceivedFrameBufferImage
Occurs when a frame buffer image has been received.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<EventArgs<FundamentalFrameType, byte[], int, int>> ReceivedFrameBufferImage
Event ReceivedFrameBufferImage As EventHandler(Of EventArgs(Of FundamentalFrameType, Byte(), Integer, Integer))
 event EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ ReceivedFrameBufferImage {
    void add (EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ value);
    void remove (EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ value);
}
Remarks
Argument1()()()() is the FundamentalFrameType of the frame buffer image that was received.
Argument2()()()() is the buffer that contains the frame image that was received.
Argument3()()()() is the offset into the buffer that contains the frame image that was received.
Argument4()()()() is the length of data in the buffer that contains the frame image that was received..


ReceivedHeaderFrame Event

ReceivedHeaderFrame Event
Namespaces ► TVA.PhasorProtocols ► IFrameParser ► ReceivedHeaderFrame
Occurs when a IHeaderFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<EventArgs<IHeaderFrame>> ReceivedHeaderFrame
Event ReceivedHeaderFrame As EventHandler(Of EventArgs(Of IHeaderFrame))
 event EventHandler<EventArgs<IHeaderFrame^>^>^ ReceivedHeaderFrame {
    void add (EventHandler<EventArgs<IHeaderFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IHeaderFrame^>^>^ value);
}
Remarks
Argument()()()() is the IHeaderFrame that was received.


ReceivedUndeterminedFrame Event

ReceivedUndeterminedFrame Event
Namespaces ► TVA.PhasorProtocols ► IFrameParser ► ReceivedUndeterminedFrame
Occurs when an undetermined IChannelFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<EventArgs<IChannelFrame>> ReceivedUndeterminedFrame
Event ReceivedUndeterminedFrame As EventHandler(Of EventArgs(Of IChannelFrame))
 event EventHandler<EventArgs<IChannelFrame^>^>^ ReceivedUndeterminedFrame {
    void add (EventHandler<EventArgs<IChannelFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IChannelFrame^>^>^ value);
}
Remarks
Argument()()()() is the undetermined IChannelFrame that was received.


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols ► IFrameParser ► Start()()()()
Start the streaming data parser.
Declaration Syntax
C# Visual Basic Visual C++
void Start()
Sub Start
void Start()


Stop Method

Stop Method
Namespaces ► TVA.PhasorProtocols ► IFrameParser ► Stop()()()()
Stops the streaming data parser.
Declaration Syntax
C# Visual Basic Visual C++
void Stop()
Sub Stop
void Stop()


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
Namespaces ► TVA.PhasorProtocols ► IFrameParser ► Write(array<Byte>[]()[][], Int32, Int32)
Writes a sequence of bytes onto the IBinaryImageParser stream for parsing.
Declaration Syntax
C# Visual Basic Visual C++
void Write(
    byte[] buffer,
    int offset,
    int count
)
Sub Write ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
)
Parameters
buffer (array< Byte >[]()[][])
An array of bytes. This method copies count bytes from buffer to the current stream.
offset (Int32)
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count (Int32)
The number of bytes to be written to the current stream.


IFrequencyDefinition Interface

IFrequencyDefinition Interface
Namespaces ► TVA.PhasorProtocols ► IFrequencyDefinition
Represents a protocol independent interface representation of a definition of a IFrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public interface IFrequencyDefinition : IChannelDefinition,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition>,
    IComparable<IChannelDefinition>, IComparable
Public Interface IFrequencyDefinition _
    Inherits IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,  _
    IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition), IComparable
public interface class IFrequencyDefinition : IChannelDefinition,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition^>,
    IComparable<IChannelDefinition^>, IComparable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable <(Of <(<' IChannelDefinition >)>)>.)
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
 | ConversionFactor | Gets or sets the conversion factor of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | DfDtOffset | Gets or sets the df/dt offset of this IFrequencyDefinition.
 | DfDtScalingValue | Gets or sets the df/dt scaling value of this IFrequencyDefinition.
 | Equals(T) | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable <(Of <(<' IChannelDefinition >)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | Index | Gets or sets the index of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | Label | Gets or sets the label of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | LabelImage | Gets the binary image of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | MaximumLabelLength | Gets the maximum length of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | NominalFrequency | Gets the nominal LineFrequency of this IFrequencyDefinition.
 | Offset | Gets or sets the offset of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | Parent | Gets the IConfigurationCell parent of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | ScalePerBit | Gets the scale/bit value of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | ScalingValue | Gets or sets the integer scaling value of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)


DfDtOffset Property

DfDtOffset Property
Namespaces ► TVA.PhasorProtocols ► IFrequencyDefinition ► DfDtOffset
Gets or sets the df/dt offset of this IFrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
double DfDtOffset { get; set; }
Property DfDtOffset As Double
    Get
    Set
property double DfDtOffset {
    double get ();
    void set (double value);
}


DfDtScalingValue Property

DfDtScalingValue Property
Namespaces ► TVA.PhasorProtocols ► IFrequencyDefinition ► DfDtScalingValue
Gets or sets the df/dt scaling value of this IFrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
uint DfDtScalingValue { get; set; }
Property DfDtScalingValue As UInteger
    Get
    Set
property unsigned int DfDtScalingValue {
    unsigned int get ();
    void set (unsigned int value);
}


NominalFrequency Property

NominalFrequency Property
Namespaces ► TVA.PhasorProtocols ► IFrequencyDefinition ► NominalFrequency
Gets the nominal LineFrequency of this IFrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
LineFrequency NominalFrequency { get; }
ReadOnly Property NominalFrequency As LineFrequency
    Get
property LineFrequency NominalFrequency {
    LineFrequency get ();
}


IFrequencyValue Interface

IFrequencyValue Interface
Namespaces ► TVA.PhasorProtocols ► IFrequencyValue
Represents a protocol independent interface of a frequency value.
Declaration Syntax
C# Visual Basic Visual C++
public interface IFrequencyValue : IChannelValue<IFrequencyDefinition>,
    IChannel, ISupportBinaryImage, ISerializable
Public Interface IFrequencyValue _
    Inherits IChannelValue(Of IFrequencyDefinition), IChannel, ISupportBinaryImage,  _
    ISerializable
public interface class IFrequencyValue : IChannelValue<IFrequencyDefinition^>,
    IChannel, ISupportBinaryImage, ISerializable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | CompositeValueCount | Gets total number of composite values that this IChannelValue<(Of <(<'T>)>)> provides. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this IChannelValue<(Of <(<'T>)>)> typically derived from DataFormat. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Definition | Gets the IChannelDefinition associated with this IChannelValue<(Of <(<'T>)>)>. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | DfDt | Gets or sets the floating point value that represents the change in this IFrequencyValue over time.
 | Frequency | Gets or sets the floating point value that represents this IFrequencyValue.
 | GetCompositeValue(Int32) | Gets the specified composite value of this IChannelValue<(Of <(<'T>)>)>. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of IChannelValue<(Of <(<'T>)>)> have been assigned a value. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Label | Gets text based label of this IChannelValue<(Of <(<'T>)>)> typically derived from Label. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this IChannelValue<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Parent | Gets the IDataCell parent of this IChannelValue<(Of <(<'T>)>)>. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
 | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this IFrequencyValue over time.
 | UnscaledFrequency | Gets or sets the unscaled integer representation of this IFrequencyValue.


DfDt Property

DfDt Property
Namespaces ► TVA.PhasorProtocols ► IFrequencyValue ► DfDt
Gets or sets the floating point value that represents the change in this IFrequencyValue over time.
Declaration Syntax
C# Visual Basic Visual C++
double DfDt { get; set; }
Property DfDt As Double
    Get
    Set
property double DfDt {
    double get ();
    void set (double value);
}


Frequency Property

Frequency Property
Namespaces ► TVA.PhasorProtocols ► IFrequencyValue ► Frequency
Gets or sets the floating point value that represents this IFrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
double Frequency { get; set; }
Property Frequency As Double
    Get
    Set
property double Frequency {
    double get ();
    void set (double value);
}


UnscaledDfDt Property

UnscaledDfDt Property
Namespaces ► TVA.PhasorProtocols ► IFrequencyValue ► UnscaledDfDt
Gets or sets the unscaled integer representation of the change in this IFrequencyValue over time.
Declaration Syntax
C# Visual Basic Visual C++
int UnscaledDfDt { get; set; }
Property UnscaledDfDt As Integer
    Get
    Set
property int UnscaledDfDt {
    int get ();
    void set (int value);
}


UnscaledFrequency Property

UnscaledFrequency Property
Namespaces ► TVA.PhasorProtocols ► IFrequencyValue ► UnscaledFrequency
Gets or sets the unscaled integer representation of this IFrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
int UnscaledFrequency { get; set; }
Property UnscaledFrequency As Integer
    Get
    Set
property int UnscaledFrequency {
    int get ();
    void set (int value);
}


IHeaderCell Interface

IHeaderCell Interface
Namespaces ► TVA.PhasorProtocols ► IHeaderCell
Represents a protocol independent interface representation of any kind of IHeaderFrame cell.
Declaration Syntax
C# Visual Basic Visual C++
public interface IHeaderCell : IChannelCell,
    IChannel, ISupportBinaryImage, ISerializable
Public Interface IHeaderCell _
    Inherits IChannelCell, IChannel, ISupportBinaryImage, ISerializable
public interface class IHeaderCell : IChannelCell,
    IChannel, ISupportBinaryImage, ISerializable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | Character | Gets or sets ASCII character as a Byte that represents this IHeaderCell.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | IDCode | Gets the numeric ID code for this IChannelCell. (Inherited from IChannelCell.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | Parent | Gets a reference to the parent IHeaderFrame for this IHeaderCell.
 | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell. (Inherited from IChannelCell.)
 | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from IChannelCell.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)


Character Property

Character Property
Namespaces ► TVA.PhasorProtocols ► IHeaderCell ► Character
Gets or sets ASCII character as a Byte that represents this IHeaderCell.
Declaration Syntax
C# Visual Basic Visual C++
byte Character { get; set; }
Property Character As Byte
    Get
    Set
property unsigned char Character {
    unsigned char get ();
    void set (unsigned char value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► IHeaderCell ► Parent
Gets a reference to the parent IHeaderFrame for this IHeaderCell.
Declaration Syntax
C# Visual Basic Visual C++
IHeaderFrame Parent { get; set; }
Property Parent As IHeaderFrame
    Get
    Set
property IHeaderFrame^ Parent {
    IHeaderFrame^ get ();
    void set (IHeaderFrame^ value);
}


IHeaderFrame Interface

IHeaderFrame Interface
Namespaces ► TVA.PhasorProtocols ► IHeaderFrame
Represents a protocol independent interface representation of any kind of header frame that contains a collection of IHeaderCell objects.
Declaration Syntax
C# Visual Basic Visual C++
public interface IHeaderFrame : IChannelFrame,
    IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame>,
    IComparable<IFrame>, IComparable, ISerializable
Public Interface IHeaderFrame _
    Inherits IChannelFrame, IChannel, ISupportBinaryImage, IFrame,  _
    IEquatable(Of IFrame), IComparable(Of IFrame), IComparable,  _
    ISerializable
public interface class IHeaderFrame : IChannelFrame,
    IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame^>,
    IComparable<IFrame^>, IComparable, ISerializable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | Cells | Gets reference to the HeaderCellCollection for this IHeaderFrame.
 | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
 | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable <(Of <(<'IFrame>)>)>.)
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(T) | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable <(Of <(<'IFrame>)>)>.)
 | FrameType | Gets the FundamentalFrameType for this IChannelFrame. (Inherited from IChannelFrame.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | HeaderData | Gets or sets header data for this IHeaderFrame.
 | IDCode | Gets or sets the ID code of this IChannelFrame. (Inherited from IChannelFrame.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | LastSortedMeasurement()()()() | (Inherited from IFrame.)
 | Measurements()()()() | (Inherited from IFrame.)
 | Published()()()() | (Inherited from IFrame.)
 | PublishedTimestamp()()()() | (Inherited from IFrame.)
 | ReceivedTimestamp()()()() | (Inherited from IFrame.)
 | SortedMeasurements()()()() | (Inherited from IFrame.)
 | State | Gets or sets the parsing state for the this IHeaderFrame.
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
 | Timestamp()()()() | (Inherited from IFrame.)
 | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame. (Inherited from IChannelFrame.)


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols ► IHeaderFrame ► Cells
Gets reference to the HeaderCellCollection for this IHeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
HeaderCellCollection Cells { get; }
ReadOnly Property Cells As HeaderCellCollection
    Get
property HeaderCellCollection^ Cells {
    HeaderCellCollection^ get ();
}


HeaderData Property

HeaderData Property
Namespaces ► TVA.PhasorProtocols ► IHeaderFrame ► HeaderData
Gets or sets header data for this IHeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
string HeaderData { get; set; }
Property HeaderData As String
    Get
    Set
property String^ HeaderData {
    String^ get ();
    void set (String^ value);
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► IHeaderFrame ► State
Gets or sets the parsing state for the this IHeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
IHeaderFrameParsingState State { get; set; }
Property State As IHeaderFrameParsingState
    Get
    Set
property IHeaderFrameParsingState^ State {
    IHeaderFrameParsingState^ get ();
    void set (IHeaderFrameParsingState^ value);
}


IHeaderFrameParsingState Interface

IHeaderFrameParsingState Interface
Namespaces ► TVA.PhasorProtocols ► IHeaderFrameParsingState
Represents a protocol independent interface representation of the parsing state of a IHeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
public interface IHeaderFrameParsingState : IChannelFrameParsingState<IHeaderCell>,
    IChannelParsingState
Public Interface IHeaderFrameParsingState _
    Inherits IChannelFrameParsingState(Of IHeaderCell), IChannelParsingState
public interface class IHeaderFrameParsingState : IChannelFrameParsingState<IHeaderCell^>,
    IChannelParsingState
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from IChannelFrameParsingState<(Of <(<'T>)>)>.)
 | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from IChannelFrameParsingState<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)


IPhasorDefinition Interface

IPhasorDefinition Interface
Namespaces ► TVA.PhasorProtocols ► IPhasorDefinition
Represents a protocol independent interface representation of a definition of a IPhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public interface IPhasorDefinition : IChannelDefinition,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition>,
    IComparable<IChannelDefinition>, IComparable
Public Interface IPhasorDefinition _
    Inherits IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,  _
    IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition), IComparable
public interface class IPhasorDefinition : IChannelDefinition,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition^>,
    IComparable<IChannelDefinition^>, IComparable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable <(Of <(<' IChannelDefinition >)>)>.)
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
 | ConversionFactor | Gets or sets the conversion factor of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | CoordinateFormat | Gets or sets the CoordinateFormat of this IPhasorDefinition.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | Equals(T) | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable <(Of <(<' IChannelDefinition >)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | Index | Gets or sets the index of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | Label | Gets or sets the label of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | LabelImage | Gets the binary image of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | MaximumLabelLength | Gets the maximum length of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | Offset | Gets or sets the offset of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | Parent | Gets the IConfigurationCell parent of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | PhasorType | Gets or sets the PhasorType of this IPhasorDefinition.
 | ScalePerBit | Gets the scale/bit value of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | ScalingValue | Gets or sets the integer scaling value of this IChannelDefinition. (Inherited from IChannelDefinition.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
 | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any).


CoordinateFormat Property

CoordinateFormat Property
Namespaces ► TVA.PhasorProtocols ► IPhasorDefinition ► CoordinateFormat
Gets or sets the CoordinateFormat of this IPhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
CoordinateFormat CoordinateFormat { get; }
ReadOnly Property CoordinateFormat As CoordinateFormat
    Get
property CoordinateFormat CoordinateFormat {
    CoordinateFormat get ();
}


PhasorType Property

PhasorType Property
Namespaces ► TVA.PhasorProtocols ► IPhasorDefinition ► PhasorType
Gets or sets the PhasorType of this IPhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
PhasorType PhasorType { get; set; }
Property PhasorType As PhasorType
    Get
    Set
property PhasorType PhasorType {
    PhasorType get ();
    void set (PhasorType value);
}


VoltageReference Property

VoltageReference Property
Namespaces ► TVA.PhasorProtocols ► IPhasorDefinition ► VoltageReference
Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any).
Declaration Syntax
C# Visual Basic Visual C++
IPhasorDefinition VoltageReference { get; set; }
Property VoltageReference As IPhasorDefinition
    Get
    Set
property IPhasorDefinition^ VoltageReference {
    IPhasorDefinition^ get ();
    void set (IPhasorDefinition^ value);
}
Remarks
This only applies to current phasors.


IPhasorValue Interface

IPhasorValue Interface
Namespaces ► TVA.PhasorProtocols ► IPhasorValue
Represents a protocol independent interface representation of a phasor value.
Declaration Syntax
C# Visual Basic Visual C++
public interface IPhasorValue : IChannelValue<IPhasorDefinition>,
    IChannel, ISupportBinaryImage, ISerializable
Public Interface IPhasorValue _
    Inherits IChannelValue(Of IPhasorDefinition), IChannel, ISupportBinaryImage,  _
    ISerializable
public interface class IPhasorValue : IChannelValue<IPhasorDefinition^>,
    IChannel, ISupportBinaryImage, ISerializable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Angle | Gets or sets the Angle value (a.k.a., the argument) of this IPhasorValue, in radians.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from IChannel.)
 | BinaryImage()()()() | (Inherited from ISupportBinaryImage.)
 | BinaryLength()()()() | (Inherited from ISupportBinaryImage.)
 | CompositeValueCount | Gets total number of composite values that this IChannelValue<(Of <(<'T>)>)> provides. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | CoordinateFormat | Gets the CoordinateFormat of this IPhasorValue.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this IChannelValue<(Of <(<'T>)>)> typically derived from DataFormat. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Definition | Gets the IChannelDefinition associated with this IChannelValue<(Of <(<'T>)>)>. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this IChannelValue<(Of <(<'T>)>)>. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
 | Imaginary | Gets or sets the imaginary floating point value of this IPhasorValue.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from ISupportBinaryImage.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of IChannelValue<(Of <(<'T>)>)> have been assigned a value. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Label | Gets text based label of this IChannelValue<(Of <(<'T>)>)> typically derived from Label. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this IPhasorValue.
 | Measurements | Gets the composite values of this IChannelValue<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Parent | Gets the IDataCell parent of this IChannelValue<(Of <(<'T>)>)>. (Inherited from IChannelValue<(Of <(<'T>)>)>.)
 | Real | Gets or sets the real floating point value of this IPhasorValue.
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
 | Type | Gets the PhasorType of this IPhasorValue.
 | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this IPhasorValue.
 | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this IPhasorValue.


Angle Property

Angle Property
Namespaces ► TVA.PhasorProtocols ► IPhasorValue ► Angle
Gets or sets the Angle value (a.k.a., the argument) of this IPhasorValue, in radians.
Declaration Syntax
C# Visual Basic Visual C++
Angle Angle { get; set; }
Property Angle As Angle
    Get
    Set
property Angle Angle {
    Angle get ();
    void set (Angle value);
}


CoordinateFormat Property

CoordinateFormat Property
Namespaces ► TVA.PhasorProtocols ► IPhasorValue ► CoordinateFormat
Gets the CoordinateFormat of this IPhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
CoordinateFormat CoordinateFormat { get; }
ReadOnly Property CoordinateFormat As CoordinateFormat
    Get
property CoordinateFormat CoordinateFormat {
    CoordinateFormat get ();
}


Imaginary Property

Imaginary Property
Namespaces ► TVA.PhasorProtocols ► IPhasorValue ► Imaginary
Gets or sets the imaginary floating point value of this IPhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
double Imaginary { get; set; }
Property Imaginary As Double
    Get
    Set
property double Imaginary {
    double get ();
    void set (double value);
}


Magnitude Property

Magnitude Property
Namespaces ► TVA.PhasorProtocols ► IPhasorValue ► Magnitude
Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this IPhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
double Magnitude { get; set; }
Property Magnitude As Double
    Get
    Set
property double Magnitude {
    double get ();
    void set (double value);
}


Real Property

Real Property
Namespaces ► TVA.PhasorProtocols ► IPhasorValue ► Real
Gets or sets the real floating point value of this IPhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
double Real { get; set; }
Property Real As Double
    Get
    Set
property double Real {
    double get ();
    void set (double value);
}


Type Property

Type Property
Namespaces ► TVA.PhasorProtocols ► IPhasorValue ► Type
Gets the PhasorType of this IPhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
PhasorType Type { get; }
ReadOnly Property Type As PhasorType
    Get
property PhasorType Type {
    PhasorType get ();
}


UnscaledImaginary Property

UnscaledImaginary Property
Namespaces ► TVA.PhasorProtocols ► IPhasorValue ► UnscaledImaginary
Gets or sets the unscaled integer representation of the imaginary value of this IPhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
int UnscaledImaginary { get; set; }
Property UnscaledImaginary As Integer
    Get
    Set
property int UnscaledImaginary {
    int get ();
    void set (int value);
}


UnscaledReal Property

UnscaledReal Property
Namespaces ► TVA.PhasorProtocols ► IPhasorValue ► UnscaledReal
Gets or sets the unscaled integer representation of the real value of this IPhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
int UnscaledReal { get; set; }
Property UnscaledReal As Integer
    Get
    Set
property int UnscaledReal {
    int get ();
    void set (int value);
}


LineFrequency Enumeration

LineFrequency Enumeration
Namespaces ► TVA.PhasorProtocols ► LineFrequency
Nominal line frequencies enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum LineFrequency
<SerializableAttribute> _
Public Enumeration LineFrequency
[SerializableAttribute]
public enum class LineFrequency
Members
Member | Description
Hz50 | 50Hz nominal frequency.
Hz60 | 60Hz nominal frequency.


MultiProtocolFrameParser Class

MultiProtocolFrameParser Class
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser
Protocol independent frame parser.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class MultiProtocolFrameParser : IFrameParser,
    IProvideStatus, IDisposable
Public NotInheritable Class MultiProtocolFrameParser _
    Implements IFrameParser, IProvideStatus, IDisposable
public ref class MultiProtocolFrameParser sealed : IFrameParser,
    IProvideStatus, IDisposable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiProtocolFrameParser()()()() | Creates a new MultiProtocolFrameParser using the default settings.
 | AllowedParsingExceptions | Gets or sets number of parsing exceptions allowed during ParsingExceptionWindow before connection is reset.
 | AutoRepeatCapturedPlayback | Gets or sets a flag that determines if a file used for replaying data should be restarted at the beginning once it has been completed.
 | AutoStartDataParsingSequence | Gets or sets flag to automatically send the ConfigFrame2 and EnableRealTimeData command frames used to start a typical data parsing sequence.
 | BitRate | Gets the calculated bit rate (i.e., bits per second (bps)) based on data received from device connection.
 | BufferSize | Gets or sets the size of the buffer used by the MultiProtocolFrameParser for sending and receiving data from a device.
 | ByteRate | Gets the calculated byte rate (i.e., bytes per second) based on data received from device connection.
 | CalculatedFrameRate | Gets the calculated frame rate (i.e., frames per second) based on data received from device connection.
 | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed.
 | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
 | ConfiguredFrameRate | Gets the configured frame rate as reported by the connected device.
 | ConnectionAttempt | Occurs when MultiProtocolFrameParser is attempting connection to a device.
 | ConnectionEstablished | Occurs when MultiProtocolFrameParser has established a connection to a device.
 | ConnectionException | Occurs when an Exception is encountered during connection attempt to a device.
 | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be applicable for the current PhasorProtocol.
 | ConnectionString | Gets or sets the key/value pair based connection information required by the MultiProtocolFrameParser to connect to a device.
 | ConnectionTerminated | Occurs when device connection has been terminated.
 | ConnectionTime | Gets total time connection has been active.
 | ConnectionType | Gets the connection type (Active, Passive or Hybrid) based on defined channels and transport selections.
 | DataChannelIsServerBased | Gets a boolean value that determines if data channel is defined as a server based connection.
 | DefaultAllowedParsingExceptions | Specfies the default value for the AllowedParsingExceptions property.
 | DefaultAutoStartDataParsingSequence | Specifies the default value for the AutoStartDataParsingSequence property.
 | DefaultBufferSize | Specifies the default value for the BufferSize property.
 | DefaultDefinedFrameRate | Specifies the default value for the DefinedFrameRate property.
 | DefaultMaximumConnectionAttempts | Specifies the default value for the MaximumConnectionAttempts property.
 | DefaultParsingExceptionWindow | Specifies the default value for the ParsingExceptionWindow property.
 | DefinedFrameRate | Gets or sets desired frame rate to use for maintaining captured frame replay timing.
 | DeviceID | Gets or sets the device identification code often needed to establish a connection.
 | DeviceSupportsCommands | Gets or sets flag that determines if a device supports commands.
 | Dispose()()()() | Releases all the resources used by the MultiProtocolFrameParser object.
 | Enabled | Gets or sets a boolean value that indicates whether the MultiProtocolFrameParser is currently enabled.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExceededParsingExceptionThreshold | Occurs when number of parsing exceptions exceed AllowedParsingExceptions during ParsingExceptionWindow.
 | ExecuteParseOnSeparateThread | Gets or sets a flag that allows frame parsing to be executed on a separate thread (i.e., other than communications thread).
 | Finalize()()()() | Releases the unmanaged resources before the MultiProtocolFrameParser object is reclaimed by GC. (Overrides Object.Finalize()()()().)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InjectSimulatedTimestamp | Gets or sets flag indicating whether or not to inject local system time into parsed data frames.
 | IsConnected | Gets a flag that determines if the currently selected TransportProtocol is connected.
 | IsIEEEProtocol | Gets a flag that determines if the currently selected PhasorProtocol is an IEEE standard protocol.
 | MaximumConnectionAttempts | Gets or sets the maximum number of times the MultiProtocolFrameParser will attempt to connect to a device.
 | MegaBitRate | Gets the calculated megabits per second (Mbps) rate based on data received from device connection.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets a descriptive name for a device connection that includes SourceName, if provided.
 | ParsingException | Occurs when an Exception is encountered while parsing the data stream.
 | ParsingExceptionWindow | Gets or sets time duration, in Ticks, to monitor parsing exceptions.
 | PhasorProtocol | Gets or sets PhasorProtocol to use with this MultiProtocolFrameParser.
 | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any.
 | ReceivedCommandFrame | Occurs when a ICommandFrame has been received.
 | ReceivedConfigurationFrame | Occurs when a IConfigurationFrame has been received.
 | ReceivedDataFrame | Occurs when a IDataFrame has been received.
 | ReceivedFrameBufferImage | Occurs when a frame buffer image has been received.
 | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received.
 | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received.
 | SendDeviceCommand(DeviceCommand) | Sends the specified DeviceCommand to the remote device.
 | SentCommandFrame | Occurs when a ICommandFrame is sent to a device.
 | ServerStarted | Occurs when the MultiProtocolFrameParser is setup as a listening connection and server connection has been started.
 | ServerStopped | Occurs when the MultiProtocolFrameParser is setup as a listening connection and server connection has been stopped.
 | SkipDisableRealTimeData | Gets or sets flag to skip automatic disabling of the real-time data stream on shutdown or startup.
 | SourceName | Gets or sets a descriptive name for a device connection.
 | Start()()()() | Starts the MultiProtocolFrameParser.
 | Status | Gets current descriptive status of the MultiProtocolFrameParser.
 | Stop()()()() | Stops the MultiProtocolFrameParser.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalBytesReceived | Gets total number of bytes that have been received from a device so far.
 | TotalCrcExceptions | Gets total number of CRC exceptions encountered from device so far.
 | TotalFramesReceived | Gets total number of frames that have been received from a device so far.
 | TotalMissingFrames | Gets total number of frames that were missing from device so far.
 | TransportProtocol | Gets or sets TransportProtocol to use with this MultiProtocolFrameParser.
 | UseHighResolutionInputTimer | Gets or sets flag that determines if a high-resolution precision timer should be used for file based input.
 | Write(array<Byte>[]()[][], Int32, Int32) | Writes data directly to the frame parsing engine buffer.
Remarks
This class takes all protocol frame parsing implementations and reduces them to a single simple-to-use class exposing all data through abstract interfaces (e.g., IConfigurationFrame, IDataFrame, etc.) - this way new protocol implementations can be added without adversely affecting consuming code. Additionally, this class implements a variety of transport options (e.g., TCP, UDP, Serial, etc.) and hides the complexities of this connectivity and internally pushes all data received from the selected transport protocol to the selected phasor parsing protocol.
Inheritance Hierarchy
Object
MultiProtocolFrameParser


MultiProtocolFrameParser Constructor

MultiProtocolFrameParser Constructor
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► MultiProtocolFrameParser()()()()
Creates a new MultiProtocolFrameParser using the default settings.
Declaration Syntax
C# Visual Basic Visual C++
public MultiProtocolFrameParser()
Public Sub New
public:
MultiProtocolFrameParser()


AllowedParsingExceptions Property

AllowedParsingExceptions Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► AllowedParsingExceptions
Gets or sets number of parsing exceptions allowed during ParsingExceptionWindow before connection is reset.
Declaration Syntax
C# Visual Basic Visual C++
public int AllowedParsingExceptions { get; set; }
Public Property AllowedParsingExceptions As Integer
    Get
    Set
public:
property int AllowedParsingExceptions {
    int get ();
    void set (int value);
}


AutoRepeatCapturedPlayback Property

AutoRepeatCapturedPlayback Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► AutoRepeatCapturedPlayback
Gets or sets a flag that determines if a file used for replaying data should be restarted at the beginning once it has been completed.
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoRepeatCapturedPlayback { get; set; }
Public Property AutoRepeatCapturedPlayback As Boolean
    Get
    Set
public:
property bool AutoRepeatCapturedPlayback {
    bool get ();
    void set (bool value);
}
Remarks
This is only applicable when connection is made to a file for replay purposes.


AutoStartDataParsingSequence Property

AutoStartDataParsingSequence Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► AutoStartDataParsingSequence
Gets or sets flag to automatically send the ConfigFrame2 and EnableRealTimeData command frames used to start a typical data parsing sequence.
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoStartDataParsingSequence { get; set; }
Public Property AutoStartDataParsingSequence As Boolean
    Get
    Set
public:
property bool AutoStartDataParsingSequence {
    bool get ();
    void set (bool value);
}
Remarks
For devices that support IEEE commands, setting this property to true will automatically start the data parsing sequence.


BitRate Property

BitRate Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► BitRate
Gets the calculated bit rate (i.e., bits per second (bps)) based on data received from device connection.
Declaration Syntax
C# Visual Basic Visual C++
public double BitRate { get; }
Public ReadOnly Property BitRate As Double
    Get
public:
property double BitRate {
    double get ();
}


BufferSize Property

BufferSize Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► BufferSize
Gets or sets the size of the buffer used by the MultiProtocolFrameParser for sending and receiving data from a device.
Declaration Syntax
C# Visual Basic Visual C++
public int BufferSize { get; set; }
Public Property BufferSize As Integer
    Get
    Set
public:
property int BufferSize {
    int get ();
    void set (int value);
}
Exceptions
Exception | Condition
ArgumentException | The value specified is either zero or negative.


ByteRate Property

ByteRate Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ByteRate
Gets the calculated byte rate (i.e., bytes per second) based on data received from device connection.
Declaration Syntax
C# Visual Basic Visual C++
public double ByteRate { get; }
Public ReadOnly Property ByteRate As Double
    Get
public:
property double ByteRate {
    double get ();
}


CalculatedFrameRate Property

CalculatedFrameRate Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► CalculatedFrameRate
Gets the calculated frame rate (i.e., frames per second) based on data received from device connection.
Declaration Syntax
C# Visual Basic Visual C++
public double CalculatedFrameRate { get; }
Public ReadOnly Property CalculatedFrameRate As Double
    Get
public:
property double CalculatedFrameRate {
    double get ();
}


ConfigurationChanged Event

ConfigurationChanged Event
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ConfigurationChanged
Occurs when a device sends a notification that its configuration has changed.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler ConfigurationChanged
Public Event ConfigurationChanged As EventHandler
public:
virtual  event EventHandler^ ConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ConfigurationFrame
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
Declaration Syntax
C# Visual Basic Visual C++
public IConfigurationFrame ConfigurationFrame { get; set; }
Public Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () sealed;
    void set (IConfigurationFrame^ value) sealed;
}
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.


ConfiguredFrameRate Property

ConfiguredFrameRate Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ConfiguredFrameRate
Gets the configured frame rate as reported by the connected device.
Declaration Syntax
C# Visual Basic Visual C++
public int ConfiguredFrameRate { get; }
Public ReadOnly Property ConfiguredFrameRate As Integer
    Get
public:
property int ConfiguredFrameRate {
    int get ();
}


ConnectionAttempt Event

ConnectionAttempt Event
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ConnectionAttempt
Occurs when MultiProtocolFrameParser is attempting connection to a device.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler ConnectionAttempt
Public Event ConnectionAttempt As EventHandler
public:
 event EventHandler^ ConnectionAttempt {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


ConnectionEstablished Event

ConnectionEstablished Event
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ConnectionEstablished
Occurs when MultiProtocolFrameParser has established a connection to a device.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler ConnectionEstablished
Public Event ConnectionEstablished As EventHandler
public:
 event EventHandler^ ConnectionEstablished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


ConnectionException Event

ConnectionException Event
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ConnectionException
Occurs when an Exception is encountered during connection attempt to a device.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<Exception, int>> ConnectionException
Public Event ConnectionException As EventHandler(Of EventArgs(Of Exception, Integer))
public:
 event EventHandler<EventArgs<Exception^, int>^>^ ConnectionException {
    void add (EventHandler<EventArgs<Exception^, int>^>^ value);
    void remove (EventHandler<EventArgs<Exception^, int>^>^ value);
}
Remarks
Argument1()()()() is the exception that occured during the connection attempt.
Argument2()()()() is the number of connections attempted so far.


ConnectionParameters Property

ConnectionParameters Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ConnectionParameters
Gets or sets any connection specific IConnectionParameters that may be applicable for the current PhasorProtocol.
Declaration Syntax
C# Visual Basic Visual C++
public IConnectionParameters ConnectionParameters { get; set; }
Public Property ConnectionParameters As IConnectionParameters
    Get
    Set
public:
virtual property IConnectionParameters^ ConnectionParameters {
    IConnectionParameters^ get () sealed;
    void set (IConnectionParameters^ value) sealed;
}


ConnectionString Property

ConnectionString Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ConnectionString
Gets or sets the key/value pair based connection information required by the MultiProtocolFrameParser to connect to a device.
Declaration Syntax
C# Visual Basic Visual C++
public string ConnectionString { get; set; }
Public Property ConnectionString As String
    Get
    Set
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}


ConnectionTerminated Event

ConnectionTerminated Event
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ConnectionTerminated
Occurs when device connection has been terminated.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler ConnectionTerminated
Public Event ConnectionTerminated As EventHandler
public:
 event EventHandler^ ConnectionTerminated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


ConnectionTime Property

ConnectionTime Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ConnectionTime
Gets total time connection has been active.
Declaration Syntax
C# Visual Basic Visual C++
public Time ConnectionTime { get; }
Public ReadOnly Property ConnectionTime As Time
    Get
public:
property Time ConnectionTime {
    Time get ();
}


ConnectionType Property

ConnectionType Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ConnectionType
Gets the connection type (Active, Passive or Hybrid) based on defined channels and transport selections.
Declaration Syntax
C# Visual Basic Visual C++
public string ConnectionType { get; }
Public ReadOnly Property ConnectionType As String
    Get
public:
property String^ ConnectionType {
    String^ get ();
}


DataChannelIsServerBased Property

DataChannelIsServerBased Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► DataChannelIsServerBased
Gets a boolean value that determines if data channel is defined as a server based connection.
Declaration Syntax
C# Visual Basic Visual C++
public bool DataChannelIsServerBased { get; }
Public ReadOnly Property DataChannelIsServerBased As Boolean
    Get
public:
property bool DataChannelIsServerBased {
    bool get ();
}


DefaultAllowedParsingExceptions Field

DefaultAllowedParsingExceptions Field
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► DefaultAllowedParsingExceptions
Specfies the default value for the AllowedParsingExceptions property.
Declaration Syntax
C# Visual Basic Visual C++
public const int DefaultAllowedParsingExceptions
Public Const DefaultAllowedParsingExceptions As Integer
public:
literal int DefaultAllowedParsingExceptions


DefaultAutoStartDataParsingSequence Field

DefaultAutoStartDataParsingSequence Field
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► DefaultAutoStartDataParsingSequence
Specifies the default value for the AutoStartDataParsingSequence property.
Declaration Syntax
C# Visual Basic Visual C++
public const bool DefaultAutoStartDataParsingSequence
Public Const DefaultAutoStartDataParsingSequence As Boolean
public:
literal bool DefaultAutoStartDataParsingSequence


DefaultBufferSize Field

DefaultBufferSize Field
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► DefaultBufferSize
Specifies the default value for the BufferSize property.
Declaration Syntax
C# Visual Basic Visual C++
public const int DefaultBufferSize
Public Const DefaultBufferSize As Integer
public:
literal int DefaultBufferSize


DefaultDefinedFrameRate Field

DefaultDefinedFrameRate Field
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► DefaultDefinedFrameRate
Specifies the default value for the DefinedFrameRate property.
Declaration Syntax
C# Visual Basic Visual C++
public const int DefaultDefinedFrameRate
Public Const DefaultDefinedFrameRate As Integer
public:
literal int DefaultDefinedFrameRate


DefaultMaximumConnectionAttempts Field

DefaultMaximumConnectionAttempts Field
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► DefaultMaximumConnectionAttempts
Specifies the default value for the MaximumConnectionAttempts property.
Declaration Syntax
C# Visual Basic Visual C++
public const int DefaultMaximumConnectionAttempts
Public Const DefaultMaximumConnectionAttempts As Integer
public:
literal int DefaultMaximumConnectionAttempts


DefaultParsingExceptionWindow Field

DefaultParsingExceptionWindow Field
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► DefaultParsingExceptionWindow
Specifies the default value for the ParsingExceptionWindow property.
Declaration Syntax
C# Visual Basic Visual C++
public const long DefaultParsingExceptionWindow
Public Const DefaultParsingExceptionWindow As Long
public:
literal long long DefaultParsingExceptionWindow


DefinedFrameRate Property

DefinedFrameRate Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► DefinedFrameRate
Gets or sets desired frame rate to use for maintaining captured frame replay timing.
Declaration Syntax
C# Visual Basic Visual C++
public int DefinedFrameRate { get; set; }
Public Property DefinedFrameRate As Integer
    Get
    Set
public:
property int DefinedFrameRate {
    int get ();
    void set (int value);
}
Remarks
This is only applicable when connection is made to a file for replay purposes.


DeviceID Property

DeviceID Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► DeviceID
Gets or sets the device identification code often needed to establish a connection.
Declaration Syntax
C# Visual Basic Visual C++
public ushort DeviceID { get; set; }
Public Property DeviceID As UShort
    Get
    Set
public:
property unsigned short DeviceID {
    unsigned short get ();
    void set (unsigned short value);
}
Remarks
Most devices validate this ID when sending commands, so it must be correct in order to start parsing sequence.


DeviceSupportsCommands Property

DeviceSupportsCommands Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► DeviceSupportsCommands
Gets or sets flag that determines if a device supports commands.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeviceSupportsCommands { get; set; }
Public Property DeviceSupportsCommands As Boolean
    Get
    Set
public:
property bool DeviceSupportsCommands {
    bool get ();
    void set (bool value);
}
Remarks
This property is automatically derived based on the selected PhasorProtocol, TransportProtocol and ConnectionString, but can be overriden if the consumer already knows that a device supports commands.


Dispose Method

Dispose Method
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► Dispose()()()()
Releases all the resources used by the MultiProtocolFrameParser object.
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed


Enabled Property

Enabled Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► Enabled
Gets or sets a boolean value that indicates whether the MultiProtocolFrameParser is currently enabled.
Declaration Syntax
C# Visual Basic Visual C++
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}
Remarks
Setting Enabled to true will start the MultiProtocolFrameParser if it is not started, setting to false will stop the MultiProtocolFrameParser if it is started.


ExceededParsingExceptionThreshold Event

ExceededParsingExceptionThreshold Event
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ExceededParsingExceptionThreshold
Occurs when number of parsing exceptions exceed AllowedParsingExceptions during ParsingExceptionWindow.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler ExceededParsingExceptionThreshold
Public Event ExceededParsingExceptionThreshold As EventHandler
public:
 event EventHandler^ ExceededParsingExceptionThreshold {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


ExecuteParseOnSeparateThread Property

ExecuteParseOnSeparateThread Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ExecuteParseOnSeparateThread
Gets or sets a flag that allows frame parsing to be executed on a separate thread (i.e., other than communications thread).
Declaration Syntax
C# Visual Basic Visual C++
public bool ExecuteParseOnSeparateThread { get; set; }
Public Property ExecuteParseOnSeparateThread As Boolean
    Get
    Set
public:
virtual property bool ExecuteParseOnSeparateThread {
    bool get () sealed;
    void set (bool value) sealed;
}
Remarks
This is typically only needed when data frames are very large. This change will happen dynamically, even if a connection is active.


Finalize Method

Finalize Method
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► Finalize()()()()
Releases the unmanaged resources before the MultiProtocolFrameParser object is reclaimed by GC.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override


InjectSimulatedTimestamp Property

InjectSimulatedTimestamp Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► InjectSimulatedTimestamp
Gets or sets flag indicating whether or not to inject local system time into parsed data frames.
Declaration Syntax
C# Visual Basic Visual C++
public bool InjectSimulatedTimestamp { get; set; }
Public Property InjectSimulatedTimestamp As Boolean
    Get
    Set
public:
property bool InjectSimulatedTimestamp {
    bool get ();
    void set (bool value);
}
Remarks
When connection is made to a file for replay purposes or consumer doesn't trust remote clock source, this flag can be set to true replace all frame timestamps with a UTC timestamp dervied from the local system clock.


IsConnected Property

IsConnected Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► IsConnected
Gets a flag that determines if the currently selected TransportProtocol is connected.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsConnected { get; }
Public ReadOnly Property IsConnected As Boolean
    Get
public:
property bool IsConnected {
    bool get ();
}


IsIEEEProtocol Property

IsIEEEProtocol Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► IsIEEEProtocol
Gets a flag that determines if the currently selected PhasorProtocol is an IEEE standard protocol.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsIEEEProtocol { get; }
Public ReadOnly Property IsIEEEProtocol As Boolean
    Get
public:
property bool IsIEEEProtocol {
    bool get ();
}


MaximumConnectionAttempts Property

MaximumConnectionAttempts Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► MaximumConnectionAttempts
Gets or sets the maximum number of times the MultiProtocolFrameParser will attempt to connect to a device.
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumConnectionAttempts { get; set; }
Public Property MaximumConnectionAttempts As Integer
    Get
    Set
public:
property int MaximumConnectionAttempts {
    int get ();
    void set (int value);
}
Remarks
Set to -1 for infinite connection attempts.


MegaBitRate Property

MegaBitRate Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► MegaBitRate
Gets the calculated megabits per second (Mbps) rate based on data received from device connection.
Declaration Syntax
C# Visual Basic Visual C++
public double MegaBitRate { get; }
Public ReadOnly Property MegaBitRate As Double
    Get
public:
property double MegaBitRate {
    double get ();
}


Name Property

Name Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► Name
Gets a descriptive name for a device connection that includes SourceName, if provided.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}


ParsingException Event

ParsingException Event
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ParsingException
Occurs when an Exception is encountered while parsing the data stream.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<Exception>> ParsingException
Public Event ParsingException As EventHandler(Of EventArgs(Of Exception))
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ ParsingException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}
Remarks
Argument()()()() is the Exception encountered while parsing the data stream.


ParsingExceptionWindow Property

ParsingExceptionWindow Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ParsingExceptionWindow
Gets or sets time duration, in Ticks, to monitor parsing exceptions.
Declaration Syntax
C# Visual Basic Visual C++
public Ticks ParsingExceptionWindow { get; set; }
Public Property ParsingExceptionWindow As Ticks
    Get
    Set
public:
property Ticks ParsingExceptionWindow {
    Ticks get ();
    void set (Ticks value);
}


PhasorProtocol Property

PhasorProtocol Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► PhasorProtocol
Gets or sets PhasorProtocol to use with this MultiProtocolFrameParser.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorProtocol PhasorProtocol { get; set; }
Public Property PhasorProtocol As PhasorProtocol
    Get
    Set
public:
property PhasorProtocol PhasorProtocol {
    PhasorProtocol get ();
    void set (PhasorProtocol value);
}


QueuedBuffers Property

QueuedBuffers Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► QueuedBuffers
Gets the total number of buffers that are currently queued for processing, if any.
Declaration Syntax
C# Visual Basic Visual C++
public int QueuedBuffers { get; }
Public ReadOnly Property QueuedBuffers As Integer
    Get
public:
virtual property int QueuedBuffers {
    int get () sealed;
}


ReceivedCommandFrame Event

ReceivedCommandFrame Event
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ReceivedCommandFrame
Occurs when a ICommandFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<ICommandFrame>> ReceivedCommandFrame
Public Event ReceivedCommandFrame As EventHandler(Of EventArgs(Of ICommandFrame))
public:
virtual  event EventHandler<EventArgs<ICommandFrame^>^>^ ReceivedCommandFrame {
    void add (EventHandler<EventArgs<ICommandFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ICommandFrame^>^>^ value);
}
Remarks
Argument()()()() is the ICommandFrame that was received.


ReceivedConfigurationFrame Event

ReceivedConfigurationFrame Event
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ReceivedConfigurationFrame
Occurs when a IConfigurationFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<IConfigurationFrame>> ReceivedConfigurationFrame
Public Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of IConfigurationFrame))
public:
virtual  event EventHandler<EventArgs<IConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<IConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IConfigurationFrame^>^>^ value);
}
Remarks
Argument()()()() is the IConfigurationFrame that was received.


ReceivedDataFrame Event

ReceivedDataFrame Event
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ReceivedDataFrame
Occurs when a IDataFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<IDataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of IDataFrame))
public:
virtual  event EventHandler<EventArgs<IDataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<IDataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IDataFrame^>^>^ value);
}
Remarks
Argument()()()() is the IDataFrame that was received.


ReceivedFrameBufferImage Event

ReceivedFrameBufferImage Event
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ReceivedFrameBufferImage
Occurs when a frame buffer image has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<FundamentalFrameType, byte[], int, int>> ReceivedFrameBufferImage
Public Event ReceivedFrameBufferImage As EventHandler(Of EventArgs(Of FundamentalFrameType, Byte(), Integer, Integer))
public:
virtual  event EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ ReceivedFrameBufferImage {
    void add (EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ value);
    void remove (EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ value);
}
Remarks
Argument1()()()() is the FundamentalFrameType of the frame buffer image that was received.
Argument2()()()() is the buffer that contains the frame image that was received.
Argument3()()()() is the offset into the buffer that contains the frame image that was received.
Argument4()()()() is the length of data in the buffer that contains the frame image that was received.


ReceivedHeaderFrame Event

ReceivedHeaderFrame Event
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ReceivedHeaderFrame
Occurs when a IHeaderFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<IHeaderFrame>> ReceivedHeaderFrame
Public Event ReceivedHeaderFrame As EventHandler(Of EventArgs(Of IHeaderFrame))
public:
virtual  event EventHandler<EventArgs<IHeaderFrame^>^>^ ReceivedHeaderFrame {
    void add (EventHandler<EventArgs<IHeaderFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IHeaderFrame^>^>^ value);
}
Remarks
Argument()()()() is the IHeaderFrame that was received.


ReceivedUndeterminedFrame Event

ReceivedUndeterminedFrame Event
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ReceivedUndeterminedFrame
Occurs when an undetermined IChannelFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<IChannelFrame>> ReceivedUndeterminedFrame
Public Event ReceivedUndeterminedFrame As EventHandler(Of EventArgs(Of IChannelFrame))
public:
virtual  event EventHandler<EventArgs<IChannelFrame^>^>^ ReceivedUndeterminedFrame {
    void add (EventHandler<EventArgs<IChannelFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IChannelFrame^>^>^ value);
}
Remarks
Argument()()()() is the undetermined IChannelFrame that was received.


SendDeviceCommand Method (command)

SendDeviceCommand Method (command)
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► SendDeviceCommand(DeviceCommand)
Sends the specified DeviceCommand to the remote device.
Declaration Syntax
C# Visual Basic Visual C++
public WaitHandle SendDeviceCommand(
    DeviceCommand command
)
Public Function SendDeviceCommand ( _
    command As DeviceCommand _
) As WaitHandle
public:
WaitHandle^ SendDeviceCommand(
    DeviceCommand command
)
Parameters
command (DeviceCommand)
DeviceCommand to send to the remote device.
Return Value
A WaitHandle.
Remarks
Command will only be sent if DeviceSupportsCommands is true and MultiProtocolFrameParser.


SentCommandFrame Event

SentCommandFrame Event
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► SentCommandFrame
Occurs when a ICommandFrame is sent to a device.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<ICommandFrame>> SentCommandFrame
Public Event SentCommandFrame As EventHandler(Of EventArgs(Of ICommandFrame))
public:
 event EventHandler<EventArgs<ICommandFrame^>^>^ SentCommandFrame {
    void add (EventHandler<EventArgs<ICommandFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ICommandFrame^>^>^ value);
}
Remarks
Argument()()()() is a reference to the ICommandFrame that was sent to the device.


ServerStarted Event

ServerStarted Event
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ServerStarted
Occurs when the MultiProtocolFrameParser is setup as a listening connection and server connection has been started.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler ServerStarted
Public Event ServerStarted As EventHandler
public:
 event EventHandler^ ServerStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


ServerStopped Event

ServerStopped Event
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► ServerStopped
Occurs when the MultiProtocolFrameParser is setup as a listening connection and server connection has been stopped.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler ServerStopped
Public Event ServerStopped As EventHandler
public:
 event EventHandler^ ServerStopped {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


SkipDisableRealTimeData Property

SkipDisableRealTimeData Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► SkipDisableRealTimeData
Gets or sets flag to skip automatic disabling of the real-time data stream on shutdown or startup.
Declaration Syntax
C# Visual Basic Visual C++
public bool SkipDisableRealTimeData { get; set; }
Public Property SkipDisableRealTimeData As Boolean
    Get
    Set
public:
property bool SkipDisableRealTimeData {
    bool get ();
    void set (bool value);
}
Remarks
This flag may important when using UDP multicast with several subscribed clients.


SourceName Property

SourceName Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► SourceName
Gets or sets a descriptive name for a device connection.
Declaration Syntax
C# Visual Basic Visual C++
public string SourceName { get; set; }
Public Property SourceName As String
    Get
    Set
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► Start()()()()
Starts the MultiProtocolFrameParser.
Declaration Syntax
C# Visual Basic Visual C++
public void Start()
Public Sub Start
public:
virtual void Start() sealed


Status Property

Status Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► Status
Gets current descriptive status of the MultiProtocolFrameParser.
Declaration Syntax
C# Visual Basic Visual C++
public string Status { get; }
Public ReadOnly Property Status As String
    Get
public:
virtual property String^ Status {
    String^ get () sealed;
}


Stop Method

Stop Method
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► Stop()()()()
Stops the MultiProtocolFrameParser.
Declaration Syntax
C# Visual Basic Visual C++
public void Stop()
Public Sub Stop
public:
virtual void Stop() sealed


TotalBytesReceived Property

TotalBytesReceived Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► TotalBytesReceived
Gets total number of bytes that have been received from a device so far.
Declaration Syntax
C# Visual Basic Visual C++
public long TotalBytesReceived { get; }
Public ReadOnly Property TotalBytesReceived As Long
    Get
public:
property long long TotalBytesReceived {
    long long get ();
}


TotalCrcExceptions Property

TotalCrcExceptions Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► TotalCrcExceptions
Gets total number of CRC exceptions encountered from device so far.
Declaration Syntax
C# Visual Basic Visual C++
public long TotalCrcExceptions { get; }
Public ReadOnly Property TotalCrcExceptions As Long
    Get
public:
property long long TotalCrcExceptions {
    long long get ();
}


TotalFramesReceived Property

TotalFramesReceived Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► TotalFramesReceived
Gets total number of frames that have been received from a device so far.
Declaration Syntax
C# Visual Basic Visual C++
public long TotalFramesReceived { get; }
Public ReadOnly Property TotalFramesReceived As Long
    Get
public:
property long long TotalFramesReceived {
    long long get ();
}


TotalMissingFrames Property

TotalMissingFrames Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► TotalMissingFrames
Gets total number of frames that were missing from device so far.
Declaration Syntax
C# Visual Basic Visual C++
public long TotalMissingFrames { get; }
Public ReadOnly Property TotalMissingFrames As Long
    Get
public:
property long long TotalMissingFrames {
    long long get ();
}


TransportProtocol Property

TransportProtocol Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► TransportProtocol
Gets or sets TransportProtocol to use with this MultiProtocolFrameParser.
Declaration Syntax
C# Visual Basic Visual C++
public TransportProtocol TransportProtocol { get; set; }
Public Property TransportProtocol As TransportProtocol
    Get
    Set
public:
property TransportProtocol TransportProtocol {
    TransportProtocol get ();
    void set (TransportProtocol value);
}


UseHighResolutionInputTimer Property

UseHighResolutionInputTimer Property
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► UseHighResolutionInputTimer
Gets or sets flag that determines if a high-resolution precision timer should be used for file based input.
Declaration Syntax
C# Visual Basic Visual C++
public bool UseHighResolutionInputTimer { get; set; }
Public Property UseHighResolutionInputTimer As Boolean
    Get
    Set
public:
property bool UseHighResolutionInputTimer {
    bool get ();
    void set (bool value);
}
Remarks
Useful when input frames need be accurately time-aligned to the local clock to better simulate an input device and calculate downstream latencies.
This is only applicable when connection is made to a file for replay purposes.


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
Namespaces ► TVA.PhasorProtocols ► MultiProtocolFrameParser ► Write(array<Byte>[]()[][], Int32, Int32)
Writes data directly to the frame parsing engine buffer.
Declaration Syntax
C# Visual Basic Visual C++
public void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Sub Write ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) sealed
Parameters
buffer (array< Byte >[]()[][])
Buffer containing data to be parsed.
offset (Int32)
Offset into buffer where data begins.
count (Int32)
Length of data in buffer to be parsed.
Remarks
This method allows consumer to "manually send extra data" to the parsing engine to be parsed, if desired.


PhasorDataConcentratorBase Class

PhasorDataConcentratorBase Class
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase
Represents an IActionAdapter used to generate and transmit concentrated stream of phasor measurements in a specific phasor protocol.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class PhasorDataConcentratorBase : ActionAdapterBase
Public MustInherit Class PhasorDataConcentratorBase _
    Inherits ActionAdapterBase
public ref class PhasorDataConcentratorBase abstract : public ActionAdapterBase
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorDataConcentratorBase()()()() | Creates a new PhasorDataConcentratorBase.
 | ActiveConnections | Gets the total number of active socket connections.
 | AllowPreemptivePublishing()()()() | (Inherited from ConcentratorBase.)
 | AllowSortsByArrival()()()() | (Inherited from ConcentratorBase.)
 | AnalogScalingValue | Gets or sets the integer scaling value to apply to analog values published by this PhasorDataConcentratorBase.
 | AssignMeasurementToFrame(IFrame, IMeasurement) | Assign IMeasurement to its IFrame. (Overrides ConcentratorBase.AssignMeasurementToFrame(IFrame, IMeasurement).)
 | AssignParentCollection(IAdapterCollection) | (Inherited from ActionAdapterBase.)
 | AutoPublishConfigurationFrame | Gets or sets flag that determines if configuration frame should be automatically published at the top of each minute on the data channel.
 | AutoStart()()()() | (Inherited from ActionAdapterBase.)
 | AutoStartDataChannel | Gets or sets flag that determines if concentrator will automatically start data channel.
 | AverageLatency | Gets the average latency in milliseconds over the last test interval.
 | AveragePublicationTimePerFrame()()()() | (Inherited from ConcentratorBase.)
 | BaseConfigurationFrame | Gets the protocol independent ConfigurationFrame defined for this PhasorDataConcentratorBase.
 | CacheConfigurationFrame(IConfigurationFrame, String) | Serialize configuration frame to cache folder for later use (if needed).
 | CommandChannel | Gets or sets reference to TcpServer command channel, attaching and/or detaching to events as needed.
 | ConfigurationFrame | Gets or sets the protocol specific IConfigurationFrame used to send to clients for protocol parsing.
 | ConnectedClientCount | Gets the current number of known connected clients on the command channel.
 | ConnectionString()()()() | (Inherited from ActionAdapterBase.)
 | CoordinateFormat | Gets or sets the CoordinateFormat defined for this PhasorDataConcentratorBase.
 | CreateNewConfigurationFrame(ConfigurationFrame) | Creates a new protocol specific IConfigurationFrame based on provided protocol independent baseConfigurationFrame.
 | CreateNewFrame(Ticks) | (Inherited from ConcentratorBase.)
 | CurrentScalingValue | Gets or sets the integer scaling value to apply to current values published by this PhasorDataConcentratorBase.
 | DataChannel | Gets or sets reference to UdpServer data channel, attaching and/or detaching to events as needed.
 | DataFormat | Gets or sets the DataFormat defined for this PhasorDataConcentratorBase.
 | DataSource()()()() | (Inherited from ActionAdapterBase.)
 | DeviceCommandHandler(Guid, String, array<Byte>[]()[][], Int32) | Handles incoming commands from devices connected over the command channel.
 | DigitalMaskValue | Gets or sets the digital mask value made available in configuration frames for use with digital values published by this PhasorDataConcentratorBase.
 | DiscardedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | DiscardingMeasurements()()()() | (Inherited from ConcentratorBase.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the PhasorDataConcentratorBase object and optionally releases the managed resources. (Overrides ActionAdapterBase.Dispose(Boolean).)
 | Dispose()()()() | (Inherited from ConcentratorBase.)
 | Disposed()()()() | (Inherited from ConcentratorBase.)
 | DownsampledMeasurements()()()() | (Inherited from ConcentratorBase.)
 | DownsamplingMethod()()()() | (Inherited from ConcentratorBase.)
 | Enabled()()()() | (Inherited from ConcentratorBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExamineQueueState()()()() | (Inherited from ActionAdapterBase.)
 | ExpectedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | Finalize()()()() | (Inherited from ConcentratorBase.)
 | FramesAheadOfSchedule()()()() | (Inherited from ConcentratorBase.)
 | FramesPerSecond()()()() | (Inherited from ConcentratorBase.)
 | GetConnectionID(IServer, Guid) | Gets connection ID (i.e., IP:Port) for specified clientID.
 | GetHashCode()()()() | Returns the hash code for this instance. (Overrides ActionAdapterBase.GetHashCode()()()().)
 | GetShortStatus(Int32) | (Inherited from ActionAdapterBase.)
 | GetSignalReference(SignalKind) | Get signal reference for specified SignalKind.
 | GetSignalReference(SignalKind, Int32, Int32) | Get signal reference for specified SignalKind and index.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID()()()() | (Inherited from ActionAdapterBase.)
 | IDCode | Gets ID code defined for this PhasorDataConcentratorBase parsed from the ConnectionString()()()().
 | IgnoreBadTimestamps()()()() | (Inherited from ConcentratorBase.)
 | InitializationTimeout()()()() | (Inherited from ActionAdapterBase.)
 | Initialize()()()() | Initializes PhasorDataConcentratorBase. (Overrides ActionAdapterBase.Initialize()()()().)
 | Initialized()()()() | (Inherited from ActionAdapterBase.)
 | InputMeasurementKeys()()()() | (Inherited from ActionAdapterBase.)
 | InputMeasurementKeysUpdated()()()() | (Inherited from ActionAdapterBase.)
 | InputSourceIDs()()()() | (Inherited from ActionAdapterBase.)
 | IsInputMeasurement(MeasurementKey) | (Inherited from ActionAdapterBase.)
 | LagTicks()()()() | (Inherited from ConcentratorBase.)
 | LagTime()()()() | (Inherited from ConcentratorBase.)
 | LastDiscardedMeasurement()()()() | (Inherited from ConcentratorBase.)
 | LastDiscardedMeasurementLatency()()()() | (Inherited from ConcentratorBase.)
 | LastFrame()()()() | (Inherited from ConcentratorBase.)
 | LatestMeasurements()()()() | (Inherited from ConcentratorBase.)
 | LeadTime()()()() | (Inherited from ConcentratorBase.)
 | MaximumLatency | Gets the maximum latency in milliseconds over the last test interval.
 | MaximumPublicationTimeout()()()() | (Inherited from ConcentratorBase.)
 | MeasurementsSortedByArrival()()()() | (Inherited from ConcentratorBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MillisecondsFromRealTime(Ticks) | (Inherited from ConcentratorBase.)
 | MinimumLatency | Gets the minimum latency in milliseconds over the last test interval.
 | MinimumMeasurementsToUse()()()() | (Inherited from ActionAdapterBase.)
 | MissedSortsByTimeout()()()() | (Inherited from ConcentratorBase.)
 | Name()()()() | (Inherited from ActionAdapterBase.)
 | NewMeasurements()()()() | (Inherited from ActionAdapterBase.)
 | NominalFrequency | Gets or sets the nominal LineFrequency defined for this PhasorDataConcentratorBase.
 | OnDiscardingMeasurements(IEnumerable<(Of <<'(IMeasurement>)>>)) | (Inherited from ConcentratorBase.)
 | OnInputMeasurementKeysUpdated()()()() | (Inherited from ActionAdapterBase.)
 | OnNewMeasurements(ICollection<(Of <<'(IMeasurement>)>>)) | (Inherited from ActionAdapterBase.)
 | OnOutputMeasurementsUpdated()()()() | (Inherited from ActionAdapterBase.)
 | OnProcessException(Exception) | (Inherited from ConcentratorBase.)
 | OnStatusMessage(String) | (Inherited from ActionAdapterBase.)
 | OnStatusMessage(String, array<Object>[]()[][]) | (Inherited from ActionAdapterBase.)
 | OnUnpublishedSamples(Int32) | (Inherited from ConcentratorBase.)
 | OutputMeasurements()()()() | (Inherited from ActionAdapterBase.)
 | OutputMeasurementsUpdated()()()() | (Inherited from ActionAdapterBase.)
 | OutputSourceIDs()()()() | (Inherited from ActionAdapterBase.)
 | Parent()()()() | (Inherited from ActionAdapterBase.)
 | PerformTimestampReasonabilityCheck()()()() | (Inherited from ConcentratorBase.)
 | ProcessByReceivedTimestamp()()()() | (Inherited from ConcentratorBase.)
 | ProcessDataValidFlag | Gets or sets flag that determines if the data valid flag assignments should be processed during frame publication.
 | ProcessedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | ProcessException()()()() | (Inherited from ConcentratorBase.)
 | ProcessingInterval()()()() | (Inherited from ConcentratorBase.)
 | ProcessMeasurementFilter()()()() | (Inherited from ActionAdapterBase.)
 | PublishedFrames()()()() | (Inherited from ConcentratorBase.)
 | PublishedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | PublishFrame(IFrame, Int32) | Publish IFrame of time-aligned collection of IMeasurement values that arrived within the concentrator's defined LagTime()()()(). (Overrides ConcentratorBase.PublishFrame(IFrame, Int32).)
 | QueueMeasurementForProcessing(IMeasurement) | Queues a single measurement for processing. (Overrides ActionAdapterBase.QueueMeasurementForProcessing(IMeasurement).)
 | QueueMeasurementsForProcessing(IEnumerable<(Of <<'(IMeasurement>)>>)) | Queues a collection of measurements for processing. (Overrides ActionAdapterBase.QueueMeasurementsForProcessing(IEnumerable<(Of <<'(IMeasurement>)>>)).)
 | QueueState()()()() | (Inherited from ConcentratorBase.)
 | RealTime()()()() | (Inherited from ConcentratorBase.)
 | ReceivedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | RequestedInputMeasurementKeys()()()() | (Inherited from ActionAdapterBase.)
 | RequestedOutputMeasurementKeys()()()() | (Inherited from ActionAdapterBase.)
 | ResetLatencyCounters()()()() | Resets counters related to latency calculations.
 | ResetStatistics()()()() | (Inherited from ActionAdapterBase.)
 | RunTime()()()() | (Inherited from ConcentratorBase.)
 | SecondsFromRealTime(Ticks) | (Inherited from ConcentratorBase.)
 | SetInitializedState(Boolean) | (Inherited from ActionAdapterBase.)
 | SetTemporalConstraint(String, String, String) | (Inherited from ActionAdapterBase.)
 | Settings()()()() | (Inherited from ActionAdapterBase.)
 | SortMeasurement(IMeasurement) | (Inherited from ConcentratorBase.)
 | SortMeasurements(IEnumerable<(Of <<'(IMeasurement>)>>)) | (Inherited from ConcentratorBase.)
 | Start()()()() | Starts the PhasorDataConcentratorBase, if it is not already running. (Overrides ActionAdapterBase.Start()()()().)
 | StartDataChannel()()()() | Starts the PhasorDataConcentratorBase real-time data stream.
 | StartTime()()()() | (Inherited from ConcentratorBase.)
 | StartTimeConstraint()()()() | (Inherited from ActionAdapterBase.)
 | Status | Returns the detailed status of this PhasorDataConcentratorBase. (Overrides ActionAdapterBase.Status()()()().)
 | StatusMessage()()()() | (Inherited from ActionAdapterBase.)
 | Stop()()()() | Stops the PhasorDataConcentratorBase. (Overrides ActionAdapterBase.Stop()()()().)
 | StopDataChannel()()()() | Stops the PhasorDataConcentratorBase real-time data stream.
 | StopTime()()()() | (Inherited from ConcentratorBase.)
 | StopTimeConstraint()()()() | (Inherited from ActionAdapterBase.)
 | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Overrides ActionAdapterBase.SupportsTemporalProcessing()()()().)
 | TicksPerFrame()()()() | (Inherited from ConcentratorBase.)
 | TimeResolution()()()() | (Inherited from ConcentratorBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalPublicationTime()()()() | (Inherited from ConcentratorBase.)
 | TrackLatestMeasurements()()()() | (Inherited from ConcentratorBase.)
 | TrackPublishedTimestamp()()()() | (Inherited from ConcentratorBase.)
 | TryGetMinimumNeededMeasurements(IFrame, array<IMeasurement>[]()[][]%) | (Inherited from ActionAdapterBase.)
 | UnpublishedSamples()()()() | (Inherited from ConcentratorBase.)
 | UpdateConfiguration()()()() | Reloads the configuration for this PhasorDataConcentratorBase.
 | UseLocalClockAsRealTime()()()() | (Inherited from ConcentratorBase.)
 | UsePrecisionTimer()()()() | (Inherited from ConcentratorBase.)
 | VoltageScalingValue | Gets or sets the integer scaling value to apply to voltage values published by this PhasorDataConcentratorBase.
 | WaitForInitialize(Int32) | (Inherited from ActionAdapterBase.)
 | WaitHandleExpirations()()()() | (Inherited from ConcentratorBase.)
Inheritance Hierarchy
Object
 | ConcentratorBase
 |  | ActionAdapterBase
 |  |  | PhasorDataConcentratorBase
 |  |  |  | Concentrator
 |  |  |  | Concentrator


PhasorDataConcentratorBase Constructor

PhasorDataConcentratorBase Constructor
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► PhasorDataConcentratorBase()()()()
Creates a new PhasorDataConcentratorBase.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorDataConcentratorBase()
Protected Sub New
protected:
PhasorDataConcentratorBase()


ActiveConnections Property

ActiveConnections Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► ActiveConnections
Gets the total number of active socket connections.
Declaration Syntax
C# Visual Basic Visual C++
public long ActiveConnections { get; }
Public ReadOnly Property ActiveConnections As Long
    Get
public:
property long long ActiveConnections {
    long long get ();
}


AnalogScalingValue Property

AnalogScalingValue Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► AnalogScalingValue
Gets or sets the integer scaling value to apply to analog values published by this PhasorDataConcentratorBase.
Declaration Syntax
C# Visual Basic Visual C++
public uint AnalogScalingValue { get; set; }
Public Property AnalogScalingValue As UInteger
    Get
    Set
public:
property unsigned int AnalogScalingValue {
    unsigned int get ();
    void set (unsigned int value);
}
Remarks
Typically only the lower 24-bits will be used to scale analog values in 10^–5 units per bit. Note that this value represents the default value that will be used if user has not specified a value for an individual device.


AssignMeasurementToFrame Method (frame, measurement)

AssignMeasurementToFrame Method (frame, measurement)
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► AssignMeasurementToFrame(IFrame, IMeasurement)
Assign IMeasurement to its IFrame.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AssignMeasurementToFrame(
    IFrame frame,
    IMeasurement measurement
)
Protected Overrides Sub AssignMeasurementToFrame ( _
    frame As IFrame, _
    measurement As IMeasurement _
)
protected:
virtual void AssignMeasurementToFrame(
    IFrame^ frame,
    IMeasurement^ measurement
) override
Parameters
frame (IFrame)
IFrame to assign measurement to.
measurement (IMeasurement)
IMeasurement to assign to frame.
Return Value
true if IMeasurement was successfully assigned to its IFrame.
Remarks
In simple concentration scenarios all you need to do is assign a measurement to its frame based on time. In the case of a phasor data concentrator you need to assign a measurement to its particular location in its IDataFrame - so this method overrides the default behavior in order to accomplish this task.


AutoPublishConfigurationFrame Property

AutoPublishConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► AutoPublishConfigurationFrame
Gets or sets flag that determines if configuration frame should be automatically published at the top of each minute on the data channel.
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPublishConfigurationFrame { get; set; }
Public Property AutoPublishConfigurationFrame As Boolean
    Get
    Set
public:
property bool AutoPublishConfigurationFrame {
    bool get ();
    void set (bool value);
}
Remarks
By default if no command channel is defined, this flag will be true; otherwise if command channel is defined the flag will be false.


AutoStartDataChannel Property

AutoStartDataChannel Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► AutoStartDataChannel
Gets or sets flag that determines if concentrator will automatically start data channel.
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoStartDataChannel { get; set; }
Public Property AutoStartDataChannel As Boolean
    Get
    Set
public:
property bool AutoStartDataChannel {
    bool get ();
    void set (bool value);
}
Remarks
By default data channel will be started automatically, setting this flag to false will allow alternate methods of enabling and disabling the real-time data stream (e.g., this can be used to allow a remote to device to enable and disable data stream if the protocol supports such commands).


AverageLatency Property

AverageLatency Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► AverageLatency
Gets the average latency in milliseconds over the last test interval.
Declaration Syntax
C# Visual Basic Visual C++
public int AverageLatency { get; }
Public ReadOnly Property AverageLatency As Integer
    Get
public:
property int AverageLatency {
    int get ();
}


BaseConfigurationFrame Property

BaseConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► BaseConfigurationFrame
Gets the protocol independent ConfigurationFrame defined for this PhasorDataConcentratorBase.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame BaseConfigurationFrame { get; }
Public ReadOnly Property BaseConfigurationFrame As ConfigurationFrame
    Get
public:
property ConfigurationFrame^ BaseConfigurationFrame {
    ConfigurationFrame^ get ();
}


CacheConfigurationFrame Method (configurationFrame, name)

CacheConfigurationFrame Method (configurationFrame, name)
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► CacheConfigurationFrame(IConfigurationFrame, String)
Serialize configuration frame to cache folder for later use (if needed).
Declaration Syntax
C# Visual Basic Visual C++
protected void CacheConfigurationFrame(
    IConfigurationFrame configurationFrame,
    string name
)
Protected Sub CacheConfigurationFrame ( _
    configurationFrame As IConfigurationFrame, _
    name As String _
)
protected:
void CacheConfigurationFrame(
    IConfigurationFrame^ configurationFrame,
    String^ name
)
Parameters
configurationFrame (IConfigurationFrame)
New IConfigurationFrame to cache.
name (String)
Name to use when caching the configurationFrame.
Remarks
Derived concentrators can call this method to manually serialize their protocol specific configuration frames. Note that after initial call to CreateNewConfigurationFrame(ConfigurationFrame) this method will be call automatically.


CommandChannel Property

CommandChannel Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► CommandChannel
Gets or sets reference to TcpServer command channel, attaching and/or detaching to events as needed.
Declaration Syntax
C# Visual Basic Visual C++
protected TcpServer CommandChannel { get; set; }
Protected Property CommandChannel As TcpServer
    Get
    Set
protected:
property TcpServer^ CommandChannel {
    TcpServer^ get ();
    void set (TcpServer^ value);
}


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► ConfigurationFrame
Gets or sets the protocol specific IConfigurationFrame used to send to clients for protocol parsing.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IConfigurationFrame ConfigurationFrame { get; set; }
Public Overridable Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get ();
    void set (IConfigurationFrame^ value);
}


ConnectedClientCount Property

ConnectedClientCount Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► ConnectedClientCount
Gets the current number of known connected clients on the command channel.
Declaration Syntax
C# Visual Basic Visual C++
public int ConnectedClientCount { get; }
Public ReadOnly Property ConnectedClientCount As Integer
    Get
public:
property int ConnectedClientCount {
    int get ();
}


CoordinateFormat Property

CoordinateFormat Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► CoordinateFormat
Gets or sets the CoordinateFormat defined for this PhasorDataConcentratorBase.
Declaration Syntax
C# Visual Basic Visual C++
public CoordinateFormat CoordinateFormat { get; set; }
Public Property CoordinateFormat As CoordinateFormat
    Get
    Set
public:
property CoordinateFormat CoordinateFormat {
    CoordinateFormat get ();
    void set (CoordinateFormat value);
}
Remarks
Note that this value represents the default format that will be used if user has not specified a coordinate format for an individual device.


CreateNewConfigurationFrame Method (baseConfigurationFrame)

CreateNewConfigurationFrame Method (baseConfigurationFrame)
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► CreateNewConfigurationFrame(ConfigurationFrame)
Creates a new protocol specific IConfigurationFrame based on provided protocol independent baseConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract IConfigurationFrame CreateNewConfigurationFrame(
    ConfigurationFrame baseConfigurationFrame
)
Protected MustOverride Function CreateNewConfigurationFrame ( _
    baseConfigurationFrame As ConfigurationFrame _
) As IConfigurationFrame
protected:
virtual IConfigurationFrame^ CreateNewConfigurationFrame(
    ConfigurationFrame^ baseConfigurationFrame
) abstract
Parameters
baseConfigurationFrame (ConfigurationFrame)
Protocol independent ConfigurationFrame.
Return Value
A new protocol specific IConfigurationFrame.
Remarks
Derived classes should notify consumers of change in configuration if system is active when new configuration frame is created if outgoing protocol allows such a notfication.


CurrentScalingValue Property

CurrentScalingValue Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► CurrentScalingValue
Gets or sets the integer scaling value to apply to current values published by this PhasorDataConcentratorBase.
Declaration Syntax
C# Visual Basic Visual C++
public uint CurrentScalingValue { get; set; }
Public Property CurrentScalingValue As UInteger
    Get
    Set
public:
property unsigned int CurrentScalingValue {
    unsigned int get ();
    void set (unsigned int value);
}
Remarks
Typically only the lower 24-bits will be used to scale current values in 10^–5 amperes per bit. Note that this value represents the default value that will be used if user has not specified a value for an individual device.


DataChannel Property

DataChannel Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► DataChannel
Gets or sets reference to UdpServer data channel, attaching and/or detaching to events as needed.
Declaration Syntax
C# Visual Basic Visual C++
protected UdpServer DataChannel { get; set; }
Protected Property DataChannel As UdpServer
    Get
    Set
protected:
property UdpServer^ DataChannel {
    UdpServer^ get ();
    void set (UdpServer^ value);
}


DataFormat Property

DataFormat Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► DataFormat
Gets or sets the DataFormat defined for this PhasorDataConcentratorBase.
Declaration Syntax
C# Visual Basic Visual C++
public DataFormat DataFormat { get; set; }
Public Property DataFormat As DataFormat
    Get
    Set
public:
property DataFormat DataFormat {
    DataFormat get ();
    void set (DataFormat value);
}
Remarks
Note that this value represents the default format that will be used if user has not specified a data format for an individual device.


DeviceCommandHandler Method (clientID, connectionID, commandBuffer, length)

DeviceCommandHandler Method (clientID, connectionID, commandBuffer, length)
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► DeviceCommandHandler(Guid, String, array<Byte>[]()[][], Int32)
Handles incoming commands from devices connected over the command channel.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void DeviceCommandHandler(
    Guid clientID,
    string connectionID,
    byte[] commandBuffer,
    int length
)
Protected Overridable Sub DeviceCommandHandler ( _
    clientID As Guid, _
    connectionID As String, _
    commandBuffer As Byte(), _
    length As Integer _
)
protected:
virtual void DeviceCommandHandler(
    Guid clientID,
    String^ connectionID,
    array<unsigned char>^ commandBuffer,
    int length
)
Parameters
clientID (Guid)
Guid of client that sent the command.
connectionID (String)
Remote client connection identification (i.e., IP:Port).
commandBuffer (array< Byte >[]()[][])
Data buffer received from connected client device.
length (Int32)
Valid length of data within the buffer.
Remarks
This method should be overriden by derived classes in order to handle incoming commands, specifically handling requests for configuration frames.


DigitalMaskValue Property

DigitalMaskValue Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► DigitalMaskValue
Gets or sets the digital mask value made available in configuration frames for use with digital values published by this PhasorDataConcentratorBase.
Declaration Syntax
C# Visual Basic Visual C++
public uint DigitalMaskValue { get; set; }
Public Property DigitalMaskValue As UInteger
    Get
    Set
public:
property unsigned int DigitalMaskValue {
    unsigned int get ();
    void set (unsigned int value);
}
Remarks
This value represents two mask words for use with digital status values. In IEEE C37.118 configuration frames, the two 16-bit words that make up a digital mask value are provided for each defined digital word. Note that this value represents the default value that will be used if user has not specified a value for an individual device. The low word will be used to indicate the normal status of the digital inputs by returning a 0 when exclusive ORed (XOR) with the status word. The high word will indicate the current valid inputs to the PMU by having a bit set in the binary position corresponding to the digital input and all other bits set to 0. If digital status words are used for something other than boolean status indications, the use is left to the user.


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► Dispose(Boolean)
Releases the unmanaged resources used by the PhasorDataConcentratorBase object and optionally releases the managed resources.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true to release both managed and unmanaged resources; false to release only unmanaged resources.


GetConnectionID Method (server, clientID)

GetConnectionID Method (server, clientID)
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► GetConnectionID(IServer, Guid)
Gets connection ID (i.e., IP:Port) for specified clientID.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual string GetConnectionID(
    IServer server,
    Guid clientID
)
Protected Overridable Function GetConnectionID ( _
    server As IServer, _
    clientID As Guid _
) As String
protected:
virtual String^ GetConnectionID(
    IServer^ server,
    Guid clientID
)
Parameters
server (IServer)
Server connection of associated clientID.
clientID (Guid)
Guid of client for ID lookup.
Return Value
Connection ID (i.e., IP:Port) for specified clientID.


GetHashCode Method

GetHashCode Method
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► GetHashCode()()()()
Returns the hash code for this instance.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
A 32-bit signed integer hash code.


GetSignalReference Method

GetSignalReference Method
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► GetSignalReference()()()()
Members
Icon | Member | Description
 | GetSignalReference(SignalKind) | Get signal reference for specified SignalKind.
 | GetSignalReference(SignalKind, Int32, Int32) | Get signal reference for specified SignalKind and index.


GetSignalReference Method (type)

GetSignalReference Method (type)
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► GetSignalReference(SignalKind)
Get signal reference for specified SignalKind.
Declaration Syntax
C# Visual Basic Visual C++
public string GetSignalReference(
    SignalKind type
)
Public Function GetSignalReference ( _
    type As SignalKind _
) As String
public:
String^ GetSignalReference(
    SignalKind type
)
Parameters
type (SignalKind)
SignalKind to request signal reference for.
Return Value
Signal reference of given SignalKind.


GetSignalReference Method (type, index, count)

GetSignalReference Method (type, index, count)
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► GetSignalReference(SignalKind, Int32, Int32)
Get signal reference for specified SignalKind and index.
Declaration Syntax
C# Visual Basic Visual C++
public string GetSignalReference(
    SignalKind type,
    int index,
    int count
)
Public Function GetSignalReference ( _
    type As SignalKind, _
    index As Integer, _
    count As Integer _
) As String
public:
String^ GetSignalReference(
    SignalKind type,
    int index,
    int count
)
Parameters
type (SignalKind)
SignalKind to request signal reference for.
index (Int32)
Index SignalKind to request signal reference for.
count (Int32)
Number of signals defined for this SignalKind.
Return Value
Signal reference of given SignalKind and index.


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► IDCode
Gets ID code defined for this PhasorDataConcentratorBase parsed from the ConnectionString()()()().
Declaration Syntax
C# Visual Basic Visual C++
public ushort IDCode { get; }
Public ReadOnly Property IDCode As UShort
    Get
public:
property unsigned short IDCode {
    unsigned short get ();
}


Initialize Method

Initialize Method
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► Initialize()()()()
Initializes PhasorDataConcentratorBase.
Declaration Syntax
C# Visual Basic Visual C++
public override void Initialize()
Public Overrides Sub Initialize
public:
virtual void Initialize() override


MaximumLatency Property

MaximumLatency Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► MaximumLatency
Gets the maximum latency in milliseconds over the last test interval.
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumLatency { get; }
Public ReadOnly Property MaximumLatency As Integer
    Get
public:
property int MaximumLatency {
    int get ();
}


MinimumLatency Property

MinimumLatency Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► MinimumLatency
Gets the minimum latency in milliseconds over the last test interval.
Declaration Syntax
C# Visual Basic Visual C++
public int MinimumLatency { get; }
Public ReadOnly Property MinimumLatency As Integer
    Get
public:
property int MinimumLatency {
    int get ();
}


NominalFrequency Property

NominalFrequency Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► NominalFrequency
Gets or sets the nominal LineFrequency defined for this PhasorDataConcentratorBase.
Declaration Syntax
C# Visual Basic Visual C++
public LineFrequency NominalFrequency { get; set; }
Public Property NominalFrequency As LineFrequency
    Get
    Set
public:
property LineFrequency NominalFrequency {
    LineFrequency get ();
    void set (LineFrequency value);
}


ProcessDataValidFlag Property

ProcessDataValidFlag Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► ProcessDataValidFlag
Gets or sets flag that determines if the data valid flag assignments should be processed during frame publication.
Declaration Syntax
C# Visual Basic Visual C++
public bool ProcessDataValidFlag { get; set; }
Public Property ProcessDataValidFlag As Boolean
    Get
    Set
public:
property bool ProcessDataValidFlag {
    bool get ();
    void set (bool value);
}
Remarks
In cases where client applications ignore the data validity flag, setting this flag to false will provide a slight processing optimization, especially useful on very large data streams.


PublishFrame Method (frame, index)

PublishFrame Method (frame, index)
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► PublishFrame(IFrame, Int32)
Publish IFrame of time-aligned collection of IMeasurement values that arrived within the concentrator's defined LagTime()()()().
Declaration Syntax
C# Visual Basic Visual C++
protected override void PublishFrame(
    IFrame frame,
    int index
)
Protected Overrides Sub PublishFrame ( _
    frame As IFrame, _
    index As Integer _
)
protected:
virtual void PublishFrame(
    IFrame^ frame,
    int index
) override
Parameters
frame (IFrame)
IFrame of measurements with the same timestamp that arrived within LagTime()()()() that are ready for processing.
index (Int32)
Index of IFrame within a second ranging from zero to FramesPerSecond()()()() - 1.


QueueMeasurementForProcessing Method (measurement)

QueueMeasurementForProcessing Method (measurement)
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► QueueMeasurementForProcessing(IMeasurement)
Queues a single measurement for processing.
Declaration Syntax
C# Visual Basic Visual C++
public override void QueueMeasurementForProcessing(
    IMeasurement measurement
)
Public Overrides Sub QueueMeasurementForProcessing ( _
    measurement As IMeasurement _
)
public:
virtual void QueueMeasurementForProcessing(
    IMeasurement^ measurement
) override
Parameters
measurement (IMeasurement)
Measurement to queue for processing.


QueueMeasurementsForProcessing Method (measurements)

QueueMeasurementsForProcessing Method (measurements)
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► QueueMeasurementsForProcessing(IEnumerable<(Of <<'(IMeasurement>)>>))
Queues a collection of measurements for processing.
Declaration Syntax
C# Visual Basic Visual C++
public override void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement> measurements
)
Public Overrides Sub QueueMeasurementsForProcessing ( _
    measurements As IEnumerable(Of IMeasurement) _
)
public:
virtual void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement^>^ measurements
) override
Parameters
measurements (IEnumerable <(Of <(<'IMeasurement>)>)>)
Collection of measurements to queue for processing.


ResetLatencyCounters Method

ResetLatencyCounters Method
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► ResetLatencyCounters()()()()
Resets counters related to latency calculations.
Declaration Syntax
C# Visual Basic Visual C++
public void ResetLatencyCounters()
Public Sub ResetLatencyCounters
public:
void ResetLatencyCounters()


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► Start()()()()
Starts the PhasorDataConcentratorBase, if it is not already running.
Declaration Syntax
C# Visual Basic Visual C++
public override void Start()
Public Overrides Sub Start
public:
virtual void Start() override


StartDataChannel Method

StartDataChannel Method
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► StartDataChannel()()()()
Starts the PhasorDataConcentratorBase real-time data stream.
Declaration Syntax
C# Visual Basic Visual C++
[AdapterCommandAttribute("Manually starts the real-time data stream.")]
public virtual void StartDataChannel()
<AdapterCommandAttribute("Manually starts the real-time data stream.")> _
Public Overridable Sub StartDataChannel
[AdapterCommandAttribute(L"Manually starts the real-time data stream.")]
public:
virtual void StartDataChannel()
Remarks
If AutoStartDataChannel is false, this method will allow host administrator to manually start the data channel, thus enabling the real-time data stream. If command channel is defined, it will be unaffected.


Status Property

Status Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► Status
Returns the detailed status of this PhasorDataConcentratorBase.
Declaration Syntax
C# Visual Basic Visual C++
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
public:
virtual property String^ Status {
    String^ get () override;
}


Stop Method

Stop Method
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► Stop()()()()
Stops the PhasorDataConcentratorBase.
Declaration Syntax
C# Visual Basic Visual C++
public override void Stop()
Public Overrides Sub Stop
public:
virtual void Stop() override


StopDataChannel Method

StopDataChannel Method
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► StopDataChannel()()()()
Stops the PhasorDataConcentratorBase real-time data stream.
Declaration Syntax
C# Visual Basic Visual C++
[AdapterCommandAttribute("Manually stops the real-time data stream.")]
public virtual void StopDataChannel()
<AdapterCommandAttribute("Manually stops the real-time data stream.")> _
Public Overridable Sub StopDataChannel
[AdapterCommandAttribute(L"Manually stops the real-time data stream.")]
public:
virtual void StopDataChannel()
Remarks
This method will allow host administrator to manually stop the data channel, thus disabling the real-time data stream. If command channel is defined, it will be unaffected.


SupportsTemporalProcessing Property

SupportsTemporalProcessing Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► SupportsTemporalProcessing
Gets the flag indicating if this adapter supports temporal processing.
Declaration Syntax
C# Visual Basic Visual C++
public override bool SupportsTemporalProcessing { get; }
Public Overrides ReadOnly Property SupportsTemporalProcessing As Boolean
    Get
public:
virtual property bool SupportsTemporalProcessing {
    bool get () override;
}
Remarks
Since the concentrator is designed to open sockets and produce data streams, it is expected that this would not be desired in a temporal data streaming session.


UpdateConfiguration Method

UpdateConfiguration Method
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► UpdateConfiguration()()()()
Reloads the configuration for this PhasorDataConcentratorBase.
Declaration Syntax
C# Visual Basic Visual C++
[AdapterCommandAttribute("Reloads the phasor data concentrator configuration.")]
public void UpdateConfiguration()
<AdapterCommandAttribute("Reloads the phasor data concentrator configuration.")> _
Public Sub UpdateConfiguration
[AdapterCommandAttribute(L"Reloads the phasor data concentrator configuration.")]
public:
void UpdateConfiguration()


VoltageScalingValue Property

VoltageScalingValue Property
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► VoltageScalingValue
Gets or sets the integer scaling value to apply to voltage values published by this PhasorDataConcentratorBase.
Declaration Syntax
C# Visual Basic Visual C++
public uint VoltageScalingValue { get; set; }
Public Property VoltageScalingValue As UInteger
    Get
    Set
public:
property unsigned int VoltageScalingValue {
    unsigned int get ();
    void set (unsigned int value);
}
Remarks
Typically only the lower 24-bits will be used to scale voltage values in 10^–5 volts per bit. Note that this value represents the default value that will be used if user has not specified a value for an individual device.


PhasorDefinitionBase Class

PhasorDefinitionBase Class
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionBase
Represents the common implementation of the protocol independent definition of a IPhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class PhasorDefinitionBase : ChannelDefinitionBase,
    IPhasorDefinition, IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IChannelDefinition>, IComparable<IChannelDefinition>, IComparable
<SerializableAttribute> _
Public MustInherit Class PhasorDefinitionBase _
    Inherits ChannelDefinitionBase _
    Implements IPhasorDefinition, IChannelDefinition, IChannel, ISupportBinaryImage,  _
    ISerializable, IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition),  _
    IComparable
[SerializableAttribute]
public ref class PhasorDefinitionBase abstract : public ChannelDefinitionBase,
    IPhasorDefinition, IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IChannelDefinition^>, IComparable<IChannelDefinition^>, IComparable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorDefinitionBase(IConfigurationCell) | Creates a new PhasorDefinitionBase.
 | PhasorDefinitionBase(IConfigurationCell, String, UInt32, Double, PhasorType, IPhasorDefinition) | Creates a new PhasorDefinitionBase from specified parameters.
 | PhasorDefinitionBase(SerializationInfo, StreamingContext) | Creates a new PhasorDefinitionBase from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorDefinitionBase object. (Overrides ChannelDefinitionBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Overrides ChannelDefinitionBase.DataFormat.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Parent | Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase.
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this PhasorDefinitionBase. (Overrides ChannelDefinitionBase.ToString()()()().)
 | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any).
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | PhasorDefinitionBase
 |  |  |  |  | PhasorDefinition
 |  |  |  |  | PhasorDefinition
 |  |  |  |  | PhasorDefinition
 |  |  |  |  | PhasorDefinition
 |  |  |  |  | PhasorDefinition
 |  |  |  |  | PhasorDefinition
 |  |  |  |  | PhasorDefinition


PhasorDefinitionBase Constructor

PhasorDefinitionBase Constructor
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionBase ► PhasorDefinitionBase()()()()
Members
Icon | Member | Description
 | PhasorDefinitionBase(IConfigurationCell) | Creates a new PhasorDefinitionBase.
 | PhasorDefinitionBase(IConfigurationCell, String, UInt32, Double, PhasorType, IPhasorDefinition) | Creates a new PhasorDefinitionBase from specified parameters.
 | PhasorDefinitionBase(SerializationInfo, StreamingContext) | Creates a new PhasorDefinitionBase from serialization parameters.


PhasorDefinitionBase Constructor (info, context)

PhasorDefinitionBase Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionBase ► PhasorDefinitionBase(SerializationInfo, StreamingContext)
Creates a new PhasorDefinitionBase from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorDefinitionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorDefinitionBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


PhasorDefinitionBase Constructor (parent)

PhasorDefinitionBase Constructor (parent)
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionBase ► PhasorDefinitionBase(IConfigurationCell)
Creates a new PhasorDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorDefinitionBase(
    IConfigurationCell parent
)
Protected Sub New ( _
    parent As IConfigurationCell _
)
protected:
PhasorDefinitionBase(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this PhasorDefinitionBase.


PhasorDefinitionBase Constructor (parent, label, scale, offset, type, voltageReference)

PhasorDefinitionBase Constructor (parent, label, scale, offset, type, voltageReference)
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionBase ► PhasorDefinitionBase(IConfigurationCell, String, UInt32, Double, PhasorType, IPhasorDefinition)
Creates a new PhasorDefinitionBase from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorDefinitionBase(
    IConfigurationCell parent,
    string label,
    uint scale,
    double offset,
    PhasorType type,
    IPhasorDefinition voltageReference
)
Protected Sub New ( _
    parent As IConfigurationCell, _
    label As String, _
    scale As UInteger, _
    offset As Double, _
    type As PhasorType, _
    voltageReference As IPhasorDefinition _
)
protected:
PhasorDefinitionBase(
    IConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset,
    PhasorType type,
    IPhasorDefinition^ voltageReference
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this PhasorDefinitionBase.
label (String)
The label of this PhasorDefinitionBase.
scale (UInt32)
The integer scaling value of this PhasorDefinitionBase.
offset (Double)
The offset of this PhasorDefinitionBase.
type (PhasorType)
The PhasorType of this PhasorDefinitionBase.
voltageReference (IPhasorDefinition)
The associated IPhasorDefinition that represents the voltage reference (if any).


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionBase ► Attributes
Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorDefinitionBase object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


CoordinateFormat Property

CoordinateFormat Property
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionBase ► CoordinateFormat
Gets or sets the CoordinateFormat of this PhasorDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual CoordinateFormat CoordinateFormat { get; }
Public Overridable ReadOnly Property CoordinateFormat As CoordinateFormat
    Get
public:
virtual property CoordinateFormat CoordinateFormat {
    CoordinateFormat get ();
}


DataFormat Property

DataFormat Property
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionBase ► DataFormat
Gets the DataFormat of this PhasorDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat DataFormat { get; }
Public Overrides ReadOnly Property DataFormat As DataFormat
    Get
public:
virtual property DataFormat DataFormat {
    DataFormat get () override;
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


PhasorType Property

PhasorType Property
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionBase ► PhasorType
Gets or sets the PhasorType of this PhasorDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual PhasorType PhasorType { get; set; }
Public Overridable Property PhasorType As PhasorType
    Get
    Set
public:
virtual property PhasorType PhasorType {
    PhasorType get ();
    void set (PhasorType value);
}


ToString Method

ToString Method
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionBase ► ToString()()()()
Gets the string respresentation of this PhasorDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
String respresentation of this PhasorDefinitionBase.


VoltageReference Property

VoltageReference Property
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionBase ► VoltageReference
Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any).
Declaration Syntax
C# Visual Basic Visual C++
public virtual IPhasorDefinition VoltageReference { get; set; }
Public Overridable Property VoltageReference As IPhasorDefinition
    Get
    Set
public:
virtual property IPhasorDefinition^ VoltageReference {
    IPhasorDefinition^ get ();
    void set (IPhasorDefinition^ value);
}
Remarks
This only applies to current phasors.


PhasorDefinitionCollection Class

PhasorDefinitionCollection Class
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionCollection
Represents a protocol independent collection of IPhasorDefinition objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PhasorDefinitionCollection : ChannelDefinitionCollectionBase<IPhasorDefinition>
<SerializableAttribute> _
Public Class PhasorDefinitionCollection _
    Inherits ChannelDefinitionCollectionBase(Of IPhasorDefinition)
[SerializableAttribute]
public ref class PhasorDefinitionCollection : public ChannelDefinitionCollectionBase<IPhasorDefinition^>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorDefinitionCollection(Int32) | Creates a new PhasorDefinitionCollection using specified lastValidIndex.
 | PhasorDefinitionCollection(SerializationInfo, StreamingContext) | Creates a new PhasorDefinitionCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelDefinitionCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelDefinitionCollectionBase<(Of <(<'T>)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelDefinitionCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelDefinitionCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelDefinitionCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' T >)>)>
 |  | ChannelCollectionBase <(Of <(<' T >)>)>
 |  |  | ChannelDefinitionCollectionBase <(Of <(<' IPhasorDefinition >)>)>
 |  |  |  | PhasorDefinitionCollection


PhasorDefinitionCollection Constructor

PhasorDefinitionCollection Constructor
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionCollection ► PhasorDefinitionCollection()()()()
Members
Icon | Member | Description
 | PhasorDefinitionCollection(Int32) | Creates a new PhasorDefinitionCollection using specified lastValidIndex.
 | PhasorDefinitionCollection(SerializationInfo, StreamingContext) | Creates a new PhasorDefinitionCollection from serialization parameters.


PhasorDefinitionCollection Constructor (lastValidIndex)

PhasorDefinitionCollection Constructor (lastValidIndex)
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionCollection ► PhasorDefinitionCollection(Int32)
Creates a new PhasorDefinitionCollection using specified lastValidIndex.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinitionCollection(
    int lastValidIndex
)
Public Sub New ( _
    lastValidIndex As Integer _
)
public:
PhasorDefinitionCollection(
    int lastValidIndex
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


PhasorDefinitionCollection Constructor (info, context)

PhasorDefinitionCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionCollection ► PhasorDefinitionCollection(SerializationInfo, StreamingContext)
Creates a new PhasorDefinitionCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorDefinitionCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorDefinitionCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


PhasorMeasurementMapper Class

PhasorMeasurementMapper Class
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper
Represents an IInputAdapter used to map measured values from a connection to a phasor measurement device to new IMeasurement values.
Declaration Syntax
C# Visual Basic Visual C++
public class PhasorMeasurementMapper : InputAdapterBase
Public Class PhasorMeasurementMapper _
    Inherits InputAdapterBase
public ref class PhasorMeasurementMapper : public InputAdapterBase
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorMeasurementMapper()()()() | Creates a new PhasorMeasurementMapper.
 | AccessID | Gets or sets access ID (or ID code) for this device connection which is often necessary in order to make a connection to some phasor protocols.
 | ActualDataRate | Gets the actual data rate.
 | ActualFrameRate | Gets the actual frame rate.
 | AllowUseOfCachedConfiguration | Gets or sets flag that determines if use of cached configuration during initial connection is allowed when a configuration has not been received within the data loss interval.
 | AssignParentCollection(IAdapterCollection) | (Inherited from AdapterBase.)
 | AttemptConnection()()()() | Attempts to connect to data input source. (Overrides InputAdapterBase.AttemptConnection()()()().)
 | AttemptDisconnection()()()() | Attempts to disconnect from data input source. (Overrides InputAdapterBase.AttemptDisconnection()()()().)
 | AutoStart()()()() | (Inherited from AdapterBase.)
 | AverageLatency | Gets the average latency in milliseconds over the last test interval.
 | ConfigurationCacheFileName | Gets the configuration cache file name, with path.
 | ConfigurationChanges | Gets the total number of received configurations.
 | ConnectionAttemptInterval()()()() | (Inherited from InputAdapterBase.)
 | ConnectionAttempts | Gets the total number of connection attempts.
 | ConnectionString()()()() | (Inherited from AdapterBase.)
 | CRCErrors | Gets the total number of CRC errors that have been encountered by the the current mapper connection.
 | DataSource()()()() | (Inherited from AdapterBase.)
 | DefinedDevices | Gets an enumeration of all defined system devices (regardless of ID or label based definition)
 | DefinedFrameRate | Gets the defined frame rate.
 | Dispose(Boolean) | Releases the unmanaged resources used by the PhasorMeasurementMapper object and optionally releases the managed resources. (Overrides InputAdapterBase.Dispose(Boolean).)
 | Dispose()()()() | (Inherited from AdapterBase.)
 | Disposed()()()() | (Inherited from AdapterBase.)
 | Enabled()()()() | (Inherited from AdapterBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtractFrameMeasurements(IDataFrame) | Extract frame measurements and add expose them via the NewMeasurements()()()() event.
 | Finalize()()()() | (Inherited from AdapterBase.)
 | FrameParser | Gets or sets reference to MultiProtocolFrameParser, attaching and/or detaching to events as needed.
 | GetHashCode()()()() | Returns the hash code for this instance. (Overrides AdapterBase.GetHashCode()()()().)
 | GetShortStatus(Int32) | Gets a short one-line status of this PhasorMeasurementMapper. (Overrides AdapterBase.GetShortStatus(Int32).)
 | GetSignalReference(SignalKind) | Get signal reference for specified SignalKind.
 | GetSignalReference(SignalKind, Int32, Int32) | Get signal reference for specified SignalKind and index.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID()()()() | (Inherited from AdapterBase.)
 | IncrementProcessedMeasurements(Int64) | (Inherited from AdapterBase.)
 | InitializationTimeout()()()() | (Inherited from AdapterBase.)
 | Initialize()()()() | Intializes PhasorMeasurementMapper. (Overrides InputAdapterBase.Initialize()()()().)
 | Initialized()()()() | (Inherited from AdapterBase.)
 | InputMeasurementKeys()()()() | (Inherited from AdapterBase.)
 | InputMeasurementKeysUpdated()()()() | (Inherited from AdapterBase.)
 | IsConcentrator | Gets flag that determines if device being mapped is a concentrator (i.e., data from multiple devices combined together from the connected device).
 | IsConnected()()()() | (Inherited from InputAdapterBase.)
 | IsInputMeasurement(MeasurementKey) | (Inherited from AdapterBase.)
 | LastReportTime | Gets or set last report time for current mapper connection.
 | LoadCachedConfiguration()()()() | Attempts to load the last known good configuration.
 | LoadConfiguration(String) | Attempts to load the specified configuration.
 | MapMeasurementAttributes(ICollection<(Of <<'(IMeasurement>)>>), String, IMeasurement) | Map parsed measurement value to defined measurement attributes (i.e., assign meta-data to parsed measured value).
 | MaximumLatency | Gets the maximum latency in milliseconds over the last test interval.
 | MeasurementReportingInterval()()()() | (Inherited from AdapterBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumLatency | Gets the minimum latency in milliseconds over the last test interval.
 | MissingFrames | Gets the total number of frames that have been missed by the current mapper connection.
 | Name()()()() | (Inherited from AdapterBase.)
 | NewMeasurements()()()() | (Inherited from InputAdapterBase.)
 | OnConnected()()()() | (Inherited from InputAdapterBase.)
 | OnDisconnected()()()() | (Inherited from InputAdapterBase.)
 | OnInputMeasurementKeysUpdated()()()() | (Inherited from AdapterBase.)
 | OnNewMeasurements(ICollection<(Of <<'(IMeasurement>)>>)) | (Inherited from InputAdapterBase.)
 | OnOutputMeasurementsUpdated()()()() | (Inherited from AdapterBase.)
 | OnProcessException(Exception) | (Inherited from InputAdapterBase.)
 | OnStatusMessage(String) | (Inherited from AdapterBase.)
 | OnStatusMessage(String, array<Object>[]()[][]) | (Inherited from AdapterBase.)
 | OutOfOrderFrames | Gets the total number frames that came in out of order from the current mapper connection.
 | OutputMeasurements()()()() | (Inherited from AdapterBase.)
 | OutputMeasurementsUpdated()()()() | (Inherited from AdapterBase.)
 | OutputSourceIDs()()()() | (Inherited from InputAdapterBase.)
 | Parent()()()() | (Inherited from AdapterBase.)
 | ProcessedMeasurements()()()() | (Inherited from AdapterBase.)
 | ProcessException()()()() | (Inherited from AdapterBase.)
 | ProcessingInterval()()()() | (Inherited from AdapterBase.)
 | ProcessMeasurementFilter()()()() | (Inherited from AdapterBase.)
 | RequestedOutputMeasurementKeys()()()() | (Inherited from InputAdapterBase.)
 | ResetDeviceStatistics(UInt16) | Resets the statistics of the specified device associated with this connection.
 | ResetLatencyCounters()()()() | Resets counters related to latency calculations.
 | ResetStatistics()()()() | Resets the statistics of all devices associated with this connection.
 | RunTime()()()() | (Inherited from AdapterBase.)
 | SendCommand(DeviceCommand) | Sends the specified DeviceCommand to the current device connection.
 | SetInitializedState(Boolean) | (Inherited from AdapterBase.)
 | SetTemporalConstraint(String, String, String) | (Inherited from AdapterBase.)
 | Settings()()()() | (Inherited from AdapterBase.)
 | SharedMapping | Gets or sets acronym of other device for which to assume a shared mapping.
 | SharedMappingID | Returns ID of associated device with shared mapping or ID()()()() of this PhasorMeasurementMapper if no shared mapping is defined.
 | Start()()()() | (Inherited from InputAdapterBase.)
 | StartTime()()()() | (Inherited from AdapterBase.)
 | StartTimeConstraint()()()() | (Inherited from AdapterBase.)
 | Status | Returns the detailed status of the data input source. (Overrides InputAdapterBase.Status()()()().)
 | StatusMessage()()()() | (Inherited from AdapterBase.)
 | Stop()()()() | (Inherited from InputAdapterBase.)
 | StopTime()()()() | (Inherited from AdapterBase.)
 | StopTimeConstraint()()()() | (Inherited from AdapterBase.)
 | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Overrides AdapterBase.SupportsTemporalProcessing()()()().)
 | TimeAdjustmentTicks | Gets or sets ticks used to manually adjust time of this PhasorMeasurementMapper.
 | TimeZone | Gets or sets time zone of this PhasorMeasurementMapper.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalConfigurationFrames | Gets the total number of received configuration frames.
 | TotalDataFrames | Gets the total number of received data frames.
 | TotalFrames | Gets the the total number of frames that have been received by the current mapper connection.
 | TotalHeaderFrames | Gets the total number of received header frames.
 | UseAsyncConnect | Gets flag that determines if the data input connects asynchronously. (Overrides InputAdapterBase.UseAsyncConnect()()()().)
 | WaitForInitialize(Int32) | (Inherited from AdapterBase.)
Inheritance Hierarchy
Object
 | AdapterBase
 |  | InputAdapterBase
 |  |  | PhasorMeasurementMapper


PhasorMeasurementMapper Constructor

PhasorMeasurementMapper Constructor
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► PhasorMeasurementMapper()()()()
Creates a new PhasorMeasurementMapper.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorMeasurementMapper()
Public Sub New
public:
PhasorMeasurementMapper()


AccessID Property

AccessID Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► AccessID
Gets or sets access ID (or ID code) for this device connection which is often necessary in order to make a connection to some phasor protocols.
Declaration Syntax
C# Visual Basic Visual C++
public ushort AccessID { get; set; }
Public Property AccessID As UShort
    Get
    Set
public:
property unsigned short AccessID {
    unsigned short get ();
    void set (unsigned short value);
}


ActualDataRate Property

ActualDataRate Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► ActualDataRate
Gets the actual data rate.
Declaration Syntax
C# Visual Basic Visual C++
public double ActualDataRate { get; }
Public ReadOnly Property ActualDataRate As Double
    Get
public:
property double ActualDataRate {
    double get ();
}


ActualFrameRate Property

ActualFrameRate Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► ActualFrameRate
Gets the actual frame rate.
Declaration Syntax
C# Visual Basic Visual C++
public double ActualFrameRate { get; }
Public ReadOnly Property ActualFrameRate As Double
    Get
public:
property double ActualFrameRate {
    double get ();
}


AllowUseOfCachedConfiguration Property

AllowUseOfCachedConfiguration Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► AllowUseOfCachedConfiguration
Gets or sets flag that determines if use of cached configuration during initial connection is allowed when a configuration has not been received within the data loss interval.
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowUseOfCachedConfiguration { get; set; }
Public Property AllowUseOfCachedConfiguration As Boolean
    Get
    Set
public:
property bool AllowUseOfCachedConfiguration {
    bool get ();
    void set (bool value);
}


AttemptConnection Method

AttemptConnection Method
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► AttemptConnection()()()()
Attempts to connect to data input source.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AttemptConnection()
Protected Overrides Sub AttemptConnection
protected:
virtual void AttemptConnection() override


AttemptDisconnection Method

AttemptDisconnection Method
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► AttemptDisconnection()()()()
Attempts to disconnect from data input source.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AttemptDisconnection()
Protected Overrides Sub AttemptDisconnection
protected:
virtual void AttemptDisconnection() override


AverageLatency Property

AverageLatency Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► AverageLatency
Gets the average latency in milliseconds over the last test interval.
Declaration Syntax
C# Visual Basic Visual C++
public int AverageLatency { get; }
Public ReadOnly Property AverageLatency As Integer
    Get
public:
property int AverageLatency {
    int get ();
}


ConfigurationCacheFileName Property

ConfigurationCacheFileName Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► ConfigurationCacheFileName
Gets the configuration cache file name, with path.
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigurationCacheFileName { get; }
Public ReadOnly Property ConfigurationCacheFileName As String
    Get
public:
property String^ ConfigurationCacheFileName {
    String^ get ();
}


ConfigurationChanges Property

ConfigurationChanges Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► ConfigurationChanges
Gets the total number of received configurations.
Declaration Syntax
C# Visual Basic Visual C++
public long ConfigurationChanges { get; }
Public ReadOnly Property ConfigurationChanges As Long
    Get
public:
property long long ConfigurationChanges {
    long long get ();
}


ConnectionAttempts Property

ConnectionAttempts Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► ConnectionAttempts
Gets the total number of connection attempts.
Declaration Syntax
C# Visual Basic Visual C++
public long ConnectionAttempts { get; }
Public ReadOnly Property ConnectionAttempts As Long
    Get
public:
property long long ConnectionAttempts {
    long long get ();
}


CRCErrors Property

CRCErrors Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► CRCErrors
Gets the total number of CRC errors that have been encountered by the the current mapper connection.
Declaration Syntax
C# Visual Basic Visual C++
public long CRCErrors { get; }
Public ReadOnly Property CRCErrors As Long
    Get
public:
property long long CRCErrors {
    long long get ();
}


DefinedDevices Property

DefinedDevices Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► DefinedDevices
Gets an enumeration of all defined system devices (regardless of ID or label based definition)
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<ConfigurationCell> DefinedDevices { get; }
Public ReadOnly Property DefinedDevices As IEnumerable(Of ConfigurationCell)
    Get
public:
property IEnumerable<ConfigurationCell^>^ DefinedDevices {
    IEnumerable<ConfigurationCell^>^ get ();
}


DefinedFrameRate Property

DefinedFrameRate Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► DefinedFrameRate
Gets the defined frame rate.
Declaration Syntax
C# Visual Basic Visual C++
public int DefinedFrameRate { get; }
Public ReadOnly Property DefinedFrameRate As Integer
    Get
public:
property int DefinedFrameRate {
    int get ();
}


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► Dispose(Boolean)
Releases the unmanaged resources used by the PhasorMeasurementMapper object and optionally releases the managed resources.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true to release both managed and unmanaged resources; false to release only unmanaged resources.


ExtractFrameMeasurements Method (frame)

ExtractFrameMeasurements Method (frame)
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► ExtractFrameMeasurements(IDataFrame)
Extract frame measurements and add expose them via the NewMeasurements()()()() event.
Declaration Syntax
C# Visual Basic Visual C++
protected void ExtractFrameMeasurements(
    IDataFrame frame
)
Protected Sub ExtractFrameMeasurements ( _
    frame As IDataFrame _
)
protected:
void ExtractFrameMeasurements(
    IDataFrame^ frame
)
Parameters
frame (IDataFrame)
Phasor data frame to extract measurements from.


FrameParser Property

FrameParser Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► FrameParser
Gets or sets reference to MultiProtocolFrameParser, attaching and/or detaching to events as needed.
Declaration Syntax
C# Visual Basic Visual C++
protected MultiProtocolFrameParser FrameParser { get; set; }
Protected Property FrameParser As MultiProtocolFrameParser
    Get
    Set
protected:
property MultiProtocolFrameParser^ FrameParser {
    MultiProtocolFrameParser^ get ();
    void set (MultiProtocolFrameParser^ value);
}


GetHashCode Method

GetHashCode Method
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► GetHashCode()()()()
Returns the hash code for this instance.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
A 32-bit signed integer hash code.


GetShortStatus Method (maxLength)

GetShortStatus Method (maxLength)
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► GetShortStatus(Int32)
Gets a short one-line status of this PhasorMeasurementMapper.
Declaration Syntax
C# Visual Basic Visual C++
public override string GetShortStatus(
    int maxLength
)
Public Overrides Function GetShortStatus ( _
    maxLength As Integer _
) As String
public:
virtual String^ GetShortStatus(
    int maxLength
) override
Parameters
maxLength (Int32)
Maximum number of available characters for display.
Return Value
A short one-line summary of the current status of this PhasorMeasurementMapper.


GetSignalReference Method

GetSignalReference Method
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► GetSignalReference()()()()
Members
Icon | Member | Description
 | GetSignalReference(SignalKind) | Get signal reference for specified SignalKind.
 | GetSignalReference(SignalKind, Int32, Int32) | Get signal reference for specified SignalKind and index.


GetSignalReference Method (type)

GetSignalReference Method (type)
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► GetSignalReference(SignalKind)
Get signal reference for specified SignalKind.
Declaration Syntax
C# Visual Basic Visual C++
public string GetSignalReference(
    SignalKind type
)
Public Function GetSignalReference ( _
    type As SignalKind _
) As String
public:
String^ GetSignalReference(
    SignalKind type
)
Parameters
type (SignalKind)
SignalKind to request signal reference for.
Return Value
Signal reference of given SignalKind.


GetSignalReference Method (type, index, count)

GetSignalReference Method (type, index, count)
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► GetSignalReference(SignalKind, Int32, Int32)
Get signal reference for specified SignalKind and index.
Declaration Syntax
C# Visual Basic Visual C++
public string GetSignalReference(
    SignalKind type,
    int index,
    int count
)
Public Function GetSignalReference ( _
    type As SignalKind, _
    index As Integer, _
    count As Integer _
) As String
public:
String^ GetSignalReference(
    SignalKind type,
    int index,
    int count
)
Parameters
type (SignalKind)
SignalKind to request signal reference for.
index (Int32)
Index SignalKind to request signal reference for.
count (Int32)
Number of signals defined for this SignalKind.
Return Value
Signal reference of given SignalKind and index.


Initialize Method

Initialize Method
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► Initialize()()()()
Intializes PhasorMeasurementMapper.
Declaration Syntax
C# Visual Basic Visual C++
public override void Initialize()
Public Overrides Sub Initialize
public:
virtual void Initialize() override


IsConcentrator Property

IsConcentrator Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► IsConcentrator
Gets flag that determines if device being mapped is a concentrator (i.e., data from multiple devices combined together from the connected device).
Declaration Syntax
C# Visual Basic Visual C++
public bool IsConcentrator { get; }
Public ReadOnly Property IsConcentrator As Boolean
    Get
public:
property bool IsConcentrator {
    bool get ();
}


LastReportTime Property

LastReportTime Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► LastReportTime
Gets or set last report time for current mapper connection.
Declaration Syntax
C# Visual Basic Visual C++
public Ticks LastReportTime { get; set; }
Public Property LastReportTime As Ticks
    Get
    Set
public:
property Ticks LastReportTime {
    Ticks get ();
    void set (Ticks value);
}


LoadCachedConfiguration Method

LoadCachedConfiguration Method
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► LoadCachedConfiguration()()()()
Attempts to load the last known good configuration.
Declaration Syntax
C# Visual Basic Visual C++
[AdapterCommandAttribute("Attempts to load the last known good configuration.")]
public void LoadCachedConfiguration()
<AdapterCommandAttribute("Attempts to load the last known good configuration.")> _
Public Sub LoadCachedConfiguration
[AdapterCommandAttribute(L"Attempts to load the last known good configuration.")]
public:
void LoadCachedConfiguration()


LoadConfiguration Method (configurationFileName)

LoadConfiguration Method (configurationFileName)
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► LoadConfiguration(String)
Attempts to load the specified configuration.
Declaration Syntax
C# Visual Basic Visual C++
[AdapterCommandAttribute("Attempts to load the specified configuration.")]
public void LoadConfiguration(
    string configurationFileName
)
<AdapterCommandAttribute("Attempts to load the specified configuration.")> _
Public Sub LoadConfiguration ( _
    configurationFileName As String _
)
[AdapterCommandAttribute(L"Attempts to load the specified configuration.")]
public:
void LoadConfiguration(
    String^ configurationFileName
)
Parameters
configurationFileName (String)
Path and file name containing serialized configuration.


MapMeasurementAttributes Method (mappedMeasurements, signalReference, parsedMeasurement)

MapMeasurementAttributes Method (mappedMeasurements, signalReference, parsedMeasurement)
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► MapMeasurementAttributes(ICollection<(Of <<'(IMeasurement>)>>), String, IMeasurement)
Map parsed measurement value to defined measurement attributes (i.e., assign meta-data to parsed measured value).
Declaration Syntax
C# Visual Basic Visual C++
protected void MapMeasurementAttributes(
    ICollection<IMeasurement> mappedMeasurements,
    string signalReference,
    IMeasurement parsedMeasurement
)
Protected Sub MapMeasurementAttributes ( _
    mappedMeasurements As ICollection(Of IMeasurement), _
    signalReference As String, _
    parsedMeasurement As IMeasurement _
)
protected:
void MapMeasurementAttributes(
    ICollection<IMeasurement^>^ mappedMeasurements,
    String^ signalReference,
    IMeasurement^ parsedMeasurement
)
Parameters
mappedMeasurements (ICollection <(Of <(<'IMeasurement>)>)>)
Destination collection for the mapped measurement values.
signalReference (String)
Derived SignalReference string for the parsed measurement value.
parsedMeasurement (IMeasurement)
The parsed IMeasurement value.
Remarks
This procedure is used to identify a parsed measurement value by its derived signal reference and apply the additional needed measurement meta-data attributes (i.e., ID, Source, Adder and Multiplier).


MaximumLatency Property

MaximumLatency Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► MaximumLatency
Gets the maximum latency in milliseconds over the last test interval.
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumLatency { get; }
Public ReadOnly Property MaximumLatency As Integer
    Get
public:
property int MaximumLatency {
    int get ();
}


MinimumLatency Property

MinimumLatency Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► MinimumLatency
Gets the minimum latency in milliseconds over the last test interval.
Declaration Syntax
C# Visual Basic Visual C++
public int MinimumLatency { get; }
Public ReadOnly Property MinimumLatency As Integer
    Get
public:
property int MinimumLatency {
    int get ();
}


MissingFrames Property

MissingFrames Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► MissingFrames
Gets the total number of frames that have been missed by the current mapper connection.
Declaration Syntax
C# Visual Basic Visual C++
public long MissingFrames { get; }
Public ReadOnly Property MissingFrames As Long
    Get
public:
property long long MissingFrames {
    long long get ();
}


OutOfOrderFrames Property

OutOfOrderFrames Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► OutOfOrderFrames
Gets the total number frames that came in out of order from the current mapper connection.
Declaration Syntax
C# Visual Basic Visual C++
public long OutOfOrderFrames { get; }
Public ReadOnly Property OutOfOrderFrames As Long
    Get
public:
property long long OutOfOrderFrames {
    long long get ();
}


ResetDeviceStatistics Method (idCode)

ResetDeviceStatistics Method (idCode)
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► ResetDeviceStatistics(UInt16)
Resets the statistics of the specified device associated with this connection.
Declaration Syntax
C# Visual Basic Visual C++
[AdapterCommandAttribute("Resets the statistics of the device with the specified ID code.")]
public void ResetDeviceStatistics(
    ushort idCode
)
<AdapterCommandAttribute("Resets the statistics of the device with the specified ID code.")> _
Public Sub ResetDeviceStatistics ( _
    idCode As UShort _
)
[AdapterCommandAttribute(L"Resets the statistics of the device with the specified ID code.")]
public:
void ResetDeviceStatistics(
    unsigned short idCode
)
Parameters
idCode (UInt16)
Integer ID code of device on which to reset statistics.


ResetLatencyCounters Method

ResetLatencyCounters Method
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► ResetLatencyCounters()()()()
Resets counters related to latency calculations.
Declaration Syntax
C# Visual Basic Visual C++
public void ResetLatencyCounters()
Public Sub ResetLatencyCounters
public:
void ResetLatencyCounters()


ResetStatistics Method

ResetStatistics Method
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► ResetStatistics()()()()
Resets the statistics of all devices associated with this connection.
Declaration Syntax
C# Visual Basic Visual C++
[AdapterCommandAttribute("Resets the statistics of all devices associated with this connection.")]
public void ResetStatistics()
<AdapterCommandAttribute("Resets the statistics of all devices associated with this connection.")> _
Public Sub ResetStatistics
[AdapterCommandAttribute(L"Resets the statistics of all devices associated with this connection.")]
public:
void ResetStatistics()


SendCommand Method (command)

SendCommand Method (command)
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► SendCommand(DeviceCommand)
Sends the specified DeviceCommand to the current device connection.
Declaration Syntax
C# Visual Basic Visual C++
[AdapterCommandAttribute("Sends the specified command to connected phasor device.")]
public void SendCommand(
    DeviceCommand command
)
<AdapterCommandAttribute("Sends the specified command to connected phasor device.")> _
Public Sub SendCommand ( _
    command As DeviceCommand _
)
[AdapterCommandAttribute(L"Sends the specified command to connected phasor device.")]
public:
void SendCommand(
    DeviceCommand command
)
Parameters
command (DeviceCommand)
DeviceCommand to send to connected device.


SharedMapping Property

SharedMapping Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► SharedMapping
Gets or sets acronym of other device for which to assume a shared mapping.
Declaration Syntax
C# Visual Basic Visual C++
public string SharedMapping { get; set; }
Public Property SharedMapping As String
    Get
    Set
public:
property String^ SharedMapping {
    String^ get ();
    void set (String^ value);
}
Remarks
Assigning acronym to this property automatically looks up ID of associated device.


SharedMappingID Property

SharedMappingID Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► SharedMappingID
Returns ID of associated device with shared mapping or ID()()()() of this PhasorMeasurementMapper if no shared mapping is defined.
Declaration Syntax
C# Visual Basic Visual C++
public uint SharedMappingID { get; }
Public ReadOnly Property SharedMappingID As UInteger
    Get
public:
property unsigned int SharedMappingID {
    unsigned int get ();
}


Status Property

Status Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► Status
Returns the detailed status of the data input source.
Declaration Syntax
C# Visual Basic Visual C++
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
public:
virtual property String^ Status {
    String^ get () override;
}


SupportsTemporalProcessing Property

SupportsTemporalProcessing Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► SupportsTemporalProcessing
Gets the flag indicating if this adapter supports temporal processing.
Declaration Syntax
C# Visual Basic Visual C++
public override bool SupportsTemporalProcessing { get; }
Public Overrides ReadOnly Property SupportsTemporalProcessing As Boolean
    Get
public:
virtual property bool SupportsTemporalProcessing {
    bool get () override;
}
Remarks
Since the phasor measurement mapper is designed to open sockets and connect to data streams, it is expected that this would not be desired in a temporal data streaming session.


TimeAdjustmentTicks Property

TimeAdjustmentTicks Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► TimeAdjustmentTicks
Gets or sets ticks used to manually adjust time of this PhasorMeasurementMapper.
Declaration Syntax
C# Visual Basic Visual C++
public Ticks TimeAdjustmentTicks { get; set; }
Public Property TimeAdjustmentTicks As Ticks
    Get
    Set
public:
property Ticks TimeAdjustmentTicks {
    Ticks get ();
    void set (Ticks value);
}
Remarks
This property will allow for precise time adjustments of connected devices should this be needed.


TimeZone Property

TimeZone Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► TimeZone
Gets or sets time zone of this PhasorMeasurementMapper.
Declaration Syntax
C# Visual Basic Visual C++
public TimeZoneInfo TimeZone { get; set; }
Public Property TimeZone As TimeZoneInfo
    Get
    Set
public:
property TimeZoneInfo^ TimeZone {
    TimeZoneInfo^ get ();
    void set (TimeZoneInfo^ value);
}
Remarks
If time zone of clock of connected device is not set to UTC, assigning this property with proper time zone will allow proper adjustment.


TotalConfigurationFrames Property

TotalConfigurationFrames Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► TotalConfigurationFrames
Gets the total number of received configuration frames.
Declaration Syntax
C# Visual Basic Visual C++
public long TotalConfigurationFrames { get; }
Public ReadOnly Property TotalConfigurationFrames As Long
    Get
public:
property long long TotalConfigurationFrames {
    long long get ();
}


TotalDataFrames Property

TotalDataFrames Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► TotalDataFrames
Gets the total number of received data frames.
Declaration Syntax
C# Visual Basic Visual C++
public long TotalDataFrames { get; }
Public ReadOnly Property TotalDataFrames As Long
    Get
public:
property long long TotalDataFrames {
    long long get ();
}


TotalFrames Property

TotalFrames Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► TotalFrames
Gets the the total number of frames that have been received by the current mapper connection.
Declaration Syntax
C# Visual Basic Visual C++
public long TotalFrames { get; }
Public ReadOnly Property TotalFrames As Long
    Get
public:
property long long TotalFrames {
    long long get ();
}


TotalHeaderFrames Property

TotalHeaderFrames Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► TotalHeaderFrames
Gets the total number of received header frames.
Declaration Syntax
C# Visual Basic Visual C++
public long TotalHeaderFrames { get; }
Public ReadOnly Property TotalHeaderFrames As Long
    Get
public:
property long long TotalHeaderFrames {
    long long get ();
}


UseAsyncConnect Property

UseAsyncConnect Property
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► UseAsyncConnect
Gets flag that determines if the data input connects asynchronously.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool UseAsyncConnect { get; }
Protected Overrides ReadOnly Property UseAsyncConnect As Boolean
    Get
protected:
virtual property bool UseAsyncConnect {
    bool get () override;
}


PhasorProtocol Enumeration

PhasorProtocol Enumeration
Namespaces ► TVA.PhasorProtocols ► PhasorProtocol
Phasor data protocols enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum PhasorProtocol
<SerializableAttribute> _
Public Enumeration PhasorProtocol
[SerializableAttribute]
public enum class PhasorProtocol
Members
Member | Description
IeeeC37_118V2 | IEEE C37.118-2011, R2 protocol.
IeeeC37_118V1 | IEEE C37.118-2005 protocol.
IeeeC37_118D6 | IEEE C37.118, draft 6 protocol.
Ieee1344 | IEEE 1344-1995 protocol.
BpaPdcStream | BPA PDCstream protocol.
FNet | Virgina Tech F-NET protocol.
SelFastMessage | SEL Fast Message protocol.
Macrodyne | Macrodyne protocol.
GetFormattedProtocolName | Returns display friendly protocol name.


PhasorType Enumeration

PhasorType Enumeration
Namespaces ► TVA.PhasorProtocols ► PhasorType
Phasor types enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum PhasorType
<SerializableAttribute> _
Public Enumeration PhasorType
[SerializableAttribute]
public enum class PhasorType
Members
Member | Description
Voltage | Voltage phasor.
Current | Current phasor.


PhasorValueBase Class

PhasorValueBase Class
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase
Represents the common implementation of the protocol independent representation of a phasor value.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class PhasorValueBase : ChannelValueBase<IPhasorDefinition>,
    IPhasorValue, IChannelValue<IPhasorDefinition>, IChannel, ISupportBinaryImage,
    ISerializable
<SerializableAttribute> _
Public MustInherit Class PhasorValueBase _
    Inherits ChannelValueBase(Of IPhasorDefinition) _
    Implements IPhasorValue, IChannelValue(Of IPhasorDefinition),  _
    IChannel, ISupportBinaryImage, ISerializable
[SerializableAttribute]
public ref class PhasorValueBase abstract : public ChannelValueBase<IPhasorDefinition^>,
    IPhasorValue, IChannelValue<IPhasorDefinition^>, IChannel, ISupportBinaryImage,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorValueBase(IDataCell, IPhasorDefinition) | Creates a new PhasorValueBase.
 | PhasorValueBase(IDataCell, IPhasorDefinition, Double, Double) | Creates a new PhasorValueBase from specified parameters.
 | PhasorValueBase(IDataCell, IPhasorDefinition, Angle, Double) | Creates a new PhasorValueBase from specified parameters.
 | PhasorValueBase(SerializationInfo, StreamingContext) | Creates a new PhasorValueBase from serialization parameters.
 | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorValueBase object. (Overrides ChannelValueBase <(Of <(<' IPhasorDefinition >)>)>.Attributes.)
 | AverageAngleValueFilter(IEnumerable<(Of <<'(IMeasurement>)>>)) | Calculates an average of the specified sequence of IMeasurement phase angle values.
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the PhasorValueBase object. (Overrides BinaryImageBase.BodyImage()()()().)
 | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBase.BodyLength()()()().)
 | CalculatePower(IPhasorValue, IPhasorValue) | Calculates watts from imaginary and real components of a voltage and current phasor.
 | CalculateVars(IPhasorValue, IPhasorValue) | Calculates vars (total volt-amperes of reactive power) from imaginary and real components of a voltage and current phasor.
 | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Overrides ChannelValueBase <(Of <(<' IPhasorDefinition >)>)>.CompositeValueCount.)
 | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the IChannelDefinition associated with this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this PhasorValueBase. (Overrides ChannelValueBase <(Of <(<' IPhasorDefinition >)>)>.GetCompositeValue(Int32).)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Overrides ChannelValueBase <(Of <(<' IPhasorDefinition >)>)>.GetMeasurementValueFilterFunction(Int32).)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelValueBase <(Of <(<' IPhasorDefinition >)>)>.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Imaginary | Gets or sets the imaginary value of this PhasorValueBase.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Overrides ChannelValueBase <(Of <(<' IPhasorDefinition >)>)>.IsEmpty.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase.
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the IDataCell parent of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides BinaryImageBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Real | Gets or sets the real value of this PhasorValueBase.
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the PhasorType of this PhasorValueBase.
 | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase.
 | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IPhasorDefinition >)>)>
 |  |  |  | PhasorValueBase
 |  |  |  |  | PhasorValue
 |  |  |  |  | PhasorValue
 |  |  |  |  | PhasorValue
 |  |  |  |  | PhasorValue
 |  |  |  |  | PhasorValue
 |  |  |  |  | PhasorValue


PhasorValueBase Constructor

PhasorValueBase Constructor
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► PhasorValueBase()()()()
Members
Icon | Member | Description
 | PhasorValueBase(IDataCell, IPhasorDefinition) | Creates a new PhasorValueBase.
 | PhasorValueBase(IDataCell, IPhasorDefinition, Double, Double) | Creates a new PhasorValueBase from specified parameters.
 | PhasorValueBase(IDataCell, IPhasorDefinition, Angle, Double) | Creates a new PhasorValueBase from specified parameters.
 | PhasorValueBase(SerializationInfo, StreamingContext) | Creates a new PhasorValueBase from serialization parameters.


PhasorValueBase Constructor (info, context)

PhasorValueBase Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► PhasorValueBase(SerializationInfo, StreamingContext)
Creates a new PhasorValueBase from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorValueBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorValueBase(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


PhasorValueBase Constructor (parent, phasorDefinition)

PhasorValueBase Constructor (parent, phasorDefinition)
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► PhasorValueBase(IDataCell, IPhasorDefinition)
Creates a new PhasorValueBase.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorValueBase(
    IDataCell parent,
    IPhasorDefinition phasorDefinition
)
Protected Sub New ( _
    parent As IDataCell, _
    phasorDefinition As IPhasorDefinition _
)
protected:
PhasorValueBase(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this PhasorValueBase.
phasorDefinition (IPhasorDefinition)
The IPhasorDefinition associated with this PhasorValueBase.


PhasorValueBase Constructor (parent, phasorDefinition, real, imaginary)

PhasorValueBase Constructor (parent, phasorDefinition, real, imaginary)
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► PhasorValueBase(IDataCell, IPhasorDefinition, Double, Double)
Creates a new PhasorValueBase from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorValueBase(
    IDataCell parent,
    IPhasorDefinition phasorDefinition,
    double real,
    double imaginary
)
Protected Sub New ( _
    parent As IDataCell, _
    phasorDefinition As IPhasorDefinition, _
    real As Double, _
    imaginary As Double _
)
protected:
PhasorValueBase(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition,
    double real,
    double imaginary
)
Parameters
parent (IDataCell)
The IDataCell parent of this PhasorValueBase.
phasorDefinition (IPhasorDefinition)
The IPhasorDefinition associated with this PhasorValueBase.
real (Double)
The real value of this PhasorValueBase.
imaginary (Double)
The imaginary value of this PhasorValueBase.


PhasorValueBase Constructor (parent, phasorDefinition, angle, magnitude)

PhasorValueBase Constructor (parent, phasorDefinition, angle, magnitude)
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► PhasorValueBase(IDataCell, IPhasorDefinition, Angle, Double)
Creates a new PhasorValueBase from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorValueBase(
    IDataCell parent,
    IPhasorDefinition phasorDefinition,
    Angle angle,
    double magnitude
)
Protected Sub New ( _
    parent As IDataCell, _
    phasorDefinition As IPhasorDefinition, _
    angle As Angle, _
    magnitude As Double _
)
protected:
PhasorValueBase(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition,
    Angle angle,
    double magnitude
)
Parameters
parent (IDataCell)
The IDataCell parent of this PhasorValueBase.
phasorDefinition (IPhasorDefinition)
The IPhasorDefinition associated with this PhasorValueBase.
angle (Angle)
The Angle value (a.k.a., the argument) of this PhasorValueBase, in radians.
magnitude (Double)
The magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase.


Angle Property

Angle Property
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► Angle
Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Angle Angle { get; set; }
Public Overridable Property Angle As Angle
    Get
    Set
public:
virtual property Angle Angle {
    Angle get ();
    void set (Angle value);
}


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► Attributes
Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorValueBase object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


AverageAngleValueFilter Method (source)

AverageAngleValueFilter Method (source)
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► AverageAngleValueFilter(IEnumerable<(Of <<'(IMeasurement>)>>))
Calculates an average of the specified sequence of IMeasurement phase angle values.
Declaration Syntax
C# Visual Basic Visual C++
public static double AverageAngleValueFilter(
    IEnumerable<IMeasurement> source
)
Public Shared Function AverageAngleValueFilter ( _
    source As IEnumerable(Of IMeasurement) _
) As Double
public:
static double AverageAngleValueFilter(
    IEnumerable<IMeasurement^>^ source
)
Parameters
source (IEnumerable <(Of <(<'IMeasurement>)>)>)
Sequence of IMeasurement values over which to run calculation.
Return Value
Average of the specified sequence of IMeasurement phase angle values.
Remarks
Phase angles wrap, so this algorithm takes the wrapping into account when calculating the average.


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► BodyImage
Gets the binary body image of the PhasorValueBase object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).


CalculatePower Method (voltage, current)

CalculatePower Method (voltage, current)
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► CalculatePower(IPhasorValue, IPhasorValue)
Calculates watts from imaginary and real components of a voltage and current phasor.
Declaration Syntax
C# Visual Basic Visual C++
public static Power CalculatePower(
    IPhasorValue voltage,
    IPhasorValue current
)
Public Shared Function CalculatePower ( _
    voltage As IPhasorValue, _
    current As IPhasorValue _
) As Power
public:
static Power CalculatePower(
    IPhasorValue^ voltage,
    IPhasorValue^ current
)
Parameters
voltage (IPhasorValue)
Voltage phasor.
current (IPhasorValue)
Current phasor.
Return Value
Calculated watts from imaginary and real components of specified voltage and current phasors.
Exceptions
Exception | Condition
ArgumentNullException | voltage and current must not be null.


CalculateVars Method (voltage, current)

CalculateVars Method (voltage, current)
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► CalculateVars(IPhasorValue, IPhasorValue)
Calculates vars (total volt-amperes of reactive power) from imaginary and real components of a voltage and current phasor.
Declaration Syntax
C# Visual Basic Visual C++
public static Power CalculateVars(
    IPhasorValue voltage,
    IPhasorValue current
)
Public Shared Function CalculateVars ( _
    voltage As IPhasorValue, _
    current As IPhasorValue _
) As Power
public:
static Power CalculateVars(
    IPhasorValue^ voltage,
    IPhasorValue^ current
)
Parameters
voltage (IPhasorValue)
Voltage phasor.
current (IPhasorValue)
Current phasor.
Return Value
Calculated vars (total volt-amperes of reactive power) from imaginary and real components of specified voltage and current phasors.
Remarks
Although the Power units class technically represents watts (i.e., real power) and vars (i.e., imaginary power) are properly expressed in volt-amperes reactive (VAr), the calculated result is still a representation of power and therefore the Power units class is used to express the return value leaving the consumer to properly apply the needed engineering units for display purposes.
Exceptions
Exception | Condition
ArgumentNullException | voltage and current must not be null.


CompositeValueCount Property

CompositeValueCount Property
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► CompositeValueCount
Gets total number of composite values that this PhasorValueBase provides.
Declaration Syntax
C# Visual Basic Visual C++
public override int CompositeValueCount { get; }
Public Overrides ReadOnly Property CompositeValueCount As Integer
    Get
public:
virtual property int CompositeValueCount {
    int get () override;
}


CoordinateFormat Property

CoordinateFormat Property
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► CoordinateFormat
Gets the CoordinateFormat of this PhasorValueBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual CoordinateFormat CoordinateFormat { get; }
Public Overridable ReadOnly Property CoordinateFormat As CoordinateFormat
    Get
public:
virtual property CoordinateFormat CoordinateFormat {
    CoordinateFormat get ();
}


GetCompositeValue Method (index)

GetCompositeValue Method (index)
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► GetCompositeValue(Int32)
Gets the specified composite value of this PhasorValueBase.
Declaration Syntax
C# Visual Basic Visual C++
public override double GetCompositeValue(
    int index
)
Public Overrides Function GetCompositeValue ( _
    index As Integer _
) As Double
public:
virtual double GetCompositeValue(
    int index
) override
Parameters
index (Int32)
Index of composite value to retrieve.
Return Value
A Double representing the composite value.
Remarks
Some ChannelValueBase<(Of <(<'T>)>)> implementations can contain more than one value, this method is used to abstractly expose each value.


GetMeasurementValueFilterFunction Method (index)

GetMeasurementValueFilterFunction Method (index)
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► GetMeasurementValueFilterFunction(Int32)
Gets function used to apply a downsampling filter over a sequence of IMeasurement values.
Declaration Syntax
C# Visual Basic Visual C++
public override MeasurementValueFilterFunction GetMeasurementValueFilterFunction(
    int index
)
Public Overrides Function GetMeasurementValueFilterFunction ( _
    index As Integer _
) As MeasurementValueFilterFunction
public:
virtual MeasurementValueFilterFunction^ GetMeasurementValueFilterFunction(
    int index
) override
Parameters
index (Int32)
Index of composite value for which to retrieve its filter function.
Return Value
Function used to apply a downsampling filter over a sequence of IMeasurement values.
Remarks
Phase angles averaging filter takes angle wrapping into account, magnitudes apply a standard average filter.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


Imaginary Property

Imaginary Property
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► Imaginary
Gets or sets the imaginary value of this PhasorValueBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Imaginary { get; set; }
Public Overridable Property Imaginary As Double
    Get
    Set
public:
virtual property double Imaginary {
    double get ();
    void set (double value);
}


IsEmpty Property

IsEmpty Property
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► IsEmpty
Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value.
Declaration Syntax
C# Visual Basic Visual C++
public override bool IsEmpty { get; }
Public Overrides ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get () override;
}


Magnitude Property

Magnitude Property
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► Magnitude
Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Magnitude { get; set; }
Public Overridable Property Magnitude As Double
    Get
    Set
public:
virtual property double Magnitude {
    double get ();
    void set (double value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).


Real Property

Real Property
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► Real
Gets or sets the real value of this PhasorValueBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Real { get; set; }
Public Overridable Property Real As Double
    Get
    Set
public:
virtual property double Real {
    double get ();
    void set (double value);
}


Type Property

Type Property
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► Type
Gets the PhasorType of this PhasorValueBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual PhasorType Type { get; }
Public Overridable ReadOnly Property Type As PhasorType
    Get
public:
virtual property PhasorType Type {
    PhasorType get ();
}


UnscaledImaginary Property

UnscaledImaginary Property
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► UnscaledImaginary
Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int UnscaledImaginary { get; set; }
Public Overridable Property UnscaledImaginary As Integer
    Get
    Set
public:
virtual property int UnscaledImaginary {
    int get ();
    void set (int value);
}


UnscaledReal Property

UnscaledReal Property
Namespaces ► TVA.PhasorProtocols ► PhasorValueBase ► UnscaledReal
Gets or sets the unscaled integer representation of the real value of this PhasorValueBase.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int UnscaledReal { get; set; }
Public Overridable Property UnscaledReal As Integer
    Get
    Set
public:
virtual property int UnscaledReal {
    int get ();
    void set (int value);
}


PhasorValueCollection Class

PhasorValueCollection Class
Namespaces ► TVA.PhasorProtocols ► PhasorValueCollection
Represents a protocol independent collection of IPhasorValue objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PhasorValueCollection : ChannelValueCollectionBase<IPhasorDefinition, IPhasorValue>
<SerializableAttribute> _
Public Class PhasorValueCollection _
    Inherits ChannelValueCollectionBase(Of IPhasorDefinition, IPhasorValue)
[SerializableAttribute]
public ref class PhasorValueCollection : public ChannelValueCollectionBase<IPhasorDefinition^, IPhasorValue^>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorValueCollection(Int32) | Creates a new PhasorValueCollection using specified lastValidIndex.
 | PhasorValueCollection(SerializationInfo, StreamingContext) | Creates a new PhasorValueCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IPhasorValue >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | AllValuesAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> object. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IPhasorValue >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IPhasorValue >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IPhasorValue >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IPhasorValue >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IPhasorValue >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IPhasorValue >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IPhasorValue >)>)>.)
 | InsertItem(Int32, TValue) | Inserts an element into the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)> at the specified index. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' IPhasorValue >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IPhasorValue >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IPhasorValue >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IPhasorValue >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | SetItem(Int32, TValue) | Replaces the element at the specified index. (Inherited from ChannelValueCollectionBase<(Of <(<'TDefinition, TValue>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IPhasorValue >)>)>
 |  | ChannelCollectionBase <(Of <(<' IPhasorValue >)>)>
 |  |  | ChannelValueCollectionBase <(Of <(<' IPhasorDefinition, IPhasorValue >)>)>
 |  |  |  | PhasorValueCollection


PhasorValueCollection Constructor

PhasorValueCollection Constructor
Namespaces ► TVA.PhasorProtocols ► PhasorValueCollection ► PhasorValueCollection()()()()
Members
Icon | Member | Description
 | PhasorValueCollection(Int32) | Creates a new PhasorValueCollection using specified lastValidIndex.
 | PhasorValueCollection(SerializationInfo, StreamingContext) | Creates a new PhasorValueCollection from serialization parameters.


PhasorValueCollection Constructor (lastValidIndex)

PhasorValueCollection Constructor (lastValidIndex)
Namespaces ► TVA.PhasorProtocols ► PhasorValueCollection ► PhasorValueCollection(Int32)
Creates a new PhasorValueCollection using specified lastValidIndex.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValueCollection(
    int lastValidIndex
)
Public Sub New ( _
    lastValidIndex As Integer _
)
public:
PhasorValueCollection(
    int lastValidIndex
)
Parameters
lastValidIndex (Int32)
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.


PhasorValueCollection Constructor (info, context)

PhasorValueCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols ► PhasorValueCollection ► PhasorValueCollection(SerializationInfo, StreamingContext)
Creates a new PhasorValueCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorValueCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorValueCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


SignalKind Enumeration

SignalKind Enumeration
Namespaces ► TVA.PhasorProtocols ► SignalKind
Fundamental signal types enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum SignalKind
<SerializableAttribute> _
Public Enumeration SignalKind
[SerializableAttribute]
public enum class SignalKind
Members
Member | Description
Angle | Phase angle.
Magnitude | Phase magnitude.
Frequency | Line frequency.
DfDt | Frequency delta over time (dF/dt).
Status | Status flags.
Digital | Digital value.
Analog | Analog value.
Calculation | Calculated value.
Statistic | Statistical value.
Unknown | Undetermined signal type.
Remarks

This signal type represents the basic type of a signal used to suffix a formatted signal reference. When used in context along with an optional index the fundamental signal type will identify a signal's location within a frame of data (see SignalReference).

Contrast the SignalKind enumeration with the SignalType enumeration which defines an explicit type for a signal (e.g., a voltage or current phasor).


SignalReference Structure

SignalReference Structure
Namespaces ► TVA.PhasorProtocols ► SignalReference
Represents a signal that can be referenced by its constituent components.
Declaration Syntax
C# Visual Basic Visual C++
public struct SignalReference : IEquatable<SignalReference>,
    IComparable<SignalReference>
Public Structure SignalReference _
    Implements IEquatable(Of SignalReference), IComparable(Of SignalReference)
public value class SignalReference : IEquatable<SignalReference>,
    IComparable<SignalReference>
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SignalReference(String) | Creates a new SignalReference.
 | Acronym | Gets or sets the acronym of this SignalReference.
 | CellIndex | Gets or sets the cell index of this SignalReference.
 | CompareTo(SignalReference) | Compares the current object with another object of the same type.
 | CompareTo(Object) | Compares the current object with another object of the same type.
 | Equality(SignalReference, SignalReference) | Compares two SignalReference values for equality.
 | Equals(Object) | Indicates whether the current object is equal to another object of the same type. (Overrides ValueType.Equals(Object).)
 | Equals(SignalReference) | Indicates whether the current object is equal to another object of the same type.
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Returns the hash code for this SignalReference. (Overrides ValueType.GetHashCode()()()().)
 | GetSignalKindAcronym(SignalKind) | Gets the acronym for the specified SignalKind.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GreaterThan(SignalReference, SignalReference) | Returns true if left SignalReference value is greater than right SignalReference value.
 | GreaterThanOrEqual(SignalReference, SignalReference) | Returns true if left SignalReference value is greater than or equal to right SignalReference value.
 | Index | Gets or sets the signal index of this SignalReference.
 | Inequality(SignalReference, SignalReference) | Compares two SignalReference values for inequality.
 | Kind | Gets or sets the SignalKind of this SignalReference.
 | LessThan(SignalReference, SignalReference) | Returns true if left SignalReference value is less than right SignalReference value.
 | LessThanOrEqual(SignalReference, SignalReference) | Returns true if left SignalReference value is less than or equal to right SignalReference value.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseSignalKind(String) | Gets the SignalKind for the specified acronym.
 | ToString()()()() | Returns a String that represents the current SignalReference. (Overrides ValueType.ToString()()()().)
 | ToString(String, SignalKind) | Returns a String that represents the specified acronym and SignalKind.
 | ToString(String, SignalKind, Int32) | Returns a String that represents the specified acronym, SignalKind and index.


SignalReference Constructor (signal)

SignalReference Constructor (signal)
Namespaces ► TVA.PhasorProtocols ► SignalReference ► SignalReference(String)
Creates a new SignalReference.
Declaration Syntax
C# Visual Basic Visual C++
public SignalReference(
    string signal
)
Public Sub New ( _
    signal As String _
)
public:
SignalReference(
    String^ signal
)
Parameters
signal (String)
String representation of this SignalReference.


Acronym Field

Acronym Field
Namespaces ► TVA.PhasorProtocols ► SignalReference ► Acronym
Gets or sets the acronym of this SignalReference.
Declaration Syntax
C# Visual Basic Visual C++
public string Acronym
Public Acronym As String
public:
String^ Acronym


CellIndex Field

CellIndex Field
Namespaces ► TVA.PhasorProtocols ► SignalReference ► CellIndex
Gets or sets the cell index of this SignalReference.
Declaration Syntax
C# Visual Basic Visual C++
public int CellIndex
Public CellIndex As Integer
public:
int CellIndex


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► SignalReference ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(SignalReference) | Compares the current object with another object of the same type.
 | CompareTo(Object) | Compares the current object with another object of the same type.


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces ► TVA.PhasorProtocols ► SignalReference ► CompareTo(Object)
Compares the current object with another object of the same type.
Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    Object obj
)
Public Function CompareTo ( _
    obj As Object _
) As Integer
public:
int CompareTo(
    Object^ obj
)
Parameters
obj (Object)
An object to compare with this SignalReference.
Return Value
A 32-bit signed integer that indicates the relative order of the objects being compared.
Exceptions
Exception | Condition
ArgumentException | Object is not a SignalReference.


CompareTo Method (other)

CompareTo Method (other)
Namespaces ► TVA.PhasorProtocols ► SignalReference ► CompareTo(SignalReference)
Compares the current object with another object of the same type.
Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    SignalReference other
)
Public Function CompareTo ( _
    other As SignalReference _
) As Integer
public:
virtual int CompareTo(
    SignalReference other
) sealed
Parameters
other (SignalReference)
Another SignalReference to compare with this SignalReference.
Return Value
A 32-bit signed integer that indicates the relative order of the objects being compared.


Equality Operator

Equality Operator
Namespaces ► TVA.PhasorProtocols ► SignalReference ► Equality(SignalReference, SignalReference)
Compares two SignalReference values for equality.
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    SignalReference signal1,
    SignalReference signal2
)
Public Shared Operator = ( _
    signal1 As SignalReference, _
    signal2 As SignalReference _
) As Boolean
public:
static bool operator ==(
    SignalReference signal1,
    SignalReference signal2
)
Parameters
signal1 (SignalReference)
A SignalReference left hand operand.
signal2 (SignalReference)
A SignalReference right hand operand.
Return Value
A boolean representing the result.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols ► SignalReference ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Indicates whether the current object is equal to another object of the same type. (Overrides ValueType.Equals(Object).)
 | Equals(SignalReference) | Indicates whether the current object is equal to another object of the same type.


Equals Method (obj)

Equals Method (obj)
Namespaces ► TVA.PhasorProtocols ► SignalReference ► Equals(Object)
Indicates whether the current object is equal to another object of the same type.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)
An object to compare with this object.
Return Value
true if the current object is equal to the other parameter; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | Object is not a SignalReference.


Equals Method (other)

Equals Method (other)
Namespaces ► TVA.PhasorProtocols ► SignalReference ► Equals(SignalReference)
Indicates whether the current object is equal to another object of the same type.
Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    SignalReference other
)
Public Function Equals ( _
    other As SignalReference _
) As Boolean
public:
virtual bool Equals(
    SignalReference other
) sealed
Parameters
other (SignalReference)
An object to compare with this object.
Return Value
true if the current object is equal to the other parameter; otherwise, false.


GetHashCode Method

GetHashCode Method
Namespaces ► TVA.PhasorProtocols ► SignalReference ► GetHashCode()()()()
Returns the hash code for this SignalReference.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
A 32-bit signed integer hash code.


GetSignalKindAcronym Method (signal)

GetSignalKindAcronym Method (signal)
Namespaces ► TVA.PhasorProtocols ► SignalReference ► GetSignalKindAcronym(SignalKind)
Gets the acronym for the specified SignalKind.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetSignalKindAcronym(
    SignalKind signal
)
Public Shared Function GetSignalKindAcronym ( _
    signal As SignalKind _
) As String
public:
static String^ GetSignalKindAcronym(
    SignalKind signal
)
Parameters
signal (SignalKind)
SignalKind to convert to an acronym.
Return Value
The acronym for the specified SignalKind.


GreaterThan Operator

GreaterThan Operator
Namespaces ► TVA.PhasorProtocols ► SignalReference ► GreaterThan(SignalReference, SignalReference)
Returns true if left SignalReference value is greater than right SignalReference value.
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator >(
    SignalReference signal1,
    SignalReference signal2
)
Public Shared Operator > ( _
    signal1 As SignalReference, _
    signal2 As SignalReference _
) As Boolean
public:
static bool operator >(
    SignalReference signal1,
    SignalReference signal2
)
Parameters
signal1 (SignalReference)
A SignalReference left hand operand.
signal2 (SignalReference)
A SignalReference right hand operand.
Return Value
A boolean representing the result.


GreaterThanOrEqual Operator

GreaterThanOrEqual Operator
Namespaces ► TVA.PhasorProtocols ► SignalReference ► GreaterThanOrEqual(SignalReference, SignalReference)
Returns true if left SignalReference value is greater than or equal to right SignalReference value.
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator >=(
    SignalReference signal1,
    SignalReference signal2
)
Public Shared Operator >= ( _
    signal1 As SignalReference, _
    signal2 As SignalReference _
) As Boolean
public:
static bool operator >=(
    SignalReference signal1,
    SignalReference signal2
)
Parameters
signal1 (SignalReference)
A SignalReference left hand operand.
signal2 (SignalReference)
A SignalReference right hand operand.
Return Value
A boolean representing the result.


Index Field

Index Field
Namespaces ► TVA.PhasorProtocols ► SignalReference ► Index
Gets or sets the signal index of this SignalReference.
Declaration Syntax
C# Visual Basic Visual C++
public int Index
Public Index As Integer
public:
int Index


Inequality Operator

Inequality Operator
Namespaces ► TVA.PhasorProtocols ► SignalReference ► Inequality(SignalReference, SignalReference)
Compares two SignalReference values for inequality.
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    SignalReference signal1,
    SignalReference signal2
)
Public Shared Operator <> ( _
    signal1 As SignalReference, _
    signal2 As SignalReference _
) As Boolean
public:
static bool operator !=(
    SignalReference signal1,
    SignalReference signal2
)
Parameters
signal1 (SignalReference)
A SignalReference left hand operand.
signal2 (SignalReference)
A SignalReference right hand operand.
Return Value
A boolean representing the result.


Kind Field

Kind Field
Namespaces ► TVA.PhasorProtocols ► SignalReference ► Kind
Gets or sets the SignalKind of this SignalReference.
Declaration Syntax
C# Visual Basic Visual C++
public SignalKind Kind
Public Kind As SignalKind
public:
SignalKind Kind


LessThan Operator

LessThan Operator
Namespaces ► TVA.PhasorProtocols ► SignalReference ► LessThan(SignalReference, SignalReference)
Returns true if left SignalReference value is less than right SignalReference value.
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator <(
    SignalReference signal1,
    SignalReference signal2
)
Public Shared Operator < ( _
    signal1 As SignalReference, _
    signal2 As SignalReference _
) As Boolean
public:
static bool operator <(
    SignalReference signal1,
    SignalReference signal2
)
Parameters
signal1 (SignalReference)
A SignalReference left hand operand.
signal2 (SignalReference)
A SignalReference right hand operand.
Return Value
A boolean representing the result.


LessThanOrEqual Operator

LessThanOrEqual Operator
Namespaces ► TVA.PhasorProtocols ► SignalReference ► LessThanOrEqual(SignalReference, SignalReference)
Returns true if left SignalReference value is less than or equal to right SignalReference value.
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator <=(
    SignalReference signal1,
    SignalReference signal2
)
Public Shared Operator <= ( _
    signal1 As SignalReference, _
    signal2 As SignalReference _
) As Boolean
public:
static bool operator <=(
    SignalReference signal1,
    SignalReference signal2
)
Parameters
signal1 (SignalReference)
A SignalReference left hand operand.
signal2 (SignalReference)
A SignalReference right hand operand.
Return Value
A boolean representing the result.


ParseSignalKind Method (acronym)

ParseSignalKind Method (acronym)
Namespaces ► TVA.PhasorProtocols ► SignalReference ► ParseSignalKind(String)
Gets the SignalKind for the specified acronym.
Declaration Syntax
C# Visual Basic Visual C++
public static SignalKind ParseSignalKind(
    string acronym
)
Public Shared Function ParseSignalKind ( _
    acronym As String _
) As SignalKind
public:
static SignalKind ParseSignalKind(
    String^ acronym
)
Parameters
acronym (String)
Acronym of the desired SignalKind.
Return Value
The SignalKind for the specified acronym.


ToString Method

ToString Method
Namespaces ► TVA.PhasorProtocols ► SignalReference ► ToString()()()()
Members
Icon | Member | Description
 | ToString()()()() | Returns a String that represents the current SignalReference. (Overrides ValueType.ToString()()()().)
 | ToString(String, SignalKind) | Returns a String that represents the specified acronym and SignalKind.
 | ToString(String, SignalKind, Int32) | Returns a String that represents the specified acronym, SignalKind and index.


ToString Method

ToString Method
Namespaces ► TVA.PhasorProtocols ► SignalReference ► ToString()()()()
Returns a String that represents the current SignalReference.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents the current SignalReference.


ToString Method (acronym, type)

ToString Method (acronym, type)
Namespaces ► TVA.PhasorProtocols ► SignalReference ► ToString(String, SignalKind)
Returns a String that represents the specified acronym and SignalKind.
Declaration Syntax
C# Visual Basic Visual C++
public static string ToString(
    string acronym,
    SignalKind type
)
Public Shared Function ToString ( _
    acronym As String, _
    type As SignalKind _
) As String
public:
static String^ ToString(
    String^ acronym,
    SignalKind type
)
Parameters
acronym (String)
Acronym portion of the desired String representation.
type (SignalKind)
SignalKind portion of the desired String representation.
Return Value
A String that represents the specified acronym and SignalKind.


ToString Method (acronym, type, index)

ToString Method (acronym, type, index)
Namespaces ► TVA.PhasorProtocols ► SignalReference ► ToString(String, SignalKind, Int32)
Returns a String that represents the specified acronym, SignalKind and index.
Declaration Syntax
C# Visual Basic Visual C++
public static string ToString(
    string acronym,
    SignalKind type,
    int index
)
Public Shared Function ToString ( _
    acronym As String, _
    type As SignalKind, _
    index As Integer _
) As String
public:
static String^ ToString(
    String^ acronym,
    SignalKind type,
    int index
)
Parameters
acronym (String)
Acronym portion of the desired String representation.
type (SignalKind)
SignalKind portion of the desired String representation.
index (Int32)
Index of SignalKind portion of the desired String representation.
Return Value
A String that represents the specified acronym, SignalKind and index.


SignalReferenceMeasurement Class

SignalReferenceMeasurement Class
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement
Represents an IMeasurement wrapper that is associated with a SignalReference.
Declaration Syntax
C# Visual Basic Visual C++
public class SignalReferenceMeasurement : IMeasurement,
    ITimeSeriesValue<double>, ITimeSeriesValue, IEquatable<ITimeSeriesValue>, IComparable<ITimeSeriesValue>,
    IComparable
Public Class SignalReferenceMeasurement _
    Implements IMeasurement, ITimeSeriesValue(Of Double),  _
    ITimeSeriesValue, IEquatable(Of ITimeSeriesValue), IComparable(Of ITimeSeriesValue),  _
    IComparable
public ref class SignalReferenceMeasurement : IMeasurement,
    ITimeSeriesValue<double>, ITimeSeriesValue, IEquatable<ITimeSeriesValue^>, IComparable<ITimeSeriesValue^>,
    IComparable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SignalReferenceMeasurement(IMeasurement, SignalReference) | Constructs a new SignalReferenceMeasurement from the specified parameters.
 | Adder | Gets or sets an offset to add to the measurement value. This defaults to 0.0.
 | AdjustedValue | Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets.
 | CompareTo(Object) | Compares the SignalReferenceMeasurement with the specified Object.
 | CompareTo(ITimeSeriesValue) | Compares the SignalReferenceMeasurement with an ITimeSeriesValue.
 | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current SignalReferenceMeasurement.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the Guid based signal ID of this SignalReferenceMeasurement, if available.
 | Key | Gets the primary key (a MeasurementKey, of this SignalReferenceMeasurement.
 | MeasurementValueFilter | Gets or sets function used to apply a downsampling filter over a sequence of IMeasurement values.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Multiplier | Defines a mulplicative offset to apply to the measurement value. This defaults to 1.0.
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this SignalReferenceMeasurement was published (post-processing).
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this SignalReferenceMeasurement was received (i.e., created).
 | SignalReference | Gets the SignalReference associated with this SignalReferenceMeasurement.
 | StateFlags | Gets or sets MeasurementStateFlags associated with this SignalReferenceMeasurement.
 | TagName | Gets or sets the text based tag name of this SignalReferenceMeasurement.
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this SignalReferenceMeasurement.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets the raw measurement value that is not offset by Adder and Multiplier.
Inheritance Hierarchy
Object
SignalReferenceMeasurement


SignalReferenceMeasurement Constructor (measurement, signalReference)

SignalReferenceMeasurement Constructor (measurement, signalReference)
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► SignalReferenceMeasurement(IMeasurement, SignalReference)
Constructs a new SignalReferenceMeasurement from the specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public SignalReferenceMeasurement(
    IMeasurement measurement,
    SignalReference signalReference
)
Public Sub New ( _
    measurement As IMeasurement, _
    signalReference As SignalReference _
)
public:
SignalReferenceMeasurement(
    IMeasurement^ measurement,
    SignalReference signalReference
)
Parameters
measurement (IMeasurement)
Source IMeasurement value.
signalReference (SignalReference)
Associated SignalReference.


Adder Property

Adder Property
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► Adder
Gets or sets an offset to add to the measurement value. This defaults to 0.0.
Declaration Syntax
C# Visual Basic Visual C++
public double Adder { get; set; }
Public Property Adder As Double
    Get
    Set
public:
virtual property double Adder {
    double get () sealed;
    void set (double value) sealed;
}


AdjustedValue Property

AdjustedValue Property
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► AdjustedValue
Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets.
Declaration Syntax
C# Visual Basic Visual C++
public double AdjustedValue { get; }
Public ReadOnly Property AdjustedValue As Double
    Get
public:
virtual property double AdjustedValue {
    double get () sealed;
}
Return Value
Value offset by Adder and Multiplier (i.e., Value * Multiplier + Adder).
Remarks
Note that returned value will be offset by Adder and Multiplier.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares the SignalReferenceMeasurement with the specified Object.
 | CompareTo(ITimeSeriesValue) | Compares the SignalReferenceMeasurement with an ITimeSeriesValue.


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► CompareTo(Object)
Compares the SignalReferenceMeasurement with the specified Object.
Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    Object obj
)
Public Function CompareTo ( _
    obj As Object _
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
Parameters
obj (Object)
The Object to compare with the current SignalReferenceMeasurement.
Return Value
A 32-bit signed integer that indicates the relative order of the objects being compared.
Remarks
Measurement implementations should compare by hash code.
Exceptions
Exception | Condition
ArgumentException | obj is not an IMeasurement.


CompareTo Method (other)

CompareTo Method (other)
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► CompareTo(ITimeSeriesValue)
Compares the SignalReferenceMeasurement with an ITimeSeriesValue.
Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    ITimeSeriesValue other
)
Public Function CompareTo ( _
    other As ITimeSeriesValue _
) As Integer
public:
virtual int CompareTo(
    ITimeSeriesValue^ other
) sealed
Parameters
other (ITimeSeriesValue)
The ITimeSeriesValue to compare with the current SignalReferenceMeasurement.
Return Value
A 32-bit signed integer that indicates the relative order of the objects being compared.
Remarks
Measurement implementations should compare by hash code.


Equals Method (other)

Equals Method (other)
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► Equals(ITimeSeriesValue)
Determines whether the specified ITimeSeriesValue is equal to the current SignalReferenceMeasurement.
Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    ITimeSeriesValue other
)
Public Function Equals ( _
    other As ITimeSeriesValue _
) As Boolean
public:
virtual bool Equals(
    ITimeSeriesValue^ other
) sealed
Parameters
other (ITimeSeriesValue)
The ITimeSeriesValue to compare with the current SignalReferenceMeasurement.
Return Value
true if the specified ITimeSeriesValue is equal to the current SignalReferenceMeasurement; otherwise, false.


ID Property

ID Property
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► ID
Gets or sets the Guid based signal ID of this SignalReferenceMeasurement, if available.
Declaration Syntax
C# Visual Basic Visual C++
public Guid ID { get; set; }
Public Property ID As Guid
    Get
    Set
public:
virtual property Guid ID {
    Guid get () sealed;
    void set (Guid value) sealed;
}


Key Property

Key Property
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► Key
Gets the primary key (a MeasurementKey, of this SignalReferenceMeasurement.
Declaration Syntax
C# Visual Basic Visual C++
public MeasurementKey Key { get; set; }
Public Property Key As MeasurementKey
    Get
    Set
public:
virtual property MeasurementKey Key {
    MeasurementKey get () sealed;
    void set (MeasurementKey value) sealed;
}


MeasurementValueFilter Property

MeasurementValueFilter Property
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► MeasurementValueFilter
Gets or sets function used to apply a downsampling filter over a sequence of IMeasurement values.
Declaration Syntax
C# Visual Basic Visual C++
public MeasurementValueFilterFunction MeasurementValueFilter { get; set; }
Public Property MeasurementValueFilter As MeasurementValueFilterFunction
    Get
    Set
public:
virtual property MeasurementValueFilterFunction^ MeasurementValueFilter {
    MeasurementValueFilterFunction^ get () sealed;
    void set (MeasurementValueFilterFunction^ value) sealed;
}


Multiplier Property

Multiplier Property
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► Multiplier
Defines a mulplicative offset to apply to the measurement value. This defaults to 1.0.
Declaration Syntax
C# Visual Basic Visual C++
public double Multiplier { get; set; }
Public Property Multiplier As Double
    Get
    Set
public:
virtual property double Multiplier {
    double get () sealed;
    void set (double value) sealed;
}


PublishedTimestamp Property

PublishedTimestamp Property
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► PublishedTimestamp
Gets or sets exact timestamp, in ticks, of when this SignalReferenceMeasurement was published (post-processing).
Declaration Syntax
C# Visual Basic Visual C++
public Ticks PublishedTimestamp { get; set; }
Public Property PublishedTimestamp As Ticks
    Get
    Set
public:
virtual property Ticks PublishedTimestamp {
    Ticks get () sealed;
    void set (Ticks value) sealed;
}
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


ReceivedTimestamp Property

ReceivedTimestamp Property
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► ReceivedTimestamp
Gets or sets exact timestamp, in ticks, of when this SignalReferenceMeasurement was received (i.e., created).
Declaration Syntax
C# Visual Basic Visual C++
public Ticks ReceivedTimestamp { get; set; }
Public Property ReceivedTimestamp As Ticks
    Get
    Set
public:
virtual property Ticks ReceivedTimestamp {
    Ticks get () sealed;
    void set (Ticks value) sealed;
}
Remarks

In the default implementation, this timestamp will simply be the ticks of UtcNow()()()() of when this class was created.

The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


SignalReference Property

SignalReference Property
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► SignalReference
Gets the SignalReference associated with this SignalReferenceMeasurement.
Declaration Syntax
C# Visual Basic Visual C++
public SignalReference SignalReference { get; }
Public ReadOnly Property SignalReference As SignalReference
    Get
public:
property SignalReference SignalReference {
    SignalReference get ();
}


StateFlags Property

StateFlags Property
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► StateFlags
Gets or sets MeasurementStateFlags associated with this SignalReferenceMeasurement.
Declaration Syntax
C# Visual Basic Visual C++
public MeasurementStateFlags StateFlags { get; set; }
Public Property StateFlags As MeasurementStateFlags
    Get
    Set
public:
virtual property MeasurementStateFlags StateFlags {
    MeasurementStateFlags get () sealed;
    void set (MeasurementStateFlags value) sealed;
}


TagName Property

TagName Property
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► TagName
Gets or sets the text based tag name of this SignalReferenceMeasurement.
Declaration Syntax
C# Visual Basic Visual C++
public string TagName { get; set; }
Public Property TagName As String
    Get
    Set
public:
virtual property String^ TagName {
    String^ get () sealed;
    void set (String^ value) sealed;
}


Timestamp Property

Timestamp Property
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► Timestamp
Gets or sets exact timestamp, in ticks, of the data represented by this SignalReferenceMeasurement.
Declaration Syntax
C# Visual Basic Visual C++
public Ticks Timestamp { get; set; }
Public Property Timestamp As Ticks
    Get
    Set
public:
virtual property Ticks Timestamp {
    Ticks get () sealed;
    void set (Ticks value) sealed;
}
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


Value Property

Value Property
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► Value
Gets or sets the raw measurement value that is not offset by Adder and Multiplier.
Declaration Syntax
C# Visual Basic Visual C++
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
virtual property double Value {
    double get () sealed;
    void set (double value) sealed;
}
Return Value
Raw value of this SignalReferenceMeasurement (i.e., value that is not offset by Adder and Multiplier).


SignalType Enumeration

SignalType Enumeration
Namespaces ► TVA.PhasorProtocols ► SignalType
Signal type enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum SignalType
<SerializableAttribute> _
Public Enumeration SignalType
[SerializableAttribute]
public enum class SignalType
Members
Member | Description
IPHM | Current phase magnitude.
IPHA | Current phase angle.
VPHM | Voltage phase magnitude.
VPHA | Voltage phase angle.
FREQ | Frequency.
DFDT | Frequency delta (dF/dt).
ALOG | Analog value.
FLAG | Status flags.
DIGI | Digital value.
CALC | Calculated value.
STAT | Statistical value.
NONE | Undefined signal.
GetFormattedSignalTypeName | Returns display friendly signal type name.
Remarks

The signal type represents the explicit type of a signal that a value represents.

Contrast the SignalType enumeration with the SignalKind enumeration which defines an abstract type for a signal (e.g., simply phase or angle).


StatisticCalculationFunction Delegate

StatisticCalculationFunction Delegate
Namespaces ► TVA.PhasorProtocols ► StatisticCalculationFunction
Method signature for function used to calculate a statistic for a given object.
Declaration Syntax
C# Visual Basic Visual C++
public delegate double StatisticCalculationFunction(
    Object source,
    string arguments
)
Public Delegate Function StatisticCalculationFunction ( _
    source As Object, _
    arguments As String _
) As Double
public delegate double StatisticCalculationFunction(
    Object^ source,
    String^ arguments
)
Parameters
source (Object)
Source object.
arguments (String)
Any needed arguments for statistic calculation.
Return Value
Actual calculated statistic.


StatisticsReader Class

StatisticsReader Class
Namespaces ► TVA.PhasorProtocols ► StatisticsReader
Reads certain device and input stream statistics from the statistics archive. The statistics that are read are the total frame count, the missing frame count, connectivity, average latency, the actual data rate, data quality errors, and time quality errors.
Declaration Syntax
C# Visual Basic Visual C++
public class StatisticsReader
Public Class StatisticsReader
public ref class StatisticsReader
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StatisticsReader()()()() | Creates a new instance of the StatisticsReader class. All parameters--ArchiveFilePath, StateFilePath, IntercomFilePath, MetadataFilePath, StartTime, and EndTime--must be set manually before attempting to read statistics from the archive.
 | StatisticsReader(String) | Creates a new instance of the StatisticsReader class. The configuration file specified in the parameter must contain the statistics historian records in order to automatically locate the archive files. Otherwise, the other constructor should be used. The StartTime and EndTime parameters are not set when using this constructor and must be set manually before attempting to read statistics from the archive.
 | ActualDataRate | After the StatisticsReader has read statistics from the archive file, this will contain the statistics on the actual data rate.
 | ArchiveFilePath | Path to the archive file (*_archive.d).
 | AverageLatency | After the StatisticsReader has read statistics from the archive file, this will contain the statistics on the average latency.
 | Close()()()() | Closes the archive file once the statistics are no longer needed.
 | ConnectedStats | After the StatisticsReader has read statistics from the archive file, this will contain the statistics on input stream connectivity.
 | DataQualityErrors | After the StatisticsReader has read statistics from the archive file, this will contain the statistics on data quality errors.
 | EndTime | The timestamp at which to stop gathering statistics from the archive.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IntercomFilePath | Path to the intercom file (scratch.dat).
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MetadataFilePath | Path to the metadata file (*_dbase.dat).
 | MissingFrames | After the StatisticsReader has read statistics from the archive file, this will contain the statistics on missing frames.
 | Open()()()() | Causes the StatisticsReader to open the archive file and retrieve the statistics.
 | StartTime | The timestamp at which to start gathering statistics from the archive.
 | StateFilePath | Path to the state file (*_startup.dat).
 | TimeQualityErrors | After the StatisticsReader has read statistics from the archive file, this will contain the statistics on time quality errors.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalFrames | After the StatisticsReader has read statistics from the archive file, this will contain the statistics on the total number of frames.
Inheritance Hierarchy
Object
StatisticsReader


StatisticsReader Constructor

StatisticsReader Constructor
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► StatisticsReader()()()()
Members
Icon | Member | Description
 | StatisticsReader()()()() | Creates a new instance of the StatisticsReader class. All parameters--ArchiveFilePath, StateFilePath, IntercomFilePath, MetadataFilePath, StartTime, and EndTime--must be set manually before attempting to read statistics from the archive.
 | StatisticsReader(String) | Creates a new instance of the StatisticsReader class. The configuration file specified in the parameter must contain the statistics historian records in order to automatically locate the archive files. Otherwise, the other constructor should be used. The StartTime and EndTime parameters are not set when using this constructor and must be set manually before attempting to read statistics from the archive.


StatisticsReader Constructor

StatisticsReader Constructor
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► StatisticsReader()()()()
Creates a new instance of the StatisticsReader class. All parameters--ArchiveFilePath, StateFilePath, IntercomFilePath, MetadataFilePath, StartTime, and EndTime--must be set manually before attempting to read statistics from the archive.
Declaration Syntax
C# Visual Basic Visual C++
public StatisticsReader()
Public Sub New
public:
StatisticsReader()


StatisticsReader Constructor (openPdcConfigPath)

StatisticsReader Constructor (openPdcConfigPath)
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► StatisticsReader(String)
Creates a new instance of the StatisticsReader class. The configuration file specified in the parameter must contain the statistics historian records in order to automatically locate the archive files. Otherwise, the other constructor should be used. The StartTime and EndTime parameters are not set when using this constructor and must be set manually before attempting to read statistics from the archive.
Declaration Syntax
C# Visual Basic Visual C++
public StatisticsReader(
    string openPdcConfigPath
)
Public Sub New ( _
    openPdcConfigPath As String _
)
public:
StatisticsReader(
    String^ openPdcConfigPath
)
Parameters
openPdcConfigPath (String)
Path to the openPDC configuration file.


ActualDataRate Property

ActualDataRate Property
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► ActualDataRate
After the StatisticsReader has read statistics from the archive file, this will contain the statistics on the actual data rate.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<MetadataRecord, IEnumerable<IDataPoint>> ActualDataRate { get; }
Public ReadOnly Property ActualDataRate As Dictionary(Of MetadataRecord, IEnumerable(Of IDataPoint))
    Get
public:
property Dictionary<MetadataRecord^, IEnumerable<IDataPoint^>^>^ ActualDataRate {
    Dictionary<MetadataRecord^, IEnumerable<IDataPoint^>^>^ get ();
}


ArchiveFilePath Property

ArchiveFilePath Property
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► ArchiveFilePath
Path to the archive file (*_archive.d).
Declaration Syntax
C# Visual Basic Visual C++
public string ArchiveFilePath { get; set; }
Public Property ArchiveFilePath As String
    Get
    Set
public:
property String^ ArchiveFilePath {
    String^ get ();
    void set (String^ value);
}


AverageLatency Property

AverageLatency Property
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► AverageLatency
After the StatisticsReader has read statistics from the archive file, this will contain the statistics on the average latency.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<MetadataRecord, IEnumerable<IDataPoint>> AverageLatency { get; }
Public ReadOnly Property AverageLatency As Dictionary(Of MetadataRecord, IEnumerable(Of IDataPoint))
    Get
public:
property Dictionary<MetadataRecord^, IEnumerable<IDataPoint^>^>^ AverageLatency {
    Dictionary<MetadataRecord^, IEnumerable<IDataPoint^>^>^ get ();
}


Close Method

Close Method
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► Close()()()()
Closes the archive file once the statistics are no longer needed.
Declaration Syntax
C# Visual Basic Visual C++
public void Close()
Public Sub Close
public:
void Close()


ConnectedStats Property

ConnectedStats Property
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► ConnectedStats
After the StatisticsReader has read statistics from the archive file, this will contain the statistics on input stream connectivity.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<MetadataRecord, IEnumerable<IDataPoint>> ConnectedStats { get; }
Public ReadOnly Property ConnectedStats As Dictionary(Of MetadataRecord, IEnumerable(Of IDataPoint))
    Get
public:
property Dictionary<MetadataRecord^, IEnumerable<IDataPoint^>^>^ ConnectedStats {
    Dictionary<MetadataRecord^, IEnumerable<IDataPoint^>^>^ get ();
}


DataQualityErrors Property

DataQualityErrors Property
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► DataQualityErrors
After the StatisticsReader has read statistics from the archive file, this will contain the statistics on data quality errors.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<MetadataRecord, IEnumerable<IDataPoint>> DataQualityErrors { get; }
Public ReadOnly Property DataQualityErrors As Dictionary(Of MetadataRecord, IEnumerable(Of IDataPoint))
    Get
public:
property Dictionary<MetadataRecord^, IEnumerable<IDataPoint^>^>^ DataQualityErrors {
    Dictionary<MetadataRecord^, IEnumerable<IDataPoint^>^>^ get ();
}


EndTime Property

EndTime Property
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► EndTime
The timestamp at which to stop gathering statistics from the archive.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


IntercomFilePath Property

IntercomFilePath Property
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► IntercomFilePath
Path to the intercom file (scratch.dat).
Declaration Syntax
C# Visual Basic Visual C++
public string IntercomFilePath { get; set; }
Public Property IntercomFilePath As String
    Get
    Set
public:
property String^ IntercomFilePath {
    String^ get ();
    void set (String^ value);
}


MetadataFilePath Property

MetadataFilePath Property
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► MetadataFilePath
Path to the metadata file (*_dbase.dat).
Declaration Syntax
C# Visual Basic Visual C++
public string MetadataFilePath { get; set; }
Public Property MetadataFilePath As String
    Get
    Set
public:
property String^ MetadataFilePath {
    String^ get ();
    void set (String^ value);
}


MissingFrames Property

MissingFrames Property
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► MissingFrames
After the StatisticsReader has read statistics from the archive file, this will contain the statistics on missing frames.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<MetadataRecord, IEnumerable<IDataPoint>> MissingFrames { get; }
Public ReadOnly Property MissingFrames As Dictionary(Of MetadataRecord, IEnumerable(Of IDataPoint))
    Get
public:
property Dictionary<MetadataRecord^, IEnumerable<IDataPoint^>^>^ MissingFrames {
    Dictionary<MetadataRecord^, IEnumerable<IDataPoint^>^>^ get ();
}


Open Method

Open Method
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► Open()()()()
Causes the StatisticsReader to open the archive file and retrieve the statistics.
Declaration Syntax
C# Visual Basic Visual C++
public void Open()
Public Sub Open
public:
void Open()


StartTime Property

StartTime Property
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► StartTime
The timestamp at which to start gathering statistics from the archive.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StateFilePath Property

StateFilePath Property
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► StateFilePath
Path to the state file (*_startup.dat).
Declaration Syntax
C# Visual Basic Visual C++
public string StateFilePath { get; set; }
Public Property StateFilePath As String
    Get
    Set
public:
property String^ StateFilePath {
    String^ get ();
    void set (String^ value);
}


TimeQualityErrors Property

TimeQualityErrors Property
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► TimeQualityErrors
After the StatisticsReader has read statistics from the archive file, this will contain the statistics on time quality errors.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<MetadataRecord, IEnumerable<IDataPoint>> TimeQualityErrors { get; }
Public ReadOnly Property TimeQualityErrors As Dictionary(Of MetadataRecord, IEnumerable(Of IDataPoint))
    Get
public:
property Dictionary<MetadataRecord^, IEnumerable<IDataPoint^>^>^ TimeQualityErrors {
    Dictionary<MetadataRecord^, IEnumerable<IDataPoint^>^>^ get ();
}


TotalFrames Property

TotalFrames Property
Namespaces ► TVA.PhasorProtocols ► StatisticsReader ► TotalFrames
After the StatisticsReader has read statistics from the archive file, this will contain the statistics on the total number of frames.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<MetadataRecord, IEnumerable<IDataPoint>> TotalFrames { get; }
Public ReadOnly Property TotalFrames As Dictionary(Of MetadataRecord, IEnumerable(Of IDataPoint))
    Get
public:
property Dictionary<MetadataRecord^, IEnumerable<IDataPoint^>^>^ TotalFrames {
    Dictionary<MetadataRecord^, IEnumerable<IDataPoint^>^>^ get ();
}


TVA.PhasorProtocols.Anonymous Namespace

TVA.PhasorProtocols.Anonymous Namespace
Namespaces ► TVA.PhasorProtocols.Anonymous
Contains a generic implementation of phasor classes used to represent phasor data that isn’t associated with any particular protocol.
Declaration Syntax
C# Visual Basic Visual C++
namespace TVA.PhasorProtocols.Anonymous
Namespace TVA.PhasorProtocols.Anonymous
namespace TVA.PhasorProtocols.Anonymous
Types
All Types Classes
Icon | Type | Description
 | AnalogDefinition | Represents a protocol independent implementation of an IAnalogDefinition.
 | ConfigurationCell | Represents a protocol independent implementation of a IConfigurationCell that can be sent or received.
 | ConfigurationCellCollection | Represents a protocol independent implementation of a collection of IConfigurationCell objects.
 | ConfigurationFrame | Represents a protocol independent implementation of a IConfigurationFrame that can be sent or received.
 | DigitalDefinition | Represents a protocol independent implementation of an IDigitalDefinition.
 | FrequencyDefinition | Represents a protocol independent implementation of a IFrequencyDefinition.
 | PhasorDefinition | Represents a protocol independent implementation of a IPhasorDefinition.


AnalogDefinition Class

AnalogDefinition Class
Namespaces ► TVA.PhasorProtocols.Anonymous ► AnalogDefinition
Represents a protocol independent implementation of an IAnalogDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class AnalogDefinition : AnalogDefinitionBase
<SerializableAttribute> _
Public Class AnalogDefinition _
    Inherits AnalogDefinitionBase
[SerializableAttribute]
public ref class AnalogDefinition : public AnalogDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalogDefinition(IConfigurationCell) | Creates a new AnalogDefinition from specified parameters.
 | AnalogDefinition(ConfigurationCell, String, UInt32, AnalogType) | Creates a new AnalogDefinition from specified parameters.
 | AnalogDefinition(SerializationInfo, StreamingContext) | Creates a new AnalogDefinition from serialization parameters.
 | AnalogType | Gets or sets AnalogType of this AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this AnalogDefinitionBase object. (Inherited from AnalogDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | DataFormat | Gets the DataFormat for the AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this AnalogDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | AnalogDefinitionBase
 |  |  |  |  | AnalogDefinition


AnalogDefinition Constructor

AnalogDefinition Constructor
Namespaces ► TVA.PhasorProtocols.Anonymous ► AnalogDefinition ► AnalogDefinition()()()()
Members
Icon | Member | Description
 | AnalogDefinition(IConfigurationCell) | Creates a new AnalogDefinition from specified parameters.
 | AnalogDefinition(ConfigurationCell, String, UInt32, AnalogType) | Creates a new AnalogDefinition from specified parameters.
 | AnalogDefinition(SerializationInfo, StreamingContext) | Creates a new AnalogDefinition from serialization parameters.


AnalogDefinition Constructor (info, context)

AnalogDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Anonymous ► AnalogDefinition ► AnalogDefinition(SerializationInfo, StreamingContext)
Creates a new AnalogDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected AnalogDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
AnalogDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


AnalogDefinition Constructor (parent, label, scale, type)

AnalogDefinition Constructor (parent, label, scale, type)
Namespaces ► TVA.PhasorProtocols.Anonymous ► AnalogDefinition ► AnalogDefinition(ConfigurationCell, String, UInt32, AnalogType)
Creates a new AnalogDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public AnalogDefinition(
    ConfigurationCell parent,
    string label,
    uint scale,
    AnalogType type
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String, _
    scale As UInteger, _
    type As AnalogType _
)
public:
AnalogDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    AnalogType type
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this AnalogDefinition.
label (String)
The label of this AnalogDefinition.
scale (UInt32)
The integer scaling value of this AnalogDefinitionBase.
type (AnalogType)
The AnalogType of this AnalogDefinition.


AnalogDefinition Constructor (parent)

AnalogDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.Anonymous ► AnalogDefinition ► AnalogDefinition(IConfigurationCell)
Creates a new AnalogDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public AnalogDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
AnalogDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this AnalogDefinition.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► AnalogDefinition ► Parent
Gets or sets the ConfigurationCell parent of this AnalogDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


ConfigurationCell Class

ConfigurationCell Class
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell
Represents a protocol independent implementation of a IConfigurationCell that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationCell : ConfigurationCellBase,
    IDisposable
<SerializableAttribute> _
Public Class ConfigurationCell _
    Inherits ConfigurationCellBase _
    Implements IDisposable
[SerializableAttribute]
public ref class ConfigurationCell : public ConfigurationCellBase,
    IDisposable
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCell(UInt16) | Creates a new ConfigurationCell from specified parameters.
 | ConfigurationCell(ConfigurationFrame, UInt16) | Creates a new ConfigurationCell from specified parameters.
 | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
 | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.AnalogDataFormat.)
 | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
 | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
 | DataQualityErrors | Gets or sets total data quality errors of this ConfigurationCell.
 | DeviceErrors | Gets or sets total device errors of this ConfigurationCell.
 | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Dispose()()()() | Releases all the resources used by the ConfigurationCell object.
 | Dispose(Boolean) | Releases the unmanaged resources used by the ConfigurationCell object and optionally releases the managed resources.
 | Disposed | Event is raised when ConfigurationCell is disposed.
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
 | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
 | Finalize()()()() | Releases the unmanaged resources before the ConfigurationCell object is reclaimed by GC. (Overrides Object.Finalize()()()().)
 | FooterImage | Gets the binary footer image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationCellBase.)
 | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBase.FrequencyDataFormat.)
 | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetSignalReference(SignalKind) | Get signal reference for specified SignalKind.
 | GetSignalReference(SignalKind, Int32, Int32) | Get signal reference for specified SignalKind and index.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationCellBase.)
 | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
 | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | LastReportTime | Gets or sets last report time of this ConfigurationCell.
 | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Parent | Gets or sets a reference to the parent IConfigurationFrame for this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ConfigurationCellBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary footer image. (Inherited from ConfigurationCellBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Inherited from ConfigurationCellBase.)
 | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.PhasorCoordinateFormat.)
 | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.PhasorDataFormat.)
 | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Source | Gets or sets the reference to the source of this ConfigurationCell.
 | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | TimeQualityErrors | Gets or sets total time quality errors of this ConfigurationCell.
 | ToString()()()() | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | TotalFrames | Gets or sets total frames of this ConfigurationCell.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | ConfigurationCellBase
 |  |  |  |  | ConfigurationCell


ConfigurationCell Constructor

ConfigurationCell Constructor
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► ConfigurationCell()()()()
Members
Icon | Member | Description
 | ConfigurationCell(UInt16) | Creates a new ConfigurationCell from specified parameters.
 | ConfigurationCell(ConfigurationFrame, UInt16) | Creates a new ConfigurationCell from specified parameters.
 | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.


ConfigurationCell Constructor (info, context)

ConfigurationCell Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► ConfigurationCell(SerializationInfo, StreamingContext)
Creates a new ConfigurationCell from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationCell(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationCell Constructor (idCode)

ConfigurationCell Constructor (idCode)
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► ConfigurationCell(UInt16)
Creates a new ConfigurationCell from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell(
    ushort idCode
)
Public Sub New ( _
    idCode As UShort _
)
public:
ConfigurationCell(
    unsigned short idCode
)
Parameters
idCode (UInt16)
The numeric ID code for this ConfigurationCell.


ConfigurationCell Constructor (parent, idCode)

ConfigurationCell Constructor (parent, idCode)
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► ConfigurationCell(ConfigurationFrame, UInt16)
Creates a new ConfigurationCell from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell(
    ConfigurationFrame parent,
    ushort idCode
)
Public Sub New ( _
    parent As ConfigurationFrame, _
    idCode As UShort _
)
public:
ConfigurationCell(
    ConfigurationFrame^ parent,
    unsigned short idCode
)
Parameters
parent (ConfigurationFrame)
The reference to parent ConfigurationFrame of this ConfigurationCell.
idCode (UInt16)
The numeric ID code for this ConfigurationCell.


AnalogDataFormat Property

AnalogDataFormat Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► AnalogDataFormat
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat AnalogDataFormat { get; set; }
Public Overrides Property AnalogDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat AnalogDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}


DataQualityErrors Property

DataQualityErrors Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► DataQualityErrors
Gets or sets total data quality errors of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public long DataQualityErrors { get; set; }
Public Property DataQualityErrors As Long
    Get
    Set
public:
property long long DataQualityErrors {
    long long get ();
    void set (long long value);
}


DeviceErrors Property

DeviceErrors Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► DeviceErrors
Gets or sets total device errors of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public long DeviceErrors { get; set; }
Public Property DeviceErrors As Long
    Get
    Set
public:
property long long DeviceErrors {
    long long get ();
    void set (long long value);
}


Dispose Method

Dispose Method
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose()()()() | Releases all the resources used by the ConfigurationCell object.
 | Dispose(Boolean) | Releases the unmanaged resources used by the ConfigurationCell object and optionally releases the managed resources.


Dispose Method

Dispose Method
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► Dispose()()()()
Releases all the resources used by the ConfigurationCell object.
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► Dispose(Boolean)
Releases the unmanaged resources used by the ConfigurationCell object and optionally releases the managed resources.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
)
Parameters
disposing (Boolean)
true to release both managed and unmanaged resources; false to release only unmanaged resources.


Disposed Event

Disposed Event
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► Disposed
Event is raised when ConfigurationCell is disposed.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler Disposed
Public Event Disposed As EventHandler
public:
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


Finalize Method

Finalize Method
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► Finalize()()()()
Releases the unmanaged resources before the ConfigurationCell object is reclaimed by GC.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override


FrequencyDataFormat Property

FrequencyDataFormat Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► FrequencyDataFormat
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat FrequencyDataFormat { get; set; }
Public Overrides Property FrequencyDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


GetSignalReference Method

GetSignalReference Method
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► GetSignalReference()()()()
Members
Icon | Member | Description
 | GetSignalReference(SignalKind) | Get signal reference for specified SignalKind.
 | GetSignalReference(SignalKind, Int32, Int32) | Get signal reference for specified SignalKind and index.


GetSignalReference Method (type)

GetSignalReference Method (type)
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► GetSignalReference(SignalKind)
Get signal reference for specified SignalKind.
Declaration Syntax
C# Visual Basic Visual C++
public string GetSignalReference(
    SignalKind type
)
Public Function GetSignalReference ( _
    type As SignalKind _
) As String
public:
String^ GetSignalReference(
    SignalKind type
)
Parameters
type (SignalKind)
SignalKind to request signal reference for.
Return Value
Signal reference of given SignalKind.


GetSignalReference Method (type, index, count)

GetSignalReference Method (type, index, count)
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► GetSignalReference(SignalKind, Int32, Int32)
Get signal reference for specified SignalKind and index.
Declaration Syntax
C# Visual Basic Visual C++
public string GetSignalReference(
    SignalKind type,
    int index,
    int count
)
Public Function GetSignalReference ( _
    type As SignalKind, _
    index As Integer, _
    count As Integer _
) As String
public:
String^ GetSignalReference(
    SignalKind type,
    int index,
    int count
)
Parameters
type (SignalKind)
SignalKind to request signal reference for.
index (Int32)
Index SignalKind to request signal reference for.
count (Int32)
Number of signals defined for this SignalKind.
Return Value
Signal reference of given SignalKind and index.


LastReportTime Property

LastReportTime Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► LastReportTime
Gets or sets last report time of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public Ticks LastReportTime { get; set; }
Public Property LastReportTime As Ticks
    Get
    Set
public:
property Ticks LastReportTime {
    Ticks get ();
    void set (Ticks value);
}


PhasorCoordinateFormat Property

PhasorCoordinateFormat Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► PhasorCoordinateFormat
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override CoordinateFormat PhasorCoordinateFormat { get; set; }
Public Overrides Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () override;
    void set (CoordinateFormat value) override;
}


PhasorDataFormat Property

PhasorDataFormat Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► PhasorDataFormat
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat PhasorDataFormat { get; set; }
Public Overrides Property PhasorDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}


Source Property

Source Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► Source
Gets or sets the reference to the source of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public Object Source { get; set; }
Public Property Source As Object
    Get
    Set
public:
property Object^ Source {
    Object^ get ();
    void set (Object^ value);
}


TimeQualityErrors Property

TimeQualityErrors Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► TimeQualityErrors
Gets or sets total time quality errors of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public long TimeQualityErrors { get; set; }
Public Property TimeQualityErrors As Long
    Get
    Set
public:
property long long TimeQualityErrors {
    long long get ();
    void set (long long value);
}


TotalFrames Property

TotalFrames Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► TotalFrames
Gets or sets total frames of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public long TotalFrames { get; set; }
Public Property TotalFrames As Long
    Get
    Set
public:
property long long TotalFrames {
    long long get ();
    void set (long long value);
}


ConfigurationCellCollection Class

ConfigurationCellCollection Class
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCellCollection
Represents a protocol independent implementation of a collection of IConfigurationCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationCellCollection : ConfigurationCellCollection
<SerializableAttribute> _
Public Class ConfigurationCellCollection _
    Inherits ConfigurationCellCollection
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ConfigurationCellCollection
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCellCollection()()()() | Creates a new ConfigurationCellCollection.
 | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | IndexOfIDCode(UInt16) | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
 | IndexOfIDLabel(String) | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
 | IndexOfStationName(String) | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets ConfigurationCell at specified index.
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetByIDCode(UInt16, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
 | TryGetByIDLabel(String, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
 | TryGetByStationName(String, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IConfigurationCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' IConfigurationCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationCellCollection
 |  |  |  |  | ConfigurationCellCollection


ConfigurationCellCollection Constructor

ConfigurationCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCellCollection ► ConfigurationCellCollection()()()()
Members
Icon | Member | Description
 | ConfigurationCellCollection()()()() | Creates a new ConfigurationCellCollection.
 | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.


ConfigurationCellCollection Constructor

ConfigurationCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCellCollection ► ConfigurationCellCollection()()()()
Creates a new ConfigurationCellCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellCollection()
Public Sub New
public:
ConfigurationCellCollection()


ConfigurationCellCollection Constructor (info, context)

ConfigurationCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCellCollection ► ConfigurationCellCollection(SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


Item Property (index)

Item Property (index)
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCellCollection ► Item[([( Int32])])
Gets or sets ConfigurationCell at specified index.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ConfigurationCell
    Get
    Set
public:
property ConfigurationCell^ default[int index] {
    ConfigurationCell^ get (int index);
    void set (int index, ConfigurationCell^ value);
}
Parameters
index (Int32)
Index of value to get or set.


ConfigurationFrame Class

ConfigurationFrame Class
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationFrame
Represents a protocol independent implementation of a IConfigurationFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationFrame : ConfigurationFrameBase
<SerializableAttribute> _
Public Class ConfigurationFrame _
    Inherits ConfigurationFrameBase
[SerializableAttribute]
public ref class ConfigurationFrame : public ConfigurationFrameBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationFrame(UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame from specified parameters.
 | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrameBase object. (Inherited from ConfigurationFrameBase.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Cache(Object) | Serialize configuration frame to cache folder for later use (if needed).
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ConfigurationCachePath | Gets the path for storing serialized phasor protocol configurations.
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | GetCachedConfiguration(String, Boolean) | Deserializes cached configuration, if available.
 | GetConfigurationCacheFileName(String) | Gets the file name with path of the specified configurationName.
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrameBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SetNominalFrequency(LineFrequency) | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationFrameBase
 |  |  |  |  | ConfigurationFrame


ConfigurationFrame Constructor

ConfigurationFrame Constructor
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationFrame ► ConfigurationFrame()()()()
Members
Icon | Member | Description
 | ConfigurationFrame(UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame from specified parameters.
 | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.


ConfigurationFrame Constructor (info, context)

ConfigurationFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationFrame ► ConfigurationFrame(SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationFrame Constructor (idCode, timestamp, frameRate)

ConfigurationFrame Constructor (idCode, timestamp, frameRate)
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationFrame ► ConfigurationFrame(UInt16, Ticks, UInt16)
Creates a new ConfigurationFrame from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame(
    ushort idCode,
    Ticks timestamp,
    ushort frameRate
)
Public Sub New ( _
    idCode As UShort, _
    timestamp As Ticks, _
    frameRate As UShort _
)
public:
ConfigurationFrame(
    unsigned short idCode,
    Ticks timestamp,
    unsigned short frameRate
)
Parameters
idCode (UInt16)
The ID code of this ConfigurationFrame.
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame.
frameRate (UInt16)
The defined frame rate of this ConfigurationFrame.


Cache Method (state)

Cache Method (state)
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationFrame ► Cache(Object)
Serialize configuration frame to cache folder for later use (if needed).
Declaration Syntax
C# Visual Basic Visual C++
public static void Cache(
    Object state
)
Public Shared Sub Cache ( _
    state As Object _
)
public:
static void Cache(
    Object^ state
)
Parameters
state (Object)
Reference to a EventArgs instance containing the following:
a reference to IConfigurationFrame (as T1),
a Action<(Of <(<'T>)>)> delegate to handle process exceptions (as T2),
and a String representing the configuration name (as T3).
Remarks
It is expected that this function will be called from the ThreadPool.


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationFrame ► Cells
Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellCollection Cells { get; }
Public ReadOnly Property Cells As ConfigurationCellCollection
    Get
public:
property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}


ConfigurationCachePath Property

ConfigurationCachePath Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationFrame ► ConfigurationCachePath
Gets the path for storing serialized phasor protocol configurations.
Declaration Syntax
C# Visual Basic Visual C++
public static string ConfigurationCachePath { get; }
Public Shared ReadOnly Property ConfigurationCachePath As String
    Get
public:
static property String^ ConfigurationCachePath {
    String^ get ();
}
Return Value
Path for storing serialized phasor protocol configurations.


GetCachedConfiguration Method (configurationName, fromCache)

GetCachedConfiguration Method (configurationName, fromCache)
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationFrame ► GetCachedConfiguration(String, Boolean)
Deserializes cached configuration, if available.
Declaration Syntax
C# Visual Basic Visual C++
public static IConfigurationFrame GetCachedConfiguration(
    string configurationName,
    bool fromCache
)
Public Shared Function GetCachedConfiguration ( _
    configurationName As String, _
    fromCache As Boolean _
) As IConfigurationFrame
public:
static IConfigurationFrame^ GetCachedConfiguration(
    String^ configurationName,
    bool fromCache
)
Parameters
configurationName (String)
Name of the configuration to get file name for.
fromCache (Boolean)
Set to True retrieve from cache, False to retrieve from specified file name in configurationName
Return Value
Cached configuration frame, or null if not available.


GetConfigurationCacheFileName Method (configurationName)

GetConfigurationCacheFileName Method (configurationName)
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationFrame ► GetConfigurationCacheFileName(String)
Gets the file name with path of the specified configurationName.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetConfigurationCacheFileName(
    string configurationName
)
Public Shared Function GetConfigurationCacheFileName ( _
    configurationName As String _
) As String
public:
static String^ GetConfigurationCacheFileName(
    String^ configurationName
)
Parameters
configurationName (String)
Name of the configuration to get file name for.
Return Value
File name with path of the specified configurationName.


DigitalDefinition Class

DigitalDefinition Class
Namespaces ► TVA.PhasorProtocols.Anonymous ► DigitalDefinition
Represents a protocol independent implementation of an IDigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DigitalDefinition : DigitalDefinitionBase
<SerializableAttribute> _
Public Class DigitalDefinition _
    Inherits DigitalDefinitionBase
[SerializableAttribute]
public ref class DigitalDefinition : public DigitalDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalDefinition(ConfigurationCell, String, UInt32) | Creates a new DigitalDefinition from specified parameters.
 | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaskValue | Gets or sets the digital mask value of this DigitalDefinition made available in configuration frames.
 | MaximumLabelLength | Gets the maximum length of the Label of this DigitalDefinition. (Overrides ChannelDefinitionBase.MaximumLabelLength.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | DigitalDefinitionBase
 |  |  |  |  | DigitalDefinition


DigitalDefinition Constructor

DigitalDefinition Constructor
Namespaces ► TVA.PhasorProtocols.Anonymous ► DigitalDefinition ► DigitalDefinition()()()()
Members
Icon | Member | Description
 | DigitalDefinition(ConfigurationCell, String, UInt32) | Creates a new DigitalDefinition from specified parameters.
 | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.


DigitalDefinition Constructor (info, context)

DigitalDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Anonymous ► DigitalDefinition ► DigitalDefinition(SerializationInfo, StreamingContext)
Creates a new DigitalDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DigitalDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DigitalDefinition Constructor (parent, label, maskValue)

DigitalDefinition Constructor (parent, label, maskValue)
Namespaces ► TVA.PhasorProtocols.Anonymous ► DigitalDefinition ► DigitalDefinition(ConfigurationCell, String, UInt32)
Creates a new DigitalDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalDefinition(
    ConfigurationCell parent,
    string label,
    uint maskValue
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String, _
    maskValue As UInteger _
)
public:
DigitalDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int maskValue
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this DigitalDefinition.
label (String)
The label of this DigitalDefinition.
maskValue (UInt32)
The value of the digital mask made available in configuration frames.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.Anonymous ► DigitalDefinition ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


MaskValue Property

MaskValue Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► DigitalDefinition ► MaskValue
Gets or sets the digital mask value of this DigitalDefinition made available in configuration frames.
Declaration Syntax
C# Visual Basic Visual C++
public uint MaskValue { get; set; }
Public Property MaskValue As UInteger
    Get
    Set
public:
property unsigned int MaskValue {
    unsigned int get ();
    void set (unsigned int value);
}


MaximumLabelLength Property

MaximumLabelLength Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► DigitalDefinition ► MaximumLabelLength
Gets the maximum length of the Label of this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
public:
virtual property int MaximumLabelLength {
    int get () override;
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► DigitalDefinition ► Parent
Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


FrequencyDefinition Class

FrequencyDefinition Class
Namespaces ► TVA.PhasorProtocols.Anonymous ► FrequencyDefinition
Represents a protocol independent implementation of a IFrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FrequencyDefinition : FrequencyDefinitionBase
<SerializableAttribute> _
Public Class FrequencyDefinition _
    Inherits FrequencyDefinitionBase
[SerializableAttribute]
public ref class FrequencyDefinition : public FrequencyDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
 | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | FrequencyDefinitionBase
 |  |  |  |  | FrequencyDefinition


FrequencyDefinition Constructor

FrequencyDefinition Constructor
Namespaces ► TVA.PhasorProtocols.Anonymous ► FrequencyDefinition ► FrequencyDefinition()()()()
Members
Icon | Member | Description
 | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
 | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.


FrequencyDefinition Constructor (info, context)

FrequencyDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Anonymous ► FrequencyDefinition ► FrequencyDefinition(SerializationInfo, StreamingContext)
Creates a new FrequencyDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrequencyDefinition Constructor (parent, label)

FrequencyDefinition Constructor (parent, label)
Namespaces ► TVA.PhasorProtocols.Anonymous ► FrequencyDefinition ► FrequencyDefinition(ConfigurationCell, String)
Creates a new FrequencyDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String _
)
public:
FrequencyDefinition(
    ConfigurationCell^ parent,
    String^ label
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this FrequencyDefinition.
label (String)
The label of this FrequencyDefinition.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► FrequencyDefinition ► Parent
Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


PhasorDefinition Class

PhasorDefinition Class
Namespaces ► TVA.PhasorProtocols.Anonymous ► PhasorDefinition
Represents a protocol independent implementation of a IPhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PhasorDefinition : PhasorDefinitionBase
<SerializableAttribute> _
Public Class PhasorDefinition _
    Inherits PhasorDefinitionBase
[SerializableAttribute]
public ref class PhasorDefinition : public PhasorDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorDefinition(ConfigurationCell, String, UInt32, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | PhasorDefinitionBase
 |  |  |  |  | PhasorDefinition


PhasorDefinition Constructor

PhasorDefinition Constructor
Namespaces ► TVA.PhasorProtocols.Anonymous ► PhasorDefinition ► PhasorDefinition()()()()
Members
Icon | Member | Description
 | PhasorDefinition(ConfigurationCell, String, UInt32, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.


PhasorDefinition Constructor (info, context)

PhasorDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Anonymous ► PhasorDefinition ► PhasorDefinition(SerializationInfo, StreamingContext)
Creates a new PhasorDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


PhasorDefinition Constructor (parent, label, scale, type, voltageReference)

PhasorDefinition Constructor (parent, label, scale, type, voltageReference)
Namespaces ► TVA.PhasorProtocols.Anonymous ► PhasorDefinition ► PhasorDefinition(ConfigurationCell, String, UInt32, PhasorType, PhasorDefinition)
Creates a new PhasorDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinition(
    ConfigurationCell parent,
    string label,
    uint scale,
    PhasorType type,
    PhasorDefinition voltageReference
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String, _
    scale As UInteger, _
    type As PhasorType, _
    voltageReference As PhasorDefinition _
)
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    PhasorType type,
    PhasorDefinition^ voltageReference
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this PhasorDefinition.
label (String)
The label of this PhasorDefinition.
scale (UInt32)
The integer scaling value of this PhasorDefinition.
type (PhasorType)
The PhasorType of this PhasorDefinition.
voltageReference (PhasorDefinition)
The associated IPhasorDefinition that represents the voltage reference (if any).


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Anonymous ► PhasorDefinition ► Parent
Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


TVA.PhasorProtocols.BpaPdcStream Namespace

TVA.PhasorProtocols.BpaPdcStream Namespace
Namespaces ► TVA.PhasorProtocols.BpaPdcStream
Contains an implementation of the phasor classes used to parse or generate a stream of data in the BPA PDCstream format.
Declaration Syntax
C# Visual Basic Visual C++
namespace TVA.PhasorProtocols.BpaPdcStream
Namespace TVA.PhasorProtocols.BpaPdcStream
namespace TVA.PhasorProtocols.BpaPdcStream
Types
All Types Classes Enumerations
Icon | Type | Description
 | AnalogDefinition | Represents the BPA PDCstream implementation of an IAnalogDefinition.
 | AnalogValue | Represents the BPA PDCstream implementation of an IAnalogValue.
 | ChannelFlags | Channel flags enumeration.
 | Common | Common BPA PDCstream declarations and functions.
 | CommonFrameHeader | Represents the common header for all BPA PDCstream frames of data.
 | Concentrator | Represents a BPA PDCstream phasor data concentrator.
 | ConfigurationCell | Represents the BPA PDCstream implementation of a IConfigurationCell that can be sent or received.
 | ConfigurationCellCollection | Represents a BPA PDCstream implementation of a collection of IConfigurationCell objects.
 | ConfigurationFrame | Represents the BPA PDCstream implementation of a IConfigurationFrame that can be sent or received.
 | ConfigurationFrameParsingState | Represents the BPA PDCstream implementation of the parsing state used by a ConfigurationFrame.
 | ConnectionParameters | Represents the extra connection parameters required for a connection to a BPA PDCstream.
 | DataCell | Represents the BPA PDCstream implementation of a IDataCell that can be sent or received.
 | DataCellCollection | Represents a BPA PDCstream implementation of a collection of IDataCell objects.
 | DataFrame | Represents the BPA PDCstream implementation of a IDataFrame that can be sent or received.
 | DataFrameParsingState | Represents the BPA PDCstream protocol implementation of the parsing state used by a DataFrame.
 | DigitalDefinition | Represents the BPA PDCstream implementation of an IDigitalDefinition.
 | DigitalValue | Represents the BPA PDCstream implementation of an IDigitalValue.
 | FileType | File type enueration.
 | FileVersion |
 | FormatFlags | Format flags enumeration.
 | FrameParser | Represents a frame parser for a BPA PDCstream binary data stream and returns parsed data via events.
 | FrameType | Frame type enumeration.
 | FrequencyDefinition | Represents the BPA PDCstream implementation of a IFrequencyDefinition.
 | FrequencyValue | Represents the BPA PDCstream implementation of a IFrequencyValue.
 | IniFileNameEditor | INI file name browser used with BPA PDCstream ConnectionParameters.
 | PhasorDefinition | Represents the BPA PDCstream implementation of a IPhasorDefinition.
 | PhasorValue | Represents the BPA PDCstream implementation of a IPhasorValue.
 | PMUStatusFlags | PMU status flags enumeration.
 | ReservedFlags | Reserved flags enumeration.
 | RevisionNumber | Stream revision number enumeration.
 | StreamType | Stream type enueration.


AnalogDefinition Class

AnalogDefinition Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogDefinition
Represents the BPA PDCstream implementation of an IAnalogDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class AnalogDefinition : AnalogDefinitionBase
<SerializableAttribute> _
Public Class AnalogDefinition _
    Inherits AnalogDefinitionBase
[SerializableAttribute]
public ref class AnalogDefinition : public AnalogDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalogDefinition(IConfigurationCell) | Creates a new AnalogDefinition from specified parameters.
 | AnalogDefinition(ConfigurationCell, String, UInt32, Double, AnalogType) | Creates a new AnalogDefinition from specified parameters.
 | AnalogDefinition(SerializationInfo, StreamingContext) | Creates a new AnalogDefinition from serialization parameters.
 | AnalogType | Gets or sets AnalogType of this AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this AnalogDefinitionBase object. (Inherited from AnalogDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the AnalogDefinition object. (Overrides ChannelDefinitionBase.BodyImage.)
 | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBase.BodyLength.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | DataFormat | Gets the DataFormat for the AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this AnalogDefinition. (Overrides ChannelDefinitionBase.MaximumLabelLength.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this AnalogDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | AnalogDefinitionBase
 |  |  |  |  | AnalogDefinition


AnalogDefinition Constructor

AnalogDefinition Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogDefinition ► AnalogDefinition()()()()
Members
Icon | Member | Description
 | AnalogDefinition(IConfigurationCell) | Creates a new AnalogDefinition from specified parameters.
 | AnalogDefinition(ConfigurationCell, String, UInt32, Double, AnalogType) | Creates a new AnalogDefinition from specified parameters.
 | AnalogDefinition(SerializationInfo, StreamingContext) | Creates a new AnalogDefinition from serialization parameters.


AnalogDefinition Constructor (info, context)

AnalogDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogDefinition ► AnalogDefinition(SerializationInfo, StreamingContext)
Creates a new AnalogDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected AnalogDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
AnalogDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


AnalogDefinition Constructor (parent, label, scale, offset, type)

AnalogDefinition Constructor (parent, label, scale, offset, type)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogDefinition ► AnalogDefinition(ConfigurationCell, String, UInt32, Double, AnalogType)
Creates a new AnalogDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public AnalogDefinition(
    ConfigurationCell parent,
    string label,
    uint scale,
    double offset,
    AnalogType type
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String, _
    scale As UInteger, _
    offset As Double, _
    type As AnalogType _
)
public:
AnalogDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset,
    AnalogType type
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this AnalogDefinition.
label (String)
The label of this AnalogDefinition.
scale (UInt32)
The integer scaling value of this AnalogDefinition.
offset (Double)
The offset of this AnalogDefinition.
type (AnalogType)
The AnalogType of this AnalogDefinition.


AnalogDefinition Constructor (parent)

AnalogDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogDefinition ► AnalogDefinition(IConfigurationCell)
Creates a new AnalogDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public AnalogDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
AnalogDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this AnalogDefinition.


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogDefinition ► BodyImage
Gets the binary body image of the AnalogDefinition object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}
Remarks
BPA PDCstream does not include analog definition in descriptor packet. Only a count of available values is defined in the data frame.


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogDefinition ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}


MaximumLabelLength Property

MaximumLabelLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogDefinition ► MaximumLabelLength
Gets the maximum length of the Label of this AnalogDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
public:
virtual property int MaximumLabelLength {
    int get () override;
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogDefinition ► Parent
Gets or sets the ConfigurationCell parent of this AnalogDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


AnalogValue Class

AnalogValue Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogValue
Represents the BPA PDCstream implementation of an IAnalogValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class AnalogValue : AnalogValueBase
<SerializableAttribute> _
Public Class AnalogValue _
    Inherits AnalogValueBase
[SerializableAttribute]
public ref class AnalogValue : public AnalogValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalogValue(IDataCell, IAnalogDefinition) | Creates a new AnalogValue.
 | AnalogValue(DataCell, AnalogDefinition, Double) | Creates a new AnalogValue from specified parameters.
 | AnalogValue(SerializationInfo, StreamingContext) | Creates a new AnalogValue from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the AnalogValueBase object. (Inherited from AnalogValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the AnalogValueBase object. (Inherited from AnalogValueBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from AnalogValueBase.)
 | CompositeValueCount | Gets total number of composite values that this AnalogValueBase provides. (Inherited from AnalogValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the AnalogDefinition associated with this AnalogValue.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this AnalogValueBase. (Inherited from AnalogValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IntegerValue | Gets or sets the integer representation of this AnalogValueBase value. (Inherited from AnalogValueBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of AnalogValueBase have been assigned a value. (Inherited from AnalogValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this AnalogValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from AnalogValueBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets the floating point value that represents this AnalogValueBase. (Inherited from AnalogValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IAnalogDefinition >)>)>
 |  |  |  | AnalogValueBase
 |  |  |  |  | AnalogValue


AnalogValue Constructor

AnalogValue Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogValue ► AnalogValue()()()()
Members
Icon | Member | Description
 | AnalogValue(IDataCell, IAnalogDefinition) | Creates a new AnalogValue.
 | AnalogValue(DataCell, AnalogDefinition, Double) | Creates a new AnalogValue from specified parameters.
 | AnalogValue(SerializationInfo, StreamingContext) | Creates a new AnalogValue from serialization parameters.


AnalogValue Constructor (info, context)

AnalogValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogValue ► AnalogValue(SerializationInfo, StreamingContext)
Creates a new AnalogValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected AnalogValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
AnalogValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


AnalogValue Constructor (parent, analogDefinition, value)

AnalogValue Constructor (parent, analogDefinition, value)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogValue ► AnalogValue(DataCell, AnalogDefinition, Double)
Creates a new AnalogValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public AnalogValue(
    DataCell parent,
    AnalogDefinition analogDefinition,
    double value
)
Public Sub New ( _
    parent As DataCell, _
    analogDefinition As AnalogDefinition, _
    value As Double _
)
public:
AnalogValue(
    DataCell^ parent,
    AnalogDefinition^ analogDefinition,
    double value
)
Parameters
parent (DataCell)
The DataCell parent of this AnalogValue.
analogDefinition (AnalogDefinition)
The AnalogDefinition associated with this AnalogValue.
value (Double)
The floating point value that represents this AnalogValue.


AnalogValue Constructor (parent, analogDefinition)

AnalogValue Constructor (parent, analogDefinition)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogValue ► AnalogValue(IDataCell, IAnalogDefinition)
Creates a new AnalogValue.
Declaration Syntax
C# Visual Basic Visual C++
public AnalogValue(
    IDataCell parent,
    IAnalogDefinition analogDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    analogDefinition As IAnalogDefinition _
)
public:
AnalogValue(
    IDataCell^ parent,
    IAnalogDefinition^ analogDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this AnalogValue.
analogDefinition (IAnalogDefinition)
The IAnalogDefinition associated with this AnalogValue.


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogValue ► Definition
Gets or sets the AnalogDefinition associated with this AnalogValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual AnalogDefinition Definition { get; set; }
Public Overridable Property Definition As AnalogDefinition
    Get
    Set
public:
virtual property AnalogDefinition^ Definition {
    AnalogDefinition^ get ();
    void set (AnalogDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogValue ► Parent
Gets or sets the DataCell parent of this AnalogValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


ChannelFlags Enumeration

ChannelFlags Enumeration
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ChannelFlags
Channel flags enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[FlagsAttribute]
public enum ChannelFlags
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration ChannelFlags
[SerializableAttribute]
[FlagsAttribute]
public enum class ChannelFlags
Members
Member | Description
DataIsValid | Valid if not set (yes = 0).
TransmissionErrors | Errors if set (yes = 1).
PmuSynchronized | Not sync'd if set (yes = 0).
DataSortedByArrival | Data out of sync if set (yes = 1).
DataSortedByTimestamp | Sorted by timestamp if not set (yes = 0).
PdcExchangeFormat | PDC format if set (yes = 1).
MacrodyneFormat | Macrodyne or IEEE format (Macrodyne = 1).
TimestampIncluded | Timestamp included if not set (yes = 0).
NoFlags | No flags.


Common Class

Common Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Common
Common BPA PDCstream declarations and functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class Common
Public NotInheritable Class Common
public ref class Common abstract sealed
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DescriptorPacketFlag | Descriptor packet flag.
 | MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
 | MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
 | MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
 | MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
 | PhasorFileFormatFlag | Phasor file format flag.
Inheritance Hierarchy
Object
Common


DescriptorPacketFlag Field

DescriptorPacketFlag Field
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Common ► DescriptorPacketFlag
Descriptor packet flag.
Declaration Syntax
C# Visual Basic Visual C++
public const byte DescriptorPacketFlag
Public Const DescriptorPacketFlag As Byte
public:
literal unsigned char DescriptorPacketFlag


MaximumAnalogValues Field

MaximumAnalogValues Field
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Common ► MaximumAnalogValues
Absolute maximum number of possible analog values that could fit into a data frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumAnalogValues
Public Const MaximumAnalogValues As UShort
public:
literal unsigned short MaximumAnalogValues


MaximumDataLength Field

MaximumDataLength Field
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Common ► MaximumDataLength
Absolute maximum data length (in bytes) that could fit into any frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumDataLength
Public Const MaximumDataLength As UShort
public:
literal unsigned short MaximumDataLength


MaximumDigitalValues Field

MaximumDigitalValues Field
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Common ► MaximumDigitalValues
Absolute maximum number of possible digital values that could fit into a data frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumDigitalValues
Public Const MaximumDigitalValues As UShort
public:
literal unsigned short MaximumDigitalValues


MaximumPhasorValues Field

MaximumPhasorValues Field
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Common ► MaximumPhasorValues
Absolute maximum number of possible phasor values that could fit into a data frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumPhasorValues
Public Const MaximumPhasorValues As UShort
public:
literal unsigned short MaximumPhasorValues


PhasorFileFormatFlag Field

PhasorFileFormatFlag Field
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Common ► PhasorFileFormatFlag
Phasor file format flag.
Declaration Syntax
C# Visual Basic Visual C++
public const byte PhasorFileFormatFlag
Public Const PhasorFileFormatFlag As Byte
public:
literal unsigned char PhasorFileFormatFlag


CommonFrameHeader Class

CommonFrameHeader Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader
Represents the common header for all BPA PDCstream frames of data.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CommonFrameHeader : ICommonHeader<FrameType>,
    ISerializable
<SerializableAttribute> _
Public Class CommonFrameHeader _
    Implements ICommonHeader(Of FrameType), ISerializable
[SerializableAttribute]
public ref class CommonFrameHeader : ICommonHeader<FrameType>,
    ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommonFrameHeader(Byte) | Creates a new CommonFrameHeader from specified parameters.
 | CommonFrameHeader(Boolean, Boolean, ConfigurationFrame, array<Byte>[]()[][], Int32, Int32) | Creates a new CommonFrameHeader from given binaryImage.
 | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
 | BinaryImage | Gets the binary image of the common header portion of this frame.
 | DataLength | Gets or sets the length of the data in the BPA PDCstream frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).
 | DstHeaderFixedLength | Total fixed length of CommonFrameHeader for header in phasor file format data.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileType | Gets or sets file type for this CommonFrameHeader used when frame is configuration frame and use phasor file format is true.
 | FileVersion | Gets or sets file version for this CommonFrameHeader used when frame is configuration frame and use phasor file format is true.
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FixedLength | Total fixed length of CommonFrameHeader, streaming data or data row in phasor file format data.
 | FrameLength | Gets or sets the BPA PDCstream frame length of this frame.
 | FrameRate | Gets frame rate based on sample rate and sample interval for the CommonFrameHeader object.
 | FrameType | Gets the fundamental frame type of this frame.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PacketNumber | Gets or sets the BPA PDCstream packet number of this frame - set to 00 for configuration frame
 | PmuCount | Gets or sets PMU count (i.e., number of cells) for the CommonFrameHeader object when use phasor file format is true.
 | PreTriggerRows | Gets or sets pre-trigger rows for the CommonFrameHeader object when use phasor file format is true.
 | RoughTimestamp | Gets rough timestamp, accuarate to the second, that can be used until configuration frame arrives.
 | RowFlags | Gets or sets row flags for this CommonFrameHeader when frame is a data frame and use phasor file format is true.
 | RowLength | Gets or sets row length for the CommonFrameHeader object when use phasor file format is true.
 | SampleInterval | Gets or sets sample interval for the CommonFrameHeader object.
 | SampleRate | Gets or sets sample rate for the CommonFrameHeader object.
 | SourceID | Gets or sets source ID for the CommonFrameHeader object.
 | StartSample | Gets or sets start sample for the CommonFrameHeader object.
 | State | Gets or sets the parsing state for the CommonFrameHeader object.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalRows | Gets or sets total number of data rows for the CommonFrameHeader object when use phasor file format is true.
 | TriggerPMU | Gets or sets trigger PMU number for the CommonFrameHeader object when use phasor file format is true.
 | TriggerSample | Gets or sets trigger sample for the CommonFrameHeader object when use phasor file format is true.
 | TriggerTime | Gets or sets trigger time for the CommonFrameHeader object when use phasor file format is true.
 | TriggerType | Gets or sets trigger type for the CommonFrameHeader object when use phasor file format is true.
 | TypeID | Gets or sets the BPA PDCstream specific frame type of this frame.
 | UsePhasorDataFileFormat | Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
 | UserInformation | Gets or sets free-form user information that can be added to the CommonFrameHeader object when use phasor file format is true.
 | WordCount | Gets or sets the BPA PDcstream word count.
Inheritance Hierarchy
Object
CommonFrameHeader


CommonFrameHeader Constructor

CommonFrameHeader Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► CommonFrameHeader()()()()
Members
Icon | Member | Description
 | CommonFrameHeader(Byte) | Creates a new CommonFrameHeader from specified parameters.
 | CommonFrameHeader(Boolean, Boolean, ConfigurationFrame, array<Byte>[]()[][], Int32, Int32) | Creates a new CommonFrameHeader from given binaryImage.
 | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.


CommonFrameHeader Constructor (parseWordCountFromByte, usePhasorDataFileFormat, configFrame, binaryImage, startIndex, length)

CommonFrameHeader Constructor (parseWordCountFromByte, usePhasorDataFileFormat, configFrame, binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► CommonFrameHeader(Boolean, Boolean, ConfigurationFrame, array<Byte>[]()[][], Int32, Int32)
Creates a new CommonFrameHeader from given binaryImage.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader(
    bool parseWordCountFromByte,
    bool usePhasorDataFileFormat,
    ConfigurationFrame configFrame,
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Sub New ( _
    parseWordCountFromByte As Boolean, _
    usePhasorDataFileFormat As Boolean, _
    configFrame As ConfigurationFrame, _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
)
public:
CommonFrameHeader(
    bool parseWordCountFromByte,
    bool usePhasorDataFileFormat,
    ConfigurationFrame^ configFrame,
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
)
Parameters
parseWordCountFromByte (Boolean)
Defines flag that interprets word count in packet header from a byte instead of a word.
usePhasorDataFileFormat (Boolean)
Defines flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
configFrame (ConfigurationFrame)
Previously parsed configuration frame, if available.
binaryImage (array< Byte >[]()[][])
Buffer that contains data to parse.
startIndex (Int32)
Start index into buffer where valid data begins.
length (Int32)
Maximum length of valid data from start index.


CommonFrameHeader Constructor (packetNumber)

CommonFrameHeader Constructor (packetNumber)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► CommonFrameHeader(Byte)
Creates a new CommonFrameHeader from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader(
    byte packetNumber
)
Public Sub New ( _
    packetNumber As Byte _
)
public:
CommonFrameHeader(
    unsigned char packetNumber
)
Parameters
packetNumber (Byte)
The BPA PDCstream packet number, configuration frame is packet zero.


CommonFrameHeader Constructor (info, context)

CommonFrameHeader Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► CommonFrameHeader(SerializationInfo, StreamingContext)
Creates a new CommonFrameHeader from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected CommonFrameHeader(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CommonFrameHeader(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


BinaryImage Property

BinaryImage Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► BinaryImage
Gets the binary image of the common header portion of this frame.
Declaration Syntax
C# Visual Basic Visual C++
public byte[] BinaryImage { get; }
Public ReadOnly Property BinaryImage As Byte()
    Get
public:
property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get ();
}


DataLength Property

DataLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► DataLength
Gets or sets the length of the data in the BPA PDCstream frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).
Declaration Syntax
C# Visual Basic Visual C++
public ushort DataLength { get; set; }
Public Property DataLength As UShort
    Get
    Set
public:
property unsigned short DataLength {
    unsigned short get ();
    void set (unsigned short value);
}


DstHeaderFixedLength Field

DstHeaderFixedLength Field
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► DstHeaderFixedLength
Total fixed length of CommonFrameHeader for header in phasor file format data.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort DstHeaderFixedLength
Public Const DstHeaderFixedLength As UShort
public:
literal unsigned short DstHeaderFixedLength


FileType Property

FileType Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► FileType
Gets or sets file type for this CommonFrameHeader used when frame is configuration frame and use phasor file format is true.
Declaration Syntax
C# Visual Basic Visual C++
public FileType FileType { get; set; }
Public Property FileType As FileType
    Get
    Set
public:
property FileType FileType {
    FileType get ();
    void set (FileType value);
}


FileVersion Property

FileVersion Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► FileVersion
Gets or sets file version for this CommonFrameHeader used when frame is configuration frame and use phasor file format is true.
Declaration Syntax
C# Visual Basic Visual C++
public FileVersion FileVersion { get; set; }
Public Property FileVersion As FileVersion
    Get
    Set
public:
property FileVersion FileVersion {
    FileVersion get ();
    void set (FileVersion value);
}


FixedLength Field

FixedLength Field
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► FixedLength
Total fixed length of CommonFrameHeader, streaming data or data row in phasor file format data.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort FixedLength
Public Const FixedLength As UShort
public:
literal unsigned short FixedLength


FrameLength Property

FrameLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► FrameLength
Gets or sets the BPA PDCstream frame length of this frame.
Declaration Syntax
C# Visual Basic Visual C++
public ushort FrameLength { get; set; }
Public Property FrameLength As UShort
    Get
    Set
public:
property unsigned short FrameLength {
    unsigned short get ();
    void set (unsigned short value);
}


FrameRate Property

FrameRate Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► FrameRate
Gets frame rate based on sample rate and sample interval for the CommonFrameHeader object.
Declaration Syntax
C# Visual Basic Visual C++
public double FrameRate { get; }
Public ReadOnly Property FrameRate As Double
    Get
public:
property double FrameRate {
    double get ();
}


FrameType Property

FrameType Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► FrameType
Gets the fundamental frame type of this frame.
Declaration Syntax
C# Visual Basic Visual C++
public FundamentalFrameType FrameType { get; }
Public ReadOnly Property FrameType As FundamentalFrameType
    Get
public:
property FundamentalFrameType FrameType {
    FundamentalFrameType get ();
}
Remarks
Frames are generally classified as data, configuration or header frames. This returns the general frame classification.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


PacketNumber Property

PacketNumber Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► PacketNumber
Gets or sets the BPA PDCstream packet number of this frame - set to 00 for configuration frame
Declaration Syntax
C# Visual Basic Visual C++
public byte PacketNumber { get; set; }
Public Property PacketNumber As Byte
    Get
    Set
public:
property unsigned char PacketNumber {
    unsigned char get ();
    void set (unsigned char value);
}


PmuCount Property

PmuCount Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► PmuCount
Gets or sets PMU count (i.e., number of cells) for the CommonFrameHeader object when use phasor file format is true.
Declaration Syntax
C# Visual Basic Visual C++
public uint PmuCount { get; set; }
Public Property PmuCount As UInteger
    Get
    Set
public:
property unsigned int PmuCount {
    unsigned int get ();
    void set (unsigned int value);
}


PreTriggerRows Property

PreTriggerRows Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► PreTriggerRows
Gets or sets pre-trigger rows for the CommonFrameHeader object when use phasor file format is true.
Declaration Syntax
C# Visual Basic Visual C++
public uint PreTriggerRows { get; set; }
Public Property PreTriggerRows As UInteger
    Get
    Set
public:
property unsigned int PreTriggerRows {
    unsigned int get ();
    void set (unsigned int value);
}


RoughTimestamp Property

RoughTimestamp Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► RoughTimestamp
Gets rough timestamp, accuarate to the second, that can be used until configuration frame arrives.
Declaration Syntax
C# Visual Basic Visual C++
public Ticks RoughTimestamp { get; }
Public ReadOnly Property RoughTimestamp As Ticks
    Get
public:
property Ticks RoughTimestamp {
    Ticks get ();
}


RowFlags Property

RowFlags Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► RowFlags
Gets or sets row flags for this CommonFrameHeader when frame is a data frame and use phasor file format is true.
Declaration Syntax
C# Visual Basic Visual C++
public uint RowFlags { get; set; }
Public Property RowFlags As UInteger
    Get
    Set
public:
property unsigned int RowFlags {
    unsigned int get ();
    void set (unsigned int value);
}


RowLength Property

RowLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► RowLength
Gets or sets row length for the CommonFrameHeader object when use phasor file format is true.
Declaration Syntax
C# Visual Basic Visual C++
public uint RowLength { get; set; }
Public Property RowLength As UInteger
    Get
    Set
public:
property unsigned int RowLength {
    unsigned int get ();
    void set (unsigned int value);
}


SampleInterval Property

SampleInterval Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► SampleInterval
Gets or sets sample interval for the CommonFrameHeader object.
Declaration Syntax
C# Visual Basic Visual C++
public ushort SampleInterval { get; set; }
Public Property SampleInterval As UShort
    Get
    Set
public:
property unsigned short SampleInterval {
    unsigned short get ();
    void set (unsigned short value);
}


SampleRate Property

SampleRate Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► SampleRate
Gets or sets sample rate for the CommonFrameHeader object.
Declaration Syntax
C# Visual Basic Visual C++
public ushort SampleRate { get; set; }
Public Property SampleRate As UShort
    Get
    Set
public:
property unsigned short SampleRate {
    unsigned short get ();
    void set (unsigned short value);
}


SourceID Property

SourceID Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► SourceID
Gets or sets source ID for the CommonFrameHeader object.
Declaration Syntax
C# Visual Basic Visual C++
public string SourceID { get; set; }
Public Property SourceID As String
    Get
    Set
public:
property String^ SourceID {
    String^ get ();
    void set (String^ value);
}


StartSample Property

StartSample Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► StartSample
Gets or sets start sample for the CommonFrameHeader object.
Declaration Syntax
C# Visual Basic Visual C++
public uint StartSample { get; set; }
Public Property StartSample As UInteger
    Get
    Set
public:
property unsigned int StartSample {
    unsigned int get ();
    void set (unsigned int value);
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► State
Gets or sets the parsing state for the CommonFrameHeader object.
Declaration Syntax
C# Visual Basic Visual C++
public IChannelParsingState State { get; set; }
Public Property State As IChannelParsingState
    Get
    Set
public:
property IChannelParsingState^ State {
    IChannelParsingState^ get ();
    void set (IChannelParsingState^ value);
}


TotalRows Property

TotalRows Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► TotalRows
Gets or sets total number of data rows for the CommonFrameHeader object when use phasor file format is true.
Declaration Syntax
C# Visual Basic Visual C++
public uint TotalRows { get; set; }
Public Property TotalRows As UInteger
    Get
    Set
public:
property unsigned int TotalRows {
    unsigned int get ();
    void set (unsigned int value);
}


TriggerPMU Property

TriggerPMU Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► TriggerPMU
Gets or sets trigger PMU number for the CommonFrameHeader object when use phasor file format is true.
Declaration Syntax
C# Visual Basic Visual C++
public ushort TriggerPMU { get; set; }
Public Property TriggerPMU As UShort
    Get
    Set
public:
property unsigned short TriggerPMU {
    unsigned short get ();
    void set (unsigned short value);
}


TriggerSample Property

TriggerSample Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► TriggerSample
Gets or sets trigger sample for the CommonFrameHeader object when use phasor file format is true.
Declaration Syntax
C# Visual Basic Visual C++
public uint TriggerSample { get; set; }
Public Property TriggerSample As UInteger
    Get
    Set
public:
property unsigned int TriggerSample {
    unsigned int get ();
    void set (unsigned int value);
}


TriggerTime Property

TriggerTime Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► TriggerTime
Gets or sets trigger time for the CommonFrameHeader object when use phasor file format is true.
Declaration Syntax
C# Visual Basic Visual C++
public Ticks TriggerTime { get; set; }
Public Property TriggerTime As Ticks
    Get
    Set
public:
property Ticks TriggerTime {
    Ticks get ();
    void set (Ticks value);
}


TriggerType Property

TriggerType Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► TriggerType
Gets or sets trigger type for the CommonFrameHeader object when use phasor file format is true.
Declaration Syntax
C# Visual Basic Visual C++
public ushort TriggerType { get; set; }
Public Property TriggerType As UShort
    Get
    Set
public:
property unsigned short TriggerType {
    unsigned short get ();
    void set (unsigned short value);
}


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► TypeID
Gets or sets the BPA PDCstream specific frame type of this frame.
Declaration Syntax
C# Visual Basic Visual C++
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}
Remarks

This returns the protocol specific frame classification which uniquely identifies the frame type.

This is the TypeID()()()() implementation.


UsePhasorDataFileFormat Property

UsePhasorDataFileFormat Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► UsePhasorDataFileFormat
Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Declaration Syntax
C# Visual Basic Visual C++
public bool UsePhasorDataFileFormat { get; set; }
Public Property UsePhasorDataFileFormat As Boolean
    Get
    Set
public:
property bool UsePhasorDataFileFormat {
    bool get ();
    void set (bool value);
}


UserInformation Property

UserInformation Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► UserInformation
Gets or sets free-form user information that can be added to the CommonFrameHeader object when use phasor file format is true.
Declaration Syntax
C# Visual Basic Visual C++
public string UserInformation { get; set; }
Public Property UserInformation As String
    Get
    Set
public:
property String^ UserInformation {
    String^ get ();
    void set (String^ value);
}


WordCount Property

WordCount Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► CommonFrameHeader ► WordCount
Gets or sets the BPA PDcstream word count.
Declaration Syntax
C# Visual Basic Visual C++
public ushort WordCount { get; set; }
Public Property WordCount As UShort
    Get
    Set
public:
property unsigned short WordCount {
    unsigned short get ();
    void set (unsigned short value);
}


Concentrator Class

Concentrator Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Concentrator
Represents a BPA PDCstream phasor data concentrator.
Declaration Syntax
C# Visual Basic Visual C++
public class Concentrator : PhasorDataConcentratorBase
Public Class Concentrator _
    Inherits PhasorDataConcentratorBase
public ref class Concentrator : public PhasorDataConcentratorBase
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Concentrator()()()() | Initializes a new instance of the Concentrator class
 | ActiveConnections | Gets the total number of active socket connections. (Inherited from PhasorDataConcentratorBase.)
 | AllowPreemptivePublishing()()()() | (Inherited from ConcentratorBase.)
 | AllowSortsByArrival()()()() | (Inherited from ConcentratorBase.)
 | AnalogScalingValue | Gets or sets the integer scaling value to apply to analog values published by this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | AssignMeasurementToFrame(IFrame, IMeasurement) | Assign IMeasurement to its IFrame. (Inherited from PhasorDataConcentratorBase.)
 | AssignParentCollection(IAdapterCollection) | (Inherited from ActionAdapterBase.)
 | AutoPublishConfigurationFrame | Gets or sets flag that determines if configuration frame should be automatically published at the top of each minute on the data channel. (Inherited from PhasorDataConcentratorBase.)
 | AutoStart()()()() | (Inherited from ActionAdapterBase.)
 | AutoStartDataChannel | Gets or sets flag that determines if concentrator will automatically start data channel. (Inherited from PhasorDataConcentratorBase.)
 | AverageLatency | Gets the average latency in milliseconds over the last test interval. (Inherited from PhasorDataConcentratorBase.)
 | AveragePublicationTimePerFrame()()()() | (Inherited from ConcentratorBase.)
 | BaseConfigurationFrame | Gets the protocol independent ConfigurationFrame defined for this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | CacheConfigurationFrame(IConfigurationFrame, String) | Serialize configuration frame to cache folder for later use (if needed). (Inherited from PhasorDataConcentratorBase.)
 | CommandChannel | Gets or sets reference to TcpServer command channel, attaching and/or detaching to events as needed. (Inherited from PhasorDataConcentratorBase.)
 | ConfigurationFrame | Gets or sets the protocol specific IConfigurationFrame used to send to clients for protocol parsing. (Inherited from PhasorDataConcentratorBase.)
 | ConnectedClientCount | Gets the current number of known connected clients on the command channel. (Inherited from PhasorDataConcentratorBase.)
 | ConnectionString()()()() | (Inherited from ActionAdapterBase.)
 | CoordinateFormat | Gets or sets the CoordinateFormat defined for this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | CreateNewConfigurationFrame(ConfigurationFrame) | Creates a new BPA PDCstream specific IConfigurationFrame based on provided protocol independent baseConfigurationFrame. (Overrides PhasorDataConcentratorBase.CreateNewConfigurationFrame(ConfigurationFrame).)
 | CreateNewFrame(Ticks) | Creates a new BPA PDCstream specific DataFrame for the given timestamp. (Overrides ConcentratorBase.CreateNewFrame(Ticks).)
 | CurrentScalingValue | Gets or sets the integer scaling value to apply to current values published by this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | DataChannel | Gets or sets reference to UdpServer data channel, attaching and/or detaching to events as needed. (Inherited from PhasorDataConcentratorBase.)
 | DataFormat | Gets or sets the DataFormat defined for this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | DataSource()()()() | (Inherited from ActionAdapterBase.)
 | DeviceCommandHandler(Guid, String, array<Byte>[]()[][], Int32) | Handles incoming commands from devices connected over the command channel. (Inherited from PhasorDataConcentratorBase.)
 | DigitalMaskValue | Gets or sets the digital mask value made available in configuration frames for use with digital values published by this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | DiscardedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | DiscardingMeasurements()()()() | (Inherited from ConcentratorBase.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the PhasorDataConcentratorBase object and optionally releases the managed resources. (Inherited from PhasorDataConcentratorBase.)
 | Dispose()()()() | (Inherited from ConcentratorBase.)
 | Disposed()()()() | (Inherited from ConcentratorBase.)
 | DownsampledMeasurements()()()() | (Inherited from ConcentratorBase.)
 | DownsamplingMethod()()()() | (Inherited from ConcentratorBase.)
 | Enabled()()()() | (Inherited from ConcentratorBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExamineQueueState()()()() | (Inherited from ActionAdapterBase.)
 | ExpectedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | Finalize()()()() | (Inherited from ConcentratorBase.)
 | FramesAheadOfSchedule()()()() | (Inherited from ConcentratorBase.)
 | FramesPerSecond()()()() | (Inherited from ConcentratorBase.)
 | GetConnectionID(IServer, Guid) | Gets connection ID (i.e., IP:Port) for specified clientID. (Inherited from PhasorDataConcentratorBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from PhasorDataConcentratorBase.)
 | GetShortStatus(Int32) | (Inherited from ActionAdapterBase.)
 | GetSignalReference(SignalKind) | Get signal reference for specified SignalKind. (Inherited from PhasorDataConcentratorBase.)
 | GetSignalReference(SignalKind, Int32, Int32) | Get signal reference for specified SignalKind and index. (Inherited from PhasorDataConcentratorBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID()()()() | (Inherited from ActionAdapterBase.)
 | IDCode | Gets ID code defined for this PhasorDataConcentratorBase parsed from the ConnectionString()()()(). (Inherited from PhasorDataConcentratorBase.)
 | IgnoreBadTimestamps()()()() | (Inherited from ConcentratorBase.)
 | IniFileName | Gets or sets the INI based configuration file name of this Concentrator.
 | InitializationTimeout()()()() | (Inherited from ActionAdapterBase.)
 | Initialize()()()() | Initializes Concentrator. (Overrides PhasorDataConcentratorBase.Initialize()()()().)
 | Initialized()()()() | (Inherited from ActionAdapterBase.)
 | InputMeasurementKeys()()()() | (Inherited from ActionAdapterBase.)
 | InputMeasurementKeysUpdated()()()() | (Inherited from ActionAdapterBase.)
 | InputSourceIDs()()()() | (Inherited from ActionAdapterBase.)
 | IsInputMeasurement(MeasurementKey) | (Inherited from ActionAdapterBase.)
 | LagTicks()()()() | (Inherited from ConcentratorBase.)
 | LagTime()()()() | (Inherited from ConcentratorBase.)
 | LastDiscardedMeasurement()()()() | (Inherited from ConcentratorBase.)
 | LastDiscardedMeasurementLatency()()()() | (Inherited from ConcentratorBase.)
 | LastFrame()()()() | (Inherited from ConcentratorBase.)
 | LatestMeasurements()()()() | (Inherited from ConcentratorBase.)
 | LeadTime()()()() | (Inherited from ConcentratorBase.)
 | MaximumLatency | Gets the maximum latency in milliseconds over the last test interval. (Inherited from PhasorDataConcentratorBase.)
 | MaximumPublicationTimeout()()()() | (Inherited from ConcentratorBase.)
 | MeasurementsSortedByArrival()()()() | (Inherited from ConcentratorBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MillisecondsFromRealTime(Ticks) | (Inherited from ConcentratorBase.)
 | MinimumLatency | Gets the minimum latency in milliseconds over the last test interval. (Inherited from PhasorDataConcentratorBase.)
 | MinimumMeasurementsToUse()()()() | (Inherited from ActionAdapterBase.)
 | MissedSortsByTimeout()()()() | (Inherited from ConcentratorBase.)
 | Name()()()() | (Inherited from ActionAdapterBase.)
 | NewMeasurements()()()() | (Inherited from ActionAdapterBase.)
 | NominalFrequency | Gets or sets the nominal LineFrequency defined for this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | OnDiscardingMeasurements(IEnumerable<(Of <<'(IMeasurement>)>>)) | (Inherited from ConcentratorBase.)
 | OnInputMeasurementKeysUpdated()()()() | (Inherited from ActionAdapterBase.)
 | OnNewMeasurements(ICollection<(Of <<'(IMeasurement>)>>)) | (Inherited from ActionAdapterBase.)
 | OnOutputMeasurementsUpdated()()()() | (Inherited from ActionAdapterBase.)
 | OnProcessException(Exception) | (Inherited from ConcentratorBase.)
 | OnStatusMessage(String) | (Inherited from ActionAdapterBase.)
 | OnStatusMessage(String, array<Object>[]()[][]) | (Inherited from ActionAdapterBase.)
 | OnUnpublishedSamples(Int32) | (Inherited from ConcentratorBase.)
 | OutputMeasurements()()()() | (Inherited from ActionAdapterBase.)
 | OutputMeasurementsUpdated()()()() | (Inherited from ActionAdapterBase.)
 | OutputSourceIDs()()()() | (Inherited from ActionAdapterBase.)
 | Parent()()()() | (Inherited from ActionAdapterBase.)
 | PerformTimestampReasonabilityCheck()()()() | (Inherited from ConcentratorBase.)
 | ProcessByReceivedTimestamp()()()() | (Inherited from ConcentratorBase.)
 | ProcessDataValidFlag | Gets or sets flag that determines if the data valid flag assignments should be processed during frame publication. (Inherited from PhasorDataConcentratorBase.)
 | ProcessedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | ProcessException()()()() | (Inherited from ConcentratorBase.)
 | ProcessingInterval()()()() | (Inherited from ConcentratorBase.)
 | ProcessMeasurementFilter()()()() | (Inherited from ActionAdapterBase.)
 | PublishedFrames()()()() | (Inherited from ConcentratorBase.)
 | PublishedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | PublishFrame(IFrame, Int32) | Publish IFrame of time-aligned collection of IMeasurement values that arrived within the concentrator's defined LagTime()()()(). (Inherited from PhasorDataConcentratorBase.)
 | QueueMeasurementForProcessing(IMeasurement) | Queues a single measurement for processing. (Inherited from PhasorDataConcentratorBase.)
 | QueueMeasurementsForProcessing(IEnumerable<(Of <<'(IMeasurement>)>>)) | Queues a collection of measurements for processing. (Inherited from PhasorDataConcentratorBase.)
 | QueueState()()()() | (Inherited from ConcentratorBase.)
 | RealTime()()()() | (Inherited from ConcentratorBase.)
 | ReceivedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | RequestedInputMeasurementKeys()()()() | (Inherited from ActionAdapterBase.)
 | RequestedOutputMeasurementKeys()()()() | (Inherited from ActionAdapterBase.)
 | ResetLatencyCounters()()()() | Resets counters related to latency calculations. (Inherited from PhasorDataConcentratorBase.)
 | ResetStatistics()()()() | (Inherited from ActionAdapterBase.)
 | RunTime()()()() | (Inherited from ConcentratorBase.)
 | SecondsFromRealTime(Ticks) | (Inherited from ConcentratorBase.)
 | SetInitializedState(Boolean) | (Inherited from ActionAdapterBase.)
 | SetTemporalConstraint(String, String, String) | (Inherited from ActionAdapterBase.)
 | Settings()()()() | (Inherited from ActionAdapterBase.)
 | SortMeasurement(IMeasurement) | (Inherited from ConcentratorBase.)
 | SortMeasurements(IEnumerable<(Of <<'(IMeasurement>)>>)) | (Inherited from ConcentratorBase.)
 | Start()()()() | Starts the PhasorDataConcentratorBase, if it is not already running. (Inherited from PhasorDataConcentratorBase.)
 | StartDataChannel()()()() | Starts the PhasorDataConcentratorBase real-time data stream. (Inherited from PhasorDataConcentratorBase.)
 | StartTime()()()() | (Inherited from ConcentratorBase.)
 | StartTimeConstraint()()()() | (Inherited from ActionAdapterBase.)
 | Status | Returns the detailed status of this Concentrator. (Overrides PhasorDataConcentratorBase.Status.)
 | StatusMessage()()()() | (Inherited from ActionAdapterBase.)
 | Stop()()()() | Stops the PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | StopDataChannel()()()() | Stops the PhasorDataConcentratorBase real-time data stream. (Inherited from PhasorDataConcentratorBase.)
 | StopTime()()()() | (Inherited from ConcentratorBase.)
 | StopTimeConstraint()()()() | (Inherited from ActionAdapterBase.)
 | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Inherited from PhasorDataConcentratorBase.)
 | TicksPerFrame()()()() | (Inherited from ConcentratorBase.)
 | TimeResolution()()()() | (Inherited from ConcentratorBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalPublicationTime()()()() | (Inherited from ConcentratorBase.)
 | TrackLatestMeasurements()()()() | (Inherited from ConcentratorBase.)
 | TrackPublishedTimestamp()()()() | (Inherited from ConcentratorBase.)
 | TryGetMinimumNeededMeasurements(IFrame, array<IMeasurement>[]()[][]%) | (Inherited from ActionAdapterBase.)
 | UnpublishedSamples()()()() | (Inherited from ConcentratorBase.)
 | UpdateConfiguration()()()() | Reloads the configuration for this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | UseLocalClockAsRealTime()()()() | (Inherited from ConcentratorBase.)
 | UsePrecisionTimer()()()() | (Inherited from ConcentratorBase.)
 | VoltageScalingValue | Gets or sets the integer scaling value to apply to voltage values published by this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | WaitForInitialize(Int32) | (Inherited from ActionAdapterBase.)
 | WaitHandleExpirations()()()() | (Inherited from ConcentratorBase.)
Inheritance Hierarchy
Object
 | ConcentratorBase
 |  | ActionAdapterBase
 |  |  | PhasorDataConcentratorBase
 |  |  |  | Concentrator


Concentrator Constructor

Concentrator Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Concentrator ► Concentrator()()()()
Initializes a new instance of the Concentrator class
Declaration Syntax
C# Visual Basic Visual C++
public Concentrator()
Public Sub New
public:
Concentrator()


CreateNewConfigurationFrame Method (baseConfigurationFrame)

CreateNewConfigurationFrame Method (baseConfigurationFrame)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Concentrator ► CreateNewConfigurationFrame(ConfigurationFrame)
Creates a new BPA PDCstream specific IConfigurationFrame based on provided protocol independent baseConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
protected override IConfigurationFrame CreateNewConfigurationFrame(
    ConfigurationFrame baseConfigurationFrame
)
Protected Overrides Function CreateNewConfigurationFrame ( _
    baseConfigurationFrame As ConfigurationFrame _
) As IConfigurationFrame
protected:
virtual IConfigurationFrame^ CreateNewConfigurationFrame(
    ConfigurationFrame^ baseConfigurationFrame
) override
Parameters
baseConfigurationFrame (ConfigurationFrame)
Protocol independent ConfigurationFrame.
Return Value
A new BPA PDCstream specific IConfigurationFrame.


CreateNewFrame Method (timestamp)

CreateNewFrame Method (timestamp)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Concentrator ► CreateNewFrame(Ticks)
Creates a new BPA PDCstream specific DataFrame for the given timestamp.
Declaration Syntax
C# Visual Basic Visual C++
protected override IFrame CreateNewFrame(
    Ticks timestamp
)
Protected Overrides Function CreateNewFrame ( _
    timestamp As Ticks _
) As IFrame
protected:
virtual IFrame^ CreateNewFrame(
    Ticks timestamp
) override
Parameters
timestamp (Ticks)
Timestamp for new IFrame in Ticks.
Return Value
New BPA PDCstream DataFrame at given timestamp.
Remarks
Note that the ConcentratorBase class (which the ActionAdapterBase is derived from) is designed to sort IMeasurement implementations into an IFrame which represents a collection of measurements at a given timestamp. The CreateNewFrame method allows consumers to create their own IFrame implementations, in our case this will be a BPA PDCstream data frame.


IniFileName Property

IniFileName Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Concentrator ► IniFileName
Gets or sets the INI based configuration file name of this Concentrator.
Declaration Syntax
C# Visual Basic Visual C++
public string IniFileName { get; set; }
Public Property IniFileName As String
    Get
    Set
public:
property String^ IniFileName {
    String^ get ();
    void set (String^ value);
}


Initialize Method

Initialize Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Concentrator ► Initialize()()()()
Initializes Concentrator.
Declaration Syntax
C# Visual Basic Visual C++
public override void Initialize()
Public Overrides Sub Initialize
public:
virtual void Initialize() override


Status Property

Status Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Concentrator ► Status
Returns the detailed status of this Concentrator.
Declaration Syntax
C# Visual Basic Visual C++
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
public:
virtual property String^ Status {
    String^ get () override;
}


ConfigurationCell Class

ConfigurationCell Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell
Represents the BPA PDCstream implementation of a IConfigurationCell that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationCell : ConfigurationCellBase
<SerializableAttribute> _
Public Class ConfigurationCell _
    Inherits ConfigurationCellBase
[SerializableAttribute]
public ref class ConfigurationCell : public ConfigurationCellBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCell(IConfigurationFrame) | Creates a new ConfigurationCell.
 | ConfigurationCell(ConfigurationFrame, UInt16, LineFrequency) | Creates a new ConfigurationCell from specified parameters.
 | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
 | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.AnalogDataFormat.)
 | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationCell object. (Overrides ConfigurationCellBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ConfigurationCell object. (Overrides ConfigurationCellBase.BodyImage.)
 | BodyLength | Gets the length of the BodyImage. (Overrides ConfigurationCellBase.BodyLength.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
 | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
 | ConfigurationFileCell | Gets or sets reference to the ConfigurationCell loaded from the configuration file associated this ConfigurationCell.
 | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
 | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage | Gets the binary footer image of the ConfigurationCell object. (Overrides ConfigurationCellBase.FooterImage.)
 | FooterLength | Gets the length of the FooterImage. (Overrides ConfigurationCellBase.FooterLength.)
 | FormatFlags | Gets or sets format flags of this ConfigurationCell.
 | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBase.FrequencyDataFormat.)
 | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBase.FrequencyDefinition.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the ConfigurationCell object. (Overrides ConfigurationCellBase.HeaderImage.)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides ConfigurationCellBase.HeaderLength.)
 | IDCode | Gets or sets the numeric ID code for this ConfigurationCell. (Overrides ChannelCellBase.IDCode.)
 | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCell. (Overrides ConfigurationCellBase.IDLabelLength.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsPdcBlockSection | Gets flag that determines if current SectionEntry defines a PDC block section.
 | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCell. (Overrides ConfigurationCellBase.MaximumStationNameLength.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBase.NominalFrequency.)
 | Offset | Gets or sets BPA PDCstream descriptor offset of this ConfigurationCell in its data packet.
 | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides ConfigurationCellBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary footer image. (Overrides ConfigurationCellBase.ParseFooterImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides ConfigurationCellBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.PhasorCoordinateFormat.)
 | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.PhasorDataFormat.)
 | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCell. (Overrides ConfigurationCellBase.PhasorDefinitions.)
 | Reserved | Gets or sets reserved word of this ConfigurationCell.
 | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | SectionEntry | Gets or sets section entry in INI based configuration file for this ConfigurationCell.
 | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | StationName | Gets or sets the station name of this ConfigurationCell. (Overrides ConfigurationCellBase.StationName.)
 | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | UsePhasorDataFileFormat | Gets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | ConfigurationCellBase
 |  |  |  |  | ConfigurationCell


ConfigurationCell Constructor

ConfigurationCell Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► ConfigurationCell()()()()
Members
Icon | Member | Description
 | ConfigurationCell(IConfigurationFrame) | Creates a new ConfigurationCell.
 | ConfigurationCell(ConfigurationFrame, UInt16, LineFrequency) | Creates a new ConfigurationCell from specified parameters.
 | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.


ConfigurationCell Constructor (info, context)

ConfigurationCell Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► ConfigurationCell(SerializationInfo, StreamingContext)
Creates a new ConfigurationCell from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationCell(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationCell Constructor (parent, idCode, nominalFrequency)

ConfigurationCell Constructor (parent, idCode, nominalFrequency)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► ConfigurationCell(ConfigurationFrame, UInt16, LineFrequency)
Creates a new ConfigurationCell from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell(
    ConfigurationFrame parent,
    ushort idCode,
    LineFrequency nominalFrequency
)
Public Sub New ( _
    parent As ConfigurationFrame, _
    idCode As UShort, _
    nominalFrequency As LineFrequency _
)
public:
ConfigurationCell(
    ConfigurationFrame^ parent,
    unsigned short idCode,
    LineFrequency nominalFrequency
)
Parameters
parent (ConfigurationFrame)
The reference to parent ConfigurationFrame of this ConfigurationCell.
idCode (UInt16)
The numeric ID code for this ConfigurationCell.
nominalFrequency (LineFrequency)
The nominal LineFrequency of the FrequencyDefinition of this ConfigurationCell.


ConfigurationCell Constructor (parent)

ConfigurationCell Constructor (parent)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► ConfigurationCell(IConfigurationFrame)
Creates a new ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell(
    IConfigurationFrame parent
)
Public Sub New ( _
    parent As IConfigurationFrame _
)
public:
ConfigurationCell(
    IConfigurationFrame^ parent
)
Parameters
parent (IConfigurationFrame)
The reference to parent IConfigurationFrame of this ConfigurationCell.


AnalogDataFormat Property

AnalogDataFormat Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► AnalogDataFormat
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat AnalogDataFormat { get; set; }
Public Overrides Property AnalogDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat AnalogDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationCell object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► BodyImage
Gets the binary body image of the ConfigurationCell object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}


ConfigurationFileCell Property

ConfigurationFileCell Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► ConfigurationFileCell
Gets or sets reference to the ConfigurationCell loaded from the configuration file associated this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell ConfigurationFileCell { get; set; }
Public Property ConfigurationFileCell As ConfigurationCell
    Get
    Set
public:
property ConfigurationCell^ ConfigurationFileCell {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


FooterImage Property

FooterImage Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► FooterImage
Gets the binary footer image of the ConfigurationCell object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] FooterImage { get; }
Protected Overrides ReadOnly Property FooterImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ FooterImage {
    array<unsigned char>^ get () override;
}


FooterLength Property

FooterLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► FooterLength
Gets the length of the FooterImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int FooterLength { get; }
Protected Overrides ReadOnly Property FooterLength As Integer
    Get
protected:
virtual property int FooterLength {
    int get () override;
}


FormatFlags Property

FormatFlags Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► FormatFlags
Gets or sets format flags of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public FormatFlags FormatFlags { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Property FormatFlags As FormatFlags
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
public:
property FormatFlags FormatFlags {
    FormatFlags get ();
    void set (FormatFlags value);
}
Remarks
These are bit flags, use properties to change basic values.


FrequencyDataFormat Property

FrequencyDataFormat Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► FrequencyDataFormat
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat FrequencyDataFormat { get; set; }
Public Overrides Property FrequencyDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}


FrequencyDefinition Property

FrequencyDefinition Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► FrequencyDefinition
Gets or sets the IFrequencyDefinition of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override IFrequencyDefinition FrequencyDefinition { get; set; }
Public Overrides Property FrequencyDefinition As IFrequencyDefinition
    Get
    Set
public:
virtual property IFrequencyDefinition^ FrequencyDefinition {
    IFrequencyDefinition^ get () override;
    void set (IFrequencyDefinition^ value) override;
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► HeaderImage
Gets the binary header image of the ConfigurationCell object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► IDCode
Gets or sets the numeric ID code for this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override ushort IDCode { get; set; }
Public Overrides Property IDCode As UShort
    Get
    Set
public:
virtual property unsigned short IDCode {
    unsigned short get () override;
    void set (unsigned short value) override;
}


IDLabelLength Property

IDLabelLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► IDLabelLength
Gets the length of the IDLabel of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override int IDLabelLength { get; }
Public Overrides ReadOnly Property IDLabelLength As Integer
    Get
public:
virtual property int IDLabelLength {
    int get () override;
}


IsPdcBlockSection Property

IsPdcBlockSection Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► IsPdcBlockSection
Gets flag that determines if current SectionEntry defines a PDC block section.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPdcBlockSection { get; }
Public ReadOnly Property IsPdcBlockSection As Boolean
    Get
public:
property bool IsPdcBlockSection {
    bool get ();
}


MaximumStationNameLength Property

MaximumStationNameLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► MaximumStationNameLength
Gets the maximum length of the StationName of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override int MaximumStationNameLength { get; }
Public Overrides ReadOnly Property MaximumStationNameLength As Integer
    Get
public:
virtual property int MaximumStationNameLength {
    int get () override;
}


NominalFrequency Property

NominalFrequency Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► NominalFrequency
Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override LineFrequency NominalFrequency { get; set; }
Public Overrides Property NominalFrequency As LineFrequency
    Get
    Set
public:
virtual property LineFrequency NominalFrequency {
    LineFrequency get () override;
    void set (LineFrequency value) override;
}


Offset Property

Offset Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► Offset
Gets or sets BPA PDCstream descriptor offset of this ConfigurationCell in its data packet.
Declaration Syntax
C# Visual Basic Visual C++
public ushort Offset { get; set; }
Public Property Offset As UShort
    Get
    Set
public:
property unsigned short Offset {
    unsigned short get ();
    void set (unsigned short value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► Parent
Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame Parent { get; set; }
Public Property Parent As ConfigurationFrame
    Get
    Set
public:
property ConfigurationFrame^ Parent {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


ParseFooterImage Method (binaryImage, startIndex, length)

ParseFooterImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► ParseFooterImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary footer image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseFooterImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseFooterImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseFooterImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


PhasorCoordinateFormat Property

PhasorCoordinateFormat Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► PhasorCoordinateFormat
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override CoordinateFormat PhasorCoordinateFormat { get; set; }
Public Overrides Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () override;
    void set (CoordinateFormat value) override;
}


PhasorDataFormat Property

PhasorDataFormat Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► PhasorDataFormat
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat PhasorDataFormat { get; set; }
Public Overrides Property PhasorDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}


PhasorDefinitions Property

PhasorDefinitions Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► PhasorDefinitions
Gets a reference to the PhasorDefinitionCollection of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override PhasorDefinitionCollection PhasorDefinitions { get; }
Public Overrides ReadOnly Property PhasorDefinitions As PhasorDefinitionCollection
    Get
public:
virtual property PhasorDefinitionCollection^ PhasorDefinitions {
    PhasorDefinitionCollection^ get () override;
}


Reserved Property

Reserved Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► Reserved
Gets or sets reserved word of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public ushort Reserved { get; set; }
Public Property Reserved As UShort
    Get
    Set
public:
property unsigned short Reserved {
    unsigned short get ();
    void set (unsigned short value);
}


SectionEntry Property

SectionEntry Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► SectionEntry
Gets or sets section entry in INI based configuration file for this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public string SectionEntry { get; set; }
Public Property SectionEntry As String
    Get
    Set
public:
property String^ SectionEntry {
    String^ get ();
    void set (String^ value);
}


StationName Property

StationName Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► StationName
Gets or sets the station name of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override string StationName { get; set; }
Public Overrides Property StationName As String
    Get
    Set
public:
virtual property String^ StationName {
    String^ get () override;
    void set (String^ value) override;
}


UsePhasorDataFileFormat Property

UsePhasorDataFileFormat Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► UsePhasorDataFileFormat
Gets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Declaration Syntax
C# Visual Basic Visual C++
public bool UsePhasorDataFileFormat { get; }
Public ReadOnly Property UsePhasorDataFileFormat As Boolean
    Get
public:
property bool UsePhasorDataFileFormat {
    bool get ();
}


ConfigurationCellCollection Class

ConfigurationCellCollection Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCellCollection
Represents a BPA PDCstream implementation of a collection of IConfigurationCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationCellCollection : ConfigurationCellCollection
<SerializableAttribute> _
Public Class ConfigurationCellCollection _
    Inherits ConfigurationCellCollection
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ConfigurationCellCollection
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCellCollection()()()() | Creates a new ConfigurationCellCollection.
 | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | IndexOfIDCode(UInt16) | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
 | IndexOfIDLabel(String) | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
 | IndexOfStationName(String) | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets ConfigurationCell at specified index.
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetByIDCode(UInt16, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
 | TryGetByIDLabel(String, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
 | TryGetBySectionEntry(String, ConfigurationCell%) | Attempts to retrieve a ConfigurationCell from this ConfigurationCellCollection with the specified sectionEntry.
 | TryGetByStationName(String, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IConfigurationCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' IConfigurationCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationCellCollection
 |  |  |  |  | ConfigurationCellCollection


ConfigurationCellCollection Constructor

ConfigurationCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCellCollection ► ConfigurationCellCollection()()()()
Members
Icon | Member | Description
 | ConfigurationCellCollection()()()() | Creates a new ConfigurationCellCollection.
 | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.


ConfigurationCellCollection Constructor

ConfigurationCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCellCollection ► ConfigurationCellCollection()()()()
Creates a new ConfigurationCellCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellCollection()
Public Sub New
public:
ConfigurationCellCollection()


ConfigurationCellCollection Constructor (info, context)

ConfigurationCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCellCollection ► ConfigurationCellCollection(SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


Item Property (index)

Item Property (index)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCellCollection ► Item[([( Int32])])
Gets or sets ConfigurationCell at specified index.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ConfigurationCell
    Get
    Set
public:
property ConfigurationCell^ default[int index] {
    ConfigurationCell^ get (int index);
    void set (int index, ConfigurationCell^ value);
}
Parameters
index (Int32)
Index of value to get or set.


TryGetBySectionEntry Method (sectionEntry, configurationCell)

TryGetBySectionEntry Method (sectionEntry, configurationCell)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCellCollection ► TryGetBySectionEntry(String, ConfigurationCell%)
Attempts to retrieve a ConfigurationCell from this ConfigurationCellCollection with the specified sectionEntry.
Declaration Syntax
C# Visual Basic Visual C++
public bool TryGetBySectionEntry(
    string sectionEntry,
    ref ConfigurationCell configurationCell
)
Public Function TryGetBySectionEntry ( _
    sectionEntry As String, _
    ByRef configurationCell As ConfigurationCell _
) As Boolean
public:
bool TryGetBySectionEntry(
    String^ sectionEntry,
    ConfigurationCell^% configurationCell
)
Parameters
sectionEntry (String)
SectionEntry value to try to find.
configurationCell (ConfigurationCell %)
ConfigurationCell with the specified sectionEntry if found; otherwise null.
Return Value
true if ConfigurationCell with the specified sectionEntry is found; otherwise false.


ConfigurationFrame Class

ConfigurationFrame Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame
Represents the BPA PDCstream implementation of a IConfigurationFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationFrame : ConfigurationFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
<SerializableAttribute> _
Public Class ConfigurationFrame _
    Inherits ConfigurationFrameBase _
    Implements ISupportFrameImage(Of FrameType), ISupportBinaryImage
[SerializableAttribute]
public ref class ConfigurationFrame : public ConfigurationFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationFrame()()()() | Creates a new ConfigurationFrame.
 | ConfigurationFrame(Ticks, String, UInt16, RevisionNumber, StreamType) | Creates a new ConfigurationFrame from specified parameters.
 | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.AppendChecksum(array<Byte>[]()[][], Int32).)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrame object. (Overrides ConfigurationFrameBase.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.ChecksumIsValid(array<Byte>[]()[][], Int32).)
 | CommonHeader | Gets or sets current CommonFrameHeader.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ConfigurationFileCells | Gets reference to the ConfigurationCellCollection loaded from the configuration file of this ConfigurationFrame.
 | ConfigurationFileName | Gets the INI based configuration file name of this ConfigurationFrame.
 | ConfigurationFileReloaded | Occurs when the BPA PDCstream INI based configuration file has been reloaded.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DefaultCurrentPhasorEntry | Default current phasor INI based configuration entry.
 | DefaultFrequency | Gets the default frequency definition.
 | DefaultFrequencyEntry | Default frequency INI based configuration entry.
 | DefaultPhasorI | Gets the default current phasor definition.
 | DefaultPhasorV | Gets the default voltage phasor definition.
 | DefaultVoltagePhasorEntry | Default voltage phasor INI based configuration entry.
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetIniFileImage(IConfigurationFrame) | Gets a generated INI configuration file image.
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the ConfigurationFrame object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.Initialize(array<Byte>[]()[][], Int32, Int32).)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PacketsPerSample | Gets or sets the number of packets per sample of this ConfigurationFrame.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides BinaryImageBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Refresh()()()() | Reload BPA PDcstream INI based configuration file.
 | RevisionNumber | Gets or sets the RevisionNumber of this ConfigurationFrame.
 | SampleIndex | Gets or sets current sample index used to calculate row time stamp when source data is in the Phasor Data File Format (i.e., a DST file).
 | SetNominalFrequency(LineFrequency) | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | StreamType | Gets or sets the BPA PDCstream protocol StreamType, i.e., legacy or compact, of this ConfigurationFrame.
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets the FrameType of this ConfigurationFrame.
 | UsePhasorDataFileFormat | Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationFrameBase
 |  |  |  |  | ConfigurationFrame


ConfigurationFrame Constructor

ConfigurationFrame Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► ConfigurationFrame()()()()
Members
Icon | Member | Description
 | ConfigurationFrame()()()() | Creates a new ConfigurationFrame.
 | ConfigurationFrame(Ticks, String, UInt16, RevisionNumber, StreamType) | Creates a new ConfigurationFrame from specified parameters.
 | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.


ConfigurationFrame Constructor

ConfigurationFrame Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► ConfigurationFrame()()()()
Creates a new ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ConfigurationFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Sub New
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
ConfigurationFrame()
Remarks
This constructor is used by FrameImageParserBase to parse a BPA PDCstream configuration frame.


ConfigurationFrame Constructor (info, context)

ConfigurationFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► ConfigurationFrame(SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationFrame Constructor (timestamp, configurationFileName, packetsPerSample, revisionNumber, streamType)

ConfigurationFrame Constructor (timestamp, configurationFileName, packetsPerSample, revisionNumber, streamType)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► ConfigurationFrame(Ticks, String, UInt16, RevisionNumber, StreamType)
Creates a new ConfigurationFrame from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame(
    Ticks timestamp,
    string configurationFileName,
    ushort packetsPerSample,
    RevisionNumber revisionNumber,
    StreamType streamType
)
Public Sub New ( _
    timestamp As Ticks, _
    configurationFileName As String, _
    packetsPerSample As UShort, _
    revisionNumber As RevisionNumber, _
    streamType As StreamType _
)
public:
ConfigurationFrame(
    Ticks timestamp,
    String^ configurationFileName,
    unsigned short packetsPerSample,
    RevisionNumber revisionNumber,
    StreamType streamType
)
Parameters
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame.
configurationFileName (String)
The required external BPA PDCstream INI based configuration file.
packetsPerSample (UInt16)
Number of packets per sample.
revisionNumber (RevisionNumber)
Defines the RevisionNumber for this BPA PDCstream configuration frame.
streamType (StreamType)
Defines the StreamType for this BPA PDCstream configuration frame.
Remarks

This constructor is used by a consumer to generate a BPA PDCstream configuration frame.

If you are going to create multiple data packets set packetsPerSample to a number greater than one. This will only start becoming necessary if you start hitting data size limits imposed by the nature of the transport protocol.


AppendChecksum Method (buffer, startIndex)

AppendChecksum Method (buffer, startIndex)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► AppendChecksum(array<Byte>[]()[][], Int32)
Appends checksum onto buffer starting at startIndex.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AppendChecksum(
    byte[] buffer,
    int startIndex
)
Protected Overrides Sub AppendChecksum ( _
    buffer As Byte(), _
    startIndex As Integer _
)
protected:
virtual void AppendChecksum(
    array<unsigned char>^ buffer,
    int startIndex
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image on which to append checksum.
startIndex (Int32)
Index into buffer where checksum should be appended.
Remarks
We override default implementation since BPA PDCstream implements check sum for frames in little-endian.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrame object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► Cells
Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellCollection Cells { get; }
Public ReadOnly Property Cells As ConfigurationCellCollection
    Get
public:
property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}


ChecksumIsValid Method (buffer, startIndex)

ChecksumIsValid Method (buffer, startIndex)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► ChecksumIsValid(array<Byte>[]()[][], Int32)
Determines if checksum in the buffer is valid.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid ( _
    buffer As Byte(), _
    startIndex As Integer _
) As Boolean
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image to validate.
startIndex (Int32)
Start index into buffer to perform checksum.
Return Value
Flag that determines if checksum over buffer is valid.
Remarks
We override default implementation since BPA PDCstream implements check sum for frames in little-endian.


CommonHeader Property

CommonHeader Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► CommonHeader
Gets or sets current CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}


ConfigurationFileCells Property

ConfigurationFileCells Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► ConfigurationFileCells
Gets reference to the ConfigurationCellCollection loaded from the configuration file of this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellCollection ConfigurationFileCells { get; }
Public ReadOnly Property ConfigurationFileCells As ConfigurationCellCollection
    Get
public:
property ConfigurationCellCollection^ ConfigurationFileCells {
    ConfigurationCellCollection^ get ();
}


ConfigurationFileName Property

ConfigurationFileName Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► ConfigurationFileName
Gets the INI based configuration file name of this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigurationFileName { get; }
Public ReadOnly Property ConfigurationFileName As String
    Get
public:
property String^ ConfigurationFileName {
    String^ get ();
}


ConfigurationFileReloaded Event

ConfigurationFileReloaded Event
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► ConfigurationFileReloaded
Occurs when the BPA PDCstream INI based configuration file has been reloaded.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler ConfigurationFileReloaded
Public Event ConfigurationFileReloaded As EventHandler
public:
 event EventHandler^ ConfigurationFileReloaded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


DefaultCurrentPhasorEntry Field

DefaultCurrentPhasorEntry Field
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► DefaultCurrentPhasorEntry
Default current phasor INI based configuration entry.
Declaration Syntax
C# Visual Basic Visual C++
public const string DefaultCurrentPhasorEntry
Public Const DefaultCurrentPhasorEntry As String
public:
literal String^ DefaultCurrentPhasorEntry


DefaultFrequency Property

DefaultFrequency Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► DefaultFrequency
Gets the default frequency definition.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyDefinition DefaultFrequency { get; }
Public ReadOnly Property DefaultFrequency As FrequencyDefinition
    Get
public:
property FrequencyDefinition^ DefaultFrequency {
    FrequencyDefinition^ get ();
}


DefaultFrequencyEntry Field

DefaultFrequencyEntry Field
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► DefaultFrequencyEntry
Default frequency INI based configuration entry.
Declaration Syntax
C# Visual Basic Visual C++
public const string DefaultFrequencyEntry
Public Const DefaultFrequencyEntry As String
public:
literal String^ DefaultFrequencyEntry


DefaultPhasorI Property

DefaultPhasorI Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► DefaultPhasorI
Gets the default current phasor definition.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinition DefaultPhasorI { get; }
Public ReadOnly Property DefaultPhasorI As PhasorDefinition
    Get
public:
property PhasorDefinition^ DefaultPhasorI {
    PhasorDefinition^ get ();
}


DefaultPhasorV Property

DefaultPhasorV Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► DefaultPhasorV
Gets the default voltage phasor definition.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinition DefaultPhasorV { get; }
Public ReadOnly Property DefaultPhasorV As PhasorDefinition
    Get
public:
property PhasorDefinition^ DefaultPhasorV {
    PhasorDefinition^ get ();
}


DefaultVoltagePhasorEntry Field

DefaultVoltagePhasorEntry Field
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► DefaultVoltagePhasorEntry
Default voltage phasor INI based configuration entry.
Declaration Syntax
C# Visual Basic Visual C++
public const string DefaultVoltagePhasorEntry
Public Const DefaultVoltagePhasorEntry As String
public:
literal String^ DefaultVoltagePhasorEntry


GetIniFileImage Method (configFrame)

GetIniFileImage Method (configFrame)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► GetIniFileImage(IConfigurationFrame)
Gets a generated INI configuration file image.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetIniFileImage(
    IConfigurationFrame configFrame
)
Public Shared Function GetIniFileImage ( _
    configFrame As IConfigurationFrame _
) As String
public:
static String^ GetIniFileImage(
    IConfigurationFrame^ configFrame
)
Parameters
configFrame (IConfigurationFrame)

[Missing <param name="configFrame"/> documentation for "M:TVA.PhasorProtocols.BpaPdcStream.ConfigurationFrame.GetIniFileImage(TVA.PhasorProtocols.IConfigurationFrame)"]

Return Value

[Missing <returns> documentation for "M:TVA.PhasorProtocols.BpaPdcStream.ConfigurationFrame.GetIniFileImage(TVA.PhasorProtocols.IConfigurationFrame)"]


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► HeaderImage
Gets the binary header image of the ConfigurationFrame object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


Initialize Method (binaryImage, startIndex, length)

Initialize Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► Initialize(array<Byte>[]()[][], Int32, Int32)
Parses the binary image.
Declaration Syntax
C# Visual Basic Visual C++
public override int Initialize(
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Overrides Function Initialize ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
public:
virtual int Initialize(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
This method is overriden so INI file can be loaded after binary image has been parsed.


PacketsPerSample Property

PacketsPerSample Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► PacketsPerSample
Gets or sets the number of packets per sample of this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ushort PacketsPerSample { get; set; }
Public Property PacketsPerSample As UShort
    Get
    Set
public:
property unsigned short PacketsPerSample {
    unsigned short get ();
    void set (unsigned short value);
}


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


Refresh Method

Refresh Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► Refresh()()()()
Reload BPA PDcstream INI based configuration file.
Declaration Syntax
C# Visual Basic Visual C++
public void Refresh()
Public Sub Refresh
public:
void Refresh()


RevisionNumber Property

RevisionNumber Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► RevisionNumber
Gets or sets the RevisionNumber of this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public RevisionNumber RevisionNumber { get; set; }
Public Property RevisionNumber As RevisionNumber
    Get
    Set
public:
property RevisionNumber RevisionNumber {
    RevisionNumber get ();
    void set (RevisionNumber value);
}


SampleIndex Property

SampleIndex Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► SampleIndex
Gets or sets current sample index used to calculate row time stamp when source data is in the Phasor Data File Format (i.e., a DST file).
Declaration Syntax
C# Visual Basic Visual C++
public uint SampleIndex { get; set; }
Public Property SampleIndex As UInteger
    Get
    Set
public:
property unsigned int SampleIndex {
    unsigned int get ();
    void set (unsigned int value);
}


StreamType Property

StreamType Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► StreamType
Gets or sets the BPA PDCstream protocol StreamType, i.e., legacy or compact, of this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public StreamType StreamType { get; set; }
Public Property StreamType As StreamType
    Get
    Set
public:
property StreamType StreamType {
    StreamType get ();
    void set (StreamType value);
}


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► TypeID
Gets the FrameType of this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}


UsePhasorDataFileFormat Property

UsePhasorDataFileFormat Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► UsePhasorDataFileFormat
Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Declaration Syntax
C# Visual Basic Visual C++
public bool UsePhasorDataFileFormat { get; }
Public ReadOnly Property UsePhasorDataFileFormat As Boolean
    Get
public:
property bool UsePhasorDataFileFormat {
    bool get ();
}


ConfigurationFrameParsingState Class

ConfigurationFrameParsingState Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrameParsingState
Represents the BPA PDCstream implementation of the parsing state used by a ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public class ConfigurationFrameParsingState : ConfigurationFrameParsingState
Public Class ConfigurationFrameParsingState _
    Inherits ConfigurationFrameParsingState
public ref class ConfigurationFrameParsingState : public ConfigurationFrameParsingState
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationFrameParsingState(Int32, String, CreateNewCellFunction<(Of <<'(IConfigurationCell>)>>)) | Creates a new ConfigurationFrameParsingState from specified parameters.
 | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBase<(Of <(<'T>)>)>.)
 | ConfigurationFileName | Gets or sets required external BPA PDCstream INI based configuration file.
 | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ChannelParsingStateBase
 |  | ChannelFrameParsingStateBase <(Of <(<' IConfigurationCell >)>)>
 |  |  | ConfigurationFrameParsingState
 |  |  |  | ConfigurationFrameParsingState


ConfigurationFrameParsingState Constructor (parsedBinaryLength, configurationFileName, createNewCellFunction)

ConfigurationFrameParsingState Constructor (parsedBinaryLength, configurationFileName, createNewCellFunction)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrameParsingState ► ConfigurationFrameParsingState(Int32, String, CreateNewCellFunction<(Of <<'(IConfigurationCell>)>>))
Creates a new ConfigurationFrameParsingState from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrameParsingState(
    int parsedBinaryLength,
    string configurationFileName,
    CreateNewCellFunction<IConfigurationCell> createNewCellFunction
)
Public Sub New ( _
    parsedBinaryLength As Integer, _
    configurationFileName As String, _
    createNewCellFunction As CreateNewCellFunction(Of IConfigurationCell) _
)
public:
ConfigurationFrameParsingState(
    int parsedBinaryLength,
    String^ configurationFileName,
    CreateNewCellFunction<IConfigurationCell^>^ createNewCellFunction
)
Parameters
parsedBinaryLength (Int32)
Binary length of the ConfigurationFrame being parsed.
configurationFileName (String)
The required external BPA PDCstream INI based configuration file.
createNewCellFunction (CreateNewCellFunction <(Of <(<' IConfigurationCell >)>)>)
Reference to delegate to create new ConfigurationCell instances.


ConfigurationFileName Property

ConfigurationFileName Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrameParsingState ► ConfigurationFileName
Gets or sets required external BPA PDCstream INI based configuration file.
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigurationFileName { get; set; }
Public Property ConfigurationFileName As String
    Get
    Set
public:
property String^ ConfigurationFileName {
    String^ get ();
    void set (String^ value);
}


ConnectionParameters Class

ConnectionParameters Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConnectionParameters
Represents the extra connection parameters required for a connection to a BPA PDCstream.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConnectionParameters : ConnectionParametersBase
<SerializableAttribute> _
Public Class ConnectionParameters _
    Inherits ConnectionParametersBase
[SerializableAttribute]
public ref class ConnectionParameters : public ConnectionParametersBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConnectionParameters()()()() | Creates a new ConnectionParameters.
 | ConnectionParameters(SerializationInfo, StreamingContext) | Creates a new ConnectionParameters from serialization parameters.
 | ConfigurationFileName | Gets or sets required external BPA PDCstream INI based configuration file.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConnectionParametersBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseWordCountFromByte | Gets or sets flag that interprets word count in packet header from a byte instead of a word.
 | RefreshConfigurationFileOnChange | Gets or sets flag that determines if configuration file is automatically reloaded when it has changed on disk.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UsePhasorDataFileFormat | Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
 | ValuesAreValid | Determines if selected BPA PDCstream configuration file exists. (Overrides ConnectionParametersBase.ValuesAreValid.)
Remarks
This class is designed to be exposed by a "PropertyGrid" so a UI can request protocol specific connection parameters. As a result the CategoryAttribute and DescriptionAttribute elements should be defined for each of the exposed properties.
Inheritance Hierarchy
Object
 | ConnectionParametersBase
 |  | ConnectionParameters


ConnectionParameters Constructor

ConnectionParameters Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConnectionParameters ► ConnectionParameters()()()()
Members
Icon | Member | Description
 | ConnectionParameters()()()() | Creates a new ConnectionParameters.
 | ConnectionParameters(SerializationInfo, StreamingContext) | Creates a new ConnectionParameters from serialization parameters.


ConnectionParameters Constructor

ConnectionParameters Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConnectionParameters ► ConnectionParameters()()()()
Creates a new ConnectionParameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConnectionParameters()
Public Sub New
public:
ConnectionParameters()


ConnectionParameters Constructor (info, context)

ConnectionParameters Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConnectionParameters ► ConnectionParameters(SerializationInfo, StreamingContext)
Creates a new ConnectionParameters from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConnectionParameters(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConnectionParameters(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationFileName Property

ConfigurationFileName Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConnectionParameters ► ConfigurationFileName
Gets or sets required external BPA PDCstream INI based configuration file.
Declaration Syntax
C# Visual Basic Visual C++
[EditorAttribute(typeof(IniFileNameEditor), typeof(UITypeEditor))]
public string ConfigurationFileName { get; set; }
<EditorAttribute(GetType(IniFileNameEditor), GetType(UITypeEditor))> _
Public Property ConfigurationFileName As String
    Get
    Set
[EditorAttribute(typeof(IniFileNameEditor), typeof(UITypeEditor))]
public:
property String^ ConfigurationFileName {
    String^ get ();
    void set (String^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConnectionParameters ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


ParseWordCountFromByte Property

ParseWordCountFromByte Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConnectionParameters ► ParseWordCountFromByte
Gets or sets flag that interprets word count in packet header from a byte instead of a word.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(false)]
public bool ParseWordCountFromByte { get; set; }
<DefaultValueAttribute(False)> _
Public Property ParseWordCountFromByte As Boolean
    Get
    Set
[DefaultValueAttribute(false)]
public:
property bool ParseWordCountFromByte {
    bool get ();
    void set (bool value);
}


RefreshConfigurationFileOnChange Property

RefreshConfigurationFileOnChange Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConnectionParameters ► RefreshConfigurationFileOnChange
Gets or sets flag that determines if configuration file is automatically reloaded when it has changed on disk.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(true)]
public bool RefreshConfigurationFileOnChange { get; set; }
<DefaultValueAttribute(True)> _
Public Property RefreshConfigurationFileOnChange As Boolean
    Get
    Set
[DefaultValueAttribute(true)]
public:
property bool RefreshConfigurationFileOnChange {
    bool get ();
    void set (bool value);
}


UsePhasorDataFileFormat Property

UsePhasorDataFileFormat Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConnectionParameters ► UsePhasorDataFileFormat
Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(false)]
public bool UsePhasorDataFileFormat { get; set; }
<DefaultValueAttribute(False)> _
Public Property UsePhasorDataFileFormat As Boolean
    Get
    Set
[DefaultValueAttribute(false)]
public:
property bool UsePhasorDataFileFormat {
    bool get ();
    void set (bool value);
}


ValuesAreValid Property

ValuesAreValid Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConnectionParameters ► ValuesAreValid
Determines if selected BPA PDCstream configuration file exists.
Declaration Syntax
C# Visual Basic Visual C++
[BrowsableAttribute(false)]
public override bool ValuesAreValid { get; }
<BrowsableAttribute(False)> _
Public Overrides ReadOnly Property ValuesAreValid As Boolean
    Get
[BrowsableAttribute(false)]
public:
virtual property bool ValuesAreValid {
    bool get () override;
}


DataCell Class

DataCell Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell
Represents the BPA PDCstream implementation of a IDataCell that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataCell : DataCellBase
<SerializableAttribute> _
Public Class DataCell _
    Inherits DataCellBase
[SerializableAttribute]
public ref class DataCell : public DataCellBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
 | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
 | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
 | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
 | AnalogValues | Gets AnalogValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataCell object. (Overrides DataCellBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength | Gets the length of the BinaryImage()()()(). (Overrides BinaryImageBase.BinaryLength()()()().)
 | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
 | ChannelFlags | Gets or sets channel flags for this DataCell.
 | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
 | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
 | DataBuffer | Gets or sets data buffer long word that prefixes each cell when source data is in the Phasor Data File Format (i.e., a DST file).
 | DataIsSortedByTimestamp | Obsolete. Gets or sets flag that determines if this DataCell data is sorted by timestamp.
 | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBase.DataIsValid.)
 | DataRate | Gets or sets data rate of this DataCell.
 | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBase.DataSortingType.)
 | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBase.DeviceError.)
 | DigitalValues | Gets DigitalValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
 | Equals(Object) | Determines whether the specified object is equal to the DataCellBase. (Inherited from DataCellBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FormatFlags | Gets or sets FormatFlags from ConfigurationCell associated with this DataCell.
 | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
 | GetHashCode()()()() | Serves as a hash function for the DataCellBase. (Inherited from DataCellBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataCellBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the DataCell object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets the numeric ID code for this DataCellBase. (Inherited from DataCellBase.)
 | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Overrides BinaryImageBase.Initialize(array<Byte>[]()[][], Int32, Int32).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from DataCellBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides BinaryImageBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
 | ReservedFlag0IsSet | Gets or sets flag that determines if reserved flag zero is set.
 | ReservedFlag1IsSet | Gets or sets flag that determines if reserved flag one is set.
 | ReservedFlags | Gets or sets reserved flags for this DataCell.
 | SampleNumber | Gets or sets sample number associated with this DataCell.
 | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
 | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
 | StatusFlags | Gets or sets 16-bit status flags of this DataCellBase. (Inherited from DataCellBase.)
 | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBase.SynchronizationIsValid.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | TimestampIsIncluded | Obsolete. Gets or sets flag that determines if timestamp is included with this DataCell.
 | ToString()()()() | Gets the string respresentation of this DataCellBase. (Inherited from DataCellBase.)
 | UsePhasorDataFileFormat | Gets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
 | UsingIeeeFormat | Gets or sets flag that determines if this DataCell is using IEEE format.
 | UsingMacrodyneFormat | Gets or sets flag that determines if this DataCell is using Macrodyne format.
 | UsingPdcExchangeFormat | Gets or sets flag that determines if this DataCell is using the PDC exchange format.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | DataCellBase
 |  |  |  |  | DataCell


DataCell Constructor

DataCell Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► DataCell()()()()
Members
Icon | Member | Description
 | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
 | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
 | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.


DataCell Constructor (info, context)

DataCell Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► DataCell(SerializationInfo, StreamingContext)
Creates a new DataCell from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataCell(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DataCell Constructor (parent, configurationCell, addEmptyValues)

DataCell Constructor (parent, configurationCell, addEmptyValues)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► DataCell(DataFrame, ConfigurationCell, Boolean)
Creates a new DataCell from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell(
    DataFrame parent,
    ConfigurationCell configurationCell,
    bool addEmptyValues
)
Public Sub New ( _
    parent As DataFrame, _
    configurationCell As ConfigurationCell, _
    addEmptyValues As Boolean _
)
public:
DataCell(
    DataFrame^ parent,
    ConfigurationCell^ configurationCell,
    bool addEmptyValues
)
Parameters
parent (DataFrame)
The reference to parent DataFrame of this DataCell.
configurationCell (ConfigurationCell)
The ConfigurationCell associated with this DataCell.
addEmptyValues (Boolean)
If true, adds empty values for each defined configuration cell definition.


DataCell Constructor (parent, configurationCell)

DataCell Constructor (parent, configurationCell)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► DataCell(IDataFrame, IConfigurationCell)
Creates a new DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell(
    IDataFrame parent,
    IConfigurationCell configurationCell
)
Public Sub New ( _
    parent As IDataFrame, _
    configurationCell As IConfigurationCell _
)
public:
DataCell(
    IDataFrame^ parent,
    IConfigurationCell^ configurationCell
)
Parameters
parent (IDataFrame)
The reference to parent IDataFrame of this DataCell.
configurationCell (IConfigurationCell)
The IConfigurationCell associated with this DataCell.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataCell object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BinaryLength Property

BinaryLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► BinaryLength
Gets the length of the BinaryImage()()()().
Declaration Syntax
C# Visual Basic Visual C++
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
public:
virtual property int BinaryLength {
    int get () override;
}
Remarks
This property is overriden to extend length evenly at 4-byte intervals.


ChannelFlags Property

ChannelFlags Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► ChannelFlags
Gets or sets channel flags for this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public ChannelFlags ChannelFlags { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Property ChannelFlags As ChannelFlags
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
public:
property ChannelFlags ChannelFlags {
    ChannelFlags get ();
    void set (ChannelFlags value);
}
Remarks
These are bit flags, use properties to change basic values.


ConfigurationCell Property

ConfigurationCell Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► ConfigurationCell
Gets or sets the ConfigurationCell associated with this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell ConfigurationCell { get; set; }
Public Property ConfigurationCell As ConfigurationCell
    Get
    Set
public:
property ConfigurationCell^ ConfigurationCell {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


DataBuffer Property

DataBuffer Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► DataBuffer
Gets or sets data buffer long word that prefixes each cell when source data is in the Phasor Data File Format (i.e., a DST file).
Declaration Syntax
C# Visual Basic Visual C++
public uint DataBuffer { get; set; }
Public Property DataBuffer As UInteger
    Get
    Set
public:
property unsigned int DataBuffer {
    unsigned int get ();
    void set (unsigned int value);
}


DataIsSortedByTimestamp Property

DataIsSortedByTimestamp Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► DataIsSortedByTimestamp
Gets or sets flag that determines if this DataCell data is sorted by timestamp.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("This bit definition is for obsolete uses that is no longer needed.",
    false)]
public bool DataIsSortedByTimestamp { get; set; }
<ObsoleteAttribute("This bit definition is for obsolete uses that is no longer needed.",  _
    False)> _
Public Property DataIsSortedByTimestamp As Boolean
    Get
    Set
[ObsoleteAttribute(L"This bit definition is for obsolete uses that is no longer needed.",
    false)]
public:
property bool DataIsSortedByTimestamp {
    bool get ();
    void set (bool value);
}


DataIsValid Property

DataIsValid Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► DataIsValid
Gets or sets flag that determines if data of this DataCell is valid.
Declaration Syntax
C# Visual Basic Visual C++
public override bool DataIsValid { get; set; }
Public Overrides Property DataIsValid As Boolean
    Get
    Set
public:
virtual property bool DataIsValid {
    bool get () override;
    void set (bool value) override;
}


DataRate Property

DataRate Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► DataRate
Gets or sets data rate of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public byte DataRate { get; set; }
Public Property DataRate As Byte
    Get
    Set
public:
property unsigned char DataRate {
    unsigned char get ();
    void set (unsigned char value);
}


DataSortingType Property

DataSortingType Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► DataSortingType
Gets or sets DataSortingType of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataSortingType DataSortingType { get; set; }
Public Overrides Property DataSortingType As DataSortingType
    Get
    Set
public:
virtual property DataSortingType DataSortingType {
    DataSortingType get () override;
    void set (DataSortingType value) override;
}


DeviceError Property

DeviceError Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► DeviceError
Gets or sets flag that determines if source device of this DataCell is reporting an error.
Declaration Syntax
C# Visual Basic Visual C++
public override bool DeviceError { get; set; }
Public Overrides Property DeviceError As Boolean
    Get
    Set
public:
virtual property bool DeviceError {
    bool get () override;
    void set (bool value) override;
}


FormatFlags Property

FormatFlags Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► FormatFlags
Gets or sets FormatFlags from ConfigurationCell associated with this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public FormatFlags FormatFlags { get; set; }
Public Property FormatFlags As FormatFlags
    Get
    Set
public:
property FormatFlags FormatFlags {
    FormatFlags get ();
    void set (FormatFlags value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► HeaderImage
Gets the binary header image of the DataCell object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}
Remarks
Although this BPA PDCstream implementation DataCell will correctly parse a PDCxchng style stream, one will not be produced. Only a fully formatted stream will ever be produced.


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


Initialize Method (binaryImage, startIndex, length)

Initialize Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► Initialize(array<Byte>[]()[][], Int32, Int32)
Parses the binary image.
Declaration Syntax
C# Visual Basic Visual C++
public override int Initialize(
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Overrides Function Initialize ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
public:
virtual int Initialize(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
This property is overriden to extend parsed length evenly at 4-byte intervals.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► Parent
Gets or sets the reference to parent DataFrame of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public DataFrame Parent { get; set; }
Public Property Parent As DataFrame
    Get
    Set
public:
property DataFrame^ Parent {
    DataFrame^ get ();
    void set (DataFrame^ value);
}


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


ReservedFlag0IsSet Property

ReservedFlag0IsSet Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► ReservedFlag0IsSet
Gets or sets flag that determines if reserved flag zero is set.
Declaration Syntax
C# Visual Basic Visual C++
public bool ReservedFlag0IsSet { get; set; }
Public Property ReservedFlag0IsSet As Boolean
    Get
    Set
public:
property bool ReservedFlag0IsSet {
    bool get ();
    void set (bool value);
}


ReservedFlag1IsSet Property

ReservedFlag1IsSet Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► ReservedFlag1IsSet
Gets or sets flag that determines if reserved flag one is set.
Declaration Syntax
C# Visual Basic Visual C++
public bool ReservedFlag1IsSet { get; set; }
Public Property ReservedFlag1IsSet As Boolean
    Get
    Set
public:
property bool ReservedFlag1IsSet {
    bool get ();
    void set (bool value);
}


ReservedFlags Property

ReservedFlags Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► ReservedFlags
Gets or sets reserved flags for this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public ReservedFlags ReservedFlags { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Property ReservedFlags As ReservedFlags
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
public:
property ReservedFlags ReservedFlags {
    ReservedFlags get ();
    void set (ReservedFlags value);
}
Remarks
These are bit flags, use properties to change basic values.


SampleNumber Property

SampleNumber Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► SampleNumber
Gets or sets sample number associated with this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public ushort SampleNumber { get; set; }
Public Property SampleNumber As UShort
    Get
    Set
public:
property unsigned short SampleNumber {
    unsigned short get ();
    void set (unsigned short value);
}


SynchronizationIsValid Property

SynchronizationIsValid Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► SynchronizationIsValid
Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock.
Declaration Syntax
C# Visual Basic Visual C++
public override bool SynchronizationIsValid { get; set; }
Public Overrides Property SynchronizationIsValid As Boolean
    Get
    Set
public:
virtual property bool SynchronizationIsValid {
    bool get () override;
    void set (bool value) override;
}


TimestampIsIncluded Property

TimestampIsIncluded Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► TimestampIsIncluded
Gets or sets flag that determines if timestamp is included with this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("This bit definition is for obsolete uses that is no longer needed.",
    false)]
public bool TimestampIsIncluded { get; set; }
<ObsoleteAttribute("This bit definition is for obsolete uses that is no longer needed.",  _
    False)> _
Public Property TimestampIsIncluded As Boolean
    Get
    Set
[ObsoleteAttribute(L"This bit definition is for obsolete uses that is no longer needed.",
    false)]
public:
property bool TimestampIsIncluded {
    bool get ();
    void set (bool value);
}


UsePhasorDataFileFormat Property

UsePhasorDataFileFormat Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► UsePhasorDataFileFormat
Gets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Declaration Syntax
C# Visual Basic Visual C++
public bool UsePhasorDataFileFormat { get; }
Public ReadOnly Property UsePhasorDataFileFormat As Boolean
    Get
public:
property bool UsePhasorDataFileFormat {
    bool get ();
}


UsingIeeeFormat Property

UsingIeeeFormat Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► UsingIeeeFormat
Gets or sets flag that determines if this DataCell is using IEEE format.
Declaration Syntax
C# Visual Basic Visual C++
public bool UsingIeeeFormat { get; set; }
Public Property UsingIeeeFormat As Boolean
    Get
    Set
public:
property bool UsingIeeeFormat {
    bool get ();
    void set (bool value);
}


UsingMacrodyneFormat Property

UsingMacrodyneFormat Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► UsingMacrodyneFormat
Gets or sets flag that determines if this DataCell is using Macrodyne format.
Declaration Syntax
C# Visual Basic Visual C++
public bool UsingMacrodyneFormat { get; set; }
Public Property UsingMacrodyneFormat As Boolean
    Get
    Set
public:
property bool UsingMacrodyneFormat {
    bool get ();
    void set (bool value);
}


UsingPdcExchangeFormat Property

UsingPdcExchangeFormat Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCell ► UsingPdcExchangeFormat
Gets or sets flag that determines if this DataCell is using the PDC exchange format.
Declaration Syntax
C# Visual Basic Visual C++
public bool UsingPdcExchangeFormat { get; set; }
Public Property UsingPdcExchangeFormat As Boolean
    Get
    Set
public:
property bool UsingPdcExchangeFormat {
    bool get ();
    void set (bool value);
}


DataCellCollection Class

DataCellCollection Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCellCollection
Represents a BPA PDCstream implementation of a collection of IDataCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataCellCollection : DataCellCollection
<SerializableAttribute> _
Public Class DataCellCollection _
    Inherits DataCellCollection
[SerializableAttribute]
public ref class DataCellCollection : public DataCellCollection
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCellCollection()()()() | Creates a new DataCellCollection.
 | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets DataCell at specified index.
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IDataCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' IDataCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' IDataCell >)>)>
 |  |  |  | DataCellCollection
 |  |  |  |  | DataCellCollection


DataCellCollection Constructor

DataCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCellCollection ► DataCellCollection()()()()
Members
Icon | Member | Description
 | DataCellCollection()()()() | Creates a new DataCellCollection.
 | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.


DataCellCollection Constructor

DataCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCellCollection ► DataCellCollection()()()()
Creates a new DataCellCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DataCellCollection()
Public Sub New
public:
DataCellCollection()


DataCellCollection Constructor (info, context)

DataCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCellCollection ► DataCellCollection(SerializationInfo, StreamingContext)
Creates a new DataCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


Item Property (index)

Item Property (index)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataCellCollection ► Item[([( Int32])])
Gets or sets DataCell at specified index.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DataCell
    Get
    Set
public:
property DataCell^ default[int index] {
    DataCell^ get (int index);
    void set (int index, DataCell^ value);
}
Parameters
index (Int32)
Index of value to get or set.


DataFrame Class

DataFrame Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame
Represents the BPA PDCstream implementation of a IDataFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataFrame : DataFrameBase, ISupportFrameImage<FrameType>,
    ISupportBinaryImage
<SerializableAttribute> _
Public Class DataFrame _
    Inherits DataFrameBase _
    Implements ISupportFrameImage(Of FrameType), ISupportBinaryImage
[SerializableAttribute]
public ref class DataFrame : public DataFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataFrame()()()() | Creates a new DataFrame.
 | DataFrame(Ticks, ConfigurationFrame, Byte, UInt16) | Creates a new DataFrame from specified parameters.
 | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.AppendChecksum(array<Byte>[]()[][], Int32).)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataFrame object. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the DataCellCollection for this DataFrame.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.ChecksumIsValid(array<Byte>[]()[][], Int32).)
 | CommonHeader | Gets or sets current CommonFrameHeader.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets the numeric ID code for this DataFrameBase. (Inherited from DataFrameBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Overrides DataFrameBase.Initialize(array<Byte>[]()[][], Int32, Int32).)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | LegacyLabels | Gets the legacy labels parsed from the DataFrame, if any.
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NtpTimeTag | Gets the timestamp of this DataFrame formatted as NTP.
 | PacketNumber | Gets or sets the packet number of this DataFrame.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides BinaryImageBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SampleNumber | Gets or sets the sample number of this DataFrame.
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this DataFrame.
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets the identifier that is used to identify the IEEE C37.118 frame.
 | UsePhasorDataFileFormat | Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IDataCell >)>)>
 |  |  |  | DataFrameBase
 |  |  |  |  | DataFrame


DataFrame Constructor

DataFrame Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► DataFrame()()()()
Members
Icon | Member | Description
 | DataFrame()()()() | Creates a new DataFrame.
 | DataFrame(Ticks, ConfigurationFrame, Byte, UInt16) | Creates a new DataFrame from specified parameters.
 | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.


DataFrame Constructor

DataFrame Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► DataFrame()()()()
Creates a new DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public DataFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Sub New
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
DataFrame()
Remarks
This constructor is used by FrameImageParserBase to parse a BPA PDCstream data frame.


DataFrame Constructor (info, context)

DataFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► DataFrame(SerializationInfo, StreamingContext)
Creates a new DataFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DataFrame Constructor (timestamp, configurationFrame, packetNumber, sampleNumber)

DataFrame Constructor (timestamp, configurationFrame, packetNumber, sampleNumber)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► DataFrame(Ticks, ConfigurationFrame, Byte, UInt16)
Creates a new DataFrame from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DataFrame(
    Ticks timestamp,
    ConfigurationFrame configurationFrame,
    byte packetNumber,
    ushort sampleNumber
)
Public Sub New ( _
    timestamp As Ticks, _
    configurationFrame As ConfigurationFrame, _
    packetNumber As Byte, _
    sampleNumber As UShort _
)
public:
DataFrame(
    Ticks timestamp,
    ConfigurationFrame^ configurationFrame,
    unsigned char packetNumber,
    unsigned short sampleNumber
)
Parameters
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this DataFrame.
configurationFrame (ConfigurationFrame)
The ConfigurationFrame associated with this DataFrame.
packetNumber (Byte)
Packet number for this DataFrame.
sampleNumber (UInt16)
Sample number for thie DataFrame.
Remarks
This constructor is used by a consumer to generate a BPA PDCstream data frame.


AppendChecksum Method (buffer, startIndex)

AppendChecksum Method (buffer, startIndex)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► AppendChecksum(array<Byte>[]()[][], Int32)
Appends checksum onto buffer starting at startIndex.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AppendChecksum(
    byte[] buffer,
    int startIndex
)
Protected Overrides Sub AppendChecksum ( _
    buffer As Byte(), _
    startIndex As Integer _
)
protected:
virtual void AppendChecksum(
    array<unsigned char>^ buffer,
    int startIndex
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image on which to append checksum.
startIndex (Int32)
Index into buffer where checksum should be appended.
Remarks
We override default implementation since BPA PDCstream implements check sum for frames in little-endian.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataFrame object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► Cells
Gets reference to the DataCellCollection for this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public DataCellCollection Cells { get; }
Public ReadOnly Property Cells As DataCellCollection
    Get
public:
property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}


ChecksumIsValid Method (buffer, startIndex)

ChecksumIsValid Method (buffer, startIndex)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► ChecksumIsValid(array<Byte>[]()[][], Int32)
Determines if checksum in the buffer is valid.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid ( _
    buffer As Byte(), _
    startIndex As Integer _
) As Boolean
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image to validate.
startIndex (Int32)
Start index into buffer to perform checksum.
Return Value
Flag that determines if checksum over buffer is valid.
Remarks
We override default implementation since BPA PDCstream implements check sum for frames in little-endian.


CommonHeader Property

CommonHeader Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► CommonHeader
Gets or sets current CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► ConfigurationFrame
Gets or sets ConfigurationFrame associated with this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame ConfigurationFrame { get; set; }
Public Property ConfigurationFrame As ConfigurationFrame
    Get
    Set
public:
property ConfigurationFrame^ ConfigurationFrame {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► HeaderImage
Gets the binary header image of the DataFrame object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


Initialize Method (binaryImage, startIndex, length)

Initialize Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► Initialize(array<Byte>[]()[][], Int32, Int32)
Parses the binary image.
Declaration Syntax
C# Visual Basic Visual C++
public override int Initialize(
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Overrides Function Initialize ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
public:
virtual int Initialize(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
This method is overriden to compensate for lack of CRC in DST files.


LegacyLabels Property

LegacyLabels Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► LegacyLabels
Gets the legacy labels parsed from the DataFrame, if any.
Declaration Syntax
C# Visual Basic Visual C++
public string[] LegacyLabels { get; }
Public ReadOnly Property LegacyLabels As String()
    Get
public:
property array<String^>^ LegacyLabels {
    array<String^>^ get ();
}


NtpTimeTag Property

NtpTimeTag Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► NtpTimeTag
Gets the timestamp of this DataFrame formatted as NTP.
Declaration Syntax
C# Visual Basic Visual C++
public NtpTimeTag NtpTimeTag { get; }
Public ReadOnly Property NtpTimeTag As NtpTimeTag
    Get
public:
property NtpTimeTag^ NtpTimeTag {
    NtpTimeTag^ get ();
}


PacketNumber Property

PacketNumber Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► PacketNumber
Gets or sets the packet number of this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public byte PacketNumber { get; set; }
Public Property PacketNumber As Byte
    Get
    Set
public:
property unsigned char PacketNumber {
    unsigned char get ();
    void set (unsigned char value);
}


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


SampleNumber Property

SampleNumber Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► SampleNumber
Gets or sets the sample number of this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ushort SampleNumber { get; set; }
Public Property SampleNumber As UShort
    Get
    Set
public:
property unsigned short SampleNumber {
    unsigned short get ();
    void set (unsigned short value);
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► State
Gets or sets the parsing state for the this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public DataFrameParsingState State { get; set; }
Public Property State As DataFrameParsingState
    Get
    Set
public:
property DataFrameParsingState^ State {
    DataFrameParsingState^ get ();
    void set (DataFrameParsingState^ value);
}


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► TypeID
Gets the identifier that is used to identify the IEEE C37.118 frame.
Declaration Syntax
C# Visual Basic Visual C++
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}


UsePhasorDataFileFormat Property

UsePhasorDataFileFormat Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► UsePhasorDataFileFormat
Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Declaration Syntax
C# Visual Basic Visual C++
public bool UsePhasorDataFileFormat { get; }
Public ReadOnly Property UsePhasorDataFileFormat As Boolean
    Get
public:
property bool UsePhasorDataFileFormat {
    bool get ();
}


DataFrameParsingState Class

DataFrameParsingState Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrameParsingState
Represents the BPA PDCstream protocol implementation of the parsing state used by a DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public class DataFrameParsingState : DataFrameParsingState
Public Class DataFrameParsingState _
    Inherits DataFrameParsingState
public ref class DataFrameParsingState : public DataFrameParsingState
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataFrameParsingState(Int32, IConfigurationFrame, CreateNewCellFunction<(Of <<'(IDataCell>)>>)) | Creates a new DataFrameParsingState from specified parameters.
 | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBase<(Of <(<'T>)>)>.)
 | ConfigurationFrame | Gets reference to the ConfigurationFrame associated with the DataFrame being parsed.
 | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
 | RemainingPdcBlockPmus | Gets or sets the remaining number of PMU's the PDC block to be parsed.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ChannelParsingStateBase
 |  | ChannelFrameParsingStateBase <(Of <(<' IDataCell >)>)>
 |  |  | DataFrameParsingState
 |  |  |  | DataFrameParsingState


DataFrameParsingState Constructor (parsedBinaryLength, configurationFrame, createNewCellFunction)

DataFrameParsingState Constructor (parsedBinaryLength, configurationFrame, createNewCellFunction)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrameParsingState ► DataFrameParsingState(Int32, IConfigurationFrame, CreateNewCellFunction<(Of <<'(IDataCell>)>>))
Creates a new DataFrameParsingState from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DataFrameParsingState(
    int parsedBinaryLength,
    IConfigurationFrame configurationFrame,
    CreateNewCellFunction<IDataCell> createNewCellFunction
)
Public Sub New ( _
    parsedBinaryLength As Integer, _
    configurationFrame As IConfigurationFrame, _
    createNewCellFunction As CreateNewCellFunction(Of IDataCell) _
)
public:
DataFrameParsingState(
    int parsedBinaryLength,
    IConfigurationFrame^ configurationFrame,
    CreateNewCellFunction<IDataCell^>^ createNewCellFunction
)
Parameters
parsedBinaryLength (Int32)
Binary length of the IDataFrame being parsed.
configurationFrame (IConfigurationFrame)
Reference to the IConfigurationFrame associated with the IDataFrame being parsed.
createNewCellFunction (CreateNewCellFunction <(Of <(<' IDataCell >)>)>)
Reference to delegate to create new IDataCell instances.


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrameParsingState ► ConfigurationFrame
Gets reference to the ConfigurationFrame associated with the DataFrame being parsed.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame ConfigurationFrame { get; }
Public ReadOnly Property ConfigurationFrame As ConfigurationFrame
    Get
public:
property ConfigurationFrame^ ConfigurationFrame {
    ConfigurationFrame^ get ();
}


RemainingPdcBlockPmus Property

RemainingPdcBlockPmus Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrameParsingState ► RemainingPdcBlockPmus
Gets or sets the remaining number of PMU's the PDC block to be parsed.
Declaration Syntax
C# Visual Basic Visual C++
public int RemainingPdcBlockPmus { get; set; }
Public Property RemainingPdcBlockPmus As Integer
    Get
    Set
public:
property int RemainingPdcBlockPmus {
    int get ();
    void set (int value);
}


DigitalDefinition Class

DigitalDefinition Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalDefinition
Represents the BPA PDCstream implementation of an IDigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DigitalDefinition : DigitalDefinitionBase
<SerializableAttribute> _
Public Class DigitalDefinition _
    Inherits DigitalDefinitionBase
[SerializableAttribute]
public ref class DigitalDefinition : public DigitalDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition from specified parameters.
 | DigitalDefinition(ConfigurationCell, String) | Creates a new DigitalDefinition from specified parameters.
 | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the DigitalDefinition object. (Overrides ChannelDefinitionBase.BodyImage.)
 | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBase.BodyLength.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this DigitalDefinition. (Overrides ChannelDefinitionBase.MaximumLabelLength.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | DigitalDefinitionBase
 |  |  |  |  | DigitalDefinition


DigitalDefinition Constructor

DigitalDefinition Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalDefinition ► DigitalDefinition()()()()
Members
Icon | Member | Description
 | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition from specified parameters.
 | DigitalDefinition(ConfigurationCell, String) | Creates a new DigitalDefinition from specified parameters.
 | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.


DigitalDefinition Constructor (info, context)

DigitalDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalDefinition ► DigitalDefinition(SerializationInfo, StreamingContext)
Creates a new DigitalDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DigitalDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DigitalDefinition Constructor (parent, label)

DigitalDefinition Constructor (parent, label)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalDefinition ► DigitalDefinition(ConfigurationCell, String)
Creates a new DigitalDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String _
)
public:
DigitalDefinition(
    ConfigurationCell^ parent,
    String^ label
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this DigitalDefinition.
label (String)
The label of this DigitalDefinition.


DigitalDefinition Constructor (parent)

DigitalDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalDefinition ► DigitalDefinition(IConfigurationCell)
Creates a new DigitalDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
DigitalDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this DigitalDefinition.


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalDefinition ► BodyImage
Gets the binary body image of the DigitalDefinition object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}
Remarks
BPA PDCstream does not include digital definition in descriptor packet. Only a count of available values is defined in the data frame.


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalDefinition ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}


MaximumLabelLength Property

MaximumLabelLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalDefinition ► MaximumLabelLength
Gets the maximum length of the Label of this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
public:
virtual property int MaximumLabelLength {
    int get () override;
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalDefinition ► Parent
Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


DigitalValue Class

DigitalValue Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalValue
Represents the BPA PDCstream implementation of an IDigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DigitalValue : DigitalValueBase
<SerializableAttribute> _
Public Class DigitalValue _
    Inherits DigitalValueBase
[SerializableAttribute]
public ref class DigitalValue : public DigitalValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
 | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
 | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DigitalValueBase object. (Inherited from DigitalValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the DigitalValueBase object. (Inherited from DigitalValueBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from DigitalValueBase.)
 | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Inherited from DigitalValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the DigitalDefinition associated with this DigitalValue.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this DigitalValueBase. (Inherited from DigitalValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from DigitalValueBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DigitalValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Inherited from DigitalValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this DigitalValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from DigitalValueBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase. (Inherited from DigitalValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IDigitalDefinition >)>)>
 |  |  |  | DigitalValueBase
 |  |  |  |  | DigitalValue


DigitalValue Constructor

DigitalValue Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalValue ► DigitalValue()()()()
Members
Icon | Member | Description
 | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
 | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
 | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.


DigitalValue Constructor (info, context)

DigitalValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalValue ► DigitalValue(SerializationInfo, StreamingContext)
Creates a new DigitalValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DigitalValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DigitalValue Constructor (parent, digitalDefinition, value)

DigitalValue Constructor (parent, digitalDefinition, value)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalValue ► DigitalValue(DataCell, DigitalDefinition, UInt16)
Creates a new DigitalValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalValue(
    DataCell parent,
    DigitalDefinition digitalDefinition,
    ushort value
)
Public Sub New ( _
    parent As DataCell, _
    digitalDefinition As DigitalDefinition, _
    value As UShort _
)
public:
DigitalValue(
    DataCell^ parent,
    DigitalDefinition^ digitalDefinition,
    unsigned short value
)
Parameters
parent (DataCell)
The DataCell parent of this DigitalValue.
digitalDefinition (DigitalDefinition)
The DigitalDefinition associated with this DigitalValue.
value (UInt16)
The unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValue.


DigitalValue Constructor (parent, digitalDefinition)

DigitalValue Constructor (parent, digitalDefinition)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalValue ► DigitalValue(IDataCell, IDigitalDefinition)
Creates a new DigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalValue(
    IDataCell parent,
    IDigitalDefinition digitalDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    digitalDefinition As IDigitalDefinition _
)
public:
DigitalValue(
    IDataCell^ parent,
    IDigitalDefinition^ digitalDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this DigitalValue.
digitalDefinition (IDigitalDefinition)
The IDigitalDefinition associated with this DigitalValue.


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalValue ► Definition
Gets or sets the DigitalDefinition associated with this DigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DigitalDefinition Definition { get; set; }
Public Overridable Property Definition As DigitalDefinition
    Get
    Set
public:
virtual property DigitalDefinition^ Definition {
    DigitalDefinition^ get ();
    void set (DigitalDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalValue ► Parent
Gets or sets the DataCell parent of this DigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


FileType Enumeration

FileType Enumeration
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FileType
File type enueration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum FileType
<SerializableAttribute> _
Public Enumeration FileType
[SerializableAttribute]
public enum class FileType
Members
Member | Description
PdcNtp | PDC phasor data recording, NTP time stamp (SOC starts 1900).
PdcUnix | PDC phasor data recording, UNIX time stamp (SOC starts 1970).
Ppsm | PPSM sample data recording.


FileVersion Enumeration

FileVersion Enumeration
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FileVersion

[Missing <summary> documentation for "T:TVA.PhasorProtocols.BpaPdcStream.FileVersion"]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum FileVersion
<SerializableAttribute> _
Public Enumeration FileVersion
[SerializableAttribute]
public enum class FileVersion
Members
Member | Description
PdcWithDbuf | PDC phasor data recording, including Dbuf flag.
PdcWithoutDbuf | PDC phasor data recording, excluding Dbuf flag.


FormatFlags Enumeration

FormatFlags Enumeration
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FormatFlags
Format flags enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[FlagsAttribute]
public enum FormatFlags
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration FormatFlags
[SerializableAttribute]
[FlagsAttribute]
public enum class FormatFlags
Members
Member | Description
Frequency | Frequency data format: Set = float, Clear = integer.
Analog | Analog data format: Set = float, Clear = integer.
Phasors | Phasor data format: Set = float, Clear = integer.
Coordinates | Phasor coordinate format: Set = polar, Clear = rectangular.
DigitalWordsMask | Digital words mask.
NoFlags | No flags.


FrameParser Class

FrameParser Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser
Represents a frame parser for a BPA PDCstream binary data stream and returns parsed data via events.
Declaration Syntax
C# Visual Basic Visual C++
[PermissionSetAttribute(SecurityAction.Demand, Name = "FullTrust")]
public class FrameParser : FrameParserBase<FrameType>
<PermissionSetAttribute(SecurityAction.Demand, Name := "FullTrust")> _
Public Class FrameParser _
    Inherits FrameParserBase(Of FrameType)
[PermissionSetAttribute(SecurityAction::Demand, Name = L"FullTrust")]
public ref class FrameParser : public FrameParserBase<FrameType>
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrameParser()()()() | Creates a new FrameParser.
 | FrameParser(String) | Creates a new FrameParser from specified parameters.
 | BeginRead(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead()()()() | (Inherited from BinaryImageParserBase.)
 | CanSeek()()()() | (Inherited from BinaryImageParserBase.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite()()()() | (Inherited from BinaryImageParserBase.)
 | Close()()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ConfigurationFileName | Gets or sets required external BPA PDCstream INI based configuration file.
 | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.ConfigurationFrame.)
 | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.ConnectionParameters.)
 | CreateBufferQueue()()()() | Creates the internal buffer queue. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | DataDiscarded()()()() | (Inherited from BinaryImageParserBase.)
 | DataParsed()()()() | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParser object and optionally releases the managed resources. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | DuplicateTypeHandlerEncountered()()()() | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | Enabled()()()() | (Inherited from BinaryImageParserBase.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteParseOnSeparateThread | Gets or sets a flag that allows frame parsing to be executed on a separate thread (i.e., other than communications thread). (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()()() | Clears all buffers for this stream and causes any buffered data to be parsed immediately. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length()()()() | (Inherited from BinaryImageParserBase.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()()()() | (Inherited from BinaryImageParserBase.)
 | OnConfigurationChanged()()()() | Raises the ConfigurationChanged event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnDataDiscarded(array<Byte>[]()[][]) | (Inherited from BinaryImageParserBase.)
 | OnDataParsed(UTP) | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | OnDuplicateTypeHandlerEncountered(Type, UTP) | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | OnOutputTypeNotFound(UTP) | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | OnParsingException(Exception) | (Inherited from BinaryImageParserBase.)
 | OnReceivedChannelFrame(IChannelFrame) | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.OnReceivedChannelFrame(IChannelFrame).)
 | OnReceivedCommandFrame(ICommandFrame) | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedConfigurationFrame(IConfigurationFrame) | Raises the ReceivedConfigurationFrame event. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.OnReceivedConfigurationFrame(IConfigurationFrame).)
 | OnReceivedDataFrame(IDataFrame) | Raises the ReceivedDataFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedFrameBufferImage(FundamentalFrameType, array<Byte>[]()[][], Int32, Int32) | Raises the ReceivedFrameBufferImage event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedHeaderFrame(IHeaderFrame) | Raises the ReceivedHeaderFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedUndeterminedFrame(IChannelFrame) | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnUnknownFrameTypeEncountered(TFrameIdentifier) | Handles unknown frame types. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OutputTypeNotFound()()()() | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | Parse(ISupportBinaryImage) | (Inherited from BinaryImageParserBase.)
 | ParseCommonHeader(array<Byte>[]()[][], Int32, Int32) | Parses a common header instance that implements ICommonHeader for the output type represented in the binary image. (Overrides FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.ParseCommonHeader(array<Byte>[]()[][], Int32, Int32).)
 | ParseFrame(array<Byte>[]()[][], Int32, Int32) | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | ParseQueuedBuffers(array<array<Byte>[]()[][]>[]()[][]) | This method is used by the internal ProcessQueue to process all queued data buffers. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ParseWordCountFromByte | Gets or sets flag that interprets word count in packet header from a byte instead of a word.
 | ParsingException()()()() | (Inherited from BinaryImageParserBase.)
 | Position()()()() | (Inherited from BinaryImageParserBase.)
 | ProtocolSyncBytes()()()() | (Inherited from BinaryImageParserBase.)
 | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBase.ProtocolUsesSyncBytes()()()().)
 | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Read(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageParserBase.)
 | ReadByte()()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | ReceivedCommandFrame | Occurs when a ICommandFrame has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ReceivedConfigurationFrame | Occurs when a BPA PDCstream ConfigurationFrame has been received.
 | ReceivedDataFrame | Occurs when a BPA PDCstream DataFrame has been received.
 | ReceivedFrameBufferImage | Occurs when a frame buffer image has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | RefreshConfigurationFileOnChange | Gets or sets flag that determines if configuration file is automatically reloaded when it has changed on disk.
 | RunTime()()()() | (Inherited from BinaryImageParserBase.)
 | Seek(Int64, SeekOrigin) | (Inherited from BinaryImageParserBase.)
 | SetLength(Int64) | (Inherited from BinaryImageParserBase.)
 | Start()()()() | Start the data parser. (Overrides FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.Start()()()().)
 | Start(IEnumerable<(Of <<'(Type>)>>)) | Starts the frame parser given the specified type implementations. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Status | Gets current descriptive status of the FrameParser. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.Status.)
 | Stop()()()() | Stops the frame parser. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | StreamInitialized()()()() | (Inherited from BinaryImageParserBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalProcessedBuffers()()()() | (Inherited from BinaryImageParserBase.)
 | UnparsedBuffer()()()() | (Inherited from BinaryImageParserBase.)
 | UsePhasorDataFileFormat | Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
 | Write(array<Byte>[]()[][], Int32, Int32) | Writes a sequence of bytes onto the stream for parsing. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks
Frame parser is implemented as a write-only stream - this way data can come from any source.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | BinaryImageParserBase
 |  |  |  | FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>
 |  |  |  |  | FrameParserBase <(Of <(<' FrameType >)>)>
 |  |  |  |  |  | FrameParser


FrameParser Constructor

FrameParser Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► FrameParser()()()()
Members
Icon | Member | Description
 | FrameParser()()()() | Creates a new FrameParser.
 | FrameParser(String) | Creates a new FrameParser from specified parameters.


FrameParser Constructor

FrameParser Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► FrameParser()()()()
Creates a new FrameParser.
Declaration Syntax
C# Visual Basic Visual C++
public FrameParser()
Public Sub New
public:
FrameParser()


FrameParser Constructor (configurationFileName)

FrameParser Constructor (configurationFileName)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► FrameParser(String)
Creates a new FrameParser from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrameParser(
    string configurationFileName
)
Public Sub New ( _
    configurationFileName As String _
)
public:
FrameParser(
    String^ configurationFileName
)
Parameters
configurationFileName (String)
The required external BPA PDCstream INI based configuration file.


ConfigurationFileName Property

ConfigurationFileName Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► ConfigurationFileName
Gets or sets required external BPA PDCstream INI based configuration file.
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigurationFileName { get; set; }
Public Property ConfigurationFileName As String
    Get
    Set
public:
property String^ ConfigurationFileName {
    String^ get ();
    void set (String^ value);
}


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► ConfigurationFrame
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
Declaration Syntax
C# Visual Basic Visual C++
public override IConfigurationFrame ConfigurationFrame { get; set; }
Public Overrides Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () override;
    void set (IConfigurationFrame^ value) override;
}
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.


ConnectionParameters Property

ConnectionParameters Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► ConnectionParameters
Gets or sets any connection specific IConnectionParameters that may be needed for parsing.
Declaration Syntax
C# Visual Basic Visual C++
public override IConnectionParameters ConnectionParameters { get; set; }
Public Overrides Property ConnectionParameters As IConnectionParameters
    Get
    Set
public:
virtual property IConnectionParameters^ ConnectionParameters {
    IConnectionParameters^ get () override;
    void set (IConnectionParameters^ value) override;
}


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► Dispose(Boolean)
Releases the unmanaged resources used by the FrameParser object and optionally releases the managed resources.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true to release both managed and unmanaged resources; false to release only unmanaged resources.


OnReceivedChannelFrame Method (frame)

OnReceivedChannelFrame Method (frame)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► OnReceivedChannelFrame(IChannelFrame)
Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
protected override void OnReceivedChannelFrame(
    IChannelFrame frame
)
Protected Overrides Sub OnReceivedChannelFrame ( _
    frame As IChannelFrame _
)
protected:
virtual void OnReceivedChannelFrame(
    IChannelFrame^ frame
) override
Parameters
frame (IChannelFrame)
IChannelFrame that was parsed by FrameImageParserBase that implements protocol specific common frame header interface.


OnReceivedConfigurationFrame Method (frame)

OnReceivedConfigurationFrame Method (frame)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► OnReceivedConfigurationFrame(IConfigurationFrame)
Raises the ReceivedConfigurationFrame event.
Declaration Syntax
C# Visual Basic Visual C++
protected override void OnReceivedConfigurationFrame(
    IConfigurationFrame frame
)
Protected Overrides Sub OnReceivedConfigurationFrame ( _
    frame As IConfigurationFrame _
)
protected:
virtual void OnReceivedConfigurationFrame(
    IConfigurationFrame^ frame
) override
Parameters
frame (IConfigurationFrame)
IConfigurationFrame to send to ReceivedConfigurationFrame event.


ParseCommonHeader Method (buffer, offset, length)

ParseCommonHeader Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► ParseCommonHeader(array<Byte>[]()[][], Int32, Int32)
Parses a common header instance that implements ICommonHeader for the output type represented in the binary image.
Declaration Syntax
C# Visual Basic Visual C++
protected override ICommonHeader<FrameType> ParseCommonHeader(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function ParseCommonHeader ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As ICommonHeader(Of FrameType)
protected:
virtual ICommonHeader<FrameType>^ ParseCommonHeader(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer containing data to parse.
offset (Int32)
Offset index into buffer that represents where to start parsing.
length (Int32)
Maximum length of valid data from offset.
Return Value
The ICommonHeader which includes a type ID for the Type to be parsed.
Remarks

Derived classes need to provide a common header instance (i.e., class that implements ICommonHeader) for the output types; this will primarily include an ID of the Type that the data image represents. This parsing is only for common header information, actual parsing will be handled by output type via its Initialize(array<Byte>[]()[][], Int32, Int32) method. This header image should also be used to add needed complex state information about the output type being parsed if needed.

If there is not enough buffer available to parse common header (as determined by length), return null. Also, if the protocol allows frame length to be determined at the time common header is being parsed and there is not enough buffer to parse the entire frame, it will be optimal to prevent further parsing by returning null.


ParseWordCountFromByte Property

ParseWordCountFromByte Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► ParseWordCountFromByte
Gets or sets flag that interprets word count in packet header from a byte instead of a word.
Declaration Syntax
C# Visual Basic Visual C++
public bool ParseWordCountFromByte { get; set; }
Public Property ParseWordCountFromByte As Boolean
    Get
    Set
public:
property bool ParseWordCountFromByte {
    bool get ();
    void set (bool value);
}
Remarks
Set to true to interpret word count in packet header from a byte instead of a word - if the sync byte (0xAA) is at position one, then the word count would be interpreted from byte four. Some older BPA PDC stream implementations have a 0x01 in byte three where there should be a 0x00 and this throws off the frame length, setting this property to true will correctly interpret the word count.


ProtocolUsesSyncBytes Property

ProtocolUsesSyncBytes Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► ProtocolUsesSyncBytes
Gets flag that determines if this protocol parsing implementation uses synchronization bytes.
Declaration Syntax
C# Visual Basic Visual C++
public override bool ProtocolUsesSyncBytes { get; }
Public Overrides ReadOnly Property ProtocolUsesSyncBytes As Boolean
    Get
public:
virtual property bool ProtocolUsesSyncBytes {
    bool get () override;
}


ReceivedConfigurationFrame Event

ReceivedConfigurationFrame Event
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► ReceivedConfigurationFrame
Occurs when a BPA PDCstream ConfigurationFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<ConfigurationFrame>> ReceivedConfigurationFrame
Public Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of ConfigurationFrame))
public:
 event EventHandler<EventArgs<ConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
}
Remarks
Argument()()()() is the ConfigurationFrame that was received.


ReceivedDataFrame Event

ReceivedDataFrame Event
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► ReceivedDataFrame
Occurs when a BPA PDCstream DataFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<DataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of DataFrame))
public:
 event EventHandler<EventArgs<DataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<DataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<DataFrame^>^>^ value);
}
Remarks
Argument()()()() is the DataFrame that was received.


RefreshConfigurationFileOnChange Property

RefreshConfigurationFileOnChange Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► RefreshConfigurationFileOnChange
Gets or sets flag that determines if configuration file is automatically reloaded when it has changed on disk.
Declaration Syntax
C# Visual Basic Visual C++
public bool RefreshConfigurationFileOnChange { get; set; }
Public Property RefreshConfigurationFileOnChange As Boolean
    Get
    Set
public:
property bool RefreshConfigurationFileOnChange {
    bool get ();
    void set (bool value);
}


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► Start()()()()
Start the data parser.
Declaration Syntax
C# Visual Basic Visual C++
public override void Start()
Public Overrides Sub Start
public:
virtual void Start() override


Status Property

Status Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► Status
Gets current descriptive status of the FrameParser.
Declaration Syntax
C# Visual Basic Visual C++
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
public:
virtual property String^ Status {
    String^ get () override;
}


UsePhasorDataFileFormat Property

UsePhasorDataFileFormat Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► UsePhasorDataFileFormat
Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Declaration Syntax
C# Visual Basic Visual C++
public bool UsePhasorDataFileFormat { get; set; }
Public Property UsePhasorDataFileFormat As Boolean
    Get
    Set
public:
property bool UsePhasorDataFileFormat {
    bool get ();
    void set (bool value);
}


FrameType Enumeration

FrameType Enumeration
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameType
Frame type enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum FrameType
<SerializableAttribute> _
Public Enumeration FrameType
[SerializableAttribute]
public enum class FrameType
Members
Member | Description
ConfigurationFrame | Configuration frame.
DataFrame | Data frame.


FrequencyDefinition Class

FrequencyDefinition Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyDefinition
Represents the BPA PDCstream implementation of a IFrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FrequencyDefinition : FrequencyDefinitionBase
<SerializableAttribute> _
Public Class FrequencyDefinition _
    Inherits FrequencyDefinitionBase
[SerializableAttribute]
public ref class FrequencyDefinition : public FrequencyDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
 | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from the specified parameters.
 | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the FrequencyDefinition object. (Overrides ChannelDefinitionBase.BodyImage.)
 | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBase.BodyLength.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides FrequencyDefinitionBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this FrequencyDefinition. (Overrides ChannelDefinitionBase.MaximumLabelLength.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Offset | Gets or sets the offset of this FrequencyDefinition. (Overrides FrequencyDefinitionBase.Offset.)
 | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | FrequencyDefinitionBase
 |  |  |  |  | FrequencyDefinition


FrequencyDefinition Constructor

FrequencyDefinition Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyDefinition ► FrequencyDefinition()()()()
Members
Icon | Member | Description
 | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
 | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from the specified parameters.
 | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.


FrequencyDefinition Constructor (info, context)

FrequencyDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyDefinition ► FrequencyDefinition(SerializationInfo, StreamingContext)
Creates a new FrequencyDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrequencyDefinition Constructor (parent, entryValue)

FrequencyDefinition Constructor (parent, entryValue)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyDefinition ► FrequencyDefinition(ConfigurationCell, String)
Creates a new FrequencyDefinition from the specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyDefinition(
    ConfigurationCell parent,
    string entryValue
)
Public Sub New ( _
    parent As ConfigurationCell, _
    entryValue As String _
)
public:
FrequencyDefinition(
    ConfigurationCell^ parent,
    String^ entryValue
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this FrequencyDefinition.
entryValue (String)
The entry value from the INI based configuration file.


FrequencyDefinition Constructor (parent)

FrequencyDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyDefinition ► FrequencyDefinition(IConfigurationCell)
Creates a new FrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
FrequencyDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this FrequencyDefinition.


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyDefinition ► BodyImage
Gets the binary body image of the FrequencyDefinition object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}
Remarks
BPA PDCstream does not include frequency definition in descriptor packet.


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyDefinition ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyDefinition ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


MaximumLabelLength Property

MaximumLabelLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyDefinition ► MaximumLabelLength
Gets the maximum length of the Label of this FrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
public:
virtual property int MaximumLabelLength {
    int get () override;
}


Offset Property

Offset Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyDefinition ► Offset
Gets or sets the offset of this FrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public override double Offset { get; set; }
Public Overrides Property Offset As Double
    Get
    Set
public:
virtual property double Offset {
    double get () override;
    void set (double value) override;
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyDefinition ► Parent
Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


FrequencyValue Class

FrequencyValue Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyValue
Represents the BPA PDCstream implementation of a IFrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FrequencyValue : FrequencyValueBase
<SerializableAttribute> _
Public Class FrequencyValue _
    Inherits FrequencyValueBase
[SerializableAttribute]
public ref class FrequencyValue : public FrequencyValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
 | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
 | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the FrequencyValue object. (Overrides FrequencyValueBase.BodyImage.)
 | BodyLength | Gets the length of the BodyImage. (Overrides FrequencyValueBase.BodyLength.)
 | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
 | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this FrequencyValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides FrequencyValueBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
 | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IFrequencyDefinition >)>)>
 |  |  |  | FrequencyValueBase
 |  |  |  |  | FrequencyValue


FrequencyValue Constructor

FrequencyValue Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyValue ► FrequencyValue()()()()
Members
Icon | Member | Description
 | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
 | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
 | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.


FrequencyValue Constructor (info, context)

FrequencyValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyValue ► FrequencyValue(SerializationInfo, StreamingContext)
Creates a new FrequencyValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrequencyValue Constructor (parent, frequencyDefinition, frequency, dfdt)

FrequencyValue Constructor (parent, frequencyDefinition, frequency, dfdt)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyValue ► FrequencyValue(DataCell, FrequencyDefinition, Double, Double)
Creates a new FrequencyValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyValue(
    DataCell parent,
    FrequencyDefinition frequencyDefinition,
    double frequency,
    double dfdt
)
Public Sub New ( _
    parent As DataCell, _
    frequencyDefinition As FrequencyDefinition, _
    frequency As Double, _
    dfdt As Double _
)
public:
FrequencyValue(
    DataCell^ parent,
    FrequencyDefinition^ frequencyDefinition,
    double frequency,
    double dfdt
)
Parameters
parent (DataCell)
The DataCell parent of this FrequencyValue.
frequencyDefinition (FrequencyDefinition)
The FrequencyDefinition associated with this FrequencyValue.
frequency (Double)
The floating point value that represents this FrequencyValue.
dfdt (Double)
The floating point value that represents the change in this FrequencyValue over time.


FrequencyValue Constructor (parent, frequencyDefinition)

FrequencyValue Constructor (parent, frequencyDefinition)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyValue ► FrequencyValue(IDataCell, IFrequencyDefinition)
Creates a new FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyValue(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    frequencyDefinition As IFrequencyDefinition _
)
public:
FrequencyValue(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this FrequencyValue.
frequencyDefinition (IFrequencyDefinition)
The IFrequencyDefinition associated with this FrequencyValue.


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyValue ► BodyImage
Gets the binary body image of the FrequencyValue object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyValue ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyValue ► Definition
Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual FrequencyDefinition Definition { get; set; }
Public Overridable Property Definition As FrequencyDefinition
    Get
    Set
public:
virtual property FrequencyDefinition^ Definition {
    FrequencyDefinition^ get ();
    void set (FrequencyDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyValue ► Parent
Gets or sets the DataCell parent of this FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyValue ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


IniFileNameEditor Class

IniFileNameEditor Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► IniFileNameEditor
INI file name browser used with BPA PDCstream ConnectionParameters.
Declaration Syntax
C# Visual Basic Visual C++
public class IniFileNameEditor : FileNameEditor
Public Class IniFileNameEditor _
    Inherits FileNameEditor
public ref class IniFileNameEditor : public FileNameEditor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IniFileNameEditor()()()() | Initializes a new instance of the IniFileNameEditor class
 | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object using the editor style provided by the GetEditStyle(ITypeDescriptorContext) method. (Inherited from FileNameEditor.)
 | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()()() method. (Inherited from UITypeEditor.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEditStyle(ITypeDescriptorContext) | Gets the editing style used by the EditValue(ITypeDescriptorContext, IServiceProvider, Object) method. (Inherited from FileNameEditor.)
 | GetEditStyle()()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPaintValueSupported()()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
 | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeDialog(OpenFileDialog) | Initializes the open file dialog when it is created. (Overrides FileNameEditor.InitializeDialog(OpenFileDialog).)
 | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
 | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | UITypeEditor
 |  | FileNameEditor
 |  |  | IniFileNameEditor


IniFileNameEditor Constructor

IniFileNameEditor Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► IniFileNameEditor ► IniFileNameEditor()()()()
Initializes a new instance of the IniFileNameEditor class
Declaration Syntax
C# Visual Basic Visual C++
public IniFileNameEditor()
Public Sub New
public:
IniFileNameEditor()


InitializeDialog Method (openFileDialog)

InitializeDialog Method (openFileDialog)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► IniFileNameEditor ► InitializeDialog(OpenFileDialog)
Initializes the open file dialog when it is created.
Declaration Syntax
C# Visual Basic Visual C++
protected override void InitializeDialog(
    OpenFileDialog openFileDialog
)
Protected Overrides Sub InitializeDialog ( _
    openFileDialog As OpenFileDialog _
)
protected:
virtual void InitializeDialog(
    OpenFileDialog^ openFileDialog
) override
Parameters
openFileDialog (OpenFileDialog)
The OpenFileDialog to use to select a file name.


PhasorDefinition Class

PhasorDefinition Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition
Represents the BPA PDCstream implementation of a IPhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PhasorDefinition : PhasorDefinitionBase
<SerializableAttribute> _
Public Class PhasorDefinition _
    Inherits PhasorDefinitionBase
[SerializableAttribute]
public ref class PhasorDefinition : public PhasorDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(ConfigurationCell, Int32, String) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorDefinition object. (Overrides PhasorDefinitionBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CalFactor | Gets or sets calibration factor of this PhasorDefinition.
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Overrides ChannelDefinitionBase.ConversionFactor.)
 | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PhasorDefinitionBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this PhasorDefinition. (Overrides ChannelDefinitionBase.MaximumLabelLength.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | Ratio | Gets or sets ratio of this PhasorDefinition.
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Shunt | Gets or sets shunt value of this PhasorDefinition.
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
 | VoltageReferenceIndex | Gets or sets voltage reference index of this PhasorDefinition.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | PhasorDefinitionBase
 |  |  |  |  | PhasorDefinition


PhasorDefinition Constructor

PhasorDefinition Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition ► PhasorDefinition()()()()
Members
Icon | Member | Description
 | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(ConfigurationCell, Int32, String) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.


PhasorDefinition Constructor (info, context)

PhasorDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition ► PhasorDefinition(SerializationInfo, StreamingContext)
Creates a new PhasorDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


PhasorDefinition Constructor (parent, index, entryValue)

PhasorDefinition Constructor (parent, index, entryValue)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition ► PhasorDefinition(ConfigurationCell, Int32, String)
Creates a new PhasorDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinition(
    ConfigurationCell parent,
    int index,
    string entryValue
)
Public Sub New ( _
    parent As ConfigurationCell, _
    index As Integer, _
    entryValue As String _
)
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    int index,
    String^ entryValue
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this PhasorDefinition.
index (Int32)
Index of phasor within INI based configuration file.
entryValue (String)
The entry value from the INI based configuration file.


PhasorDefinition Constructor (parent, label, scale, offset, type, voltageReference)

PhasorDefinition Constructor (parent, label, scale, offset, type, voltageReference)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition ► PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition)
Creates a new PhasorDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinition(
    ConfigurationCell parent,
    string label,
    uint scale,
    double offset,
    PhasorType type,
    PhasorDefinition voltageReference
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String, _
    scale As UInteger, _
    offset As Double, _
    type As PhasorType, _
    voltageReference As PhasorDefinition _
)
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset,
    PhasorType type,
    PhasorDefinition^ voltageReference
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this PhasorDefinition.
label (String)
The label of this PhasorDefinition.
scale (UInt32)
The integer scaling value of this PhasorDefinition.
offset (Double)
The offset of this PhasorDefinition.
type (PhasorType)
The PhasorType of this PhasorDefinition.
voltageReference (PhasorDefinition)
The associated IPhasorDefinition that represents the voltage reference (if any).


PhasorDefinition Constructor (parent)

PhasorDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition ► PhasorDefinition(IConfigurationCell)
Creates a new PhasorDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
PhasorDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this PhasorDefinition.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition ► Attributes
Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorDefinition object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


CalFactor Property

CalFactor Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition ► CalFactor
Gets or sets calibration factor of this PhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public double CalFactor { get; set; }
Public Property CalFactor As Double
    Get
    Set
public:
property double CalFactor {
    double get ();
    void set (double value);
}


ConversionFactor Property

ConversionFactor Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition ► ConversionFactor
Gets or sets the conversion factor of this ChannelDefinitionBase.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override double ConversionFactor { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides Property ConversionFactor As Double
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property double ConversionFactor {
    double get () override;
    void set (double value) override;
}
Remarks
This method is hidden from the consumer since BPA PDCstream uses a custom conversion factor. Property always returns 1.0, updates are ignored.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


MaximumLabelLength Property

MaximumLabelLength Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition ► MaximumLabelLength
Gets the maximum length of the Label of this PhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
public:
virtual property int MaximumLabelLength {
    int get () override;
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition ► Parent
Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


Ratio Property

Ratio Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition ► Ratio
Gets or sets ratio of this PhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public double Ratio { get; set; }
Public Property Ratio As Double
    Get
    Set
public:
property double Ratio {
    double get ();
    void set (double value);
}


Shunt Property

Shunt Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition ► Shunt
Gets or sets shunt value of this PhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public double Shunt { get; set; }
Public Property Shunt As Double
    Get
    Set
public:
property double Shunt {
    double get ();
    void set (double value);
}


VoltageReferenceIndex Property

VoltageReferenceIndex Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition ► VoltageReferenceIndex
Gets or sets voltage reference index of this PhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public int VoltageReferenceIndex { get; set; }
Public Property VoltageReferenceIndex As Integer
    Get
    Set
public:
property int VoltageReferenceIndex {
    int get ();
    void set (int value);
}


PhasorValue Class

PhasorValue Class
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorValue
Represents the BPA PDCstream implementation of a IPhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PhasorValue : PhasorValueBase
<SerializableAttribute> _
Public Class PhasorValue _
    Inherits PhasorValueBase
[SerializableAttribute]
public ref class PhasorValue : public PhasorValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
 | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
 | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValue, in radians. (Overrides PhasorValueBase.Angle.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
 | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
 | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue. (Overrides PhasorValueBase.Magnitude.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this PhasorValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from PhasorValueBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IPhasorDefinition >)>)>
 |  |  |  | PhasorValueBase
 |  |  |  |  | PhasorValue


PhasorValue Constructor

PhasorValue Constructor
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorValue ► PhasorValue()()()()
Members
Icon | Member | Description
 | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
 | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.


PhasorValue Constructor (info, context)

PhasorValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorValue ► PhasorValue(SerializationInfo, StreamingContext)
Creates a new PhasorValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


PhasorValue Constructor (parent, phasorDefinition, real, imaginary)

PhasorValue Constructor (parent, phasorDefinition, real, imaginary)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorValue ► PhasorValue(DataCell, PhasorDefinition, Double, Double)
Creates a new PhasorValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    double real,
    double imaginary
)
Public Sub New ( _
    parent As DataCell, _
    phasorDefinition As PhasorDefinition, _
    real As Double, _
    imaginary As Double _
)
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    double real,
    double imaginary
)
Parameters
parent (DataCell)
The DataCell parent of this PhasorValue.
phasorDefinition (PhasorDefinition)
The PhasorDefinition associated with this PhasorValue.
real (Double)
The real value of this PhasorValue.
imaginary (Double)
The imaginary value of this PhasorValue.


PhasorValue Constructor (parent, phasorDefinition, angle, magnitude)

PhasorValue Constructor (parent, phasorDefinition, angle, magnitude)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorValue ► PhasorValue(DataCell, PhasorDefinition, Angle, Double)
Creates a new PhasorValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    Angle angle,
    double magnitude
)
Public Sub New ( _
    parent As DataCell, _
    phasorDefinition As PhasorDefinition, _
    angle As Angle, _
    magnitude As Double _
)
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    Angle angle,
    double magnitude
)
Parameters
parent (DataCell)
The DataCell parent of this PhasorValue.
phasorDefinition (PhasorDefinition)
The PhasorDefinition associated with this PhasorValue.
angle (Angle)
The Angle value (a.k.a., the argument) of this PhasorValue, in radians.
magnitude (Double)
The magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue.


PhasorValue Constructor (parent, phasorDefinition)

PhasorValue Constructor (parent, phasorDefinition)
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorValue ► PhasorValue(IDataCell, IPhasorDefinition)
Creates a new PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    IDataCell parent,
    IPhasorDefinition phasorDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    phasorDefinition As IPhasorDefinition _
)
public:
PhasorValue(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this PhasorValue.
phasorDefinition (IPhasorDefinition)
The IPhasorDefinition associated with this PhasorValue.


Angle Property

Angle Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorValue ► Angle
Gets or sets the Angle value (a.k.a., the argument) of this PhasorValue, in radians.
Declaration Syntax
C# Visual Basic Visual C++
public override Angle Angle { get; set; }
Public Overrides Property Angle As Angle
    Get
    Set
public:
virtual property Angle Angle {
    Angle get () override;
    void set (Angle value) override;
}


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorValue ► Definition
Gets or sets the PhasorDefinition associated with this PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual PhasorDefinition Definition { get; set; }
Public Overridable Property Definition As PhasorDefinition
    Get
    Set
public:
virtual property PhasorDefinition^ Definition {
    PhasorDefinition^ get ();
    void set (PhasorDefinition^ value);
}


Magnitude Property

Magnitude Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorValue ► Magnitude
Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public override double Magnitude { get; set; }
Public Overrides Property Magnitude As Double
    Get
    Set
public:
virtual property double Magnitude {
    double get () override;
    void set (double value) override;
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorValue ► Parent
Gets or sets the DataCell parent of this PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


PMUStatusFlags Enumeration

PMUStatusFlags Enumeration
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PMUStatusFlags
PMU status flags enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[FlagsAttribute]
public enum PMUStatusFlags
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration PMUStatusFlags
[SerializableAttribute]
[FlagsAttribute]
public enum class PMUStatusFlags
Members
Member | Description
SyncInvalid | Synchonization is invalid.
DataInvalid | Data is invalid.
NoFlags | No flags.


ReservedFlags Enumeration

ReservedFlags Enumeration
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ReservedFlags
Reserved flags enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[FlagsAttribute]
public enum ReservedFlags
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration ReservedFlags
[SerializableAttribute]
[FlagsAttribute]
public enum class ReservedFlags
Members
Member | Description
Reserved0 | Reserved bit 7.
Reserved1 | Reserved bit 6.
AnalogWordsMask | Analog words mask.
NoFlags | No flags.


RevisionNumber Enumeration

RevisionNumber Enumeration
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► RevisionNumber
Stream revision number enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum RevisionNumber
<SerializableAttribute> _
Public Enumeration RevisionNumber
[SerializableAttribute]
public enum class RevisionNumber
Members
Member | Description
Revision0 | Original revision for all to June 2002, use NTP timetag (start count 1900).
Revision1 | July 2002 revision for std. 37.118, use UNIX timetag (start count 1970).
Revision2 | May 2005 revision for std. 37.118, change ChanFlag for added data types.


StreamType Enumeration

StreamType Enumeration
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► StreamType
Stream type enueration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum StreamType
<SerializableAttribute> _
Public Enumeration StreamType
[SerializableAttribute]
public enum class StreamType
Members
Member | Description
Legacy | Standard full data stream.
Compact | Full data stream with PMU ID's and offsets removed from data packet.


TVA.PhasorProtocols.FNet Namespace

TVA.PhasorProtocols.FNet Namespace
Namespaces ► TVA.PhasorProtocols.FNet
Contains an implementation of the phasor classes used to parse or generate a stream of data in the F-NET device format.
Declaration Syntax
C# Visual Basic Visual C++
namespace TVA.PhasorProtocols.FNet
Namespace TVA.PhasorProtocols.FNet
namespace TVA.PhasorProtocols.FNet
Types
All Types Classes
Icon | Type | Description
 | Common | Common F-NET declarations and functions.
 | CommonFrameHeader | Represents the common header for a F-NET frame of data.
 | ConfigurationCell | Represents the F-NET implementation of a IConfigurationCell that can be sent or received.
 | ConfigurationCellCollection | Represents a F-NET implementation of a collection of IConfigurationCell objects.
 | ConfigurationFrame | Represents the F-NET implementation of a IConfigurationFrame that can be sent or received.
 | ConnectionParameters | Represents the extra connection parameters required for a connection to a F-NET device.
 | DataCell | Represents the F-NET implementation of a IDataCell that can be sent or received.
 | DataCellCollection | Represents a F-NET implementation of a collection of IDataCell objects.
 | DataFrame | Represents the F-NET implementation of a IDataFrame that can be sent or received.
 | FrameParser | Represents a frame parser for a F-NET text based data stream that returns parsed data via events.
 | FrequencyDefinition | Represents the F-NET implementation of a IFrequencyDefinition.
 | FrequencyValue | Represents the F-NET implementation of a IFrequencyValue.
 | PhasorDefinition | Represents the F-NET implementation of a IPhasorDefinition.
 | PhasorValue | Represents the F-NET implementation of a IPhasorValue.


Common Class

Common Class
Namespaces ► TVA.PhasorProtocols.FNet ► Common
Common F-NET declarations and functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class Common
Public NotInheritable Class Common
public ref class Common abstract sealed
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DefaultFrameRate | Default frame rate for F-NET devices is 10 frames per second.
 | DefaultNominalFrequency | Default nominal frequency for F-NET devices is 60Hz.
 | DefaultStationName | Default F-NET station name.
 | DefaultTimeOffset | Default real-time ticks offset for F-NET.
 | EndByte | F-NET data frame start byte.
 | MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
 | MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
 | MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
 | MaximumPracticalFrameSize | The maximum practical limit for an F-NET data frame.
 | StartByte | F-NET data frame start byte.
Inheritance Hierarchy
Object
Common


DefaultFrameRate Field

DefaultFrameRate Field
Namespaces ► TVA.PhasorProtocols.FNet ► Common ► DefaultFrameRate
Default frame rate for F-NET devices is 10 frames per second.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort DefaultFrameRate
Public Const DefaultFrameRate As UShort
public:
literal unsigned short DefaultFrameRate


DefaultNominalFrequency Field

DefaultNominalFrequency Field
Namespaces ► TVA.PhasorProtocols.FNet ► Common ► DefaultNominalFrequency
Default nominal frequency for F-NET devices is 60Hz.
Declaration Syntax
C# Visual Basic Visual C++
public const LineFrequency DefaultNominalFrequency
Public Const DefaultNominalFrequency As LineFrequency
public:
literal LineFrequency DefaultNominalFrequency


DefaultStationName Field

DefaultStationName Field
Namespaces ► TVA.PhasorProtocols.FNet ► Common ► DefaultStationName
Default F-NET station name.
Declaration Syntax
C# Visual Basic Visual C++
public const string DefaultStationName
Public Const DefaultStationName As String
public:
literal String^ DefaultStationName


DefaultTimeOffset Field

DefaultTimeOffset Field
Namespaces ► TVA.PhasorProtocols.FNet ► Common ► DefaultTimeOffset
Default real-time ticks offset for F-NET.
Declaration Syntax
C# Visual Basic Visual C++
public const long DefaultTimeOffset
Public Const DefaultTimeOffset As Long
public:
literal long long DefaultTimeOffset


EndByte Field

EndByte Field
Namespaces ► TVA.PhasorProtocols.FNet ► Common ► EndByte
F-NET data frame start byte.
Declaration Syntax
C# Visual Basic Visual C++
public const byte EndByte
Public Const EndByte As Byte
public:
literal unsigned char EndByte


MaximumAnalogValues Field

MaximumAnalogValues Field
Namespaces ► TVA.PhasorProtocols.FNet ► Common ► MaximumAnalogValues
Absolute maximum number of possible analog values that could fit into a data frame.
Declaration Syntax
C# Visual Basic Visual C++
public const int MaximumAnalogValues
Public Const MaximumAnalogValues As Integer
public:
literal int MaximumAnalogValues
Remarks
F-NET doesn't support analog values.


MaximumDigitalValues Field

MaximumDigitalValues Field
Namespaces ► TVA.PhasorProtocols.FNet ► Common ► MaximumDigitalValues
Absolute maximum number of possible digital values that could fit into a data frame.
Declaration Syntax
C# Visual Basic Visual C++
public const int MaximumDigitalValues
Public Const MaximumDigitalValues As Integer
public:
literal int MaximumDigitalValues
Remarks
F-NET doesn't support digital values.


MaximumPhasorValues Field

MaximumPhasorValues Field
Namespaces ► TVA.PhasorProtocols.FNet ► Common ► MaximumPhasorValues
Absolute maximum number of possible phasor values that could fit into a data frame.
Declaration Syntax
C# Visual Basic Visual C++
public const int MaximumPhasorValues
Public Const MaximumPhasorValues As Integer
public:
literal int MaximumPhasorValues


MaximumPracticalFrameSize Field

MaximumPracticalFrameSize Field
Namespaces ► TVA.PhasorProtocols.FNet ► Common ► MaximumPracticalFrameSize
The maximum practical limit for an F-NET data frame.
Declaration Syntax
C# Visual Basic Visual C++
public const int MaximumPracticalFrameSize
Public Const MaximumPracticalFrameSize As Integer
public:
literal int MaximumPracticalFrameSize


StartByte Field

StartByte Field
Namespaces ► TVA.PhasorProtocols.FNet ► Common ► StartByte
F-NET data frame start byte.
Declaration Syntax
C# Visual Basic Visual C++
public const byte StartByte
Public Const StartByte As Byte
public:
literal unsigned char StartByte


CommonFrameHeader Class

CommonFrameHeader Class
Namespaces ► TVA.PhasorProtocols.FNet ► CommonFrameHeader
Represents the common header for a F-NET frame of data.
Declaration Syntax
C# Visual Basic Visual C++
public class CommonFrameHeader : CommonHeaderBase<int>
Public Class CommonFrameHeader _
    Inherits CommonHeaderBase(Of Integer)
public ref class CommonFrameHeader : public CommonHeaderBase<int>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommonFrameHeader(array<Byte>[]()[][], Int32, Int32) | Creates a new CommonFrameHeader from given binaryImage.
 | DataElements | Gets F-NET data elements parsed during construction.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParsedLength | Gets length of data parsed during construction.
 | State()()()() | (Inherited from CommonHeaderBase<(Of <(<' Int32 >)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID()()()() | (Inherited from CommonHeaderBase<(Of <(<' Int32 >)>)>.)
Remarks
Because of its simplicity, all F-NET parsing is handled in the constructor of this class. Subsequently all parsed data is available as an array of strings where needed.
Inheritance Hierarchy
Object
 | CommonHeaderBase<(Of <(<' Int32 >)>)>
 |  | CommonFrameHeader


CommonFrameHeader Constructor (binaryImage, startIndex, length)

CommonFrameHeader Constructor (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.FNet ► CommonFrameHeader ► CommonFrameHeader(array<Byte>[]()[][], Int32, Int32)
Creates a new CommonFrameHeader from given binaryImage.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader(
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Sub New ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
)
public:
CommonFrameHeader(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
)
Parameters
binaryImage (array< Byte >[]()[][])
Buffer that contains data to parse.
startIndex (Int32)
Start index into buffer where valid data begins.
length (Int32)
Length of valid data in binaryImage.


DataElements Property

DataElements Property
Namespaces ► TVA.PhasorProtocols.FNet ► CommonFrameHeader ► DataElements
Gets F-NET data elements parsed during construction.
Declaration Syntax
C# Visual Basic Visual C++
public string[] DataElements { get; }
Public ReadOnly Property DataElements As String()
    Get
public:
property array<String^>^ DataElements {
    array<String^>^ get ();
}


ParsedLength Property

ParsedLength Property
Namespaces ► TVA.PhasorProtocols.FNet ► CommonFrameHeader ► ParsedLength
Gets length of data parsed during construction.
Declaration Syntax
C# Visual Basic Visual C++
public int ParsedLength { get; }
Public ReadOnly Property ParsedLength As Integer
    Get
public:
property int ParsedLength {
    int get ();
}


ConfigurationCell Class

ConfigurationCell Class
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell
Represents the F-NET implementation of a IConfigurationCell that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationCell : ConfigurationCellBase
<SerializableAttribute> _
Public Class ConfigurationCell _
    Inherits ConfigurationCellBase
[SerializableAttribute]
public ref class ConfigurationCell : public ConfigurationCellBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
 | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.AnalogDataFormat.)
 | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationCell object. (Overrides ConfigurationCellBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
 | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
 | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
 | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage | Gets the binary footer image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationCellBase.)
 | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBase.FrequencyDataFormat.)
 | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationCellBase.)
 | IDCode | Gets or sets the ID code of this ConfigurationCell. (Overrides ChannelCellBase.IDCode.)
 | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Latitude | Gets or sets the latitude (i.e., North/South geospatial position) of the device defined by this ConfigurationCell.
 | Longitude | Gets or sets the longitude (i.e., East/West geospatial position) of the device defined by this ConfigurationCell.
 | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCell. (Overrides ConfigurationCellBase.MaximumStationNameLength.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | NumberOfSatellites | Gets or sets the number of satellites visible to the GPS timing source of the device defined by this ConfigurationCell.
 | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ConfigurationCellBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary footer image. (Inherited from ConfigurationCellBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Inherited from ConfigurationCellBase.)
 | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.PhasorCoordinateFormat.)
 | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.PhasorDataFormat.)
 | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | TimeOffset | Gets or sets time offset of F-NET device in Ticks.
 | ToString()()()() | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | ConfigurationCellBase
 |  |  |  |  | ConfigurationCell


ConfigurationCell Constructor (info, context)

ConfigurationCell Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell ► ConfigurationCell(SerializationInfo, StreamingContext)
Creates a new ConfigurationCell from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationCell(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


AnalogDataFormat Property

AnalogDataFormat Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell ► AnalogDataFormat
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat AnalogDataFormat { get; set; }
Public Overrides Property AnalogDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat AnalogDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}
Remarks
This property only supports floating-point data; F-NET doesn't transport scaled values.
Exceptions
Exception | Condition
NotSupportedException | F-NET only supports floating-point data.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationCell object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


FrequencyDataFormat Property

FrequencyDataFormat Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell ► FrequencyDataFormat
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat FrequencyDataFormat { get; set; }
Public Overrides Property FrequencyDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}
Remarks
This property only supports floating-point data; F-NET doesn't transport scaled values.
Exceptions
Exception | Condition
NotSupportedException | F-NET only supports floating-point data.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell ► IDCode
Gets or sets the ID code of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override ushort IDCode { get; set; }
Public Overrides Property IDCode As UShort
    Get
    Set
public:
virtual property unsigned short IDCode {
    unsigned short get () override;
    void set (unsigned short value) override;
}


Latitude Property

Latitude Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell ► Latitude
Gets or sets the latitude (i.e., North/South geospatial position) of the device defined by this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public double Latitude { get; set; }
Public Property Latitude As Double
    Get
    Set
public:
property double Latitude {
    double get ();
    void set (double value);
}


Longitude Property

Longitude Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell ► Longitude
Gets or sets the longitude (i.e., East/West geospatial position) of the device defined by this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public double Longitude { get; set; }
Public Property Longitude As Double
    Get
    Set
public:
property double Longitude {
    double get ();
    void set (double value);
}


MaximumStationNameLength Property

MaximumStationNameLength Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell ► MaximumStationNameLength
Gets the maximum length of the StationName of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override int MaximumStationNameLength { get; }
Public Overrides ReadOnly Property MaximumStationNameLength As Integer
    Get
public:
virtual property int MaximumStationNameLength {
    int get () override;
}


NumberOfSatellites Property

NumberOfSatellites Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell ► NumberOfSatellites
Gets or sets the number of satellites visible to the GPS timing source of the device defined by this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfSatellites { get; set; }
Public Property NumberOfSatellites As Integer
    Get
    Set
public:
property int NumberOfSatellites {
    int get ();
    void set (int value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell ► Parent
Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame Parent { get; set; }
Public Property Parent As ConfigurationFrame
    Get
    Set
public:
property ConfigurationFrame^ Parent {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}


PhasorCoordinateFormat Property

PhasorCoordinateFormat Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell ► PhasorCoordinateFormat
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override CoordinateFormat PhasorCoordinateFormat { get; set; }
Public Overrides Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () override;
    void set (CoordinateFormat value) override;
}
Remarks
This property only supports polar phasor data; F-NET doesn't transport rectangular phasor values.
Exceptions
Exception | Condition
NotSupportedException | F-NET only supports polar phasor data.


PhasorDataFormat Property

PhasorDataFormat Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell ► PhasorDataFormat
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat PhasorDataFormat { get; set; }
Public Overrides Property PhasorDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}
Remarks
This property only supports floating-point data; F-NET doesn't transport scaled values.
Exceptions
Exception | Condition
NotSupportedException | F-NET only supports floating-point data.


TimeOffset Property

TimeOffset Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell ► TimeOffset
Gets or sets time offset of F-NET device in Ticks.
Declaration Syntax
C# Visual Basic Visual C++
public Ticks TimeOffset { get; set; }
Public Property TimeOffset As Ticks
    Get
    Set
public:
property Ticks TimeOffset {
    Ticks get ();
    void set (Ticks value);
}
Remarks
F-NET devices normally report time in 11 seconds past real-time, this property defines the offset for this this artificial delay. Note that the parameter value is in ticks to allow a very high-resolution offset; 1 second = 10,000,000 ticks.


ConfigurationCellCollection Class

ConfigurationCellCollection Class
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCellCollection
Represents a F-NET implementation of a collection of IConfigurationCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationCellCollection : ConfigurationCellCollection
<SerializableAttribute> _
Public Class ConfigurationCellCollection _
    Inherits ConfigurationCellCollection
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ConfigurationCellCollection
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCellCollection()()()() | Creates a new ConfigurationCellCollection.
 | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | IndexOfIDCode(UInt16) | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
 | IndexOfIDLabel(String) | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
 | IndexOfStationName(String) | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets ConfigurationCell at specified index.
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetByIDCode(UInt16, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
 | TryGetByIDLabel(String, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
 | TryGetByStationName(String, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IConfigurationCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' IConfigurationCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationCellCollection
 |  |  |  |  | ConfigurationCellCollection


ConfigurationCellCollection Constructor

ConfigurationCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCellCollection ► ConfigurationCellCollection()()()()
Members
Icon | Member | Description
 | ConfigurationCellCollection()()()() | Creates a new ConfigurationCellCollection.
 | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.


ConfigurationCellCollection Constructor

ConfigurationCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCellCollection ► ConfigurationCellCollection()()()()
Creates a new ConfigurationCellCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellCollection()
Public Sub New
public:
ConfigurationCellCollection()


ConfigurationCellCollection Constructor (info, context)

ConfigurationCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCellCollection ► ConfigurationCellCollection(SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


Item Property (index)

Item Property (index)
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCellCollection ► Item[([( Int32])])
Gets or sets ConfigurationCell at specified index.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ConfigurationCell
    Get
    Set
public:
property ConfigurationCell^ default[int index] {
    ConfigurationCell^ get (int index);
    void set (int index, ConfigurationCell^ value);
}
Parameters
index (Int32)
Index of value to get or set.


ConfigurationFrame Class

ConfigurationFrame Class
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationFrame
Represents the F-NET implementation of a IConfigurationFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationFrame : ConfigurationFrameBase
<SerializableAttribute> _
Public Class ConfigurationFrame _
    Inherits ConfigurationFrameBase
[SerializableAttribute]
public ref class ConfigurationFrame : public ConfigurationFrameBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationFrame(UInt16, Ticks, UInt16, LineFrequency, Ticks, String) | Creates a new ConfigurationFrame from specified parameters.
 | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrameBase object. (Inherited from ConfigurationFrameBase.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Method is not implemented. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.ChecksumIsValid(array<Byte>[]()[][], Int32).)
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrameBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Latitude | Gets or sets the latitude (i.e., North/South geospatial position) of the device.
 | Longitude | Gets or sets the longitude (i.e., East/West geospatial position) of the device.
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets or sets the nominal LineFrequency of this ConfigurationFrame.
 | NumberOfSatellites | Gets or sets the number of satellites visible to the GPS timing source of the device.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SetNominalFrequency(LineFrequency) | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | TimeOffset | Gets or sets the time offset of F-NET device in Ticks.
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationFrameBase
 |  |  |  |  | ConfigurationFrame


ConfigurationFrame Constructor

ConfigurationFrame Constructor
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationFrame ► ConfigurationFrame()()()()
Members
Icon | Member | Description
 | ConfigurationFrame(UInt16, Ticks, UInt16, LineFrequency, Ticks, String) | Creates a new ConfigurationFrame from specified parameters.
 | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.


ConfigurationFrame Constructor (info, context)

ConfigurationFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationFrame ► ConfigurationFrame(SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationFrame Constructor (idCode, timestamp, frameRate, nominalFrequency, timeOffset, stationName)

ConfigurationFrame Constructor (idCode, timestamp, frameRate, nominalFrequency, timeOffset, stationName)
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationFrame ► ConfigurationFrame(UInt16, Ticks, UInt16, LineFrequency, Ticks, String)
Creates a new ConfigurationFrame from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame(
    ushort idCode,
    Ticks timestamp,
    ushort frameRate,
    LineFrequency nominalFrequency,
    Ticks timeOffset,
    string stationName
)
Public Sub New ( _
    idCode As UShort, _
    timestamp As Ticks, _
    frameRate As UShort, _
    nominalFrequency As LineFrequency, _
    timeOffset As Ticks, _
    stationName As String _
)
public:
ConfigurationFrame(
    unsigned short idCode,
    Ticks timestamp,
    unsigned short frameRate,
    LineFrequency nominalFrequency,
    Ticks timeOffset,
    String^ stationName
)
Parameters
idCode (UInt16)
The ID code of this ConfigurationFrame.
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame.
frameRate (UInt16)
The defined frame rate of this ConfigurationFrame.
nominalFrequency (LineFrequency)
The nominal LineFrequency of this ConfigurationFrame.
timeOffset (Ticks)
The time offset of F-NET device in Ticks.
stationName (String)
The station name of the F-NET device.
Remarks
This constructor is used by a consumer to generate an F-NET configuration frame.


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Method is not implemented.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
A Byte array.
offset (Int32)
An Int32 for the length.
length (Int32)
An Int32 for the offset.
Return Value
An UInt16.
Exceptions
Exception | Condition
NotImplementedException | F-NET doesn't use checksums.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationFrame ► Cells
Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellCollection Cells { get; }
Public ReadOnly Property Cells As ConfigurationCellCollection
    Get
public:
property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}


ChecksumIsValid Method (buffer, startIndex)

ChecksumIsValid Method (buffer, startIndex)
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationFrame ► ChecksumIsValid(array<Byte>[]()[][], Int32)
Determines if checksum in the buffer is valid.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid ( _
    buffer As Byte(), _
    startIndex As Integer _
) As Boolean
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image to validate.
startIndex (Int32)
Start index into buffer to perform checksum.
Return Value
Flag that determines if checksum over buffer is valid.
Remarks
F-NET doesn't use checksums - this always returns true.


Latitude Property

Latitude Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationFrame ► Latitude
Gets or sets the latitude (i.e., North/South geospatial position) of the device.
Declaration Syntax
C# Visual Basic Visual C++
public double Latitude { get; set; }
Public Property Latitude As Double
    Get
    Set
public:
property double Latitude {
    double get ();
    void set (double value);
}


Longitude Property

Longitude Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationFrame ► Longitude
Gets or sets the longitude (i.e., East/West geospatial position) of the device.
Declaration Syntax
C# Visual Basic Visual C++
public double Longitude { get; set; }
Public Property Longitude As Double
    Get
    Set
public:
property double Longitude {
    double get ();
    void set (double value);
}


NominalFrequency Property

NominalFrequency Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationFrame ► NominalFrequency
Gets or sets the nominal LineFrequency of this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public LineFrequency NominalFrequency { get; set; }
Public Property NominalFrequency As LineFrequency
    Get
    Set
public:
property LineFrequency NominalFrequency {
    LineFrequency get ();
    void set (LineFrequency value);
}


NumberOfSatellites Property

NumberOfSatellites Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationFrame ► NumberOfSatellites
Gets or sets the number of satellites visible to the GPS timing source of the device.
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfSatellites { get; set; }
Public Property NumberOfSatellites As Integer
    Get
    Set
public:
property int NumberOfSatellites {
    int get ();
    void set (int value);
}


TimeOffset Property

TimeOffset Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationFrame ► TimeOffset
Gets or sets the time offset of F-NET device in Ticks.
Declaration Syntax
C# Visual Basic Visual C++
public Ticks TimeOffset { get; set; }
Public Property TimeOffset As Ticks
    Get
    Set
public:
property Ticks TimeOffset {
    Ticks get ();
    void set (Ticks value);
}
Remarks
F-NET devices normally report time in 11 seconds past real-time, this property defines the offset for this this artificial delay. Note that the parameter value is in ticks to allow a very high-resolution offset; 1 second = 10,000,000 ticks.


ConnectionParameters Class

ConnectionParameters Class
Namespaces ► TVA.PhasorProtocols.FNet ► ConnectionParameters
Represents the extra connection parameters required for a connection to a F-NET device.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConnectionParameters : ConnectionParametersBase
<SerializableAttribute> _
Public Class ConnectionParameters _
    Inherits ConnectionParametersBase
[SerializableAttribute]
public ref class ConnectionParameters : public ConnectionParametersBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConnectionParameters()()()() | Creates a new ConnectionParameters.
 | ConnectionParameters(SerializationInfo, StreamingContext) | Creates a new ConnectionParameters from serialization parameters.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FrameRate | Gets or sets the configured frame rate for the F-NET device.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConnectionParametersBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets or sets the nominal LineFrequency of this F-NET device.
 | StationName | Gets or sets the station name for the F-NET device.
 | TimeOffset | Gets or sets time offset of the F-NET device in Ticks.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValuesAreValid | Determines if custom connection parameters are valid. (Inherited from ConnectionParametersBase.)
Remarks
This class is designed to be exposed by a "PropertyGrid" so a UI can request protocol specific connection parameters. As a result the CategoryAttribute and DescriptionAttribute elements should be defined for each of the exposed properties.
Inheritance Hierarchy
Object
 | ConnectionParametersBase
 |  | ConnectionParameters


ConnectionParameters Constructor

ConnectionParameters Constructor
Namespaces ► TVA.PhasorProtocols.FNet ► ConnectionParameters ► ConnectionParameters()()()()
Members
Icon | Member | Description
 | ConnectionParameters()()()() | Creates a new ConnectionParameters.
 | ConnectionParameters(SerializationInfo, StreamingContext) | Creates a new ConnectionParameters from serialization parameters.


ConnectionParameters Constructor

ConnectionParameters Constructor
Namespaces ► TVA.PhasorProtocols.FNet ► ConnectionParameters ► ConnectionParameters()()()()
Creates a new ConnectionParameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConnectionParameters()
Public Sub New
public:
ConnectionParameters()


ConnectionParameters Constructor (info, context)

ConnectionParameters Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.FNet ► ConnectionParameters ► ConnectionParameters(SerializationInfo, StreamingContext)
Creates a new ConnectionParameters from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConnectionParameters(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConnectionParameters(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrameRate Property

FrameRate Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConnectionParameters ► FrameRate
Gets or sets the configured frame rate for the F-NET device.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute()]
public ushort FrameRate { get; set; }
<DefaultValueAttribute()> _
Public Property FrameRate As UShort
    Get
    Set
[DefaultValueAttribute()]
public:
property unsigned short FrameRate {
    unsigned short get ();
    void set (unsigned short value);
}
Remarks
This is typically set to 10 frames per second.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.FNet ► ConnectionParameters ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


NominalFrequency Property

NominalFrequency Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConnectionParameters ► NominalFrequency
Gets or sets the nominal LineFrequency of this F-NET device.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(typeof(LineFrequency), "Hz60")]
public LineFrequency NominalFrequency { get; set; }
<DefaultValueAttribute(GetType(LineFrequency), "Hz60")> _
Public Property NominalFrequency As LineFrequency
    Get
    Set
[DefaultValueAttribute(typeof(LineFrequency), L"Hz60")]
public:
property LineFrequency NominalFrequency {
    LineFrequency get ();
    void set (LineFrequency value);
}


StationName Property

StationName Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConnectionParameters ► StationName
Gets or sets the station name for the F-NET device.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute("F-NET Unit")]
public string StationName { get; set; }
<DefaultValueAttribute("F-NET Unit")> _
Public Property StationName As String
    Get
    Set
[DefaultValueAttribute(L"F-NET Unit")]
public:
property String^ StationName {
    String^ get ();
    void set (String^ value);
}


TimeOffset Property

TimeOffset Property
Namespaces ► TVA.PhasorProtocols.FNet ► ConnectionParameters ► TimeOffset
Gets or sets time offset of the F-NET device in Ticks.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute()]
public long TimeOffset { get; set; }
<DefaultValueAttribute()> _
Public Property TimeOffset As Long
    Get
    Set
[DefaultValueAttribute()]
public:
property long long TimeOffset {
    long long get ();
    void set (long long value);
}
Remarks
F-NET devices normally report time in 11 seconds past real-time, this property defines the offset for this this artificial delay. Note that the parameter value is in ticks to allow a very high-resolution offset; 1 second = 10,000,000 ticks.


DataCell Class

DataCell Class
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell
Represents the F-NET implementation of a IDataCell that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataCell : DataCellBase
<SerializableAttribute> _
Public Class DataCell _
    Inherits DataCellBase
[SerializableAttribute]
public ref class DataCell : public DataCellBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
 | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
 | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
 | AnalogValue | Gets or sets analog value for F-NET data row.
 | AnalogValues | Gets AnalogValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataCell object. (Overrides DataCellBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the DataCell object. (Overrides DataCellBase.BodyImage.)
 | BodyLength | Gets the length of the BodyImage. (Overrides DataCellBase.BodyLength.)
 | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
 | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
 | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBase.DataIsValid.)
 | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBase.DataSortingType.)
 | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBase.DeviceError.)
 | DigitalValues | Gets DigitalValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
 | Equals(Object) | Determines whether the specified object is equal to the DataCellBase. (Inherited from DataCellBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FNetDataRow | Gets image of this DataCell as a F-NET formatted data row.
 | FNetDate | Gets date in F-NET format.
 | FNetTime | Gets time in F-NET format.
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
 | GetHashCode()()()() | Serves as a hash function for the DataCellBase. (Inherited from DataCellBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataCellBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets the numeric ID code for this DataCellBase. (Inherited from DataCellBase.)
 | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides DataCellBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
 | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
 | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
 | StatusFlags | Gets or sets 16-bit status flags of this DataCellBase. (Inherited from DataCellBase.)
 | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBase.SynchronizationIsValid.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this DataCellBase. (Inherited from DataCellBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | DataCellBase
 |  |  |  |  | DataCell


DataCell Constructor

DataCell Constructor
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► DataCell()()()()
Members
Icon | Member | Description
 | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
 | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.


DataCell Constructor (info, context)

DataCell Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► DataCell(SerializationInfo, StreamingContext)
Creates a new DataCell from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataCell(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DataCell Constructor (parent, configurationCell)

DataCell Constructor (parent, configurationCell)
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► DataCell(IDataFrame, IConfigurationCell)
Creates a new DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell(
    IDataFrame parent,
    IConfigurationCell configurationCell
)
Public Sub New ( _
    parent As IDataFrame, _
    configurationCell As IConfigurationCell _
)
public:
DataCell(
    IDataFrame^ parent,
    IConfigurationCell^ configurationCell
)
Parameters
parent (IDataFrame)
The reference to parent IDataFrame of this DataCell.
configurationCell (IConfigurationCell)
The IConfigurationCell associated with this DataCell.


AnalogValue Property

AnalogValue Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► AnalogValue
Gets or sets analog value for F-NET data row.
Declaration Syntax
C# Visual Basic Visual C++
public double AnalogValue { get; set; }
Public Property AnalogValue As Double
    Get
    Set
public:
property double AnalogValue {
    double get ();
    void set (double value);
}


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataCell object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► BodyImage
Gets the binary body image of the DataCell object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}


ConfigurationCell Property

ConfigurationCell Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► ConfigurationCell
Gets or sets the ConfigurationCell associated with this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell ConfigurationCell { get; set; }
Public Property ConfigurationCell As ConfigurationCell
    Get
    Set
public:
property ConfigurationCell^ ConfigurationCell {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


DataIsValid Property

DataIsValid Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► DataIsValid
Gets or sets flag that determines if data of this DataCell is valid.
Declaration Syntax
C# Visual Basic Visual C++
public override bool DataIsValid { get; set; }
Public Overrides Property DataIsValid As Boolean
    Get
    Set
public:
virtual property bool DataIsValid {
    bool get () override;
    void set (bool value) override;
}


DataSortingType Property

DataSortingType Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► DataSortingType
Gets or sets DataSortingType of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataSortingType DataSortingType { get; set; }
Public Overrides Property DataSortingType As DataSortingType
    Get
    Set
public:
virtual property DataSortingType DataSortingType {
    DataSortingType get () override;
    void set (DataSortingType value) override;
}


DeviceError Property

DeviceError Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► DeviceError
Gets or sets flag that determines if source device of this DataCell is reporting an error.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override bool DeviceError { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides Property DeviceError As Boolean
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property bool DeviceError {
    bool get () override;
    void set (bool value) override;
}
Remarks
F-NET doesn't define any flags for device errors.


FNetDataRow Property

FNetDataRow Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► FNetDataRow
Gets image of this DataCell as a F-NET formatted data row.
Declaration Syntax
C# Visual Basic Visual C++
public string FNetDataRow { get; }
Public ReadOnly Property FNetDataRow As String
    Get
public:
property String^ FNetDataRow {
    String^ get ();
}


FNetDate Property

FNetDate Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► FNetDate
Gets date in F-NET format.
Declaration Syntax
C# Visual Basic Visual C++
public string FNetDate { get; }
Public ReadOnly Property FNetDate As String
    Get
public:
property String^ FNetDate {
    String^ get ();
}


FNetTime Property

FNetTime Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► FNetTime
Gets time in F-NET format.
Declaration Syntax
C# Visual Basic Visual C++
public string FNetTime { get; }
Public ReadOnly Property FNetTime As String
    Get
public:
property String^ FNetTime {
    String^ get ();
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► Parent
Gets or sets the reference to parent DataFrame of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public DataFrame Parent { get; set; }
Public Property Parent As DataFrame
    Get
    Set
public:
property DataFrame^ Parent {
    DataFrame^ get ();
    void set (DataFrame^ value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
The longitude, latitude and number of satellites arrive at the top of minute in F-NET data as the analog data in a siggle row, each on their own row, as sample 1, 2, and 3 respectively.


SynchronizationIsValid Property

SynchronizationIsValid Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataCell ► SynchronizationIsValid
Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock.
Declaration Syntax
C# Visual Basic Visual C++
public override bool SynchronizationIsValid { get; set; }
Public Overrides Property SynchronizationIsValid As Boolean
    Get
    Set
public:
virtual property bool SynchronizationIsValid {
    bool get () override;
    void set (bool value) override;
}
Remarks
F-NET defines synchronization validity as a derived value based on the number of available satellites, i.e., synchronization is valid if number of visible sattellites is greater than zero.


DataCellCollection Class

DataCellCollection Class
Namespaces ► TVA.PhasorProtocols.FNet ► DataCellCollection
Represents a F-NET implementation of a collection of IDataCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataCellCollection : DataCellCollection
<SerializableAttribute> _
Public Class DataCellCollection _
    Inherits DataCellCollection
[SerializableAttribute]
public ref class DataCellCollection : public DataCellCollection
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCellCollection()()()() | Creates a new DataCellCollection.
 | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets DataCell at specified index.
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IDataCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' IDataCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' IDataCell >)>)>
 |  |  |  | DataCellCollection
 |  |  |  |  | DataCellCollection


DataCellCollection Constructor

DataCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.FNet ► DataCellCollection ► DataCellCollection()()()()
Members
Icon | Member | Description
 | DataCellCollection()()()() | Creates a new DataCellCollection.
 | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.


DataCellCollection Constructor

DataCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.FNet ► DataCellCollection ► DataCellCollection()()()()
Creates a new DataCellCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DataCellCollection()
Public Sub New
public:
DataCellCollection()


DataCellCollection Constructor (info, context)

DataCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.FNet ► DataCellCollection ► DataCellCollection(SerializationInfo, StreamingContext)
Creates a new DataCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


Item Property (index)

Item Property (index)
Namespaces ► TVA.PhasorProtocols.FNet ► DataCellCollection ► Item[([( Int32])])
Gets or sets DataCell at specified index.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DataCell
    Get
    Set
public:
property DataCell^ default[int index] {
    DataCell^ get (int index);
    void set (int index, DataCell^ value);
}
Parameters
index (Int32)
Index of value to get or set.


DataFrame Class

DataFrame Class
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame
Represents the F-NET implementation of a IDataFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataFrame : DataFrameBase, ISupportFrameImage<int>,
    ISupportBinaryImage
<SerializableAttribute> _
Public Class DataFrame _
    Inherits DataFrameBase _
    Implements ISupportFrameImage(Of Integer), ISupportBinaryImage
[SerializableAttribute]
public ref class DataFrame : public DataFrameBase,
    ISupportFrameImage<int>, ISupportBinaryImage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataFrame()()()() | Creates a new DataFrame.
 | DataFrame(Ticks, ConfigurationFrame, Int16) | Creates a new DataFrame from specified parameters.
 | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataFrame object. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Method is not implemented. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the DataCellCollection for this DataFrame.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.ChecksumIsValid(array<Byte>[]()[][], Int32).)
 | CommonHeader | Gets or sets current CommonFrameHeader.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets the numeric ID code for this DataFrameBase. (Inherited from DataFrameBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Overrides DataFrameBase.Initialize(array<Byte>[]()[][], Int32, Int32).)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SampleIndex | Gets or sets the sample index of this DataFrame.
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets the identifier that is used to identify the F-NET frame.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IDataCell >)>)>
 |  |  |  | DataFrameBase
 |  |  |  |  | DataFrame


DataFrame Constructor

DataFrame Constructor
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame ► DataFrame()()()()
Members
Icon | Member | Description
 | DataFrame()()()() | Creates a new DataFrame.
 | DataFrame(Ticks, ConfigurationFrame, Int16) | Creates a new DataFrame from specified parameters.
 | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.


DataFrame Constructor

DataFrame Constructor
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame ► DataFrame()()()()
Creates a new DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public DataFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Sub New
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
DataFrame()
Remarks
This constructor is used by FrameImageParserBase to parse an F-NET data frame.


DataFrame Constructor (info, context)

DataFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame ► DataFrame(SerializationInfo, StreamingContext)
Creates a new DataFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DataFrame Constructor (timestamp, configurationFrame, sampleIndex)

DataFrame Constructor (timestamp, configurationFrame, sampleIndex)
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame ► DataFrame(Ticks, ConfigurationFrame, Int16)
Creates a new DataFrame from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DataFrame(
    Ticks timestamp,
    ConfigurationFrame configurationFrame,
    short sampleIndex
)
Public Sub New ( _
    timestamp As Ticks, _
    configurationFrame As ConfigurationFrame, _
    sampleIndex As Short _
)
public:
DataFrame(
    Ticks timestamp,
    ConfigurationFrame^ configurationFrame,
    short sampleIndex
)
Parameters
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this DataFrame.
configurationFrame (ConfigurationFrame)
The ConfigurationFrame associated with this DataFrame.
sampleIndex (Int16)
The sample index of this DataFrame.
Remarks
This constructor is used by a consumer to generate a F-NET data frame.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataFrame object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Method is not implemented.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Array of Bytes.
offset (Int32)
An Int32 value for offset to read from.
length (Int32)
An Int32 value for the bytes to read.
Return Value
An UInt16 as the checksum.
Exceptions
Exception | Condition
NotImplementedException | F-NET doesn't use checksums.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame ► Cells
Gets reference to the DataCellCollection for this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public DataCellCollection Cells { get; }
Public ReadOnly Property Cells As DataCellCollection
    Get
public:
property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}


ChecksumIsValid Method (buffer, startIndex)

ChecksumIsValid Method (buffer, startIndex)
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame ► ChecksumIsValid(array<Byte>[]()[][], Int32)
Determines if checksum in the buffer is valid.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid ( _
    buffer As Byte(), _
    startIndex As Integer _
) As Boolean
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image to validate.
startIndex (Int32)
Start index into buffer to perform checksum.
Return Value
Flag that determines if checksum over buffer is valid.
Remarks
F-NET doesn't use checksums - this always returns true.


CommonHeader Property

CommonHeader Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame ► CommonHeader
Gets or sets current CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame ► ConfigurationFrame
Gets or sets ConfigurationFrame associated with this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame ConfigurationFrame { get; set; }
Public Property ConfigurationFrame As ConfigurationFrame
    Get
    Set
public:
property ConfigurationFrame^ ConfigurationFrame {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


Initialize Method (binaryImage, startIndex, length)

Initialize Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame ► Initialize(array<Byte>[]()[][], Int32, Int32)
Parses the binary image.
Declaration Syntax
C# Visual Basic Visual C++
public override int Initialize(
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Overrides Function Initialize ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
public:
virtual int Initialize(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
This method is overriden to compensate for lack of CRC in F-NET frame.


SampleIndex Property

SampleIndex Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame ► SampleIndex
Gets or sets the sample index of this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public short SampleIndex { get; set; }
Public Property SampleIndex As Short
    Get
    Set
public:
property short SampleIndex {
    short get ();
    void set (short value);
}


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame ► TypeID
Gets the identifier that is used to identify the F-NET frame.
Declaration Syntax
C# Visual Basic Visual C++
public int TypeID { get; }
Public ReadOnly Property TypeID As Integer
    Get
public:
virtual property int TypeID {
    int get () sealed;
}


FrameParser Class

FrameParser Class
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser
Represents a frame parser for a F-NET text based data stream that returns parsed data via events.
Declaration Syntax
C# Visual Basic Visual C++
public class FrameParser : FrameParserBase<int>
Public Class FrameParser _
    Inherits FrameParserBase(Of Integer)
public ref class FrameParser : public FrameParserBase<int>
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrameParser()()()() | Creates a new FrameParser.
 | FrameParser(UInt16, LineFrequency, Ticks, String) | Creates a new FrameParser from specified parameters.
 | BeginRead(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead()()()() | (Inherited from BinaryImageParserBase.)
 | CanSeek()()()() | (Inherited from BinaryImageParserBase.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite()()()() | (Inherited from BinaryImageParserBase.)
 | Close()()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBase <(Of <(<' Int32 >)>)>.ConfigurationFrame.)
 | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Overrides FrameParserBase <(Of <(<' Int32 >)>)>.ConnectionParameters.)
 | CreateBufferQueue()()()() | Creates the internal buffer queue. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | DataDiscarded()()()() | (Inherited from BinaryImageParserBase.)
 | DataParsed()()()() | (Inherited from FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBase<(Of <(<'TFrameIdentifier>)>)> object and optionally releases the managed resources. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | DuplicateTypeHandlerEncountered()()()() | (Inherited from FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.)
 | Enabled()()()() | (Inherited from BinaryImageParserBase.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteParseOnSeparateThread | Gets or sets a flag that allows frame parsing to be executed on a separate thread (i.e., other than communications thread). (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()()() | Clears all buffers for this stream and causes any buffered data to be parsed immediately. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | FrameRate | Gets or sets the configured frame rate for the F-NET device.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length()()()() | (Inherited from BinaryImageParserBase.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()()()() | (Inherited from BinaryImageParserBase.)
 | NominalFrequency | Gets or sets the nominal LineFrequency of the F-NET device.
 | OnConfigurationChanged()()()() | Raises the ConfigurationChanged event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnDataDiscarded(array<Byte>[]()[][]) | (Inherited from BinaryImageParserBase.)
 | OnDataParsed(UTP) | (Inherited from FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.)
 | OnDuplicateTypeHandlerEncountered(Type, UTP) | (Inherited from FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.)
 | OnOutputTypeNotFound(UTP) | (Inherited from FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.)
 | OnParsingException(Exception) | (Inherited from BinaryImageParserBase.)
 | OnReceivedChannelFrame(IChannelFrame) | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame). (Overrides FrameParserBase <(Of <(<' Int32 >)>)>.OnReceivedChannelFrame(IChannelFrame).)
 | OnReceivedCommandFrame(ICommandFrame) | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedConfigurationFrame(IConfigurationFrame) | Raises the ReceivedConfigurationFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedDataFrame(IDataFrame) | Raises the ReceivedDataFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedFrameBufferImage(FundamentalFrameType, array<Byte>[]()[][], Int32, Int32) | Raises the ReceivedFrameBufferImage event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedHeaderFrame(IHeaderFrame) | Raises the ReceivedHeaderFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedUndeterminedFrame(IChannelFrame) | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnUnknownFrameTypeEncountered(TFrameIdentifier) | Handles unknown frame types. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OutputTypeNotFound()()()() | (Inherited from FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.)
 | Parse(ISupportBinaryImage) | (Inherited from BinaryImageParserBase.)
 | ParseCommonHeader(array<Byte>[]()[][], Int32, Int32) | Parses a common header instance that implements ICommonHeader for the output type represented in the binary image. (Overrides FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.ParseCommonHeader(array<Byte>[]()[][], Int32, Int32).)
 | ParseFrame(array<Byte>[]()[][], Int32, Int32) | (Inherited from FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.)
 | ParseQueuedBuffers(array<array<Byte>[]()[][]>[]()[][]) | This method is used by the internal ProcessQueue to process all queued data buffers. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ParsingException()()()() | (Inherited from BinaryImageParserBase.)
 | Position()()()() | (Inherited from BinaryImageParserBase.)
 | ProtocolSyncBytes()()()() | (Inherited from BinaryImageParserBase.)
 | ProtocolUsesSyncBytes | Gets flag that determines if F-NET protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBase.ProtocolUsesSyncBytes()()()().)
 | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Read(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageParserBase.)
 | ReadByte()()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | ReceivedCommandFrame | Occurs when a ICommandFrame has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ReceivedConfigurationFrame | Occurs when a F-NET ConfigurationFrame has been received.
 | ReceivedDataFrame | Occurs when a F-NET DataFrame has been received.
 | ReceivedFrameBufferImage | Occurs when a frame buffer image has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | RunTime()()()() | (Inherited from BinaryImageParserBase.)
 | Seek(Int64, SeekOrigin) | (Inherited from BinaryImageParserBase.)
 | SetLength(Int64) | (Inherited from BinaryImageParserBase.)
 | Start()()()() | Start the data parser. (Overrides FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.Start()()()().)
 | Start(IEnumerable<(Of <<'(Type>)>>)) | Starts the frame parser given the specified type implementations. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | StationName | Gets or sets the station name for the F-NET device.
 | Status | Gets current descriptive status of the FrameParser. (Overrides FrameParserBase <(Of <(<' Int32 >)>)>.Status.)
 | Stop()()()() | Stops the frame parser. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | StreamInitialized()()()() | (Inherited from BinaryImageParserBase.)
 | TimeOffset | Gets or sets time offset of F-NET device in Ticks.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalProcessedBuffers()()()() | (Inherited from BinaryImageParserBase.)
 | UnparsedBuffer()()()() | (Inherited from BinaryImageParserBase.)
 | Write(array<Byte>[]()[][], Int32, Int32) | Writes a sequence of bytes onto the stream for parsing. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks
Frame parser is implemented as a write-only stream - this way data can come from any source.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | BinaryImageParserBase
 |  |  |  | FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>
 |  |  |  |  | FrameParserBase <(Of <(<' Int32 >)>)>
 |  |  |  |  |  | FrameParser


FrameParser Constructor

FrameParser Constructor
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► FrameParser()()()()
Members
Icon | Member | Description
 | FrameParser()()()() | Creates a new FrameParser.
 | FrameParser(UInt16, LineFrequency, Ticks, String) | Creates a new FrameParser from specified parameters.


FrameParser Constructor

FrameParser Constructor
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► FrameParser()()()()
Creates a new FrameParser.
Declaration Syntax
C# Visual Basic Visual C++
public FrameParser()
Public Sub New
public:
FrameParser()


FrameParser Constructor (frameRate, nominalFrequency, timeOffset, stationName)

FrameParser Constructor (frameRate, nominalFrequency, timeOffset, stationName)
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► FrameParser(UInt16, LineFrequency, Ticks, String)
Creates a new FrameParser from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrameParser(
    ushort frameRate,
    LineFrequency nominalFrequency,
    Ticks timeOffset,
    string stationName
)
Public Sub New ( _
    frameRate As UShort, _
    nominalFrequency As LineFrequency, _
    timeOffset As Ticks, _
    stationName As String _
)
public:
FrameParser(
    unsigned short frameRate,
    LineFrequency nominalFrequency,
    Ticks timeOffset,
    String^ stationName
)
Parameters
frameRate (UInt16)
The defined frame rate of this ConfigurationFrame.
nominalFrequency (LineFrequency)
The nominal LineFrequency of this ConfigurationFrame.
timeOffset (Ticks)
The time offset of F-NET device in Ticks.
stationName (String)
The station name of the F-NET device.


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► ConfigurationFrame
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
Declaration Syntax
C# Visual Basic Visual C++
public override IConfigurationFrame ConfigurationFrame { get; set; }
Public Overrides Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () override;
    void set (IConfigurationFrame^ value) override;
}
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.


ConnectionParameters Property

ConnectionParameters Property
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► ConnectionParameters
Gets or sets any connection specific IConnectionParameters that may be needed for parsing.
Declaration Syntax
C# Visual Basic Visual C++
public override IConnectionParameters ConnectionParameters { get; set; }
Public Overrides Property ConnectionParameters As IConnectionParameters
    Get
    Set
public:
virtual property IConnectionParameters^ ConnectionParameters {
    IConnectionParameters^ get () override;
    void set (IConnectionParameters^ value) override;
}


FrameRate Property

FrameRate Property
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► FrameRate
Gets or sets the configured frame rate for the F-NET device.
Declaration Syntax
C# Visual Basic Visual C++
public ushort FrameRate { get; set; }
Public Property FrameRate As UShort
    Get
    Set
public:
property unsigned short FrameRate {
    unsigned short get ();
    void set (unsigned short value);
}
Remarks
This is typically set to 10 frames per second.


NominalFrequency Property

NominalFrequency Property
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► NominalFrequency
Gets or sets the nominal LineFrequency of the F-NET device.
Declaration Syntax
C# Visual Basic Visual C++
public LineFrequency NominalFrequency { get; set; }
Public Property NominalFrequency As LineFrequency
    Get
    Set
public:
property LineFrequency NominalFrequency {
    LineFrequency get ();
    void set (LineFrequency value);
}


OnReceivedChannelFrame Method (frame)

OnReceivedChannelFrame Method (frame)
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► OnReceivedChannelFrame(IChannelFrame)
Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame).
Declaration Syntax
C# Visual Basic Visual C++
protected override void OnReceivedChannelFrame(
    IChannelFrame frame
)
Protected Overrides Sub OnReceivedChannelFrame ( _
    frame As IChannelFrame _
)
protected:
virtual void OnReceivedChannelFrame(
    IChannelFrame^ frame
) override
Parameters
frame (IChannelFrame)
IChannelFrame that was parsed by FrameImageParserBase that implements protocol specific common frame header interface.


ParseCommonHeader Method (buffer, offset, length)

ParseCommonHeader Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► ParseCommonHeader(array<Byte>[]()[][], Int32, Int32)
Parses a common header instance that implements ICommonHeader for the output type represented in the binary image.
Declaration Syntax
C# Visual Basic Visual C++
protected override ICommonHeader<int> ParseCommonHeader(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function ParseCommonHeader ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As ICommonHeader(Of Integer)
protected:
virtual ICommonHeader<int>^ ParseCommonHeader(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer containing data to parse.
offset (Int32)
Offset index into buffer that represents where to start parsing.
length (Int32)
Maximum length of valid data from offset.
Return Value
The ICommonHeader which includes a type ID for the Type to be parsed.
Remarks

Derived classes need to provide a common header instance (i.e., class that implements ICommonHeader) for the output types; this will primarily include an ID of the Type that the data image represents. This parsing is only for common header information, actual parsing will be handled by output type via its Initialize(array<Byte>[]()[][], Int32, Int32) method. This header image should also be used to add needed complex state information about the output type being parsed if needed.

If there is not enough buffer available to parse common header (as determined by length), return null. Also, if the protocol allows frame length to be determined at the time common header is being parsed and there is not enough buffer to parse the entire frame, it will be optimal to prevent further parsing by returning null.


ProtocolUsesSyncBytes Property

ProtocolUsesSyncBytes Property
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► ProtocolUsesSyncBytes
Gets flag that determines if F-NET protocol parsing implementation uses synchronization bytes.
Declaration Syntax
C# Visual Basic Visual C++
public override bool ProtocolUsesSyncBytes { get; }
Public Overrides ReadOnly Property ProtocolUsesSyncBytes As Boolean
    Get
public:
virtual property bool ProtocolUsesSyncBytes {
    bool get () override;
}


ReceivedConfigurationFrame Event

ReceivedConfigurationFrame Event
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► ReceivedConfigurationFrame
Occurs when a F-NET ConfigurationFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<ConfigurationFrame>> ReceivedConfigurationFrame
Public Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of ConfigurationFrame))
public:
 event EventHandler<EventArgs<ConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
}
Remarks
Argument()()()() is the ConfigurationFrame that was received.


ReceivedDataFrame Event

ReceivedDataFrame Event
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► ReceivedDataFrame
Occurs when a F-NET DataFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<DataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of DataFrame))
public:
 event EventHandler<EventArgs<DataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<DataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<DataFrame^>^>^ value);
}
Remarks
Argument()()()() is the DataFrame that was received.


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► Start()()()()
Start the data parser.
Declaration Syntax
C# Visual Basic Visual C++
public override void Start()
Public Overrides Sub Start
public:
virtual void Start() override


StationName Property

StationName Property
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► StationName
Gets or sets the station name for the F-NET device.
Declaration Syntax
C# Visual Basic Visual C++
public string StationName { get; set; }
Public Property StationName As String
    Get
    Set
public:
property String^ StationName {
    String^ get ();
    void set (String^ value);
}


Status Property

Status Property
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► Status
Gets current descriptive status of the FrameParser.
Declaration Syntax
C# Visual Basic Visual C++
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
public:
virtual property String^ Status {
    String^ get () override;
}


TimeOffset Property

TimeOffset Property
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► TimeOffset
Gets or sets time offset of F-NET device in Ticks.
Declaration Syntax
C# Visual Basic Visual C++
public Ticks TimeOffset { get; set; }
Public Property TimeOffset As Ticks
    Get
    Set
public:
property Ticks TimeOffset {
    Ticks get ();
    void set (Ticks value);
}
Remarks
F-NET devices normally report time in 11 seconds past real-time, this property defines the offset for this this artificial delay. Note that the parameter value is in ticks to allow a very high-resolution offset; 1 second = 10000000 ticks.


FrequencyDefinition Class

FrequencyDefinition Class
Namespaces ► TVA.PhasorProtocols.FNet ► FrequencyDefinition
Represents the F-NET implementation of a IFrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FrequencyDefinition : FrequencyDefinitionBase
<SerializableAttribute> _
Public Class FrequencyDefinition _
    Inherits FrequencyDefinitionBase
[SerializableAttribute]
public ref class FrequencyDefinition : public FrequencyDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
 | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
 | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | FrequencyDefinitionBase
 |  |  |  |  | FrequencyDefinition


FrequencyDefinition Constructor

FrequencyDefinition Constructor
Namespaces ► TVA.PhasorProtocols.FNet ► FrequencyDefinition ► FrequencyDefinition()()()()
Members
Icon | Member | Description
 | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
 | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
 | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.


FrequencyDefinition Constructor (info, context)

FrequencyDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.FNet ► FrequencyDefinition ► FrequencyDefinition(SerializationInfo, StreamingContext)
Creates a new FrequencyDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrequencyDefinition Constructor (parent, label)

FrequencyDefinition Constructor (parent, label)
Namespaces ► TVA.PhasorProtocols.FNet ► FrequencyDefinition ► FrequencyDefinition(ConfigurationCell, String)
Creates a new FrequencyDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String _
)
public:
FrequencyDefinition(
    ConfigurationCell^ parent,
    String^ label
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this FrequencyDefinition.
label (String)
The label of this FrequencyDefinition.


FrequencyDefinition Constructor (parent)

FrequencyDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.FNet ► FrequencyDefinition ► FrequencyDefinition(IConfigurationCell)
Creates a new FrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
FrequencyDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this FrequencyDefinition.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.FNet ► FrequencyDefinition ► Parent
Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


FrequencyValue Class

FrequencyValue Class
Namespaces ► TVA.PhasorProtocols.FNet ► FrequencyValue
Represents the F-NET implementation of a IFrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FrequencyValue : FrequencyValueBase
<SerializableAttribute> _
Public Class FrequencyValue _
    Inherits FrequencyValueBase
[SerializableAttribute]
public ref class FrequencyValue : public FrequencyValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
 | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
 | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from FrequencyValueBase.)
 | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
 | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this FrequencyValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from FrequencyValueBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
 | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IFrequencyDefinition >)>)>
 |  |  |  | FrequencyValueBase
 |  |  |  |  | FrequencyValue


FrequencyValue Constructor

FrequencyValue Constructor
Namespaces ► TVA.PhasorProtocols.FNet ► FrequencyValue ► FrequencyValue()()()()
Members
Icon | Member | Description
 | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
 | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
 | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.


FrequencyValue Constructor (info, context)

FrequencyValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.FNet ► FrequencyValue ► FrequencyValue(SerializationInfo, StreamingContext)
Creates a new FrequencyValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrequencyValue Constructor (parent, frequencyDefinition, frequency, dfdt)

FrequencyValue Constructor (parent, frequencyDefinition, frequency, dfdt)
Namespaces ► TVA.PhasorProtocols.FNet ► FrequencyValue ► FrequencyValue(DataCell, FrequencyDefinition, Double, Double)
Creates a new FrequencyValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyValue(
    DataCell parent,
    FrequencyDefinition frequencyDefinition,
    double frequency,
    double dfdt
)
Public Sub New ( _
    parent As DataCell, _
    frequencyDefinition As FrequencyDefinition, _
    frequency As Double, _
    dfdt As Double _
)
public:
FrequencyValue(
    DataCell^ parent,
    FrequencyDefinition^ frequencyDefinition,
    double frequency,
    double dfdt
)
Parameters
parent (DataCell)
The DataCell parent of this FrequencyValue.
frequencyDefinition (FrequencyDefinition)
The FrequencyDefinition associated with this FrequencyValue.
frequency (Double)
The floating point value that represents this FrequencyValue.
dfdt (Double)
The floating point value that represents the change in this FrequencyValue over time.


FrequencyValue Constructor (parent, frequencyDefinition)

FrequencyValue Constructor (parent, frequencyDefinition)
Namespaces ► TVA.PhasorProtocols.FNet ► FrequencyValue ► FrequencyValue(IDataCell, IFrequencyDefinition)
Creates a new FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyValue(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    frequencyDefinition As IFrequencyDefinition _
)
public:
FrequencyValue(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this FrequencyValue.
frequencyDefinition (IFrequencyDefinition)
The IFrequencyDefinition associated with this FrequencyValue.


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.FNet ► FrequencyValue ► Definition
Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual FrequencyDefinition Definition { get; set; }
Public Overridable Property Definition As FrequencyDefinition
    Get
    Set
public:
virtual property FrequencyDefinition^ Definition {
    FrequencyDefinition^ get ();
    void set (FrequencyDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.FNet ► FrequencyValue ► Parent
Gets or sets the DataCell parent of this FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


PhasorDefinition Class

PhasorDefinition Class
Namespaces ► TVA.PhasorProtocols.FNet ► PhasorDefinition
Represents the F-NET implementation of a IPhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PhasorDefinition : PhasorDefinitionBase
<SerializableAttribute> _
Public Class PhasorDefinition _
    Inherits PhasorDefinitionBase
[SerializableAttribute]
public ref class PhasorDefinition : public PhasorDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(ConfigurationCell, String, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | PhasorDefinitionBase
 |  |  |  |  | PhasorDefinition


PhasorDefinition Constructor

PhasorDefinition Constructor
Namespaces ► TVA.PhasorProtocols.FNet ► PhasorDefinition ► PhasorDefinition()()()()
Members
Icon | Member | Description
 | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(ConfigurationCell, String, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.


PhasorDefinition Constructor (info, context)

PhasorDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.FNet ► PhasorDefinition ► PhasorDefinition(SerializationInfo, StreamingContext)
Creates a new PhasorDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


PhasorDefinition Constructor (parent, label, type, voltageReference)

PhasorDefinition Constructor (parent, label, type, voltageReference)
Namespaces ► TVA.PhasorProtocols.FNet ► PhasorDefinition ► PhasorDefinition(ConfigurationCell, String, PhasorType, PhasorDefinition)
Creates a new PhasorDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinition(
    ConfigurationCell parent,
    string label,
    PhasorType type,
    PhasorDefinition voltageReference
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String, _
    type As PhasorType, _
    voltageReference As PhasorDefinition _
)
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    String^ label,
    PhasorType type,
    PhasorDefinition^ voltageReference
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this PhasorDefinition.
label (String)
The label of this PhasorDefinition.
type (PhasorType)
The PhasorType of this PhasorDefinition.
voltageReference (PhasorDefinition)
The associated IPhasorDefinition that represents the voltage reference (if any).


PhasorDefinition Constructor (parent)

PhasorDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.FNet ► PhasorDefinition ► PhasorDefinition(IConfigurationCell)
Creates a new PhasorDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
PhasorDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this PhasorDefinition.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.FNet ► PhasorDefinition ► Parent
Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


PhasorValue Class

PhasorValue Class
Namespaces ► TVA.PhasorProtocols.FNet ► PhasorValue
Represents the F-NET implementation of a IPhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PhasorValue : PhasorValueBase
<SerializableAttribute> _
Public Class PhasorValue _
    Inherits PhasorValueBase
[SerializableAttribute]
public ref class PhasorValue : public PhasorValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
 | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
 | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
 | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
 | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this PhasorValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from PhasorValueBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IPhasorDefinition >)>)>
 |  |  |  | PhasorValueBase
 |  |  |  |  | PhasorValue


PhasorValue Constructor

PhasorValue Constructor
Namespaces ► TVA.PhasorProtocols.FNet ► PhasorValue ► PhasorValue()()()()
Members
Icon | Member | Description
 | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
 | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.


PhasorValue Constructor (info, context)

PhasorValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.FNet ► PhasorValue ► PhasorValue(SerializationInfo, StreamingContext)
Creates a new PhasorValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


PhasorValue Constructor (parent, phasorDefinition, real, imaginary)

PhasorValue Constructor (parent, phasorDefinition, real, imaginary)
Namespaces ► TVA.PhasorProtocols.FNet ► PhasorValue ► PhasorValue(DataCell, PhasorDefinition, Double, Double)
Creates a new PhasorValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    double real,
    double imaginary
)
Public Sub New ( _
    parent As DataCell, _
    phasorDefinition As PhasorDefinition, _
    real As Double, _
    imaginary As Double _
)
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    double real,
    double imaginary
)
Parameters
parent (DataCell)
The DataCell parent of this PhasorValue.
phasorDefinition (PhasorDefinition)
The PhasorDefinition associated with this PhasorValue.
real (Double)
The real value of this PhasorValue.
imaginary (Double)
The imaginary value of this PhasorValue.


PhasorValue Constructor (parent, phasorDefinition, angle, magnitude)

PhasorValue Constructor (parent, phasorDefinition, angle, magnitude)
Namespaces ► TVA.PhasorProtocols.FNet ► PhasorValue ► PhasorValue(DataCell, PhasorDefinition, Angle, Double)
Creates a new PhasorValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    Angle angle,
    double magnitude
)
Public Sub New ( _
    parent As DataCell, _
    phasorDefinition As PhasorDefinition, _
    angle As Angle, _
    magnitude As Double _
)
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    Angle angle,
    double magnitude
)
Parameters
parent (DataCell)
The DataCell parent of this PhasorValue.
phasorDefinition (PhasorDefinition)
The PhasorDefinition associated with this PhasorValue.
angle (Angle)
The Angle value (a.k.a., the argument) of this PhasorValue, in radians.
magnitude (Double)
The magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue.


PhasorValue Constructor (parent, phasorDefinition)

PhasorValue Constructor (parent, phasorDefinition)
Namespaces ► TVA.PhasorProtocols.FNet ► PhasorValue ► PhasorValue(IDataCell, IPhasorDefinition)
Creates a new PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    IDataCell parent,
    IPhasorDefinition phasorDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    phasorDefinition As IPhasorDefinition _
)
public:
PhasorValue(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this PhasorValue.
phasorDefinition (IPhasorDefinition)
The IPhasorDefinition associated with this PhasorValue.


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.FNet ► PhasorValue ► Definition
Gets or sets the PhasorDefinition associated with this PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual PhasorDefinition Definition { get; set; }
Public Overridable Property Definition As PhasorDefinition
    Get
    Set
public:
virtual property PhasorDefinition^ Definition {
    PhasorDefinition^ get ();
    void set (PhasorDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.FNet ► PhasorValue ► Parent
Gets or sets the DataCell parent of this PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


TVA.PhasorProtocols.Ieee1344 Namespace

TVA.PhasorProtocols.Ieee1344 Namespace
Namespaces ► TVA.PhasorProtocols.Ieee1344
Contains an implementation of the phasor classes used to parse or generate a stream of data in the IEEE 1344-1995 standard format.
Declaration Syntax
C# Visual Basic Visual C++
namespace TVA.PhasorProtocols.Ieee1344
Namespace TVA.PhasorProtocols.Ieee1344
namespace TVA.PhasorProtocols.Ieee1344
Types
All Types Classes Enumerations
Icon | Type | Description
 | CommandFrame | Represents the IEEE 1344 implementation of a ICommandFrame that can be sent or received.
 | Common | Common IEEE 1344 declarations and functions.
 | CommonFrameHeader | Represents the common header for all IEEE 1344 frames of data.
 | ConfigurationCell | Represents the IEEE 1344 implementation of a IConfigurationCell that can be sent or received.
 | ConfigurationCellCollection | Represents a IEEE 1344 implementation of a collection of IConfigurationCell objects.
 | ConfigurationFrame | Represents the IEEE 1344 implementation of a IConfigurationFrame that can be sent or received.
 | DataCell | Represents the IEEE 1344 implementation of a IDataCell that can be sent or received.
 | DataCellCollection | Represents a IEEE 1344 implementation of a collection of IDataCell objects.
 | DataFrame | Represents the IEEE 1344 implementation of a IDataFrame that can be sent or received.
 | DigitalDefinition | Represents the IEEE 1344 implementation of a IDigitalDefinition.
 | DigitalValue | Represents the IEEE 1344 implementation of a IDigitalValue.
 | FrameImageCollector | Collects frame images until a full IEEE 1344 frame has been received.
 | FrameParser | Represents a frame parser for an IEEE 1344 binary data stream that returns parsed data via events.
 | FrameType | IEEE 1344 frame types enumeration.
 | FrequencyDefinition | Represents the IEEE 1344 implementation of a IFrequencyDefinition.
 | FrequencyValue | Represents the IEEE 1344 implementation of a IFrequencyValue.
 | HeaderFrame | Represents the IEEE 1344 implementation of a IHeaderFrame that can be sent or received.
 | PhasorDefinition | Represents the IEEE 1344 implementation of a IPhasorDefinition.
 | PhasorValue | Represents the IEEE 1344 implementation of a IPhasorValue.
 | TriggerStatus | IEEE 1344 trigger status enumeration.


CommandFrame Class

CommandFrame Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame
Represents the IEEE 1344 implementation of a ICommandFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CommandFrame : CommandFrameBase
<SerializableAttribute> _
Public Class CommandFrame _
    Inherits CommandFrameBase
[SerializableAttribute]
public ref class CommandFrame : public CommandFrameBase
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandFrame(array<Byte>[]()[][], Int32, Int32) | Creates a new CommandFrame from the given binaryImage.
 | CommandFrame(UInt64, DeviceCommand) | Creates a new CommandFrame from specified parameters.
 | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the CommandFrame object. (Overrides CommandFrameBase.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this CommandFrameBase. (Inherited from CommandFrameBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from CommandFrameBase.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' ICommandCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the CommandCellCollection for this CommandFrame. (Overrides CommandFrameBase.Cells.)
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Command | Gets or sets the DeviceCommand for this CommandFrameBase. (Inherited from CommandFrameBase.)
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ExtendedData | Gets or sets extended binary image data for this CommandFrame. (Overrides CommandFrameBase.ExtendedData.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameLength | Total frame length of a IEEE 1344 CommandFrame.
 | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Inherited from CommandFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides CommandFrameBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the CommandFrame object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets or sets the ID code of this CommandFrame.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from CommandFrameBase.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides BinaryImageBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this CommandFrameBase. (Inherited from CommandFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | TimeTag | Gets NTP based time representation of the ticks of this CommandFrame.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
IEEE 1344 command frames are designed only to be sent to a device, not received from a device. As a result this frame does not implement ISupportFrameImage for automated frame parsing. This class exposes a constructor that accepts a binary image in order to manually parse a command frame.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' ICommandCell >)>)>
 |  |  |  | CommandFrameBase
 |  |  |  |  | CommandFrame


CommandFrame Constructor

CommandFrame Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► CommandFrame()()()()
Members
Icon | Member | Description
 | CommandFrame(array<Byte>[]()[][], Int32, Int32) | Creates a new CommandFrame from the given binaryImage.
 | CommandFrame(UInt64, DeviceCommand) | Creates a new CommandFrame from specified parameters.
 | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.


CommandFrame Constructor (binaryImage, startIndex, length)

CommandFrame Constructor (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► CommandFrame(array<Byte>[]()[][], Int32, Int32)
Creates a new CommandFrame from the given binaryImage.
Declaration Syntax
C# Visual Basic Visual C++
public CommandFrame(
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Sub New ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
)
public:
CommandFrame(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
)
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Remarks
This constructor is used by a consumer to parse a received IEEE 1344 command frame. Typically command frames are sent to a device. This constructor would used if this code was being used inside of a phasor measurement device.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | length must be at least 16.


CommandFrame Constructor (info, context)

CommandFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► CommandFrame(SerializationInfo, StreamingContext)
Creates a new CommandFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected CommandFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CommandFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


CommandFrame Constructor (idCode, command)

CommandFrame Constructor (idCode, command)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► CommandFrame(UInt64, DeviceCommand)
Creates a new CommandFrame from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public CommandFrame(
    ulong idCode,
    DeviceCommand command
)
Public Sub New ( _
    idCode As ULong, _
    command As DeviceCommand _
)
public:
CommandFrame(
    unsigned long long idCode,
    DeviceCommand command
)
Parameters
idCode (UInt64)
The ID code of this CommandFrame.
command (DeviceCommand)
The DeviceCommand for this CommandFrame.
Remarks
This constructor is used by a consumer to generate an IEEE 1344 command frame.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the CommandFrame object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► Cells
Gets reference to the CommandCellCollection for this CommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override CommandCellCollection Cells { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides ReadOnly Property Cells As CommandCellCollection
    Get
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property CommandCellCollection^ Cells {
    CommandCellCollection^ get () override;
}


ExtendedData Property

ExtendedData Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► ExtendedData
Gets or sets extended binary image data for this CommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override byte[] ExtendedData { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides Property ExtendedData As Byte()
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property array<unsigned char>^ ExtendedData {
    array<unsigned char>^ get () override;
    void set (array<unsigned char>^ value) override;
}


FrameLength Field

FrameLength Field
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► FrameLength
Total frame length of a IEEE 1344 CommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort FrameLength
Public Const FrameLength As UShort
public:
literal unsigned short FrameLength


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► HeaderImage
Gets the binary header image of the CommandFrame object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► IDCode
Gets or sets the ID code of this CommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ulong IDCode { get; set; }
Public Property IDCode As ULong
    Get
    Set
public:
property unsigned long long IDCode {
    unsigned long long get ();
    void set (unsigned long long value);
}


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


TimeTag Property

TimeTag Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► TimeTag
Gets NTP based time representation of the ticks of this CommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
public NtpTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As NtpTimeTag
    Get
public:
property NtpTimeTag^ TimeTag {
    NtpTimeTag^ get ();
}


Common Class

Common Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► Common
Common IEEE 1344 declarations and functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class Common
Public NotInheritable Class Common
public ref class Common abstract sealed
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FrameCountMask | Frame count mask (for multi-framed files) constant.
 | FrameLengthMask | Frame length mask constant.
 | FrameTypeMask | Frame type mask constant.
 | MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame constant.
 | MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
 | MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame constant.
 | MaximumFrameCount | Maximum frame count (for multi-framed files) constant.
 | MaximumFrameLength | Absolute maximum frame length constant.
 | MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame constant.
 | MaximumSampleCount | Absolute maximum number of samples constant.
 | TriggerMask | Trigger mask constant.
Inheritance Hierarchy
Object
Common


FrameCountMask Field

FrameCountMask Field
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► Common ► FrameCountMask
Frame count mask (for multi-framed files) constant.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort FrameCountMask
Public Const FrameCountMask As UShort
public:
literal unsigned short FrameCountMask


FrameLengthMask Field

FrameLengthMask Field
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► Common ► FrameLengthMask
Frame length mask constant.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort FrameLengthMask
Public Const FrameLengthMask As UShort
public:
literal unsigned short FrameLengthMask


FrameTypeMask Field

FrameTypeMask Field
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► Common ► FrameTypeMask
Frame type mask constant.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort FrameTypeMask
Public Const FrameTypeMask As UShort
public:
literal unsigned short FrameTypeMask


MaximumAnalogValues Field

MaximumAnalogValues Field
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► Common ► MaximumAnalogValues
Absolute maximum number of possible analog values that could fit into a data frame constant.
Declaration Syntax
C# Visual Basic Visual C++
public const int MaximumAnalogValues
Public Const MaximumAnalogValues As Integer
public:
literal int MaximumAnalogValues
Remarks
IEEE 1344 doesn't support analog values


MaximumDataLength Field

MaximumDataLength Field
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► Common ► MaximumDataLength
Absolute maximum data length (in bytes) that could fit into any frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumDataLength
Public Const MaximumDataLength As UShort
public:
literal unsigned short MaximumDataLength


MaximumDigitalValues Field

MaximumDigitalValues Field
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► Common ► MaximumDigitalValues
Absolute maximum number of possible digital values that could fit into a data frame constant.
Declaration Syntax
C# Visual Basic Visual C++
public const int MaximumDigitalValues
Public Const MaximumDigitalValues As Integer
public:
literal int MaximumDigitalValues


MaximumFrameCount Field

MaximumFrameCount Field
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► Common ► MaximumFrameCount
Maximum frame count (for multi-framed files) constant.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumFrameCount
Public Const MaximumFrameCount As UShort
public:
literal unsigned short MaximumFrameCount


MaximumFrameLength Field

MaximumFrameLength Field
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► Common ► MaximumFrameLength
Absolute maximum frame length constant.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumFrameLength
Public Const MaximumFrameLength As UShort
public:
literal unsigned short MaximumFrameLength


MaximumPhasorValues Field

MaximumPhasorValues Field
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► Common ► MaximumPhasorValues
Absolute maximum number of possible phasor values that could fit into a data frame constant.
Declaration Syntax
C# Visual Basic Visual C++
public const int MaximumPhasorValues
Public Const MaximumPhasorValues As Integer
public:
literal int MaximumPhasorValues


MaximumSampleCount Field

MaximumSampleCount Field
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► Common ► MaximumSampleCount
Absolute maximum number of samples constant.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumSampleCount
Public Const MaximumSampleCount As UShort
public:
literal unsigned short MaximumSampleCount


TriggerMask Field

TriggerMask Field
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► Common ► TriggerMask
Trigger mask constant.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort TriggerMask
Public Const TriggerMask As UShort
public:
literal unsigned short TriggerMask


CommonFrameHeader Class

CommonFrameHeader Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader
Represents the common header for all IEEE 1344 frames of data.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CommonFrameHeader : ICommonHeader<FrameType>,
    ISerializable
<SerializableAttribute> _
Public Class CommonFrameHeader _
    Implements ICommonHeader(Of FrameType), ISerializable
[SerializableAttribute]
public ref class CommonFrameHeader : ICommonHeader<FrameType>,
    ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommonFrameHeader(FrameType, Ticks) | Creates a new CommonFrameHeader from specified parameters.
 | CommonFrameHeader(ConfigurationFrame, array<Byte>[]()[][], Int32) | Creates a new CommonFrameHeader from given binaryImage.
 | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
 | BinaryImage | Gets the binary image of the common header portion of this frame.
 | ChecksumIsValid(array<Byte>[]()[][], Int32, Int32) | Validates the CRC-CCITT for the specified IEEE 1344 buffer.
 | DataLength | Gets or sets the length of the data in the IEEE 1344 frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FixedLength | Total fixed length of CommonFrameHeader.
 | FrameCount | Gets or sets the total frame count.
 | FrameImages | Gets or sets reference to a FrameImageCollector associated the IEEE 1344 frame, if any.
 | FrameLength | Gets or sets the entire length of the IEEE 1344 frame.
 | FrameType | Gets the fundamental frame type of this frame.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsFirstFrame | Gets or sets flag from that determines if this is the first frame image in a series of images representing an entire frame.
 | IsLastFrame | Gets or sets flag that determines if this is the last frame image in a series of images representing an entire frame.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SampleCount | Gets or sets the sample number (i.e., frame count) of this frame.
 | State | Gets or sets the parsing state for the CommonFrameHeader object.
 | Timestamp | Gets or sets timestamp of this CommonFrameHeader.
 | TimeTag | Gets the timestamp of this frame in NTP format.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets or sets the IEEE 1344 specific frame type of this frame.
Inheritance Hierarchy
Object
CommonFrameHeader


CommonFrameHeader Constructor

CommonFrameHeader Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► CommonFrameHeader()()()()
Members
Icon | Member | Description
 | CommonFrameHeader(FrameType, Ticks) | Creates a new CommonFrameHeader from specified parameters.
 | CommonFrameHeader(ConfigurationFrame, array<Byte>[]()[][], Int32) | Creates a new CommonFrameHeader from given binaryImage.
 | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.


CommonFrameHeader Constructor (info, context)

CommonFrameHeader Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► CommonFrameHeader(SerializationInfo, StreamingContext)
Creates a new CommonFrameHeader from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected CommonFrameHeader(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CommonFrameHeader(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


CommonFrameHeader Constructor (configurationFrame, binaryImage, startIndex)

CommonFrameHeader Constructor (configurationFrame, binaryImage, startIndex)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► CommonFrameHeader(ConfigurationFrame, array<Byte>[]()[][], Int32)
Creates a new CommonFrameHeader from given binaryImage.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader(
    ConfigurationFrame configurationFrame,
    byte[] binaryImage,
    int startIndex
)
Public Sub New ( _
    configurationFrame As ConfigurationFrame, _
    binaryImage As Byte(), _
    startIndex As Integer _
)
public:
CommonFrameHeader(
    ConfigurationFrame^ configurationFrame,
    array<unsigned char>^ binaryImage,
    int startIndex
)
Parameters
configurationFrame (ConfigurationFrame)
IEEE 1344 ConfigurationFrame if already parsed.
binaryImage (array< Byte >[]()[][])
Buffer that contains data to parse.
startIndex (Int32)
Start index into buffer where valid data begins.


CommonFrameHeader Constructor (typeID, timestamp)

CommonFrameHeader Constructor (typeID, timestamp)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► CommonFrameHeader(FrameType, Ticks)
Creates a new CommonFrameHeader from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader(
    FrameType typeID,
    Ticks timestamp
)
Public Sub New ( _
    typeID As FrameType, _
    timestamp As Ticks _
)
public:
CommonFrameHeader(
    FrameType typeID,
    Ticks timestamp
)
Parameters
typeID (FrameType)
The IEEE 1344 specific frame type of this frame.
timestamp (Ticks)
The timestamp of this frame.


BinaryImage Property

BinaryImage Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► BinaryImage
Gets the binary image of the common header portion of this frame.
Declaration Syntax
C# Visual Basic Visual C++
public byte[] BinaryImage { get; }
Public ReadOnly Property BinaryImage As Byte()
    Get
public:
property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get ();
}


ChecksumIsValid Method (buffer, startIndex, length)

ChecksumIsValid Method (buffer, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► ChecksumIsValid(array<Byte>[]()[][], Int32, Int32)
Validates the CRC-CCITT for the specified IEEE 1344 buffer.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ChecksumIsValid(
    byte[] buffer,
    int startIndex,
    int length
)
Public Shared Function ChecksumIsValid ( _
    buffer As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Boolean
public:
static bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)
Parameters
buffer (array< Byte >[]()[][])
A Byte array buffer.
startIndex (Int32)
An Int32 value as the start index into being reading the value at.
length (Int32)
An Int32 value as the number of bytes to read for the checksum.
Return Value
A Boolean indicating whether the checksum is valid.


DataLength Property

DataLength Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► DataLength
Gets or sets the length of the data in the IEEE 1344 frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).
Declaration Syntax
C# Visual Basic Visual C++
public ushort DataLength { get; set; }
Public Property DataLength As UShort
    Get
    Set
public:
property unsigned short DataLength {
    unsigned short get ();
    void set (unsigned short value);
}


FixedLength Field

FixedLength Field
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► FixedLength
Total fixed length of CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort FixedLength
Public Const FixedLength As UShort
public:
literal unsigned short FixedLength


FrameCount Property

FrameCount Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► FrameCount
Gets or sets the total frame count.
Declaration Syntax
C# Visual Basic Visual C++
public ushort FrameCount { get; set; }
Public Property FrameCount As UShort
    Get
    Set
public:
property unsigned short FrameCount {
    unsigned short get ();
    void set (unsigned short value);
}


FrameImages Property

FrameImages Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► FrameImages
Gets or sets reference to a FrameImageCollector associated the IEEE 1344 frame, if any.
Declaration Syntax
C# Visual Basic Visual C++
public FrameImageCollector FrameImages { get; set; }
Public Property FrameImages As FrameImageCollector
    Get
    Set
public:
property FrameImageCollector^ FrameImages {
    FrameImageCollector^ get ();
    void set (FrameImageCollector^ value);
}


FrameLength Property

FrameLength Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► FrameLength
Gets or sets the entire length of the IEEE 1344 frame.
Declaration Syntax
C# Visual Basic Visual C++
public ushort FrameLength { get; set; }
Public Property FrameLength As UShort
    Get
    Set
public:
property unsigned short FrameLength {
    unsigned short get ();
    void set (unsigned short value);
}


FrameType Property

FrameType Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► FrameType
Gets the fundamental frame type of this frame.
Declaration Syntax
C# Visual Basic Visual C++
public FundamentalFrameType FrameType { get; }
Public ReadOnly Property FrameType As FundamentalFrameType
    Get
public:
property FundamentalFrameType FrameType {
    FundamentalFrameType get ();
}
Remarks
Frames are generally classified as data, configuration or header frames. This returns the general frame classification.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


IsFirstFrame Property

IsFirstFrame Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► IsFirstFrame
Gets or sets flag from that determines if this is the first frame image in a series of images representing an entire frame.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFirstFrame { get; set; }
Public Property IsFirstFrame As Boolean
    Get
    Set
public:
property bool IsFirstFrame {
    bool get ();
    void set (bool value);
}


IsLastFrame Property

IsLastFrame Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► IsLastFrame
Gets or sets flag that determines if this is the last frame image in a series of images representing an entire frame.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLastFrame { get; set; }
Public Property IsLastFrame As Boolean
    Get
    Set
public:
property bool IsLastFrame {
    bool get ();
    void set (bool value);
}


SampleCount Property

SampleCount Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► SampleCount
Gets or sets the sample number (i.e., frame count) of this frame.
Declaration Syntax
C# Visual Basic Visual C++
public ushort SampleCount { get; set; }
Public Property SampleCount As UShort
    Get
    Set
public:
property unsigned short SampleCount {
    unsigned short get ();
    void set (unsigned short value);
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► State
Gets or sets the parsing state for the CommonFrameHeader object.
Declaration Syntax
C# Visual Basic Visual C++
public IChannelParsingState State { get; set; }
Public Property State As IChannelParsingState
    Get
    Set
public:
property IChannelParsingState^ State {
    IChannelParsingState^ get ();
    void set (IChannelParsingState^ value);
}


Timestamp Property

Timestamp Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► Timestamp
Gets or sets timestamp of this CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public Ticks Timestamp { get; set; }
Public Property Timestamp As Ticks
    Get
    Set
public:
property Ticks Timestamp {
    Ticks get ();
    void set (Ticks value);
}


TimeTag Property

TimeTag Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► TimeTag
Gets the timestamp of this frame in NTP format.
Declaration Syntax
C# Visual Basic Visual C++
public NtpTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As NtpTimeTag
    Get
public:
property NtpTimeTag^ TimeTag {
    NtpTimeTag^ get ();
}


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommonFrameHeader ► TypeID
Gets or sets the IEEE 1344 specific frame type of this frame.
Declaration Syntax
C# Visual Basic Visual C++
public FrameType TypeID { get; set; }
Public Property TypeID As FrameType
    Get
    Set
public:
virtual property FrameType TypeID {
    FrameType get () sealed;
    void set (FrameType value) sealed;
}
Remarks

This returns the protocol specific frame classification which uniquely identifies the frame type.

This is the TypeID()()()() implementation.


ConfigurationCell Class

ConfigurationCell Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell
Represents the IEEE 1344 implementation of a IConfigurationCell that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationCell : ConfigurationCellBase
<SerializableAttribute> _
Public Class ConfigurationCell _
    Inherits ConfigurationCellBase
[SerializableAttribute]
public ref class ConfigurationCell : public ConfigurationCellBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCell(IConfigurationFrame) | Creates a new ConfigurationCell.
 | ConfigurationCell(ConfigurationFrame, UInt64, LineFrequency) | Creates a new ConfigurationCell from specified parameters.
 | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
 | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.AnalogDataFormat.)
 | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationCell object. (Overrides ConfigurationCellBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
 | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
 | DataIsValid | Gets or sets flag that determines if data of this ConfigurationCell is valid.
 | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
 | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage | Gets the binary footer image of the ConfigurationCell object. (Overrides ConfigurationCellBase.FooterImage.)
 | FooterLength | Gets the length of the FooterImage. (Overrides ConfigurationCellBase.FooterLength.)
 | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBase.FrequencyDataFormat.)
 | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the ConfigurationCell object. (Overrides ConfigurationCellBase.HeaderImage.)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides ConfigurationCellBase.HeaderLength.)
 | IDCode | Gets or sets the ID code of this ConfigurationCell.
 | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ConfigurationCellBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary footer image. (Overrides ConfigurationCellBase.ParseFooterImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides ConfigurationCellBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.PhasorCoordinateFormat.)
 | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.PhasorDataFormat.)
 | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | StatusFlags | Gets or sets status flags of this ConfigurationCell.
 | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this ConfigurationCell is valid based on GPS lock.
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | TriggerStatus | Gets or sets trigger status of this ConfigurationCell.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | ConfigurationCellBase
 |  |  |  |  | ConfigurationCell


ConfigurationCell Constructor

ConfigurationCell Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► ConfigurationCell()()()()
Members
Icon | Member | Description
 | ConfigurationCell(IConfigurationFrame) | Creates a new ConfigurationCell.
 | ConfigurationCell(ConfigurationFrame, UInt64, LineFrequency) | Creates a new ConfigurationCell from specified parameters.
 | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.


ConfigurationCell Constructor (info, context)

ConfigurationCell Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► ConfigurationCell(SerializationInfo, StreamingContext)
Creates a new ConfigurationCell from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationCell(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationCell Constructor (parent)

ConfigurationCell Constructor (parent)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► ConfigurationCell(IConfigurationFrame)
Creates a new ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell(
    IConfigurationFrame parent
)
Public Sub New ( _
    parent As IConfigurationFrame _
)
public:
ConfigurationCell(
    IConfigurationFrame^ parent
)
Parameters
parent (IConfigurationFrame)
The reference to parent IConfigurationFrame of this ConfigurationCell.


ConfigurationCell Constructor (parent, idCode, nominalFrequency)

ConfigurationCell Constructor (parent, idCode, nominalFrequency)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► ConfigurationCell(ConfigurationFrame, UInt64, LineFrequency)
Creates a new ConfigurationCell from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell(
    ConfigurationFrame parent,
    ulong idCode,
    LineFrequency nominalFrequency
)
Public Sub New ( _
    parent As ConfigurationFrame, _
    idCode As ULong, _
    nominalFrequency As LineFrequency _
)
public:
ConfigurationCell(
    ConfigurationFrame^ parent,
    unsigned long long idCode,
    LineFrequency nominalFrequency
)
Parameters
parent (ConfigurationFrame)
The reference to parent ConfigurationFrame of this ConfigurationCell.
idCode (UInt64)
The numeric ID code for this ConfigurationCell.
nominalFrequency (LineFrequency)
The nominal LineFrequency of the FrequencyDefinition of this ConfigurationCell.


AnalogDataFormat Property

AnalogDataFormat Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► AnalogDataFormat
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override DataFormat AnalogDataFormat { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides Property AnalogDataFormat As DataFormat
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property DataFormat AnalogDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}
Remarks

IEEE 1344 doesn't define any analog values.

This property only supports scaled data; IEEE 1344 doesn't transport floating point values.

Exceptions
Exception | Condition
NotSupportedException | IEEE 1344 only supports scaled data.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationCell object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


DataIsValid Property

DataIsValid Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► DataIsValid
Gets or sets flag that determines if data of this ConfigurationCell is valid.
Declaration Syntax
C# Visual Basic Visual C++
public bool DataIsValid { get; set; }
Public Property DataIsValid As Boolean
    Get
    Set
public:
property bool DataIsValid {
    bool get ();
    void set (bool value);
}


FooterImage Property

FooterImage Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► FooterImage
Gets the binary footer image of the ConfigurationCell object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] FooterImage { get; }
Protected Overrides ReadOnly Property FooterImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ FooterImage {
    array<unsigned char>^ get () override;
}


FooterLength Property

FooterLength Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► FooterLength
Gets the length of the FooterImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int FooterLength { get; }
Protected Overrides ReadOnly Property FooterLength As Integer
    Get
protected:
virtual property int FooterLength {
    int get () override;
}


FrequencyDataFormat Property

FrequencyDataFormat Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► FrequencyDataFormat
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat FrequencyDataFormat { get; set; }
Public Overrides Property FrequencyDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}
Remarks
This property only supports scaled data; IEEE 1344 doesn't transport floating point values.
Exceptions
Exception | Condition
NotSupportedException | IEEE 1344 only supports scaled data.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► HeaderImage
Gets the binary header image of the ConfigurationCell object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► IDCode
Gets or sets the ID code of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public ulong IDCode { get; set; }
Public Property IDCode As ULong
    Get
    Set
public:
property unsigned long long IDCode {
    unsigned long long get ();
    void set (unsigned long long value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► Parent
Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame Parent { get; set; }
Public Property Parent As ConfigurationFrame
    Get
    Set
public:
property ConfigurationFrame^ Parent {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}


ParseFooterImage Method (binaryImage, startIndex, length)

ParseFooterImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► ParseFooterImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary footer image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseFooterImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseFooterImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseFooterImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


PhasorCoordinateFormat Property

PhasorCoordinateFormat Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► PhasorCoordinateFormat
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override CoordinateFormat PhasorCoordinateFormat { get; set; }
Public Overrides Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () override;
    void set (CoordinateFormat value) override;
}


PhasorDataFormat Property

PhasorDataFormat Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► PhasorDataFormat
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat PhasorDataFormat { get; set; }
Public Overrides Property PhasorDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}
Remarks
This property only supports scaled data; IEEE 1344 doesn't transport floating point values.
Exceptions
Exception | Condition
NotSupportedException | IEEE 1344 only supports scaled data.


StatusFlags Property

StatusFlags Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► StatusFlags
Gets or sets status flags of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public ushort StatusFlags { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Property StatusFlags As UShort
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
public:
property unsigned short StatusFlags {
    unsigned short get ();
    void set (unsigned short value);
}
Remarks
These are bit flags, use properties to change basic values.


SynchronizationIsValid Property

SynchronizationIsValid Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► SynchronizationIsValid
Gets or sets flag that determines if timestamp of this ConfigurationCell is valid based on GPS lock.
Declaration Syntax
C# Visual Basic Visual C++
public bool SynchronizationIsValid { get; set; }
Public Property SynchronizationIsValid As Boolean
    Get
    Set
public:
property bool SynchronizationIsValid {
    bool get ();
    void set (bool value);
}


TriggerStatus Property

TriggerStatus Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► TriggerStatus
Gets or sets trigger status of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public TriggerStatus TriggerStatus { get; set; }
Public Property TriggerStatus As TriggerStatus
    Get
    Set
public:
property TriggerStatus TriggerStatus {
    TriggerStatus get ();
    void set (TriggerStatus value);
}


ConfigurationCellCollection Class

ConfigurationCellCollection Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCellCollection
Represents a IEEE 1344 implementation of a collection of IConfigurationCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationCellCollection : ConfigurationCellCollection
<SerializableAttribute> _
Public Class ConfigurationCellCollection _
    Inherits ConfigurationCellCollection
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ConfigurationCellCollection
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCellCollection()()()() | Creates a new ConfigurationCellCollection.
 | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | IndexOfIDCode(UInt16) | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
 | IndexOfIDLabel(String) | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
 | IndexOfStationName(String) | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets ConfigurationCell at specified index.
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetByIDCode(UInt16, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
 | TryGetByIDLabel(String, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
 | TryGetByStationName(String, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IConfigurationCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' IConfigurationCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationCellCollection
 |  |  |  |  | ConfigurationCellCollection


ConfigurationCellCollection Constructor

ConfigurationCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCellCollection ► ConfigurationCellCollection()()()()
Members
Icon | Member | Description
 | ConfigurationCellCollection()()()() | Creates a new ConfigurationCellCollection.
 | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.


ConfigurationCellCollection Constructor

ConfigurationCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCellCollection ► ConfigurationCellCollection()()()()
Creates a new ConfigurationCellCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellCollection()
Public Sub New
public:
ConfigurationCellCollection()


ConfigurationCellCollection Constructor (info, context)

ConfigurationCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCellCollection ► ConfigurationCellCollection(SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


Item Property (index)

Item Property (index)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCellCollection ► Item[([( Int32])])
Gets or sets ConfigurationCell at specified index.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ConfigurationCell
    Get
    Set
public:
property ConfigurationCell^ default[int index] {
    ConfigurationCell^ get (int index);
    void set (int index, ConfigurationCell^ value);
}
Parameters
index (Int32)
Index of value to get or set.


ConfigurationFrame Class

ConfigurationFrame Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame
Represents the IEEE 1344 implementation of a IConfigurationFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationFrame : ConfigurationFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
<SerializableAttribute> _
Public Class ConfigurationFrame _
    Inherits ConfigurationFrameBase _
    Implements ISupportFrameImage(Of FrameType), ISupportBinaryImage
[SerializableAttribute]
public ref class ConfigurationFrame : public ConfigurationFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationFrame()()()() | Creates a new ConfigurationFrame.
 | ConfigurationFrame(UInt64, Ticks, UInt16) | Creates a new ConfigurationFrame from specified parameters.
 | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrame object. (Overrides ConfigurationFrameBase.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CommonHeader | Gets or sets current CommonFrameHeader.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage | Gets the binary footer image of the ConfigurationFrame object. (Overrides BinaryImageBase.FooterImage()()()().)
 | FooterLength | Gets the length of the FooterImage. (Overrides BinaryImageBase.FooterLength()()()().)
 | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the ConfigurationFrame object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets or sets the ID code of this ConfigurationFrame.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.Initialize(array<Byte>[]()[][], Int32, Int32).)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets or sets the nominal LineFrequency of this ConfigurationFrame.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary footer image. (Overrides BinaryImageBase.ParseFooterImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides BinaryImageBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | Period | Gets or sets the IEEE 1344 period value.
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SetNominalFrequency(LineFrequency) | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.Timestamp.)
 | TimeTag | Gets the timestamp of this frame in NTP format.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets the identifier that is used to identify the IEEE 1344 frame.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationFrameBase
 |  |  |  |  | ConfigurationFrame


ConfigurationFrame Constructor

ConfigurationFrame Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► ConfigurationFrame()()()()
Members
Icon | Member | Description
 | ConfigurationFrame()()()() | Creates a new ConfigurationFrame.
 | ConfigurationFrame(UInt64, Ticks, UInt16) | Creates a new ConfigurationFrame from specified parameters.
 | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.


ConfigurationFrame Constructor

ConfigurationFrame Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► ConfigurationFrame()()()()
Creates a new ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ConfigurationFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Sub New
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
ConfigurationFrame()
Remarks
This constructor is used by FrameImageParserBase to parse an IEEE 1344 configuration frame.


ConfigurationFrame Constructor (info, context)

ConfigurationFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► ConfigurationFrame(SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationFrame Constructor (idCode, timestamp, frameRate)

ConfigurationFrame Constructor (idCode, timestamp, frameRate)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► ConfigurationFrame(UInt64, Ticks, UInt16)
Creates a new ConfigurationFrame from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame(
    ulong idCode,
    Ticks timestamp,
    ushort frameRate
)
Public Sub New ( _
    idCode As ULong, _
    timestamp As Ticks, _
    frameRate As UShort _
)
public:
ConfigurationFrame(
    unsigned long long idCode,
    Ticks timestamp,
    unsigned short frameRate
)
Parameters
idCode (UInt64)
The ID code of this ConfigurationFrame.
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame.
frameRate (UInt16)
The defined frame rate of this ConfigurationFrame.
Remarks
This constructor is used by a consumer to generate an IEEE 1344 configuration frame.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrame object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► Cells
Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellCollection Cells { get; }
Public ReadOnly Property Cells As ConfigurationCellCollection
    Get
public:
property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}


CommonHeader Property

CommonHeader Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► CommonHeader
Gets or sets current CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}


FooterImage Property

FooterImage Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► FooterImage
Gets the binary footer image of the ConfigurationFrame object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] FooterImage { get; }
Protected Overrides ReadOnly Property FooterImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ FooterImage {
    array<unsigned char>^ get () override;
}


FooterLength Property

FooterLength Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► FooterLength
Gets the length of the FooterImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int FooterLength { get; }
Protected Overrides ReadOnly Property FooterLength As Integer
    Get
protected:
virtual property int FooterLength {
    int get () override;
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► HeaderImage
Gets the binary header image of the ConfigurationFrame object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► IDCode
Gets or sets the ID code of this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ulong IDCode { get; set; }
Public Property IDCode As ULong
    Get
    Set
public:
property unsigned long long IDCode {
    unsigned long long get ();
    void set (unsigned long long value);
}


Initialize Method (binaryImage, startIndex, length)

Initialize Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► Initialize(array<Byte>[]()[][], Int32, Int32)
Parses the binary image.
Declaration Syntax
C# Visual Basic Visual C++
public override int Initialize(
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Overrides Function Initialize ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
public:
virtual int Initialize(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
This method is overriden to parse from cumulated frame images.


NominalFrequency Property

NominalFrequency Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► NominalFrequency
Gets or sets the nominal LineFrequency of this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public LineFrequency NominalFrequency { get; set; }
Public Property NominalFrequency As LineFrequency
    Get
    Set
public:
property LineFrequency NominalFrequency {
    LineFrequency get ();
    void set (LineFrequency value);
}


ParseFooterImage Method (binaryImage, startIndex, length)

ParseFooterImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► ParseFooterImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary footer image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseFooterImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseFooterImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseFooterImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


Period Property

Period Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► Period
Gets or sets the IEEE 1344 period value.
Declaration Syntax
C# Visual Basic Visual C++
public ushort Period { get; set; }
Public Property Period As UShort
    Get
    Set
public:
property unsigned short Period {
    unsigned short get ();
    void set (unsigned short value);
}


Timestamp Property

Timestamp Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► Timestamp
Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


TimeTag Property

TimeTag Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► TimeTag
Gets the timestamp of this frame in NTP format.
Declaration Syntax
C# Visual Basic Visual C++
public NtpTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As NtpTimeTag
    Get
public:
property NtpTimeTag^ TimeTag {
    NtpTimeTag^ get ();
}


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► TypeID
Gets the identifier that is used to identify the IEEE 1344 frame.
Declaration Syntax
C# Visual Basic Visual C++
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}


DataCell Class

DataCell Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCell
Represents the IEEE 1344 implementation of a IDataCell that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataCell : DataCellBase
<SerializableAttribute> _
Public Class DataCell _
    Inherits DataCellBase
[SerializableAttribute]
public ref class DataCell : public DataCellBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
 | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
 | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
 | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
 | AnalogValues | Gets AnalogValueCollection of this DataCell. (Overrides DataCellBase.AnalogValues.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataCell object. (Overrides DataCellBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
 | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
 | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
 | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBase.DataIsValid.)
 | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBase.DataSortingType.)
 | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBase.DeviceError.)
 | DigitalValues | Gets DigitalValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
 | Equals(Object) | Determines whether the specified object is equal to the DataCellBase. (Inherited from DataCellBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
 | GetHashCode()()()() | Serves as a hash function for the DataCellBase. (Inherited from DataCellBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DataCellBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets the numeric ID code for this DataCell.
 | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from DataCellBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
 | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
 | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
 | StatusFlags | Gets or sets 16-bit status flags of this DataCellBase. (Inherited from DataCellBase.)
 | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBase.SynchronizationIsValid.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this DataCellBase. (Inherited from DataCellBase.)
 | TriggerStatus | Gets or sets trigger status of this DataCell.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | DataCellBase
 |  |  |  |  | DataCell


DataCell Constructor

DataCell Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCell ► DataCell()()()()
Members
Icon | Member | Description
 | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
 | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
 | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.


DataCell Constructor (info, context)

DataCell Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCell ► DataCell(SerializationInfo, StreamingContext)
Creates a new DataCell from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataCell(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DataCell Constructor (parent, configurationCell)

DataCell Constructor (parent, configurationCell)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCell ► DataCell(IDataFrame, IConfigurationCell)
Creates a new DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell(
    IDataFrame parent,
    IConfigurationCell configurationCell
)
Public Sub New ( _
    parent As IDataFrame, _
    configurationCell As IConfigurationCell _
)
public:
DataCell(
    IDataFrame^ parent,
    IConfigurationCell^ configurationCell
)
Parameters
parent (IDataFrame)
The reference to parent IDataFrame of this DataCell.
configurationCell (IConfigurationCell)
The IConfigurationCell associated with this DataCell.


DataCell Constructor (parent, configurationCell, addEmptyValues)

DataCell Constructor (parent, configurationCell, addEmptyValues)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCell ► DataCell(DataFrame, ConfigurationCell, Boolean)
Creates a new DataCell from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell(
    DataFrame parent,
    ConfigurationCell configurationCell,
    bool addEmptyValues
)
Public Sub New ( _
    parent As DataFrame, _
    configurationCell As ConfigurationCell, _
    addEmptyValues As Boolean _
)
public:
DataCell(
    DataFrame^ parent,
    ConfigurationCell^ configurationCell,
    bool addEmptyValues
)
Parameters
parent (DataFrame)
The reference to parent DataFrame of this DataCell.
configurationCell (ConfigurationCell)
The ConfigurationCell associated with this DataCell.
addEmptyValues (Boolean)
If true, adds empty values for each defined configuration cell definition.


AnalogValues Property

AnalogValues Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCell ► AnalogValues
Gets AnalogValueCollection of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override AnalogValueCollection AnalogValues { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides ReadOnly Property AnalogValues As AnalogValueCollection
    Get
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property AnalogValueCollection^ AnalogValues {
    AnalogValueCollection^ get () override;
}
Remarks
IEEE 1344 doesn't define any analog values.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCell ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataCell object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


ConfigurationCell Property

ConfigurationCell Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCell ► ConfigurationCell
Gets or sets the ConfigurationCell associated with this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell ConfigurationCell { get; set; }
Public Property ConfigurationCell As ConfigurationCell
    Get
    Set
public:
property ConfigurationCell^ ConfigurationCell {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


DataIsValid Property

DataIsValid Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCell ► DataIsValid
Gets or sets flag that determines if data of this DataCell is valid.
Declaration Syntax
C# Visual Basic Visual C++
public override bool DataIsValid { get; set; }
Public Overrides Property DataIsValid As Boolean
    Get
    Set
public:
virtual property bool DataIsValid {
    bool get () override;
    void set (bool value) override;
}


DataSortingType Property

DataSortingType Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCell ► DataSortingType
Gets or sets DataSortingType of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataSortingType DataSortingType { get; set; }
Public Overrides Property DataSortingType As DataSortingType
    Get
    Set
public:
virtual property DataSortingType DataSortingType {
    DataSortingType get () override;
    void set (DataSortingType value) override;
}


DeviceError Property

DeviceError Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCell ► DeviceError
Gets or sets flag that determines if source device of this DataCell is reporting an error.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override bool DeviceError { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides Property DeviceError As Boolean
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property bool DeviceError {
    bool get () override;
    void set (bool value) override;
}
Remarks
IEEE 1344 doesn't define bits for device error.


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCell ► IDCode
Gets the numeric ID code for this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public ulong IDCode { get; }
Public ReadOnly Property IDCode As ULong
    Get
public:
property unsigned long long IDCode {
    unsigned long long get ();
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCell ► Parent
Gets or sets the reference to parent DataFrame of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public DataFrame Parent { get; set; }
Public Property Parent As DataFrame
    Get
    Set
public:
property DataFrame^ Parent {
    DataFrame^ get ();
    void set (DataFrame^ value);
}


SynchronizationIsValid Property

SynchronizationIsValid Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCell ► SynchronizationIsValid
Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock.
Declaration Syntax
C# Visual Basic Visual C++
public override bool SynchronizationIsValid { get; set; }
Public Overrides Property SynchronizationIsValid As Boolean
    Get
    Set
public:
virtual property bool SynchronizationIsValid {
    bool get () override;
    void set (bool value) override;
}


TriggerStatus Property

TriggerStatus Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCell ► TriggerStatus
Gets or sets trigger status of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public TriggerStatus TriggerStatus { get; set; }
Public Property TriggerStatus As TriggerStatus
    Get
    Set
public:
property TriggerStatus TriggerStatus {
    TriggerStatus get ();
    void set (TriggerStatus value);
}


DataCellCollection Class

DataCellCollection Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCellCollection
Represents a IEEE 1344 implementation of a collection of IDataCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataCellCollection : DataCellCollection
<SerializableAttribute> _
Public Class DataCellCollection _
    Inherits DataCellCollection
[SerializableAttribute]
public ref class DataCellCollection : public DataCellCollection
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCellCollection()()()() | Creates a new DataCellCollection.
 | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets DataCell at specified index.
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IDataCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' IDataCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' IDataCell >)>)>
 |  |  |  | DataCellCollection
 |  |  |  |  | DataCellCollection


DataCellCollection Constructor

DataCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCellCollection ► DataCellCollection()()()()
Members
Icon | Member | Description
 | DataCellCollection()()()() | Creates a new DataCellCollection.
 | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.


DataCellCollection Constructor

DataCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCellCollection ► DataCellCollection()()()()
Creates a new DataCellCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DataCellCollection()
Public Sub New
public:
DataCellCollection()


DataCellCollection Constructor (info, context)

DataCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCellCollection ► DataCellCollection(SerializationInfo, StreamingContext)
Creates a new DataCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


Item Property (index)

Item Property (index)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataCellCollection ► Item[([( Int32])])
Gets or sets DataCell at specified index.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DataCell
    Get
    Set
public:
property DataCell^ default[int index] {
    DataCell^ get (int index);
    void set (int index, DataCell^ value);
}
Parameters
index (Int32)
Index of value to get or set.


DataFrame Class

DataFrame Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame
Represents the IEEE 1344 implementation of a IDataFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataFrame : DataFrameBase, ISupportFrameImage<FrameType>,
    ISupportBinaryImage
<SerializableAttribute> _
Public Class DataFrame _
    Inherits DataFrameBase _
    Implements ISupportFrameImage(Of FrameType), ISupportBinaryImage
[SerializableAttribute]
public ref class DataFrame : public DataFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataFrame()()()() | Creates a new DataFrame.
 | DataFrame(Ticks, ConfigurationFrame) | Creates a new DataFrame from specified parameters.
 | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataFrame object. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the DataCellCollection for this DataFrame.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CommonHeader | Gets or sets current CommonFrameHeader.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets the numeric ID code for this DataFrame.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from DataFrameBase.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides BinaryImageBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.Timestamp.)
 | TimeTag | Gets the timestamp of this frame in NTP format.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets the identifier that is used to identify the IEEE 1344 frame.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IDataCell >)>)>
 |  |  |  | DataFrameBase
 |  |  |  |  | DataFrame


DataFrame Constructor

DataFrame Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► DataFrame()()()()
Members
Icon | Member | Description
 | DataFrame()()()() | Creates a new DataFrame.
 | DataFrame(Ticks, ConfigurationFrame) | Creates a new DataFrame from specified parameters.
 | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.


DataFrame Constructor

DataFrame Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► DataFrame()()()()
Creates a new DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public DataFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Sub New
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
DataFrame()
Remarks
This constructor is used by FrameImageParserBase to parse an IEEE 1344 data frame.


DataFrame Constructor (info, context)

DataFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► DataFrame(SerializationInfo, StreamingContext)
Creates a new DataFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DataFrame Constructor (timestamp, configurationFrame)

DataFrame Constructor (timestamp, configurationFrame)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► DataFrame(Ticks, ConfigurationFrame)
Creates a new DataFrame from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DataFrame(
    Ticks timestamp,
    ConfigurationFrame configurationFrame
)
Public Sub New ( _
    timestamp As Ticks, _
    configurationFrame As ConfigurationFrame _
)
public:
DataFrame(
    Ticks timestamp,
    ConfigurationFrame^ configurationFrame
)
Parameters
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this DataFrame.
configurationFrame (ConfigurationFrame)
The ConfigurationFrame associated with this DataFrame.
Remarks
This constructor is used by a consumer to generate an IEEE 1344 data frame.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataFrame object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► Cells
Gets reference to the DataCellCollection for this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public DataCellCollection Cells { get; }
Public ReadOnly Property Cells As DataCellCollection
    Get
public:
property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}


CommonHeader Property

CommonHeader Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► CommonHeader
Gets or sets current CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► ConfigurationFrame
Gets or sets ConfigurationFrame associated with this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame ConfigurationFrame { get; set; }
Public Property ConfigurationFrame As ConfigurationFrame
    Get
    Set
public:
property ConfigurationFrame^ ConfigurationFrame {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► HeaderImage
Gets the binary header image of the DataFrame object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► IDCode
Gets the numeric ID code for this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ulong IDCode { get; }
Public ReadOnly Property IDCode As ULong
    Get
public:
property unsigned long long IDCode {
    unsigned long long get ();
}


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


Timestamp Property

Timestamp Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► Timestamp
Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


TimeTag Property

TimeTag Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► TimeTag
Gets the timestamp of this frame in NTP format.
Declaration Syntax
C# Visual Basic Visual C++
public NtpTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As NtpTimeTag
    Get
public:
property NtpTimeTag^ TimeTag {
    NtpTimeTag^ get ();
}


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► TypeID
Gets the identifier that is used to identify the IEEE 1344 frame.
Declaration Syntax
C# Visual Basic Visual C++
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}


DigitalDefinition Class

DigitalDefinition Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalDefinition
Represents the IEEE 1344 implementation of a IDigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DigitalDefinition : DigitalDefinitionBase
<SerializableAttribute> _
Public Class DigitalDefinition _
    Inherits DigitalDefinitionBase
[SerializableAttribute]
public ref class DigitalDefinition : public DigitalDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition.
 | DigitalDefinition(ConfigurationCell, String) | Creates a new DigitalDefinition from specified parameters.
 | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this DigitalDefinition object. (Overrides ChannelDefinitionBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NormalStatus | Gets or sets normal status for this DigitalDefinition.
 | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ValidInputs | Gets or sets valid input for this DigitalDefinition.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | DigitalDefinitionBase
 |  |  |  |  | DigitalDefinition


DigitalDefinition Constructor

DigitalDefinition Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalDefinition ► DigitalDefinition()()()()
Members
Icon | Member | Description
 | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition.
 | DigitalDefinition(ConfigurationCell, String) | Creates a new DigitalDefinition from specified parameters.
 | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.


DigitalDefinition Constructor (info, context)

DigitalDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalDefinition ► DigitalDefinition(SerializationInfo, StreamingContext)
Creates a new DigitalDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DigitalDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DigitalDefinition Constructor (parent)

DigitalDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalDefinition ► DigitalDefinition(IConfigurationCell)
Creates a new DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
DigitalDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this DigitalDefinition.


DigitalDefinition Constructor (parent, label)

DigitalDefinition Constructor (parent, label)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalDefinition ► DigitalDefinition(ConfigurationCell, String)
Creates a new DigitalDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String _
)
public:
DigitalDefinition(
    ConfigurationCell^ parent,
    String^ label
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this DigitalDefinition.
label (String)
The label of this DigitalDefinition.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalDefinition ► Attributes
Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this DigitalDefinition object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalDefinition ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


NormalStatus Property

NormalStatus Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalDefinition ► NormalStatus
Gets or sets normal status for this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public ushort NormalStatus { get; set; }
Public Property NormalStatus As UShort
    Get
    Set
public:
property unsigned short NormalStatus {
    unsigned short get ();
    void set (unsigned short value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalDefinition ► Parent
Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


ValidInputs Property

ValidInputs Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalDefinition ► ValidInputs
Gets or sets valid input for this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public ushort ValidInputs { get; set; }
Public Property ValidInputs As UShort
    Get
    Set
public:
property unsigned short ValidInputs {
    unsigned short get ();
    void set (unsigned short value);
}


DigitalValue Class

DigitalValue Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalValue
Represents the IEEE 1344 implementation of a IDigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DigitalValue : DigitalValueBase
<SerializableAttribute> _
Public Class DigitalValue _
    Inherits DigitalValueBase
[SerializableAttribute]
public ref class DigitalValue : public DigitalValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
 | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
 | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DigitalValueBase object. (Inherited from DigitalValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the DigitalValueBase object. (Inherited from DigitalValueBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from DigitalValueBase.)
 | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Inherited from DigitalValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the DigitalDefinition associated with this DigitalValue.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this DigitalValueBase. (Inherited from DigitalValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from DigitalValueBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DigitalValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Inherited from DigitalValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this DigitalValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from DigitalValueBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase. (Inherited from DigitalValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IDigitalDefinition >)>)>
 |  |  |  | DigitalValueBase
 |  |  |  |  | DigitalValue


DigitalValue Constructor

DigitalValue Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalValue ► DigitalValue()()()()
Members
Icon | Member | Description
 | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
 | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
 | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.


DigitalValue Constructor (info, context)

DigitalValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalValue ► DigitalValue(SerializationInfo, StreamingContext)
Creates a new DigitalValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DigitalValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DigitalValue Constructor (parent, digitalDefinition)

DigitalValue Constructor (parent, digitalDefinition)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalValue ► DigitalValue(IDataCell, IDigitalDefinition)
Creates a new DigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalValue(
    IDataCell parent,
    IDigitalDefinition digitalDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    digitalDefinition As IDigitalDefinition _
)
public:
DigitalValue(
    IDataCell^ parent,
    IDigitalDefinition^ digitalDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this DigitalValue.
digitalDefinition (IDigitalDefinition)
The IDigitalDefinition associated with this DigitalValue.


DigitalValue Constructor (parent, digitalDefinition, value)

DigitalValue Constructor (parent, digitalDefinition, value)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalValue ► DigitalValue(DataCell, DigitalDefinition, UInt16)
Creates a new DigitalValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalValue(
    DataCell parent,
    DigitalDefinition digitalDefinition,
    ushort value
)
Public Sub New ( _
    parent As DataCell, _
    digitalDefinition As DigitalDefinition, _
    value As UShort _
)
public:
DigitalValue(
    DataCell^ parent,
    DigitalDefinition^ digitalDefinition,
    unsigned short value
)
Parameters
parent (DataCell)
The DataCell parent of this DigitalValue.
digitalDefinition (DigitalDefinition)
The DigitalDefinition associated with this DigitalValue.
value (UInt16)
The unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValue.


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalValue ► Definition
Gets or sets the DigitalDefinition associated with this DigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DigitalDefinition Definition { get; set; }
Public Overridable Property Definition As DigitalDefinition
    Get
    Set
public:
virtual property DigitalDefinition^ Definition {
    DigitalDefinition^ get ();
    void set (DigitalDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalValue ► Parent
Gets or sets the DataCell parent of this DigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


FrameImageCollector Class

FrameImageCollector Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameImageCollector
Collects frame images until a full IEEE 1344 frame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public class FrameImageCollector
Public Class FrameImageCollector
public ref class FrameImageCollector
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrameImageCollector()()()() | Creates a new FrameImageCollector.
 | AppendFrameImage(array<Byte>[]()[][], Int32, Int32) | Appends the current frame image to the frame image collection.
 | BinaryImage | Gets the combined binary image of all the collected frame images.
 | BinaryLength | Gets the length of the combined binary image of all the collected frame images.
 | Count | Gets the total number frames appended to FrameImageCollector.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FrameImageCollector


FrameImageCollector Constructor

FrameImageCollector Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameImageCollector ► FrameImageCollector()()()()
Creates a new FrameImageCollector.
Declaration Syntax
C# Visual Basic Visual C++
public FrameImageCollector()
Public Sub New
public:
FrameImageCollector()


AppendFrameImage Method (binaryImage, offset, length)

AppendFrameImage Method (binaryImage, offset, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameImageCollector ► AppendFrameImage(array<Byte>[]()[][], Int32, Int32)
Appends the current frame image to the frame image collection.
Declaration Syntax
C# Visual Basic Visual C++
public void AppendFrameImage(
    byte[] binaryImage,
    int offset,
    int length
)
Public Sub AppendFrameImage ( _
    binaryImage As Byte(), _
    offset As Integer, _
    length As Integer _
)
public:
void AppendFrameImage(
    array<unsigned char>^ binaryImage,
    int offset,
    int length
)
Parameters
binaryImage (array< Byte >[]()[][])
A Byte array to append to the collection.
offset (Int32)
An Int32 value indicating the offset to read from.
length (Int32)
An Int32 value indicating the number of bytes to read from the binaryImage.


BinaryImage Property

BinaryImage Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameImageCollector ► BinaryImage
Gets the combined binary image of all the collected frame images.
Declaration Syntax
C# Visual Basic Visual C++
public byte[] BinaryImage { get; }
Public ReadOnly Property BinaryImage As Byte()
    Get
public:
property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get ();
}


BinaryLength Property

BinaryLength Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameImageCollector ► BinaryLength
Gets the length of the combined binary image of all the collected frame images.
Declaration Syntax
C# Visual Basic Visual C++
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
public:
property int BinaryLength {
    int get ();
}


Count Property

Count Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameImageCollector ► Count
Gets the total number frames appended to FrameImageCollector.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}


FrameParser Class

FrameParser Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameParser
Represents a frame parser for an IEEE 1344 binary data stream that returns parsed data via events.
Declaration Syntax
C# Visual Basic Visual C++
public class FrameParser : FrameParserBase<FrameType>
Public Class FrameParser _
    Inherits FrameParserBase(Of FrameType)
public ref class FrameParser : public FrameParserBase<FrameType>
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrameParser()()()() | Initializes a new instance of the FrameParser class
 | BeginRead(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead()()()() | (Inherited from BinaryImageParserBase.)
 | CanSeek()()()() | (Inherited from BinaryImageParserBase.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite()()()() | (Inherited from BinaryImageParserBase.)
 | Close()()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.ConfigurationFrame.)
 | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | CreateBufferQueue()()()() | Creates the internal buffer queue. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | DataDiscarded()()()() | (Inherited from BinaryImageParserBase.)
 | DataParsed()()()() | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBase<(Of <(<'TFrameIdentifier>)>)> object and optionally releases the managed resources. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | DuplicateTypeHandlerEncountered()()()() | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | Enabled()()()() | (Inherited from BinaryImageParserBase.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteParseOnSeparateThread | Gets or sets a flag that allows frame parsing to be executed on a separate thread (i.e., other than communications thread). (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()()() | Clears all buffers for this stream and causes any buffered data to be parsed immediately. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length()()()() | (Inherited from BinaryImageParserBase.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()()()() | (Inherited from BinaryImageParserBase.)
 | OnConfigurationChanged()()()() | Raises the ConfigurationChanged event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnDataDiscarded(array<Byte>[]()[][]) | (Inherited from BinaryImageParserBase.)
 | OnDataParsed(UTP) | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | OnDuplicateTypeHandlerEncountered(Type, UTP) | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | OnOutputTypeNotFound(UTP) | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | OnParsingException(Exception) | (Inherited from BinaryImageParserBase.)
 | OnReceivedChannelFrame(IChannelFrame) | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame, ConfigurationFrame, CommandFrame or HeaderFrame). (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.OnReceivedChannelFrame(IChannelFrame).)
 | OnReceivedCommandFrame(ICommandFrame) | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedConfigurationFrame(IConfigurationFrame) | Raises the ReceivedConfigurationFrame event. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.OnReceivedConfigurationFrame(IConfigurationFrame).)
 | OnReceivedDataFrame(IDataFrame) | Raises the ReceivedDataFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedFrameBufferImage(FundamentalFrameType, array<Byte>[]()[][], Int32, Int32) | Raises the ReceivedFrameBufferImage event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedHeaderFrame(IHeaderFrame) | Raises the ReceivedHeaderFrame event. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.OnReceivedHeaderFrame(IHeaderFrame).)
 | OnReceivedUndeterminedFrame(IChannelFrame) | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnUnknownFrameTypeEncountered(TFrameIdentifier) | Handles unknown frame types. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OutputTypeNotFound()()()() | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | Parse(ISupportBinaryImage) | (Inherited from BinaryImageParserBase.)
 | ParseCommonHeader(array<Byte>[]()[][], Int32, Int32) | Parses a common header instance that implements ICommonHeader for the output type represented in the binary image. (Overrides FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.ParseCommonHeader(array<Byte>[]()[][], Int32, Int32).)
 | ParseFrame(array<Byte>[]()[][], Int32, Int32) | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | ParseQueuedBuffers(array<array<Byte>[]()[][]>[]()[][]) | This method is used by the internal ProcessQueue to process all queued data buffers. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ParsingException()()()() | (Inherited from BinaryImageParserBase.)
 | Position()()()() | (Inherited from BinaryImageParserBase.)
 | ProtocolSyncBytes()()()() | (Inherited from BinaryImageParserBase.)
 | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBase.ProtocolUsesSyncBytes()()()().)
 | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Read(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageParserBase.)
 | ReadByte()()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | ReceivedCommandFrame | Occurs when an IEEE 1344 CommandFrame has been received.
 | ReceivedConfigurationFrame | Occurs when an IEEE 1344 ConfigurationFrame has been received.
 | ReceivedDataFrame | Occurs when an IEEE 1344 DataFrame has been received.
 | ReceivedFrameBufferImage | Occurs when a frame buffer image has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ReceivedHeaderFrame | Occurs when an IEEE 1344 HeaderFrame has been received.
 | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | RunTime()()()() | (Inherited from BinaryImageParserBase.)
 | Seek(Int64, SeekOrigin) | (Inherited from BinaryImageParserBase.)
 | SetLength(Int64) | (Inherited from BinaryImageParserBase.)
 | Start()()()() | Start the data parser. (Overrides FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.Start()()()().)
 | Start(IEnumerable<(Of <<'(Type>)>>)) | Starts the frame parser given the specified type implementations. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Status | Gets current descriptive status of the FrameParserBase<(Of <(<'TFrameIdentifier>)>)>. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Stop()()()() | Stops the frame parser. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | StreamInitialized()()()() | (Inherited from BinaryImageParserBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalProcessedBuffers()()()() | (Inherited from BinaryImageParserBase.)
 | UnparsedBuffer()()()() | (Inherited from BinaryImageParserBase.)
 | Write(array<Byte>[]()[][], Int32, Int32) | Writes a sequence of bytes onto the stream for parsing. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks
Frame parser is implemented as a write-only stream - this way data can come from any source.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | BinaryImageParserBase
 |  |  |  | FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>
 |  |  |  |  | FrameParserBase <(Of <(<' FrameType >)>)>
 |  |  |  |  |  | FrameParser


FrameParser Constructor

FrameParser Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameParser ► FrameParser()()()()
Initializes a new instance of the FrameParser class
Declaration Syntax
C# Visual Basic Visual C++
public FrameParser()
Public Sub New
public:
FrameParser()


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameParser ► ConfigurationFrame
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
Declaration Syntax
C# Visual Basic Visual C++
public override IConfigurationFrame ConfigurationFrame { get; set; }
Public Overrides Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () override;
    void set (IConfigurationFrame^ value) override;
}
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.


OnReceivedChannelFrame Method (frame)

OnReceivedChannelFrame Method (frame)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameParser ► OnReceivedChannelFrame(IChannelFrame)
Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame, ConfigurationFrame, CommandFrame or HeaderFrame).
Declaration Syntax
C# Visual Basic Visual C++
protected override void OnReceivedChannelFrame(
    IChannelFrame frame
)
Protected Overrides Sub OnReceivedChannelFrame ( _
    frame As IChannelFrame _
)
protected:
virtual void OnReceivedChannelFrame(
    IChannelFrame^ frame
) override
Parameters
frame (IChannelFrame)
IChannelFrame that was parsed by FrameImageParserBase that implements protocol specific common frame header interface.


OnReceivedConfigurationFrame Method (frame)

OnReceivedConfigurationFrame Method (frame)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameParser ► OnReceivedConfigurationFrame(IConfigurationFrame)
Raises the ReceivedConfigurationFrame event.
Declaration Syntax
C# Visual Basic Visual C++
protected override void OnReceivedConfigurationFrame(
    IConfigurationFrame frame
)
Protected Overrides Sub OnReceivedConfigurationFrame ( _
    frame As IConfigurationFrame _
)
protected:
virtual void OnReceivedConfigurationFrame(
    IConfigurationFrame^ frame
) override
Parameters
frame (IConfigurationFrame)
IConfigurationFrame to send to ReceivedConfigurationFrame event.


OnReceivedHeaderFrame Method (frame)

OnReceivedHeaderFrame Method (frame)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameParser ► OnReceivedHeaderFrame(IHeaderFrame)
Raises the ReceivedHeaderFrame event.
Declaration Syntax
C# Visual Basic Visual C++
protected override void OnReceivedHeaderFrame(
    IHeaderFrame frame
)
Protected Overrides Sub OnReceivedHeaderFrame ( _
    frame As IHeaderFrame _
)
protected:
virtual void OnReceivedHeaderFrame(
    IHeaderFrame^ frame
) override
Parameters
frame (IHeaderFrame)
IHeaderFrame to send to ReceivedHeaderFrame event.


ParseCommonHeader Method (buffer, offset, length)

ParseCommonHeader Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameParser ► ParseCommonHeader(array<Byte>[]()[][], Int32, Int32)
Parses a common header instance that implements ICommonHeader for the output type represented in the binary image.
Declaration Syntax
C# Visual Basic Visual C++
protected override ICommonHeader<FrameType> ParseCommonHeader(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function ParseCommonHeader ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As ICommonHeader(Of FrameType)
protected:
virtual ICommonHeader<FrameType>^ ParseCommonHeader(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer containing data to parse.
offset (Int32)
Offset index into buffer that represents where to start parsing.
length (Int32)
Maximum length of valid data from offset.
Return Value
The ICommonHeader which includes a type ID for the Type to be parsed.
Remarks

Derived classes need to provide a common header instance (i.e., class that implements ICommonHeader) for the output types; this will primarily include an ID of the Type that the data image represents. This parsing is only for common header information, actual parsing will be handled by output type via its Initialize(array<Byte>[]()[][], Int32, Int32) method. This header image should also be used to add needed complex state information about the output type being parsed if needed.

If there is not enough buffer available to parse common header (as determined by length), return null. Also, if the protocol allows frame length to be determined at the time common header is being parsed and there is not enough buffer to parse the entire frame, it will be optimal to prevent further parsing by returning null.


ProtocolUsesSyncBytes Property

ProtocolUsesSyncBytes Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameParser ► ProtocolUsesSyncBytes
Gets flag that determines if this protocol parsing implementation uses synchronization bytes.
Declaration Syntax
C# Visual Basic Visual C++
public override bool ProtocolUsesSyncBytes { get; }
Public Overrides ReadOnly Property ProtocolUsesSyncBytes As Boolean
    Get
public:
virtual property bool ProtocolUsesSyncBytes {
    bool get () override;
}
Remarks
The IEEE 1344 protocol does not use synchronization bytes, as a result this property returns false.


ReceivedCommandFrame Event

ReceivedCommandFrame Event
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameParser ► ReceivedCommandFrame
Occurs when an IEEE 1344 CommandFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<CommandFrame>> ReceivedCommandFrame
Public Event ReceivedCommandFrame As EventHandler(Of EventArgs(Of CommandFrame))
public:
 event EventHandler<EventArgs<CommandFrame^>^>^ ReceivedCommandFrame {
    void add (EventHandler<EventArgs<CommandFrame^>^>^ value);
    void remove (EventHandler<EventArgs<CommandFrame^>^>^ value);
}
Remarks
Argument()()()() is the CommandFrame that was received.

Command frames are normally sent, not received, but there is nothing that prevents this.


ReceivedConfigurationFrame Event

ReceivedConfigurationFrame Event
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameParser ► ReceivedConfigurationFrame
Occurs when an IEEE 1344 ConfigurationFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<ConfigurationFrame>> ReceivedConfigurationFrame
Public Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of ConfigurationFrame))
public:
 event EventHandler<EventArgs<ConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
}
Remarks
Argument()()()() is the ConfigurationFrame that was received.


ReceivedDataFrame Event

ReceivedDataFrame Event
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameParser ► ReceivedDataFrame
Occurs when an IEEE 1344 DataFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<DataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of DataFrame))
public:
 event EventHandler<EventArgs<DataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<DataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<DataFrame^>^>^ value);
}
Remarks
Argument()()()() is the DataFrame that was received.


ReceivedHeaderFrame Event

ReceivedHeaderFrame Event
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameParser ► ReceivedHeaderFrame
Occurs when an IEEE 1344 HeaderFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<HeaderFrame>> ReceivedHeaderFrame
Public Event ReceivedHeaderFrame As EventHandler(Of EventArgs(Of HeaderFrame))
public:
 event EventHandler<EventArgs<HeaderFrame^>^>^ ReceivedHeaderFrame {
    void add (EventHandler<EventArgs<HeaderFrame^>^>^ value);
    void remove (EventHandler<EventArgs<HeaderFrame^>^>^ value);
}
Remarks
Argument()()()() is the HeaderFrame that was received.


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameParser ► Start()()()()
Start the data parser.
Declaration Syntax
C# Visual Basic Visual C++
public override void Start()
Public Overrides Sub Start
public:
virtual void Start() override


FrameType Enumeration

FrameType Enumeration
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameType
IEEE 1344 frame types enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum FrameType
<SerializableAttribute> _
Public Enumeration FrameType
[SerializableAttribute]
public enum class FrameType
Members
Member | Description
DataFrame | 000 Data frame.
HeaderFrame | 001 Header frame.
ConfigurationFrame | 010 Configuration frame.
Reserved0 | 011 Reserved flags 0.
Reserved1 | 110 Reserved flags 1.
Reserved2 | 100 Reserved flags 2.
UserDefined0 | 101 User defined flags 0.
UserDefined1 | 111 User defined flags 1.


FrequencyDefinition Class

FrequencyDefinition Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyDefinition
Represents the IEEE 1344 implementation of a IFrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FrequencyDefinition : FrequencyDefinitionBase
<SerializableAttribute> _
Public Class FrequencyDefinition _
    Inherits FrequencyDefinitionBase
[SerializableAttribute]
public ref class FrequencyDefinition : public FrequencyDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
 | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
 | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this FrequencyDefinition object. (Overrides FrequencyDefinitionBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the FrequencyDefinition object. (Overrides ChannelDefinitionBase.BodyImage.)
 | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBase.BodyLength.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | DfDtIsAvailable | Gets or sets flag that determines if df/dt measurement is available in FrequencyValue.
 | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrequencyIsAvailable | Gets or sets flag that determines if frequency measurement is available in FrequencyValue.
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides FrequencyDefinitionBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides ChannelDefinitionBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | FrequencyDefinitionBase
 |  |  |  |  | FrequencyDefinition


FrequencyDefinition Constructor

FrequencyDefinition Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyDefinition ► FrequencyDefinition()()()()
Members
Icon | Member | Description
 | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
 | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
 | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.


FrequencyDefinition Constructor (info, context)

FrequencyDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyDefinition ► FrequencyDefinition(SerializationInfo, StreamingContext)
Creates a new FrequencyDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrequencyDefinition Constructor (parent)

FrequencyDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyDefinition ► FrequencyDefinition(IConfigurationCell)
Creates a new FrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
FrequencyDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this FrequencyDefinition.


FrequencyDefinition Constructor (parent, label)

FrequencyDefinition Constructor (parent, label)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyDefinition ► FrequencyDefinition(ConfigurationCell, String)
Creates a new FrequencyDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String _
)
public:
FrequencyDefinition(
    ConfigurationCell^ parent,
    String^ label
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this FrequencyDefinition.
label (String)
The label of this FrequencyDefinition.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyDefinition ► Attributes
Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this FrequencyDefinition object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyDefinition ► BodyImage
Gets the binary body image of the FrequencyDefinition object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyDefinition ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}


DfDtIsAvailable Property

DfDtIsAvailable Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyDefinition ► DfDtIsAvailable
Gets or sets flag that determines if df/dt measurement is available in FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public bool DfDtIsAvailable { get; set; }
Public Property DfDtIsAvailable As Boolean
    Get
    Set
public:
property bool DfDtIsAvailable {
    bool get ();
    void set (bool value);
}


FrequencyIsAvailable Property

FrequencyIsAvailable Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyDefinition ► FrequencyIsAvailable
Gets or sets flag that determines if frequency measurement is available in FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public bool FrequencyIsAvailable { get; set; }
Public Property FrequencyIsAvailable As Boolean
    Get
    Set
public:
property bool FrequencyIsAvailable {
    bool get ();
    void set (bool value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyDefinition ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyDefinition ► Parent
Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyDefinition ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
The base implementation assumes that all channel defintions begin with a label as this is the general case, override functionality if this is not the case.


FrequencyValue Class

FrequencyValue Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyValue
Represents the IEEE 1344 implementation of a IFrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FrequencyValue : FrequencyValueBase
<SerializableAttribute> _
Public Class FrequencyValue _
    Inherits FrequencyValueBase
[SerializableAttribute]
public ref class FrequencyValue : public FrequencyValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
 | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
 | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the FrequencyValue object. (Overrides FrequencyValueBase.BodyImage.)
 | BodyLength | Gets the length of the BodyImage. (Overrides FrequencyValueBase.BodyLength.)
 | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
 | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this FrequencyValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides FrequencyValueBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
 | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IFrequencyDefinition >)>)>
 |  |  |  | FrequencyValueBase
 |  |  |  |  | FrequencyValue


FrequencyValue Constructor

FrequencyValue Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyValue ► FrequencyValue()()()()
Members
Icon | Member | Description
 | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
 | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
 | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.


FrequencyValue Constructor (info, context)

FrequencyValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyValue ► FrequencyValue(SerializationInfo, StreamingContext)
Creates a new FrequencyValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrequencyValue Constructor (parent, frequencyDefinition)

FrequencyValue Constructor (parent, frequencyDefinition)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyValue ► FrequencyValue(IDataCell, IFrequencyDefinition)
Creates a new FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyValue(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    frequencyDefinition As IFrequencyDefinition _
)
public:
FrequencyValue(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this FrequencyValue.
frequencyDefinition (IFrequencyDefinition)
The IFrequencyDefinition associated with this FrequencyValue.


FrequencyValue Constructor (parent, frequencyDefinition, frequency, dfdt)

FrequencyValue Constructor (parent, frequencyDefinition, frequency, dfdt)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyValue ► FrequencyValue(DataCell, FrequencyDefinition, Double, Double)
Creates a new FrequencyValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyValue(
    DataCell parent,
    FrequencyDefinition frequencyDefinition,
    double frequency,
    double dfdt
)
Public Sub New ( _
    parent As DataCell, _
    frequencyDefinition As FrequencyDefinition, _
    frequency As Double, _
    dfdt As Double _
)
public:
FrequencyValue(
    DataCell^ parent,
    FrequencyDefinition^ frequencyDefinition,
    double frequency,
    double dfdt
)
Parameters
parent (DataCell)
The DataCell parent of this FrequencyValue.
frequencyDefinition (FrequencyDefinition)
The FrequencyDefinition associated with this FrequencyValue.
frequency (Double)
The floating point value that represents this FrequencyValue.
dfdt (Double)
The floating point value that represents the change in this FrequencyValue over time.


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyValue ► BodyImage
Gets the binary body image of the FrequencyValue object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}
Remarks
The IEEE 1344 protocol provides frequency and df/dt as optional data measurements, so we override the default behavior to account for this change in operation.


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyValue ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}
Remarks
The IEEE 1344 protocol provides frequency and df/dt as optional data measurements, so we override the default behavior to account for this change in operation.


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyValue ► Definition
Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual FrequencyDefinition Definition { get; set; }
Public Overridable Property Definition As FrequencyDefinition
    Get
    Set
public:
virtual property FrequencyDefinition^ Definition {
    FrequencyDefinition^ get ();
    void set (FrequencyDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyValue ► Parent
Gets or sets the DataCell parent of this FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyValue ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
The IEEE 1344 protocol provides frequency and df/dt as optional data measurements, so we override the default behavior to account for this change in operation.


HeaderFrame Class

HeaderFrame Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame
Represents the IEEE 1344 implementation of a IHeaderFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class HeaderFrame : HeaderFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
<SerializableAttribute> _
Public Class HeaderFrame _
    Inherits HeaderFrameBase _
    Implements ISupportFrameImage(Of FrameType), ISupportBinaryImage
[SerializableAttribute]
public ref class HeaderFrame : public HeaderFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HeaderFrame()()()() | Creates a new HeaderFrame.
 | HeaderFrame(SerializationInfo, StreamingContext) | Creates a new HeaderFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the HeaderFrame object. (Overrides HeaderFrameBase.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' IHeaderCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the HeaderCellCollection for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CommonHeader | Gets or sets current CommonFrameHeader.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameType | Gets the FundamentalFrameType for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelFrameBase <(Of <(<' IHeaderCell >)>)>.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderData | Gets or sets header data for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
 | HeaderImage | Gets the binary header image of the HeaderFrame object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets or sets the ID code of this HeaderFrame.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Overrides ChannelFrameBase <(Of <(<' IHeaderCell >)>)>.Initialize(array<Byte>[]()[][], Int32, Int32).)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides BinaryImageBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this HeaderFrameBase. (Inherited from HeaderFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this HeaderFrame. (Overrides ChannelFrameBase <(Of <(<' IHeaderCell >)>)>.Timestamp.)
 | TimeTag | Gets the timestamp of this frame in NTP format.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets the identifier that is used to identify the IEEE 1344 frame.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IHeaderCell >)>)>
 |  |  |  | HeaderFrameBase
 |  |  |  |  | HeaderFrame


HeaderFrame Constructor

HeaderFrame Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► HeaderFrame()()()()
Members
Icon | Member | Description
 | HeaderFrame()()()() | Creates a new HeaderFrame.
 | HeaderFrame(SerializationInfo, StreamingContext) | Creates a new HeaderFrame from serialization parameters.


HeaderFrame Constructor

HeaderFrame Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► HeaderFrame()()()()
Creates a new HeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public HeaderFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Sub New
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
HeaderFrame()
Remarks
This constructor is used by a consumer to generate an IEEE 1344 configuration frame and by the FrameImageParserBase to parse an IEEE 1344 configuration frame.


HeaderFrame Constructor (info, context)

HeaderFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► HeaderFrame(SerializationInfo, StreamingContext)
Creates a new HeaderFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected HeaderFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
HeaderFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the HeaderFrame object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.


CommonHeader Property

CommonHeader Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► CommonHeader
Gets or sets current CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► HeaderImage
Gets the binary header image of the HeaderFrame object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► IDCode
Gets or sets the ID code of this HeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ulong IDCode { get; set; }
Public Property IDCode As ULong
    Get
    Set
public:
property unsigned long long IDCode {
    unsigned long long get ();
    void set (unsigned long long value);
}


Initialize Method (binaryImage, startIndex, length)

Initialize Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► Initialize(array<Byte>[]()[][], Int32, Int32)
Parses the binary image.
Declaration Syntax
C# Visual Basic Visual C++
public override int Initialize(
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Overrides Function Initialize ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
public:
virtual int Initialize(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
This method is overriden to parse from cumulated frame images.


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


Timestamp Property

Timestamp Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► Timestamp
Gets or sets exact timestamp, in ticks, of the data represented by this HeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


TimeTag Property

TimeTag Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► TimeTag
Gets the timestamp of this frame in NTP format.
Declaration Syntax
C# Visual Basic Visual C++
public NtpTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As NtpTimeTag
    Get
public:
property NtpTimeTag^ TimeTag {
    NtpTimeTag^ get ();
}


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► TypeID
Gets the identifier that is used to identify the IEEE 1344 frame.
Declaration Syntax
C# Visual Basic Visual C++
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}


PhasorDefinition Class

PhasorDefinition Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► PhasorDefinition
Represents the IEEE 1344 implementation of a IPhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PhasorDefinition : PhasorDefinitionBase
<SerializableAttribute> _
Public Class PhasorDefinition _
    Inherits PhasorDefinitionBase
[SerializableAttribute]
public ref class PhasorDefinition : public PhasorDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | PhasorDefinitionBase
 |  |  |  |  | PhasorDefinition


PhasorDefinition Constructor

PhasorDefinition Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► PhasorDefinition ► PhasorDefinition()()()()
Members
Icon | Member | Description
 | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.


PhasorDefinition Constructor (info, context)

PhasorDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► PhasorDefinition ► PhasorDefinition(SerializationInfo, StreamingContext)
Creates a new PhasorDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


PhasorDefinition Constructor (parent)

PhasorDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► PhasorDefinition ► PhasorDefinition(IConfigurationCell)
Creates a new PhasorDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
PhasorDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this PhasorDefinition.


PhasorDefinition Constructor (parent, label, scale, offset, type, voltageReference)

PhasorDefinition Constructor (parent, label, scale, offset, type, voltageReference)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► PhasorDefinition ► PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition)
Creates a new PhasorDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinition(
    ConfigurationCell parent,
    string label,
    uint scale,
    double offset,
    PhasorType type,
    PhasorDefinition voltageReference
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String, _
    scale As UInteger, _
    offset As Double, _
    type As PhasorType, _
    voltageReference As PhasorDefinition _
)
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset,
    PhasorType type,
    PhasorDefinition^ voltageReference
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this PhasorDefinition.
label (String)
The label of this PhasorDefinition.
scale (UInt32)
The integer scaling value of this PhasorDefinition.
offset (Double)
The offset of this PhasorDefinition.
type (PhasorType)
The PhasorType of this PhasorDefinition.
voltageReference (PhasorDefinition)
The associated IPhasorDefinition that represents the voltage reference (if any).


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► PhasorDefinition ► Parent
Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


PhasorValue Class

PhasorValue Class
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► PhasorValue
Represents the IEEE 1344 implementation of a IPhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PhasorValue : PhasorValueBase
<SerializableAttribute> _
Public Class PhasorValue _
    Inherits PhasorValueBase
[SerializableAttribute]
public ref class PhasorValue : public PhasorValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
 | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
 | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
 | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
 | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this PhasorValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from PhasorValueBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IPhasorDefinition >)>)>
 |  |  |  | PhasorValueBase
 |  |  |  |  | PhasorValue


PhasorValue Constructor

PhasorValue Constructor
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► PhasorValue ► PhasorValue()()()()
Members
Icon | Member | Description
 | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
 | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.


PhasorValue Constructor (info, context)

PhasorValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► PhasorValue ► PhasorValue(SerializationInfo, StreamingContext)
Creates a new PhasorValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


PhasorValue Constructor (parent, phasorDefinition)

PhasorValue Constructor (parent, phasorDefinition)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► PhasorValue ► PhasorValue(IDataCell, IPhasorDefinition)
Creates a new PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    IDataCell parent,
    IPhasorDefinition phasorDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    phasorDefinition As IPhasorDefinition _
)
public:
PhasorValue(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this PhasorValue.
phasorDefinition (IPhasorDefinition)
The IPhasorDefinition associated with this PhasorValue.


PhasorValue Constructor (parent, phasorDefinition, real, imaginary)

PhasorValue Constructor (parent, phasorDefinition, real, imaginary)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► PhasorValue ► PhasorValue(DataCell, PhasorDefinition, Double, Double)
Creates a new PhasorValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    double real,
    double imaginary
)
Public Sub New ( _
    parent As DataCell, _
    phasorDefinition As PhasorDefinition, _
    real As Double, _
    imaginary As Double _
)
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    double real,
    double imaginary
)
Parameters
parent (DataCell)
The DataCell parent of this PhasorValue.
phasorDefinition (PhasorDefinition)
The PhasorDefinition associated with this PhasorValue.
real (Double)
The real value of this PhasorValue.
imaginary (Double)
The imaginary value of this PhasorValue.


PhasorValue Constructor (parent, phasorDefinition, angle, magnitude)

PhasorValue Constructor (parent, phasorDefinition, angle, magnitude)
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► PhasorValue ► PhasorValue(DataCell, PhasorDefinition, Angle, Double)
Creates a new PhasorValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    Angle angle,
    double magnitude
)
Public Sub New ( _
    parent As DataCell, _
    phasorDefinition As PhasorDefinition, _
    angle As Angle, _
    magnitude As Double _
)
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    Angle angle,
    double magnitude
)
Parameters
parent (DataCell)
The DataCell parent of this PhasorValue.
phasorDefinition (PhasorDefinition)
The PhasorDefinition associated with this PhasorValue.
angle (Angle)
The Angle value (a.k.a., the argument) of this PhasorValue, in radians.
magnitude (Double)
The magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue.


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► PhasorValue ► Definition
Gets or sets the PhasorDefinition associated with this PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual PhasorDefinition Definition { get; set; }
Public Overridable Property Definition As PhasorDefinition
    Get
    Set
public:
virtual property PhasorDefinition^ Definition {
    PhasorDefinition^ get ();
    void set (PhasorDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► PhasorValue ► Parent
Gets or sets the DataCell parent of this PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


TriggerStatus Enumeration

TriggerStatus Enumeration
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► TriggerStatus
IEEE 1344 trigger status enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum TriggerStatus
<SerializableAttribute> _
Public Enumeration TriggerStatus
[SerializableAttribute]
public enum class TriggerStatus
Members
Member | Description
FrequencyTrigger | 111 Frequency trigger.
DfDtTrigger | 110 df/dt trigger.
AngleTrigger | 101 Angle trigger.
OverCurrentTrigger | 100 Overcurrent trigger.
UnderVoltageTrigger | 011 Undervoltage trigger.
RateTrigger | 010 Rate trigger.
UserDefined | 001 User defined.
Unused | 000 Unused.


TVA.PhasorProtocols.IeeeC37_118 Namespace

TVA.PhasorProtocols.IeeeC37_118 Namespace
Namespaces ► TVA.PhasorProtocols.IeeeC37_118
Contains an implementation of the phasor classes used to parse or generate a stream of data in the IEEE C37.118-2005 standard format.
Declaration Syntax
C# Visual Basic Visual C++
namespace TVA.PhasorProtocols.IeeeC37_118
Namespace TVA.PhasorProtocols.IeeeC37_118
namespace TVA.PhasorProtocols.IeeeC37_118
Types
All Types Classes Enumerations
Icon | Type | Description
 | AnalogDefinition | Represents the IEEE C37.118 implementation of an IAnalogDefinition.
 | AnalogValue | Represents the IEEE C37.118 implementation of an IAnalogValue.
 | CommandFrame | Represents the IEEE C37.118 implementation of a ICommandFrame that can be sent or received.
 | Common | Common IEEE C37.118 declarations and functions.
 | CommonFrameHeader | Represents the common header for all IEEE C37.118 frames of data.
 | Concentrator | Represents an IEEE C37.118 phasor data concentrator.
 | ConfigurationCell | Represents the IEEE C37.118 implementation of a IConfigurationCell that can be sent or received.
 | ConfigurationCellCollection | Represents a IEEE C37.118 implementation of a collection of IConfigurationCell objects.
 | ConfigurationFrame1 | Represents the IEEE C37.118 implementation of a IConfigurationFrame, type 1, that can be sent or received.
 | ConfigurationFrame1Draft6 | Represents the IEEE C37.118 draft 6 implementation of a IConfigurationFrame, type 1, that can be sent or received.
 | ConfigurationFrame2 | Represents the IEEE C37.118 implementation of a IConfigurationFrame, type 2, that can be sent or received.
 | ConfigurationFrame2Draft6 | Represents the IEEE C37.118 draft 6 implementation of a IConfigurationFrame, type 2, that can be sent or received.
 | DataCell | Represents the IEEE C37.118 implementation of a IDataCell that can be sent or received.
 | DataCellCollection | Represents a IEEE C37.118 implementation of a collection of IDataCell objects.
 | DataFrame | Represents the IEEE C37.118 implementation of a IDataFrame that can be sent or received.
 | DigitalDefinition | Represents the IEEE C37.118 implementation of a IDigitalDefinition.
 | DigitalValue | Represents the IEEE C37.118 implementation of a IDigitalValue.
 | DraftRevision | Protocol draft revision numbers enumeration.
 | FormatFlags | Data format flags enumeration.
 | FrameParser | Represents a frame parser for an IEEE C37.118 binary data stream and returns parsed data via events.
 | FrameType | IEEE C37.118 frame types enumeration.
 | FrequencyDefinition | Represents the IEEE C37.118 implementation of a IFrequencyDefinition.
 | FrequencyValue | Represents the IEEE C37.118 implementation of a IFrequencyValue.
 | HeaderFrame | Represents the IEEE C37.118 implementation of a IHeaderFrame that can be sent or received.
 | PhasorDefinition | Represents the IEEE C37.118 implementation of a IPhasorDefinition.
 | PhasorValue | Represents the IEEE C37.118 implementation of a IPhasorValue.
 | StatusFlags | Status flags enumeration.
 | TimeQualityFlags | Time quality flags enumeration.
 | TimeQualityIndicatorCode | Time quality indicator code enumeration.
 | TriggerReason | Trigger reason enumeration.
 | UnlockedTime | Unlocked time enumeration.


AnalogDefinition Class

AnalogDefinition Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► AnalogDefinition
Represents the IEEE C37.118 implementation of an IAnalogDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class AnalogDefinition : AnalogDefinitionBase
<SerializableAttribute> _
Public Class AnalogDefinition _
    Inherits AnalogDefinitionBase
[SerializableAttribute]
public ref class AnalogDefinition : public AnalogDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalogDefinition(IConfigurationCell) | Creates a new AnalogDefinition from specified parameters.
 | AnalogDefinition(ConfigurationCell, String, UInt32, Double, AnalogType) | Creates a new AnalogDefinition from specified parameters.
 | AnalogDefinition(SerializationInfo, StreamingContext) | Creates a new AnalogDefinition from serialization parameters.
 | AnalogType | Gets or sets AnalogType of this AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this AnalogDefinitionBase object. (Inherited from AnalogDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | DataFormat | Gets the DataFormat for the AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this AnalogDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | AnalogDefinitionBase
 |  |  |  |  | AnalogDefinition


AnalogDefinition Constructor

AnalogDefinition Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► AnalogDefinition ► AnalogDefinition()()()()
Members
Icon | Member | Description
 | AnalogDefinition(IConfigurationCell) | Creates a new AnalogDefinition from specified parameters.
 | AnalogDefinition(ConfigurationCell, String, UInt32, Double, AnalogType) | Creates a new AnalogDefinition from specified parameters.
 | AnalogDefinition(SerializationInfo, StreamingContext) | Creates a new AnalogDefinition from serialization parameters.


AnalogDefinition Constructor (info, context)

AnalogDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► AnalogDefinition ► AnalogDefinition(SerializationInfo, StreamingContext)
Creates a new AnalogDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected AnalogDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
AnalogDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


AnalogDefinition Constructor (parent)

AnalogDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► AnalogDefinition ► AnalogDefinition(IConfigurationCell)
Creates a new AnalogDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public AnalogDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
AnalogDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this AnalogDefinition.


AnalogDefinition Constructor (parent, label, scale, offset, type)

AnalogDefinition Constructor (parent, label, scale, offset, type)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► AnalogDefinition ► AnalogDefinition(ConfigurationCell, String, UInt32, Double, AnalogType)
Creates a new AnalogDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public AnalogDefinition(
    ConfigurationCell parent,
    string label,
    uint scale,
    double offset,
    AnalogType type
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String, _
    scale As UInteger, _
    offset As Double, _
    type As AnalogType _
)
public:
AnalogDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset,
    AnalogType type
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this AnalogDefinition.
label (String)
The label of this AnalogDefinition.
scale (UInt32)
The integer scaling value of this AnalogDefinition.
offset (Double)
The offset of this AnalogDefinition.
type (AnalogType)
The AnalogType of this AnalogDefinition.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► AnalogDefinition ► Parent
Gets or sets the ConfigurationCell parent of this AnalogDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


AnalogValue Class

AnalogValue Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► AnalogValue
Represents the IEEE C37.118 implementation of an IAnalogValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class AnalogValue : AnalogValueBase
<SerializableAttribute> _
Public Class AnalogValue _
    Inherits AnalogValueBase
[SerializableAttribute]
public ref class AnalogValue : public AnalogValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalogValue(IDataCell, IAnalogDefinition) | Creates a new AnalogValue.
 | AnalogValue(DataCell, AnalogDefinition, Double) | Creates a new AnalogValue from specified parameters.
 | AnalogValue(SerializationInfo, StreamingContext) | Creates a new AnalogValue from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the AnalogValueBase object. (Inherited from AnalogValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the AnalogValueBase object. (Inherited from AnalogValueBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from AnalogValueBase.)
 | CompositeValueCount | Gets total number of composite values that this AnalogValueBase provides. (Inherited from AnalogValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the AnalogDefinition associated with this AnalogValue.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this AnalogValueBase. (Inherited from AnalogValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IntegerValue | Gets or sets the integer representation of this AnalogValueBase value. (Inherited from AnalogValueBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of AnalogValueBase have been assigned a value. (Inherited from AnalogValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this AnalogValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from AnalogValueBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets the floating point value that represents this AnalogValueBase. (Inherited from AnalogValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IAnalogDefinition >)>)>
 |  |  |  | AnalogValueBase
 |  |  |  |  | AnalogValue


AnalogValue Constructor

AnalogValue Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► AnalogValue ► AnalogValue()()()()
Members
Icon | Member | Description
 | AnalogValue(IDataCell, IAnalogDefinition) | Creates a new AnalogValue.
 | AnalogValue(DataCell, AnalogDefinition, Double) | Creates a new AnalogValue from specified parameters.
 | AnalogValue(SerializationInfo, StreamingContext) | Creates a new AnalogValue from serialization parameters.


AnalogValue Constructor (info, context)

AnalogValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► AnalogValue ► AnalogValue(SerializationInfo, StreamingContext)
Creates a new AnalogValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected AnalogValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
AnalogValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


AnalogValue Constructor (parent, analogDefinition)

AnalogValue Constructor (parent, analogDefinition)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► AnalogValue ► AnalogValue(IDataCell, IAnalogDefinition)
Creates a new AnalogValue.
Declaration Syntax
C# Visual Basic Visual C++
public AnalogValue(
    IDataCell parent,
    IAnalogDefinition analogDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    analogDefinition As IAnalogDefinition _
)
public:
AnalogValue(
    IDataCell^ parent,
    IAnalogDefinition^ analogDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this AnalogValue.
analogDefinition (IAnalogDefinition)
The IAnalogDefinition associated with this AnalogValue.


AnalogValue Constructor (parent, analogDefinition, value)

AnalogValue Constructor (parent, analogDefinition, value)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► AnalogValue ► AnalogValue(DataCell, AnalogDefinition, Double)
Creates a new AnalogValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public AnalogValue(
    DataCell parent,
    AnalogDefinition analogDefinition,
    double value
)
Public Sub New ( _
    parent As DataCell, _
    analogDefinition As AnalogDefinition, _
    value As Double _
)
public:
AnalogValue(
    DataCell^ parent,
    AnalogDefinition^ analogDefinition,
    double value
)
Parameters
parent (DataCell)
The DataCell parent of this AnalogValue.
analogDefinition (AnalogDefinition)
The AnalogDefinition associated with this AnalogValue.
value (Double)
The floating point value that represents this AnalogValue.


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► AnalogValue ► Definition
Gets or sets the AnalogDefinition associated with this AnalogValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual AnalogDefinition Definition { get; set; }
Public Overridable Property Definition As AnalogDefinition
    Get
    Set
public:
virtual property AnalogDefinition^ Definition {
    AnalogDefinition^ get ();
    void set (AnalogDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► AnalogValue ► Parent
Gets or sets the DataCell parent of this AnalogValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


CommandFrame Class

CommandFrame Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommandFrame
Represents the IEEE C37.118 implementation of a ICommandFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CommandFrame : CommandFrameBase
<SerializableAttribute> _
Public Class CommandFrame _
    Inherits CommandFrameBase
[SerializableAttribute]
public ref class CommandFrame : public CommandFrameBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandFrame(array<Byte>[]()[][], Int32, Int32) | Creates a new CommandFrame from the given binaryImage.
 | CommandFrame(UInt16, DeviceCommand, Byte) | Creates a new CommandFrame from specified parameters.
 | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataFrame object. (Overrides CommandFrameBase.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this CommandFrameBase. (Inherited from CommandFrameBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from CommandFrameBase.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' ICommandCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the CommandCellCollection for this CommandFrameBase. (Inherited from CommandFrameBase.)
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Command | Gets or sets the DeviceCommand for this CommandFrameBase. (Inherited from CommandFrameBase.)
 | CommonHeader | Gets or sets current CommonFrameHeader.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ExtendedData | Gets or sets extended binary image data for this CommandFrameBase. (Inherited from CommandFrameBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Inherited from CommandFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides CommandFrameBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from CommandFrameBase.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides BinaryImageBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this CommandFrameBase. (Inherited from CommandFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame. (Overrides ChannelFrameBase <(Of <(<' ICommandCell >)>)>.Timestamp.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version | Gets the IEEE C37.118 protocol version of this CommandFrame.
Remarks
IEEE C37.118 command frames are designed only to be sent to a device, not received from a device. As a result this frame does not implement ISupportFrameImage for automated frame parsing. This class exposes a constructor that accepts a binary image in order to manually parse a command frame.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' ICommandCell >)>)>
 |  |  |  | CommandFrameBase
 |  |  |  |  | CommandFrame


CommandFrame Constructor

CommandFrame Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommandFrame ► CommandFrame()()()()
Members
Icon | Member | Description
 | CommandFrame(array<Byte>[]()[][], Int32, Int32) | Creates a new CommandFrame from the given binaryImage.
 | CommandFrame(UInt16, DeviceCommand, Byte) | Creates a new CommandFrame from specified parameters.
 | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.


CommandFrame Constructor (binaryImage, startIndex, length)

CommandFrame Constructor (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommandFrame ► CommandFrame(array<Byte>[]()[][], Int32, Int32)
Creates a new CommandFrame from the given binaryImage.
Declaration Syntax
C# Visual Basic Visual C++
public CommandFrame(
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Sub New ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
)
public:
CommandFrame(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
)
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Remarks
This constructor is used by a consumer to parse a received IEEE C37.118 command frame. Typically command frames are sent to a device. This constructor would used if this code was being used inside of a phasor measurement device.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | length is not large enough to parse frame.


CommandFrame Constructor (info, context)

CommandFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommandFrame ► CommandFrame(SerializationInfo, StreamingContext)
Creates a new CommandFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected CommandFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CommandFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


CommandFrame Constructor (idCode, command, version)

CommandFrame Constructor (idCode, command, version)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommandFrame ► CommandFrame(UInt16, DeviceCommand, Byte)
Creates a new CommandFrame from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public CommandFrame(
    ushort idCode,
    DeviceCommand command,
    byte version
)
Public Sub New ( _
    idCode As UShort, _
    command As DeviceCommand, _
    version As Byte _
)
public:
CommandFrame(
    unsigned short idCode,
    DeviceCommand command,
    unsigned char version
)
Parameters
idCode (UInt16)
The ID code of this CommandFrame.
command (DeviceCommand)
The DeviceCommand for this CommandFrame.
version (Byte)
IEEE C37.118 revision number.
Remarks
This constructor is used by a consumer to generate an IEEE C37.118 command frame.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommandFrame ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataFrame object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommandFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.


CommonHeader Property

CommonHeader Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommandFrame ► CommonHeader
Gets or sets current CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommandFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommandFrame ► HeaderImage
Gets the binary header image of the DataFrame object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommandFrame ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommandFrame ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


Timestamp Property

Timestamp Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommandFrame ► Timestamp
Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


Version Property

Version Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommandFrame ► Version
Gets the IEEE C37.118 protocol version of this CommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
public byte Version { get; set; }
Public Property Version As Byte
    Get
    Set
public:
property unsigned char Version {
    unsigned char get ();
    void set (unsigned char value);
}


Common Class

Common Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Common
Common IEEE C37.118 declarations and functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class Common
Public NotInheritable Class Common
public ref class Common abstract sealed
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
 | MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
 | MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
 | MaximumExtendedDataLength | Absolute maximum number of bytes of extended data that could fit into a command frame.
 | MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
 | TimeQualityFlagsMask | Time quality flags mask.
Inheritance Hierarchy
Object
Common


MaximumAnalogValues Field

MaximumAnalogValues Field
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Common ► MaximumAnalogValues
Absolute maximum number of possible analog values that could fit into a data frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumAnalogValues
Public Const MaximumAnalogValues As UShort
public:
literal unsigned short MaximumAnalogValues


MaximumDataLength Field

MaximumDataLength Field
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Common ► MaximumDataLength
Absolute maximum data length (in bytes) that could fit into any frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumDataLength
Public Const MaximumDataLength As UShort
public:
literal unsigned short MaximumDataLength


MaximumDigitalValues Field

MaximumDigitalValues Field
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Common ► MaximumDigitalValues
Absolute maximum number of possible digital values that could fit into a data frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumDigitalValues
Public Const MaximumDigitalValues As UShort
public:
literal unsigned short MaximumDigitalValues


MaximumExtendedDataLength Field

MaximumExtendedDataLength Field
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Common ► MaximumExtendedDataLength
Absolute maximum number of bytes of extended data that could fit into a command frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumExtendedDataLength
Public Const MaximumExtendedDataLength As UShort
public:
literal unsigned short MaximumExtendedDataLength


MaximumPhasorValues Field

MaximumPhasorValues Field
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Common ► MaximumPhasorValues
Absolute maximum number of possible phasor values that could fit into a data frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumPhasorValues
Public Const MaximumPhasorValues As UShort
public:
literal unsigned short MaximumPhasorValues


TimeQualityFlagsMask Field

TimeQualityFlagsMask Field
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Common ► TimeQualityFlagsMask
Time quality flags mask.
Declaration Syntax
C# Visual Basic Visual C++
public const uint TimeQualityFlagsMask
Public Const TimeQualityFlagsMask As UInteger
public:
literal unsigned int TimeQualityFlagsMask


CommonFrameHeader Class

CommonFrameHeader Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader
Represents the common header for all IEEE C37.118 frames of data.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CommonFrameHeader : ICommonHeader<FrameType>,
    ISerializable
<SerializableAttribute> _
Public Class CommonFrameHeader _
    Implements ICommonHeader(Of FrameType), ISerializable
[SerializableAttribute]
public ref class CommonFrameHeader : ICommonHeader<FrameType>,
    ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommonFrameHeader(FrameType, UInt16, Ticks) | Creates a new CommonFrameHeader from specified parameters.
 | CommonFrameHeader(ConfigurationFrame1, array<Byte>[]()[][], Int32) | Creates a new CommonFrameHeader from given binaryImage.
 | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
 | BinaryImage | Gets the binary image of the common header portion of this frame.
 | DataLength | Gets or sets the length of the data in the IEEE C37.118 frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FixedLength | Total fixed length of CommonFrameHeader.
 | FractionOfSecond | Gets the IEEE C37.118 fraction of second.
 | FrameLength | Gets or sets the IEEE C37.118 frame length of this frame.
 | FrameType | Gets the fundamental frame type of this frame.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IDCode | Gets or sets the IEEE C37.118 ID code of this frame.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SecondOfCentury | Gets the IEEE C37.118 second of century.
 | State | Gets or sets the parsing state for the CommonFrameHeader object.
 | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps.
 | TimeQualityFlags | Gets or sets the IEEE C37.118 TimeQualityFlags.
 | TimeQualityIndicatorCode | Gets or sets the IEEE C37.118 TimeQualityIndicatorCode.
 | Timestamp | Gets or sets timestamp of this CommonFrameHeader.
 | TimeTag | Gets time as a UnixTimeTag representing seconds of current Timestamp.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets or sets the IEEE C37.118 specific frame type of this frame.
 | Version | Gets or sets the IEEE C37.118 version of this frame.
Inheritance Hierarchy
Object
CommonFrameHeader


CommonFrameHeader Constructor

CommonFrameHeader Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► CommonFrameHeader()()()()
Members
Icon | Member | Description
 | CommonFrameHeader(FrameType, UInt16, Ticks) | Creates a new CommonFrameHeader from specified parameters.
 | CommonFrameHeader(ConfigurationFrame1, array<Byte>[]()[][], Int32) | Creates a new CommonFrameHeader from given binaryImage.
 | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.


CommonFrameHeader Constructor (info, context)

CommonFrameHeader Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► CommonFrameHeader(SerializationInfo, StreamingContext)
Creates a new CommonFrameHeader from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected CommonFrameHeader(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CommonFrameHeader(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


CommonFrameHeader Constructor (configurationFrame, binaryImage, startIndex)

CommonFrameHeader Constructor (configurationFrame, binaryImage, startIndex)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► CommonFrameHeader(ConfigurationFrame1, array<Byte>[]()[][], Int32)
Creates a new CommonFrameHeader from given binaryImage.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader(
    ConfigurationFrame1 configurationFrame,
    byte[] binaryImage,
    int startIndex
)
Public Sub New ( _
    configurationFrame As ConfigurationFrame1, _
    binaryImage As Byte(), _
    startIndex As Integer _
)
public:
CommonFrameHeader(
    ConfigurationFrame1^ configurationFrame,
    array<unsigned char>^ binaryImage,
    int startIndex
)
Parameters
configurationFrame (ConfigurationFrame1)
IEEE C37.118 ConfigurationFrame1 if already parsed.
binaryImage (array< Byte >[]()[][])
Buffer that contains data to parse.
startIndex (Int32)
Start index into buffer where valid data begins.


CommonFrameHeader Constructor (typeID, idCode, timestamp)

CommonFrameHeader Constructor (typeID, idCode, timestamp)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► CommonFrameHeader(FrameType, UInt16, Ticks)
Creates a new CommonFrameHeader from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader(
    FrameType typeID,
    ushort idCode,
    Ticks timestamp
)
Public Sub New ( _
    typeID As FrameType, _
    idCode As UShort, _
    timestamp As Ticks _
)
public:
CommonFrameHeader(
    FrameType typeID,
    unsigned short idCode,
    Ticks timestamp
)
Parameters
typeID (FrameType)
The IEEE C37.118 specific frame type of this frame.
idCode (UInt16)
The ID code of this frame.
timestamp (Ticks)
The timestamp of this frame.


BinaryImage Property

BinaryImage Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► BinaryImage
Gets the binary image of the common header portion of this frame.
Declaration Syntax
C# Visual Basic Visual C++
public byte[] BinaryImage { get; }
Public ReadOnly Property BinaryImage As Byte()
    Get
public:
property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get ();
}


DataLength Property

DataLength Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► DataLength
Gets or sets the length of the data in the IEEE C37.118 frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).
Declaration Syntax
C# Visual Basic Visual C++
public ushort DataLength { get; set; }
Public Property DataLength As UShort
    Get
    Set
public:
property unsigned short DataLength {
    unsigned short get ();
    void set (unsigned short value);
}


FixedLength Field

FixedLength Field
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► FixedLength
Total fixed length of CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort FixedLength
Public Const FixedLength As UShort
public:
literal unsigned short FixedLength


FractionOfSecond Property

FractionOfSecond Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► FractionOfSecond
Gets the IEEE C37.118 fraction of second.
Declaration Syntax
C# Visual Basic Visual C++
public UInt24 FractionOfSecond { get; }
Public ReadOnly Property FractionOfSecond As UInt24
    Get
public:
property UInt24 FractionOfSecond {
    UInt24 get ();
}


FrameLength Property

FrameLength Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► FrameLength
Gets or sets the IEEE C37.118 frame length of this frame.
Declaration Syntax
C# Visual Basic Visual C++
public ushort FrameLength { get; set; }
Public Property FrameLength As UShort
    Get
    Set
public:
property unsigned short FrameLength {
    unsigned short get ();
    void set (unsigned short value);
}


FrameType Property

FrameType Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► FrameType
Gets the fundamental frame type of this frame.
Declaration Syntax
C# Visual Basic Visual C++
public FundamentalFrameType FrameType { get; }
Public ReadOnly Property FrameType As FundamentalFrameType
    Get
public:
property FundamentalFrameType FrameType {
    FundamentalFrameType get ();
}
Remarks
Frames are generally classified as data, configuration or header frames. This returns the general frame classification.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► IDCode
Gets or sets the IEEE C37.118 ID code of this frame.
Declaration Syntax
C# Visual Basic Visual C++
public ushort IDCode { get; set; }
Public Property IDCode As UShort
    Get
    Set
public:
property unsigned short IDCode {
    unsigned short get ();
    void set (unsigned short value);
}


SecondOfCentury Property

SecondOfCentury Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► SecondOfCentury
Gets the IEEE C37.118 second of century.
Declaration Syntax
C# Visual Basic Visual C++
public uint SecondOfCentury { get; }
Public ReadOnly Property SecondOfCentury As UInteger
    Get
public:
property unsigned int SecondOfCentury {
    unsigned int get ();
}


State Property

State Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► State
Gets or sets the parsing state for the CommonFrameHeader object.
Declaration Syntax
C# Visual Basic Visual C++
public IChannelParsingState State { get; set; }
Public Property State As IChannelParsingState
    Get
    Set
public:
property IChannelParsingState^ State {
    IChannelParsingState^ get ();
    void set (IChannelParsingState^ value);
}


Timebase Property

Timebase Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► Timebase
Gets or sets the IEEE C37.118 resolution of fractional time stamps.
Declaration Syntax
C# Visual Basic Visual C++
public uint Timebase { get; set; }
Public Property Timebase As UInteger
    Get
    Set
public:
property unsigned int Timebase {
    unsigned int get ();
    void set (unsigned int value);
}


TimeQualityFlags Property

TimeQualityFlags Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► TimeQualityFlags
Gets or sets the IEEE C37.118 TimeQualityFlags.
Declaration Syntax
C# Visual Basic Visual C++
public TimeQualityFlags TimeQualityFlags { get; set; }
Public Property TimeQualityFlags As TimeQualityFlags
    Get
    Set
public:
property TimeQualityFlags TimeQualityFlags {
    TimeQualityFlags get ();
    void set (TimeQualityFlags value);
}


TimeQualityIndicatorCode Property

TimeQualityIndicatorCode Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► TimeQualityIndicatorCode
Gets or sets the IEEE C37.118 TimeQualityIndicatorCode.
Declaration Syntax
C# Visual Basic Visual C++
public TimeQualityIndicatorCode TimeQualityIndicatorCode { get; set; }
Public Property TimeQualityIndicatorCode As TimeQualityIndicatorCode
    Get
    Set
public:
property TimeQualityIndicatorCode TimeQualityIndicatorCode {
    TimeQualityIndicatorCode get ();
    void set (TimeQualityIndicatorCode value);
}


Timestamp Property

Timestamp Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► Timestamp
Gets or sets timestamp of this CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public Ticks Timestamp { get; set; }
Public Property Timestamp As Ticks
    Get
    Set
public:
property Ticks Timestamp {
    Ticks get ();
    void set (Ticks value);
}


TimeTag Property

TimeTag Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► TimeTag
Gets time as a UnixTimeTag representing seconds of current Timestamp.
Declaration Syntax
C# Visual Basic Visual C++
public UnixTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As UnixTimeTag
    Get
public:
property UnixTimeTag^ TimeTag {
    UnixTimeTag^ get ();
}


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► TypeID
Gets or sets the IEEE C37.118 specific frame type of this frame.
Declaration Syntax
C# Visual Basic Visual C++
public FrameType TypeID { get; set; }
Public Property TypeID As FrameType
    Get
    Set
public:
virtual property FrameType TypeID {
    FrameType get () sealed;
    void set (FrameType value) sealed;
}
Remarks

This returns the protocol specific frame classification which uniquely identifies the frame type.

This is the TypeID()()()() implementation.


Version Property

Version Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommonFrameHeader ► Version
Gets or sets the IEEE C37.118 version of this frame.
Declaration Syntax
C# Visual Basic Visual C++
public byte Version { get; set; }
Public Property Version As Byte
    Get
    Set
public:
property unsigned char Version {
    unsigned char get ();
    void set (unsigned char value);
}


Concentrator Class

Concentrator Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Concentrator
Represents an IEEE C37.118 phasor data concentrator.
Declaration Syntax
C# Visual Basic Visual C++
public class Concentrator : PhasorDataConcentratorBase
Public Class Concentrator _
    Inherits PhasorDataConcentratorBase
public ref class Concentrator : public PhasorDataConcentratorBase
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Concentrator()()()() | Initializes a new instance of the Concentrator class
 | ActiveConnections | Gets the total number of active socket connections. (Inherited from PhasorDataConcentratorBase.)
 | AllowPreemptivePublishing()()()() | (Inherited from ConcentratorBase.)
 | AllowSortsByArrival()()()() | (Inherited from ConcentratorBase.)
 | AnalogScalingValue | Gets or sets the integer scaling value to apply to analog values published by this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | AssignMeasurementToFrame(IFrame, IMeasurement) | Assign IMeasurement to its IFrame. (Inherited from PhasorDataConcentratorBase.)
 | AssignParentCollection(IAdapterCollection) | (Inherited from ActionAdapterBase.)
 | AutoPublishConfigurationFrame | Gets or sets flag that determines if configuration frame should be automatically published at the top of each minute on the data channel. (Inherited from PhasorDataConcentratorBase.)
 | AutoStart()()()() | (Inherited from ActionAdapterBase.)
 | AutoStartDataChannel | Gets or sets flag that determines if concentrator will automatically start data channel. (Inherited from PhasorDataConcentratorBase.)
 | AverageLatency | Gets the average latency in milliseconds over the last test interval. (Inherited from PhasorDataConcentratorBase.)
 | AveragePublicationTimePerFrame()()()() | (Inherited from ConcentratorBase.)
 | BaseConfigurationFrame | Gets the protocol independent ConfigurationFrame defined for this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | CacheConfigurationFrame(IConfigurationFrame, String) | Serialize configuration frame to cache folder for later use (if needed). (Inherited from PhasorDataConcentratorBase.)
 | CommandChannel | Gets or sets reference to TcpServer command channel, attaching and/or detaching to events as needed. (Inherited from PhasorDataConcentratorBase.)
 | ConfigurationFrame | Gets or sets the protocol specific IConfigurationFrame used to send to clients for protocol parsing. (Inherited from PhasorDataConcentratorBase.)
 | ConnectedClientCount | Gets the current number of known connected clients on the command channel. (Inherited from PhasorDataConcentratorBase.)
 | ConnectionString()()()() | (Inherited from ActionAdapterBase.)
 | CoordinateFormat | Gets or sets the CoordinateFormat defined for this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | CreateConfigurationFrame(ConfigurationFrame, UInt32, LineFrequency) | Creates a new IEEE C37.118 ConfigurationFrame2 based on provided protocol independent baseConfigurationFrame.
 | CreateDataFrame(Ticks, ConfigurationFrame1) | Creates a new IEEE C37.118 specific DataFrame for the given timestamp.
 | CreateNewConfigurationFrame(ConfigurationFrame) | Creates a new IEEE C37.118 specific IConfigurationFrame based on provided protocol independent baseConfigurationFrame. (Overrides PhasorDataConcentratorBase.CreateNewConfigurationFrame(ConfigurationFrame).)
 | CreateNewFrame(Ticks) | Creates a new IEEE C37.118 specific DataFrame for the given timestamp. (Overrides ConcentratorBase.CreateNewFrame(Ticks).)
 | CurrentScalingValue | Gets or sets the integer scaling value to apply to current values published by this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | DataChannel | Gets or sets reference to UdpServer data channel, attaching and/or detaching to events as needed. (Inherited from PhasorDataConcentratorBase.)
 | DataFormat | Gets or sets the DataFormat defined for this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | DataSource()()()() | (Inherited from ActionAdapterBase.)
 | DeviceCommandHandler(Guid, String, array<Byte>[]()[][], Int32) | Handles incoming commands from devices connected over the command channel. (Overrides PhasorDataConcentratorBase.DeviceCommandHandler(Guid, String, array<Byte>[]()[][], Int32).)
 | DigitalMaskValue | Gets or sets the digital mask value made available in configuration frames for use with digital values published by this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | DiscardedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | DiscardingMeasurements()()()() | (Inherited from ConcentratorBase.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the PhasorDataConcentratorBase object and optionally releases the managed resources. (Inherited from PhasorDataConcentratorBase.)
 | Dispose()()()() | (Inherited from ConcentratorBase.)
 | Disposed()()()() | (Inherited from ConcentratorBase.)
 | DownsampledMeasurements()()()() | (Inherited from ConcentratorBase.)
 | DownsamplingMethod()()()() | (Inherited from ConcentratorBase.)
 | Enabled()()()() | (Inherited from ConcentratorBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExamineQueueState()()()() | (Inherited from ActionAdapterBase.)
 | ExpectedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | Finalize()()()() | (Inherited from ConcentratorBase.)
 | FramesAheadOfSchedule()()()() | (Inherited from ConcentratorBase.)
 | FramesPerSecond()()()() | (Inherited from ConcentratorBase.)
 | GetConnectionID(IServer, Guid) | Gets connection ID (i.e., IP:Port) for specified clientID. (Inherited from PhasorDataConcentratorBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from PhasorDataConcentratorBase.)
 | GetShortStatus(Int32) | (Inherited from ActionAdapterBase.)
 | GetSignalReference(SignalKind) | Get signal reference for specified SignalKind. (Inherited from PhasorDataConcentratorBase.)
 | GetSignalReference(SignalKind, Int32, Int32) | Get signal reference for specified SignalKind and index. (Inherited from PhasorDataConcentratorBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID()()()() | (Inherited from ActionAdapterBase.)
 | IDCode | Gets ID code defined for this PhasorDataConcentratorBase parsed from the ConnectionString()()()(). (Inherited from PhasorDataConcentratorBase.)
 | IgnoreBadTimestamps()()()() | (Inherited from ConcentratorBase.)
 | InitializationTimeout()()()() | (Inherited from ActionAdapterBase.)
 | Initialize()()()() | Initializes Concentrator. (Overrides PhasorDataConcentratorBase.Initialize()()()().)
 | Initialized()()()() | (Inherited from ActionAdapterBase.)
 | InputMeasurementKeys()()()() | (Inherited from ActionAdapterBase.)
 | InputMeasurementKeysUpdated()()()() | (Inherited from ActionAdapterBase.)
 | InputSourceIDs()()()() | (Inherited from ActionAdapterBase.)
 | IsInputMeasurement(MeasurementKey) | (Inherited from ActionAdapterBase.)
 | LagTicks()()()() | (Inherited from ConcentratorBase.)
 | LagTime()()()() | (Inherited from ConcentratorBase.)
 | LastDiscardedMeasurement()()()() | (Inherited from ConcentratorBase.)
 | LastDiscardedMeasurementLatency()()()() | (Inherited from ConcentratorBase.)
 | LastFrame()()()() | (Inherited from ConcentratorBase.)
 | LatestMeasurements()()()() | (Inherited from ConcentratorBase.)
 | LeadTime()()()() | (Inherited from ConcentratorBase.)
 | MaximumLatency | Gets the maximum latency in milliseconds over the last test interval. (Inherited from PhasorDataConcentratorBase.)
 | MaximumPublicationTimeout()()()() | (Inherited from ConcentratorBase.)
 | MeasurementsSortedByArrival()()()() | (Inherited from ConcentratorBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MillisecondsFromRealTime(Ticks) | (Inherited from ConcentratorBase.)
 | MinimumLatency | Gets the minimum latency in milliseconds over the last test interval. (Inherited from PhasorDataConcentratorBase.)
 | MinimumMeasurementsToUse()()()() | (Inherited from ActionAdapterBase.)
 | MissedSortsByTimeout()()()() | (Inherited from ConcentratorBase.)
 | Name()()()() | (Inherited from ActionAdapterBase.)
 | NewMeasurements()()()() | (Inherited from ActionAdapterBase.)
 | NominalFrequency | Gets or sets the nominal LineFrequency defined for this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | OnDiscardingMeasurements(IEnumerable<(Of <<'(IMeasurement>)>>)) | (Inherited from ConcentratorBase.)
 | OnInputMeasurementKeysUpdated()()()() | (Inherited from ActionAdapterBase.)
 | OnNewMeasurements(ICollection<(Of <<'(IMeasurement>)>>)) | (Inherited from ActionAdapterBase.)
 | OnOutputMeasurementsUpdated()()()() | (Inherited from ActionAdapterBase.)
 | OnProcessException(Exception) | (Inherited from ConcentratorBase.)
 | OnStatusMessage(String) | (Inherited from ActionAdapterBase.)
 | OnStatusMessage(String, array<Object>[]()[][]) | (Inherited from ActionAdapterBase.)
 | OnUnpublishedSamples(Int32) | (Inherited from ConcentratorBase.)
 | OutputMeasurements()()()() | (Inherited from ActionAdapterBase.)
 | OutputMeasurementsUpdated()()()() | (Inherited from ActionAdapterBase.)
 | OutputSourceIDs()()()() | (Inherited from ActionAdapterBase.)
 | Parent()()()() | (Inherited from ActionAdapterBase.)
 | PerformTimestampReasonabilityCheck()()()() | (Inherited from ConcentratorBase.)
 | ProcessByReceivedTimestamp()()()() | (Inherited from ConcentratorBase.)
 | ProcessDataValidFlag | Gets or sets flag that determines if the data valid flag assignments should be processed during frame publication. (Inherited from PhasorDataConcentratorBase.)
 | ProcessedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | ProcessException()()()() | (Inherited from ConcentratorBase.)
 | ProcessingInterval()()()() | (Inherited from ConcentratorBase.)
 | ProcessMeasurementFilter()()()() | (Inherited from ActionAdapterBase.)
 | PublishedFrames()()()() | (Inherited from ConcentratorBase.)
 | PublishedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | PublishFrame(IFrame, Int32) | Publish IFrame of time-aligned collection of IMeasurement values that arrived within the concentrator's defined LagTime()()()(). (Inherited from PhasorDataConcentratorBase.)
 | QueueMeasurementForProcessing(IMeasurement) | Queues a single measurement for processing. (Inherited from PhasorDataConcentratorBase.)
 | QueueMeasurementsForProcessing(IEnumerable<(Of <<'(IMeasurement>)>>)) | Queues a collection of measurements for processing. (Inherited from PhasorDataConcentratorBase.)
 | QueueState()()()() | (Inherited from ConcentratorBase.)
 | RealTime()()()() | (Inherited from ConcentratorBase.)
 | ReceivedMeasurements()()()() | (Inherited from ConcentratorBase.)
 | RequestedInputMeasurementKeys()()()() | (Inherited from ActionAdapterBase.)
 | RequestedOutputMeasurementKeys()()()() | (Inherited from ActionAdapterBase.)
 | ResetLatencyCounters()()()() | Resets counters related to latency calculations. (Inherited from PhasorDataConcentratorBase.)
 | ResetStatistics()()()() | (Inherited from ActionAdapterBase.)
 | RunTime()()()() | (Inherited from ConcentratorBase.)
 | SecondsFromRealTime(Ticks) | (Inherited from ConcentratorBase.)
 | SetInitializedState(Boolean) | (Inherited from ActionAdapterBase.)
 | SetTemporalConstraint(String, String, String) | (Inherited from ActionAdapterBase.)
 | Settings()()()() | (Inherited from ActionAdapterBase.)
 | SortMeasurement(IMeasurement) | (Inherited from ConcentratorBase.)
 | SortMeasurements(IEnumerable<(Of <<'(IMeasurement>)>>)) | (Inherited from ConcentratorBase.)
 | Start()()()() | Starts the PhasorDataConcentratorBase, if it is not already running. (Inherited from PhasorDataConcentratorBase.)
 | StartDataChannel()()()() | Starts the PhasorDataConcentratorBase real-time data stream. (Inherited from PhasorDataConcentratorBase.)
 | StartTime()()()() | (Inherited from ConcentratorBase.)
 | StartTimeConstraint()()()() | (Inherited from ActionAdapterBase.)
 | Status | Returns the detailed status of this Concentrator. (Overrides PhasorDataConcentratorBase.Status.)
 | StatusMessage()()()() | (Inherited from ActionAdapterBase.)
 | Stop()()()() | Stops the PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | StopDataChannel()()()() | Stops the PhasorDataConcentratorBase real-time data stream. (Inherited from PhasorDataConcentratorBase.)
 | StopTime()()()() | (Inherited from ConcentratorBase.)
 | StopTimeConstraint()()()() | (Inherited from ActionAdapterBase.)
 | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Inherited from PhasorDataConcentratorBase.)
 | TicksPerFrame()()()() | (Inherited from ConcentratorBase.)
 | TimeBase | Gets or sets IEEE C37.118 time base for this concentrator instance.
 | TimeResolution()()()() | (Inherited from ConcentratorBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalPublicationTime()()()() | (Inherited from ConcentratorBase.)
 | TrackLatestMeasurements()()()() | (Inherited from ConcentratorBase.)
 | TrackPublishedTimestamp()()()() | (Inherited from ConcentratorBase.)
 | TryGetMinimumNeededMeasurements(IFrame, array<IMeasurement>[]()[][]%) | (Inherited from ActionAdapterBase.)
 | UnpublishedSamples()()()() | (Inherited from ConcentratorBase.)
 | UpdateConfiguration()()()() | Reloads the configuration for this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | UseLocalClockAsRealTime()()()() | (Inherited from ConcentratorBase.)
 | UsePrecisionTimer()()()() | (Inherited from ConcentratorBase.)
 | ValidateIDCode | Gets or sets flag that determines if concentrator will validate ID code before processing commands.
 | VoltageScalingValue | Gets or sets the integer scaling value to apply to voltage values published by this PhasorDataConcentratorBase. (Inherited from PhasorDataConcentratorBase.)
 | WaitForInitialize(Int32) | (Inherited from ActionAdapterBase.)
 | WaitHandleExpirations()()()() | (Inherited from ConcentratorBase.)
Inheritance Hierarchy
Object
 | ConcentratorBase
 |  | ActionAdapterBase
 |  |  | PhasorDataConcentratorBase
 |  |  |  | Concentrator


Concentrator Constructor

Concentrator Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Concentrator ► Concentrator()()()()
Initializes a new instance of the Concentrator class
Declaration Syntax
C# Visual Basic Visual C++
public Concentrator()
Public Sub New
public:
Concentrator()


CreateConfigurationFrame Method (baseConfigurationFrame, timeBase, nominalFrequency)

CreateConfigurationFrame Method (baseConfigurationFrame, timeBase, nominalFrequency)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Concentrator ► CreateConfigurationFrame(ConfigurationFrame, UInt32, LineFrequency)
Creates a new IEEE C37.118 ConfigurationFrame2 based on provided protocol independent baseConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public static ConfigurationFrame2 CreateConfigurationFrame(
    ConfigurationFrame baseConfigurationFrame,
    uint timeBase,
    LineFrequency nominalFrequency
)
Public Shared Function CreateConfigurationFrame ( _
    baseConfigurationFrame As ConfigurationFrame, _
    timeBase As UInteger, _
    nominalFrequency As LineFrequency _
) As ConfigurationFrame2
public:
static ConfigurationFrame2^ CreateConfigurationFrame(
    ConfigurationFrame^ baseConfigurationFrame,
    unsigned int timeBase,
    LineFrequency nominalFrequency
)
Parameters
baseConfigurationFrame (ConfigurationFrame)
Protocol independent ConfigurationFrame.
timeBase (UInt32)
Timebase to use for fraction second resolution.
nominalFrequency (LineFrequency)
The nominal LineFrequency to use for the new ConfigurationFrame2
Return Value
A new IEEE C37.118 ConfigurationFrame2.


CreateDataFrame Method (timestamp, configurationFrame)

CreateDataFrame Method (timestamp, configurationFrame)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Concentrator ► CreateDataFrame(Ticks, ConfigurationFrame1)
Creates a new IEEE C37.118 specific DataFrame for the given timestamp.
Declaration Syntax
C# Visual Basic Visual C++
public static DataFrame CreateDataFrame(
    Ticks timestamp,
    ConfigurationFrame1 configurationFrame
)
Public Shared Function CreateDataFrame ( _
    timestamp As Ticks, _
    configurationFrame As ConfigurationFrame1 _
) As DataFrame
public:
static DataFrame^ CreateDataFrame(
    Ticks timestamp,
    ConfigurationFrame1^ configurationFrame
)
Parameters
timestamp (Ticks)
Timestamp for new IFrame in Ticks.
configurationFrame (ConfigurationFrame1)
Associated ConfigurationFrame1 for the new DataFrame.
Return Value
New IEEE C37.118 DataFrame at given timestamp.


CreateNewConfigurationFrame Method (baseConfigurationFrame)

CreateNewConfigurationFrame Method (baseConfigurationFrame)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Concentrator ► CreateNewConfigurationFrame(ConfigurationFrame)
Creates a new IEEE C37.118 specific IConfigurationFrame based on provided protocol independent baseConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
protected override IConfigurationFrame CreateNewConfigurationFrame(
    ConfigurationFrame baseConfigurationFrame
)
Protected Overrides Function CreateNewConfigurationFrame ( _
    baseConfigurationFrame As ConfigurationFrame _
) As IConfigurationFrame
protected:
virtual IConfigurationFrame^ CreateNewConfigurationFrame(
    ConfigurationFrame^ baseConfigurationFrame
) override
Parameters
baseConfigurationFrame (ConfigurationFrame)
Protocol independent ConfigurationFrame.
Return Value
A new IEEE C37.118 specific IConfigurationFrame.


CreateNewFrame Method (timestamp)

CreateNewFrame Method (timestamp)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Concentrator ► CreateNewFrame(Ticks)
Creates a new IEEE C37.118 specific DataFrame for the given timestamp.
Declaration Syntax
C# Visual Basic Visual C++
protected override IFrame CreateNewFrame(
    Ticks timestamp
)
Protected Overrides Function CreateNewFrame ( _
    timestamp As Ticks _
) As IFrame
protected:
virtual IFrame^ CreateNewFrame(
    Ticks timestamp
) override
Parameters
timestamp (Ticks)
Timestamp for new IFrame in Ticks.
Return Value
New IEEE C37.118 DataFrame at given timestamp.
Remarks
Note that the ConcentratorBase class (which the ActionAdapterBase is derived from) is designed to sort IMeasurement implementations into an IFrame which represents a collection of measurements at a given timestamp. The CreateNewFrame method allows consumers to create their own IFrame implementations, in our case this will be an IEEE C37.118 data frame.


DeviceCommandHandler Method (clientID, connectionID, commandBuffer, length)

DeviceCommandHandler Method (clientID, connectionID, commandBuffer, length)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Concentrator ► DeviceCommandHandler(Guid, String, array<Byte>[]()[][], Int32)
Handles incoming commands from devices connected over the command channel.
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeviceCommandHandler(
    Guid clientID,
    string connectionID,
    byte[] commandBuffer,
    int length
)
Protected Overrides Sub DeviceCommandHandler ( _
    clientID As Guid, _
    connectionID As String, _
    commandBuffer As Byte(), _
    length As Integer _
)
protected:
virtual void DeviceCommandHandler(
    Guid clientID,
    String^ connectionID,
    array<unsigned char>^ commandBuffer,
    int length
) override
Parameters
clientID (Guid)
Guid of client that sent the command.
connectionID (String)
Remote client connection identification (i.e., IP:Port).
commandBuffer (array< Byte >[]()[][])
Data buffer received from connected client device.
length (Int32)
Valid length of data within the buffer.


Initialize Method

Initialize Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Concentrator ► Initialize()()()()
Initializes Concentrator.
Declaration Syntax
C# Visual Basic Visual C++
public override void Initialize()
Public Overrides Sub Initialize
public:
virtual void Initialize() override


Status Property

Status Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Concentrator ► Status
Returns the detailed status of this Concentrator.
Declaration Syntax
C# Visual Basic Visual C++
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
public:
virtual property String^ Status {
    String^ get () override;
}


TimeBase Property

TimeBase Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Concentrator ► TimeBase
Gets or sets IEEE C37.118 time base for this concentrator instance.
Declaration Syntax
C# Visual Basic Visual C++
public uint TimeBase { get; set; }
Public Property TimeBase As UInteger
    Get
    Set
public:
property unsigned int TimeBase {
    unsigned int get ();
    void set (unsigned int value);
}


ValidateIDCode Property

ValidateIDCode Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Concentrator ► ValidateIDCode
Gets or sets flag that determines if concentrator will validate ID code before processing commands.
Declaration Syntax
C# Visual Basic Visual C++
public bool ValidateIDCode { get; set; }
Public Property ValidateIDCode As Boolean
    Get
    Set
public:
property bool ValidateIDCode {
    bool get ();
    void set (bool value);
}


ConfigurationCell Class

ConfigurationCell Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell
Represents the IEEE C37.118 implementation of a IConfigurationCell that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationCell : ConfigurationCellBase
<SerializableAttribute> _
Public Class ConfigurationCell _
    Inherits ConfigurationCellBase
[SerializableAttribute]
public ref class ConfigurationCell : public ConfigurationCellBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCell(IConfigurationFrame) | Creates a new ConfigurationCell.
 | ConfigurationCell(ConfigurationFrame1, UInt16, LineFrequency) | Creates a new ConfigurationCell from specified parameters.
 | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
 | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.AnalogDataFormat.)
 | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationCell object. (Overrides ConfigurationCellBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
 | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
 | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
 | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage | Gets the binary footer image of the ConfigurationCell object. (Overrides ConfigurationCellBase.FooterImage.)
 | FooterLength | Gets the length of the FooterImage. (Overrides ConfigurationCellBase.FooterLength.)
 | FormatFlags | Gets or sets format flags of this ConfigurationCell.
 | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBase.FrequencyDataFormat.)
 | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the ConfigurationCell object. (Overrides ConfigurationCellBase.HeaderImage.)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides ConfigurationCellBase.HeaderLength.)
 | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
 | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Parent | Gets a reference to the parent ConfigurationFrame1 for this ConfigurationCell.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ConfigurationCellBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary footer image. (Overrides ConfigurationCellBase.ParseFooterImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides ConfigurationCellBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.PhasorCoordinateFormat.)
 | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.PhasorDataFormat.)
 | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | ConfigurationCellBase
 |  |  |  |  | ConfigurationCell


ConfigurationCell Constructor

ConfigurationCell Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► ConfigurationCell()()()()
Members
Icon | Member | Description
 | ConfigurationCell(IConfigurationFrame) | Creates a new ConfigurationCell.
 | ConfigurationCell(ConfigurationFrame1, UInt16, LineFrequency) | Creates a new ConfigurationCell from specified parameters.
 | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.


ConfigurationCell Constructor (info, context)

ConfigurationCell Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► ConfigurationCell(SerializationInfo, StreamingContext)
Creates a new ConfigurationCell from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationCell(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationCell Constructor (parent)

ConfigurationCell Constructor (parent)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► ConfigurationCell(IConfigurationFrame)
Creates a new ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell(
    IConfigurationFrame parent
)
Public Sub New ( _
    parent As IConfigurationFrame _
)
public:
ConfigurationCell(
    IConfigurationFrame^ parent
)
Parameters
parent (IConfigurationFrame)
The reference to parent IConfigurationFrame of this ConfigurationCell.


ConfigurationCell Constructor (parent, idCode, nominalFrequency)

ConfigurationCell Constructor (parent, idCode, nominalFrequency)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► ConfigurationCell(ConfigurationFrame1, UInt16, LineFrequency)
Creates a new ConfigurationCell from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell(
    ConfigurationFrame1 parent,
    ushort idCode,
    LineFrequency nominalFrequency
)
Public Sub New ( _
    parent As ConfigurationFrame1, _
    idCode As UShort, _
    nominalFrequency As LineFrequency _
)
public:
ConfigurationCell(
    ConfigurationFrame1^ parent,
    unsigned short idCode,
    LineFrequency nominalFrequency
)
Parameters
parent (ConfigurationFrame1)
The reference to parent ConfigurationFrame1 of this ConfigurationCell.
idCode (UInt16)
The numeric ID code for this ConfigurationCell.
nominalFrequency (LineFrequency)
The nominal LineFrequency of the FrequencyDefinition of this ConfigurationCell.


AnalogDataFormat Property

AnalogDataFormat Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► AnalogDataFormat
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat AnalogDataFormat { get; set; }
Public Overrides Property AnalogDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat AnalogDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationCell object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


FooterImage Property

FooterImage Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► FooterImage
Gets the binary footer image of the ConfigurationCell object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] FooterImage { get; }
Protected Overrides ReadOnly Property FooterImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ FooterImage {
    array<unsigned char>^ get () override;
}


FooterLength Property

FooterLength Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► FooterLength
Gets the length of the FooterImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int FooterLength { get; }
Protected Overrides ReadOnly Property FooterLength As Integer
    Get
protected:
virtual property int FooterLength {
    int get () override;
}


FormatFlags Property

FormatFlags Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► FormatFlags
Gets or sets format flags of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public FormatFlags FormatFlags { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Property FormatFlags As FormatFlags
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
public:
property FormatFlags FormatFlags {
    FormatFlags get ();
    void set (FormatFlags value);
}
Remarks
These are bit flags, use properties to change basic values.


FrequencyDataFormat Property

FrequencyDataFormat Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► FrequencyDataFormat
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat FrequencyDataFormat { get; set; }
Public Overrides Property FrequencyDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► HeaderImage
Gets the binary header image of the ConfigurationCell object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► Parent
Gets a reference to the parent ConfigurationFrame1 for this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame1 Parent { get; set; }
Public Property Parent As ConfigurationFrame1
    Get
    Set
public:
property ConfigurationFrame1^ Parent {
    ConfigurationFrame1^ get ();
    void set (ConfigurationFrame1^ value);
}


ParseFooterImage Method (binaryImage, startIndex, length)

ParseFooterImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► ParseFooterImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary footer image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseFooterImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseFooterImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseFooterImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


PhasorCoordinateFormat Property

PhasorCoordinateFormat Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► PhasorCoordinateFormat
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override CoordinateFormat PhasorCoordinateFormat { get; set; }
Public Overrides Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () override;
    void set (CoordinateFormat value) override;
}


PhasorDataFormat Property

PhasorDataFormat Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► PhasorDataFormat
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat PhasorDataFormat { get; set; }
Public Overrides Property PhasorDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}


ConfigurationCellCollection Class

ConfigurationCellCollection Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCellCollection
Represents a IEEE C37.118 implementation of a collection of IConfigurationCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationCellCollection : ConfigurationCellCollection
<SerializableAttribute> _
Public Class ConfigurationCellCollection _
    Inherits ConfigurationCellCollection
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ConfigurationCellCollection
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCellCollection()()()() | Creates a new ConfigurationCellCollection.
 | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | IndexOfIDCode(UInt16) | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
 | IndexOfIDLabel(String) | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
 | IndexOfStationName(String) | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets ConfigurationCell at specified index.
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetByIDCode(UInt16, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
 | TryGetByIDLabel(String, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
 | TryGetByStationName(String, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IConfigurationCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' IConfigurationCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationCellCollection
 |  |  |  |  | ConfigurationCellCollection


ConfigurationCellCollection Constructor

ConfigurationCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCellCollection ► ConfigurationCellCollection()()()()
Members
Icon | Member | Description
 | ConfigurationCellCollection()()()() | Creates a new ConfigurationCellCollection.
 | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.


ConfigurationCellCollection Constructor

ConfigurationCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCellCollection ► ConfigurationCellCollection()()()()
Creates a new ConfigurationCellCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellCollection()
Public Sub New
public:
ConfigurationCellCollection()


ConfigurationCellCollection Constructor (info, context)

ConfigurationCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCellCollection ► ConfigurationCellCollection(SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


Item Property (index)

Item Property (index)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCellCollection ► Item[([( Int32])])
Gets or sets ConfigurationCell at specified index.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ConfigurationCell
    Get
    Set
public:
property ConfigurationCell^ default[int index] {
    ConfigurationCell^ get (int index);
    void set (int index, ConfigurationCell^ value);
}
Parameters
index (Int32)
Index of value to get or set.


ConfigurationFrame1 Class

ConfigurationFrame1 Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1
Represents the IEEE C37.118 implementation of a IConfigurationFrame, type 1, that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationFrame1 : ConfigurationFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
<SerializableAttribute> _
Public Class ConfigurationFrame1 _
    Inherits ConfigurationFrameBase _
    Implements ISupportFrameImage(Of FrameType), ISupportBinaryImage
[SerializableAttribute]
public ref class ConfigurationFrame1 : public ConfigurationFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationFrame1()()()() | Creates a new ConfigurationFrame1.
 | ConfigurationFrame1(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame1 from specified parameters.
 | ConfigurationFrame1(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame1 from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrame1 object. (Overrides ConfigurationFrameBase.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame1.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CommonHeader | Gets or sets current CommonFrameHeader.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DraftRevision | Gets the DraftRevision of this ConfigurationFrame1.
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage | Gets the binary footer image of the ConfigurationFrame1 object. (Overrides BinaryImageBase.FooterImage()()()().)
 | FooterLength | Gets the length of the FooterImage. (Overrides BinaryImageBase.FooterLength()()()().)
 | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the ConfigurationFrame1 object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary footer image. (Overrides BinaryImageBase.ParseFooterImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides BinaryImageBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SetNominalFrequency(LineFrequency) | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps of this ConfigurationFrame1.
 | TimeQualityFlags | Gets or sets the TimeQualityFlags of this ConfigurationFrame1.
 | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame1.
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame1. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.Timestamp.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets the FrameType of this ConfigurationFrame1.
 | Version | Gets or sets the IEEE C37.118 protocol version of this ConfigurationFrame1.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationFrameBase
 |  |  |  |  | ConfigurationFrame1
 |  |  |  |  |  | ConfigurationFrame1Draft6
 |  |  |  |  |  | ConfigurationFrame2


ConfigurationFrame1 Constructor

ConfigurationFrame1 Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► ConfigurationFrame1()()()()
Members
Icon | Member | Description
 | ConfigurationFrame1()()()() | Creates a new ConfigurationFrame1.
 | ConfigurationFrame1(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame1 from specified parameters.
 | ConfigurationFrame1(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame1 from serialization parameters.


ConfigurationFrame1 Constructor

ConfigurationFrame1 Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► ConfigurationFrame1()()()()
Creates a new ConfigurationFrame1.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ConfigurationFrame1()
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Sub New
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
ConfigurationFrame1()
Remarks
This constructor is used by FrameImageParserBase to parse an IEEE C37.118 configuration frame.


ConfigurationFrame1 Constructor (info, context)

ConfigurationFrame1 Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► ConfigurationFrame1(SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame1 from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationFrame1(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationFrame1(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationFrame1 Constructor (timebase, idCode, timestamp, frameRate)

ConfigurationFrame1 Constructor (timebase, idCode, timestamp, frameRate)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► ConfigurationFrame1(UInt32, UInt16, Ticks, UInt16)
Creates a new ConfigurationFrame1 from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame1(
    uint timebase,
    ushort idCode,
    Ticks timestamp,
    ushort frameRate
)
Public Sub New ( _
    timebase As UInteger, _
    idCode As UShort, _
    timestamp As Ticks, _
    frameRate As UShort _
)
public:
ConfigurationFrame1(
    unsigned int timebase,
    unsigned short idCode,
    Ticks timestamp,
    unsigned short frameRate
)
Parameters
timebase (UInt32)
Timebase to use for fraction second resolution.
idCode (UInt16)
The ID code of this ConfigurationFrame1.
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame1.
frameRate (UInt16)
The defined frame rate of this ConfigurationFrame1.
Remarks
This constructor is used by a consumer to generate an IEEE C37.118 configuration frame.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrame1 object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► Cells
Gets reference to the ConfigurationCellCollection for this ConfigurationFrame1.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellCollection Cells { get; }
Public ReadOnly Property Cells As ConfigurationCellCollection
    Get
public:
property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}


CommonHeader Property

CommonHeader Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► CommonHeader
Gets or sets current CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}


DraftRevision Property

DraftRevision Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► DraftRevision
Gets the DraftRevision of this ConfigurationFrame1.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DraftRevision DraftRevision { get; }
Public Overridable ReadOnly Property DraftRevision As DraftRevision
    Get
public:
virtual property DraftRevision DraftRevision {
    DraftRevision get ();
}


FooterImage Property

FooterImage Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► FooterImage
Gets the binary footer image of the ConfigurationFrame1 object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] FooterImage { get; }
Protected Overrides ReadOnly Property FooterImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ FooterImage {
    array<unsigned char>^ get () override;
}


FooterLength Property

FooterLength Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► FooterLength
Gets the length of the FooterImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int FooterLength { get; }
Protected Overrides ReadOnly Property FooterLength As Integer
    Get
protected:
virtual property int FooterLength {
    int get () override;
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► HeaderImage
Gets the binary header image of the ConfigurationFrame1 object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


ParseFooterImage Method (binaryImage, startIndex, length)

ParseFooterImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► ParseFooterImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary footer image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseFooterImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseFooterImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseFooterImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


Timebase Property

Timebase Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► Timebase
Gets or sets the IEEE C37.118 resolution of fractional time stamps of this ConfigurationFrame1.
Declaration Syntax
C# Visual Basic Visual C++
public uint Timebase { get; set; }
Public Property Timebase As UInteger
    Get
    Set
public:
property unsigned int Timebase {
    unsigned int get ();
    void set (unsigned int value);
}


TimeQualityFlags Property

TimeQualityFlags Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► TimeQualityFlags
Gets or sets the TimeQualityFlags of this ConfigurationFrame1.
Declaration Syntax
C# Visual Basic Visual C++
public TimeQualityFlags TimeQualityFlags { get; set; }
Public Property TimeQualityFlags As TimeQualityFlags
    Get
    Set
public:
property TimeQualityFlags TimeQualityFlags {
    TimeQualityFlags get ();
    void set (TimeQualityFlags value);
}


TimeQualityIndicatorCode Property

TimeQualityIndicatorCode Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► TimeQualityIndicatorCode
Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame1.
Declaration Syntax
C# Visual Basic Visual C++
public TimeQualityIndicatorCode TimeQualityIndicatorCode { get; set; }
Public Property TimeQualityIndicatorCode As TimeQualityIndicatorCode
    Get
    Set
public:
property TimeQualityIndicatorCode TimeQualityIndicatorCode {
    TimeQualityIndicatorCode get ();
    void set (TimeQualityIndicatorCode value);
}


Timestamp Property

Timestamp Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► Timestamp
Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame1.
Declaration Syntax
C# Visual Basic Visual C++
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► TypeID
Gets the FrameType of this ConfigurationFrame1.
Declaration Syntax
C# Visual Basic Visual C++
public virtual FrameType TypeID { get; }
Public Overridable ReadOnly Property TypeID As FrameType
    Get
public:
virtual property FrameType TypeID {
    FrameType get ();
}


Version Property

Version Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► Version
Gets or sets the IEEE C37.118 protocol version of this ConfigurationFrame1.
Declaration Syntax
C# Visual Basic Visual C++
public byte Version { get; set; }
Public Property Version As Byte
    Get
    Set
public:
property unsigned char Version {
    unsigned char get ();
    void set (unsigned char value);
}


ConfigurationFrame1Draft6 Class

ConfigurationFrame1Draft6 Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1Draft6
Represents the IEEE C37.118 draft 6 implementation of a IConfigurationFrame, type 1, that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationFrame1Draft6 : ConfigurationFrame1
<SerializableAttribute> _
Public Class ConfigurationFrame1Draft6 _
    Inherits ConfigurationFrame1
[SerializableAttribute]
public ref class ConfigurationFrame1Draft6 : public ConfigurationFrame1
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationFrame1Draft6()()()() | Creates a new ConfigurationFrame1Draft6.
 | ConfigurationFrame1Draft6(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame1Draft6 from specified parameters.
 | ConfigurationFrame1Draft6(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame1Draft6 from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Inherited from ConfigurationFrame1.)
 | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CommonHeader | Gets or sets current CommonFrameHeader. (Inherited from ConfigurationFrame1.)
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | DraftRevision | Gets the DraftRevision of this ConfigurationFrame1Draft6. (Overrides ConfigurationFrame1.DraftRevision.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage | Gets the binary footer image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
 | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationFrame1.)
 | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrame1.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
 | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationFrame1.)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary footer image. (Inherited from ConfigurationFrame1.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Inherited from ConfigurationFrame1.)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SetNominalFrequency(LineFrequency) | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | TimeQualityFlags | Gets or sets the TimeQualityFlags of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets the FrameType of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | Version | Gets or sets the IEEE C37.118 protocol version of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationFrameBase
 |  |  |  |  | ConfigurationFrame1
 |  |  |  |  |  | ConfigurationFrame1Draft6


ConfigurationFrame1Draft6 Constructor

ConfigurationFrame1Draft6 Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1Draft6 ► ConfigurationFrame1Draft6()()()()
Members
Icon | Member | Description
 | ConfigurationFrame1Draft6()()()() | Creates a new ConfigurationFrame1Draft6.
 | ConfigurationFrame1Draft6(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame1Draft6 from specified parameters.
 | ConfigurationFrame1Draft6(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame1Draft6 from serialization parameters.


ConfigurationFrame1Draft6 Constructor

ConfigurationFrame1Draft6 Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1Draft6 ► ConfigurationFrame1Draft6()()()()
Creates a new ConfigurationFrame1Draft6.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ConfigurationFrame1Draft6()
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Sub New
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
ConfigurationFrame1Draft6()
Remarks
This constructor is used by FrameImageParserBase to parse an IEEE C37.118 draft 6 configuration frame.


ConfigurationFrame1Draft6 Constructor (info, context)

ConfigurationFrame1Draft6 Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1Draft6 ► ConfigurationFrame1Draft6(SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame1Draft6 from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationFrame1Draft6(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationFrame1Draft6(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationFrame1Draft6 Constructor (timebase, idCode, timestamp, frameRate)

ConfigurationFrame1Draft6 Constructor (timebase, idCode, timestamp, frameRate)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1Draft6 ► ConfigurationFrame1Draft6(UInt32, UInt16, Ticks, UInt16)
Creates a new ConfigurationFrame1Draft6 from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame1Draft6(
    uint timebase,
    ushort idCode,
    Ticks timestamp,
    ushort frameRate
)
Public Sub New ( _
    timebase As UInteger, _
    idCode As UShort, _
    timestamp As Ticks, _
    frameRate As UShort _
)
public:
ConfigurationFrame1Draft6(
    unsigned int timebase,
    unsigned short idCode,
    Ticks timestamp,
    unsigned short frameRate
)
Parameters
timebase (UInt32)
Timebase to use for fraction second resolution.
idCode (UInt16)
The ID code of this ConfigurationFrame1Draft6.
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame1Draft6.
frameRate (UInt16)
The defined frame rate of this ConfigurationFrame1Draft6.
Remarks
This constructor is used by a consumer to generate an IEEE C37.118 draft 6 configuration frame.


DraftRevision Property

DraftRevision Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1Draft6 ► DraftRevision
Gets the DraftRevision of this ConfigurationFrame1Draft6.
Declaration Syntax
C# Visual Basic Visual C++
public override DraftRevision DraftRevision { get; }
Public Overrides ReadOnly Property DraftRevision As DraftRevision
    Get
public:
virtual property DraftRevision DraftRevision {
    DraftRevision get () override;
}


ConfigurationFrame2 Class

ConfigurationFrame2 Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame2
Represents the IEEE C37.118 implementation of a IConfigurationFrame, type 2, that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationFrame2 : ConfigurationFrame1
<SerializableAttribute> _
Public Class ConfigurationFrame2 _
    Inherits ConfigurationFrame1
[SerializableAttribute]
public ref class ConfigurationFrame2 : public ConfigurationFrame1
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationFrame2()()()() | Creates a new ConfigurationFrame2.
 | ConfigurationFrame2(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame2 from specified parameters.
 | ConfigurationFrame2(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame2 from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Inherited from ConfigurationFrame1.)
 | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CommonHeader | Gets or sets current CommonFrameHeader. (Inherited from ConfigurationFrame1.)
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | DraftRevision | Gets the DraftRevision of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage | Gets the binary footer image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
 | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationFrame1.)
 | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrame1.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
 | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationFrame1.)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary footer image. (Inherited from ConfigurationFrame1.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Inherited from ConfigurationFrame1.)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SetNominalFrequency(LineFrequency) | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | TimeQualityFlags | Gets or sets the TimeQualityFlags of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets the FrameType of this ConfigurationFrame2. (Overrides ConfigurationFrame1.TypeID.)
 | Version | Gets or sets the IEEE C37.118 protocol version of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationFrameBase
 |  |  |  |  | ConfigurationFrame1
 |  |  |  |  |  | ConfigurationFrame2
 |  |  |  |  |  |  | ConfigurationFrame2Draft6


ConfigurationFrame2 Constructor

ConfigurationFrame2 Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame2 ► ConfigurationFrame2()()()()
Members
Icon | Member | Description
 | ConfigurationFrame2()()()() | Creates a new ConfigurationFrame2.
 | ConfigurationFrame2(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame2 from specified parameters.
 | ConfigurationFrame2(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame2 from serialization parameters.


ConfigurationFrame2 Constructor

ConfigurationFrame2 Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame2 ► ConfigurationFrame2()()()()
Creates a new ConfigurationFrame2.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ConfigurationFrame2()
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Sub New
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
ConfigurationFrame2()
Remarks
This constructor is used by FrameImageParserBase to parse an IEEE C37.118 configuration frame, type 2.


ConfigurationFrame2 Constructor (info, context)

ConfigurationFrame2 Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame2 ► ConfigurationFrame2(SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame2 from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationFrame2(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationFrame2(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationFrame2 Constructor (timebase, idCode, timestamp, frameRate)

ConfigurationFrame2 Constructor (timebase, idCode, timestamp, frameRate)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame2 ► ConfigurationFrame2(UInt32, UInt16, Ticks, UInt16)
Creates a new ConfigurationFrame2 from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame2(
    uint timebase,
    ushort idCode,
    Ticks timestamp,
    ushort frameRate
)
Public Sub New ( _
    timebase As UInteger, _
    idCode As UShort, _
    timestamp As Ticks, _
    frameRate As UShort _
)
public:
ConfigurationFrame2(
    unsigned int timebase,
    unsigned short idCode,
    Ticks timestamp,
    unsigned short frameRate
)
Parameters
timebase (UInt32)
Timebase to use for fraction second resolution.
idCode (UInt16)
The ID code of this ConfigurationFrame2.
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame2.
frameRate (UInt16)
The defined frame rate of this ConfigurationFrame2.
Remarks
This constructor is used by a consumer to generate an IEEE C37.118 configuration frame, type 2.


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame2 ► TypeID
Gets the FrameType of this ConfigurationFrame2.
Declaration Syntax
C# Visual Basic Visual C++
public override FrameType TypeID { get; }
Public Overrides ReadOnly Property TypeID As FrameType
    Get
public:
virtual property FrameType TypeID {
    FrameType get () override;
}


ConfigurationFrame2Draft6 Class

ConfigurationFrame2Draft6 Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame2Draft6
Represents the IEEE C37.118 draft 6 implementation of a IConfigurationFrame, type 2, that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationFrame2Draft6 : ConfigurationFrame2
<SerializableAttribute> _
Public Class ConfigurationFrame2Draft6 _
    Inherits ConfigurationFrame2
[SerializableAttribute]
public ref class ConfigurationFrame2Draft6 : public ConfigurationFrame2
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationFrame2Draft6()()()() | Creates a new ConfigurationFrame2Draft6.
 | ConfigurationFrame2Draft6(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame2Draft6 from specified parameters.
 | ConfigurationFrame2Draft6(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame2Draft6 from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Inherited from ConfigurationFrame1.)
 | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CommonHeader | Gets or sets current CommonFrameHeader. (Inherited from ConfigurationFrame1.)
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | DraftRevision | Gets the DraftRevision of this ConfigurationFrame2Draft6. (Overrides ConfigurationFrame1.DraftRevision.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage | Gets the binary footer image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
 | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationFrame1.)
 | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrame1.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
 | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationFrame1.)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary footer image. (Inherited from ConfigurationFrame1.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Inherited from ConfigurationFrame1.)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SetNominalFrequency(LineFrequency) | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | TimeQualityFlags | Gets or sets the TimeQualityFlags of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets the FrameType of this ConfigurationFrame2. (Inherited from ConfigurationFrame2.)
 | Version | Gets or sets the IEEE C37.118 protocol version of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationFrameBase
 |  |  |  |  | ConfigurationFrame1
 |  |  |  |  |  | ConfigurationFrame2
 |  |  |  |  |  |  | ConfigurationFrame2Draft6


ConfigurationFrame2Draft6 Constructor

ConfigurationFrame2Draft6 Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame2Draft6 ► ConfigurationFrame2Draft6()()()()
Members
Icon | Member | Description
 | ConfigurationFrame2Draft6()()()() | Creates a new ConfigurationFrame2Draft6.
 | ConfigurationFrame2Draft6(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame2Draft6 from specified parameters.
 | ConfigurationFrame2Draft6(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame2Draft6 from serialization parameters.


ConfigurationFrame2Draft6 Constructor

ConfigurationFrame2Draft6 Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame2Draft6 ► ConfigurationFrame2Draft6()()()()
Creates a new ConfigurationFrame2Draft6.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ConfigurationFrame2Draft6()
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Sub New
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
ConfigurationFrame2Draft6()
Remarks
This constructor is used by FrameImageParserBase to parse an IEEE C37.118 draft 6 configuration frame, type 2.


ConfigurationFrame2Draft6 Constructor (info, context)

ConfigurationFrame2Draft6 Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame2Draft6 ► ConfigurationFrame2Draft6(SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame2Draft6 from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationFrame2Draft6(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationFrame2Draft6(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationFrame2Draft6 Constructor (timebase, idCode, timestamp, frameRate)

ConfigurationFrame2Draft6 Constructor (timebase, idCode, timestamp, frameRate)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame2Draft6 ► ConfigurationFrame2Draft6(UInt32, UInt16, Ticks, UInt16)
Creates a new ConfigurationFrame2Draft6 from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame2Draft6(
    uint timebase,
    ushort idCode,
    Ticks timestamp,
    ushort frameRate
)
Public Sub New ( _
    timebase As UInteger, _
    idCode As UShort, _
    timestamp As Ticks, _
    frameRate As UShort _
)
public:
ConfigurationFrame2Draft6(
    unsigned int timebase,
    unsigned short idCode,
    Ticks timestamp,
    unsigned short frameRate
)
Parameters
timebase (UInt32)
Timebase to use for fraction second resolution.
idCode (UInt16)
The ID code of this ConfigurationFrame2Draft6.
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame2Draft6.
frameRate (UInt16)
The defined frame rate of this ConfigurationFrame2Draft6.
Remarks
This constructor is used by a consumer to generate an IEEE C37.118 draft 6 configuration frame, type 2.


DraftRevision Property

DraftRevision Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame2Draft6 ► DraftRevision
Gets the DraftRevision of this ConfigurationFrame2Draft6.
Declaration Syntax
C# Visual Basic Visual C++
public override DraftRevision DraftRevision { get; }
Public Overrides ReadOnly Property DraftRevision As DraftRevision
    Get
public:
virtual property DraftRevision DraftRevision {
    DraftRevision get () override;
}


DataCell Class

DataCell Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell
Represents the IEEE C37.118 implementation of a IDataCell that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataCell : DataCellBase
<SerializableAttribute> _
Public Class DataCell _
    Inherits DataCellBase
[SerializableAttribute]
public ref class DataCell : public DataCellBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
 | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
 | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
 | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
 | AnalogValues | Gets AnalogValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataCell object. (Overrides DataCellBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
 | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
 | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
 | ConfigurationChangeDetected | Gets or sets flag that determines if configuration change was detected for this DataCell.
 | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBase.DataIsValid.)
 | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBase.DataSortingType.)
 | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBase.DeviceError.)
 | DeviceTriggerDetected | Gets or sets flag that determines if device trigger is detected for this DataCell.
 | DigitalValues | Gets DigitalValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
 | Equals(Object) | Determines whether the specified object is equal to the DataCellBase. (Inherited from DataCellBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
 | GetHashCode()()()() | Serves as a hash function for the DataCellBase. (Inherited from DataCellBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DataCellBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets the numeric ID code for this DataCellBase. (Inherited from DataCellBase.)
 | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from DataCellBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
 | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
 | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
 | StatusFlags | Gets or sets status flags for this DataCell.
 | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBase.SynchronizationIsValid.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this DataCellBase. (Inherited from DataCellBase.)
 | TriggerReason | Gets or sets trigger reason of this DataCell.
 | UnlockedTime | Gets or sets unlocked time of this DataCell.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | DataCellBase
 |  |  |  |  | DataCell


DataCell Constructor

DataCell Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell ► DataCell()()()()
Members
Icon | Member | Description
 | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
 | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
 | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.


DataCell Constructor (info, context)

DataCell Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell ► DataCell(SerializationInfo, StreamingContext)
Creates a new DataCell from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataCell(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DataCell Constructor (parent, configurationCell)

DataCell Constructor (parent, configurationCell)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell ► DataCell(IDataFrame, IConfigurationCell)
Creates a new DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell(
    IDataFrame parent,
    IConfigurationCell configurationCell
)
Public Sub New ( _
    parent As IDataFrame, _
    configurationCell As IConfigurationCell _
)
public:
DataCell(
    IDataFrame^ parent,
    IConfigurationCell^ configurationCell
)
Parameters
parent (IDataFrame)
The reference to parent IDataFrame of this DataCell.
configurationCell (IConfigurationCell)
The IConfigurationCell associated with this DataCell.


DataCell Constructor (parent, configurationCell, addEmptyValues)

DataCell Constructor (parent, configurationCell, addEmptyValues)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell ► DataCell(DataFrame, ConfigurationCell, Boolean)
Creates a new DataCell from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell(
    DataFrame parent,
    ConfigurationCell configurationCell,
    bool addEmptyValues
)
Public Sub New ( _
    parent As DataFrame, _
    configurationCell As ConfigurationCell, _
    addEmptyValues As Boolean _
)
public:
DataCell(
    DataFrame^ parent,
    ConfigurationCell^ configurationCell,
    bool addEmptyValues
)
Parameters
parent (DataFrame)
The reference to parent DataFrame of this DataCell.
configurationCell (ConfigurationCell)
The ConfigurationCell associated with this DataCell.
addEmptyValues (Boolean)
If true, adds empty values for each defined configuration cell definition.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataCell object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


ConfigurationCell Property

ConfigurationCell Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell ► ConfigurationCell
Gets or sets the ConfigurationCell associated with this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell ConfigurationCell { get; set; }
Public Property ConfigurationCell As ConfigurationCell
    Get
    Set
public:
property ConfigurationCell^ ConfigurationCell {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


ConfigurationChangeDetected Property

ConfigurationChangeDetected Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell ► ConfigurationChangeDetected
Gets or sets flag that determines if configuration change was detected for this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public bool ConfigurationChangeDetected { get; set; }
Public Property ConfigurationChangeDetected As Boolean
    Get
    Set
public:
property bool ConfigurationChangeDetected {
    bool get ();
    void set (bool value);
}


DataIsValid Property

DataIsValid Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell ► DataIsValid
Gets or sets flag that determines if data of this DataCell is valid.
Declaration Syntax
C# Visual Basic Visual C++
public override bool DataIsValid { get; set; }
Public Overrides Property DataIsValid As Boolean
    Get
    Set
public:
virtual property bool DataIsValid {
    bool get () override;
    void set (bool value) override;
}


DataSortingType Property

DataSortingType Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell ► DataSortingType
Gets or sets DataSortingType of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataSortingType DataSortingType { get; set; }
Public Overrides Property DataSortingType As DataSortingType
    Get
    Set
public:
virtual property DataSortingType DataSortingType {
    DataSortingType get () override;
    void set (DataSortingType value) override;
}


DeviceError Property

DeviceError Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell ► DeviceError
Gets or sets flag that determines if source device of this DataCell is reporting an error.
Declaration Syntax
C# Visual Basic Visual C++
public override bool DeviceError { get; set; }
Public Overrides Property DeviceError As Boolean
    Get
    Set
public:
virtual property bool DeviceError {
    bool get () override;
    void set (bool value) override;
}


DeviceTriggerDetected Property

DeviceTriggerDetected Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell ► DeviceTriggerDetected
Gets or sets flag that determines if device trigger is detected for this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeviceTriggerDetected { get; set; }
Public Property DeviceTriggerDetected As Boolean
    Get
    Set
public:
property bool DeviceTriggerDetected {
    bool get ();
    void set (bool value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell ► Parent
Gets or sets the reference to parent DataFrame of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public DataFrame Parent { get; set; }
Public Property Parent As DataFrame
    Get
    Set
public:
property DataFrame^ Parent {
    DataFrame^ get ();
    void set (DataFrame^ value);
}


StatusFlags Property

StatusFlags Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell ► StatusFlags
Gets or sets status flags for this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public StatusFlags StatusFlags { get; set; }
Public Property StatusFlags As StatusFlags
    Get
    Set
public:
property StatusFlags StatusFlags {
    StatusFlags get ();
    void set (StatusFlags value);
}


SynchronizationIsValid Property

SynchronizationIsValid Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell ► SynchronizationIsValid
Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock.
Declaration Syntax
C# Visual Basic Visual C++
public override bool SynchronizationIsValid { get; set; }
Public Overrides Property SynchronizationIsValid As Boolean
    Get
    Set
public:
virtual property bool SynchronizationIsValid {
    bool get () override;
    void set (bool value) override;
}


TriggerReason Property

TriggerReason Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell ► TriggerReason
Gets or sets trigger reason of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public TriggerReason TriggerReason { get; set; }
Public Property TriggerReason As TriggerReason
    Get
    Set
public:
property TriggerReason TriggerReason {
    TriggerReason get ();
    void set (TriggerReason value);
}


UnlockedTime Property

UnlockedTime Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCell ► UnlockedTime
Gets or sets unlocked time of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public UnlockedTime UnlockedTime { get; set; }
Public Property UnlockedTime As UnlockedTime
    Get
    Set
public:
property UnlockedTime UnlockedTime {
    UnlockedTime get ();
    void set (UnlockedTime value);
}


DataCellCollection Class

DataCellCollection Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCellCollection
Represents a IEEE C37.118 implementation of a collection of IDataCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataCellCollection : DataCellCollection
<SerializableAttribute> _
Public Class DataCellCollection _
    Inherits DataCellCollection
[SerializableAttribute]
public ref class DataCellCollection : public DataCellCollection
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCellCollection()()()() | Creates a new DataCellCollection.
 | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets DataCell at specified index.
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IDataCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' IDataCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' IDataCell >)>)>
 |  |  |  | DataCellCollection
 |  |  |  |  | DataCellCollection


DataCellCollection Constructor

DataCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCellCollection ► DataCellCollection()()()()
Members
Icon | Member | Description
 | DataCellCollection()()()() | Creates a new DataCellCollection.
 | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.


DataCellCollection Constructor

DataCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCellCollection ► DataCellCollection()()()()
Creates a new DataCellCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DataCellCollection()
Public Sub New
public:
DataCellCollection()


DataCellCollection Constructor (info, context)

DataCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCellCollection ► DataCellCollection(SerializationInfo, StreamingContext)
Creates a new DataCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


Item Property (index)

Item Property (index)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataCellCollection ► Item[([( Int32])])
Gets or sets DataCell at specified index.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DataCell
    Get
    Set
public:
property DataCell^ default[int index] {
    DataCell^ get (int index);
    void set (int index, DataCell^ value);
}
Parameters
index (Int32)
Index of value to get or set.


DataFrame Class

DataFrame Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame
Represents the IEEE C37.118 implementation of a IDataFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataFrame : DataFrameBase, ISupportFrameImage<FrameType>,
    ISupportBinaryImage
<SerializableAttribute> _
Public Class DataFrame _
    Inherits DataFrameBase _
    Implements ISupportFrameImage(Of FrameType), ISupportBinaryImage
[SerializableAttribute]
public ref class DataFrame : public DataFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataFrame()()()() | Creates a new DataFrame.
 | DataFrame(Ticks, ConfigurationFrame1) | Creates a new DataFrame from specified parameters.
 | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataFrame object. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the DataCellCollection for this DataFrame.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CommonHeader | Gets or sets current CommonFrameHeader.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ConfigurationFrame | Gets or sets ConfigurationFrame1 associated with this DataFrame.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets the numeric ID code for this DataFrameBase. (Inherited from DataFrameBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from DataFrameBase.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides BinaryImageBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | TimeBase | Gets the IEEE C37.118 timebase of this DataFrame as specified by the associated ConfigurationFrame.
 | TimeQualityFlags | Gets or sets the TimeQualityFlags associated with this DataFrame.
 | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode associated with this DataFrame.
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.Timestamp.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets the identifier that is used to identify the IEEE C37.118 frame.
 | Version | Gets the IEEE C37.118 protocol version of this DataFrame as specified by the associated ConfigurationFrame.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IDataCell >)>)>
 |  |  |  | DataFrameBase
 |  |  |  |  | DataFrame


DataFrame Constructor

DataFrame Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► DataFrame()()()()
Members
Icon | Member | Description
 | DataFrame()()()() | Creates a new DataFrame.
 | DataFrame(Ticks, ConfigurationFrame1) | Creates a new DataFrame from specified parameters.
 | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.


DataFrame Constructor

DataFrame Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► DataFrame()()()()
Creates a new DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public DataFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Sub New
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
DataFrame()
Remarks
This constructor is used by FrameImageParserBase to parse an IEEE C37.118 data frame.


DataFrame Constructor (info, context)

DataFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► DataFrame(SerializationInfo, StreamingContext)
Creates a new DataFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DataFrame Constructor (timestamp, configurationFrame)

DataFrame Constructor (timestamp, configurationFrame)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► DataFrame(Ticks, ConfigurationFrame1)
Creates a new DataFrame from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DataFrame(
    Ticks timestamp,
    ConfigurationFrame1 configurationFrame
)
Public Sub New ( _
    timestamp As Ticks, _
    configurationFrame As ConfigurationFrame1 _
)
public:
DataFrame(
    Ticks timestamp,
    ConfigurationFrame1^ configurationFrame
)
Parameters
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this DataFrame.
configurationFrame (ConfigurationFrame1)
The ConfigurationFrame associated with this DataFrame.
Remarks
This constructor is used by a consumer to generate an IEEE C37.118 data frame.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataFrame object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► Cells
Gets reference to the DataCellCollection for this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public DataCellCollection Cells { get; }
Public ReadOnly Property Cells As DataCellCollection
    Get
public:
property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}


CommonHeader Property

CommonHeader Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► CommonHeader
Gets or sets current CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► ConfigurationFrame
Gets or sets ConfigurationFrame1 associated with this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame1 ConfigurationFrame { get; set; }
Public Property ConfigurationFrame As ConfigurationFrame1
    Get
    Set
public:
property ConfigurationFrame1^ ConfigurationFrame {
    ConfigurationFrame1^ get ();
    void set (ConfigurationFrame1^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► HeaderImage
Gets the binary header image of the DataFrame object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


TimeBase Property

TimeBase Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► TimeBase
Gets the IEEE C37.118 timebase of this DataFrame as specified by the associated ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public uint TimeBase { get; }
Public ReadOnly Property TimeBase As UInteger
    Get
public:
property unsigned int TimeBase {
    unsigned int get ();
}


TimeQualityFlags Property

TimeQualityFlags Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► TimeQualityFlags
Gets or sets the TimeQualityFlags associated with this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public TimeQualityFlags TimeQualityFlags { get; set; }
Public Property TimeQualityFlags As TimeQualityFlags
    Get
    Set
public:
property TimeQualityFlags TimeQualityFlags {
    TimeQualityFlags get ();
    void set (TimeQualityFlags value);
}


TimeQualityIndicatorCode Property

TimeQualityIndicatorCode Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► TimeQualityIndicatorCode
Gets or sets the TimeQualityIndicatorCode associated with this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public TimeQualityIndicatorCode TimeQualityIndicatorCode { get; set; }
Public Property TimeQualityIndicatorCode As TimeQualityIndicatorCode
    Get
    Set
public:
property TimeQualityIndicatorCode TimeQualityIndicatorCode {
    TimeQualityIndicatorCode get ();
    void set (TimeQualityIndicatorCode value);
}


Timestamp Property

Timestamp Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► Timestamp
Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► TypeID
Gets the identifier that is used to identify the IEEE C37.118 frame.
Declaration Syntax
C# Visual Basic Visual C++
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}


Version Property

Version Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► Version
Gets the IEEE C37.118 protocol version of this DataFrame as specified by the associated ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public byte Version { get; }
Public ReadOnly Property Version As Byte
    Get
public:
property unsigned char Version {
    unsigned char get ();
}


DigitalDefinition Class

DigitalDefinition Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition
Represents the IEEE C37.118 implementation of a IDigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DigitalDefinition : DigitalDefinitionBase
<SerializableAttribute> _
Public Class DigitalDefinition _
    Inherits DigitalDefinitionBase
[SerializableAttribute]
public ref class DigitalDefinition : public DigitalDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition.
 | DigitalDefinition(ConfigurationCell, String, UInt16, UInt16) | Creates a new DigitalDefinition from specified parameters.
 | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this DigitalDefinition object. (Overrides ChannelDefinitionBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | DraftRevision | Gets the DraftRevision of this DigitalDefinition.
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetLabel(Int32) | Gets the individual labels for specified bit in this DigitalDefinition.
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the combined set of label images of this DigitalDefinition. (Overrides ChannelDefinitionBase.Label.)
 | LabelCount | Gets the number of labels defined in this DigitalDefinition.
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this DigitalDefinition. (Overrides ChannelDefinitionBase.MaximumLabelLength.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NormalStatus | Gets or sets normal status for this DigitalDefinition.
 | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides ChannelDefinitionBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | SetLabel(Int32, String) | Sets the individual labels for specified bit in this DigitalDefinition.
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ValidInputs | Gets or sets valid input for this DigitalDefinition.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | DigitalDefinitionBase
 |  |  |  |  | DigitalDefinition


DigitalDefinition Constructor

DigitalDefinition Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► DigitalDefinition()()()()
Members
Icon | Member | Description
 | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition.
 | DigitalDefinition(ConfigurationCell, String, UInt16, UInt16) | Creates a new DigitalDefinition from specified parameters.
 | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.


DigitalDefinition Constructor (info, context)

DigitalDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► DigitalDefinition(SerializationInfo, StreamingContext)
Creates a new DigitalDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DigitalDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DigitalDefinition Constructor (parent)

DigitalDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► DigitalDefinition(IConfigurationCell)
Creates a new DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
DigitalDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this DigitalDefinition.


DigitalDefinition Constructor (parent, label, normalStatus, validInputs)

DigitalDefinition Constructor (parent, label, normalStatus, validInputs)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► DigitalDefinition(ConfigurationCell, String, UInt16, UInt16)
Creates a new DigitalDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalDefinition(
    ConfigurationCell parent,
    string label,
    ushort normalStatus,
    ushort validInputs
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String, _
    normalStatus As UShort, _
    validInputs As UShort _
)
public:
DigitalDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned short normalStatus,
    unsigned short validInputs
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this DigitalDefinition.
label (String)
The label of this DigitalDefinition.
normalStatus (UInt16)
The normal status for this DigitalDefinition.
validInputs (UInt16)
The valid input for this DigitalDefinition.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► Attributes
Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this DigitalDefinition object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


DraftRevision Property

DraftRevision Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► DraftRevision
Gets the DraftRevision of this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public DraftRevision DraftRevision { get; }
Public ReadOnly Property DraftRevision As DraftRevision
    Get
public:
property DraftRevision DraftRevision {
    DraftRevision get ();
}


GetLabel Method (index)

GetLabel Method (index)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► GetLabel(Int32)
Gets the individual labels for specified bit in this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public string GetLabel(
    int index
)
Public Function GetLabel ( _
    index As Integer _
) As String
public:
String^ GetLabel(
    int index
)
Parameters
index (Int32)
Index of desired bit label to access.
Return Value
A String value of the label corresponding to the parameter.
Remarks

In the final version of the protocol each digital bit can be labeled, but we read them out as one big string in the "Label" property so this property allows individual access to each label.

Note that the draft 6 implementation of the protocol supports one label for all 16-bits, however draft 7 (i.e., version 1) supports a label for each of the 16 bits.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


Label Property

Label Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► Label
Gets or sets the combined set of label images of this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override string Label { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides Property Label As String
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property String^ Label {
    String^ get () override;
    void set (String^ value) override;
}


LabelCount Property

LabelCount Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► LabelCount
Gets the number of labels defined in this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public int LabelCount { get; }
Public ReadOnly Property LabelCount As Integer
    Get
public:
property int LabelCount {
    int get ();
}


MaximumLabelLength Property

MaximumLabelLength Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► MaximumLabelLength
Gets the maximum length of the Label of this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
public:
virtual property int MaximumLabelLength {
    int get () override;
}


NormalStatus Property

NormalStatus Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► NormalStatus
Gets or sets normal status for this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public ushort NormalStatus { get; set; }
Public Property NormalStatus As UShort
    Get
    Set
public:
property unsigned short NormalStatus {
    unsigned short get ();
    void set (unsigned short value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► Parent
Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


SetLabel Method (index, value)

SetLabel Method (index, value)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► SetLabel(Int32, String)
Sets the individual labels for specified bit in this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public void SetLabel(
    int index,
    string value
)
Public Sub SetLabel ( _
    index As Integer, _
    value As String _
)
public:
void SetLabel(
    int index,
    String^ value
)
Parameters
index (Int32)
Index of desired bit label to access.
value (String)
Value of the bit label to assign.
Remarks

In the final version of the protocol each digital bit can be labeled, but we read them out as one big string in the "Label" property so this property allows individual access to each label.

Note that the draft 6 implementation of the protocol supports one label for all 16-bits, however draft 7 (i.e., version 1) supports a label for each of the 16 bits.


ValidInputs Property

ValidInputs Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► ValidInputs
Gets or sets valid input for this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public ushort ValidInputs { get; set; }
Public Property ValidInputs As UShort
    Get
    Set
public:
property unsigned short ValidInputs {
    unsigned short get ();
    void set (unsigned short value);
}


DigitalValue Class

DigitalValue Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalValue
Represents the IEEE C37.118 implementation of a IDigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DigitalValue : DigitalValueBase
<SerializableAttribute> _
Public Class DigitalValue _
    Inherits DigitalValueBase
[SerializableAttribute]
public ref class DigitalValue : public DigitalValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
 | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
 | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DigitalValueBase object. (Inherited from DigitalValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the DigitalValueBase object. (Inherited from DigitalValueBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from DigitalValueBase.)
 | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Inherited from DigitalValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the DigitalDefinition associated with this DigitalValue.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this DigitalValueBase. (Inherited from DigitalValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from DigitalValueBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DigitalValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Inherited from DigitalValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this DigitalValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from DigitalValueBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase. (Inherited from DigitalValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IDigitalDefinition >)>)>
 |  |  |  | DigitalValueBase
 |  |  |  |  | DigitalValue


DigitalValue Constructor

DigitalValue Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalValue ► DigitalValue()()()()
Members
Icon | Member | Description
 | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
 | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
 | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.


DigitalValue Constructor (info, context)

DigitalValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalValue ► DigitalValue(SerializationInfo, StreamingContext)
Creates a new DigitalValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DigitalValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DigitalValue Constructor (parent, digitalDefinition)

DigitalValue Constructor (parent, digitalDefinition)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalValue ► DigitalValue(IDataCell, IDigitalDefinition)
Creates a new DigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalValue(
    IDataCell parent,
    IDigitalDefinition digitalDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    digitalDefinition As IDigitalDefinition _
)
public:
DigitalValue(
    IDataCell^ parent,
    IDigitalDefinition^ digitalDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this DigitalValue.
digitalDefinition (IDigitalDefinition)
The IDigitalDefinition associated with this DigitalValue.


DigitalValue Constructor (parent, digitalDefinition, value)

DigitalValue Constructor (parent, digitalDefinition, value)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalValue ► DigitalValue(DataCell, DigitalDefinition, UInt16)
Creates a new DigitalValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalValue(
    DataCell parent,
    DigitalDefinition digitalDefinition,
    ushort value
)
Public Sub New ( _
    parent As DataCell, _
    digitalDefinition As DigitalDefinition, _
    value As UShort _
)
public:
DigitalValue(
    DataCell^ parent,
    DigitalDefinition^ digitalDefinition,
    unsigned short value
)
Parameters
parent (DataCell)
The DataCell parent of this DigitalValue.
digitalDefinition (DigitalDefinition)
The DigitalDefinition associated with this DigitalValue.
value (UInt16)
The unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValue.


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalValue ► Definition
Gets or sets the DigitalDefinition associated with this DigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DigitalDefinition Definition { get; set; }
Public Overridable Property Definition As DigitalDefinition
    Get
    Set
public:
virtual property DigitalDefinition^ Definition {
    DigitalDefinition^ get ();
    void set (DigitalDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalValue ► Parent
Gets or sets the DataCell parent of this DigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


DraftRevision Enumeration

DraftRevision Enumeration
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DraftRevision
Protocol draft revision numbers enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum DraftRevision
<SerializableAttribute> _
Public Enumeration DraftRevision
[SerializableAttribute]
public enum class DraftRevision
Members
Member | Description
Draft6 | Draft 6.0.
Draft7 | Draft 7.0 (Version 1.0).


FormatFlags Enumeration

FormatFlags Enumeration
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FormatFlags
Data format flags enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[FlagsAttribute]
public enum FormatFlags
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration FormatFlags
[SerializableAttribute]
[FlagsAttribute]
public enum class FormatFlags
Members
Member | Description
Frequency | Frequency value format (Set = float, Clear = integer).
Analog | Analog value format (Set = float, Clear = integer).
Phasors | Phasor value format (Set = float, Clear = integer).
Coordinates | Phasor coordinate format (Set = polar, Clear = rectangular).
UnusedMask | Unsed format bits mask.
NoFlags | No flags.


FrameParser Class

FrameParser Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser
Represents a frame parser for an IEEE C37.118 binary data stream and returns parsed data via events.
Declaration Syntax
C# Visual Basic Visual C++
public class FrameParser : FrameParserBase<FrameType>
Public Class FrameParser _
    Inherits FrameParserBase(Of FrameType)
public ref class FrameParser : public FrameParserBase<FrameType>
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrameParser(DraftRevision) | Creates a new FrameParser from specified parameters.
 | BeginRead(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead()()()() | (Inherited from BinaryImageParserBase.)
 | CanSeek()()()() | (Inherited from BinaryImageParserBase.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite()()()() | (Inherited from BinaryImageParserBase.)
 | Close()()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.ConfigurationFrame.)
 | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | CreateBufferQueue()()()() | Creates the internal buffer queue. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | DataDiscarded()()()() | (Inherited from BinaryImageParserBase.)
 | DataParsed()()()() | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBase<(Of <(<'TFrameIdentifier>)>)> object and optionally releases the managed resources. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | DraftRevision | Gets or sets the DraftRevision of this FrameParser.
 | DuplicateTypeHandlerEncountered()()()() | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | Enabled()()()() | (Inherited from BinaryImageParserBase.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteParseOnSeparateThread | Gets or sets a flag that allows frame parsing to be executed on a separate thread (i.e., other than communications thread). (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()()() | Clears all buffers for this stream and causes any buffered data to be parsed immediately. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length()()()() | (Inherited from BinaryImageParserBase.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()()()() | (Inherited from BinaryImageParserBase.)
 | OnConfigurationChanged()()()() | Raises the ConfigurationChanged event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnDataDiscarded(array<Byte>[]()[][]) | (Inherited from BinaryImageParserBase.)
 | OnDataParsed(UTP) | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | OnDuplicateTypeHandlerEncountered(Type, UTP) | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | OnOutputTypeNotFound(UTP) | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | OnParsingException(Exception) | (Inherited from BinaryImageParserBase.)
 | OnReceivedChannelFrame(IChannelFrame) | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame, ConfigurationFrame, CommandFrame or HeaderFrame). (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.OnReceivedChannelFrame(IChannelFrame).)
 | OnReceivedCommandFrame(ICommandFrame) | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedConfigurationFrame(IConfigurationFrame) | Raises the ReceivedConfigurationFrame event. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.OnReceivedConfigurationFrame(IConfigurationFrame).)
 | OnReceivedDataFrame(IDataFrame) | Raises the ReceivedDataFrame event. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.OnReceivedDataFrame(IDataFrame).)
 | OnReceivedFrameBufferImage(FundamentalFrameType, array<Byte>[]()[][], Int32, Int32) | Raises the ReceivedFrameBufferImage event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedHeaderFrame(IHeaderFrame) | Raises the ReceivedHeaderFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedUndeterminedFrame(IChannelFrame) | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnUnknownFrameTypeEncountered(FrameType) | Handles unknown frame types. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.OnUnknownFrameTypeEncountered(TFrameIdentifier).)
 | OutputTypeNotFound()()()() | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | Parse(ISupportBinaryImage) | (Inherited from BinaryImageParserBase.)
 | ParseCommonHeader(array<Byte>[]()[][], Int32, Int32) | Parses a common header instance that implements ICommonHeader for the output type represented in the binary image. (Overrides FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.ParseCommonHeader(array<Byte>[]()[][], Int32, Int32).)
 | ParseFrame(array<Byte>[]()[][], Int32, Int32) | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | ParseQueuedBuffers(array<array<Byte>[]()[][]>[]()[][]) | This method is used by the internal ProcessQueue to process all queued data buffers. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ParsingException()()()() | (Inherited from BinaryImageParserBase.)
 | Position()()()() | (Inherited from BinaryImageParserBase.)
 | ProtocolSyncBytes()()()() | (Inherited from BinaryImageParserBase.)
 | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBase.ProtocolUsesSyncBytes()()()().)
 | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Read(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageParserBase.)
 | ReadByte()()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | ReceivedCommandFrame | Occurs when an IEEE C37.118 CommandFrame has been received.
 | ReceivedConfigurationFrame | Occurs when a IConfigurationFrame has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ReceivedConfigurationFrame1 | Occurs when an IEEE C37.118 ConfigurationFrame1 has been received.
 | ReceivedConfigurationFrame2 | Occurs when an IEEE C37.118 ConfigurationFrame2 has been received.
 | ReceivedDataFrame | Occurs when an IEEE C37.118 DataFrame has been received.
 | ReceivedFrameBufferImage | Occurs when a frame buffer image has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ReceivedHeaderFrame | Occurs when an IEEE C37.118 HeaderFrame has been received.
 | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | RunTime()()()() | (Inherited from BinaryImageParserBase.)
 | Seek(Int64, SeekOrigin) | (Inherited from BinaryImageParserBase.)
 | SetLength(Int64) | (Inherited from BinaryImageParserBase.)
 | Start()()()() | Start the data parser. (Overrides FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.Start()()()().)
 | Start(IEnumerable<(Of <<'(Type>)>>)) | Starts the frame parser given the specified type implementations. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Status | Gets current descriptive status of the FrameParser. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.Status.)
 | Stop()()()() | Stops the frame parser. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | StreamInitialized()()()() | (Inherited from BinaryImageParserBase.)
 | Timebase | Gets the IEEE C37.118 resolution of fractional timestamps of the current ConfigurationFrame, if one has been parsed.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalProcessedBuffers()()()() | (Inherited from BinaryImageParserBase.)
 | UnparsedBuffer()()()() | (Inherited from BinaryImageParserBase.)
 | Write(array<Byte>[]()[][], Int32, Int32) | Writes a sequence of bytes onto the stream for parsing. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks
Frame parser is implemented as a write-only stream - this way data can come from any source.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | BinaryImageParserBase
 |  |  |  | FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>
 |  |  |  |  | FrameParserBase <(Of <(<' FrameType >)>)>
 |  |  |  |  |  | FrameParser


FrameParser Constructor (draftRevision)

FrameParser Constructor (draftRevision)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► FrameParser(DraftRevision)
Creates a new FrameParser from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrameParser(
    DraftRevision draftRevision
)
Public Sub New ( _
    draftRevision As DraftRevision _
)
public:
FrameParser(
    DraftRevision draftRevision
)
Parameters
draftRevision (DraftRevision)
The DraftRevision of this FrameParser.


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► ConfigurationFrame
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
Declaration Syntax
C# Visual Basic Visual C++
public override IConfigurationFrame ConfigurationFrame { get; set; }
Public Overrides Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () override;
    void set (IConfigurationFrame^ value) override;
}
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.


DraftRevision Property

DraftRevision Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► DraftRevision
Gets or sets the DraftRevision of this FrameParser.
Declaration Syntax
C# Visual Basic Visual C++
public DraftRevision DraftRevision { get; set; }
Public Property DraftRevision As DraftRevision
    Get
    Set
public:
property DraftRevision DraftRevision {
    DraftRevision get ();
    void set (DraftRevision value);
}


OnReceivedChannelFrame Method (frame)

OnReceivedChannelFrame Method (frame)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► OnReceivedChannelFrame(IChannelFrame)
Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame, ConfigurationFrame, CommandFrame or HeaderFrame).
Declaration Syntax
C# Visual Basic Visual C++
protected override void OnReceivedChannelFrame(
    IChannelFrame frame
)
Protected Overrides Sub OnReceivedChannelFrame ( _
    frame As IChannelFrame _
)
protected:
virtual void OnReceivedChannelFrame(
    IChannelFrame^ frame
) override
Parameters
frame (IChannelFrame)
IChannelFrame that was parsed by FrameImageParserBase that implements protocol specific common frame header interface.


OnReceivedConfigurationFrame Method (frame)

OnReceivedConfigurationFrame Method (frame)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► OnReceivedConfigurationFrame(IConfigurationFrame)
Raises the ReceivedConfigurationFrame event.
Declaration Syntax
C# Visual Basic Visual C++
protected override void OnReceivedConfigurationFrame(
    IConfigurationFrame frame
)
Protected Overrides Sub OnReceivedConfigurationFrame ( _
    frame As IConfigurationFrame _
)
protected:
virtual void OnReceivedConfigurationFrame(
    IConfigurationFrame^ frame
) override
Parameters
frame (IConfigurationFrame)
IConfigurationFrame to send to ReceivedConfigurationFrame event.


OnReceivedDataFrame Method (frame)

OnReceivedDataFrame Method (frame)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► OnReceivedDataFrame(IDataFrame)
Raises the ReceivedDataFrame event.
Declaration Syntax
C# Visual Basic Visual C++
protected override void OnReceivedDataFrame(
    IDataFrame frame
)
Protected Overrides Sub OnReceivedDataFrame ( _
    frame As IDataFrame _
)
protected:
virtual void OnReceivedDataFrame(
    IDataFrame^ frame
) override
Parameters
frame (IDataFrame)
IDataFrame to send to ReceivedDataFrame event.


OnUnknownFrameTypeEncountered Method (frameType)

OnUnknownFrameTypeEncountered Method (frameType)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► OnUnknownFrameTypeEncountered(FrameType)
Handles unknown frame types.
Declaration Syntax
C# Visual Basic Visual C++
protected override void OnUnknownFrameTypeEncountered(
    FrameType frameType
)
Protected Overrides Sub OnUnknownFrameTypeEncountered ( _
    frameType As FrameType _
)
protected:
virtual void OnUnknownFrameTypeEncountered(
    FrameType frameType
) override
Parameters
frameType (FrameType)
Unknown frame ID.


ParseCommonHeader Method (buffer, offset, length)

ParseCommonHeader Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► ParseCommonHeader(array<Byte>[]()[][], Int32, Int32)
Parses a common header instance that implements ICommonHeader for the output type represented in the binary image.
Declaration Syntax
C# Visual Basic Visual C++
protected override ICommonHeader<FrameType> ParseCommonHeader(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function ParseCommonHeader ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As ICommonHeader(Of FrameType)
protected:
virtual ICommonHeader<FrameType>^ ParseCommonHeader(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer containing data to parse.
offset (Int32)
Offset index into buffer that represents where to start parsing.
length (Int32)
Maximum length of valid data from offset.
Return Value
The ICommonHeader which includes a type ID for the Type to be parsed.
Remarks

Derived classes need to provide a common header instance (i.e., class that implements ICommonHeader) for the output types; this will primarily include an ID of the Type that the data image represents. This parsing is only for common header information, actual parsing will be handled by output type via its Initialize(array<Byte>[]()[][], Int32, Int32) method. This header image should also be used to add needed complex state information about the output type being parsed if needed.

If there is not enough buffer available to parse common header (as determined by length), return null. Also, if the protocol allows frame length to be determined at the time common header is being parsed and there is not enough buffer to parse the entire frame, it will be optimal to prevent further parsing by returning null.


ProtocolUsesSyncBytes Property

ProtocolUsesSyncBytes Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► ProtocolUsesSyncBytes
Gets flag that determines if this protocol parsing implementation uses synchronization bytes.
Declaration Syntax
C# Visual Basic Visual C++
public override bool ProtocolUsesSyncBytes { get; }
Public Overrides ReadOnly Property ProtocolUsesSyncBytes As Boolean
    Get
public:
virtual property bool ProtocolUsesSyncBytes {
    bool get () override;
}


ReceivedCommandFrame Event

ReceivedCommandFrame Event
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► ReceivedCommandFrame
Occurs when an IEEE C37.118 CommandFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<CommandFrame>> ReceivedCommandFrame
Public Event ReceivedCommandFrame As EventHandler(Of EventArgs(Of CommandFrame))
public:
 event EventHandler<EventArgs<CommandFrame^>^>^ ReceivedCommandFrame {
    void add (EventHandler<EventArgs<CommandFrame^>^>^ value);
    void remove (EventHandler<EventArgs<CommandFrame^>^>^ value);
}
Remarks
Argument()()()() is the CommandFrame that was received.

Command frames are normally sent, not received, but there is nothing that prevents this.


ReceivedConfigurationFrame1 Event

ReceivedConfigurationFrame1 Event
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► ReceivedConfigurationFrame1
Occurs when an IEEE C37.118 ConfigurationFrame1 has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<ConfigurationFrame1>> ReceivedConfigurationFrame1
Public Event ReceivedConfigurationFrame1 As EventHandler(Of EventArgs(Of ConfigurationFrame1))
public:
 event EventHandler<EventArgs<ConfigurationFrame1^>^>^ ReceivedConfigurationFrame1 {
    void add (EventHandler<EventArgs<ConfigurationFrame1^>^>^ value);
    void remove (EventHandler<EventArgs<ConfigurationFrame1^>^>^ value);
}
Remarks
Argument()()()() is the ConfigurationFrame1 that was received.


ReceivedConfigurationFrame2 Event

ReceivedConfigurationFrame2 Event
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► ReceivedConfigurationFrame2
Occurs when an IEEE C37.118 ConfigurationFrame2 has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<ConfigurationFrame2>> ReceivedConfigurationFrame2
Public Event ReceivedConfigurationFrame2 As EventHandler(Of EventArgs(Of ConfigurationFrame2))
public:
 event EventHandler<EventArgs<ConfigurationFrame2^>^>^ ReceivedConfigurationFrame2 {
    void add (EventHandler<EventArgs<ConfigurationFrame2^>^>^ value);
    void remove (EventHandler<EventArgs<ConfigurationFrame2^>^>^ value);
}
Remarks
Argument()()()() is the ConfigurationFrame2 that was received.


ReceivedDataFrame Event

ReceivedDataFrame Event
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► ReceivedDataFrame
Occurs when an IEEE C37.118 DataFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<DataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of DataFrame))
public:
 event EventHandler<EventArgs<DataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<DataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<DataFrame^>^>^ value);
}
Remarks
Argument()()()() is the DataFrame that was received.


ReceivedHeaderFrame Event

ReceivedHeaderFrame Event
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► ReceivedHeaderFrame
Occurs when an IEEE C37.118 HeaderFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<HeaderFrame>> ReceivedHeaderFrame
Public Event ReceivedHeaderFrame As EventHandler(Of EventArgs(Of HeaderFrame))
public:
 event EventHandler<EventArgs<HeaderFrame^>^>^ ReceivedHeaderFrame {
    void add (EventHandler<EventArgs<HeaderFrame^>^>^ value);
    void remove (EventHandler<EventArgs<HeaderFrame^>^>^ value);
}
Remarks
Argument()()()() is the HeaderFrame that was received.


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► Start()()()()
Start the data parser.
Declaration Syntax
C# Visual Basic Visual C++
public override void Start()
Public Overrides Sub Start
public:
virtual void Start() override


Status Property

Status Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► Status
Gets current descriptive status of the FrameParser.
Declaration Syntax
C# Visual Basic Visual C++
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
public:
virtual property String^ Status {
    String^ get () override;
}


Timebase Property

Timebase Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► Timebase
Gets the IEEE C37.118 resolution of fractional timestamps of the current ConfigurationFrame, if one has been parsed.
Declaration Syntax
C# Visual Basic Visual C++
public uint Timebase { get; }
Public ReadOnly Property Timebase As UInteger
    Get
public:
property unsigned int Timebase {
    unsigned int get ();
}


FrameType Enumeration

FrameType Enumeration
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameType
IEEE C37.118 frame types enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum FrameType
<SerializableAttribute> _
Public Enumeration FrameType
[SerializableAttribute]
public enum class FrameType
Members
Member | Description
DataFrame | 000 Data frame.
HeaderFrame | 001 Header frame.
ConfigurationFrame1 | 010 Configuration frame 1.
ConfigurationFrame2 | 011 Configuration frame 2.
CommandFrame | 100 Command frame.
Reserved | . Reserved bit.
VersionNumberMask | Version number mask.


FrequencyDefinition Class

FrequencyDefinition Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyDefinition
Represents the IEEE C37.118 implementation of a IFrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FrequencyDefinition : FrequencyDefinitionBase
<SerializableAttribute> _
Public Class FrequencyDefinition _
    Inherits FrequencyDefinitionBase
[SerializableAttribute]
public ref class FrequencyDefinition : public FrequencyDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
 | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
 | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the FrequencyDefinition object. (Overrides ChannelDefinitionBase.BodyImage.)
 | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBase.BodyLength.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides ChannelDefinitionBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | FrequencyDefinitionBase
 |  |  |  |  | FrequencyDefinition


FrequencyDefinition Constructor

FrequencyDefinition Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyDefinition ► FrequencyDefinition()()()()
Members
Icon | Member | Description
 | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
 | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
 | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.


FrequencyDefinition Constructor (info, context)

FrequencyDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyDefinition ► FrequencyDefinition(SerializationInfo, StreamingContext)
Creates a new FrequencyDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrequencyDefinition Constructor (parent)

FrequencyDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyDefinition ► FrequencyDefinition(IConfigurationCell)
Creates a new FrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
FrequencyDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this FrequencyDefinition.


FrequencyDefinition Constructor (parent, label)

FrequencyDefinition Constructor (parent, label)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyDefinition ► FrequencyDefinition(ConfigurationCell, String)
Creates a new FrequencyDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String _
)
public:
FrequencyDefinition(
    ConfigurationCell^ parent,
    String^ label
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this FrequencyDefinition.
label (String)
The label of this FrequencyDefinition.


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyDefinition ► BodyImage
Gets the binary body image of the FrequencyDefinition object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyDefinition ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyDefinition ► Parent
Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyDefinition ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Remarks
The base implementation assumes that all channel defintions begin with a label as this is the general case, override functionality if this is not the case.


FrequencyValue Class

FrequencyValue Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyValue
Represents the IEEE C37.118 implementation of a IFrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FrequencyValue : FrequencyValueBase
<SerializableAttribute> _
Public Class FrequencyValue _
    Inherits FrequencyValueBase
[SerializableAttribute]
public ref class FrequencyValue : public FrequencyValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
 | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
 | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from FrequencyValueBase.)
 | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
 | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this FrequencyValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from FrequencyValueBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
 | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IFrequencyDefinition >)>)>
 |  |  |  | FrequencyValueBase
 |  |  |  |  | FrequencyValue


FrequencyValue Constructor

FrequencyValue Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyValue ► FrequencyValue()()()()
Members
Icon | Member | Description
 | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
 | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
 | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.


FrequencyValue Constructor (info, context)

FrequencyValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyValue ► FrequencyValue(SerializationInfo, StreamingContext)
Creates a new FrequencyValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrequencyValue Constructor (parent, frequencyDefinition)

FrequencyValue Constructor (parent, frequencyDefinition)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyValue ► FrequencyValue(IDataCell, IFrequencyDefinition)
Creates a new FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyValue(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    frequencyDefinition As IFrequencyDefinition _
)
public:
FrequencyValue(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this FrequencyValue.
frequencyDefinition (IFrequencyDefinition)
The IFrequencyDefinition associated with this FrequencyValue.


FrequencyValue Constructor (parent, frequencyDefinition, frequency, dfdt)

FrequencyValue Constructor (parent, frequencyDefinition, frequency, dfdt)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyValue ► FrequencyValue(DataCell, FrequencyDefinition, Double, Double)
Creates a new FrequencyValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyValue(
    DataCell parent,
    FrequencyDefinition frequencyDefinition,
    double frequency,
    double dfdt
)
Public Sub New ( _
    parent As DataCell, _
    frequencyDefinition As FrequencyDefinition, _
    frequency As Double, _
    dfdt As Double _
)
public:
FrequencyValue(
    DataCell^ parent,
    FrequencyDefinition^ frequencyDefinition,
    double frequency,
    double dfdt
)
Parameters
parent (DataCell)
The DataCell parent of this FrequencyValue.
frequencyDefinition (FrequencyDefinition)
The FrequencyDefinition associated with this FrequencyValue.
frequency (Double)
The floating point value that represents this FrequencyValue.
dfdt (Double)
The floating point value that represents the change in this FrequencyValue over time.


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyValue ► Definition
Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual FrequencyDefinition Definition { get; set; }
Public Overridable Property Definition As FrequencyDefinition
    Get
    Set
public:
virtual property FrequencyDefinition^ Definition {
    FrequencyDefinition^ get ();
    void set (FrequencyDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyValue ► Parent
Gets or sets the DataCell parent of this FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


HeaderFrame Class

HeaderFrame Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame
Represents the IEEE C37.118 implementation of a IHeaderFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class HeaderFrame : HeaderFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
<SerializableAttribute> _
Public Class HeaderFrame _
    Inherits HeaderFrameBase _
    Implements ISupportFrameImage(Of FrameType), ISupportBinaryImage
[SerializableAttribute]
public ref class HeaderFrame : public HeaderFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HeaderFrame()()()() | Creates a new HeaderFrame.
 | HeaderFrame(String) | Creates a new HeaderFrame.
 | HeaderFrame(SerializationInfo, StreamingContext) | Creates a new HeaderFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the HeaderFrame object. (Overrides HeaderFrameBase.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' IHeaderCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the HeaderCellCollection for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CommonHeader | Gets or sets current CommonFrameHeader.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameType | Gets the FundamentalFrameType for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelFrameBase <(Of <(<' IHeaderCell >)>)>.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderData | Gets or sets header data for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
 | HeaderImage | Gets the binary header image of the HeaderFrame object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides BinaryImageBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this HeaderFrameBase. (Inherited from HeaderFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | TimeBase | Gets the IEEE C37.118 timebase of this HeaderFrame.
 | TimeQualityFlags | Gets or sets the TimeQualityFlags associated with this HeaderFrame.
 | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode associated with this HeaderFrame.
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this HeaderFrame. (Overrides ChannelFrameBase <(Of <(<' IHeaderCell >)>)>.Timestamp.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets the identifier that is used to identify the IEEE C37.118 frame.
 | Version | Gets the IEEE C37.118 protocol version of this HeaderFrame.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IHeaderCell >)>)>
 |  |  |  | HeaderFrameBase
 |  |  |  |  | HeaderFrame


HeaderFrame Constructor

HeaderFrame Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► HeaderFrame()()()()
Members
Icon | Member | Description
 | HeaderFrame()()()() | Creates a new HeaderFrame.
 | HeaderFrame(String) | Creates a new HeaderFrame.
 | HeaderFrame(SerializationInfo, StreamingContext) | Creates a new HeaderFrame from serialization parameters.


HeaderFrame Constructor

HeaderFrame Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► HeaderFrame()()()()
Creates a new HeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
public HeaderFrame()
Public Sub New
public:
HeaderFrame()
Remarks
This constructor is used by a consumer or by FrameImageParserBase to generate or parse an IEEE C37.118 header frame.


HeaderFrame Constructor (info, context)

HeaderFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► HeaderFrame(SerializationInfo, StreamingContext)
Creates a new HeaderFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected HeaderFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
HeaderFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


HeaderFrame Constructor (headerData)

HeaderFrame Constructor (headerData)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► HeaderFrame(String)
Creates a new HeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
public HeaderFrame(
    string headerData
)
Public Sub New ( _
    headerData As String _
)
public:
HeaderFrame(
    String^ headerData
)
Parameters
headerData (String)
String based data to include in this HeaderFrame.
Remarks
This constructor is used by a consumer to generate an IEEE C37.118 header frame.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the HeaderFrame object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.


CommonHeader Property

CommonHeader Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► CommonHeader
Gets or sets current CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► HeaderImage
Gets the binary header image of the HeaderFrame object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


TimeBase Property

TimeBase Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► TimeBase
Gets the IEEE C37.118 timebase of this HeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
public uint TimeBase { get; }
Public ReadOnly Property TimeBase As UInteger
    Get
public:
property unsigned int TimeBase {
    unsigned int get ();
}


TimeQualityFlags Property

TimeQualityFlags Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► TimeQualityFlags
Gets or sets the TimeQualityFlags associated with this HeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
public TimeQualityFlags TimeQualityFlags { get; set; }
Public Property TimeQualityFlags As TimeQualityFlags
    Get
    Set
public:
property TimeQualityFlags TimeQualityFlags {
    TimeQualityFlags get ();
    void set (TimeQualityFlags value);
}


TimeQualityIndicatorCode Property

TimeQualityIndicatorCode Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► TimeQualityIndicatorCode
Gets or sets the TimeQualityIndicatorCode associated with this HeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
public TimeQualityIndicatorCode TimeQualityIndicatorCode { get; set; }
Public Property TimeQualityIndicatorCode As TimeQualityIndicatorCode
    Get
    Set
public:
property TimeQualityIndicatorCode TimeQualityIndicatorCode {
    TimeQualityIndicatorCode get ();
    void set (TimeQualityIndicatorCode value);
}


Timestamp Property

Timestamp Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► Timestamp
Gets or sets exact timestamp, in ticks, of the data represented by this HeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► TypeID
Gets the identifier that is used to identify the IEEE C37.118 frame.
Declaration Syntax
C# Visual Basic Visual C++
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}


Version Property

Version Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► Version
Gets the IEEE C37.118 protocol version of this HeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
public byte Version { get; }
Public ReadOnly Property Version As Byte
    Get
public:
property unsigned char Version {
    unsigned char get ();
}


PhasorDefinition Class

PhasorDefinition Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► PhasorDefinition
Represents the IEEE C37.118 implementation of a IPhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PhasorDefinition : PhasorDefinitionBase
<SerializableAttribute> _
Public Class PhasorDefinition _
    Inherits PhasorDefinitionBase
[SerializableAttribute]
public ref class PhasorDefinition : public PhasorDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | PhasorDefinitionBase
 |  |  |  |  | PhasorDefinition


PhasorDefinition Constructor

PhasorDefinition Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► PhasorDefinition ► PhasorDefinition()()()()
Members
Icon | Member | Description
 | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.


PhasorDefinition Constructor (info, context)

PhasorDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► PhasorDefinition ► PhasorDefinition(SerializationInfo, StreamingContext)
Creates a new PhasorDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


PhasorDefinition Constructor (parent)

PhasorDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► PhasorDefinition ► PhasorDefinition(IConfigurationCell)
Creates a new PhasorDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
PhasorDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this PhasorDefinition.


PhasorDefinition Constructor (parent, label, scale, offset, type, voltageReference)

PhasorDefinition Constructor (parent, label, scale, offset, type, voltageReference)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► PhasorDefinition ► PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition)
Creates a new PhasorDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinition(
    ConfigurationCell parent,
    string label,
    uint scale,
    double offset,
    PhasorType type,
    PhasorDefinition voltageReference
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String, _
    scale As UInteger, _
    offset As Double, _
    type As PhasorType, _
    voltageReference As PhasorDefinition _
)
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset,
    PhasorType type,
    PhasorDefinition^ voltageReference
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this PhasorDefinition.
label (String)
The label of this PhasorDefinition.
scale (UInt32)
The integer scaling value of this PhasorDefinition.
offset (Double)
The offset of this PhasorDefinition.
type (PhasorType)
The PhasorType of this PhasorDefinition.
voltageReference (PhasorDefinition)
The associated IPhasorDefinition that represents the voltage reference (if any).


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► PhasorDefinition ► Parent
Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


PhasorValue Class

PhasorValue Class
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► PhasorValue
Represents the IEEE C37.118 implementation of a IPhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PhasorValue : PhasorValueBase
<SerializableAttribute> _
Public Class PhasorValue _
    Inherits PhasorValueBase
[SerializableAttribute]
public ref class PhasorValue : public PhasorValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
 | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
 | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
 | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
 | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this PhasorValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from PhasorValueBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IPhasorDefinition >)>)>
 |  |  |  | PhasorValueBase
 |  |  |  |  | PhasorValue


PhasorValue Constructor

PhasorValue Constructor
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► PhasorValue ► PhasorValue()()()()
Members
Icon | Member | Description
 | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
 | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.


PhasorValue Constructor (info, context)

PhasorValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► PhasorValue ► PhasorValue(SerializationInfo, StreamingContext)
Creates a new PhasorValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


PhasorValue Constructor (parent, phasorDefinition)

PhasorValue Constructor (parent, phasorDefinition)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► PhasorValue ► PhasorValue(IDataCell, IPhasorDefinition)
Creates a new PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    IDataCell parent,
    IPhasorDefinition phasorDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    phasorDefinition As IPhasorDefinition _
)
public:
PhasorValue(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this PhasorValue.
phasorDefinition (IPhasorDefinition)
The IPhasorDefinition associated with this PhasorValue.


PhasorValue Constructor (parent, phasorDefinition, real, imaginary)

PhasorValue Constructor (parent, phasorDefinition, real, imaginary)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► PhasorValue ► PhasorValue(DataCell, PhasorDefinition, Double, Double)
Creates a new PhasorValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    double real,
    double imaginary
)
Public Sub New ( _
    parent As DataCell, _
    phasorDefinition As PhasorDefinition, _
    real As Double, _
    imaginary As Double _
)
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    double real,
    double imaginary
)
Parameters
parent (DataCell)
The DataCell parent of this PhasorValue.
phasorDefinition (PhasorDefinition)
The PhasorDefinition associated with this PhasorValue.
real (Double)
The real value of this PhasorValue.
imaginary (Double)
The imaginary value of this PhasorValue.


PhasorValue Constructor (parent, phasorDefinition, angle, magnitude)

PhasorValue Constructor (parent, phasorDefinition, angle, magnitude)
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► PhasorValue ► PhasorValue(DataCell, PhasorDefinition, Angle, Double)
Creates a new PhasorValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    Angle angle,
    double magnitude
)
Public Sub New ( _
    parent As DataCell, _
    phasorDefinition As PhasorDefinition, _
    angle As Angle, _
    magnitude As Double _
)
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    Angle angle,
    double magnitude
)
Parameters
parent (DataCell)
The DataCell parent of this PhasorValue.
phasorDefinition (PhasorDefinition)
The PhasorDefinition associated with this PhasorValue.
angle (Angle)
The Angle value (a.k.a., the argument) of this PhasorValue, in radians.
magnitude (Double)
The magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue.


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► PhasorValue ► Definition
Gets or sets the PhasorDefinition associated with this PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual PhasorDefinition Definition { get; set; }
Public Overridable Property Definition As PhasorDefinition
    Get
    Set
public:
virtual property PhasorDefinition^ Definition {
    PhasorDefinition^ get ();
    void set (PhasorDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► PhasorValue ► Parent
Gets or sets the DataCell parent of this PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


StatusFlags Enumeration

StatusFlags Enumeration
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► StatusFlags
Status flags enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[FlagsAttribute]
public enum StatusFlags
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration StatusFlags
[SerializableAttribute]
[FlagsAttribute]
public enum class StatusFlags
Members
Member | Description
DataIsValid | Data is valid (0 when device data is valid, 1 when invalid or device is in test mode).
DeviceError | Device error including configuration error, 0 when no error.
DeviceSynchronizationError | Device synchronization error, 0 when in sync.
DataSortingType | Data sorting type, 0 by timestamp, 1 by arrival.
DeviceTriggerDetected | Device trigger detected, 0 when no trigger.
ConfigurationChanged | Configuration changed, set to 1 for one minute when configuration changed.
ReservedFlags | Reserved bits for security, presently set to 0.
UnlockedTimeMask | Unlocked time mask.
TriggerReasonMask | Trigger reason mask.
NoFlags | No flags.


TimeQualityFlags Enumeration

TimeQualityFlags Enumeration
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► TimeQualityFlags
Time quality flags enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[FlagsAttribute]
public enum TimeQualityFlags
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration TimeQualityFlags
[SerializableAttribute]
[FlagsAttribute]
public enum class TimeQualityFlags
Members
Member | Description
Reserved | Reserved bit.
LeapSecondDirection | Leap second direction – 0 for add, 1 for delete.
LeapSecondOccurred | Leap second occurred – set in the first second after the leap second occurs and remains set for 24 hours.
LeapSecondPending | Leap second pending – set before a leap second occurs and cleared in the second after the leap second occurs.
TimeQualityIndicatorCodeMask | Time quality indicator code mask.
NoFlags | No flags.


TimeQualityIndicatorCode Enumeration

TimeQualityIndicatorCode Enumeration
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► TimeQualityIndicatorCode
Time quality indicator code enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum TimeQualityIndicatorCode
<SerializableAttribute> _
Public Enumeration TimeQualityIndicatorCode
[SerializableAttribute]
public enum class TimeQualityIndicatorCode
Members
Member | Description
Failure | 1111 - 0xF: Fault--clock failure, time not reliable.
UnlockedWithin10Seconds | 1011 - 0xB: Clock unlocked, time within 10^1 s.
UnlockedWithin1Second | 1010 - 0xA: Clock unlocked, time within 10^0 s.
UnlockedWithinPoint1Seconds | 1001 - 0x9: Clock unlocked, time within 10^-1 s.
UnlockedWithinPoint01Seconds | 1000 - 0x8: Clock unlocked, time within 10^-2 s.
UnlockedWithinPoint001Seconds | 0111 - 0x7: Clock unlocked, time within 10^-3 s.
UnlockedWithinPoint0001Seconds | 0110 - 0x6: Clock unlocked, time within 10^-4 s.
UnlockedWithinPoint00001Seconds | 0101 - 0x5: Clock unlocked, time within 10^-5 s.
UnlockedWithinPoint000001Seconds | 0100 - 0x4: Clock unlocked, time within 10^-6 s.
UnlockedWithinPoint0000001Seconds | 0011 - 0x3: Clock unlocked, time within 10^-7 s.
UnlockedWithinPoint00000001Seconds | 0010 - 0x2: Clock unlocked, time within 10^-8 s.
UnlockedWithinPoint000000001Seconds | 0001 - 0x1: Clock unlocked, time within 10^-9 s.
Locked | 0000 - 0x0: Normal operation, clock locked.


TriggerReason Enumeration

TriggerReason Enumeration
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► TriggerReason
Trigger reason enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum TriggerReason
<SerializableAttribute> _
Public Enumeration TriggerReason
[SerializableAttribute]
public enum class TriggerReason
Members
Member | Description
VendorDefinedTrigger8 | 1111 Vendor defined trigger 8.
VendorDefinedTrigger7 | 1110 Vendor defined trigger 7.
VendorDefinedTrigger6 | 1101 Vendor defined trigger 6.
VendorDefinedTrigger5 | 1100 Vendor defined trigger 5.
VendorDefinedTrigger4 | 1011 Vendor defined trigger 4.
VendorDefinedTrigger3 | 1010 Vendor defined trigger 3.
VendorDefinedTrigger2 | 1001 Vendor defined trigger 2.
VendorDefinedTrigger1 | 1000 Vendor defined trigger 1.
Digital | 0111 Digital.
DfDtHigh | 0101 df/dt high.
PhaseAngleDifference | 0011 Phase angle difference.
MagnitudeLow | 0001 Magnitude low.
Reserved | 0110 Reserved.
FrequencyHighOrLow | 0100 Frequency high/low.
MagnitudeHigh | 0010 Magnitude high.
Manual | 0000 Manual.


UnlockedTime Enumeration

UnlockedTime Enumeration
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► UnlockedTime
Unlocked time enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum UnlockedTime
<SerializableAttribute> _
Public Enumeration UnlockedTime
[SerializableAttribute]
public enum class UnlockedTime
Members
Member | Description
SyncLocked | Sync locked, best quality.
UnlockedFor10Seconds | Unlocked for 10 seconds.
UnlockedFor100Seconds | Unlocked for 100 seconds.
UnlockedForOver1000Seconds | Unlocked for over 1000 seconds.


TVA.PhasorProtocols.Macrodyne Namespace

TVA.PhasorProtocols.Macrodyne Namespace
Namespaces ► TVA.PhasorProtocols.Macrodyne
Contains an implementation of the phasor classes used to parse or generate a stream of data in the Macrodyne PMU device format.
Declaration Syntax
C# Visual Basic Visual C++
namespace TVA.PhasorProtocols.Macrodyne
Namespace TVA.PhasorProtocols.Macrodyne
namespace TVA.PhasorProtocols.Macrodyne
Types
All Types Classes Enumerations
Icon | Type | Description
 | ClockStatusFlags | Macrodyne clock status flags enumeration (from byte 1 in time string).
 | CommandFrame | Represents the Macrodyne implementation of a ICommandFrame that can be sent or received.
 | Common | Common Macrodyne declarations and functions.
 | CommonFrameHeader | Represents the common header for all Macrodyne frames of data.
 | ConfigurationCell | Represents the Macrodyne implementation of a IConfigurationCell that can be sent or received.
 | ConfigurationCellCollection | Represents a Macrodyne implementation of a collection of IConfigurationCell objects.
 | ConfigurationFrame | Represents the Macrodyne implementation of a IConfigurationFrame that can be sent or received.
 | ConfigurationFrameParsingState | Represents the Macrodyne implementation of the parsing state used by a ConfigurationFrame.
 | DataCell | Represents the Macrodyne implementation of a IDataCell that can be sent or received.
 | DataCellCollection | Represents a Macrodyne implementation of a collection of IDataCell objects.
 | DataFrame | Represents the Macrodyne implementation of a IDataFrame that can be sent or received.
 | DataInputCommand | Macrodyne data input commands enumeration.
 | DeviceCommand | Macrodyne set and request commands enumeration.
 | DevicePort | Macrodyne device ports enumeration.
 | DigitalDefinition | Represents the Macrodyne implementation of an IDigitalDefinition.
 | DigitalValue | Represents the Macrodyne implementation of an IDigitalValue.
 | FrameParser | Represents a frame parser for a Macrodyne binary data stream that returns parsed data via events.
 | FrameType | Macrodyne frame types enumeration.
 | FrequencyDefinition | Represents the Macrodyne implementation of a IFrequencyDefinition.
 | FrequencyValue | Represents the Macrodyne implementation of a IFrequencyValue.
 | GpsStatus | Macrodyne GPS status enumeration (from Status 2 byte, bits 3-4).
 | HeaderFrame | Represents the Macrodyne implementation of a IHeaderFrame that can be sent or received.
 | OnlineDataFormatFlags | Macrodyne ON-LINE data format flags enumeration (from RequestOnlineDataFormat 2 byte response).
 | OperationalLimitFlags | Macrodyne operational limit reached flags enumeration (from RequestOperationalLimitFlags first byte of 3 byte response).
 | PhasorDefinition | Represents the Macrodyne implementation of a IPhasorDefinition.
 | PhasorValue | Represents the Macrodyne implementation of a IPhasorValue.
 | StatusFlags | Macrodyne status flags enumeration (from Status 1 byte).
 | TriggerReason | Macrodyne trigger reason enumeration (from Status 2 byte, bits 0-2).


ClockStatusFlags Enumeration

ClockStatusFlags Enumeration
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ClockStatusFlags
Macrodyne clock status flags enumeration (from byte 1 in time string).
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[FlagsAttribute]
public enum ClockStatusFlags
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration ClockStatusFlags
[SerializableAttribute]
[FlagsAttribute]
public enum class ClockStatusFlags
Members
Member | Description
DacBeyondLimits | Set when DAC811 adjustment on the GPS board is beyond limits.
GpsComIssue | Set when the time output is that from the internal buffer (in GPS board processor) incremented by one second.
GpsUnlocked | Set when the internal oscillator is not disciplined (the GPS clock is not locked).
GpsTimeInvalid | Set when the last GPS receiver time tag was invalid.
ResynchronizationPending | Set when the system is about to be resynchronized to the GPS receiver.
ErrorCondition | Set when an error condition exists.
UsingLocalTime | Set for local time mode, cleared for UTC mode.
ClockAndReceiverOutOfSync | Set when the GPS clock 1 PPS and the GPS receiver 1 PPS differ by more than 5 microseconds.
NoFlags | No flags.


CommandFrame Class

CommandFrame Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommandFrame
Represents the Macrodyne implementation of a ICommandFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CommandFrame : CommandFrameBase
<SerializableAttribute> _
Public Class CommandFrame _
    Inherits CommandFrameBase
[SerializableAttribute]
public ref class CommandFrame : public CommandFrameBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandFrame(DeviceCommand) | Creates a new CommandFrame from specified parameters.
 | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the CommandFrameBase object. (Inherited from CommandFrameBase.)
 | BinaryImage | Gets the binary body image of this CommandFrame. (Overrides ChannelFrameBase <(Of <(<' ICommandCell >)>)>.BinaryImage.)
 | BinaryLength | Gets the length of the BinaryImage. (Overrides ChannelFrameBase <(Of <(<' ICommandCell >)>)>.BinaryLength.)
 | BodyImage | Gets the binary body image of this CommandFrameBase. (Inherited from CommandFrameBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from CommandFrameBase.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' ICommandCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the CommandCellCollection for this CommandFrameBase. (Inherited from CommandFrameBase.)
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Command | Gets or sets the DeviceCommand for this CommandFrame.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ExtendedData | Gets or sets extended binary image data for this CommandFrameBase. (Inherited from CommandFrameBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Inherited from CommandFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from CommandFrameBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from CommandFrameBase.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this CommandFrameBase. (Inherited from CommandFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Macrodyne command frames are designed only to be sent to a device, not received from a device. As a result this frame does not implement ISupportFrameImage for automated frame parsing.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' ICommandCell >)>)>
 |  |  |  | CommandFrameBase
 |  |  |  |  | CommandFrame


CommandFrame Constructor

CommandFrame Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommandFrame ► CommandFrame()()()()
Members
Icon | Member | Description
 | CommandFrame(DeviceCommand) | Creates a new CommandFrame from specified parameters.
 | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.


CommandFrame Constructor (info, context)

CommandFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommandFrame ► CommandFrame(SerializationInfo, StreamingContext)
Creates a new CommandFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected CommandFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CommandFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


CommandFrame Constructor (command)

CommandFrame Constructor (command)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommandFrame ► CommandFrame(DeviceCommand)
Creates a new CommandFrame from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public CommandFrame(
    DeviceCommand command
)
Public Sub New ( _
    command As DeviceCommand _
)
public:
CommandFrame(
    DeviceCommand command
)
Parameters
command (DeviceCommand)
The DeviceCommand for this CommandFrame.
Remarks
This constructor is used by a consumer to generate an Macrodyne command frame.


BinaryImage Property

BinaryImage Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommandFrame ► BinaryImage
Gets the binary body image of this CommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
public override byte[] BinaryImage { get; }
Public Overrides ReadOnly Property BinaryImage As Byte()
    Get
public:
virtual property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get () override;
}


BinaryLength Property

BinaryLength Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommandFrame ► BinaryLength
Gets the length of the BinaryImage.
Declaration Syntax
C# Visual Basic Visual C++
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
public:
virtual property int BinaryLength {
    int get () override;
}


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommandFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.
Remarks
The Macrodyne does not use checksums for sending commands.


Command Property

Command Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommandFrame ► Command
Gets or sets the DeviceCommand for this CommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
public DeviceCommand Command { get; set; }
Public Property Command As DeviceCommand
    Get
    Set
public:
property DeviceCommand Command {
    DeviceCommand get ();
    void set (DeviceCommand value);
}


Common Class

Common Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► Common
Common Macrodyne declarations and functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class Common
Public NotInheritable Class Common
public ref class Common abstract sealed
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GpsStatusMask | Macrodyne GPS status mask (from Status 2 byte, bits 3-4).
 | GpsSynchronizationBit | GPS synchronization bit (from Status 2 byte, bits 7): set = last time mark was true / tracking, not set = last time mark was false / not tracking.
 | MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
 | MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
 | MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
 | MaximumExtendedDataLength | Absolute maximum number of bytes of extended data that could fit into a command frame.
 | MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
 | ReferenceInputPortBit | Reference input port bit (from Status 2 byte, bits 5): set = port 3, not set = port 4.
 | ReferenceOutputPortBit | Reference output port bit (from Status 2 byte, bits 6): set = port 2, not set = port 1.
 | TriggerReasonMask | Macrodyne trigger reason mask (from Status 2 byte, bits 0-2).
Inheritance Hierarchy
Object
Common


GpsStatusMask Field

GpsStatusMask Field
Namespaces ► TVA.PhasorProtocols.Macrodyne ► Common ► GpsStatusMask
Macrodyne GPS status mask (from Status 2 byte, bits 3-4).
Declaration Syntax
C# Visual Basic Visual C++
public const byte GpsStatusMask
Public Const GpsStatusMask As Byte
public:
literal unsigned char GpsStatusMask


GpsSynchronizationBit Field

GpsSynchronizationBit Field
Namespaces ► TVA.PhasorProtocols.Macrodyne ► Common ► GpsSynchronizationBit
GPS synchronization bit (from Status 2 byte, bits 7): set = last time mark was true / tracking, not set = last time mark was false / not tracking.
Declaration Syntax
C# Visual Basic Visual C++
public const byte GpsSynchronizationBit
Public Const GpsSynchronizationBit As Byte
public:
literal unsigned char GpsSynchronizationBit


MaximumAnalogValues Field

MaximumAnalogValues Field
Namespaces ► TVA.PhasorProtocols.Macrodyne ► Common ► MaximumAnalogValues
Absolute maximum number of possible analog values that could fit into a data frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumAnalogValues
Public Const MaximumAnalogValues As UShort
public:
literal unsigned short MaximumAnalogValues


MaximumDataLength Field

MaximumDataLength Field
Namespaces ► TVA.PhasorProtocols.Macrodyne ► Common ► MaximumDataLength
Absolute maximum data length (in bytes) that could fit into any frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumDataLength
Public Const MaximumDataLength As UShort
public:
literal unsigned short MaximumDataLength


MaximumDigitalValues Field

MaximumDigitalValues Field
Namespaces ► TVA.PhasorProtocols.Macrodyne ► Common ► MaximumDigitalValues
Absolute maximum number of possible digital values that could fit into a data frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumDigitalValues
Public Const MaximumDigitalValues As UShort
public:
literal unsigned short MaximumDigitalValues


MaximumExtendedDataLength Field

MaximumExtendedDataLength Field
Namespaces ► TVA.PhasorProtocols.Macrodyne ► Common ► MaximumExtendedDataLength
Absolute maximum number of bytes of extended data that could fit into a command frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumExtendedDataLength
Public Const MaximumExtendedDataLength As UShort
public:
literal unsigned short MaximumExtendedDataLength


MaximumPhasorValues Field

MaximumPhasorValues Field
Namespaces ► TVA.PhasorProtocols.Macrodyne ► Common ► MaximumPhasorValues
Absolute maximum number of possible phasor values that could fit into a data frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumPhasorValues
Public Const MaximumPhasorValues As UShort
public:
literal unsigned short MaximumPhasorValues


ReferenceInputPortBit Field

ReferenceInputPortBit Field
Namespaces ► TVA.PhasorProtocols.Macrodyne ► Common ► ReferenceInputPortBit
Reference input port bit (from Status 2 byte, bits 5): set = port 3, not set = port 4.
Declaration Syntax
C# Visual Basic Visual C++
public const byte ReferenceInputPortBit
Public Const ReferenceInputPortBit As Byte
public:
literal unsigned char ReferenceInputPortBit


ReferenceOutputPortBit Field

ReferenceOutputPortBit Field
Namespaces ► TVA.PhasorProtocols.Macrodyne ► Common ► ReferenceOutputPortBit
Reference output port bit (from Status 2 byte, bits 6): set = port 2, not set = port 1.
Declaration Syntax
C# Visual Basic Visual C++
public const byte ReferenceOutputPortBit
Public Const ReferenceOutputPortBit As Byte
public:
literal unsigned char ReferenceOutputPortBit


TriggerReasonMask Field

TriggerReasonMask Field
Namespaces ► TVA.PhasorProtocols.Macrodyne ► Common ► TriggerReasonMask
Macrodyne trigger reason mask (from Status 2 byte, bits 0-2).
Declaration Syntax
C# Visual Basic Visual C++
public const byte TriggerReasonMask
Public Const TriggerReasonMask As Byte
public:
literal unsigned char TriggerReasonMask


CommonFrameHeader Class

CommonFrameHeader Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommonFrameHeader
Represents the common header for all Macrodyne frames of data.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CommonFrameHeader : CommonHeaderBase<FrameType>,
    ISerializable
<SerializableAttribute> _
Public Class CommonFrameHeader _
    Inherits CommonHeaderBase(Of FrameType) _
    Implements ISerializable
[SerializableAttribute]
public ref class CommonFrameHeader : public CommonHeaderBase<FrameType>,
    ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommonFrameHeader()()()() | Creates a new CommonFrameHeader.
 | CommonFrameHeader(array<Byte>[]()[][], Int32, ConfigurationFrame) | Creates a new CommonFrameHeader from given binaryImage.
 | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
 | BinaryImage | Gets the binary image of the common header portion of this CommonFrameHeader.
 | DataLength | Gets the Macrodyne data length.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FixedLength | Total fixed length of CommonFrameHeader.
 | FrameLength | Gets the Macrodyne frame length.
 | FrameType | Gets the fundamental frame type of this frame.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | State()()()() | (Inherited from CommonHeaderBase<(Of <(<' FrameType >)>)>.)
 | StatusFlags | Gets or sets the StatusFlags of this CommonFrameHeader.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID()()()() | (Inherited from CommonHeaderBase<(Of <(<' FrameType >)>)>.)
Inheritance Hierarchy
Object
 | CommonHeaderBase<(Of <(<' FrameType >)>)>
 |  | CommonFrameHeader


CommonFrameHeader Constructor

CommonFrameHeader Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommonFrameHeader ► CommonFrameHeader()()()()
Members
Icon | Member | Description
 | CommonFrameHeader()()()() | Creates a new CommonFrameHeader.
 | CommonFrameHeader(array<Byte>[]()[][], Int32, ConfigurationFrame) | Creates a new CommonFrameHeader from given binaryImage.
 | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.


CommonFrameHeader Constructor

CommonFrameHeader Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommonFrameHeader ► CommonFrameHeader()()()()
Creates a new CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader()
Public Sub New
public:
CommonFrameHeader()


CommonFrameHeader Constructor (binaryImage, startIndex, configurationFrame)

CommonFrameHeader Constructor (binaryImage, startIndex, configurationFrame)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommonFrameHeader ► CommonFrameHeader(array<Byte>[]()[][], Int32, ConfigurationFrame)
Creates a new CommonFrameHeader from given binaryImage.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader(
    byte[] binaryImage,
    int startIndex,
    ConfigurationFrame configurationFrame
)
Public Sub New ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    configurationFrame As ConfigurationFrame _
)
public:
CommonFrameHeader(
    array<unsigned char>^ binaryImage,
    int startIndex,
    ConfigurationFrame^ configurationFrame
)
Parameters
binaryImage (array< Byte >[]()[][])
Buffer that contains data to parse.
startIndex (Int32)
Start index into buffer where valid data begins.
configurationFrame (ConfigurationFrame)
Configuration frame, if available.


CommonFrameHeader Constructor (info, context)

CommonFrameHeader Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommonFrameHeader ► CommonFrameHeader(SerializationInfo, StreamingContext)
Creates a new CommonFrameHeader from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected CommonFrameHeader(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CommonFrameHeader(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


BinaryImage Property

BinaryImage Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommonFrameHeader ► BinaryImage
Gets the binary image of the common header portion of this CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public byte[] BinaryImage { get; }
Public ReadOnly Property BinaryImage As Byte()
    Get
public:
property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get ();
}


DataLength Property

DataLength Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommonFrameHeader ► DataLength
Gets the Macrodyne data length.
Declaration Syntax
C# Visual Basic Visual C++
public ushort DataLength { get; }
Public ReadOnly Property DataLength As UShort
    Get
public:
property unsigned short DataLength {
    unsigned short get ();
}


FixedLength Field

FixedLength Field
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommonFrameHeader ► FixedLength
Total fixed length of CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort FixedLength
Public Const FixedLength As UShort
public:
literal unsigned short FixedLength


FrameLength Property

FrameLength Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommonFrameHeader ► FrameLength
Gets the Macrodyne frame length.
Declaration Syntax
C# Visual Basic Visual C++
public ushort FrameLength { get; }
Public ReadOnly Property FrameLength As UShort
    Get
public:
property unsigned short FrameLength {
    unsigned short get ();
}


FrameType Property

FrameType Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommonFrameHeader ► FrameType
Gets the fundamental frame type of this frame.
Declaration Syntax
C# Visual Basic Visual C++
public FundamentalFrameType FrameType { get; }
Public ReadOnly Property FrameType As FundamentalFrameType
    Get
public:
property FundamentalFrameType FrameType {
    FundamentalFrameType get ();
}
Remarks
Frames are generally classified as data, configuration or header frames. This returns the general frame classification.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommonFrameHeader ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


StatusFlags Property

StatusFlags Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommonFrameHeader ► StatusFlags
Gets or sets the StatusFlags of this CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public StatusFlags StatusFlags { get; set; }
Public Property StatusFlags As StatusFlags
    Get
    Set
public:
property StatusFlags StatusFlags {
    StatusFlags get ();
    void set (StatusFlags value);
}


ConfigurationCell Class

ConfigurationCell Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCell
Represents the Macrodyne implementation of a IConfigurationCell that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationCell : ConfigurationCellBase
<SerializableAttribute> _
Public Class ConfigurationCell _
    Inherits ConfigurationCellBase
[SerializableAttribute]
public ref class ConfigurationCell : public ConfigurationCellBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCell(ConfigurationFrame) | Creates a new ConfigurationCell from specified parameters.
 | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
 | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.AnalogDataFormat.)
 | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
 | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
 | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
 | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage | Gets the binary footer image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationCellBase.)
 | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBase.FrequencyDataFormat.)
 | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationCellBase.)
 | IDCode | Gets or sets the ID code of this ConfigurationCell. (Overrides ChannelCellBase.IDCode.)
 | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCell. (Overrides ConfigurationCellBase.MaximumStationNameLength.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ConfigurationCellBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary footer image. (Inherited from ConfigurationCellBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Inherited from ConfigurationCellBase.)
 | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.PhasorCoordinateFormat.)
 | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.PhasorDataFormat.)
 | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | ConfigurationCellBase
 |  |  |  |  | ConfigurationCell


ConfigurationCell Constructor

ConfigurationCell Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCell ► ConfigurationCell()()()()
Members
Icon | Member | Description
 | ConfigurationCell(ConfigurationFrame) | Creates a new ConfigurationCell from specified parameters.
 | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.


ConfigurationCell Constructor (info, context)

ConfigurationCell Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCell ► ConfigurationCell(SerializationInfo, StreamingContext)
Creates a new ConfigurationCell from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationCell(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationCell Constructor (parent)

ConfigurationCell Constructor (parent)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCell ► ConfigurationCell(ConfigurationFrame)
Creates a new ConfigurationCell from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell(
    ConfigurationFrame parent
)
Public Sub New ( _
    parent As ConfigurationFrame _
)
public:
ConfigurationCell(
    ConfigurationFrame^ parent
)
Parameters
parent (ConfigurationFrame)
The parent ConfigurationFrame reference to use.


AnalogDataFormat Property

AnalogDataFormat Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCell ► AnalogDataFormat
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override DataFormat AnalogDataFormat { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides Property AnalogDataFormat As DataFormat
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property DataFormat AnalogDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}
Remarks

Macrodyne doesn't define any analog values.

This property only supports scaled data; Macrodyne doesn't transport floating point values.

Exceptions
Exception | Condition
NotSupportedException | Macrodyne only supports scaled data.


FrequencyDataFormat Property

FrequencyDataFormat Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCell ► FrequencyDataFormat
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat FrequencyDataFormat { get; set; }
Public Overrides Property FrequencyDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}
Remarks
This property only supports scaled data; Macrodyne doesn't transport floating-point values.
Exceptions
Exception | Condition
NotSupportedException | Macrodyne only supports scaled data.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCell ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCell ► IDCode
Gets or sets the ID code of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override ushort IDCode { get; set; }
Public Overrides Property IDCode As UShort
    Get
    Set
public:
virtual property unsigned short IDCode {
    unsigned short get () override;
    void set (unsigned short value) override;
}


MaximumStationNameLength Property

MaximumStationNameLength Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCell ► MaximumStationNameLength
Gets the maximum length of the StationName of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override int MaximumStationNameLength { get; }
Public Overrides ReadOnly Property MaximumStationNameLength As Integer
    Get
public:
virtual property int MaximumStationNameLength {
    int get () override;
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCell ► Parent
Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame Parent { get; set; }
Public Property Parent As ConfigurationFrame
    Get
    Set
public:
property ConfigurationFrame^ Parent {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}


PhasorCoordinateFormat Property

PhasorCoordinateFormat Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCell ► PhasorCoordinateFormat
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override CoordinateFormat PhasorCoordinateFormat { get; set; }
Public Overrides Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () override;
    void set (CoordinateFormat value) override;
}
Remarks
This property only supports rectangular phasor data; Macrodyne doesn't transport polar phasor values.
Exceptions
Exception | Condition
NotSupportedException | Macrodyne only supports rectangular phasor data.


PhasorDataFormat Property

PhasorDataFormat Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCell ► PhasorDataFormat
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat PhasorDataFormat { get; set; }
Public Overrides Property PhasorDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}
Remarks
This property only supports scaled data; Macrodyne doesn't transport floating-point values.
Exceptions
Exception | Condition
NotSupportedException | Macrodyne only supports scaled data.


ConfigurationCellCollection Class

ConfigurationCellCollection Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCellCollection
Represents a Macrodyne implementation of a collection of IConfigurationCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationCellCollection : ConfigurationCellCollection
<SerializableAttribute> _
Public Class ConfigurationCellCollection _
    Inherits ConfigurationCellCollection
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ConfigurationCellCollection
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCellCollection()()()() | Creates a new ConfigurationCellCollection.
 | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | IndexOfIDCode(UInt16) | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
 | IndexOfIDLabel(String) | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
 | IndexOfStationName(String) | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets ConfigurationCell at specified index.
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetByIDCode(UInt16, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
 | TryGetByIDLabel(String, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
 | TryGetByStationName(String, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IConfigurationCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' IConfigurationCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationCellCollection
 |  |  |  |  | ConfigurationCellCollection


ConfigurationCellCollection Constructor

ConfigurationCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCellCollection ► ConfigurationCellCollection()()()()
Members
Icon | Member | Description
 | ConfigurationCellCollection()()()() | Creates a new ConfigurationCellCollection.
 | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.


ConfigurationCellCollection Constructor

ConfigurationCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCellCollection ► ConfigurationCellCollection()()()()
Creates a new ConfigurationCellCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellCollection()
Public Sub New
public:
ConfigurationCellCollection()


ConfigurationCellCollection Constructor (info, context)

ConfigurationCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCellCollection ► ConfigurationCellCollection(SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


Item Property (index)

Item Property (index)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCellCollection ► Item[([( Int32])])
Gets or sets ConfigurationCell at specified index.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ConfigurationCell
    Get
    Set
public:
property ConfigurationCell^ default[int index] {
    ConfigurationCell^ get (int index);
    void set (int index, ConfigurationCell^ value);
}
Parameters
index (Int32)
Index of value to get or set.


ConfigurationFrame Class

ConfigurationFrame Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame
Represents the Macrodyne implementation of a IConfigurationFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationFrame : ConfigurationFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
<SerializableAttribute> _
Public Class ConfigurationFrame _
    Inherits ConfigurationFrameBase _
    Implements ISupportFrameImage(Of FrameType), ISupportBinaryImage
[SerializableAttribute]
public ref class ConfigurationFrame : public ConfigurationFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationFrame()()()() | Creates a new ConfigurationFrame.
 | ConfigurationFrame(OnlineDataFormatFlags, String) | Creates a new ConfigurationFrame.
 | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.AppendChecksum(array<Byte>[]()[][], Int32).)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrame object. (Overrides ConfigurationFrameBase.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage()()()(). (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.BinaryLength.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.ChecksumIsValid(array<Byte>[]()[][], Int32).)
 | CommonHeader | Gets or sets current CommonFrameHeader.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | DataFrameLength | Gets length of data frame based on enabled streaming data.
 | Digital1Included | Gets flag that determines if Digital 1 is included in ON-LINE data.
 | Digital2Included | Gets flag that determines if Digital 2 is included in ON-LINE data.
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.Initialize(array<Byte>[]()[][], Int32, Int32).)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnlineDataFormatFlags | Gets or sets the Macrodyne OnlineDataFormatFlags of this ConfigurationFrame.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides BinaryImageBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | PhasorCount | Gets phasor count derived from OnlineDataFormatFlags of this ConfigurationFrame.
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReferenceIncluded | Gets flag that determines if reference phasor is included in ON-LINE data.
 | SetNominalFrequency(LineFrequency) | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | StationName | Gets station name retrieved from header frame.
 | Status2Included | Gets flag that determines if status 2 flags are included in ON-LINE data.
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | TimestampIncluded | Gets flag that determines if timestamp is included in ON-LINE data.
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets the identifier that is used to identify the Macrodyne frame.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationFrameBase
 |  |  |  |  | ConfigurationFrame


ConfigurationFrame Constructor

ConfigurationFrame Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► ConfigurationFrame()()()()
Members
Icon | Member | Description
 | ConfigurationFrame()()()() | Creates a new ConfigurationFrame.
 | ConfigurationFrame(OnlineDataFormatFlags, String) | Creates a new ConfigurationFrame.
 | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.


ConfigurationFrame Constructor

ConfigurationFrame Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► ConfigurationFrame()()()()
Creates a new ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ConfigurationFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Sub New
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
ConfigurationFrame()
Remarks
This constructor is used by FrameImageParserBase to parse a Macrodyne configuration frame.


ConfigurationFrame Constructor (info, context)

ConfigurationFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► ConfigurationFrame(SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationFrame Constructor (onlineDataFormatFlags, unitID)

ConfigurationFrame Constructor (onlineDataFormatFlags, unitID)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► ConfigurationFrame(OnlineDataFormatFlags, String)
Creates a new ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame(
    OnlineDataFormatFlags onlineDataFormatFlags,
    string unitID
)
Public Sub New ( _
    onlineDataFormatFlags As OnlineDataFormatFlags, _
    unitID As String _
)
public:
ConfigurationFrame(
    OnlineDataFormatFlags onlineDataFormatFlags,
    String^ unitID
)
Parameters
onlineDataFormatFlags (OnlineDataFormatFlags)
Online data format flags to use in this Macrodyne ConfigurationFrame.
unitID (String)
8 character unit ID to use in this Macrodyne ConfigurationFrame.
Remarks
This constructor is used by a consumer to generate a Macrodyne configuration frame.


AppendChecksum Method (buffer, startIndex)

AppendChecksum Method (buffer, startIndex)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► AppendChecksum(array<Byte>[]()[][], Int32)
Appends checksum onto buffer starting at startIndex.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AppendChecksum(
    byte[] buffer,
    int startIndex
)
Protected Overrides Sub AppendChecksum ( _
    buffer As Byte(), _
    startIndex As Integer _
)
protected:
virtual void AppendChecksum(
    array<unsigned char>^ buffer,
    int startIndex
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image on which to append checksum.
startIndex (Int32)
Index into buffer where checksum should be appended.
Remarks
Default implementation encodes checksum in big-endian order and expects buffer size large enough to accomodate 2-byte checksum representation. We override this method since checksum in Macrodyne is a single byte.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrame object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BinaryLength Property

BinaryLength Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► BinaryLength
Gets the length of the BinaryImage()()()().
Declaration Syntax
C# Visual Basic Visual C++
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
public:
virtual property int BinaryLength {
    int get () override;
}
Remarks
This property is overriden so the length can be extended to include a 1-byte checksum.


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► Cells
Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellCollection Cells { get; }
Public ReadOnly Property Cells As ConfigurationCellCollection
    Get
public:
property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}


ChecksumIsValid Method (buffer, startIndex)

ChecksumIsValid Method (buffer, startIndex)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► ChecksumIsValid(array<Byte>[]()[][], Int32)
Determines if checksum in the buffer is valid.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid ( _
    buffer As Byte(), _
    startIndex As Integer _
) As Boolean
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image to validate.
startIndex (Int32)
Start index into buffer to perform checksum.
Return Value
Flag that determines if checksum over buffer is valid.
Remarks
Default implementation expects 2-byte big-endian ordered checksum. So we override method since checksum in Macrodyne is a single byte.


CommonHeader Property

CommonHeader Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► CommonHeader
Gets or sets current CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}


DataFrameLength Property

DataFrameLength Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► DataFrameLength
Gets length of data frame based on enabled streaming data.
Declaration Syntax
C# Visual Basic Visual C++
public ushort DataFrameLength { get; }
Public ReadOnly Property DataFrameLength As UShort
    Get
public:
property unsigned short DataFrameLength {
    unsigned short get ();
}


Digital1Included Property

Digital1Included Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► Digital1Included
Gets flag that determines if Digital 1 is included in ON-LINE data.
Declaration Syntax
C# Visual Basic Visual C++
public bool Digital1Included { get; }
Public ReadOnly Property Digital1Included As Boolean
    Get
public:
property bool Digital1Included {
    bool get ();
}


Digital2Included Property

Digital2Included Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► Digital2Included
Gets flag that determines if Digital 2 is included in ON-LINE data.
Declaration Syntax
C# Visual Basic Visual C++
public bool Digital2Included { get; }
Public ReadOnly Property Digital2Included As Boolean
    Get
public:
property bool Digital2Included {
    bool get ();
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► HeaderImage
Gets the binary header image of the DataFrame object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


Initialize Method (binaryImage, startIndex, length)

Initialize Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► Initialize(array<Byte>[]()[][], Int32, Int32)
Parses the binary image.
Declaration Syntax
C# Visual Basic Visual C++
public override int Initialize(
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Overrides Function Initialize ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
public:
virtual int Initialize(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Exceptions
Exception | Condition
InvalidOperationException | Invalid binary image detected - check sum did not match.


OnlineDataFormatFlags Property

OnlineDataFormatFlags Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► OnlineDataFormatFlags
Gets or sets the Macrodyne OnlineDataFormatFlags of this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public OnlineDataFormatFlags OnlineDataFormatFlags { get; set; }
Public Property OnlineDataFormatFlags As OnlineDataFormatFlags
    Get
    Set
public:
property OnlineDataFormatFlags OnlineDataFormatFlags {
    OnlineDataFormatFlags get ();
    void set (OnlineDataFormatFlags value);
}


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


PhasorCount Property

PhasorCount Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► PhasorCount
Gets phasor count derived from OnlineDataFormatFlags of this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public int PhasorCount { get; }
Public ReadOnly Property PhasorCount As Integer
    Get
public:
property int PhasorCount {
    int get ();
}


ReferenceIncluded Property

ReferenceIncluded Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► ReferenceIncluded
Gets flag that determines if reference phasor is included in ON-LINE data.
Declaration Syntax
C# Visual Basic Visual C++
public bool ReferenceIncluded { get; }
Public ReadOnly Property ReferenceIncluded As Boolean
    Get
public:
property bool ReferenceIncluded {
    bool get ();
}


StationName Property

StationName Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► StationName
Gets station name retrieved from header frame.
Declaration Syntax
C# Visual Basic Visual C++
public string StationName { get; }
Public ReadOnly Property StationName As String
    Get
public:
property String^ StationName {
    String^ get ();
}


Status2Included Property

Status2Included Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► Status2Included
Gets flag that determines if status 2 flags are included in ON-LINE data.
Declaration Syntax
C# Visual Basic Visual C++
public bool Status2Included { get; }
Public ReadOnly Property Status2Included As Boolean
    Get
public:
property bool Status2Included {
    bool get ();
}


TimestampIncluded Property

TimestampIncluded Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► TimestampIncluded
Gets flag that determines if timestamp is included in ON-LINE data.
Declaration Syntax
C# Visual Basic Visual C++
public bool TimestampIncluded { get; }
Public ReadOnly Property TimestampIncluded As Boolean
    Get
public:
property bool TimestampIncluded {
    bool get ();
}


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► TypeID
Gets the identifier that is used to identify the Macrodyne frame.
Declaration Syntax
C# Visual Basic Visual C++
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}


ConfigurationFrameParsingState Class

ConfigurationFrameParsingState Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrameParsingState
Represents the Macrodyne implementation of the parsing state used by a ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public class ConfigurationFrameParsingState : ConfigurationFrameParsingState
Public Class ConfigurationFrameParsingState _
    Inherits ConfigurationFrameParsingState
public ref class ConfigurationFrameParsingState : public ConfigurationFrameParsingState
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationFrameParsingState(Int32, HeaderFrame, CreateNewCellFunction<(Of <<'(IConfigurationCell>)>>)) | Creates a new ConfigurationFrameParsingState from specified parameters.
 | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBase<(Of <(<'T>)>)>.)
 | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderFrame | Gets or sets the header frame, which contains the unit ID (i.e., station name), of the device.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ChannelParsingStateBase
 |  | ChannelFrameParsingStateBase <(Of <(<' IConfigurationCell >)>)>
 |  |  | ConfigurationFrameParsingState
 |  |  |  | ConfigurationFrameParsingState


ConfigurationFrameParsingState Constructor (parsedBinaryLength, headerFrame, createNewCellFunction)

ConfigurationFrameParsingState Constructor (parsedBinaryLength, headerFrame, createNewCellFunction)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrameParsingState ► ConfigurationFrameParsingState(Int32, HeaderFrame, CreateNewCellFunction<(Of <<'(IConfigurationCell>)>>))
Creates a new ConfigurationFrameParsingState from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrameParsingState(
    int parsedBinaryLength,
    HeaderFrame headerFrame,
    CreateNewCellFunction<IConfigurationCell> createNewCellFunction
)
Public Sub New ( _
    parsedBinaryLength As Integer, _
    headerFrame As HeaderFrame, _
    createNewCellFunction As CreateNewCellFunction(Of IConfigurationCell) _
)
public:
ConfigurationFrameParsingState(
    int parsedBinaryLength,
    HeaderFrame^ headerFrame,
    CreateNewCellFunction<IConfigurationCell^>^ createNewCellFunction
)
Parameters
parsedBinaryLength (Int32)
Binary length of the ConfigurationFrame being parsed.
headerFrame (HeaderFrame)
Previously parsed header frame that contains needed station name.
createNewCellFunction (CreateNewCellFunction <(Of <(<' IConfigurationCell >)>)>)
Reference to delegate to create new ConfigurationCell instances.


HeaderFrame Property

HeaderFrame Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrameParsingState ► HeaderFrame
Gets or sets the header frame, which contains the unit ID (i.e., station name), of the device.
Declaration Syntax
C# Visual Basic Visual C++
public HeaderFrame HeaderFrame { get; set; }
Public Property HeaderFrame As HeaderFrame
    Get
    Set
public:
property HeaderFrame^ HeaderFrame {
    HeaderFrame^ get ();
    void set (HeaderFrame^ value);
}


DataCell Class

DataCell Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell
Represents the Macrodyne implementation of a IDataCell that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataCell : DataCellBase
<SerializableAttribute> _
Public Class DataCell _
    Inherits DataCellBase
[SerializableAttribute]
public ref class DataCell : public DataCellBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
 | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
 | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
 | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
 | AnalogValues | Gets AnalogValueCollection of this DataCell. (Overrides DataCellBase.AnalogValues.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataCell object. (Overrides DataCellBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
 | ClockStatusFlags | Gets or sets ClockStatusFlags for this DataCell.
 | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
 | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
 | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBase.DataIsValid.)
 | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBase.DataSortingType.)
 | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBase.DeviceError.)
 | DigitalValues | Gets DigitalValueCollection of this DataCell. (Overrides DataCellBase.DigitalValues.)
 | Equals(Object) | Determines whether the specified object is equal to the DataCellBase. (Inherited from DataCellBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
 | GetHashCode()()()() | Serves as a hash function for the DataCellBase. (Inherited from DataCellBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataCellBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GpsStatus | Gets or sets GpsStatus for this DataCell.
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets the numeric ID code for this DataCell.
 | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides DataCellBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
 | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
 | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
 | Status1Flags | Gets or sets status 1 flags for this DataCell.
 | Status2Flags | Gets or sets status 2 flags for this DataCell.
 | StatusFlags | Gets or sets 16-bit status flags of this DataCellBase. (Inherited from DataCellBase.)
 | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBase.SynchronizationIsValid.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this DataCellBase. (Inherited from DataCellBase.)
 | TriggerReason | Gets or sets TriggerReason for this DataCell.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | DataCellBase
 |  |  |  |  | DataCell


DataCell Constructor

DataCell Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► DataCell()()()()
Members
Icon | Member | Description
 | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
 | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
 | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.


DataCell Constructor (info, context)

DataCell Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► DataCell(SerializationInfo, StreamingContext)
Creates a new DataCell from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataCell(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DataCell Constructor (parent, configurationCell)

DataCell Constructor (parent, configurationCell)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► DataCell(IDataFrame, IConfigurationCell)
Creates a new DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell(
    IDataFrame parent,
    IConfigurationCell configurationCell
)
Public Sub New ( _
    parent As IDataFrame, _
    configurationCell As IConfigurationCell _
)
public:
DataCell(
    IDataFrame^ parent,
    IConfigurationCell^ configurationCell
)
Parameters
parent (IDataFrame)
The reference to parent IDataFrame of this DataCell.
configurationCell (IConfigurationCell)
The IConfigurationCell associated with this DataCell.


DataCell Constructor (parent, configurationCell, addEmptyValues)

DataCell Constructor (parent, configurationCell, addEmptyValues)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► DataCell(DataFrame, ConfigurationCell, Boolean)
Creates a new DataCell from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell(
    DataFrame parent,
    ConfigurationCell configurationCell,
    bool addEmptyValues
)
Public Sub New ( _
    parent As DataFrame, _
    configurationCell As ConfigurationCell, _
    addEmptyValues As Boolean _
)
public:
DataCell(
    DataFrame^ parent,
    ConfigurationCell^ configurationCell,
    bool addEmptyValues
)
Parameters
parent (DataFrame)
The reference to parent DataFrame of this DataCell.
configurationCell (ConfigurationCell)
The ConfigurationCell associated with this DataCell.
addEmptyValues (Boolean)
If true, adds empty values for each defined configuration cell definition.


AnalogValues Property

AnalogValues Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► AnalogValues
Gets AnalogValueCollection of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override AnalogValueCollection AnalogValues { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides ReadOnly Property AnalogValues As AnalogValueCollection
    Get
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property AnalogValueCollection^ AnalogValues {
    AnalogValueCollection^ get () override;
}
Remarks
Macrodyne doesn't define any analog values.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataCell object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


ClockStatusFlags Property

ClockStatusFlags Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► ClockStatusFlags
Gets or sets ClockStatusFlags for this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public ClockStatusFlags ClockStatusFlags { get; set; }
Public Property ClockStatusFlags As ClockStatusFlags
    Get
    Set
public:
property ClockStatusFlags ClockStatusFlags {
    ClockStatusFlags get ();
    void set (ClockStatusFlags value);
}


ConfigurationCell Property

ConfigurationCell Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► ConfigurationCell
Gets or sets the ConfigurationCell associated with this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell ConfigurationCell { get; set; }
Public Property ConfigurationCell As ConfigurationCell
    Get
    Set
public:
property ConfigurationCell^ ConfigurationCell {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


DataIsValid Property

DataIsValid Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► DataIsValid
Gets or sets flag that determines if data of this DataCell is valid.
Declaration Syntax
C# Visual Basic Visual C++
public override bool DataIsValid { get; set; }
Public Overrides Property DataIsValid As Boolean
    Get
    Set
public:
virtual property bool DataIsValid {
    bool get () override;
    void set (bool value) override;
}


DataSortingType Property

DataSortingType Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► DataSortingType
Gets or sets DataSortingType of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataSortingType DataSortingType { get; set; }
Public Overrides Property DataSortingType As DataSortingType
    Get
    Set
public:
virtual property DataSortingType DataSortingType {
    DataSortingType get () override;
    void set (DataSortingType value) override;
}


DeviceError Property

DeviceError Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► DeviceError
Gets or sets flag that determines if source device of this DataCell is reporting an error.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override bool DeviceError { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides Property DeviceError As Boolean
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property bool DeviceError {
    bool get () override;
    void set (bool value) override;
}
Remarks
Macrodyne doesn't define bits for device error.


DigitalValues Property

DigitalValues Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► DigitalValues
Gets DigitalValueCollection of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override DigitalValueCollection DigitalValues { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides ReadOnly Property DigitalValues As DigitalValueCollection
    Get
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property DigitalValueCollection^ DigitalValues {
    DigitalValueCollection^ get () override;
}
Remarks
Macrodyne doesn't define any digital values.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


GpsStatus Property

GpsStatus Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► GpsStatus
Gets or sets GpsStatus for this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public GpsStatus GpsStatus { get; set; }
Public Property GpsStatus As GpsStatus
    Get
    Set
public:
property GpsStatus GpsStatus {
    GpsStatus get ();
    void set (GpsStatus value);
}


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► IDCode
Gets the numeric ID code for this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public uint IDCode { get; }
Public ReadOnly Property IDCode As UInteger
    Get
public:
property unsigned int IDCode {
    unsigned int get ();
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► Parent
Gets or sets the reference to parent DataFrame of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public DataFrame Parent { get; set; }
Public Property Parent As DataFrame
    Get
    Set
public:
property DataFrame^ Parent {
    DataFrame^ get ();
    void set (DataFrame^ value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


Status1Flags Property

Status1Flags Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► Status1Flags
Gets or sets status 1 flags for this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public StatusFlags Status1Flags { get; set; }
Public Property Status1Flags As StatusFlags
    Get
    Set
public:
property StatusFlags Status1Flags {
    StatusFlags get ();
    void set (StatusFlags value);
}


Status2Flags Property

Status2Flags Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► Status2Flags
Gets or sets status 2 flags for this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public byte Status2Flags { get; set; }
Public Property Status2Flags As Byte
    Get
    Set
public:
property unsigned char Status2Flags {
    unsigned char get ();
    void set (unsigned char value);
}


SynchronizationIsValid Property

SynchronizationIsValid Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► SynchronizationIsValid
Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock.
Declaration Syntax
C# Visual Basic Visual C++
public override bool SynchronizationIsValid { get; set; }
Public Overrides Property SynchronizationIsValid As Boolean
    Get
    Set
public:
virtual property bool SynchronizationIsValid {
    bool get () override;
    void set (bool value) override;
}


TriggerReason Property

TriggerReason Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCell ► TriggerReason
Gets or sets TriggerReason for this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public TriggerReason TriggerReason { get; set; }
Public Property TriggerReason As TriggerReason
    Get
    Set
public:
property TriggerReason TriggerReason {
    TriggerReason get ();
    void set (TriggerReason value);
}


DataCellCollection Class

DataCellCollection Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCellCollection
Represents a Macrodyne implementation of a collection of IDataCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataCellCollection : DataCellCollection
<SerializableAttribute> _
Public Class DataCellCollection _
    Inherits DataCellCollection
[SerializableAttribute]
public ref class DataCellCollection : public DataCellCollection
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCellCollection()()()() | Creates a new DataCellCollection.
 | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets DataCell at specified index.
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IDataCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' IDataCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' IDataCell >)>)>
 |  |  |  | DataCellCollection
 |  |  |  |  | DataCellCollection


DataCellCollection Constructor

DataCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCellCollection ► DataCellCollection()()()()
Members
Icon | Member | Description
 | DataCellCollection()()()() | Creates a new DataCellCollection.
 | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.


DataCellCollection Constructor

DataCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCellCollection ► DataCellCollection()()()()
Creates a new DataCellCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DataCellCollection()
Public Sub New
public:
DataCellCollection()


DataCellCollection Constructor (info, context)

DataCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCellCollection ► DataCellCollection(SerializationInfo, StreamingContext)
Creates a new DataCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


Item Property (index)

Item Property (index)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataCellCollection ► Item[([( Int32])])
Gets or sets DataCell at specified index.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DataCell
    Get
    Set
public:
property DataCell^ default[int index] {
    DataCell^ get (int index);
    void set (int index, DataCell^ value);
}
Parameters
index (Int32)
Index of value to get or set.


DataFrame Class

DataFrame Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame
Represents the Macrodyne implementation of a IDataFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataFrame : DataFrameBase, ISupportFrameImage<FrameType>,
    ISupportBinaryImage
<SerializableAttribute> _
Public Class DataFrame _
    Inherits DataFrameBase _
    Implements ISupportFrameImage(Of FrameType), ISupportBinaryImage
[SerializableAttribute]
public ref class DataFrame : public DataFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataFrame()()()() | Creates a new DataFrame.
 | DataFrame(Ticks) | Creates a new DataFrame from specified parameters.
 | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.AppendChecksum(array<Byte>[]()[][], Int32).)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ChannelFrameBase<(Of <(<'T>)>)> object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage()()()(). (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.BinaryLength.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the DataCellCollection for this DataFrame.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.ChecksumIsValid(array<Byte>[]()[][], Int32).)
 | CommonHeader | Gets or sets current CommonFrameHeader.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets the numeric ID code for this DataFrameBase. (Inherited from DataFrameBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Overrides DataFrameBase.Initialize(array<Byte>[]()[][], Int32, Int32).)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides BinaryImageBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets the identifier that is used to identify the Macrodyne frame.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IDataCell >)>)>
 |  |  |  | DataFrameBase
 |  |  |  |  | DataFrame


DataFrame Constructor

DataFrame Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► DataFrame()()()()
Members
Icon | Member | Description
 | DataFrame()()()() | Creates a new DataFrame.
 | DataFrame(Ticks) | Creates a new DataFrame from specified parameters.
 | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.


DataFrame Constructor

DataFrame Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► DataFrame()()()()
Creates a new DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public DataFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Sub New
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
DataFrame()
Remarks
This constructor is used by FrameImageParserBase to parse a Macrodyne data frame.


DataFrame Constructor (info, context)

DataFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► DataFrame(SerializationInfo, StreamingContext)
Creates a new DataFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DataFrame Constructor (timestamp)

DataFrame Constructor (timestamp)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► DataFrame(Ticks)
Creates a new DataFrame from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DataFrame(
    Ticks timestamp
)
Public Sub New ( _
    timestamp As Ticks _
)
public:
DataFrame(
    Ticks timestamp
)
Parameters
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this DataFrame.
Remarks
This constructor is used by a consumer to generate a Macrodyne data frame.


AppendChecksum Method (buffer, startIndex)

AppendChecksum Method (buffer, startIndex)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► AppendChecksum(array<Byte>[]()[][], Int32)
Appends checksum onto buffer starting at startIndex.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AppendChecksum(
    byte[] buffer,
    int startIndex
)
Protected Overrides Sub AppendChecksum ( _
    buffer As Byte(), _
    startIndex As Integer _
)
protected:
virtual void AppendChecksum(
    array<unsigned char>^ buffer,
    int startIndex
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image on which to append checksum.
startIndex (Int32)
Index into buffer where checksum should be appended.
Remarks
Default implementation encodes checksum in big-endian order and expects buffer size large enough to accomodate 2-byte checksum representation. We override this method since checksum in Macrodyne is a single byte.


BinaryLength Property

BinaryLength Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► BinaryLength
Gets the length of the BinaryImage()()()().
Declaration Syntax
C# Visual Basic Visual C++
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
public:
virtual property int BinaryLength {
    int get () override;
}
Remarks
This property is overriden so the length can be extended to include a 1-byte checksum.


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► Cells
Gets reference to the DataCellCollection for this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public DataCellCollection Cells { get; }
Public ReadOnly Property Cells As DataCellCollection
    Get
public:
property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}


ChecksumIsValid Method (buffer, startIndex)

ChecksumIsValid Method (buffer, startIndex)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► ChecksumIsValid(array<Byte>[]()[][], Int32)
Determines if checksum in the buffer is valid.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid ( _
    buffer As Byte(), _
    startIndex As Integer _
) As Boolean
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image to validate.
startIndex (Int32)
Start index into buffer to perform checksum.
Return Value
Flag that determines if checksum over buffer is valid.
Remarks
Default implementation expects 2-byte big-endian ordered checksum. So we override method since checksum in Macrodyne is a single byte.


CommonHeader Property

CommonHeader Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► CommonHeader
Gets or sets current CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► ConfigurationFrame
Gets or sets ConfigurationFrame associated with this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame ConfigurationFrame { get; set; }
Public Property ConfigurationFrame As ConfigurationFrame
    Get
    Set
public:
property ConfigurationFrame^ ConfigurationFrame {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► HeaderImage
Gets the binary header image of the DataFrame object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


Initialize Method (binaryImage, startIndex, length)

Initialize Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► Initialize(array<Byte>[]()[][], Int32, Int32)
Parses the binary image.
Declaration Syntax
C# Visual Basic Visual C++
public override int Initialize(
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Overrides Function Initialize ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
public:
virtual int Initialize(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Exceptions
Exception | Condition
InvalidOperationException | Invalid binary image detected - check sum did not match.


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► TypeID
Gets the identifier that is used to identify the Macrodyne frame.
Declaration Syntax
C# Visual Basic Visual C++
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}


DataInputCommand Enumeration

DataInputCommand Enumeration
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataInputCommand
Macrodyne data input commands enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum DataInputCommand
<SerializableAttribute> _
Public Enumeration DataInputCommand
[SerializableAttribute]
public enum class DataInputCommand
Members
Member | Description
SendReferencePhasor | Send reference phasor.
SendWordData | Send word data.
SendUnitIDData | Send unit ID data.
SendByteData | Send byte data.


DeviceCommand Enumeration

DeviceCommand Enumeration
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DeviceCommand
Macrodyne set and request commands enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum DeviceCommand
<SerializableAttribute> _
Public Enumeration DeviceCommand
[SerializableAttribute]
public enum class DeviceCommand
Members
Member | Description
SelectEvent1 | Select Event 1.
SelectEvent2 | Select Event 2.
SelectEvent3 | Select Event 3.
SelectEvent4 | Select Event 4.
SelectEvent5 | Select Event 5.
SelectEvent6 | Select Event 6.
SelectEvent7 | Select Event 7.
SelectEvent8 | Select Event 8.
SelectEvent9 | Select Event 9.
SelectEvent10 | Select Event 10.
SelectEvent11 | Select Event 11.
SelectEvent12 | Select Event 12.
SelectEvent13 | Select Event 13.
SelectEvent14 | Select Event 14.
SelectEvent15 | Select Event 15.
SelectEvent16 | Select Event 16.
EraseSelectedEvent | Erase selected event.
ForceEvent | Force an event.
SetOneSecondPreTriggerValue | Set the 1 second table pre-trigger to the value in the word buffer.
SetExtendedPreTriggerValue | Set the extended table pre-trigger to the value in the word buffer.
SetUnitID | Set the unit ID (8 ASCII bytes) to the values in the 8 byte buffer (set using SendUnitIDData.
StartOnlineData | Start sending ON-LINE data down this port (the port the command was received on).
StopOnlineData | Stop sending ON-LINE data or reference data down this port.
StartSendingReferencePort1 | Start sending the reference down port1.
StartSendingReferencePort2 | Start sending the reference down port2.
StopSendingReference | Stop sending the reference down either port.
EnableReferenceReception | Enable the reference reception in any port.
DisableReferenceReception | Disable the reference reception in any port.
RebootUnit | Re-boot the PMU code from the EEPROM and re-start the unit.
ResetUnitAndFlags | Reset the unit and reset the flags.
Set2CycleOutputRate | Set the output rate to 2 cycles (i.e. 30 times/sec).
Set5CycleOutputRate | Set the output rate to 5 cycles (i.e. 12 times/sec).
Set10CycleOutputRate | Set the output rate to 10 cycles (i.e. 6 times/sec).
Use5Phasors | Set the PMU for 5 phasors.
Use4Phasors | Set the PMU for 4 phasors.
Use3Phasors | Set the PMU for 3 phasors.
Use2Phasors | Set the PMU for 2 phasors.
Use1Phasor | Set the PMU for 1 phasor.
SetMScaleValue | Set mscale to the value in the word buffer.
EnableAllTriggers | Enable all triggers.
DisableAllTriggers | Disable all triggers.
SetVMinTrigger | Set the VMIN trigger to the value in the word buffer.
SetVMaxTrigger | Set the VMAX trigger to the value in the word buffer.
SetAngdTrigger | Set the ANGD trigger to the value in the word buffer.
SetFreqTrigger | Set the FREQ trigger to the value in the word buffer.
SetDfDtTrigger | Set the DFDT trigger to the value in the word buffer.
SetLncmTrigger | Set the LNCM trigger to the value in the word buffer.
SetVCoefValue | Set the VCOEF value to the value in the word buffer.
SetFCoefValue | Set the FCOEF value to the value in the word buffer.
SetDCoefValue | Set the DCOEF value to the value in the word buffer.
SetNrmDigState | Set the NRM_DIG (normal state of digital channel) to the value in the word buffer.
SetDigEnbTrigger | Set the DIG_ENB (digital channel trigger enable) to the value in the word buffer.
ResetOnlineDataFormat | Reset the ON-LINE data format to the default setting.
AddSecondStatus | Add the second status byte to the ON-LINE data.
AddTimeStamp | Add the time stamp to the ON-LINE data.
AddSecondPhasor | Add the second phasor to the ON-LINE data.
AddThirdPhasor | Add the third phasor to the ON-LINE data.
AddForthPhasor | Add the fourth phasor to the ON-LINE data.
AddFifthPhasor | Add the fifth phasor to the ON-LINE data.
AddReferencePhasor | Add the reference phasor to the ON-LINE data.
SetVMinOperationalLimit | Set the VMIN operational limit to the value in the byte buffer.
SetVMaxOperationalLimit | Set the VMAX operational limit to the value in the byte buffer.
SetAngdOperationalLimit | Set the ANGD operational limit to the value in the byte buffer.
SetFreqOperationalLimit | Set the FREQ operational limit to the value in the byte buffer.
SetDfDtOperationalLimit | Set the DFDT operational limit to the value in the byte buffer.
SetLncmOperationalLimit | Set the LNCM operational limit to the value in the byte buffer.
SetDigitalOperationalLimit | Set the digital channels operational limit to the value in the byte buffer.
ResetOperationalLimitCounters | Reset all operational limit counters (ANALOG AND DIGITAL) to 0.
AddDigitals | Add digital channels to the ON-LINE data.
SetPhasorType | Set the first set of analog channels to the value in the word buffer which designates what each channel will be, VOLTAGE or CURRENT.
SetGpsTransparentMode | Set GPS to transparent mode (host port A only).
SendCommandToSecondBoard | Send this command when the following command refers to the second board.
SetDigitalsTo16 | Set the number of Digital Channels to 16.
SetDigitalsTo32 | Set the number of Digital Channels to 32.
SetRawPreTriggerValue | Set Raw data pretrigger to the value in the word buffer.
StartDebugMode | Start Debug Mode. Stops PMU program and enters the debugger.
RequestStatus1Flags | Request STATU1 flag (1 response byte).
RequestStatus2Flags | Request STATU2 flag (1 response byte).
RequestOnlineDataFormat | Request ON-LINE data format (2 response bytes).
RequestOperationalLimitFlags | Request operational limit reached flags (3 response bytes).
RequestWordBufferValue | Request value in word buffer (2 response bytes).
RequestByteBufferValue | Request value in byte buffer (1 response byte).
RequestTimeTagValue | Request current time tag string (6 response bytes).
RequestUnitStatus | Request unit status.
RequestAnalogTriggerValues | Request analog trigger values (18 response bytes).
RequestVMinTriggerValue | Request VMIN trigger value (2 response bytes).
RequestVMaxTriggerValue | Request VMAX trigger value (2 response bytes).
RequestAngdTriggerValue | Request ANGD trigger value (2 response bytes).
RequestFreqTriggerValue | Request FREQ trigger value (2 response bytes).
RequestDfDtTriggerValue | Request DFDT trigger value (2 response bytes).
RequestLncmTriggerValue | Request LNCM trigger value (2 response bytes).
RequestVCoefTriggerValue | Request VCOEF trigger value (2 response bytes).
RequestFCoefTriggerValue | Request FCOEF trigger value (2 response bytes).
RequestDCoefTriggerValue | Request DCOEF trigger value (2 response bytes).
RequestDigitalsNormalState | Request normal state of digital channels (2 response bytes).
RequestDigitalsTriggerEnabledState | Request trigger enabled state of digital channels (1 response byte).
RequestUnitIDBufferValue | Request value in unit ID buffer (8 ASCII response bytes).
RequestPhasorType | Request the value which determines what each analog channel is, bit # = channel #, 1 = VOLTAGE, 0 = CURRENT.
RequestOneSecondTableLine | Request table line from 1 second table.
RequestExtendedTableLine | Request table line from extended table.
RequestPreviousTableLine | Request previous table line/block.
RequestTableTimeInformation | Request time information for selected table.
RequestTableTriggerInformation | Request trigger information for selected table.
RequestTableWithFreezeReason | Request table with freeze reason (16 response bytes).
RequestTimeOfFreezeTableSize | Request number of bytes in time of freeze tables (1 response byte).
RequestTimeOfFreezeTables | Request time of freeze tables.
RequestOperationalLimitsValue | Request value of operational limits (7 response bytes).
RequestOperationalCountersValue | Request value of operational counters (6 response bytes).
RequestOperationalDigitalCountsValue | Request value of operational counts of digital channels (16 response bytes).
RequestRawTableLine | Request raw table line.
RequestRawTableInformation | Request raw table information (18 response bytes).
RequestCurrentRawTablePreTrigger | Request current raw table pretrigger (22 response bytes).
Undefined | Undefined command.
Remarks
These commands should be transmitted in big-endian to make sure high word and low word are in the expected order.


DevicePort Enumeration

DevicePort Enumeration
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DevicePort
Macrodyne device ports enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum DevicePort
<SerializableAttribute> _
Public Enumeration DevicePort
[SerializableAttribute]
public enum class DevicePort
Members
Member | Description
Port1 | Serial port 1.
Port2 | Serial port 2.
Port3 | Serial port 3.
Port4 | Serial port 4.


DigitalDefinition Class

DigitalDefinition Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DigitalDefinition
Represents the Macrodyne implementation of an IDigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DigitalDefinition : DigitalDefinitionBase
<SerializableAttribute> _
Public Class DigitalDefinition _
    Inherits DigitalDefinitionBase
[SerializableAttribute]
public ref class DigitalDefinition : public DigitalDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition from specified parameters.
 | DigitalDefinition(ConfigurationCell, String) | Creates a new DigitalDefinition from specified parameters.
 | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | DigitalDefinitionBase
 |  |  |  |  | DigitalDefinition


DigitalDefinition Constructor

DigitalDefinition Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DigitalDefinition ► DigitalDefinition()()()()
Members
Icon | Member | Description
 | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition from specified parameters.
 | DigitalDefinition(ConfigurationCell, String) | Creates a new DigitalDefinition from specified parameters.
 | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.


DigitalDefinition Constructor (info, context)

DigitalDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DigitalDefinition ► DigitalDefinition(SerializationInfo, StreamingContext)
Creates a new DigitalDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DigitalDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DigitalDefinition Constructor (parent)

DigitalDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DigitalDefinition ► DigitalDefinition(IConfigurationCell)
Creates a new DigitalDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
DigitalDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this DigitalDefinition.


DigitalDefinition Constructor (parent, label)

DigitalDefinition Constructor (parent, label)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DigitalDefinition ► DigitalDefinition(ConfigurationCell, String)
Creates a new DigitalDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String _
)
public:
DigitalDefinition(
    ConfigurationCell^ parent,
    String^ label
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this DigitalDefinition.
label (String)
The label of this DigitalDefinition.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DigitalDefinition ► Parent
Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


DigitalValue Class

DigitalValue Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DigitalValue
Represents the Macrodyne implementation of an IDigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DigitalValue : DigitalValueBase
<SerializableAttribute> _
Public Class DigitalValue _
    Inherits DigitalValueBase
[SerializableAttribute]
public ref class DigitalValue : public DigitalValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
 | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
 | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DigitalValueBase object. (Inherited from DigitalValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the DigitalValueBase object. (Inherited from DigitalValueBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from DigitalValueBase.)
 | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Inherited from DigitalValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the DigitalDefinition associated with this DigitalValue.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this DigitalValueBase. (Inherited from DigitalValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from DigitalValueBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DigitalValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Inherited from DigitalValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this DigitalValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from DigitalValueBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase. (Inherited from DigitalValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IDigitalDefinition >)>)>
 |  |  |  | DigitalValueBase
 |  |  |  |  | DigitalValue


DigitalValue Constructor

DigitalValue Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DigitalValue ► DigitalValue()()()()
Members
Icon | Member | Description
 | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
 | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
 | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.


DigitalValue Constructor (info, context)

DigitalValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DigitalValue ► DigitalValue(SerializationInfo, StreamingContext)
Creates a new DigitalValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DigitalValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DigitalValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DigitalValue Constructor (parent, digitalDefinition)

DigitalValue Constructor (parent, digitalDefinition)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DigitalValue ► DigitalValue(IDataCell, IDigitalDefinition)
Creates a new DigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalValue(
    IDataCell parent,
    IDigitalDefinition digitalDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    digitalDefinition As IDigitalDefinition _
)
public:
DigitalValue(
    IDataCell^ parent,
    IDigitalDefinition^ digitalDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this DigitalValue.
digitalDefinition (IDigitalDefinition)
The IDigitalDefinition associated with this DigitalValue.


DigitalValue Constructor (parent, digitalDefinition, value)

DigitalValue Constructor (parent, digitalDefinition, value)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DigitalValue ► DigitalValue(DataCell, DigitalDefinition, UInt16)
Creates a new DigitalValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DigitalValue(
    DataCell parent,
    DigitalDefinition digitalDefinition,
    ushort value
)
Public Sub New ( _
    parent As DataCell, _
    digitalDefinition As DigitalDefinition, _
    value As UShort _
)
public:
DigitalValue(
    DataCell^ parent,
    DigitalDefinition^ digitalDefinition,
    unsigned short value
)
Parameters
parent (DataCell)
The DataCell parent of this DigitalValue.
digitalDefinition (DigitalDefinition)
The DigitalDefinition associated with this DigitalValue.
value (UInt16)
The unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValue.


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DigitalValue ► Definition
Gets or sets the DigitalDefinition associated with this DigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DigitalDefinition Definition { get; set; }
Public Overridable Property Definition As DigitalDefinition
    Get
    Set
public:
virtual property DigitalDefinition^ Definition {
    DigitalDefinition^ get ();
    void set (DigitalDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DigitalValue ► Parent
Gets or sets the DataCell parent of this DigitalValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


FrameParser Class

FrameParser Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrameParser
Represents a frame parser for a Macrodyne binary data stream that returns parsed data via events.
Declaration Syntax
C# Visual Basic Visual C++
public class FrameParser : FrameParserBase<FrameType>
Public Class FrameParser _
    Inherits FrameParserBase(Of FrameType)
public ref class FrameParser : public FrameParserBase<FrameType>
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrameParser()()()() | Initializes a new instance of the FrameParser class
 | BeginRead(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead()()()() | (Inherited from BinaryImageParserBase.)
 | CanSeek()()()() | (Inherited from BinaryImageParserBase.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite()()()() | (Inherited from BinaryImageParserBase.)
 | Close()()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.ConfigurationFrame.)
 | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | CreateBufferQueue()()()() | Creates the internal buffer queue. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | DataDiscarded()()()() | (Inherited from BinaryImageParserBase.)
 | DataParsed()()()() | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBase<(Of <(<'TFrameIdentifier>)>)> object and optionally releases the managed resources. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | DuplicateTypeHandlerEncountered()()()() | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | Enabled()()()() | (Inherited from BinaryImageParserBase.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteParseOnSeparateThread | Gets or sets a flag that allows frame parsing to be executed on a separate thread (i.e., other than communications thread). (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()()() | Clears all buffers for this stream and causes any buffered data to be parsed immediately. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length()()()() | (Inherited from BinaryImageParserBase.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()()()() | (Inherited from BinaryImageParserBase.)
 | OnConfigurationChanged()()()() | Raises the ConfigurationChanged event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnDataDiscarded(array<Byte>[]()[][]) | (Inherited from BinaryImageParserBase.)
 | OnDataParsed(UTP) | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | OnDuplicateTypeHandlerEncountered(Type, UTP) | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | OnOutputTypeNotFound(UTP) | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | OnParsingException(Exception) | (Inherited from BinaryImageParserBase.)
 | OnReceivedChannelFrame(IChannelFrame) | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame). (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.OnReceivedChannelFrame(IChannelFrame).)
 | OnReceivedCommandFrame(ICommandFrame) | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedConfigurationFrame(IConfigurationFrame) | Raises the ReceivedConfigurationFrame event. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.OnReceivedConfigurationFrame(IConfigurationFrame).)
 | OnReceivedDataFrame(IDataFrame) | Raises the ReceivedDataFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedFrameBufferImage(FundamentalFrameType, array<Byte>[]()[][], Int32, Int32) | Raises the ReceivedFrameBufferImage event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedHeaderFrame(IHeaderFrame) | Raises the ReceivedHeaderFrame event. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.OnReceivedHeaderFrame(IHeaderFrame).)
 | OnReceivedUndeterminedFrame(IChannelFrame) | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnUnknownFrameTypeEncountered(TFrameIdentifier) | Handles unknown frame types. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OutputTypeNotFound()()()() | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | Parse(ISupportBinaryImage) | (Inherited from BinaryImageParserBase.)
 | ParseCommonHeader(array<Byte>[]()[][], Int32, Int32) | Parses a common header instance that implements ICommonHeader for the output type represented in the binary image. (Overrides FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.ParseCommonHeader(array<Byte>[]()[][], Int32, Int32).)
 | ParseFrame(array<Byte>[]()[][], Int32, Int32) | (Inherited from FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.)
 | ParseQueuedBuffers(array<array<Byte>[]()[][]>[]()[][]) | This method is used by the internal ProcessQueue to process all queued data buffers. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ParsingException()()()() | (Inherited from BinaryImageParserBase.)
 | Position()()()() | (Inherited from BinaryImageParserBase.)
 | ProtocolSyncBytes()()()() | (Inherited from BinaryImageParserBase.)
 | ProtocolUsesSyncBytes | Gets flag that determines if Macrodyne protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBase.ProtocolUsesSyncBytes()()()().)
 | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Read(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageParserBase.)
 | ReadByte()()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | ReceivedCommandFrame | Occurs when a ICommandFrame has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ReceivedConfigurationFrame | Occurs when a Macrodyne ConfigurationFrame has been received.
 | ReceivedDataFrame | Occurs when a Macrodyne DataFrame has been received.
 | ReceivedFrameBufferImage | Occurs when a frame buffer image has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ReceivedHeaderFrame | Occurs when a Macrodyne HeaderFrame that contains the UnitID (i.e., station name) has been received.
 | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | RunTime()()()() | (Inherited from BinaryImageParserBase.)
 | Seek(Int64, SeekOrigin) | (Inherited from BinaryImageParserBase.)
 | SetLength(Int64) | (Inherited from BinaryImageParserBase.)
 | Start()()()() | Start the data parser. (Overrides FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.Start()()()().)
 | Start(IEnumerable<(Of <<'(Type>)>>)) | Starts the frame parser given the specified type implementations. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Status | Gets current descriptive status of the FrameParserBase<(Of <(<'TFrameIdentifier>)>)>. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Stop()()()() | Stops the frame parser. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | StreamInitialized()()()() | (Inherited from BinaryImageParserBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalProcessedBuffers()()()() | (Inherited from BinaryImageParserBase.)
 | UnparsedBuffer()()()() | (Inherited from BinaryImageParserBase.)
 | Write(array<Byte>[]()[][], Int32, Int32) | Writes a sequence of bytes onto the stream for parsing. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks
Frame parser is implemented as a write-only stream - this way data can come from any source.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | BinaryImageParserBase
 |  |  |  | FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>
 |  |  |  |  | FrameParserBase <(Of <(<' FrameType >)>)>
 |  |  |  |  |  | FrameParser


FrameParser Constructor

FrameParser Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrameParser ► FrameParser()()()()
Initializes a new instance of the FrameParser class
Declaration Syntax
C# Visual Basic Visual C++
public FrameParser()
Public Sub New
public:
FrameParser()


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrameParser ► ConfigurationFrame
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
Declaration Syntax
C# Visual Basic Visual C++
public override IConfigurationFrame ConfigurationFrame { get; set; }
Public Overrides Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () override;
    void set (IConfigurationFrame^ value) override;
}
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.


OnReceivedChannelFrame Method (frame)

OnReceivedChannelFrame Method (frame)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrameParser ► OnReceivedChannelFrame(IChannelFrame)
Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame).
Declaration Syntax
C# Visual Basic Visual C++
protected override void OnReceivedChannelFrame(
    IChannelFrame frame
)
Protected Overrides Sub OnReceivedChannelFrame ( _
    frame As IChannelFrame _
)
protected:
virtual void OnReceivedChannelFrame(
    IChannelFrame^ frame
) override
Parameters
frame (IChannelFrame)
IChannelFrame that was parsed by FrameImageParserBase that implements protocol specific common frame header interface.


OnReceivedConfigurationFrame Method (frame)

OnReceivedConfigurationFrame Method (frame)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrameParser ► OnReceivedConfigurationFrame(IConfigurationFrame)
Raises the ReceivedConfigurationFrame event.
Declaration Syntax
C# Visual Basic Visual C++
protected override void OnReceivedConfigurationFrame(
    IConfigurationFrame frame
)
Protected Overrides Sub OnReceivedConfigurationFrame ( _
    frame As IConfigurationFrame _
)
protected:
virtual void OnReceivedConfigurationFrame(
    IConfigurationFrame^ frame
) override
Parameters
frame (IConfigurationFrame)
IConfigurationFrame to send to ReceivedConfigurationFrame event.


OnReceivedHeaderFrame Method (frame)

OnReceivedHeaderFrame Method (frame)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrameParser ► OnReceivedHeaderFrame(IHeaderFrame)
Raises the ReceivedHeaderFrame event.
Declaration Syntax
C# Visual Basic Visual C++
protected override void OnReceivedHeaderFrame(
    IHeaderFrame frame
)
Protected Overrides Sub OnReceivedHeaderFrame ( _
    frame As IHeaderFrame _
)
protected:
virtual void OnReceivedHeaderFrame(
    IHeaderFrame^ frame
) override
Parameters
frame (IHeaderFrame)
IHeaderFrame to send to ReceivedHeaderFrame event.


ParseCommonHeader Method (buffer, offset, length)

ParseCommonHeader Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrameParser ► ParseCommonHeader(array<Byte>[]()[][], Int32, Int32)
Parses a common header instance that implements ICommonHeader for the output type represented in the binary image.
Declaration Syntax
C# Visual Basic Visual C++
protected override ICommonHeader<FrameType> ParseCommonHeader(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function ParseCommonHeader ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As ICommonHeader(Of FrameType)
protected:
virtual ICommonHeader<FrameType>^ ParseCommonHeader(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer containing data to parse.
offset (Int32)
Offset index into buffer that represents where to start parsing.
length (Int32)
Maximum length of valid data from offset.
Return Value
The ICommonHeader which includes a type ID for the Type to be parsed.
Remarks

Derived classes need to provide a common header instance (i.e., class that implements ICommonHeader) for the output types; this will primarily include an ID of the Type that the data image represents. This parsing is only for common header information, actual parsing will be handled by output type via its Initialize(array<Byte>[]()[][], Int32, Int32) method. This header image should also be used to add needed complex state information about the output type being parsed if needed.

If there is not enough buffer available to parse common header (as determined by length), return null. Also, if the protocol allows frame length to be determined at the time common header is being parsed and there is not enough buffer to parse the entire frame, it will be optimal to prevent further parsing by returning null.


ProtocolUsesSyncBytes Property

ProtocolUsesSyncBytes Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrameParser ► ProtocolUsesSyncBytes
Gets flag that determines if Macrodyne protocol parsing implementation uses synchronization bytes.
Declaration Syntax
C# Visual Basic Visual C++
public override bool ProtocolUsesSyncBytes { get; }
Public Overrides ReadOnly Property ProtocolUsesSyncBytes As Boolean
    Get
public:
virtual property bool ProtocolUsesSyncBytes {
    bool get () override;
}


ReceivedConfigurationFrame Event

ReceivedConfigurationFrame Event
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrameParser ► ReceivedConfigurationFrame
Occurs when a Macrodyne ConfigurationFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<ConfigurationFrame>> ReceivedConfigurationFrame
Public Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of ConfigurationFrame))
public:
 event EventHandler<EventArgs<ConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
}
Remarks
Argument()()()() is the ConfigurationFrame that was received.


ReceivedDataFrame Event

ReceivedDataFrame Event
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrameParser ► ReceivedDataFrame
Occurs when a Macrodyne DataFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<DataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of DataFrame))
public:
 event EventHandler<EventArgs<DataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<DataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<DataFrame^>^>^ value);
}
Remarks
Argument()()()() is the DataFrame that was received.


ReceivedHeaderFrame Event

ReceivedHeaderFrame Event
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrameParser ► ReceivedHeaderFrame
Occurs when a Macrodyne HeaderFrame that contains the UnitID (i.e., station name) has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<HeaderFrame>> ReceivedHeaderFrame
Public Event ReceivedHeaderFrame As EventHandler(Of EventArgs(Of HeaderFrame))
public:
 event EventHandler<EventArgs<HeaderFrame^>^>^ ReceivedHeaderFrame {
    void add (EventHandler<EventArgs<HeaderFrame^>^>^ value);
    void remove (EventHandler<EventArgs<HeaderFrame^>^>^ value);
}
Remarks
Argument()()()() is the HeaderFrame that was received.


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrameParser ► Start()()()()
Start the data parser.
Declaration Syntax
C# Visual Basic Visual C++
public override void Start()
Public Overrides Sub Start
public:
virtual void Start() override


FrameType Enumeration

FrameType Enumeration
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrameType
Macrodyne frame types enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum FrameType
<SerializableAttribute> _
Public Enumeration FrameType
[SerializableAttribute]
public enum class FrameType
Members
Member | Description
DataFrame | Data frame.
ConfigurationFrame | Configuration frame.
HeaderFrame | Header frame.


FrequencyDefinition Class

FrequencyDefinition Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrequencyDefinition
Represents the Macrodyne implementation of a IFrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FrequencyDefinition : FrequencyDefinitionBase
<SerializableAttribute> _
Public Class FrequencyDefinition _
    Inherits FrequencyDefinitionBase
[SerializableAttribute]
public ref class FrequencyDefinition : public FrequencyDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
 | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
 | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | FrequencyDefinitionBase
 |  |  |  |  | FrequencyDefinition


FrequencyDefinition Constructor

FrequencyDefinition Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrequencyDefinition ► FrequencyDefinition()()()()
Members
Icon | Member | Description
 | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
 | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
 | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.


FrequencyDefinition Constructor (info, context)

FrequencyDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrequencyDefinition ► FrequencyDefinition(SerializationInfo, StreamingContext)
Creates a new FrequencyDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrequencyDefinition Constructor (parent)

FrequencyDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrequencyDefinition ► FrequencyDefinition(IConfigurationCell)
Creates a new FrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
FrequencyDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this FrequencyDefinition.


FrequencyDefinition Constructor (parent, label)

FrequencyDefinition Constructor (parent, label)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrequencyDefinition ► FrequencyDefinition(ConfigurationCell, String)
Creates a new FrequencyDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String _
)
public:
FrequencyDefinition(
    ConfigurationCell^ parent,
    String^ label
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this FrequencyDefinition.
label (String)
The label of this FrequencyDefinition.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrequencyDefinition ► Parent
Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


FrequencyValue Class

FrequencyValue Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrequencyValue
Represents the Macrodyne implementation of a IFrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FrequencyValue : FrequencyValueBase
<SerializableAttribute> _
Public Class FrequencyValue _
    Inherits FrequencyValueBase
[SerializableAttribute]
public ref class FrequencyValue : public FrequencyValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
 | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
 | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from FrequencyValueBase.)
 | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
 | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this FrequencyValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from FrequencyValueBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
 | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IFrequencyDefinition >)>)>
 |  |  |  | FrequencyValueBase
 |  |  |  |  | FrequencyValue


FrequencyValue Constructor

FrequencyValue Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrequencyValue ► FrequencyValue()()()()
Members
Icon | Member | Description
 | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
 | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
 | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.


FrequencyValue Constructor (info, context)

FrequencyValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrequencyValue ► FrequencyValue(SerializationInfo, StreamingContext)
Creates a new FrequencyValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrequencyValue Constructor (parent, frequencyDefinition)

FrequencyValue Constructor (parent, frequencyDefinition)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrequencyValue ► FrequencyValue(IDataCell, IFrequencyDefinition)
Creates a new FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyValue(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    frequencyDefinition As IFrequencyDefinition _
)
public:
FrequencyValue(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this FrequencyValue.
frequencyDefinition (IFrequencyDefinition)
The IFrequencyDefinition associated with this FrequencyValue.


FrequencyValue Constructor (parent, frequencyDefinition, frequency, dfdt)

FrequencyValue Constructor (parent, frequencyDefinition, frequency, dfdt)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrequencyValue ► FrequencyValue(DataCell, FrequencyDefinition, Double, Double)
Creates a new FrequencyValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyValue(
    DataCell parent,
    FrequencyDefinition frequencyDefinition,
    double frequency,
    double dfdt
)
Public Sub New ( _
    parent As DataCell, _
    frequencyDefinition As FrequencyDefinition, _
    frequency As Double, _
    dfdt As Double _
)
public:
FrequencyValue(
    DataCell^ parent,
    FrequencyDefinition^ frequencyDefinition,
    double frequency,
    double dfdt
)
Parameters
parent (DataCell)
The DataCell parent of this FrequencyValue.
frequencyDefinition (FrequencyDefinition)
The FrequencyDefinition associated with this FrequencyValue.
frequency (Double)
The floating point value that represents this FrequencyValue.
dfdt (Double)
The floating point value that represents the change in this FrequencyValue over time.


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrequencyValue ► Definition
Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual FrequencyDefinition Definition { get; set; }
Public Overridable Property Definition As FrequencyDefinition
    Get
    Set
public:
virtual property FrequencyDefinition^ Definition {
    FrequencyDefinition^ get ();
    void set (FrequencyDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrequencyValue ► Parent
Gets or sets the DataCell parent of this FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


GpsStatus Enumeration

GpsStatus Enumeration
Namespaces ► TVA.PhasorProtocols.Macrodyne ► GpsStatus
Macrodyne GPS status enumeration (from Status 2 byte, bits 3-4).
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum GpsStatus
<SerializableAttribute> _
Public Enumeration GpsStatus
[SerializableAttribute]
public enum class GpsStatus
Members
Member | Description
StatusIsGood | 00 - GPS clock status is good.
NoStatus1 | 01 - None (undefined state 1).
NoStatus2 | 10 - None (undefined state 2).
StatusIsBad | 11 - GPS clock status is bad.


HeaderFrame Class

HeaderFrame Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame
Represents the Macrodyne implementation of a IHeaderFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class HeaderFrame : HeaderFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
<SerializableAttribute> _
Public Class HeaderFrame _
    Inherits HeaderFrameBase _
    Implements ISupportFrameImage(Of FrameType), ISupportBinaryImage
[SerializableAttribute]
public ref class HeaderFrame : public HeaderFrameBase,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HeaderFrame()()()() | Creates a new HeaderFrame.
 | HeaderFrame(String) | Creates a new HeaderFrame.
 | HeaderFrame(SerializationInfo, StreamingContext) | Creates a new HeaderFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Overrides ChannelFrameBase <(Of <(<' IHeaderCell >)>)>.AppendChecksum(array<Byte>[]()[][], Int32).)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the HeaderFrameBase object. (Inherited from HeaderFrameBase.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage()()()(). (Overrides ChannelFrameBase <(Of <(<' IHeaderCell >)>)>.BinaryLength.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' IHeaderCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the HeaderCellCollection for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBase <(Of <(<' IHeaderCell >)>)>.ChecksumIsValid(array<Byte>[]()[][], Int32).)
 | CommonHeader | Gets or sets current CommonFrameHeader.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameType | Gets the FundamentalFrameType for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelFrameBase <(Of <(<' IHeaderCell >)>)>.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderData | Gets or sets header data for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
 | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Overrides ChannelFrameBase <(Of <(<' IHeaderCell >)>)>.Initialize(array<Byte>[]()[][], Int32, Int32).)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides BinaryImageBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this HeaderFrameBase. (Inherited from HeaderFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets the identifier that is used to identify the Macrodyne frame.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IHeaderCell >)>)>
 |  |  |  | HeaderFrameBase
 |  |  |  |  | HeaderFrame


HeaderFrame Constructor

HeaderFrame Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► HeaderFrame()()()()
Members
Icon | Member | Description
 | HeaderFrame()()()() | Creates a new HeaderFrame.
 | HeaderFrame(String) | Creates a new HeaderFrame.
 | HeaderFrame(SerializationInfo, StreamingContext) | Creates a new HeaderFrame from serialization parameters.


HeaderFrame Constructor

HeaderFrame Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► HeaderFrame()()()()
Creates a new HeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
public HeaderFrame()
Public Sub New
public:
HeaderFrame()
Remarks
This constructor is used by a consumer or by FrameImageParserBase to generate or parse a Macrodyne header frame.


HeaderFrame Constructor (info, context)

HeaderFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► HeaderFrame(SerializationInfo, StreamingContext)
Creates a new HeaderFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected HeaderFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
HeaderFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


HeaderFrame Constructor (headerData)

HeaderFrame Constructor (headerData)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► HeaderFrame(String)
Creates a new HeaderFrame.
Declaration Syntax
C# Visual Basic Visual C++
public HeaderFrame(
    string headerData
)
Public Sub New ( _
    headerData As String _
)
public:
HeaderFrame(
    String^ headerData
)
Parameters
headerData (String)
String based data to include in this HeaderFrame.
Remarks
This constructor is used by a consumer to generate a Macrodyne header frame.


AppendChecksum Method (buffer, startIndex)

AppendChecksum Method (buffer, startIndex)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► AppendChecksum(array<Byte>[]()[][], Int32)
Appends checksum onto buffer starting at startIndex.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AppendChecksum(
    byte[] buffer,
    int startIndex
)
Protected Overrides Sub AppendChecksum ( _
    buffer As Byte(), _
    startIndex As Integer _
)
protected:
virtual void AppendChecksum(
    array<unsigned char>^ buffer,
    int startIndex
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image on which to append checksum.
startIndex (Int32)
Index into buffer where checksum should be appended.
Remarks
Default implementation encodes checksum in big-endian order and expects buffer size large enough to accomodate 2-byte checksum representation. We override this method since checksum in Macrodyne is a single byte.


BinaryLength Property

BinaryLength Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► BinaryLength
Gets the length of the BinaryImage()()()().
Declaration Syntax
C# Visual Basic Visual C++
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
public:
virtual property int BinaryLength {
    int get () override;
}
Remarks
This property is overriden so the length can be extended to include a 1-byte checksum.


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.


ChecksumIsValid Method (buffer, startIndex)

ChecksumIsValid Method (buffer, startIndex)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► ChecksumIsValid(array<Byte>[]()[][], Int32)
Determines if checksum in the buffer is valid.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid ( _
    buffer As Byte(), _
    startIndex As Integer _
) As Boolean
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image to validate.
startIndex (Int32)
Start index into buffer to perform checksum.
Return Value
Flag that determines if checksum over buffer is valid.
Remarks
Default implementation expects 2-byte big-endian ordered checksum. So we override method since checksum in Macrodyne is a single byte.


CommonHeader Property

CommonHeader Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► CommonHeader
Gets or sets current CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► HeaderImage
Gets the binary header image of the DataFrame object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


Initialize Method (binaryImage, startIndex, length)

Initialize Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► Initialize(array<Byte>[]()[][], Int32, Int32)
Parses the binary image.
Declaration Syntax
C# Visual Basic Visual C++
public override int Initialize(
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Overrides Function Initialize ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
public:
virtual int Initialize(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.
Exceptions
Exception | Condition
InvalidOperationException | Invalid binary image detected - check sum did not match.


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► TypeID
Gets the identifier that is used to identify the Macrodyne frame.
Declaration Syntax
C# Visual Basic Visual C++
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}


OnlineDataFormatFlags Enumeration

OnlineDataFormatFlags Enumeration
Namespaces ► TVA.PhasorProtocols.Macrodyne ► OnlineDataFormatFlags
Macrodyne ON-LINE data format flags enumeration (from RequestOnlineDataFormat 2 byte response).
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[FlagsAttribute]
public enum OnlineDataFormatFlags
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration OnlineDataFormatFlags
[SerializableAttribute]
[FlagsAttribute]
public enum class OnlineDataFormatFlags
Members
Member | Description
Phasor6Enabled | Phasor 6 enabled.
Phasor7Enabled | Phasor 7 enabled.
Phasor8Enabled | Phasor 8 enabled.
Phasor9Enabled | Phasor 9 enabled.
Phasor10Enabled | Phasor 10 enabled.
Digital2Enabled | Digital channel 2 enabled.
NotUsed1 | Bit not used (undefined bit 1).
NotUsed2 | Bit not used (undefined bit 2).
Status2ByteEnabled | Status 2 enabled.
TimestampEnabled | Timestamp enabled.
Phasor2Enabled | Phasor 2 enabled.
Phasor3Enabled | Phasor 3 enabled.
Phasor4Enabled | Phasor 4 enabled.
Phasor5Enabled | Phasor 5 enabled.
ReferenceEnabled | Reference enabled.
Digital1Enabled | Digital channel 1 enabled.
NoFlags | No flags.


OperationalLimitFlags Enumeration

OperationalLimitFlags Enumeration
Namespaces ► TVA.PhasorProtocols.Macrodyne ► OperationalLimitFlags
Macrodyne operational limit reached flags enumeration (from RequestOperationalLimitFlags first byte of 3 byte response).
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[FlagsAttribute]
public enum OperationalLimitFlags
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration OperationalLimitFlags
[SerializableAttribute]
[FlagsAttribute]
public enum class OperationalLimitFlags
Members
Member | Description
VMinLimitReached | VMIN operations limit reached.
VMaxLimitReached | VMAX operations limit reached.
AngdLimitReached | ANGD operations limit reached.
FreqLimitReached | FREQ operations limit reached.
DtDtLimitReached | DFDT operations limit reached.
LncmLimitReached | LNCM operations limit reached.
NotUsed1 | Bit not used (undefined bit 1).
NotUsed2 | Bit not used (undefined bit 2).
NoFlags | No flags.


PhasorDefinition Class

PhasorDefinition Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► PhasorDefinition
Represents the Macrodyne implementation of a IPhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PhasorDefinition : PhasorDefinitionBase
<SerializableAttribute> _
Public Class PhasorDefinition _
    Inherits PhasorDefinitionBase
[SerializableAttribute]
public ref class PhasorDefinition : public PhasorDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(ConfigurationCell, String, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | PhasorDefinitionBase
 |  |  |  |  | PhasorDefinition


PhasorDefinition Constructor

PhasorDefinition Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► PhasorDefinition ► PhasorDefinition()()()()
Members
Icon | Member | Description
 | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(ConfigurationCell, String, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.


PhasorDefinition Constructor (info, context)

PhasorDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► PhasorDefinition ► PhasorDefinition(SerializationInfo, StreamingContext)
Creates a new PhasorDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


PhasorDefinition Constructor (parent)

PhasorDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► PhasorDefinition ► PhasorDefinition(IConfigurationCell)
Creates a new PhasorDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
PhasorDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this PhasorDefinition.


PhasorDefinition Constructor (parent, label, type, voltageReference)

PhasorDefinition Constructor (parent, label, type, voltageReference)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► PhasorDefinition ► PhasorDefinition(ConfigurationCell, String, PhasorType, PhasorDefinition)
Creates a new PhasorDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinition(
    ConfigurationCell parent,
    string label,
    PhasorType type,
    PhasorDefinition voltageReference
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String, _
    type As PhasorType, _
    voltageReference As PhasorDefinition _
)
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    String^ label,
    PhasorType type,
    PhasorDefinition^ voltageReference
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this PhasorDefinition.
label (String)
The label of this PhasorDefinition.
type (PhasorType)
The PhasorType of this PhasorDefinition.
voltageReference (PhasorDefinition)
The associated IPhasorDefinition that represents the voltage reference (if any).


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► PhasorDefinition ► Parent
Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


PhasorValue Class

PhasorValue Class
Namespaces ► TVA.PhasorProtocols.Macrodyne ► PhasorValue
Represents the Macrodyne implementation of a IPhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PhasorValue : PhasorValueBase
<SerializableAttribute> _
Public Class PhasorValue _
    Inherits PhasorValueBase
[SerializableAttribute]
public ref class PhasorValue : public PhasorValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
 | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
 | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
 | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
 | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this PhasorValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from PhasorValueBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IPhasorDefinition >)>)>
 |  |  |  | PhasorValueBase
 |  |  |  |  | PhasorValue


PhasorValue Constructor

PhasorValue Constructor
Namespaces ► TVA.PhasorProtocols.Macrodyne ► PhasorValue ► PhasorValue()()()()
Members
Icon | Member | Description
 | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
 | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.


PhasorValue Constructor (info, context)

PhasorValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► PhasorValue ► PhasorValue(SerializationInfo, StreamingContext)
Creates a new PhasorValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


PhasorValue Constructor (parent, phasorDefinition)

PhasorValue Constructor (parent, phasorDefinition)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► PhasorValue ► PhasorValue(IDataCell, IPhasorDefinition)
Creates a new PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    IDataCell parent,
    IPhasorDefinition phasorDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    phasorDefinition As IPhasorDefinition _
)
public:
PhasorValue(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this PhasorValue.
phasorDefinition (IPhasorDefinition)
The IPhasorDefinition associated with this PhasorValue.


PhasorValue Constructor (parent, phasorDefinition, real, imaginary)

PhasorValue Constructor (parent, phasorDefinition, real, imaginary)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► PhasorValue ► PhasorValue(DataCell, PhasorDefinition, Double, Double)
Creates a new PhasorValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    double real,
    double imaginary
)
Public Sub New ( _
    parent As DataCell, _
    phasorDefinition As PhasorDefinition, _
    real As Double, _
    imaginary As Double _
)
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    double real,
    double imaginary
)
Parameters
parent (DataCell)
The DataCell parent of this PhasorValue.
phasorDefinition (PhasorDefinition)
The PhasorDefinition associated with this PhasorValue.
real (Double)
The real value of this PhasorValue.
imaginary (Double)
The imaginary value of this PhasorValue.


PhasorValue Constructor (parent, phasorDefinition, angle, magnitude)

PhasorValue Constructor (parent, phasorDefinition, angle, magnitude)
Namespaces ► TVA.PhasorProtocols.Macrodyne ► PhasorValue ► PhasorValue(DataCell, PhasorDefinition, Angle, Double)
Creates a new PhasorValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    Angle angle,
    double magnitude
)
Public Sub New ( _
    parent As DataCell, _
    phasorDefinition As PhasorDefinition, _
    angle As Angle, _
    magnitude As Double _
)
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    Angle angle,
    double magnitude
)
Parameters
parent (DataCell)
The DataCell parent of this PhasorValue.
phasorDefinition (PhasorDefinition)
The PhasorDefinition associated with this PhasorValue.
angle (Angle)
The Angle value (a.k.a., the argument) of this PhasorValue, in radians.
magnitude (Double)
The magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue.


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► PhasorValue ► Definition
Gets or sets the PhasorDefinition associated with this PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual PhasorDefinition Definition { get; set; }
Public Overridable Property Definition As PhasorDefinition
    Get
    Set
public:
virtual property PhasorDefinition^ Definition {
    PhasorDefinition^ get ();
    void set (PhasorDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.Macrodyne ► PhasorValue ► Parent
Gets or sets the DataCell parent of this PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


StatusFlags Enumeration

StatusFlags Enumeration
Namespaces ► TVA.PhasorProtocols.Macrodyne ► StatusFlags
Macrodyne status flags enumeration (from Status 1 byte).
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[FlagsAttribute]
public enum StatusFlags
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration StatusFlags
[SerializableAttribute]
[FlagsAttribute]
public enum class StatusFlags
Members
Member | Description
TriggerDetected | TRG = 1 - Trigger detected, table being collected.
OperationalLimitReached | OP = 1 - Operational limit reached.
ResetOccurred | UR = 1 - Reset occurred.
TimeError | TTE = 1 - Error in GPS time or time tag.
ReferenceLost | RL = 1 - Reference expected but not received.
InputReferenceEnabled | RI = 1 - Unit enabled to receive reference.
OuputReferenceEnabled | RO = 1 - Unit set to output reference.
TriggerDetectedMemoryFull | Trigger detected, but memory full.
NoFlags | No flags.


TriggerReason Enumeration

TriggerReason Enumeration
Namespaces ► TVA.PhasorProtocols.Macrodyne ► TriggerReason
Macrodyne trigger reason enumeration (from Status 2 byte, bits 0-2).
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum TriggerReason
<SerializableAttribute> _
Public Enumeration TriggerReason
[SerializableAttribute]
public enum class TriggerReason
Members
Member | Description
DigitalChannelTrigger | 111 DCHN - Digital channel.
LinearCombinationTrigger | 110 LNCM - Linear combination.
DfDtTrigger | 101 DFDT - Change in frequency over time.
FrequencyTrigger | 100 FREQ - Maximum allowed offset from 60 Hz.
AngleDifferenceTrigger | 011 ANGD - Angle difference from reference.
MaximumMagnitudeTrigger | 010 VMAX - Maximum magnitude.
MinimumMagnitudeTrigger | 001 VMIN - Minimum magnitude.
UserDefined | 000 USER - Manual trigger.


TVA.PhasorProtocols.SelFastMessage Namespace

TVA.PhasorProtocols.SelFastMessage Namespace
Namespaces ► TVA.PhasorProtocols.SelFastMessage
Contains an implementation of the phasor classes used to parse or generate a stream of data in the SEL Fast Message format used by a variety of SEL devices.
Declaration Syntax
C# Visual Basic Visual C++
namespace TVA.PhasorProtocols.SelFastMessage
Namespace TVA.PhasorProtocols.SelFastMessage
namespace TVA.PhasorProtocols.SelFastMessage
Types
All Types Classes Enumerations
Icon | Type | Description
 | CommandFrame | Represents the SEL Fast Message implementation of a ICommandFrame that can be sent or received.
 | Common | Common SEL Fast Message declarations and functions.
 | CommonFrameHeader | Represents the common header for all SEL Fast Message frames of data.
 | ConfigurationCell | Represents the SEL Fast Message implementation of a IConfigurationCell that can be sent or received.
 | ConfigurationCellCollection | Represents a SEL Fast Message implementation of a collection of IConfigurationCell objects.
 | ConfigurationFrame | Represents the SEL Fast Message implementation of a IConfigurationFrame that can be sent or received.
 | ConnectionParameters | Represents the extra connection parameters required for a connection to a SEL device.
 | DataCell | Represents the SEL Fast Message implementation of a IDataCell that can be sent or received.
 | DataCellCollection | Represents a SEL Fast Message implementation of a collection of IDataCell objects.
 | DataFrame | Represents the SEL Fast Message implementation of a IDataFrame that can be sent or received.
 | DeviceCommand | SEL Fast Message device commands enumeration.
 | FrameParser | Represents a frame parser for a SEL Fast Message binary data stream that returns parsed data via events.
 | FrameSize | SEL Fast Message PMDATA setting frame size enumeration.
 | FrequencyDefinition | Represents the SEL Fast Message implementation of a IFrequencyDefinition.
 | FrequencyValue | Represents the SEL Fast Message implementation of a IFrequencyValue.
 | MessagePeriod | SEL Fast Message frame rate enumeration.
 | PhasorDefinition | Represents the SEL Fast Message implementation of a IPhasorDefinition.
 | PhasorValue | Represents the SEL Fast Message implementation of a IPhasorValue.
 | StatusFlags | SEL Fast Message status word flags enumeration.


CommandFrame Class

CommandFrame Class
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame
Represents the SEL Fast Message implementation of a ICommandFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CommandFrame : CommandFrameBase
<SerializableAttribute> _
Public Class CommandFrame _
    Inherits CommandFrameBase
[SerializableAttribute]
public ref class CommandFrame : public CommandFrameBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandFrame(array<Byte>[]()[][], Int32, Int32) | Creates a new CommandFrame from the given binaryImage.
 | CommandFrame(DeviceCommand, MessagePeriod) | Creates a new CommandFrame from specified parameters.
 | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataFrame object. (Overrides CommandFrameBase.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this CommandFrame. (Overrides CommandFrameBase.BodyImage.)
 | BodyLength | Gets the length of the BodyImage. (Overrides CommandFrameBase.BodyLength.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' ICommandCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the CommandCellCollection for this CommandFrameBase. (Inherited from CommandFrameBase.)
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Command | Gets or sets the DeviceCommand for this CommandFrame.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ExtendedData | Gets or sets extended binary image data for this CommandFrameBase. (Inherited from CommandFrameBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameSize | Gets frame size based on Command.
 | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Inherited from CommandFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides CommandFrameBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets or sets the ID code of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessagePeriod | Gets or sets the desired message period for the SEL device.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from CommandFrameBase.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this CommandFrameBase. (Inherited from CommandFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
SEL Fast Message command frames are designed only to be sent to a device, not received from a device. As a result this frame does not implement ISupportFrameImage for automated frame parsing. This class exposes a constructor that accepts a binary image in order to manually parse a command frame.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' ICommandCell >)>)>
 |  |  |  | CommandFrameBase
 |  |  |  |  | CommandFrame


CommandFrame Constructor

CommandFrame Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame ► CommandFrame()()()()
Members
Icon | Member | Description
 | CommandFrame(array<Byte>[]()[][], Int32, Int32) | Creates a new CommandFrame from the given binaryImage.
 | CommandFrame(DeviceCommand, MessagePeriod) | Creates a new CommandFrame from specified parameters.
 | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.


CommandFrame Constructor (binaryImage, startIndex, length)

CommandFrame Constructor (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame ► CommandFrame(array<Byte>[]()[][], Int32, Int32)
Creates a new CommandFrame from the given binaryImage.
Declaration Syntax
C# Visual Basic Visual C++
public CommandFrame(
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Sub New ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
)
public:
CommandFrame(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
)
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Remarks
This constructor is used by a consumer to parse a received SEL Fast Message command frame. Typically command frames are sent to a device. This constructor would used if this code was being used inside of a phasor measurement device.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | length is not large enough to parse frame.


CommandFrame Constructor (info, context)

CommandFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame ► CommandFrame(SerializationInfo, StreamingContext)
Creates a new CommandFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected CommandFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CommandFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


CommandFrame Constructor (command, messagePeriod)

CommandFrame Constructor (command, messagePeriod)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame ► CommandFrame(DeviceCommand, MessagePeriod)
Creates a new CommandFrame from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public CommandFrame(
    DeviceCommand command,
    MessagePeriod messagePeriod
)
Public Sub New ( _
    command As DeviceCommand, _
    messagePeriod As MessagePeriod _
)
public:
CommandFrame(
    DeviceCommand command,
    MessagePeriod messagePeriod
)
Parameters
command (DeviceCommand)
The DeviceCommand for this CommandFrame.
messagePeriod (MessagePeriod)
The desired MessagePeriod for SEL device connection.
Remarks
This constructor is used by a consumer to generate an SEL Fast Message command frame.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataFrame object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame ► BodyImage
Gets the binary body image of this CommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.


Command Property

Command Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame ► Command
Gets or sets the DeviceCommand for this CommandFrame.
Declaration Syntax
C# Visual Basic Visual C++
public DeviceCommand Command { get; set; }
Public Property Command As DeviceCommand
    Get
    Set
public:
property DeviceCommand Command {
    DeviceCommand get ();
    void set (DeviceCommand value);
}


FrameSize Property

FrameSize Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame ► FrameSize
Gets frame size based on Command.
Declaration Syntax
C# Visual Basic Visual C++
public byte FrameSize { get; }
Public ReadOnly Property FrameSize As Byte
    Get
public:
property unsigned char FrameSize {
    unsigned char get ();
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame ► HeaderImage
Gets the binary header image of the DataFrame object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


MessagePeriod Property

MessagePeriod Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame ► MessagePeriod
Gets or sets the desired message period for the SEL device.
Declaration Syntax
C# Visual Basic Visual C++
public MessagePeriod MessagePeriod { get; set; }
Public Property MessagePeriod As MessagePeriod
    Get
    Set
public:
property MessagePeriod MessagePeriod {
    MessagePeriod get ();
    void set (MessagePeriod value);
}


Common Class

Common Class
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► Common
Common SEL Fast Message declarations and functions.
Declaration Syntax
C# Visual Basic Visual C++
public static class Common
Public NotInheritable Class Common
public ref class Common abstract sealed
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HeaderByte1 | SEL Fast message data frame header byte 1.
 | HeaderByte2 | SEL Fast message data frame header byte 2.
 | MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
 | MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
 | MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
 | MaximumExtendedDataLength | Absolute maximum number of bytes of extended data that could fit into a command frame.
 | MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
Inheritance Hierarchy
Object
Common


HeaderByte1 Field

HeaderByte1 Field
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► Common ► HeaderByte1
SEL Fast message data frame header byte 1.
Declaration Syntax
C# Visual Basic Visual C++
public const byte HeaderByte1
Public Const HeaderByte1 As Byte
public:
literal unsigned char HeaderByte1


HeaderByte2 Field

HeaderByte2 Field
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► Common ► HeaderByte2
SEL Fast message data frame header byte 2.
Declaration Syntax
C# Visual Basic Visual C++
public const byte HeaderByte2
Public Const HeaderByte2 As Byte
public:
literal unsigned char HeaderByte2


MaximumAnalogValues Field

MaximumAnalogValues Field
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► Common ► MaximumAnalogValues
Absolute maximum number of possible analog values that could fit into a data frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumAnalogValues
Public Const MaximumAnalogValues As UShort
public:
literal unsigned short MaximumAnalogValues


MaximumDataLength Field

MaximumDataLength Field
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► Common ► MaximumDataLength
Absolute maximum data length (in bytes) that could fit into any frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumDataLength
Public Const MaximumDataLength As UShort
public:
literal unsigned short MaximumDataLength


MaximumDigitalValues Field

MaximumDigitalValues Field
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► Common ► MaximumDigitalValues
Absolute maximum number of possible digital values that could fit into a data frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumDigitalValues
Public Const MaximumDigitalValues As UShort
public:
literal unsigned short MaximumDigitalValues


MaximumExtendedDataLength Field

MaximumExtendedDataLength Field
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► Common ► MaximumExtendedDataLength
Absolute maximum number of bytes of extended data that could fit into a command frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumExtendedDataLength
Public Const MaximumExtendedDataLength As UShort
public:
literal unsigned short MaximumExtendedDataLength


MaximumPhasorValues Field

MaximumPhasorValues Field
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► Common ► MaximumPhasorValues
Absolute maximum number of possible phasor values that could fit into a data frame.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort MaximumPhasorValues
Public Const MaximumPhasorValues As UShort
public:
literal unsigned short MaximumPhasorValues


CommonFrameHeader Class

CommonFrameHeader Class
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader
Represents the common header for all SEL Fast Message frames of data.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CommonFrameHeader : CommonHeaderBase<int>,
    ISerializable
<SerializableAttribute> _
Public Class CommonFrameHeader _
    Inherits CommonHeaderBase(Of Integer) _
    Implements ISerializable
[SerializableAttribute]
public ref class CommonFrameHeader : public CommonHeaderBase<int>,
    ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommonFrameHeader(FrameSize, Ticks) | Creates a new CommonFrameHeader from specified parameters.
 | CommonFrameHeader(array<Byte>[]()[][], Int32) | Creates a new CommonFrameHeader from given binaryImage.
 | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
 | BinaryImage | Gets the binary image of the common header portion of this CommonFrameHeader.
 | DataLength | Gets the length of the data in the SEL Fast Message frame (i.e., the FrameSize minus the HeaderLength and checksum) of this CommonFrameHeader.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FixedLength | Total fixed length of CommonFrameHeader.
 | FrameSize | Gets or sets the SEL Fast Message frame size of this CommonFrameHeader.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderLength | Total header length of CommonFrameHeader.
 | IDCode | Gets or sets the SEL Fast Message destination address (PMADDR setting) of this CommonFrameHeader.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterCount | Gets the SEL Fast Message register count of this CommonFrameHeader.
 | SampleNumber | Gets the SEL Fast Message sample number of this CommonFrameHeader.
 | SecondOfCentury | Gets the SEL Fast Message second of century of this CommonFrameHeader.
 | State()()()() | (Inherited from CommonHeaderBase<(Of <(<' Int32 >)>)>.)
 | Timestamp | Gets or sets timestamp of this CommonFrameHeader.
 | TimeTag | Gets the timestamp of this frame in NTP format.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID()()()() | (Inherited from CommonHeaderBase<(Of <(<' Int32 >)>)>.)
Inheritance Hierarchy
Object
 | CommonHeaderBase<(Of <(<' Int32 >)>)>
 |  | CommonFrameHeader


CommonFrameHeader Constructor

CommonFrameHeader Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader ► CommonFrameHeader()()()()
Members
Icon | Member | Description
 | CommonFrameHeader(FrameSize, Ticks) | Creates a new CommonFrameHeader from specified parameters.
 | CommonFrameHeader(array<Byte>[]()[][], Int32) | Creates a new CommonFrameHeader from given binaryImage.
 | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.


CommonFrameHeader Constructor (binaryImage, startIndex)

CommonFrameHeader Constructor (binaryImage, startIndex)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader ► CommonFrameHeader(array<Byte>[]()[][], Int32)
Creates a new CommonFrameHeader from given binaryImage.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader(
    byte[] binaryImage,
    int startIndex
)
Public Sub New ( _
    binaryImage As Byte(), _
    startIndex As Integer _
)
public:
CommonFrameHeader(
    array<unsigned char>^ binaryImage,
    int startIndex
)
Parameters
binaryImage (array< Byte >[]()[][])
Buffer that contains data to parse.
startIndex (Int32)
Start index into buffer where valid data begins.


CommonFrameHeader Constructor (info, context)

CommonFrameHeader Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader ► CommonFrameHeader(SerializationInfo, StreamingContext)
Creates a new CommonFrameHeader from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected CommonFrameHeader(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CommonFrameHeader(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


CommonFrameHeader Constructor (frameSize, timestamp)

CommonFrameHeader Constructor (frameSize, timestamp)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader ► CommonFrameHeader(FrameSize, Ticks)
Creates a new CommonFrameHeader from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader(
    FrameSize frameSize,
    Ticks timestamp
)
Public Sub New ( _
    frameSize As FrameSize, _
    timestamp As Ticks _
)
public:
CommonFrameHeader(
    FrameSize frameSize,
    Ticks timestamp
)
Parameters
frameSize (FrameSize)
The FrameSize of this frame.
timestamp (Ticks)
The timestamp of this frame.


BinaryImage Property

BinaryImage Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader ► BinaryImage
Gets the binary image of the common header portion of this CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public byte[] BinaryImage { get; }
Public ReadOnly Property BinaryImage As Byte()
    Get
public:
property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get ();
}


DataLength Property

DataLength Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader ► DataLength
Gets the length of the data in the SEL Fast Message frame (i.e., the FrameSize minus the HeaderLength and checksum) of this CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public ushort DataLength { get; }
Public ReadOnly Property DataLength As UShort
    Get
public:
property unsigned short DataLength {
    unsigned short get ();
}


FixedLength Field

FixedLength Field
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader ► FixedLength
Total fixed length of CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort FixedLength
Public Const FixedLength As UShort
public:
literal unsigned short FixedLength


FrameSize Property

FrameSize Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader ► FrameSize
Gets or sets the SEL Fast Message frame size of this CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public FrameSize FrameSize { get; set; }
Public Property FrameSize As FrameSize
    Get
    Set
public:
property FrameSize FrameSize {
    FrameSize get ();
    void set (FrameSize value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderLength Field

HeaderLength Field
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader ► HeaderLength
Total header length of CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public const ushort HeaderLength
Public Const HeaderLength As UShort
public:
literal unsigned short HeaderLength


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader ► IDCode
Gets or sets the SEL Fast Message destination address (PMADDR setting) of this CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public uint IDCode { get; set; }
Public Property IDCode As UInteger
    Get
    Set
public:
property unsigned int IDCode {
    unsigned int get ();
    void set (unsigned int value);
}


RegisterCount Property

RegisterCount Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader ► RegisterCount
Gets the SEL Fast Message register count of this CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public ushort RegisterCount { get; }
Public ReadOnly Property RegisterCount As UShort
    Get
public:
property unsigned short RegisterCount {
    unsigned short get ();
}


SampleNumber Property

SampleNumber Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader ► SampleNumber
Gets the SEL Fast Message sample number of this CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public ushort SampleNumber { get; }
Public ReadOnly Property SampleNumber As UShort
    Get
public:
property unsigned short SampleNumber {
    unsigned short get ();
}


SecondOfCentury Property

SecondOfCentury Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader ► SecondOfCentury
Gets the SEL Fast Message second of century of this CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public uint SecondOfCentury { get; }
Public ReadOnly Property SecondOfCentury As UInteger
    Get
public:
property unsigned int SecondOfCentury {
    unsigned int get ();
}


Timestamp Property

Timestamp Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader ► Timestamp
Gets or sets timestamp of this CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public Ticks Timestamp { get; set; }
Public Property Timestamp As Ticks
    Get
    Set
public:
property Ticks Timestamp {
    Ticks get ();
    void set (Ticks value);
}


TimeTag Property

TimeTag Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommonFrameHeader ► TimeTag
Gets the timestamp of this frame in NTP format.
Declaration Syntax
C# Visual Basic Visual C++
public NtpTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As NtpTimeTag
    Get
public:
property NtpTimeTag^ TimeTag {
    NtpTimeTag^ get ();
}


ConfigurationCell Class

ConfigurationCell Class
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCell
Represents the SEL Fast Message implementation of a IConfigurationCell that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationCell : ConfigurationCellBase
<SerializableAttribute> _
Public Class ConfigurationCell _
    Inherits ConfigurationCellBase
[SerializableAttribute]
public ref class ConfigurationCell : public ConfigurationCellBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCell(ConfigurationFrame) | Creates a new ConfigurationCell from specified parameters.
 | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
 | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.AnalogDataFormat.)
 | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
 | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
 | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
 | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage | Gets the binary footer image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationCellBase.)
 | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBase.FrequencyDataFormat.)
 | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
 | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationCellBase.)
 | IDCode | Gets or sets the ID code of this ConfigurationCell.
 | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCell. (Overrides ConfigurationCellBase.MaximumStationNameLength.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ConfigurationCellBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary footer image. (Inherited from ConfigurationCellBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Inherited from ConfigurationCellBase.)
 | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.PhasorCoordinateFormat.)
 | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBase.PhasorDataFormat.)
 | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | ConfigurationCellBase
 |  |  |  |  | ConfigurationCell


ConfigurationCell Constructor

ConfigurationCell Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCell ► ConfigurationCell()()()()
Members
Icon | Member | Description
 | ConfigurationCell(ConfigurationFrame) | Creates a new ConfigurationCell from specified parameters.
 | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.


ConfigurationCell Constructor (info, context)

ConfigurationCell Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCell ► ConfigurationCell(SerializationInfo, StreamingContext)
Creates a new ConfigurationCell from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationCell(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationCell Constructor (parent)

ConfigurationCell Constructor (parent)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCell ► ConfigurationCell(ConfigurationFrame)
Creates a new ConfigurationCell from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell(
    ConfigurationFrame parent
)
Public Sub New ( _
    parent As ConfigurationFrame _
)
public:
ConfigurationCell(
    ConfigurationFrame^ parent
)
Parameters
parent (ConfigurationFrame)
The parent ConfigurationFrame.


AnalogDataFormat Property

AnalogDataFormat Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCell ► AnalogDataFormat
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat AnalogDataFormat { get; set; }
Public Overrides Property AnalogDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat AnalogDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}
Remarks
This property only supports floating-point data; SEL Fast Message doesn't transport scaled values.
Exceptions
Exception | Condition
NotSupportedException | SEL Fast Message only supports floating-point data.


FrequencyDataFormat Property

FrequencyDataFormat Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCell ► FrequencyDataFormat
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat FrequencyDataFormat { get; set; }
Public Overrides Property FrequencyDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}
Remarks
This property only supports floating-point data; SEL Fast Message doesn't transport scaled values.
Exceptions
Exception | Condition
NotSupportedException | SEL Fast Message only supports floating-point data.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCell ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCell ► IDCode
Gets or sets the ID code of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public uint IDCode { get; set; }
Public Property IDCode As UInteger
    Get
    Set
public:
property unsigned int IDCode {
    unsigned int get ();
    void set (unsigned int value);
}


MaximumStationNameLength Property

MaximumStationNameLength Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCell ► MaximumStationNameLength
Gets the maximum length of the StationName of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override int MaximumStationNameLength { get; }
Public Overrides ReadOnly Property MaximumStationNameLength As Integer
    Get
public:
virtual property int MaximumStationNameLength {
    int get () override;
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCell ► Parent
Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame Parent { get; set; }
Public Property Parent As ConfigurationFrame
    Get
    Set
public:
property ConfigurationFrame^ Parent {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}


PhasorCoordinateFormat Property

PhasorCoordinateFormat Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCell ► PhasorCoordinateFormat
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override CoordinateFormat PhasorCoordinateFormat { get; set; }
Public Overrides Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () override;
    void set (CoordinateFormat value) override;
}
Remarks
This property only supports polar phasor data; SEL Fast Message doesn't transport rectangular phasor values.
Exceptions
Exception | Condition
NotSupportedException | SEL Fast Message only supports polar phasor data.


PhasorDataFormat Property

PhasorDataFormat Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCell ► PhasorDataFormat
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataFormat PhasorDataFormat { get; set; }
Public Overrides Property PhasorDataFormat As DataFormat
    Get
    Set
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}
Remarks
This property only supports floating-point data; SEL Fast Message doesn't transport scaled values.
Exceptions
Exception | Condition
NotSupportedException | SEL Fast Message only supports floating-point data.


ConfigurationCellCollection Class

ConfigurationCellCollection Class
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCellCollection
Represents a SEL Fast Message implementation of a collection of IConfigurationCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationCellCollection : ConfigurationCellCollection
<SerializableAttribute> _
Public Class ConfigurationCellCollection _
    Inherits ConfigurationCellCollection
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ConfigurationCellCollection
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationCellCollection()()()() | Creates a new ConfigurationCellCollection.
 | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | IndexOfIDCode(UInt16) | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
 | IndexOfIDLabel(String) | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
 | IndexOfStationName(String) | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets ConfigurationCell at specified index.
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IConfigurationCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetByIDCode(UInt16, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
 | TryGetByIDLabel(String, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
 | TryGetByStationName(String, IConfigurationCell%) | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IConfigurationCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' IConfigurationCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationCellCollection
 |  |  |  |  | ConfigurationCellCollection


ConfigurationCellCollection Constructor

ConfigurationCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCellCollection ► ConfigurationCellCollection()()()()
Members
Icon | Member | Description
 | ConfigurationCellCollection()()()() | Creates a new ConfigurationCellCollection.
 | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.


ConfigurationCellCollection Constructor

ConfigurationCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCellCollection ► ConfigurationCellCollection()()()()
Creates a new ConfigurationCellCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellCollection()
Public Sub New
public:
ConfigurationCellCollection()


ConfigurationCellCollection Constructor (info, context)

ConfigurationCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCellCollection ► ConfigurationCellCollection(SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


Item Property (index)

Item Property (index)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCellCollection ► Item[([( Int32])])
Gets or sets ConfigurationCell at specified index.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ConfigurationCell
    Get
    Set
public:
property ConfigurationCell^ default[int index] {
    ConfigurationCell^ get (int index);
    void set (int index, ConfigurationCell^ value);
}
Parameters
index (Int32)
Index of value to get or set.


ConfigurationFrame Class

ConfigurationFrame Class
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationFrame
Represents the SEL Fast Message implementation of a IConfigurationFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConfigurationFrame : ConfigurationFrameBase
<SerializableAttribute> _
Public Class ConfigurationFrame _
    Inherits ConfigurationFrameBase
[SerializableAttribute]
public ref class ConfigurationFrame : public ConfigurationFrameBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationFrame(FrameSize, MessagePeriod, UInt32) | Creates a new ConfigurationFrame.
 | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrame object. (Overrides ConfigurationFrameBase.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Method is not implemented. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>.ChecksumIsValid(array<Byte>[]()[][], Int32).)
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | FrameSize | Gets the SEL Fast Message frame size of this ConfigurationFrame.
 | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets or sets the ID code of this ConfigurationFrame.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessagePeriod | Gets defined MessagePeriod for SEL device.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SetNominalFrequency(LineFrequency) | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IConfigurationCell >)>)>
 |  |  |  | ConfigurationFrameBase
 |  |  |  |  | ConfigurationFrame


ConfigurationFrame Constructor

ConfigurationFrame Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationFrame ► ConfigurationFrame()()()()
Members
Icon | Member | Description
 | ConfigurationFrame(FrameSize, MessagePeriod, UInt32) | Creates a new ConfigurationFrame.
 | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.


ConfigurationFrame Constructor (info, context)

ConfigurationFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationFrame ► ConfigurationFrame(SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConfigurationFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConfigurationFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


ConfigurationFrame Constructor (frameSize, messagePeriod, idCode)

ConfigurationFrame Constructor (frameSize, messagePeriod, idCode)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationFrame ► ConfigurationFrame(FrameSize, MessagePeriod, UInt32)
Creates a new ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame(
    FrameSize frameSize,
    MessagePeriod messagePeriod,
    uint idCode
)
Public Sub New ( _
    frameSize As FrameSize, _
    messagePeriod As MessagePeriod, _
    idCode As UInteger _
)
public:
ConfigurationFrame(
    FrameSize frameSize,
    MessagePeriod messagePeriod,
    unsigned int idCode
)
Parameters
frameSize (FrameSize)
A FrameSize object.
messagePeriod (MessagePeriod)
A MessagePeriod object.
idCode (UInt32)
An UInt32 as the id code.
Remarks
This constructor is used by a consumer to generate a SEL Fast Message configuration frame.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationFrame ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the ConfigurationFrame object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Method is not implemented.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
A Byte buffer to read data from.
offset (Int32)
An Int32 offset to read from.
length (Int32)
An Int32 number of bytes to read.
Return Value
An UInt16 value for the checksum.
Exceptions
Exception | Condition
NotImplementedException | SEL Fast Message doesn't define a binary configuration frame - so no checksum is defined.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationFrame ► Cells
Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCellCollection Cells { get; }
Public ReadOnly Property Cells As ConfigurationCellCollection
    Get
public:
property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}


ChecksumIsValid Method (buffer, startIndex)

ChecksumIsValid Method (buffer, startIndex)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationFrame ► ChecksumIsValid(array<Byte>[]()[][], Int32)
Determines if checksum in the buffer is valid.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid ( _
    buffer As Byte(), _
    startIndex As Integer _
) As Boolean
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image to validate.
startIndex (Int32)
Start index into buffer to perform checksum.
Return Value
Flag that determines if checksum over buffer is valid.
Remarks
SEL Fast Message doesn't define a binary configuration frame - so no checksum is defined - this always returns true.


FrameSize Property

FrameSize Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationFrame ► FrameSize
Gets the SEL Fast Message frame size of this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public FrameSize FrameSize { get; }
Public ReadOnly Property FrameSize As FrameSize
    Get
public:
property FrameSize FrameSize {
    FrameSize get ();
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationFrame ► IDCode
Gets or sets the ID code of this ConfigurationFrame.
Declaration Syntax
C# Visual Basic Visual C++
public uint IDCode { get; set; }
Public Property IDCode As UInteger
    Get
    Set
public:
property unsigned int IDCode {
    unsigned int get ();
    void set (unsigned int value);
}


MessagePeriod Property

MessagePeriod Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationFrame ► MessagePeriod
Gets defined MessagePeriod for SEL device.
Declaration Syntax
C# Visual Basic Visual C++
public MessagePeriod MessagePeriod { get; }
Public ReadOnly Property MessagePeriod As MessagePeriod
    Get
public:
property MessagePeriod MessagePeriod {
    MessagePeriod get ();
}


ConnectionParameters Class

ConnectionParameters Class
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConnectionParameters
Represents the extra connection parameters required for a connection to a SEL device.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConnectionParameters : ConnectionParametersBase
<SerializableAttribute> _
Public Class ConnectionParameters _
    Inherits ConnectionParametersBase
[SerializableAttribute]
public ref class ConnectionParameters : public ConnectionParametersBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConnectionParameters()()()() | Creates a new ConnectionParameters.
 | ConnectionParameters(SerializationInfo, StreamingContext) | Creates a new ConnectionParameters from serialization parameters.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConnectionParametersBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessagePeriod | Gets or sets desired MessagePeriod for SEL device.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValuesAreValid | Determines if custom connection parameters are valid. (Inherited from ConnectionParametersBase.)
Remarks
This class is designed to be exposed by a "PropertyGrid" so a UI can request protocol specific connection parameters. As a result the CategoryAttribute and DescriptionAttribute elements should be defined for each of the exposed properties.
Inheritance Hierarchy
Object
 | ConnectionParametersBase
 |  | ConnectionParameters


ConnectionParameters Constructor

ConnectionParameters Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConnectionParameters ► ConnectionParameters()()()()
Members
Icon | Member | Description
 | ConnectionParameters()()()() | Creates a new ConnectionParameters.
 | ConnectionParameters(SerializationInfo, StreamingContext) | Creates a new ConnectionParameters from serialization parameters.


ConnectionParameters Constructor

ConnectionParameters Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConnectionParameters ► ConnectionParameters()()()()
Creates a new ConnectionParameters.
Declaration Syntax
C# Visual Basic Visual C++
public ConnectionParameters()
Public Sub New
public:
ConnectionParameters()


ConnectionParameters Constructor (info, context)

ConnectionParameters Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConnectionParameters ► ConnectionParameters(SerializationInfo, StreamingContext)
Creates a new ConnectionParameters from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected ConnectionParameters(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConnectionParameters(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConnectionParameters ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


MessagePeriod Property

MessagePeriod Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConnectionParameters ► MessagePeriod
Gets or sets desired MessagePeriod for SEL device.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(typeof(MessagePeriod), "DefaultRate")]
public MessagePeriod MessagePeriod { get; set; }
<DefaultValueAttribute(GetType(MessagePeriod), "DefaultRate")> _
Public Property MessagePeriod As MessagePeriod
    Get
    Set
[DefaultValueAttribute(typeof(MessagePeriod), L"DefaultRate")]
public:
property MessagePeriod MessagePeriod {
    MessagePeriod get ();
    void set (MessagePeriod value);
}


DataCell Class

DataCell Class
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell
Represents the SEL Fast Message implementation of a IDataCell that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataCell : DataCellBase
<SerializableAttribute> _
Public Class DataCell _
    Inherits DataCellBase
[SerializableAttribute]
public ref class DataCell : public DataCellBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
 | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
 | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
 | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
 | AnalogValues | Gets AnalogValueCollection of this DataCell. (Overrides DataCellBase.AnalogValues.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataCell object. (Overrides DataCellBase.Attributes.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
 | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
 | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
 | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBase.DataIsValid.)
 | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBase.DataSortingType.)
 | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBase.DeviceError.)
 | DigitalValues | Gets DigitalValueCollection of this DataCell. (Overrides DataCellBase.DigitalValues.)
 | Equals(Object) | Determines whether the specified object is equal to the DataCellBase. (Inherited from DataCellBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
 | GetHashCode()()()() | Serves as a hash function for the DataCellBase. (Inherited from DataCellBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DataCellBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | IDCode | Gets the numeric ID code for this DataCell.
 | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides DataCellBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
 | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
 | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
 | StatusFlags | Gets or sets status flags for this DataCell.
 | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBase.SynchronizationIsValid.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this DataCellBase. (Inherited from DataCellBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelCellBase
 |  |  |  | DataCellBase
 |  |  |  |  | DataCell


DataCell Constructor

DataCell Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell ► DataCell()()()()
Members
Icon | Member | Description
 | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
 | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
 | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.


DataCell Constructor (info, context)

DataCell Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell ► DataCell(SerializationInfo, StreamingContext)
Creates a new DataCell from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataCell(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DataCell Constructor (parent, configurationCell)

DataCell Constructor (parent, configurationCell)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell ► DataCell(IDataFrame, IConfigurationCell)
Creates a new DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell(
    IDataFrame parent,
    IConfigurationCell configurationCell
)
Public Sub New ( _
    parent As IDataFrame, _
    configurationCell As IConfigurationCell _
)
public:
DataCell(
    IDataFrame^ parent,
    IConfigurationCell^ configurationCell
)
Parameters
parent (IDataFrame)
The reference to parent IDataFrame of this DataCell.
configurationCell (IConfigurationCell)
The IConfigurationCell associated with this DataCell.


DataCell Constructor (parent, configurationCell, addEmptyValues)

DataCell Constructor (parent, configurationCell, addEmptyValues)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell ► DataCell(DataFrame, ConfigurationCell, Boolean)
Creates a new DataCell from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell(
    DataFrame parent,
    ConfigurationCell configurationCell,
    bool addEmptyValues
)
Public Sub New ( _
    parent As DataFrame, _
    configurationCell As ConfigurationCell, _
    addEmptyValues As Boolean _
)
public:
DataCell(
    DataFrame^ parent,
    ConfigurationCell^ configurationCell,
    bool addEmptyValues
)
Parameters
parent (DataFrame)
The reference to parent DataFrame of this DataCell.
configurationCell (ConfigurationCell)
The ConfigurationCell associated with this DataCell.
addEmptyValues (Boolean)
If true, adds empty values for each defined configuration cell definition.


AnalogValues Property

AnalogValues Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell ► AnalogValues
Gets AnalogValueCollection of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override AnalogValueCollection AnalogValues { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides ReadOnly Property AnalogValues As AnalogValueCollection
    Get
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property AnalogValueCollection^ AnalogValues {
    AnalogValueCollection^ get () override;
}
Remarks
SEL Fast Message doesn't define any analog values.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataCell object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


ConfigurationCell Property

ConfigurationCell Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell ► ConfigurationCell
Gets or sets the ConfigurationCell associated with this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationCell ConfigurationCell { get; set; }
Public Property ConfigurationCell As ConfigurationCell
    Get
    Set
public:
property ConfigurationCell^ ConfigurationCell {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


DataIsValid Property

DataIsValid Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell ► DataIsValid
Gets or sets flag that determines if data of this DataCell is valid.
Declaration Syntax
C# Visual Basic Visual C++
public override bool DataIsValid { get; set; }
Public Overrides Property DataIsValid As Boolean
    Get
    Set
public:
virtual property bool DataIsValid {
    bool get () override;
    void set (bool value) override;
}


DataSortingType Property

DataSortingType Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell ► DataSortingType
Gets or sets DataSortingType of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public override DataSortingType DataSortingType { get; set; }
Public Overrides Property DataSortingType As DataSortingType
    Get
    Set
public:
virtual property DataSortingType DataSortingType {
    DataSortingType get () override;
    void set (DataSortingType value) override;
}


DeviceError Property

DeviceError Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell ► DeviceError
Gets or sets flag that determines if source device of this DataCell is reporting an error.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override bool DeviceError { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides Property DeviceError As Boolean
    Get
    Set
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property bool DeviceError {
    bool get () override;
    void set (bool value) override;
}
Remarks
SEL Fast Message doesn't define bits for device error.


DigitalValues Property

DigitalValues Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell ► DigitalValues
Gets DigitalValueCollection of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override DigitalValueCollection DigitalValues { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overrides ReadOnly Property DigitalValues As DigitalValueCollection
    Get
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
virtual property DigitalValueCollection^ DigitalValues {
    DigitalValueCollection^ get () override;
}
Remarks
SEL Fast Message doesn't define any digital values.


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell ► IDCode
Gets the numeric ID code for this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public uint IDCode { get; }
Public ReadOnly Property IDCode As UInteger
    Get
public:
property unsigned int IDCode {
    unsigned int get ();
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell ► Parent
Gets or sets the reference to parent DataFrame of this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public DataFrame Parent { get; set; }
Public Property Parent As DataFrame
    Get
    Set
public:
property DataFrame^ Parent {
    DataFrame^ get ();
    void set (DataFrame^ value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


StatusFlags Property

StatusFlags Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell ► StatusFlags
Gets or sets status flags for this DataCell.
Declaration Syntax
C# Visual Basic Visual C++
public StatusFlags StatusFlags { get; set; }
Public Property StatusFlags As StatusFlags
    Get
    Set
public:
property StatusFlags StatusFlags {
    StatusFlags get ();
    void set (StatusFlags value);
}


SynchronizationIsValid Property

SynchronizationIsValid Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCell ► SynchronizationIsValid
Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock.
Declaration Syntax
C# Visual Basic Visual C++
public override bool SynchronizationIsValid { get; set; }
Public Overrides Property SynchronizationIsValid As Boolean
    Get
    Set
public:
virtual property bool SynchronizationIsValid {
    bool get () override;
    void set (bool value) override;
}


DataCellCollection Class

DataCellCollection Class
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCellCollection
Represents a SEL Fast Message implementation of a collection of IDataCell objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataCellCollection : DataCellCollection
<SerializableAttribute> _
Public Class DataCellCollection _
    Inherits DataCellCollection
[SerializableAttribute]
public ref class DataCellCollection : public DataCellCollection
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCellCollection()()()() | Creates a new DataCellCollection.
 | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this ChannelCellCollectionBase<(Of <(<'T>)>)> object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | BinaryImage | Gets the binary image of this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | ClearItems()()()() | Removes all elements from the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBase<(Of <(<'T>)>)> are constant. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBase<(Of <(<'T>)>)>.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Item[([( Int32])]) | Gets or sets DataCell at specified index.
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCollectionChanged(NotifyCollectionChangedEventArgs) | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | RefreshBinding()()()() | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' IDataCell >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the ChannelCollectionBase<(Of <(<'T>)>)>. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBase<(Of <(<'T>)>)>.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' IDataCell >)>)>
 |  | ChannelCollectionBase <(Of <(<' IDataCell >)>)>
 |  |  | ChannelCellCollectionBase <(Of <(<' IDataCell >)>)>
 |  |  |  | DataCellCollection
 |  |  |  |  | DataCellCollection


DataCellCollection Constructor

DataCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCellCollection ► DataCellCollection()()()()
Members
Icon | Member | Description
 | DataCellCollection()()()() | Creates a new DataCellCollection.
 | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.


DataCellCollection Constructor

DataCellCollection Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCellCollection ► DataCellCollection()()()()
Creates a new DataCellCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DataCellCollection()
Public Sub New
public:
DataCellCollection()


DataCellCollection Constructor (info, context)

DataCellCollection Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCellCollection ► DataCellCollection(SerializationInfo, StreamingContext)
Creates a new DataCellCollection from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


Item Property (index)

Item Property (index)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataCellCollection ► Item[([( Int32])])
Gets or sets DataCell at specified index.
Declaration Syntax
C# Visual Basic Visual C++
public DataCell this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DataCell
    Get
    Set
public:
property DataCell^ default[int index] {
    DataCell^ get (int index);
    void set (int index, DataCell^ value);
}
Parameters
index (Int32)
Index of value to get or set.


DataFrame Class

DataFrame Class
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame
Represents the SEL Fast Message implementation of a IDataFrame that can be sent or received.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataFrame : DataFrameBase, ISupportFrameImage<int>,
    ISupportBinaryImage
<SerializableAttribute> _
Public Class DataFrame _
    Inherits DataFrameBase _
    Implements ISupportFrameImage(Of Integer), ISupportBinaryImage
[SerializableAttribute]
public ref class DataFrame : public DataFrameBase,
    ISupportFrameImage<int>, ISupportBinaryImage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataFrame()()()() | Creates a new DataFrame.
 | DataFrame(Ticks, FrameSize, UInt32) | Creates a new DataFrame from specified parameters.
 | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
 | AppendChecksum(array<Byte>[]()[][], Int32) | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataFrame object. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.Attributes.)
 | BinaryImage | Gets the binary image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyImage | Gets the binary body image of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CalculateChecksum(array<Byte>[]()[][], Int32, Int32) | Calculates checksum of given buffer. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.CalculateChecksum(array<Byte>[]()[][], Int32, Int32).)
 | Cells | Gets reference to the DataCellCollection for this DataFrame.
 | ChecksumIsValid(array<Byte>[]()[][], Int32) | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CommonHeader | Gets or sets current CommonFrameHeader.
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
 | CopyImage(ISupportBinaryImage, array<Byte>[]()[][], Int32%) | This is a common optimized block copy function for any kind of data. (Inherited from Common.)
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | FrameSize | Gets or sets the SEL Fast Message frame size of this DataFrame.
 | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides BinaryImageBase.HeaderImage()()()().)
 | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBase.HeaderLength()()()().)
 | IDCode | Gets or sets the SEL Fast Message destination address (PMADDR setting) for this DataFrame.
 | Initialize(array<Byte>[]()[][], Int32, Int32) | Parses the binary image. (Inherited from DataFrameBase.)
 | LastSortedMeasurement | Gets ot sets reference to last IMeasurement that was sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | Measurements | Keyed measurements in this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary header image. (Overrides BinaryImageBase.ParseHeaderImage(array<Byte>[]()[][], Int32, Int32).)
 | Published | Gets or sets published state of this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was published (post-processing). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBase<(Of <(<'T>)>)> was received (i.e., created). (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBase<(Of <(<'T>)>)>. (Inherited from ChannelFrameBase<(Of <(<'T>)>)>.)
 | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame. (Overrides ChannelFrameBase <(Of <(<' IDataCell >)>)>.Timestamp.)
 | TimeTag | Gets the timestamp of this frame in NTP format.
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeID | Gets the identifier that is used to identify the SEL Fast Message frame.
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelFrameBase <(Of <(<' IDataCell >)>)>
 |  |  |  | DataFrameBase
 |  |  |  |  | DataFrame


DataFrame Constructor

DataFrame Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► DataFrame()()()()
Members
Icon | Member | Description
 | DataFrame()()()() | Creates a new DataFrame.
 | DataFrame(Ticks, FrameSize, UInt32) | Creates a new DataFrame from specified parameters.
 | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.


DataFrame Constructor

DataFrame Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► DataFrame()()()()
Creates a new DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public DataFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Sub New
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
DataFrame()
Remarks
This constructor is used by FrameImageParserBase to parse a SEL Fast Message data frame.


DataFrame Constructor (info, context)

DataFrame Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► DataFrame(SerializationInfo, StreamingContext)
Creates a new DataFrame from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected DataFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DataFrame(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


DataFrame Constructor (timestamp, frameSize, idCode)

DataFrame Constructor (timestamp, frameSize, idCode)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► DataFrame(Ticks, FrameSize, UInt32)
Creates a new DataFrame from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public DataFrame(
    Ticks timestamp,
    FrameSize frameSize,
    uint idCode
)
Public Sub New ( _
    timestamp As Ticks, _
    frameSize As FrameSize, _
    idCode As UInteger _
)
public:
DataFrame(
    Ticks timestamp,
    FrameSize frameSize,
    unsigned int idCode
)
Parameters
timestamp (Ticks)
The exact timestamp, in Ticks, of the data represented by this DataFrame.
frameSize (FrameSize)
The SEL Fast Message frame size of this DataFrame.
idCode (UInt32)
The SEL Fast Message destination address (PMADDR setting) for this DataFrame
Remarks
This constructor is used by a consumer to generate a SEL Fast Message data frame.


Attributes Property

Attributes Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► Attributes
Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the DataFrame object.
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}


CalculateChecksum Method (buffer, offset, length)

CalculateChecksum Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► CalculateChecksum(array<Byte>[]()[][], Int32, Int32)
Calculates checksum of given buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As UShort
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer image over which to calculate checksum.
offset (Int32)
Start index into buffer to calculate checksum.
length (Int32)
Length of data within buffer to calculate checksum.
Return Value
Checksum over specified portion of buffer.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► Cells
Gets reference to the DataCellCollection for this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public DataCellCollection Cells { get; }
Public ReadOnly Property Cells As DataCellCollection
    Get
public:
property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}


CommonHeader Property

CommonHeader Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► CommonHeader
Gets or sets current CommonFrameHeader.
Declaration Syntax
C# Visual Basic Visual C++
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► ConfigurationFrame
Gets or sets ConfigurationFrame associated with this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationFrame ConfigurationFrame { get; set; }
Public Property ConfigurationFrame As ConfigurationFrame
    Get
    Set
public:
property ConfigurationFrame^ ConfigurationFrame {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}


FrameSize Property

FrameSize Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► FrameSize
Gets or sets the SEL Fast Message frame size of this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public FrameSize FrameSize { get; set; }
Public Property FrameSize As FrameSize
    Get
    Set
public:
property FrameSize FrameSize {
    FrameSize get ();
    void set (FrameSize value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination StreamingContext for this serialization.


HeaderImage Property

HeaderImage Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► HeaderImage
Gets the binary header image of the DataFrame object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}


HeaderLength Property

HeaderLength Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► HeaderLength
Gets the length of the HeaderImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
protected:
virtual property int HeaderLength {
    int get () override;
}


IDCode Property

IDCode Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► IDCode
Gets or sets the SEL Fast Message destination address (PMADDR setting) for this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public uint IDCode { get; set; }
Public Property IDCode As UInteger
    Get
    Set
public:
property unsigned int IDCode {
    unsigned int get ();
    void set (unsigned int value);
}


ParseHeaderImage Method (binaryImage, startIndex, length)

ParseHeaderImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► ParseHeaderImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary header image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseHeaderImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


Timestamp Property

Timestamp Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► Timestamp
Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame.
Declaration Syntax
C# Visual Basic Visual C++
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.


TimeTag Property

TimeTag Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► TimeTag
Gets the timestamp of this frame in NTP format.
Declaration Syntax
C# Visual Basic Visual C++
public NtpTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As NtpTimeTag
    Get
public:
property NtpTimeTag^ TimeTag {
    NtpTimeTag^ get ();
}


TypeID Property

TypeID Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► TypeID
Gets the identifier that is used to identify the SEL Fast Message frame.
Declaration Syntax
C# Visual Basic Visual C++
public int TypeID { get; }
Public ReadOnly Property TypeID As Integer
    Get
public:
virtual property int TypeID {
    int get () sealed;
}


DeviceCommand Enumeration

DeviceCommand Enumeration
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DeviceCommand
SEL Fast Message device commands enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum DeviceCommand
<SerializableAttribute> _
Public Enumeration DeviceCommand
[SerializableAttribute]
public enum class DeviceCommand
Members
Member | Description
EnableUnsolicitedMessages | Enable unsolicited write messages.
DisableUnsolicitedMessages | Disable unsolicited write messages.
Undefined | Undefined command.


FrameParser Class

FrameParser Class
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser
Represents a frame parser for a SEL Fast Message binary data stream that returns parsed data via events.
Declaration Syntax
C# Visual Basic Visual C++
public class FrameParser : FrameParserBase<int>
Public Class FrameParser _
    Inherits FrameParserBase(Of Integer)
public ref class FrameParser : public FrameParserBase<int>
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrameParser()()()() | Creates a new FrameParser.
 | FrameParser(MessagePeriod) | Creates a new FrameParser from specified parameters.
 | BeginRead(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead()()()() | (Inherited from BinaryImageParserBase.)
 | CanSeek()()()() | (Inherited from BinaryImageParserBase.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite()()()() | (Inherited from BinaryImageParserBase.)
 | Close()()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBase <(Of <(<' Int32 >)>)>.ConfigurationFrame.)
 | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Overrides FrameParserBase <(Of <(<' Int32 >)>)>.ConnectionParameters.)
 | CreateBufferQueue()()()() | Creates the internal buffer queue. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | DataDiscarded()()()() | (Inherited from BinaryImageParserBase.)
 | DataParsed()()()() | (Inherited from FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBase<(Of <(<'TFrameIdentifier>)>)> object and optionally releases the managed resources. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | DuplicateTypeHandlerEncountered()()()() | (Inherited from FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.)
 | Enabled()()()() | (Inherited from BinaryImageParserBase.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteParseOnSeparateThread | Gets or sets a flag that allows frame parsing to be executed on a separate thread (i.e., other than communications thread). (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()()() | Clears all buffers for this stream and causes any buffered data to be parsed immediately. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length()()()() | (Inherited from BinaryImageParserBase.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessagePeriod | Gets or sets the desired message period for the SEL device.
 | Name()()()() | (Inherited from BinaryImageParserBase.)
 | OnConfigurationChanged()()()() | Raises the ConfigurationChanged event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnDataDiscarded(array<Byte>[]()[][]) | (Inherited from BinaryImageParserBase.)
 | OnDataParsed(UTP) | (Inherited from FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.)
 | OnDuplicateTypeHandlerEncountered(Type, UTP) | (Inherited from FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.)
 | OnOutputTypeNotFound(UTP) | (Inherited from FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.)
 | OnParsingException(Exception) | (Inherited from BinaryImageParserBase.)
 | OnReceivedChannelFrame(IChannelFrame) | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame). (Overrides FrameParserBase <(Of <(<' Int32 >)>)>.OnReceivedChannelFrame(IChannelFrame).)
 | OnReceivedCommandFrame(ICommandFrame) | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedConfigurationFrame(IConfigurationFrame) | Raises the ReceivedConfigurationFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedDataFrame(IDataFrame) | Raises the ReceivedDataFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedFrameBufferImage(FundamentalFrameType, array<Byte>[]()[][], Int32, Int32) | Raises the ReceivedFrameBufferImage event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedHeaderFrame(IHeaderFrame) | Raises the ReceivedHeaderFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnReceivedUndeterminedFrame(IChannelFrame) | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OnUnknownFrameTypeEncountered(TFrameIdentifier) | Handles unknown frame types. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | OutputTypeNotFound()()()() | (Inherited from FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.)
 | Parse(ISupportBinaryImage) | (Inherited from BinaryImageParserBase.)
 | ParseCommonHeader(array<Byte>[]()[][], Int32, Int32) | Parses a common header instance that implements ICommonHeader for the output type represented in the binary image. (Overrides FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.ParseCommonHeader(array<Byte>[]()[][], Int32, Int32).)
 | ParseFrame(array<Byte>[]()[][], Int32, Int32) | (Inherited from FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.)
 | ParseQueuedBuffers(array<array<Byte>[]()[][]>[]()[][]) | This method is used by the internal ProcessQueue to process all queued data buffers. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ParsingException()()()() | (Inherited from BinaryImageParserBase.)
 | Position()()()() | (Inherited from BinaryImageParserBase.)
 | ProtocolSyncBytes()()()() | (Inherited from BinaryImageParserBase.)
 | ProtocolUsesSyncBytes | Gets flag that determines if SEL Fast Message protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBase.ProtocolUsesSyncBytes()()()().)
 | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Read(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageParserBase.)
 | ReadByte()()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | ReceivedCommandFrame | Occurs when a ICommandFrame has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ReceivedConfigurationFrame | Occurs when a SEL Fast Message ConfigurationFrame has been received.
 | ReceivedDataFrame | Occurs when a SEL Fast Message DataFrame has been received.
 | ReceivedFrameBufferImage | Occurs when a frame buffer image has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | RunTime()()()() | (Inherited from BinaryImageParserBase.)
 | Seek(Int64, SeekOrigin) | (Inherited from BinaryImageParserBase.)
 | SetLength(Int64) | (Inherited from BinaryImageParserBase.)
 | Start()()()() | Start the data parser. (Overrides FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.Start()()()().)
 | Start(IEnumerable<(Of <<'(Type>)>>)) | Starts the frame parser given the specified type implementations. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | Status | Gets current descriptive status of the FrameParser. (Overrides FrameParserBase <(Of <(<' Int32 >)>)>.Status.)
 | Stop()()()() | Stops the frame parser. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | StreamInitialized()()()() | (Inherited from BinaryImageParserBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalProcessedBuffers()()()() | (Inherited from BinaryImageParserBase.)
 | UnparsedBuffer()()()() | (Inherited from BinaryImageParserBase.)
 | Write(array<Byte>[]()[][], Int32, Int32) | Writes a sequence of bytes onto the stream for parsing. (Inherited from FrameParserBase<(Of <(<'TFrameIdentifier>)>)>.)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks
Frame parser is implemented as a write-only stream - this way data can come from any source.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | BinaryImageParserBase
 |  |  |  | FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>
 |  |  |  |  | FrameParserBase <(Of <(<' Int32 >)>)>
 |  |  |  |  |  | FrameParser


FrameParser Constructor

FrameParser Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser ► FrameParser()()()()
Members
Icon | Member | Description
 | FrameParser()()()() | Creates a new FrameParser.
 | FrameParser(MessagePeriod) | Creates a new FrameParser from specified parameters.


FrameParser Constructor

FrameParser Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser ► FrameParser()()()()
Creates a new FrameParser.
Declaration Syntax
C# Visual Basic Visual C++
public FrameParser()
Public Sub New
public:
FrameParser()


FrameParser Constructor (messagePeriod)

FrameParser Constructor (messagePeriod)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser ► FrameParser(MessagePeriod)
Creates a new FrameParser from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrameParser(
    MessagePeriod messagePeriod
)
Public Sub New ( _
    messagePeriod As MessagePeriod _
)
public:
FrameParser(
    MessagePeriod messagePeriod
)
Parameters
messagePeriod (MessagePeriod)
The desired MessagePeriod for SEL device connection.


ConfigurationFrame Property

ConfigurationFrame Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser ► ConfigurationFrame
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
Declaration Syntax
C# Visual Basic Visual C++
public override IConfigurationFrame ConfigurationFrame { get; set; }
Public Overrides Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () override;
    void set (IConfigurationFrame^ value) override;
}
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.


ConnectionParameters Property

ConnectionParameters Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser ► ConnectionParameters
Gets or sets any connection specific IConnectionParameters that may be needed for parsing.
Declaration Syntax
C# Visual Basic Visual C++
public override IConnectionParameters ConnectionParameters { get; set; }
Public Overrides Property ConnectionParameters As IConnectionParameters
    Get
    Set
public:
virtual property IConnectionParameters^ ConnectionParameters {
    IConnectionParameters^ get () override;
    void set (IConnectionParameters^ value) override;
}


MessagePeriod Property

MessagePeriod Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser ► MessagePeriod
Gets or sets the desired message period for the SEL device.
Declaration Syntax
C# Visual Basic Visual C++
public MessagePeriod MessagePeriod { get; set; }
Public Property MessagePeriod As MessagePeriod
    Get
    Set
public:
property MessagePeriod MessagePeriod {
    MessagePeriod get ();
    void set (MessagePeriod value);
}


OnReceivedChannelFrame Method (frame)

OnReceivedChannelFrame Method (frame)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser ► OnReceivedChannelFrame(IChannelFrame)
Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame).
Declaration Syntax
C# Visual Basic Visual C++
protected override void OnReceivedChannelFrame(
    IChannelFrame frame
)
Protected Overrides Sub OnReceivedChannelFrame ( _
    frame As IChannelFrame _
)
protected:
virtual void OnReceivedChannelFrame(
    IChannelFrame^ frame
) override
Parameters
frame (IChannelFrame)
IChannelFrame that was parsed by FrameImageParserBase that implements protocol specific common frame header interface.


ParseCommonHeader Method (buffer, offset, length)

ParseCommonHeader Method (buffer, offset, length)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser ► ParseCommonHeader(array<Byte>[]()[][], Int32, Int32)
Parses a common header instance that implements ICommonHeader for the output type represented in the binary image.
Declaration Syntax
C# Visual Basic Visual C++
protected override ICommonHeader<int> ParseCommonHeader(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function ParseCommonHeader ( _
    buffer As Byte(), _
    offset As Integer, _
    length As Integer _
) As ICommonHeader(Of Integer)
protected:
virtual ICommonHeader<int>^ ParseCommonHeader(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override
Parameters
buffer (array< Byte >[]()[][])
Buffer containing data to parse.
offset (Int32)
Offset index into buffer that represents where to start parsing.
length (Int32)
Maximum length of valid data from offset.
Return Value
The ICommonHeader which includes a type ID for the Type to be parsed.
Remarks

Derived classes need to provide a common header instance (i.e., class that implements ICommonHeader) for the output types; this will primarily include an ID of the Type that the data image represents. This parsing is only for common header information, actual parsing will be handled by output type via its Initialize(array<Byte>[]()[][], Int32, Int32) method. This header image should also be used to add needed complex state information about the output type being parsed if needed.

If there is not enough buffer available to parse common header (as determined by length), return null. Also, if the protocol allows frame length to be determined at the time common header is being parsed and there is not enough buffer to parse the entire frame, it will be optimal to prevent further parsing by returning null.


ProtocolUsesSyncBytes Property

ProtocolUsesSyncBytes Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser ► ProtocolUsesSyncBytes
Gets flag that determines if SEL Fast Message protocol parsing implementation uses synchronization bytes.
Declaration Syntax
C# Visual Basic Visual C++
public override bool ProtocolUsesSyncBytes { get; }
Public Overrides ReadOnly Property ProtocolUsesSyncBytes As Boolean
    Get
public:
virtual property bool ProtocolUsesSyncBytes {
    bool get () override;
}


ReceivedConfigurationFrame Event

ReceivedConfigurationFrame Event
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser ► ReceivedConfigurationFrame
Occurs when a SEL Fast Message ConfigurationFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<ConfigurationFrame>> ReceivedConfigurationFrame
Public Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of ConfigurationFrame))
public:
 event EventHandler<EventArgs<ConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
}
Remarks
Argument()()()() is the ConfigurationFrame that was received.


ReceivedDataFrame Event

ReceivedDataFrame Event
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser ► ReceivedDataFrame
Occurs when a SEL Fast Message DataFrame has been received.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs<DataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of DataFrame))
public:
 event EventHandler<EventArgs<DataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<DataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<DataFrame^>^>^ value);
}
Remarks
Argument()()()() is the DataFrame that was received.


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser ► Start()()()()
Start the data parser.
Declaration Syntax
C# Visual Basic Visual C++
public override void Start()
Public Overrides Sub Start
public:
virtual void Start() override


Status Property

Status Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser ► Status
Gets current descriptive status of the FrameParser.
Declaration Syntax
C# Visual Basic Visual C++
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
public:
virtual property String^ Status {
    String^ get () override;
}


FrameSize Enumeration

FrameSize Enumeration
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameSize
SEL Fast Message PMDATA setting frame size enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum FrameSize
<SerializableAttribute> _
Public Enumeration FrameSize
[SerializableAttribute]
public enum class FrameSize
Members
Member | Description
V1 | Positive sequence voltage phasor.
V | Three-phase and positive sequence voltage phasors.
A | Three-phase and positive sequence voltage and current phasors.


FrequencyDefinition Class

FrequencyDefinition Class
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyDefinition
Represents the SEL Fast Message implementation of a IFrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FrequencyDefinition : FrequencyDefinitionBase
<SerializableAttribute> _
Public Class FrequencyDefinition _
    Inherits FrequencyDefinitionBase
[SerializableAttribute]
public ref class FrequencyDefinition : public FrequencyDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
 | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
 | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | FrequencyDefinitionBase
 |  |  |  |  | FrequencyDefinition


FrequencyDefinition Constructor

FrequencyDefinition Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyDefinition ► FrequencyDefinition()()()()
Members
Icon | Member | Description
 | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
 | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
 | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.


FrequencyDefinition Constructor (info, context)

FrequencyDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyDefinition ► FrequencyDefinition(SerializationInfo, StreamingContext)
Creates a new FrequencyDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrequencyDefinition Constructor (parent)

FrequencyDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyDefinition ► FrequencyDefinition(IConfigurationCell)
Creates a new FrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
FrequencyDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this FrequencyDefinition.


FrequencyDefinition Constructor (parent, label)

FrequencyDefinition Constructor (parent, label)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyDefinition ► FrequencyDefinition(ConfigurationCell, String)
Creates a new FrequencyDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String _
)
public:
FrequencyDefinition(
    ConfigurationCell^ parent,
    String^ label
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this FrequencyDefinition.
label (String)
The label of this FrequencyDefinition.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyDefinition ► Parent
Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


FrequencyValue Class

FrequencyValue Class
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyValue
Represents the SEL Fast Message implementation of a IFrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FrequencyValue : FrequencyValueBase
<SerializableAttribute> _
Public Class FrequencyValue _
    Inherits FrequencyValueBase
[SerializableAttribute]
public ref class FrequencyValue : public FrequencyValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
 | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
 | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
 | Attributes | Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the FrequencyValue object. (Overrides FrequencyValueBase.BodyImage.)
 | BodyLength | Gets the length of the BodyImage. (Overrides FrequencyValueBase.BodyLength.)
 | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
 | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this FrequencyValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides FrequencyValueBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
 | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IFrequencyDefinition >)>)>
 |  |  |  | FrequencyValueBase
 |  |  |  |  | FrequencyValue


FrequencyValue Constructor

FrequencyValue Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyValue ► FrequencyValue()()()()
Members
Icon | Member | Description
 | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
 | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
 | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.


FrequencyValue Constructor (info, context)

FrequencyValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyValue ► FrequencyValue(SerializationInfo, StreamingContext)
Creates a new FrequencyValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected FrequencyValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
FrequencyValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


FrequencyValue Constructor (parent, frequencyDefinition)

FrequencyValue Constructor (parent, frequencyDefinition)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyValue ► FrequencyValue(IDataCell, IFrequencyDefinition)
Creates a new FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyValue(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    frequencyDefinition As IFrequencyDefinition _
)
public:
FrequencyValue(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this FrequencyValue.
frequencyDefinition (IFrequencyDefinition)
The IFrequencyDefinition associated with this FrequencyValue.


FrequencyValue Constructor (parent, frequencyDefinition, frequency, dfdt)

FrequencyValue Constructor (parent, frequencyDefinition, frequency, dfdt)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyValue ► FrequencyValue(DataCell, FrequencyDefinition, Double, Double)
Creates a new FrequencyValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public FrequencyValue(
    DataCell parent,
    FrequencyDefinition frequencyDefinition,
    double frequency,
    double dfdt
)
Public Sub New ( _
    parent As DataCell, _
    frequencyDefinition As FrequencyDefinition, _
    frequency As Double, _
    dfdt As Double _
)
public:
FrequencyValue(
    DataCell^ parent,
    FrequencyDefinition^ frequencyDefinition,
    double frequency,
    double dfdt
)
Parameters
parent (DataCell)
The DataCell parent of this FrequencyValue.
frequencyDefinition (FrequencyDefinition)
The FrequencyDefinition associated with this FrequencyValue.
frequency (Double)
The floating point value that represents this FrequencyValue.
dfdt (Double)
The floating point value that represents the change in this FrequencyValue over time.


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyValue ► BodyImage
Gets the binary body image of the FrequencyValue object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyValue ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}
Remarks
The SEL Fast Message protocol provides frequency and df/dt as optional data measurements, so we override the default behavior to account for this change in operation.


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyValue ► Definition
Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual FrequencyDefinition Definition { get; set; }
Public Overridable Property Definition As FrequencyDefinition
    Get
    Set
public:
virtual property FrequencyDefinition^ Definition {
    FrequencyDefinition^ get ();
    void set (FrequencyDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyValue ► Parent
Gets or sets the DataCell parent of this FrequencyValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyValue ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


MessagePeriod Enumeration

MessagePeriod Enumeration
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► MessagePeriod
SEL Fast Message frame rate enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public enum MessagePeriod
<SerializableAttribute> _
Public Enumeration MessagePeriod
[SerializableAttribute]
public enum class MessagePeriod
Members
Member | Description
DefaultRate | Default message rate, 20 messages per second.
TwentyPerSecond | 20 messages per second.
TenPerSecond | 10 messages per second.
FivePerSecond | 5 messages per second.
FourPerSecond | 4 messages per second.
TwoPerSecond | 2 messages per second.
OnePerSecond | 1 packet per second, or 60 messages per minute.
ThirtyPerMinute | 30 messages per minute, or 1/2 packet per second.
TwentyPerMinute | 20 messages per minute.
FifteenPerMinute | 15 messages per minute.
TwelvePerMinute | 12 messages per minute.
TenPerMinute | 10 messages per minute.
SixPerMinute | 6 messages per minute.
FourPerMinute | 4 messages per minute.
ThreePerMinute | 3 messages per minute.
TwoPerMinute | 2 messages per minute.
OnePerMinute | 1 message per minute.


PhasorDefinition Class

PhasorDefinition Class
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorDefinition
Represents the SEL Fast Message implementation of a IPhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PhasorDefinition : PhasorDefinitionBase
<SerializableAttribute> _
Public Class PhasorDefinition _
    Inherits PhasorDefinitionBase
[SerializableAttribute]
public ref class PhasorDefinition : public PhasorDefinitionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(ConfigurationCell, String, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
 | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
 | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
 | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelDefinitionBase
 |  |  |  | PhasorDefinitionBase
 |  |  |  |  | PhasorDefinition


PhasorDefinition Constructor

PhasorDefinition Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorDefinition ► PhasorDefinition()()()()
Members
Icon | Member | Description
 | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(ConfigurationCell, String, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
 | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.


PhasorDefinition Constructor (info, context)

PhasorDefinition Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorDefinition ► PhasorDefinition(SerializationInfo, StreamingContext)
Creates a new PhasorDefinition from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorDefinition(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


PhasorDefinition Constructor (parent)

PhasorDefinition Constructor (parent)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorDefinition ► PhasorDefinition(IConfigurationCell)
Creates a new PhasorDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinition(
    IConfigurationCell parent
)
Public Sub New ( _
    parent As IConfigurationCell _
)
public:
PhasorDefinition(
    IConfigurationCell^ parent
)
Parameters
parent (IConfigurationCell)
The IConfigurationCell parent of this PhasorDefinition.


PhasorDefinition Constructor (parent, label, type, voltageReference)

PhasorDefinition Constructor (parent, label, type, voltageReference)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorDefinition ► PhasorDefinition(ConfigurationCell, String, PhasorType, PhasorDefinition)
Creates a new PhasorDefinition from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorDefinition(
    ConfigurationCell parent,
    string label,
    PhasorType type,
    PhasorDefinition voltageReference
)
Public Sub New ( _
    parent As ConfigurationCell, _
    label As String, _
    type As PhasorType, _
    voltageReference As PhasorDefinition _
)
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    String^ label,
    PhasorType type,
    PhasorDefinition^ voltageReference
)
Parameters
parent (ConfigurationCell)
The ConfigurationCell parent of this PhasorDefinition.
label (String)
The label of this PhasorDefinition.
type (PhasorType)
The PhasorType of this PhasorDefinition.
voltageReference (PhasorDefinition)
The associated IPhasorDefinition that represents the voltage reference (if any).


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorDefinition ► Parent
Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}


PhasorValue Class

PhasorValue Class
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorValue
Represents the SEL Fast Message implementation of a IPhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PhasorValue : PhasorValueBase
<SerializableAttribute> _
Public Class PhasorValue _
    Inherits PhasorValueBase
[SerializableAttribute]
public ref class PhasorValue : public PhasorValueBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
 | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
 | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
 | Attributes | Gets a Dictionary<(Of <(<'TKey, TValue>)>)> of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
 | BinaryImage()()()() | (Inherited from BinaryImageBase.)
 | BinaryLength()()()() | (Inherited from BinaryImageBase.)
 | BodyImage | Gets the binary body image of the PhasorValueBase object. (Overrides PhasorValueBase.BodyImage.)
 | BodyLength | Gets the length of the BodyImage. (Overrides PhasorValueBase.BodyLength.)
 | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
 | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | DataFormat | Gets the DataFormat of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FooterImage()()()() | (Inherited from BinaryImageBase.)
 | FooterLength()()()() | (Inherited from BinaryImageBase.)
 | GetCompositeValue(Int32) | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMeasurementValueFilterFunction(Int32) | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderImage()()()() | (Inherited from BinaryImageBase.)
 | HeaderLength()()()() | (Inherited from BinaryImageBase.)
 | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | Initialize(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
 | Label | Gets text based label of this ChannelValueBase<(Of <(<'T>)>)>. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | Measurements | Gets the composite values of this ChannelValueBase<(Of <(<'T>)>)> as an array of IMeasurement values. (Inherited from ChannelValueBase<(Of <(<'T>)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets or sets the DataCell parent of this PhasorValue.
 | ParseBodyImage(array<Byte>[]()[][], Int32, Int32) | Parses the binary body image. (Overrides PhasorValueBase.ParseBodyImage(array<Byte>[]()[][], Int32, Int32).)
 | ParseFooterImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | ParseHeaderImage(array<Byte>[]()[][], Int32, Int32) | (Inherited from BinaryImageBase.)
 | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
 | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
 | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
 | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Inheritance Hierarchy
Object
 | BinaryImageBase
 |  | ChannelBase
 |  |  | ChannelValueBase <(Of <(<' IPhasorDefinition >)>)>
 |  |  |  | PhasorValueBase
 |  |  |  |  | PhasorValue


PhasorValue Constructor

PhasorValue Constructor
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorValue ► PhasorValue()()()()
Members
Icon | Member | Description
 | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
 | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
 | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.


PhasorValue Constructor (info, context)

PhasorValue Constructor (info, context)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorValue ► PhasorValue(SerializationInfo, StreamingContext)
Creates a new PhasorValue from serialization parameters.
Declaration Syntax
C# Visual Basic Visual C++
protected PhasorValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
PhasorValue(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo with populated with data.
context (StreamingContext)
The source StreamingContext for this deserialization.


PhasorValue Constructor (parent, phasorDefinition)

PhasorValue Constructor (parent, phasorDefinition)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorValue ► PhasorValue(IDataCell, IPhasorDefinition)
Creates a new PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    IDataCell parent,
    IPhasorDefinition phasorDefinition
)
Public Sub New ( _
    parent As IDataCell, _
    phasorDefinition As IPhasorDefinition _
)
public:
PhasorValue(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition
)
Parameters
parent (IDataCell)
The IDataCell parent of this PhasorValue.
phasorDefinition (IPhasorDefinition)
The IPhasorDefinition associated with this PhasorValue.


PhasorValue Constructor (parent, phasorDefinition, real, imaginary)

PhasorValue Constructor (parent, phasorDefinition, real, imaginary)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorValue ► PhasorValue(DataCell, PhasorDefinition, Double, Double)
Creates a new PhasorValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    double real,
    double imaginary
)
Public Sub New ( _
    parent As DataCell, _
    phasorDefinition As PhasorDefinition, _
    real As Double, _
    imaginary As Double _
)
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    double real,
    double imaginary
)
Parameters
parent (DataCell)
The DataCell parent of this PhasorValue.
phasorDefinition (PhasorDefinition)
The PhasorDefinition associated with this PhasorValue.
real (Double)
The real value of this PhasorValue.
imaginary (Double)
The imaginary value of this PhasorValue.


PhasorValue Constructor (parent, phasorDefinition, angle, magnitude)

PhasorValue Constructor (parent, phasorDefinition, angle, magnitude)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorValue ► PhasorValue(DataCell, PhasorDefinition, Angle, Double)
Creates a new PhasorValue from specified parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    Angle angle,
    double magnitude
)
Public Sub New ( _
    parent As DataCell, _
    phasorDefinition As PhasorDefinition, _
    angle As Angle, _
    magnitude As Double _
)
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    Angle angle,
    double magnitude
)
Parameters
parent (DataCell)
The DataCell parent of this PhasorValue.
phasorDefinition (PhasorDefinition)
The PhasorDefinition associated with this PhasorValue.
angle (Angle)
The Angle value (a.k.a., the argument) of this PhasorValue, in radians.
magnitude (Double)
The magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue.


BodyImage Property

BodyImage Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorValue ► BodyImage
Gets the binary body image of the PhasorValueBase object.
Declaration Syntax
C# Visual Basic Visual C++
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}


BodyLength Property

BodyLength Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorValue ► BodyLength
Gets the length of the BodyImage.
Declaration Syntax
C# Visual Basic Visual C++
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
protected:
virtual property int BodyLength {
    int get () override;
}


Definition Property

Definition Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorValue ► Definition
Gets or sets the PhasorDefinition associated with this PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual PhasorDefinition Definition { get; set; }
Public Overridable Property Definition As PhasorDefinition
    Get
    Set
public:
virtual property PhasorDefinition^ Definition {
    PhasorDefinition^ get ();
    void set (PhasorDefinition^ value);
}


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorValue ► Parent
Gets or sets the DataCell parent of this PhasorValue.
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}


ParseBodyImage Method (binaryImage, startIndex, length)

ParseBodyImage Method (binaryImage, startIndex, length)
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorValue ► ParseBodyImage(array<Byte>[]()[][], Int32, Int32)
Parses the binary body image.
Declaration Syntax
C# Visual Basic Visual C++
protected override int ParseBodyImage(
    byte[] binaryImage,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage ( _
    binaryImage As Byte(), _
    startIndex As Integer, _
    length As Integer _
) As Integer
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
) override
Parameters
binaryImage (array< Byte >[]()[][])
Binary image to parse.
startIndex (Int32)
Start index into binaryImage to begin parsing.
length (Int32)
Length of valid data within binaryImage.
Return Value
The length of the data that was parsed.


StatusFlags Enumeration

StatusFlags Enumeration
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► StatusFlags
SEL Fast Message status word flags enumeration.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[FlagsAttribute]
public enum StatusFlags
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration StatusFlags
[SerializableAttribute]
[FlagsAttribute]
public enum class StatusFlags
Members
Member | Description
TSOK | Time synchronization OK, 1 when OK.
PMDOK | Phasor measurement data OK, 1 when OK.
PSV51 | User programmable bit 1.
PSV52 | User programmable bit 2.
PSV53 | User programmable bit 3.
PSV54 | User programmable bit 4.
PSV55 | User programmable bit 5.
PSV56 | User programmable bit 6.
PSV57 | User programmable bit 7.
PSV58 | User programmable bit 8.
PSV59 | User programmable bit 9.
PSV60 | User programmable bit 10.
PSV61 | User programmable bit 11.
PSV62 | User programmable bit 12.
PSV63 | User programmable bit 13.
PSV64 | User programmable bit 14.
NoFlags | No flags.


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameParser ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► Parent
Members
Icon | Member | Description
 | Parent | Gets a reference to the parent IConfigurationFrame for this IConfigurationCell.
 | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


OnStatusMessage Method

OnStatusMessage Method
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► OnStatusMessage()()()()
Members
Icon | Member | Description
 | OnStatusMessage(String) |
 | OnStatusMessage(String, array<Object>[]()[][]) |


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


OnStatusMessage Method

OnStatusMessage Method
Namespaces ► HistorianAdapters ► LocalOutputAdapter ► OnStatusMessage()()()()
Members
Icon | Member | Description
 | OnStatusMessage(String) |
 | OnStatusMessage(String, array<Object>[]()[][]) |

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► AnalogDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


Dispose Method

Dispose Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBase<(Of <(<'TFrameIdentifier>)>)> object and optionally releases the managed resources. (Overrides FrameImageParserBase<(Of <(<' TFrameIdentifier, ISupportFrameImage<(Of <(<' TFrameIdentifier >)>)>>)>)>.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Stream.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommandFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


GetSignalReference Method

GetSignalReference Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Concentrator ► GetSignalReference()()()()
Members
Icon | Member | Description
 | GetSignalReference(SignalKind) | Get signal reference for specified SignalKind.
 | GetSignalReference(SignalKind, Int32, Int32) | Get signal reference for specified SignalKind and index.


SetItem Method

SetItem Method
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionCollection ► SetItem()()()()
Members
Icon | Member | Description
 | SetItem(Int32, T) | Replaces the element at the specified index.
 | SetItem(Int32, T) | Replaces the element at the specified index. (Overrides Collection <(Of <(<' T >)>)>.SetItem(Int32, T).)


Value Property

Value Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► Value
Members
Icon | Member | Description
 | Value()()()() |
 | Value()()()() |


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrequencyDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Anonymous ► PhasorDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► CommandFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


OnStatusMessage Method

OnStatusMessage Method
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► OnStatusMessage()()()()
Members
Icon | Member | Description
 | OnStatusMessage(String) |
 | OnStatusMessage(String, array<Object>[]()[][]) |


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► IDigitalDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(T) | Compares the current object with another object of the same type.
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


OnStatusMessage Method

OnStatusMessage Method
Namespaces ► HistorianAdapters ► LocalInputAdapter ► OnStatusMessage()()()()
Members
Icon | Member | Description
 | OnStatusMessage(String) |
 | OnStatusMessage(String, array<Object>[]()[][]) |

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value.


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► IDataFrame ► State
Members
Icon | Member | Description
 | State | Gets or sets the parsing state for the this IDataFrame.
 | State | Gets or sets the parsing state for this IChannel object.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionBase ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


SetItem Method

SetItem Method
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionCollection ► SetItem()()()()
Members
Icon | Member | Description
 | SetItem(Int32, T) | Replaces the element at the specified index.
 | SetItem(Int32, T) | Replaces the element at the specified index. (Overrides Collection <(Of <(<' T >)>)>.SetItem(Int32, T).)


InsertItem Method

InsertItem Method
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionCollectionBase<(Of <(<'T>)>)> ► InsertItem()()()()
Members
Icon | Member | Description
 | InsertItem(Int32, T) | Inserts an element into the ChannelDefinitionCollectionBase<(Of <(<'T>)>)> at the specified index.
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Overrides Collection <(Of <(<' T >)>)>.InsertItem(Int32, T).)


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionBase ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► ICommandFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(T) | Compares the current object with another object of the same type.
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols ► CommandFrameBase ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DataFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► Start()()()()
Members
Icon | Member | Description
 | Start()()()() | Start the data parser. (Overrides FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.Start()()()().)
 | Start(IEnumerable<(Of <<'(Type>)>>)) | Starts the frame parser given the specified type implementations. (Overrides FrameImageParserBase<(Of <(<' TFrameIdentifier, ISupportFrameImage<(Of <(<' TFrameIdentifier >)>)>>)>)>.Start(IEnumerable<(Of <<'(Type>)>>)).)


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► IHeaderCell ► State
Members
Icon | Member | Description
 | State | Gets or sets the parsing state for the this ChannelCellBase.
 | State | Gets or sets the parsing state for this IChannel object.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameBase ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionBase ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols ► ICommandFrame ► Cells
Members
Icon | Member | Description
 | Cells | Gets reference to the CommandCellCollection for this ICommandFrame.
 | Cells | Gets the strongly-typed reference to the collection of cells for this IChannelFrame<(Of <(<'T>)>)>.
 | Cells | Gets the simple reference to the collection of cells for this IChannelFrame.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► PhasorDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► IFrequencyDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(T) | Compares the current object with another object of the same type.
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(T) | Compares the current object with another object of the same type.
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.FNet ► PhasorDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► IChannelFrame<(Of <(<'T>)>)> ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(T) | Compares the current object with another object of the same type.
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► IConfigurationFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(T) | Compares the current object with another object of the same type.
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser ► Start()()()()
Members
Icon | Member | Description
 | Start()()()() | Start the data parser. (Overrides FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.Start()()()().)
 | Start(IEnumerable<(Of <<'(Type>)>>)) | Starts the frame parser given the specified type implementations. (Overrides FrameImageParserBase<(Of <(<' TFrameIdentifier, ISupportFrameImage<(Of <(<' TFrameIdentifier >)>)>>)>)>.Start(IEnumerable<(Of <<'(Type>)>>)).)


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DigitalDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionBase ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCell ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values.


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► ICommandFrame ► State
Members
Icon | Member | Description
 | State | Gets or sets the parsing state for the this ICommandFrame.
 | State | Gets or sets the parsing state for this IChannelFrame<(Of <(<'T>)>)>.
 | State | Gets or sets the parsing state for this IChannel object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


SetItem Method

SetItem Method
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionCollection ► SetItem()()()()
Members
Icon | Member | Description
 | SetItem(Int32, T) | Replaces the element at the specified index.
 | SetItem(Int32, T) | Replaces the element at the specified index. (Overrides Collection <(Of <(<' T >)>)>.SetItem(Int32, T).)


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionBase ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► ICommandCell ► Parent
Members
Icon | Member | Description
 | Parent | Gets a reference to the parent ICommandFrame for this ICommandCell.
 | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Anonymous ► DigitalDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


OnStatusMessage Method

OnStatusMessage Method
Namespaces ► TVA.PhasorProtocols ► CalculatedMeasurementBase ► OnStatusMessage()()()()
Members
Icon | Member | Description
 | OnStatusMessage(String) |
 | OnStatusMessage(String, array<Object>[]()[][]) |


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Anonymous ► FrequencyDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► ICommandCell ► State
Members
Icon | Member | Description
 | State | Gets or sets the parsing state for the this ChannelCellBase.
 | State | Gets or sets the parsing state for this IChannel object.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Anonymous ► FrequencyDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionBase ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


OnStatusMessage Method

OnStatusMessage Method
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► OnStatusMessage()()()()
Members
Icon | Member | Description
 | OnStatusMessage(String) |
 | OnStatusMessage(String, array<Object>[]()[][]) |


InsertItem Method

InsertItem Method
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionCollection ► InsertItem()()()()
Members
Icon | Member | Description
 | InsertItem(Int32, T) | Inserts an element into the ChannelDefinitionCollectionBase<(Of <(<'T>)>)> at the specified index.
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Overrides Collection <(Of <(<' T >)>)>.InsertItem(Int32, T).)


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameParser ► Start()()()()
Members
Icon | Member | Description
 | Start()()()() | Start the data parser. (Overrides FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.Start()()()().)
 | Start(IEnumerable<(Of <<'(Type>)>>)) | Starts the frame parser given the specified type implementations. (Overrides FrameImageParserBase<(Of <(<' TFrameIdentifier, ISupportFrameImage<(Of <(<' TFrameIdentifier >)>)>>)>)>.Start(IEnumerable<(Of <<'(Type>)>>)).)


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols ► IDataFrame ► Cells
Members
Icon | Member | Description
 | Cells | Gets reference to the DataCellCollection for this IDataFrame.
 | Cells | Gets the simple reference to the collection of cells for this IChannelFrame.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► DataFrameBase ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► Parent
Members
Icon | Member | Description
 | Parent | Gets reference to parent IDataFrame of this IDataCell.
 | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► IPhasorDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(T) | Compares the current object with another object of the same type.
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► IChannelFrame<(Of <(<'T>)>)> ► State
Members
Icon | Member | Description
 | State | Gets or sets the parsing state for this IChannelFrame<(Of <(<'T>)>)>.
 | State | Gets or sets the parsing state for this IChannel object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values.


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► IChannelCell ► State
Members
Icon | Member | Description
 | State | Gets or sets the parsing state for the this ChannelCellBase.
 | State | Gets or sets the parsing state for this IChannel object.


OnStatusMessage Method

OnStatusMessage Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Concentrator ► OnStatusMessage()()()()
Members
Icon | Member | Description
 | OnStatusMessage(String) |
 | OnStatusMessage(String, array<Object>[]()[][]) |


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► HeaderFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


SetItem Method

SetItem Method
Namespaces ► TVA.PhasorProtocols ► PhasorDefinitionCollection ► SetItem()()()()
Members
Icon | Member | Description
 | SetItem(Int32, T) | Replaces the element at the specified index.
 | SetItem(Int32, T) | Replaces the element at the specified index. (Overrides Collection <(Of <(<' T >)>)>.SetItem(Int32, T).)


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► IDataCell ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(T) | Compares the current object with another object of the same type.
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCell ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


Dispose Method

Dispose Method
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose()()()() |
 | Dispose(Boolean) | Releases the unmanaged resources used by this RemoteOutputAdapter and optionally releases the managed resources. (Overrides OutputAdapterBase.Dispose(Boolean).)

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


GetEnumerator Method

GetEnumerator Method
Namespaces ► TVA.PhasorProtocols ► IChannelCellCollection<(Of <(<'T>)>)> ► GetEnumerator()()()()
Members
Icon | Member | Description
 | GetEnumerator()()()() | Returns an enumerator that iterates through the collection.
 | GetEnumerator()()()() | Returns an enumerator that iterates through a collection.


SetItem Method

SetItem Method
Namespaces ► TVA.PhasorProtocols ► ChannelDefinitionCollectionBase<(Of <(<'T>)>)> ► SetItem()()()()
Members
Icon | Member | Description
 | SetItem(Int32, T) | Replaces the element at the specified index.
 | SetItem(Int32, T) | Replaces the element at the specified index. (Overrides Collection <(Of <(<' T >)>)>.SetItem(Int32, T).)


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrameParser ► Start()()()()
Members
Icon | Member | Description
 | Start()()()() | Start the data parser. (Overrides FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.Start()()()().)
 | Start(IEnumerable<(Of <<'(Type>)>>)) | Starts the frame parser given the specified type implementations. (Overrides FrameImageParserBase<(Of <(<' TFrameIdentifier, ISupportFrameImage<(Of <(<' TFrameIdentifier >)>)>>)>)>.Start(IEnumerable<(Of <<'(Type>)>>)).)


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► IDataFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(T) | Compares the current object with another object of the same type.
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► CommandFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationCell ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Anonymous ► DigitalDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.FNet ► FrequencyDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


PaintValue Method

PaintValue Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► IniFileNameEditor ► PaintValue()()()()
Members
Icon | Member | Description
 | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas.
 | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationCell ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► HeaderFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols ► SignalReferenceMeasurement ► Equals()()()()
Members
Icon | Member | Description
 | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current SignalReferenceMeasurement.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.FNet ► DataFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


Dispose Method

Dispose Method
Namespaces ► TVA.PhasorProtocols ► CalculatedMeasurementBase ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.FNet ► FrequencyDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationCell ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols ► IHeaderFrame ► Cells
Members
Icon | Member | Description
 | Cells | Gets reference to the HeaderCellCollection for this IHeaderFrame.
 | Cells | Gets the simple reference to the collection of cells for this IChannelFrame.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► AnalogDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationCell ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values.


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► Start()()()()
Members
Icon | Member | Description
 | Start()()()() | Start the data parser. (Overrides FrameImageParserBase<(Of <(<' Int32, ISupportFrameImage<(Of <(<' Int32 >)>)>>)>)>.Start()()()().)
 | Start(IEnumerable<(Of <<'(Type>)>>)) | Starts the frame parser given the specified type implementations. (Overrides FrameImageParserBase<(Of <(<' TFrameIdentifier, ISupportFrameImage<(Of <(<' TFrameIdentifier >)>)>>)>)>.Start(IEnumerable<(Of <<'(Type>)>>)).)


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols ► DataFrameBase ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommandFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1 ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


InsertItem Method

InsertItem Method
Namespaces ► TVA.PhasorProtocols ► AnalogDefinitionCollection ► InsertItem()()()()
Members
Icon | Member | Description
 | InsertItem(Int32, T) | Inserts an element into the ChannelDefinitionCollectionBase<(Of <(<'T>)>)> at the specified index.
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Overrides Collection <(Of <(<' T >)>)>.InsertItem(Int32, T).)


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrequencyDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


Dispose Method

Dispose Method
Namespaces ► HistorianAdapters ► RemoteInputAdapter ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose()()()() |
 | Dispose(Boolean) | Releases the unmanaged resources used by this RemoteInputAdapter and optionally releases the managed resources. (Overrides InputAdapterBase.Dispose(Boolean).)

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► IHeaderFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(T) | Compares the current object with another object of the same type.
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► ConfigurationFrameBase ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


OnStatusMessage Method

OnStatusMessage Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Concentrator ► OnStatusMessage()()()()
Members
Icon | Member | Description
 | OnStatusMessage(String) |
 | OnStatusMessage(String, array<Object>[]()[][]) |


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationCell ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► PhasorDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► PhasorDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► DataFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


Dispose Method

Dispose Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► FrameParser ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBase<(Of <(<'TFrameIdentifier>)>)> object and optionally releases the managed resources. (Overrides FrameImageParserBase<(Of <(<' TFrameIdentifier, ISupportFrameImage<(Of <(<' TFrameIdentifier >)>)>>)>)>.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Stream.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrequencyDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DataFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


Dispose Method

Dispose Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrameParser ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParser object and optionally releases the managed resources. (Overrides FrameParserBase <(Of <(<' FrameType >)>)>.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Stream.


Dispose Method

Dispose Method
Namespaces ► HistorianAdapters ► LocalInputAdapter ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose()()()() |
 | Dispose(Boolean) | Releases the unmanaged resources used by the LocalInputAdapter object and optionally releases the managed resources. (Overrides InputAdapterBase.Dispose(Boolean).)

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► IDataCell ► State
Members
Icon | Member | Description
 | State | Gets or sets the parsing state for the this IDataCell.
 | State | Gets or sets the parsing state for the this ChannelCellBase.
 | State | Gets or sets the parsing state for this IChannel object.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► CommandFrameBase ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► DigitalDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame2 ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► IAnalogDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(T) | Compares the current object with another object of the same type.
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► IChannelFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(T) | Compares the current object with another object of the same type.
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.


Dispose Method

Dispose Method
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBase<(Of <(<'TFrameIdentifier>)>)> object and optionally releases the managed resources. (Overrides FrameImageParserBase<(Of <(<' TFrameIdentifier, ISupportFrameImage<(Of <(<' TFrameIdentifier >)>)>>)>)>.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Stream.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► ConfigurationFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► PhasorDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► IHeaderFrame ► State
Members
Icon | Member | Description
 | State | Gets or sets the parsing state for the this IHeaderFrame.
 | State | Gets or sets the parsing state for this IChannel object.


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationFrame ► State
Members
Icon | Member | Description
 | State | Gets or sets the parsing state for the this IConfigurationFrame.
 | State | Gets or sets the parsing state for this IChannel object.


Dispose Method

Dispose Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Concentrator ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose()()()() |
 | Dispose(Boolean) | Releases the unmanaged resources used by the PhasorDataConcentratorBase object and optionally releases the managed resources. (Overrides ActionAdapterBase.Dispose(Boolean).)


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrequencyDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


Dispose Method

Dispose Method
Namespaces ► TVA.PhasorProtocols.FNet ► FrameParser ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBase<(Of <(<'TFrameIdentifier>)>)> object and optionally releases the managed resources. (Overrides FrameImageParserBase<(Of <(<' TFrameIdentifier, ISupportFrameImage<(Of <(<' TFrameIdentifier >)>)>>)>)>.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Stream.


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Anonymous ► AnalogDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


Dispose Method

Dispose Method
Namespaces ► HistorianAdapters ► LocalOutputAdapter ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose()()()() |
 | Dispose(Boolean) | Releases the unmanaged resources used by this LocalOutputAdapter and optionally releases the managed resources. (Overrides OutputAdapterBase.Dispose(Boolean).)

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols ► HeaderFrameBase ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame2Draft6 ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


Dispose Method

Dispose Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrameParser ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBase<(Of <(<'TFrameIdentifier>)>)> object and optionally releases the managed resources. (Overrides FrameImageParserBase<(Of <(<' TFrameIdentifier, ISupportFrameImage<(Of <(<' TFrameIdentifier >)>)>>)>)>.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Stream.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DataFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrameParser ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


State Property

State Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationCell ► State
Members
Icon | Member | Description
 | State | Gets or sets the parsing state for the this IConfigurationCell.
 | State | Gets or sets the parsing state for the this ChannelCellBase.
 | State | Gets or sets the parsing state for this IChannel object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► PhasorDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionBase ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame2 ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► FrequencyDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionBase ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► DigitalDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.FNet ► ConfigurationCell ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1Draft6 ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► HeaderFrameBase ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


Dispose Method

Dispose Method
Namespaces ► TVA.PhasorProtocols ► PhasorMeasurementMapper ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose()()()() |
 | Dispose(Boolean) | Releases the unmanaged resources used by the PhasorMeasurementMapper object and optionally releases the managed resources. (Overrides InputAdapterBase.Dispose(Boolean).)


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


GetPaintValueSupported Method

GetPaintValueSupported Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► IniFileNameEditor ► GetPaintValueSupported()()()()
Members
Icon | Member | Description
 | GetPaintValueSupported()()()() | Indicates whether this editor supports painting a representation of an object's value.
 | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame1Draft6 ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols ► IChannelFrame<(Of <(<'T>)>)> ► Cells
Members
Icon | Member | Description
 | Cells | Gets the strongly-typed reference to the collection of cells for this IChannelFrame<(Of <(<'T>)>)>.
 | Cells | Gets the simple reference to the collection of cells for this IChannelFrame.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Anonymous ► AnalogDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


OnStatusMessage Method

OnStatusMessage Method
Namespaces ► HistorianAdapters ► RemoteInputAdapter ► OnStatusMessage()()()()
Members
Icon | Member | Description
 | OnStatusMessage(String) |
 | OnStatusMessage(String, array<Object>[]()[][]) |

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DigitalDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


InsertItem Method

InsertItem Method
Namespaces ► TVA.PhasorProtocols ► FrequencyDefinitionCollection ► InsertItem()()()()
Members
Icon | Member | Description
 | InsertItem(Int32, T) | Inserts an element into the ChannelDefinitionCollectionBase<(Of <(<'T>)>)> at the specified index.
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Overrides Collection <(Of <(<' T >)>)>.InsertItem(Int32, T).)


Parent Property

Parent Property
Namespaces ► TVA.PhasorProtocols ► IHeaderCell ► Parent
Members
Icon | Member | Description
 | Parent | Gets a reference to the parent IHeaderFrame for this IHeaderCell.
 | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell.


EditValue Method

EditValue Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► IniFileNameEditor ► EditValue()()()()
Members
Icon | Member | Description
 | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object using the editor style provided by the GetEditStyle(ITypeDescriptorContext) method. (Overrides UITypeEditor.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)
 | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()()() method.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► CommandFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


Dispose Method

Dispose Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► Concentrator ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose()()()() |
 | Dispose(Boolean) | Releases the unmanaged resources used by the PhasorDataConcentratorBase object and optionally releases the managed resources. (Overrides ActionAdapterBase.Dispose(Boolean).)


Namespaces

Namespaces
Namespaces
Namespaces
Namespace | Description
HistorianAdapters |
TVA.PhasorProtocols | Contains fundamental classes and interfaces used by all phasor protocol parsing and generating code.
TVA.PhasorProtocols.Anonymous | Contains a generic implementation of phasor classes used to represent phasor data that isn’t associated with any particular protocol.
TVA.PhasorProtocols.BpaPdcStream | Contains an implementation of the phasor classes used to parse or generate a stream of data in the BPA PDCstream format.
TVA.PhasorProtocols.FNet | Contains an implementation of the phasor classes used to parse or generate a stream of data in the F-NET device format.
TVA.PhasorProtocols.Ieee1344 | Contains an implementation of the phasor classes used to parse or generate a stream of data in the IEEE 1344-1995 standard format.
TVA.PhasorProtocols.IeeeC37_118 | Contains an implementation of the phasor classes used to parse or generate a stream of data in the IEEE C37.118-2005 standard format.
TVA.PhasorProtocols.Macrodyne | Contains an implementation of the phasor classes used to parse or generate a stream of data in the Macrodyne PMU device format.
TVA.PhasorProtocols.SelFastMessage | Contains an implementation of the phasor classes used to parse or generate a stream of data in the SEL Fast Message format used by a variety of SEL devices.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.FNet ► PhasorDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► DataFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


InsertItem Method

InsertItem Method
Namespaces ► TVA.PhasorProtocols ► DigitalDefinitionCollection ► InsertItem()()()()
Members
Icon | Member | Description
 | InsertItem(Int32, T) | Inserts an element into the ChannelDefinitionCollectionBase<(Of <(<'T>)>)> at the specified index.
 | InsertItem(Int32, T) | Inserts an element into the ChannelCollectionBase<(Of <(<'T>)>)> at the specified index. (Overrides Collection <(Of <(<' T >)>)>.InsertItem(Int32, T).)


GetEnumerator Method

GetEnumerator Method
Namespaces ► TVA.PhasorProtocols ► IChannelCollection<(Of <(<'T>)>)> ► GetEnumerator()()()()
Members
Icon | Member | Description
 | GetEnumerator()()()() | Returns an enumerator that iterates through the collection.
 | GetEnumerator()()()() | Returns an enumerator that iterates through a collection.


OnStatusMessage Method

OnStatusMessage Method
Namespaces ► HistorianAdapters ► RemoteOutputAdapter ► OnStatusMessage()()()()
Members
Icon | Member | Description
 | OnStatusMessage(String) |
 | OnStatusMessage(String, array<Object>[]()[][]) |

Send comments on this topic to J. Ritchie Carroll

Copyright © 2010, Grid Protection Alliance. All Rights Reserved.

Assembly: HistorianAdapters (Module: HistorianAdapters) Version: 1.4.192.0


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols ► IChannelDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(T) | Compares the current object with another object of the same type.
 | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► DigitalDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► ConfigurationCell ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► PhasorDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Anonymous ► ConfigurationFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► FrequencyDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


Cells Property

Cells Property
Namespaces ► TVA.PhasorProtocols ► IConfigurationFrame ► Cells
Members
Icon | Member | Description
 | Cells | Gets reference to the ConfigurationCellCollection for this IConfigurationFrame.
 | Cells | Gets the simple reference to the collection of cells for this IChannelFrame.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► CommandFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Macrodyne ► ConfigurationFrame ► Equals()()()()
Members
Icon | Member | Description
 | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBase<(Of <(<'T>)>)>.
 | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBase<(Of <(<'T>)>)>. (Overrides Object.Equals(Object).)


Dispose Method

Dispose Method
Namespaces ► TVA.PhasorProtocols ► PhasorDataConcentratorBase ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose()()()() |
 | Dispose(Boolean) | Releases the unmanaged resources used by the PhasorDataConcentratorBase object and optionally releases the managed resources. (Overrides ActionAdapterBase.Dispose(Boolean).)


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► FrameParser ► Start()()()()
Members
Icon | Member | Description
 | Start()()()() | Start the data parser. (Overrides FrameImageParserBase<(Of <(<' FrameType, ISupportFrameImage<(Of <(<' FrameType >)>)>>)>)>.Start()()()().)
 | Start(IEnumerable<(Of <<'(Type>)>>)) | Starts the frame parser given the specified type implementations. (Overrides FrameImageParserBase<(Of <(<' TFrameIdentifier, ISupportFrameImage<(Of <(<' TFrameIdentifier >)>)>>)>)>.Start(IEnumerable<(Of <<'(Type>)>>)).)


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► AnalogDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► PhasorDefinition ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
 | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.Ieee1344 ► ConfigurationFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► HeaderFrame ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


CompareTo Method

CompareTo Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► ConfigurationFrame2Draft6 ► CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(IFrame) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with an IFrame.
 | CompareTo(Object) | Compares the ChannelFrameBase<(Of <(<'T>)>)> with the specified Object.


Start Method

Start Method
Namespaces ► TVA.PhasorProtocols ► FrameParserBase<(Of <(<'TFrameIdentifier>)>)> ► Start()()()()
Members
Icon | Member | Description
 | Start()()()() |
 | Start(IEnumerable<(Of <<'(Type>)>>)) | Starts the frame parser given the specified type implementations. (Overrides FrameImageParserBase<(Of <(<' TFrameIdentifier, ISupportFrameImage<(Of <(<' TFrameIdentifier >)>)>>)>)>.Start(IEnumerable<(Of <<'(Type>)>>)).)


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► PhasorDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


GetSignalReference Method

GetSignalReference Method
Namespaces ► TVA.PhasorProtocols.IeeeC37_118 ► Concentrator ► GetSignalReference()()()()
Members
Icon | Member | Description
 | GetSignalReference(SignalKind) | Get signal reference for specified SignalKind.
 | GetSignalReference(SignalKind, Int32, Int32) | Get signal reference for specified SignalKind and index.


GetEditStyle Method

GetEditStyle Method
Namespaces ► TVA.PhasorProtocols.BpaPdcStream ► IniFileNameEditor ► GetEditStyle()()()()
Members
Icon | Member | Description
 | GetEditStyle(ITypeDescriptorContext) | Gets the editing style used by the EditValue(ITypeDescriptorContext, IServiceProvider, Object) method. (Overrides UITypeEditor.GetEditStyle(ITypeDescriptorContext).)
 | GetEditStyle()()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method.


Equals Method

Equals Method
Namespaces ► TVA.PhasorProtocols.Anonymous ► PhasorDefinition ► Equals()()()()
Members
Icon | Member | Description
 | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides Object.Equals(Object).)
 | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.


Dispose Method

Dispose Method
Namespaces ► TVA.PhasorProtocols ► CommonPhasorServices ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose()()()() |
 | Dispose(Boolean) | Releases the unmanaged resources used by the CommonPhasorServices object and optionally releases the managed resources. (Overrides AdapterBase.Dispose(Boolean).)


Dispose Method

Dispose Method
Namespaces ► TVA.PhasorProtocols.SelFastMessage ► FrameParser ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBase<(Of <(<'TFrameIdentifier>)>)> object and optionally releases the managed resources. (Overrides FrameImageParserBase<(Of <(<' TFrameIdentifier, ISupportFrameImage<(Of <(<' TFrameIdentifier >)>)>>)>)>.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Stream.